Copyright

This guide is copyrighted ©2005 by Digidesign, a division of Avid Technology, Inc. (hereafter “Digidesign”), with all rights reserved. Under copyright laws, this guide may not be duplicated in whole or in part without the written consent of Digidesign.

DIGIDESIGN, AVID, M-Audio, and PRO TOOLS are trademarks or registered trademarks of Digidesign and/or Avid Technology, Inc. All other trademarks are the property of their respective owners.

Product features, specifications, system requirements, and availability are subject to change without notice.

PN 9106-17743-00 REV A 011/05
Contents

Part I       Introduction

Chapter 1. Welcome to Pro Tools .......................................................... 3
  The Pro Tools Guides ................................................................. 3
  Compatibility Information ......................................................... 4
  About www.digidesign.com ......................................................... 4

Chapter 2. Pro Tools System Configurations ........................................ 5
  Pro Tools|HD Systems ............................................................... 5
  Pro Tools LE Systems .............................................................. 9
  Pro Tools M-Powered .............................................................. 10

Chapter 3. Pro Tools Concepts ............................................................ 11
  Hard Disk Audio Recording..................................................... 11
  The Digidesign Audio Engine .................................................. 11
  Pro Tools Sessions ................................................................. 12
  System Resources ................................................................. 16
  MIDI Concepts ................................................................. 19

Chapter 4. Pro Tools Windows ............................................................. 21
  The Mix Window ................................................................. 21
  The Edit Window ................................................................. 21
  The Transport Window .......................................................... 25
  Menus and Windows ............................................................. 29
  Tool Tips .............................................................................. 30

Chapter 5. Keyboard Shortcuts ............................................................ 31
  Global Key Commands .......................................................... 31
  Keyboard Focus ................................................................. 32
  Numeric Keypad Modes ......................................................... 33
Part II Sessions & Tracks

Chapter 6. Sessions .................................................. 37
  Starting Up or Shutting Down Your System ................................ 37
  Configuring Pro Tools System Settings (in the Playback Engine) ........ 37
  Configuring Pro Tools Hardware Settings .................................. 42
  Creating a New Session ................................................. 45
  Session Files and Folders ............................................... 46
  Opening a Session ..................................................... 47
  Saving a Session ........................................................ 49
  Creating Custom Session Templates .................................... 53
  Closing a Session ....................................................... 54
  Quitting Pro Tools ....................................................... 54
  System Usage .......................................................... 55
  Preferences .............................................................. 56

Chapter 7. I/O Setup .................................................. 69
  The I/O Setup Dialog ................................................... 72
  Routing Hardware I/O to Pro Tools I/O ................................ 73
  Creating and Editing Paths .............................................. 74
  I/O Settings Files ...................................................... 81
  I/O Setup Options ..................................................... 83
  H/W Insert Delay Compensation ....................................... 86

Chapter 8. Tracks ..................................................... 87
  Track Types ............................................................ 87
  Track Channel Strips .................................................. 88
  Track Controls and Indicators ......................................... 91
  Adjusting Track Width ................................................ 93
  Creating Tracks ....................................................... 93
  The Track List ........................................................ 98
  Assigning Inputs and Outputs to Tracks ............................... 100
  Track Priority and Voice Assignment ................................ 102
  Setting MIDI Input and Output ...................................... 105
  Soloing and Muting Tracks .......................................... 107
  Making Tracks Inactive ............................................... 111
  Color Coding for Tracks, Regions, Markers and Groups ............ 111
  Grouping Tracks ...................................................... 114

Chapter 9. Importing and Exporting Session Data ................. 119
  Importing Audio ...................................................... 119
  Conversion Quality ................................................... 121
  Importing Audio Files and Regions ................................... 121
  Importing Tracks and Track Attributes ................................ 124
Exporting Audio ................................................................. 131
Exporting Pro Tools Tracks as OMFI or AAF Sequences .............. 133
Exporting Sessions as Text .................................................... 133
Send via DigiDelivery ............................................................ 135
Importing MIDI Files ............................................................ 136
Exporting MIDI Files ............................................................ 138
Importing and Exporting Region Group Files .............................. 139

Chapter 10. File and Session Management and Compatibility ......... 141
Audio File Management ......................................................... 141
WAV File Compatibility .......................................................... 143
Sharing Sessions Created on Different Computer Platforms ......... 144
Sharing Sessions Created on Different Pro Tools Systems ............ 146
Sharing Sessions Created on Different Pro Tools Software Versions .. 147
Multilingual Application Support for Pro Tools|HD Systems .......... 148

Part III               Recording

Chapter 11. Record Setup ...................................................... 151
Input Connections and Audio Levels ...................................... 151
Record Enabling Tracks ....................................................... 152
Record Monitoring Modes .................................................... 154
Monitor Levels for Record and Playback .................................. 156
Monitoring Latency .............................................................. 156
Low Latency Monitoring with Delay Compensation .................... 157
Default Track Names ............................................................ 158
Disk Allocation ................................................................. 159
Allocating Hard Drive Space for Recording .............................. 161
Monitoring Drive Space ........................................................ 162
Record Modes ................................................................. 162
Recording with a Click ......................................................... 165
Setting the Default Meter and Tempo ..................................... 166

Chapter 12. Basic Audio Recording .......................................... 169
Recording an Audio Track .................................................... 169
Record Shortcuts ............................................................... 173
Record Pause Mode ............................................................. 173
Recording Additional Takes .................................................... 173
Punch Recording Audio ......................................................... 176
Loop Recording Audio .......................................................... 177
<table>
<thead>
<tr>
<th>Chapter 13. MIDI Recording</th>
<th>187</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recording from MIDI Devices</td>
<td>187</td>
</tr>
<tr>
<td>Enabling Input Devices</td>
<td>188</td>
</tr>
<tr>
<td>MIDI Thru</td>
<td>189</td>
</tr>
<tr>
<td>MIDI Input Filter</td>
<td>190</td>
</tr>
<tr>
<td>Input Quantize</td>
<td>190</td>
</tr>
<tr>
<td>Wait for Note</td>
<td>191</td>
</tr>
<tr>
<td>MIDI Merge/Replace</td>
<td>191</td>
</tr>
<tr>
<td>Configuring MIDI or Instrument Tracks for Recording</td>
<td>192</td>
</tr>
<tr>
<td>Recording to MIDI and Instrument Tracks</td>
<td>194</td>
</tr>
<tr>
<td>Punch Recording MIDI</td>
<td>195</td>
</tr>
<tr>
<td>Loop Recording MIDI</td>
<td>197</td>
</tr>
<tr>
<td>MIDI Step Input</td>
<td>200</td>
</tr>
<tr>
<td>Recording System Exclusive Data</td>
<td>203</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 14. Advanced Recording</th>
<th>205</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuickPunch Audio Recording</td>
<td>205</td>
</tr>
<tr>
<td>TrackPunch Audio Recording</td>
<td>208</td>
</tr>
</tbody>
</table>

**Part IV  Editing**

<table>
<thead>
<tr>
<th>Chapter 15. Editing Basics</th>
<th>219</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools Editing</td>
<td>219</td>
</tr>
<tr>
<td>Track Material</td>
<td>220</td>
</tr>
<tr>
<td>Displaying Region Names, Region Times, and Other Data in Playlists</td>
<td>225</td>
</tr>
<tr>
<td>Audio Regions and Waveforms</td>
<td>226</td>
</tr>
<tr>
<td>MIDI Regions and MIDI Data</td>
<td>228</td>
</tr>
<tr>
<td>Timebase Rulers and Conductor Rulers</td>
<td>231</td>
</tr>
<tr>
<td>Main Time Scale</td>
<td>232</td>
</tr>
<tr>
<td>Tick-Based Timing</td>
<td>234</td>
</tr>
<tr>
<td>Playlists.</td>
<td>236</td>
</tr>
<tr>
<td>Multiple Undo</td>
<td>239</td>
</tr>
<tr>
<td>The Region List</td>
<td>240</td>
</tr>
<tr>
<td>Edit Modes</td>
<td>246</td>
</tr>
<tr>
<td>Edit Tools</td>
<td>248</td>
</tr>
<tr>
<td>Zooming</td>
<td>249</td>
</tr>
<tr>
<td>Trimming</td>
<td>254</td>
</tr>
<tr>
<td>Using the Selector Tool</td>
<td>257</td>
</tr>
</tbody>
</table>
Chapter 19. Managing Regions .......................................................... 345
  Stripping Silence from Regions .................................................. 345
  Inserting Silence ........................................................................... 347
  Consolidate Command ................................................................... 348
  Compacting an Audio File ............................................................. 349
  Naming and Displaying Regions .................................................... 350

Chapter 20. Conductor Tracks and Memory Locations ......................... 353
  Song Start Marker ........................................................................ 353
  Tempo ......................................................................................... 354
  Graphic Tempo Editor ................................................................... 358
  Changing the Linearity Display Mode ............................................. 363
  Tempo Operations Window ........................................................... 364
  Identify Beat Command ................................................................. 370
  Meter Events ................................................................................. 374
  Time Operations .......................................................................... 376
  Renumbering Bars ....................................................................... 382
  Memory Locations and Markers .................................................... 382
  Memory Locations Window ........................................................... 389

Chapter 21. Beat Detective ................................................................. 391
  Beat Detective Requirements ........................................................ 392
  The Beat Detective Window ........................................................ 393
  Beat Detective Modes ................................................................. 393
  Defining a Beat Detective Selection .............................................. 394
  Calculating Tempo with Beat Detective ......................................... 395
  Generating Beat Triggers ............................................................... 396
  Generating Bar|Beat Markers with Beat Detective ........................... 401
  DigiGroove Templates ................................................................... 402
  Separating Regions with Beat Detective (Audio Only) .................... 404
  Conforming Regions with Beat Detective (Audio Only) ................. 406
  Edit Smoothing (Audio Only) ....................................................... 408
  Detection (Normal) and Collection Mode ...................................... 410

Part V MIDI Editing

Chapter 22. MIDI Editing ................................................................. 415
  Mirrored MIDI Editing ................................................................. 415
  The Pencil Tool .............................................................................. 416
  Custom Note Duration ................................................................... 417
  Setting the Grid Value .................................................................. 418
  Inserting MIDI Notes ..................................................................... 418
  Manually Editing MIDI Notes ....................................................... 419
Contents

Chapter 23. MIDI Operations .......................................................... 437
  MIDI Operations Window ......................................................... 437
  Grid/Groove Quantize .............................................................. 438
  Restore Performance ............................................................... 448
  Flatten Performance ............................................................... 449
  Change Velocity ................................................................. 449
  Change Duration ................................................................. 451
  Transpose ....................................................................... 453
  Select/Split Notes .............................................................. 454
  Input Quantize ................................................................. 456
  Step Input ................................................................. 457
  MIDI Real-Time Properties .................................................. 460

Chapter 24. MIDI Event List ....................................................... 467
  The MIDI Event List ............................................................ 467
  Inserting Events in the MIDI Event List .................................. 470
  Editing in the MIDI Event List .............................................. 472
  MIDI Event List Options ...................................................... 474

Part VI  Mixing

Chapter 25. Basic Mixing ........................................................... 477
  Mixing Concepts ................................................................. 477
  Metering and Calibration ...................................................... 477
  Signal Flow ................................................................. 478
  Inserts ................................................................. 482
  Views in the Mix and Edit Windows ....................................... 483
  Audio Input and Output Paths ............................................. 486
  Sends ................................................................. 488
  Output Windows for Tracks and Sends .................................... 494
Chapter 26. Plug-In and Hardware Inserts

Chapter 27. Automation

Chapter 28. Mixdown
# Table of Contents

**Part VII**  
**Surround**

**Chapter 29. Surround Concepts (Pro Tools HD Only)**  
- Mixing Formats and Surround Formats ........................................... 589  
- Pro Tools Mixing Formats .......................................................... 590  
- Speaker Layouts ........................................................................... 590  
- Surround Monitoring ..................................................................... 592  
- Formats and Terminology ............................................................. 593  
- Surround Mixing Concepts ............................................................ 596

**Chapter 30. Pro Tools Setup for Surround (Pro Tools HD Only)**  
- Pro Tools Audio Connections for 5.1 Mixing .............................. 599  
- Configuring Pro Tools for Multichannel Sessions ....................... 600  
- Default I/O Selectors in I/O Setup .............................................. 603  
- 5.1 Track Layouts, Routing, and Metering ................................. 604

**Chapter 31. Multichannel Tracks and Signal Routing (Pro Tools HD Only)**  
- Multichannel Quick Start ............................................................ 605  
- Multichannel Audio Tracks ........................................................... 606  
- Multichannel Signal Routing .......................................................... 609  
- Paths in Surround Mixes .............................................................. 612  
- Example Paths and Signal Routing for a Surround Mix ............... 614

**Chapter 32. Surround Panning and Mixing (Pro Tools HD Only)**  
- Introduction to Pro Tools Surround Panning .............................. 619  
- Output Window .............................................................................. 619  
- Standard Controls ......................................................................... 620  
- Surround Panner Controls ............................................................. 621  
- Panning Modes ............................................................................. 622  
- Divergence and Center Percentage ............................................. 624  
- LFE Faders in Multichannel Panners ......................................... 627  
- Pan Playlists .................................................................................. 629  
- SurroundScope Metering Plug-In ............................................... 630

---

*Contents xi*
Part VIII       Synchronization

Chapter 33. Synchronization Concepts ........................................ 633
   Synchronization Requirements ........................................... 633
   Aspects of Synchronization ............................................. 633
   Synchronizing Pro Tools ................................................. 634
   SMPTE Frame Formats .................................................. 637
   Working with Film-Originated Material .................................. 638

Chapter 34. Working with Synchronization .................................. 643
   Pro Tools Synchronization Options ...................................... 643
   Session Setup Window .................................................. 645
   Preparing to Work with SMPTE .......................................... 649
   Configuring Pro Tools for SMPTE ....................................... 649
   Pull Up and Pull Down .................................................. 652
   Putting Pro Tools Online ................................................ 656
   Generating Time Code .................................................. 656
   Using MIDI Machine Control ........................................... 657
   Setting Minimum Sync Delay ........................................... 660
   Remote Track Arming .................................................... 660
   MIDI Beat Clock ........................................................ 661
   Spotting Regions to SMPTE Frame Locations .......................... 661
   Time Stamping .......................................................... 664
   Identifying a Synchronization Point .................................... 666
   Troubleshooting Synchronization ....................................... 667

Chapter 35. Working with QuickTime Movies ............................... 669
   About QuickTime ........................................................ 669
   QuickTime Requirements ................................................. 671
   QuickTime Movie Playback Performance Options ...................... 671
   Importing a QuickTime Movie .......................................... 672
   FireWire Playback of QuickTime DV Movies ............................ 673
   Setting the Movie Start Time (Movie Offset) .......................... 676
   Spotting Audio to a QuickTime Movie .................................. 677
   Importing QuickTime Audio (and Other Compressed Video Files) 678
   Bouncing to a New Movie ............................................... 679

Glossary ................................................................................. 681

Index .................................................................................... 691
Part I: Introduction
Chapter 1: Welcome to Pro Tools

Welcome to Pro Tools®. Pro Tools integrates powerful multitrack digital audio and MIDI sequencing features, giving you everything you need to record, arrange, edit, mix, and master quality audio for music, video, film, and multimedia.

The Pro Tools Guides

Pro Tools systems include the following guides:

**Getting Started Guide** Instructions for installing your Pro Tools system and connecting your studio.

**Basics Guide (Pro Tools LE and Pro Tools M-Powered Only)** Designed for new users, these guides provide specific methods for accomplishing common tasks (such as getting sound in and out of your Pro Tools LE or Digidesign-qualified M-Audio hardware, connecting a mic or instrument, and recording a session).

**Pro Tools Reference Guide** Full details on all Pro Tools functionality and operations. (Pro Tools LE and M-Powered systems only include an electronic PDF version of the Reference Guide.)


**DigiRack Plug-Ins Guide** Instructions for using the DigiRack plug-ins (included with Pro Tools) for both real-time and file-based audio processing in Pro Tools. (Pro Tools LE and M-Powered systems only include an electronic PDF version of this guide.)

**Digidesign Plug-Ins Guide** Electronic PDF guide with instructions for using optional Digidesign plug-ins for both real-time and file-based audio processing in Pro Tools.

**DigiBase Guide** Full details on using Pro Tools DigiBase databasing and browsers for data and media management. (Pro Tools LE and M-Powered systems only include an electronic PDF version of this guide.)

**Expanded Systems Guide (Pro Tools|HD Systems Only)** Instructions for expanding a Pro Tools|HD system with optional Digidesign cards or an expansion chassis.

**MachineControl™ Guide (Pro Tools|HD Systems Only)** Electronic PDF guide for MachineControl option. This guide includes installation and operation instructions for using the MachineControl option for Pro Tools to enable serial communication with remote audio and video transports.

**Pro Tools Keyboard Shortcuts** Separate electronic PDF guides for Windows and Macintosh that list keyboard shortcuts not shown in Pro Tools menus.
Digidesign also provides guides with audio interfaces, dedicated worksurfaces (such as D-Control) and controllers (such as Command|8), and other Digidesign options (such as MIDI I/O, PRE, and SYNC I/O). Refer to the separate guide provided with each Digidesign product.

Conventions Used in These Guides

The Pro Tools guides use the following conventions to indicate menu choices and key commands:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save</td>
<td>Choose Save from the File menu</td>
</tr>
<tr>
<td>Control+N</td>
<td>Hold down the Control key and press the N key</td>
</tr>
<tr>
<td>Control-click</td>
<td>Hold down the Control key and click the mouse button</td>
</tr>
<tr>
<td>Right-click (Windows)</td>
<td>Click with the right mouse button</td>
</tr>
</tbody>
</table>

The following symbols are used to highlight important information:

⚠️ User Tips are helpful hints for getting the most from your Pro Tools system.

⚠️ Important Notices include information that could affect your Pro Tools session data or the performance of your Pro Tools system.

🔍 Shortcuts show you useful keyboard or mouse shortcuts.

🔍 Cross References point to related sections in Digidesign guides.

Compatibility Information

Digidesign can only assure compatibility and provide support for hardware and software it has tested and approved.

For a list of Digidesign-qualified computers, operating systems, hard drives, and third-party devices, refer to the latest compatibility information on the Digidesign Web site (www.digidesign.com/compato).

About www.digidesign.com

The Digidesign Web site (www.digidesign.com) is your best online source for information to help you get the most out of your Pro Tools system. The following are just a few of the services and features available.

Registration Register your purchase online. See the registration form included with your system for instructions.

Support Contact Digidesign Technical Support or Customer Service; download software updates and the latest online manuals; browse the Compatibility documents for system requirements; search the online Answerbase or join the worldwide Pro Tools community on the Digidesign User Conference.

Training and Education Study on your own using courses available online or find out how you can learn in a classroom setting at a certified Pro Tools training center.

Products and Developers Learn about Digidesign products; download demo software or learn about our Development Partners and their plugins, applications, and hardware.

News and Events Get the latest news from Digidesign or sign up for a Pro Tools demo.
Chapter 2: Pro Tools System Configurations

There are three types of Pro Tools systems:

**Pro Tools|HD®** These systems include Pro Tools HD software for Pro Tools|HD system hardware.

**Pro Tools LE™** These systems include Pro Tools LE software for Digi 002®, Digi 002 Rack™, Mbox 2™, or Mbox™ hardware.

**Pro Tools M-Powered™** These systems include Pro Tools M-Powered software for Digidesign-qualified M-Audio® interfaces.

---

**Pro Tools|HD Systems**

Pro Tools|HD systems are available in the configurations shown on page 6. Each system requires at least one Digidesign audio interface (sold separately). Pro Tools|HD systems can be expanded by adding Pro Tools|HD system cards to increase track count, add to the amount of possible plug-in and mixer processing, and connect additional audio interfaces.

⚠️ *Pro Tools system performance depends on factors such as computer processor speed, amount of system memory, and hard drive performance. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.*
### Pro Tools|HD Systems

**Pro Tools|HD 1**
Includes:
- HD Core card
- Pro Tools HD software

**Pro Tools|HD 2 Accel**
Includes:
- HD Core card
- HD Accel card
- Pro Tools HD software

**Pro Tools|HD 3 Accel**
Includes:
- HD Core card
- Two HD Accel cards
- Pro Tools HD software

**Pro Tools|HD 2**
Includes:
- HD Core card
- HD Process card
- Pro Tools HD software

**Pro Tools|HD 3**
Includes:
- HD Core card
- Two HD Process cards
- Pro Tools HD software

⚠️ *HD Accel and HD Process cards can be used in the same system. Refer to the Pro Tools|HD Getting Started Guide.*

---

### Supported Audio Interfaces

(Pro Tools|HD Systems Only)

The following audio interfaces are compatible with Pro Tools|HD systems:
- 192 I/O™
- 192 Digital I/O™
- 96 I/O™
- 96i I/O™

⚠️ *Pro Tools|HD systems require the use of at least one 192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O.*

The following “Legacy” Digidesign audio interfaces are supported with Pro Tools|HD systems:
- 888|24 I/O™ and 882|20 I/O™
- 1622 I/O™
- 24-bit ADAT Bridge I/O™
Pro Tools|HD System Playback, Recording and Voice Limits

The following table lists the audio playback, recording, and voiceable track limits of each type of Pro Tools|HD system. Playback and recording voices refer to the number of unique simultaneous playback and record tracks on your system. Total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system. (Mono tracks take up one voice. Stereo and multichannel tracks take up one voice per channel.) Voice limits are dependent on the session sample rate and the number of DSP chips dedicated to the system’s Playback Engine.

Pro Tools|HD systems can open sessions with up to 256 audio tracks, but any audio tracks beyond that system’s voiceable track limit will be automatically set to Voice Off.

Table 3. Pro Tools|HD system audio playback, recording and voice limits

<table>
<thead>
<tr>
<th>Core System Type</th>
<th>Sample Rate (kHz)</th>
<th>Playback Voices (Mono Tracks of Simultaneous Playback)</th>
<th>Recording Voices (Mono Tracks of Simultaneous Recording)</th>
<th>Total Voiceable Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools</td>
<td>HD 1</td>
<td>44.1/48</td>
<td>96</td>
<td>96</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>48</td>
<td>48</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>HD Accel 2, Pro Tools</td>
<td>HD Accel 3</td>
<td>44.1/48</td>
<td>192</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>96</td>
<td>96</td>
<td>120</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>36</td>
<td>36</td>
<td>36</td>
</tr>
<tr>
<td>Expanded Pro Tools</td>
<td>HD 1, Pro Tools</td>
<td>HD 2, Pro Tools</td>
<td>HD 3</td>
<td>44.1/48</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>64</td>
<td>64</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>24</td>
<td>24</td>
<td>24</td>
</tr>
</tbody>
</table>

Pro Tools|HD systems provide up to 160 Auxiliary Input tracks and a total of 128 internal mix busses. These systems also provide up to 5 inserts and 10 sends per track (depending on the DSP capacity of your system). In addition, Pro Tools|HD systems support up to 128 Instrument tracks and 256 MIDI tracks.
Audio Interfaces for Pro Tools|HD Systems

Table 4 lists the input and output capabilities of the various audio interfaces for Pro Tools|HD systems.

Table 4. Pro Tools|HD system audio interface channel capabilities

<table>
<thead>
<tr>
<th>Interface Type</th>
<th>Number of I/O Channels</th>
<th>Sample Rates (kHz)</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>192 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>192 Digital I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>None</td>
<td>None</td>
<td>24-bit</td>
</tr>
<tr>
<td>96 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>96i I/O</td>
<td>16 in/2 out</td>
<td>44.1, 48, 88.2, 96</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>888</td>
<td>24 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>24-bit</td>
<td>24-bit (or 20-bit, on older I/O)</td>
</tr>
<tr>
<td>882</td>
<td>20 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>20-bit</td>
</tr>
<tr>
<td>1622 I/O</td>
<td>16 in/2 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>24-bit ADAT</td>
<td>16 in/16 out</td>
<td>44.1, 48</td>
<td>None</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

You can expand your Pro Tools|HD system by adding Pro Tools|HD cards to your computer, either directly in the computer or using an expansion chassis. Expanding your Pro Tools system will provide an increased track count, add to the amount of possible plug-in and mixer processing, and let you connect additional audio interfaces. For more information, see the *Expanded Systems Guide*. 
Pro Tools LE Systems

Pro Tools LE-based systems are available in the following configurations:

**Digi 002®**
A Digi 002 system includes:
- Digi 002 combined audio interface and controller
- Pro Tools LE software

**Digi 002 Rack™**
A Digi 002 Rack system includes:
- Digi 002 audio interface
- Pro Tools LE software

**Mbox 2™**
An Mbox 2 system includes:
- Mbox 2 audio interface
- Pro Tools LE software

**Mbox™**
An Mbox system includes:
- Mbox audio interface
- Pro Tools LE software

Processing Capacity

⚠️ The total processing capacity of a Pro Tools LE system depends on the processing power of your computer. Contact your Digidesign dealer or visit Digidesign’s Web site (www.digidesign.com) for the latest system requirements and compatibility information.
Pro Tools LE System Capabilities

Table 5 lists the playback, recording, and input and output capabilities of each Pro Tools LE system. Mono tracks of simultaneous playback refers to the number of unique simultaneous playback and record tracks on your system. Total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system. (Mono tracks take up a single audio track, while stereo tracks take up two tracks.) If you open a Pro Tools session created on a Pro Tools|HD system containing more than the number of tracks supported on the LE-based system, audio tracks beyond the LE system’s voiceable track limit will be automatically set to inactive.

Table 5. Pro Tools LE system audio playback, recording, and channel capabilities

<table>
<thead>
<tr>
<th>System Type</th>
<th>Mono Tracks of Simultaneous Playback</th>
<th>Total Voiceable Tracks</th>
<th>Number of I/O Channels</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digi 002 or Digi 002 Rack</td>
<td>32</td>
<td>128</td>
<td>up to 18 in/18 out (48 kHz or lower)</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>up to 10 in/10 out (88.2 or 96 kHz)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mbox 2 or Mbox</td>
<td>32</td>
<td>128</td>
<td>up to 2 in/2 out</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

Pro Tools LE systems provide up to 128 Auxiliary Input tracks, a total of 32 internal mix busses, and up to 5 inserts and 10 sends per track (depending on your computer’s processing capacity). In addition, Pro Tools LE systems support up to 32 Instrument tracks and 256 MIDI tracks.

For details on transferring session material between Pro Tools|HD and Pro Tools LE systems, see “Sharing Sessions Created on Different Pro Tools Systems” on page 146.

Pro Tools M-Powered

A Pro Tools M-Powered system includes:

- Pro Tools M-Powered software
- Digidesign-qualified M-Audio interface (not supplied with M-Powered software)

⚠️ References to Pro Tools LE in this guide are usually interchangeable with Pro Tools M-Powered, except as noted in this guide and the Pro Tools M-Powered Getting Started Guide.

⚠️ For a list of Digidesign-qualified M-Audio interfaces, refer to the latest compatibility information on the Digidesign Web site (www.digidesign.com/compato).
This chapter explains the principles and concepts that form the foundation of Pro Tools operation and functionality.

**Hard Disk Audio Recording**

Tape-based recording is a *linear* medium—you need to rewind or fast forward a tape to hear a particular spot in a recording. To rearrange or repeat material in a linear system, you need to re-record it.

Hard disk recording is a *nonlinear* (or random access) medium—you can go immediately to any spot in a recording without having to rewind or fast forward.

Nonlinear systems have several advantages. You can easily rearrange or repeat parts of a recording by making the hard disk read parts of the recording in a different order and/or multiple times. In addition, this re-arrangement is *nondestructive*, meaning that the original recorded material is not altered.

Pro Tools is a nonlinear recording system that lets you rearrange and mix recorded material nondestructively.

**The Digidesign Audio Engine**

DAE (or Digidesign Audio Engine) is Digidesign’s real-time operating system for digital audio recording, playback, and processing. When you install Pro Tools, DAE is automatically installed on your system.

In the same way that a computer’s operating system provides the foundation for programs that run on the computer, DAE provides the foundation for much of the hard disk recording, digital signal processing, and mix automation required by Pro Tools and other products from Digidesign and its Development Partners.

The DAE Playback Buffer Size determines the amount of memory DAE allocates to manage disk buffers.

For more information, see “DAE Playback Buffer Size” on page 41. The DAE Playback Buffer Size can be changed in the Playback Engine dialog, discussed below.
**Playback Engine Dialog**

Pro Tools takes advantage of your computer’s host processor for certain tasks and optional host-based DSP processing.

Pro Tools LE uses host (CPU) processing to provide audio track recording, playback, mixing, and effects processing. Pro Tools HD can also use host processing to run RTAS plug-ins for effects processing. Performance is determined by your system and its Playback Engine settings.

The Playback Engine dialog lets you set a hardware buffer size and allocate a percentage of CPU resources for these tasks. For more information, see “Configuring Pro Tools System Settings (in the Playback Engine)” on page 37.

**Pro Tools Sessions**

When you start a project in Pro Tools, you create a session. Some basic elements of sessions are explained in this section.

**Session File**

A session file is the document that Pro Tools creates when you choose File > New Session and configure a new session. Pro Tools can open only one session file at a time. The session file is named with a .ptf (Pro Tools file) extension. Session files contain maps of all elements associated with a project, including audio files, MIDI data, and all your edit and mix information. It is important to realize that a Pro Tools session file does not contain any media files (audio or video), but rather it references audio, video, MIDI, and other files. You can make changes to a session and save those changes in a new session file. This lets you create multiple versions of a session or back up your editing and mixing work.

Pro Tools HD, Pro Tools LE, and Pro Tools M-Powered have different session file icons.

Although there are different session file icons, the session files may be opened by all three applications (with certain restrictions). See “Opening a Session” on page 47.

> When a session is transferred to a different Pro Tools system, its session file icon will change to the icon type of the destination system.
Tracks

Pro Tools tracks are where audio, MIDI, and automation data are recorded and edited. Pro Tools tracks also provide audio channels for routing internal busses, and physical inputs and outputs for audio and MIDI.

Pro Tools provides five types of tracks: audio tracks, Auxiliary Inputs, Master Faders, Instruments tracks, and MIDI tracks.

Audio, MIDI, and Instrument track data can be edited into regions or repeated in different locations to create loops, re-arrange sections or entire songs, or to assemble tracks using material from multiple takes.

Auxiliary Input tracks can route internal audio busses or physical inputs to internal busses or physical outputs. Auxiliary Inputs are typically used for audio effects busses, audio throughput, and submixing.

Master Fader tracks provide controls for physical audio output channels, including the volume level of your mix, panning, and plug-in inserts.

Audio, Auxiliary Input, Instrument, and Master Fader tracks can be mono, stereo, or multi-channel (Pro Tools HD only). When creating a new track, you can choose from a list of formats supported by your system.

Audio File

When you record audio into a Pro Tools session, audio files are created.

Audio files for each session are stored in a folder named “Audio Files.” Audio files are listed in the Pro Tools Region List and can appear in an audio track. A section of an audio file can be defined as a region. See “Regions” on page 13.

Regions

A region is a segment of audio or MIDI data. A region could be a drum loop, a guitar riff, a verse of a song, a recording take, a sound effect, a piece of dialog, or an entire sound file. A region can also have associated automation data. In Pro Tools, regions are created from audio or MIDI files, and can be arranged in audio and MIDI track playlists. Regions can also be grouped and looped.
**Playlist**

A playlist is a sequence of regions arranged on an audio or MIDI track. Tracks have edit playlists and automation playlists.

On audio tracks, an edit playlist tells the hard disk which audio regions to play in what order. For example, you can use the same audio region to access the same piece of audio multiple times at different locations and not use additional disk space. Different versions of the same original audio can be used in different places and have different effects applied. On MIDI and Instrument tracks, edit playlists can store multiple MIDI sequences (or performances) on a track.

A playlist can be made up of a single region or many separate regions. It can be made up of similar elements, such as regions from several different takes of a solo, or dissimilar elements, such as several sound effects.

You can create any number of alternate edit playlists for a track. This lets you assemble different versions of performances or edits on a single track and choose between them with a pop-up menu on the track.

Each track also has a single set of automation playlists, for volume, pan, mute and each automation-enabled control for the insert and send assignments on that track.

**Channel**

The term *channel* is used to describe several related components of a Pro Tools system. The first example of channel refers to a physical input or output of your Pro Tools system.

For example, a 96 I/O audio interface (Figure 1) provides up to 16 channels of input and output to a Pro Tools|HD system, while an Mbox 2 audio interface provides up to 4 inputs and 2 outputs.

---

**Figure 1.** Back view of 96 I/O, with eight analog inputs, eight analog outputs, and eight digital input/output channels (using a lightpipe)
The second use of the term channel refers to a channel strip in the Pro Tools Mix window. Each track in a Pro Tools session has a corresponding channel strip in the Mix window.

Audio and MIDI channel strips have similar controls, but those controls have slightly different effects. For example, audio and Auxiliary Input channel strip faders control the output gain to the mix bus for that channel, while MIDI channel strip faders send MIDI volume data (MIDI controller 7) to the MIDI instrument. Instrument track channel strips combine a MIDI track and Auxiliary Input into a single channel strip.

**Signal Routing**

Pro Tools provides software-based mixing and signal routing controls. The Mix window is where these controls are located. (Some of these controls can also be accessed from the Edit window.)

A common signal routing task is to submix multiple tracks to a single channel strip (such as an Auxiliary Input or a Master Fader) for shared processing and level control. The following example shows three audio tracks submixed to a stereo Auxiliary Input.

![Figure 2. Channel strip in the Mix window (audio track)](image)

The term channel also describes a separate aspect of MIDI operation. See “MIDI Concepts” on page 19.
Signal Routing Options

Signal routing options include the following:

**Track Input and Output (I/O) Controls** The most basic type of signal routing is track input and output. A track needs to have an assigned input path to record audio, and an assigned output path in order to be audible through a hardware output. Signals can also be routed to or from other tracks in Pro Tools (or hardware inputs and outputs) using internal busses.

**Auxiliary Inputs and Master Faders** Auxiliary Inputs are tracks that can be used as returns, submixers and bus masters. Master Faders are used as bus and output master level controls. Both Auxiliary Inputs and Master Faders can have plug-in and/or hardware inserts.

**Instrument Tracks** Instrument tracks let you route sound from a plug-in instrument to outputs, sends and busses, or other inserts.

**Sends** Sends route audio from tracks to hardware outputs, or to internal busses that are in turn routed to other tracks within Pro Tools. Master Faders do not have sends.

**Plug-In and Hardware Inserts** Plug-in processing occurs completely within the Pro Tools system. Hardware inserts utilize audio interface inputs and outputs, for traditional insert routing to and from external effects and other devices.

**Paths** Paths are any routing option in Pro Tools, including internal or external inputs, outputs, busses, and inserts. Pro Tools lets you name these paths, and these path names appear in the Audio Input and Output Path selectors and other menus. See Chapter 7, “I/O Setup” for more information.

Mixing Formats

Sessions can include combinations of mono, stereo, and multichannel format tracks, busses, inputs, outputs, and inserts. (Multichannel formats are supported on Pro Tools|HD systems only.)

System Resources

Track count, plug-in processing, signal path and routing options, and voice availability are ultimately limited by the combined resources available from the host computer, and from your Pro Tools hardware.

Pro Tools provides several ways to manage and conserve resources to maximize the performance of your system. As you begin working with Pro Tools sessions and tracks, you can take advantage of the following features to extend the effectiveness of your available DSP and other resources:

- Pro Tools lets you adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording capabilities. See “Configuring Pro Tools System Settings (in the Playback Engine)” on page 37.
- In order to free up needed DSP resources, Pro Tools allows for certain items (such as tracks and inserts) to be manually made inactive. Inactive elements are viewable, editable, and retained within the session. See “Active and Inactive Items” on page 17.
- All Pro Tools systems provide flexible voice options for audio tracks, to help maximize use of available voices in your system. For more information on voice management and options, see “Voice Borrowing” on page 104.
Active and Inactive Items

Pro Tools lets you set certain items (such as tracks and inserts) as inactive, in order to free up DSP resources and mixer connections.

Items in Pro Tools that can be made inactive (or active) include the following:

- Audio, Auxiliary Input, Instrument, and Master Fader tracks
- Track Inputs and Outputs
- Sends
- Side-chain inputs
- Plug-ins
- Hardware inserts
- Paths (session-wide)

⚠️ MIDI tracks cannot be made inactive.

In addition to manually setting Active and Inactive modes, Pro Tools will automatically make items inactive if there are insufficient or unavailable resources.

When active, items are fully engaged and operational.

When inactive, items are silent and off, although most associated controls can still be adjusted. Different inactive items affect available system resources in specific ways, as follows:

Plug-Ins When a plug-in is inactive on a track, its DSP is made available for other plug-ins and processing. Plug-in assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 18).

Display of Inactive Items

When items are inactive, their names appear in italics, and their background becomes dark grey. When a track is inactive, the entire channel strip is grayed out.

Paths and Path Assignments When a path or path assignment is inactive, its mixer resources are made available for other signal routing purposes in the session. Paths and assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 18).

Tracks When a track is made inactive, its voices become available for another track. Mono inactive tracks free up one voice, and stereo and multichannel tracks free up one voice per channel. Additionally, when an audio, Auxiliary Input, Instrument, or Master Fader track is made inactive, its plug-ins, inserts, sends, and I/O assignments become inactive, and the associated DSP used is freed up for use elsewhere in the session.
Active and Inactive Modes

Active and Inactive modes are powerful options for session transfer and system resource management. Pro Tools provides automatic and manual Inactive mode switching. You can manually make items inactive (or active) to selectively manage system resources while editing and mixing.

Automatically Inactive Items

When opening a session, it is possible that not all signal paths, plug-ins, or audio interfaces used in the session will be available as defined on the current system. When opening a session, sufficient voices may also be unavailable if the session was created on a different Pro Tools system type (for example, opening a session created on a Pro Tools HD system on a Pro Tools LE system).

Whenever this occurs, the session will open as it was last saved. All items that are unavailable, or cannot be loaded due to insufficient resources, are made inactive.

Manual Inactive Switching

You can manually apply Active or Inactive modes to manage system resources. By making an item inactive, its associated resources are made available elsewhere in the session.

The following are basic instructions for manually making items inactive. Throughout the Pro Tools Reference Guide, instructions are provided whenever an item can be made inactive.

To toggle an item active or inactive:

- Control-Start-click (Windows) or Command-Control-click (Macintosh) the item.

You can apply Active or Inactive modes to all or all selected tracks using standard Pro Tools modifiers (Alt and Alt+Shift in Windows, Option and Option+Shift on the Macintosh). Side-chain inputs support direct active and inactive switching, but do not follow switching all or all selected side-chain inputs.
MIDI Concepts

MIDI (Musical Instrument Digital Interface) is a communication protocol for musical instruments. This industry standard enables connections between a variety of devices from different manufacturers. Examples of MIDI-compatible equipment include synthesizers, sound modules, drum machines, patch bays, effects processors, MIDI interfaces, MIDI control surfaces, and sequencers.

MIDI devices are equipped with 5-pin DIN connectors, labeled as either IN, OUT, or THRU. The MIDI OUT port transmits messages. The MIDI IN port receives messages. The MIDI THRU echoes whatever is received from the IN port. MIDI devices are connected with MIDI cables that are available at most music stores.

The MIDI protocol provides 16-channels of MIDI per port. A single MIDI cable can transmit a separate set of messages for each of the 16 channels. These 16 channels correspond to separate MIDI devices or to multiple channels within a single device (if the device is multi-timbral). Each channel can control a different instrument sound. For example, bass on channel 1, piano on channel 2, and drums on channel 10. Similar to a multitrack tape recorder, a MIDI sequencer can record complex arrangements—even using a single multi-timbral keyboard.

MIDI Terms

The following are some basic MIDI terms:

MIDI Instrument (or Virtual Instrument) An instrument plug-in. In this guide, “instrument” refers to soft synths and plug-in inserts.

MIDI Interface Hardware that lets computers connect to and communicate with MIDI devices.

MIDI Device Any keyboard, sound module, effects device or other equipment that can send or receive MIDI information.

MIDI Controller Any MIDI device that transmits MIDI performance data. These include keyboards, MIDI guitar controllers, MIDI wind instruments, and others. Controllers transmit MIDI from their MIDI OUT ports.

MIDI Control Surface Any device (such as the Digidesign Command|8), which uses a MIDI connection to send control messages to a software program, but is not generally used to record MIDI information.

MIDI Tone Generator (MIDI Sound Source) Any MIDI instrument capable of playing back MIDI-triggered sound. Sound sources receive MIDI from their MIDI IN ports.

Multi-Timbral The ability of one MIDI device to play several different instrument sounds (such as piano, bass, and drums) simultaneously on separate channels. This makes it possible for a single MIDI sound source to play back entire arrangements.
**MIDI Channel**  Up to 16 channels of MIDI performance data can be transmitted on a single MIDI cable. The channel number separates the different messages so your sound sources can receive the right ones.

**Program Change Event**  A MIDI command that tells a sound source which of its sounds (or sound patches) to use. The MIDI protocol lets you choose from a range of 128 patches.

**Bank Select Message**  Many devices have more than 128 patches, which are arranged in banks. The Bank Select Message is a MIDI command that specifies the bank of patches from which to choose.

**Local Control**  A controller setting found on most MIDI keyboards that lets them play their own sound source. Disabling “local control” ensures that a device’s internal sound source is only played by external MIDI messages. When using Pro Tools, “local control” should usually be disabled. When “local control” is off, your keyboard still transmits data to its MIDI OUT port.

**Continuous Controller Events**  MIDI instructions that allow real-time changes to notes that are currently sounding. These include pitch bend, modulation, volume, pan, and many others.

**System Exclusive Data**  MIDI data commonly used for sending and retrieving patch parameter information for storage purposes.

**Common MIDI Misconceptions**

MIDI is not audio, and by itself makes no sound. MIDI is control information only. It is like the piano roll for a player piano; it provides control information for what note to play when, for how long, and at what volume. For example, when you strike a key on a MIDI keyboard, it sends a message to a MIDI instrument or tone generator to play that particular note at that particular velocity. This could be its internal tone generator, an external MIDI instrument, or an instrument plug-in, which can be contained completely within Pro Tools. In order to create or play a MIDI recording, you must have a MIDI instrument. Audio from your instrument can be sent to an external mixer or monitored through your Pro Tools audio interface.

If you are using an external MIDI instrument, it must be connected to MIDI ports that are recognized by your computer. These ports can be on a Pro Tools interface that has MIDI ports (such as MIDI I/O, Mbox 2, or a Digidesign-qualified M-Audio interface) or some other MIDI interface.

![Signal paths for external MIDI instruments](image)

To actually hear an external MIDI instrument, you need to connect its audio outputs to a mixing console or connect it to one of the audio inputs of your Pro Tools audio interface.

Just as each Pro Tools system has hardware limitations, each MIDI device has its own limitations as to the number of voices and instruments it can play at one time. Consult the device’s documentation for its limitations.

When using MIDI with instrument plug-ins in Pro Tools, virtual MIDI nodes are created. These nodes provide software MIDI connections between Pro Tools and other MIDI software, such as instrument plug-ins. For example, when you insert Propellerhead’s Reason as a ReWire client on a track, its various MIDI inputs become available to Pro Tools MIDI and Instrument track MIDI outputs.
Chapter 4: Pro Tools Windows

Pro Tools provides two complementary ways of viewing a session: the Mix window and the Edit window. Pro Tools also lets you control the transport and transport-related functions in the Transport window.

To toggle between the Mix and Edit windows, press Control+Equals (=) (Windows), or press Command+Equals (=) (Macintosh).

For information on the main elements of the Mix window and Edit window, see the page references provided in Figure 3 on page 22, and Figure 4 on page 23.

Pro Tools also includes DigiBase browsers for searching, sorting, and importing data.

For more information on DigiBase, see the DigiBase Guide.

The Mix Window

In the Mix window, tracks appear as channel strips, with controls for inserts, sends, input and output assignments, volume, panning, record enable, automation mode, and solo/mute.

To display the Mix window:

- Choose Window > Mix.

To display all Mix window view options:

- Select View > Mix Window > All.

For information on selecting individual view options, see “Views in the Mix and Edit Windows” on page 483.

The Edit Window

The Edit window provides a timeline display of audio, as well as MIDI data and mixer automation for recording, editing and arranging tracks. As in the Mix window, each track has controls for record enable, solo, mute and automation mode. Pro Tools also provides a video track.

To display the Edit window:

- Choose Window > Edit.

To display all Edit window view options:

- Select View > Edit Window > All.

For information on selecting individual view options, see “Views in the Mix and Edit Windows” on page 483.
Figure 3. Pro Tools Mix window
Figure 4. Pro Tools Edit window
**Track Controls**

- Automation Mode selector (page 536)
- Record Enable button (page 152)
- TrackInput button (page 155)
- Mute button (page 110)
- Solo button (page 107)

*Mix window track controls for mono audio track (Wide View)*

- Record Enable button (page 152)
- Track Name button (page 94)
- Playlist selector (page 236)
- Solo button (page 107)
- Mute button (page 110)
- Track Height selector (page 224)
- Voice selector (page 103)
- Automation Mode selector (page 536)
- Track Input Monitor button (page 155)
- Timebase selector (page 235)

*Edit window track controls for stereo audio track (medium track height)*

- Zoomer tool (page 249)
- Selector tool (page 265)
- Grabber tools (page 276)
- Scrubber tool (page 260)
- Pencil tool (page 416)

*Zoom Toggle (page 249)*

**Edit Tools**

- Zoom Toggle (page 249)
- Smart Tool (page 259)
- Custom Note Duration button (page 417)

*Edit tools in Edit window*

**Edit Window Counters and Selection Indicators**

**Main and Sub Counters**

Main and Sub Counters (page 269)

*Edit window display showing counters*

The Main and Sub Counters can be set for different Time Scale formats (such as Samples, Bars:Beats, or Minutes:Seconds). For more information, see “Main Time Scale” on page 232. These counters are also displayed in the Transport window.

**Edit Selection Indicators**

*Edit Selection indicators in the Edit window*

The Edit Selection Start, End, and Length indicators display can be set for different Time Scale formats (such as Samples, Bars:Beats, or Minutes:Seconds). For more information, see “Main Time Scale” on page 232.

**Event Edit Area**

The Event Edit Area provides time, pitch, and other information for the currently selected audio or MIDI data. It also lets you define selections using the keyboard.

*Event Edit Area showing MIDI track information*
**Edit Window Bar**

The Edit Window bar contains various selectors, commands, indicators, and pop-up menus for working in the Pro Tools Edit window.

**View Selectors**

The Edit Window bar contains various selectors, commands, indicators, and pop-up menus for working in the Pro Tools Edit window.

**Commands**

The Edit Window bar contains various selectors, commands, indicators, and pop-up menus for working in the Pro Tools Edit window.

**Grid/Nudge Value Indicators and Pop-Up Menus**

The Edit Window bar contains various selectors, commands, indicators, and pop-up menus for working in the Pro Tools Edit window.

**Cursor Location Indicators**

The Edit Window bar contains various selectors, commands, indicators, and pop-up menus for working in the Pro Tools Edit window.

**The Transport Window**

The Transport window can be set to show basic transport controls, counters, MIDI controls, and expanded features. The counters in the Transport window mirror the controls and counters at the top of the Edit window.

**To display the Transport window:**

- Choose Window > Transport.

**Basic Transport Controls and Counters**

The Transport window can be set to show basic transport controls, counters, MIDI controls, and expanded features. The counters in the Transport window mirror the controls and counters at the top of the Edit window.

- Choose Window > Transport.

**Transport window showing basic transport controls and counters (Main and Sub Counters and MIDI not shown)**
Online Puts Pro Tools online so that playback and recording is triggered by an external time code source.

Return to Zero Locates to the beginning of the session.

Press Enter (Windows) or Return (Macintosh) to Return to Zero.

Rewind Rewinds from the current play location. You can also click repeatedly to rewind incrementally, by an amount based on the Main Time Scale, as follows:

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time Code (Pro Tools HD or Pro Tools LE with DV Toolkit)</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet+Frame (Pro Tools HD or Pro Tools LE with DV Toolkit)</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Transport, you can rewind by pressing 1.

Stop Stops playback or recording. You can also stop the Transport with the following shortcuts:

- Press the Spacebar.
- With Numeric Keypad mode set to Transport, press 0.

Play Starts playback or (if the Record Enable button was clicked first) recording from the Timeline insertion point.

With the Transport stopped, Right-click Play (Windows) or Control-click Play (Macintosh) to toggle Loop Playback mode. When enabled, a loop symbol appears in the Play button and Pro Tools plays continuously from the beginning of the selection to the end.

You can also initiate playback with the following shortcuts:

- Press the Spacebar.
- With the Numeric Keypad mode set to Transport, press 0.

You can play at half-speed with the following shortcuts:

- Press Shift+Spacebar.
- Shift-click (Macintosh) the Play button.

Fast Forward Fast forwards from the Timeline insertion point. You can also click repeatedly to fast forward incrementally (by an amount based on the Main Time Scale).

Fast Forward Increments

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time Code (Pro Tools HD or Pro Tools LE with DV Toolkit)</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet+Frame (Pro Tools HD or Pro Tools LE with DV Toolkit)</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>
Go to End  Locates to the end of the session.

Record Enable  Arms Pro Tools for recording (the button flashes). Clicking Play then initiates recording on record-enabled tracks only.

With the Transport stopped, Right-click Record Enable (Windows) or Control-click Record Enable (Macintosh) to cycle through the five record modes. The Record Enable button changes to indicate the currently selected mode: blank for Nondestructive, “D” for Destructive, a loop symbol for Loop Record, “P” for Quick-Punch, and “T” for TrackPunch.

You can also begin recording with the following shortcuts:

- Press F12.

On Macintosh systems, the F12 key is initially used for the Mac OS X “Spotlight” menu keyboard shortcut. To use F12 in Pro Tools, remap the “Spotlight” menu keyboard shortcut in the Macintosh System Preferences. See your Getting Started Guide.

- Control+Spacebar (Windows) or press Command+Spacebar (Macintosh).
- With the Numeric Keypad mode set to Transport, press 3.

To initiate recording at half-speed, press Control+Shift+Spacebar (Windows) or Command+Shift+Spacebar (Macintosh).

Track Record Enable Indicator  When lit (red), indicates that at least one audio track is currently record-enabled. When off (grey), no tracks are currently record-enabled.

Track Input Monitor Indicator  When lit (green), indicates that at least one audio track is currently set to Input Only monitoring (regardless of record enable status). When off (grey), all tracks are in Auto Input monitoring.

Pre-Roll  During playback or record, specifies the amount that plays before the play (timeline) Cursor location or beginning of the Timeline selection. Pre-roll is particularly useful with punch recording since it provides you with time to “catch the beat” before reaching the punch-in point. To set the pre-roll amount, enter a new value in this field, or drag the Pre-Roll flag in the Main Timebase ruler.

To enable pre-roll, click the Pre-Roll button to the left of the pre-roll field so it becomes highlighted.

Post-Roll  During playback or record, specifies the amount that plays after the end of a Timeline selection. Post-roll is useful in punch recording since playback continues after the punch-out point so you can check for a smooth transition to previously recorded material. To set the post-roll amount, enter a new value in this field, or drag the Post-Roll flag in the Main Timebase ruler.

To enable post-roll, click the Post-Roll button to the left of the post-roll field so it becomes highlighted.

Start  Specifies the beginning of the play or record range. You can set the start point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase ruler. For more information, see “Playback Markers” on page 181.
End Specifies the end of the play or record range. You can set the end point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase ruler. For more information, see “Playback Markers” on page 181.

Length Specifies the length for the play or record range. You can set the length by entering a location in this field, or by selecting a range in any Timebase ruler.

If the Timeline and Edit selections are linked, you can drag in a track’s playlist to set the play and record range. See “Linking or Unlinking Timeline and Edit Selections” on page 272

Transport Master Selector Specifies the “master” for transport functions and provides a control to take enabled devices offline.

To set a Transport Master:
- Click the Transport Master selector, click the Transport pop-up menu, and select a Transport Master: Pro Tools, Machine, MMC (MIDI Machine Control), or Remote.

To take a device offline:
- Click the Transport Master selector, click the Online pop-up menu, and uncheck the device (MIDI or Machine). Device choices depend on the current Transport Master, and which devices have been set up in Pro Tools.

To bring the device back online, recheck it in the Online pop-up menu.

If you are using the Digidesign Machine-Control option, see the MachineControl Guide.

MIDI Controls

Temperature Ruler
- Enable Wait for Note
- Current Meter
- Metronome Click
- MIDI Merge
- Countoff
- Tempo Resolution (Beat Value) pop-up menu
- Current Tempo
- Tempo slider

To view the MIDI controls in the Transport, do one of the following:
- Select View > Transport > MIDI Controls.
- or -
- Control-click (Windows) or Command-click (Macintosh) the Expand/Collapse “+” button in the Transport window to display the MIDI controls.
Wait for Note  When selected, recording does not begin until a MIDI event is received. This ensures that you begin recording when you're ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range.

You can press F11 to turn on Wait for Note, unless the Operation preference for “Disable F11 for Wait for Note” is selected.

Metronome Click  When selected, Pro Tools will generate a metronome pulse that can be set to trigger built-in sounds or MIDI instruments during playback and recording.

The Pro Tools metronome is configured in the Click/Countoff Options dialog. Double-click the Metronome Click button to open the Click/Countoff Options dialog.

With the Numeric Keypad mode set to Transport, you can press 7 to enable the Metronome Click.

Countoff  When selected, Pro Tools counts off a specified number of measures (indicated in the button) before playback or recording begins.

Double-click the Countoff button, to open the Click/Countoff Options dialog.

With the Numeric Keypad mode set to Transport, you can press 8 to enable the Countoff.

MIDI Merge  When selected (Merge mode), recorded MIDI data is merged with existing track material. When deselected (Replace mode), recorded MIDI data replaces existing track material.

With the Numeric Keypad mode set to Transport, you can press 9 to enable MIDI Merge.

Tempo Ruler Enable (Conductor)  When selected, Pro Tools uses the tempo map defined in the Tempo ruler. When deselected, Pro Tools switches to Manual Tempo mode and ignores the Tempo ruler.

In Manual Tempo mode, you can enter a BPM value in the tempo field, or tap in the tempo by clicking the T key on your QWERTY keyboard.

Tempo Slider  When the Tempo Ruler Enable (Conductor) is disabled, Pro Tools ignores the tempo events in the Tempo track and instead plays back a Manual Tempo. This tempo can be set with the Tempo slider.

Current Meter  Displays the session’s current meter based on the play location. Double-click the Current Meter indicator to open the Change Meter window.

Current Tempo  Displays the session’s current tempo based on the play location. In Manual Tempo mode, you can enter a BPM value into this field. In addition, when the tempo field is selected, you can tap in a tempo from a MIDI controller.

Menus and Windows
Pro Tools menus provide commands and options for configuring and working with Pro Tools, sessions, and session material.

For detailed information, see the Pro Tools Menus Guide.

Pro Tools includes the following main menus:

File  Provides commands that read and write session data to and from disk.

Edit  Provides actions that operate on the current selection and affect data in tracks or the clipboard.
**View** Provides choices to customize what is shown in various windows.

**Track** Provides actions that affect all of the selected tracks.

**Region** Provides actions that affect all of the selected regions.

**Event** Provides actions that affect selected events, such as MIDI or tempo data.

**AudioSuite** Provides AudioSuite plug-ins.

**Options** Provides items that determine how Pro Tools responds.

**Setup** Provides dialog boxes to configure application and hardware peripheral settings.

**Window** Lets you open specific Pro Tools windows.

### Track, Region, and Group List Menus

The Track, Region, and Group Lists provide pop-up menus for managing and working with the contents of each list, as follows:

**Track List Pop-Up Menu** Provides commands to show and hide tracks in the Mix and Edit windows. The Track List pop-up menu also lets you sort the contents of the Track List. (See “The Track List” on page 98.)

**Region List Pop-Up Menu (Edit Window Only)** Provides commands to find, select, sort, clear, rename, time stamp, compact, export, and recalculate waveform overviews of items in the Region List. The pop-up menu also lets you set the drop order for regions dragged from the Region List and dropped in the timeline. (See “The Region List” on page 240.)

**Group List Pop-Up Menus (Edit Groups and Mix Groups)** Provides commands to create, display, suspend, and delete Mix and Edit Groups. (See “Using the Group List” on page 115.)

### Tool Tips

Pro Tools provides Tool Tips in all main windows. Parking the cursor for a few seconds over an abbreviated name, or unlabeled icon or tool, will display either the function or details of the item (depending on the Tool Tips preferences settings).

**To configure Tool Tips for Pro Tools:**

1. Choose Setup > Preferences, and click the Display tab.
2. In the Tool Tips Display section, click the Tool Tip options you want displayed.
3. Leave both options unchecked to turn off Tool Tips.
Chapter 5: Keyboard Shortcuts

This chapter provides an overview of Pro Tools keyboard shortcuts. For a complete list of shortcuts, refer to the electronic PDF versions of the Keyboard Shortcuts Guides.

Global Key Commands

This section shows keyboard shortcuts that apply to many functions in Pro Tools.

Track Functions

- Changing Automation mode
- Enabling playlists
- Adding plug-ins
- Record enabling, soloing, and muting tracks
- Record saing and solo saing tracks
- Assigning inputs, outputs, and sends
- Toggling volume/peak/delay display
- Clearing meters
- Changing track heights

List and Parameter Selection

- Selection of tracks in Track List
- Enabling of groups in Group List
- Automation Enable window parameters
- Setting memory location parameters

Controls and Editing Tools

- Use to move plug-in controls, faders and sliders, the Scrubber, and automation data

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle item and set all others to same new state</td>
<td>Alt-click item</td>
<td>Option-click item</td>
</tr>
<tr>
<td>Toggle item and set all others to opposite state</td>
<td>Control-click item</td>
<td>Command-click item</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fine adjustment of sliders, knobs, and breakpoints</td>
<td>Hold Control while clicking the item</td>
<td>Hold Command while clicking the item</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply action to all channel strips/tracks</td>
<td>Alt+ action</td>
<td>Option+ action</td>
</tr>
<tr>
<td>Apply action to selected channel strips/tracks</td>
<td>Alt+ Shift+ action</td>
<td>Option+ Shift+ action</td>
</tr>
</tbody>
</table>
Keyboard Focus

The Keyboard Focus in Pro Tools determines how the alpha keys function. Depending on which Keyboard Focus is enabled, you can use the keys on your QWERTY (alpha) keyboard to select regions in the Region List, enable or disable groups, or perform an edit or play command.

You can only enable one Keyboard Focus at a time. Enabling a Keyboard Focus will disable the one previously enabled.

There are three types of Keyboard Focus:

Commands Keyboard Focus When selected, this provides a wide range of single key shortcuts from the QWERTY keyboard for editing and playing.

With Commands Keyboard Focus disabled, you can still access any of its key shortcuts by pressing the Start key (Windows) or Control (Macintosh) along with the key.

Region List Keyboard Focus When selected, audio regions, MIDI regions, and Region Groups can be located and selected in the Region List by typing the first few letters of the region’s name.

Group List Keyboard Focus When selected, Mix and Edit Groups can be enabled or disabled by typing the Group ID letter (in either the Mix or Edit window).

An electronic PDF listing of keyboard shortcuts is available in Pro Tools. Choose Help > Keyboard Shortcuts.

To set the Keyboard Focus, do one of the following:

■ Click the a–z button for the focus you want to enable.

— or —

■ While pressing Control+Alt (Windows) or Command+Option (Macintosh), press one of the following keys: 1 (Commands), 2 (Region List), or 3 (Group List).

Although multiple plug-in windows can have a keyboard focus enabled, only the front-most window will receive any keyboard input.
Numeric Keypad Modes

The Operation preference for Numeric Keypad mode determines how the numeric keypad functions for Transport.

There are two Shuttle Lock modes (Classic and Transport), and one Shuttle mode.

No matter which Numeric Keypad mode is selected, you can always use the numeric keypad to select and enter values in the Event Edit Area, Edit Selection indicators, Main and Sub Counters, and Transport fields.

To set the Numeric Keypad Mode:

1. Choose Setup > Preferences and click the Operation tab.

2. Under the option for Numeric Keypad mode, select a keypad mode (Classic, Transport, or Shuttle), then click Done.

Shuttle Lock Modes

With either Shuttle Lock mode (Classic or Transport) you can use the numeric keypad to shuttle forward or backwards at specific speeds.

- 5 is normal speed.
- 6–9 provide increasingly faster fast-forward speeds.
- 1–4 provide progressively faster rewind speeds (4 is the slowest rewind Shuttle Lock speed, 1 is the fastest).
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.

Custom Shuttle Lock Speed

The highest fast-forward Shuttle Lock speed (key 9) can be customized (Pro Tools HD and Pro Tools LE with DV Toolkit only). See “Custom Shuttle Lock Speed” on page 262.

Classic Mode

This mode emulates the way Pro Tools worked in versions lower than 5.0. With the Numeric Keypad mode set to Classic, you can:

- Play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Macintosh), followed by 1–9 for different play speeds.
- Press Plus or Minus to reverse direction.
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.
- Recall Memory Locations by typing the Memory Location, followed by a Period (.).
Transport Mode

This mode allows you to set a number of record and play functions, and also operate the Transport from the numeric keypad.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on/off</td>
<td>7</td>
</tr>
<tr>
<td>Countoff on/off</td>
<td>8</td>
</tr>
<tr>
<td>MIDI Merge/Replace mode</td>
<td>9</td>
</tr>
<tr>
<td>Loop Playback mode on/off</td>
<td>4</td>
</tr>
<tr>
<td>Loop Record mode on/off</td>
<td>5</td>
</tr>
<tr>
<td>QuickPunch mode on/off</td>
<td>6</td>
</tr>
<tr>
<td>Rewind</td>
<td>1</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>2</td>
</tr>
<tr>
<td>Record enable</td>
<td>3</td>
</tr>
<tr>
<td>Play/Stop</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Transport, you can also:

- Play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Macintosh), followed by 1–9 for different play speeds.
- Press Plus or Minus to reverse direction.
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.
- Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

Shuttle Mode

(Pro Tools HD Only)

Pro Tools offers another form of shuttling, different from that of the two Shuttle Lock modes. With the Numeric Keypad mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

<table>
<thead>
<tr>
<th>Playback Speeds</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1x Forward</td>
<td>6</td>
</tr>
<tr>
<td>1x Rewind</td>
<td>4</td>
</tr>
<tr>
<td>4x Forward</td>
<td>9</td>
</tr>
<tr>
<td>4x Rewind</td>
<td>7</td>
</tr>
<tr>
<td>1/4x Forward</td>
<td>3</td>
</tr>
<tr>
<td>1/4x Rewind</td>
<td>1</td>
</tr>
<tr>
<td>1/2x Forward</td>
<td>5+6</td>
</tr>
<tr>
<td>1/2x Rewind</td>
<td>5+4</td>
</tr>
<tr>
<td>2x Forward</td>
<td>8+9</td>
</tr>
<tr>
<td>2x Rewind</td>
<td>8+7</td>
</tr>
<tr>
<td>1/16x Forward</td>
<td>2+3</td>
</tr>
<tr>
<td>1/16x Rewind</td>
<td>2+1</td>
</tr>
<tr>
<td>Loop Selection (1x)</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Shuttle, you can also:

- Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

⚠️ Shuttle Lock modes are not available when the Numeric Keypad mode is set to Shuttle.
Part II: Sessions & Tracks
Chapter 6: Sessions

This chapter covers the basics of starting a project in Pro Tools, including how to set up and save a Pro Tools session.

Starting Up or Shutting Down Your System

To ensure that the components of your Pro Tools system communicate properly with each other, you need to start them in a particular order.

Start up your Pro Tools system in this order:

1. For Pro Tools|HD systems with an expansion chassis, turn on the chassis.
2. Turn on any external hard drives. Wait approximately ten seconds for them to spin up to speed.
3. Turn on any MIDI interfaces, MIDI devices, or synchronization peripherals.
4. Lower the volume of all output devices in your system.
5. For Pro Tools|HD systems, turn on your Pro Tools audio interfaces. Wait at least fifteen seconds for your system hardware to initialize.
6. Turn on your computer.
7. Launch Pro Tools or any third-party audio or MIDI applications.

Shut down your Pro Tools system in this order:

1. Quit Pro Tools and any other running applications.
   - To quit Pro Tools, choose File > Exit (Windows) or Pro Tools > Quit (Macintosh)
2. Turn off or lower the volume of all output devices in your system.
3. Turn off your computer.
4. For Pro Tools|HD systems, turn off audio interfaces.
5. For Pro Tools|HD systems with an expansion chassis, turn off the chassis.
6. Turn off any MIDI interfaces, MIDI devices, or synchronization peripherals.
7. Turn off any external hard drives.

Configuring Pro Tools System Settings (in the Playback Engine)

Pro Tools allows you to adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording.

These system settings are changed in the Playback Engine Dialog (Setup > Playback Engine).
In most cases, the default settings for your system provide optimum performance, but you may want to adjust them to accommodate large or processing-intensive Pro Tools sessions.

**Hardware Buffer Size**

The Hardware Buffer Size (H/W Buffer Size) controls the size of the hardware cache used to handle host-based tasks such as Real-Time Audio-Suite (RTAS) plug-in processing.

- Lower Hardware Buffer Size settings reduce monitoring latency, and are useful when you are recording live input.
- Higher Hardware Buffer Size settings allow for more audio processing and effects, and are useful when you are mixing and using more RTAS plug-ins.

⚠️ In addition to causing slower screen response and monitoring latency, higher Hardware Buffer Size settings can affect the accuracy of plug-in automation, mute data, and timing for MIDI tracks.

**To change the Hardware Buffer Size:**

2. From the H/W Buffer Size pop-up menu, select the audio buffer size, in samples.
3. Click OK.

**RTAS Processors**

The RTAS Processors setting determines the number of processors in your computer allocated for RTAS (real-time plug-ins) plug-in processing.

With computers that have multiple processors, or that feature multi-core processing or hyper-threading, this setting lets you enable multi-processor support for RTAS processes. Used in combination with the CPU Usage Limit setting, the RTAS Processors setting lets you control the way RTAS processing and other Pro Tools tasks are carried out by the system.

For example:

- For sessions with large numbers of RTAS plug-ins you can allocate 2 or more processors to RTAS and set a high CPU Usage Limit.
- In sessions with few RTAS plug-ins, you can allocate fewer processors to RTAS and set a low CPU Usage Limit to leave more CPU resources available for automation accuracy, screen response, or video.
- Increase or decrease these settings to accommodate TDM/RTAS plug-in conversion. TDM/RTAS conversion can be desirable during recording, depending on the latencies, voicing needs, and record-monitoring capabilities of TDM and RTAS plug-ins.
- Depending on the importance of video and overall screen response, and on the density of automation being employed, different combinations of RTAS Processing and CPU Usage Limit settings may achieve the best results.

The System Usage window shows the combined amount of RTAS processing occurring on all enabled processors with a single indicator, regardless of how many CPUs are in the system. If the System Usage Window shows that you are at the limit of available resources, increase the number of RTAS processors and/or the CPU Usage Limit setting. (For more information, see “System Usage” on page 55.)
To set the number of RTAS Processors:


2. From the RTAS Processing pop-up menu, select the number of available processors you want to allocate. The number of processors available varies depending on how many processors are available on your computer:
   - Choose 1 Processor to limit RTAS processing to one CPU in the system.
   - Choose 2 Processors to enable load balancing across two available processors.
   - On systems running four or more processors, choose the desired number of RTAS processors as needed.

3. Click OK.

CPU Usage Limit

The CPU Usage Limit controls the percentage of CPU resources allocated to Pro Tools host processing tasks. Used in combination with the RTAS Processors setting, the CPU Usage Limit setting lets you control the way Pro Tools tasks are carried out by the system:

- Lower CPU Usage Limit settings limit the effect of Pro Tools processing on other CPU-intensive tasks, such as screen redraws, and are useful when you are experiencing slow system response, or when running other applications at the same time as Pro Tools.

- Higher CPU Usage Limit settings allocate more processing power to Pro Tools, and are useful for playing back large sessions or using more real-time plug-ins.

The maximum CPU Usage Limit is 85 percent for single-processor computers (except for Digi 002, which has a limit of 99 percent), and 99 percent for multi-process computers. (The 99 percent setting dedicates one entire processor to Pro Tools.)

On multi-processor computers, the maximum CPU Usage Limit is reduced when you use all your processors (as selected in the RTAS Processing pop-up menu). For example, on dual-processors, the limit will be 90%. On four-processor computers, the limit will be 95%.

Increasing the CPU Usage Limit may slow down screen responses on slower computers.

To change the CPU Usage Limit:


2. From the CPU Usage Limit pop-up menu, select the percentage of CPU processing you want to allocate to Pro Tools.

3. Click OK.

Number of Voices

(Pro Tools HD Only)

On Pro Tools HD systems, the Number of Voices setting lets you control the number of available voices and how those voices are allocated to DSPs in your system. For example, the default number of voices on a Pro Tools HD 1 system is 48 voices, using one DSP (at sample rates of 44.1 kHz or 48 kHz).

Changing the number of voices affects DSP usage, the total number of voiceable tracks, and overall system performance.
Depending on the current sample rate and the number of Pro Tools|HD cards in your system, you will have different choices for voice count. For voice limits on different Pro Tools|HD systems, see “Pro Tools|HD System Playback, Recording and Voice Limits” on page 7.

To change the number of voices and DSP to allocate for voicing:


2. Select the number of voices and DSPs to allocate for voicing by selecting a value from the Number of Voices pop-up menu.
   - Select higher voice numbers when your Pro Tools|HD cards are the only PCI cards in your computer, or when you are using an expansion chassis to run higher track counts.
   - Select medium voice numbers when your Pro Tools|HD cards are in an expansion chassis, or when you are using other PCI cards along with Pro Tools|HD cards.
   - Select minimum voice numbers if you are using high-bandwidth PCI cards (such as video capture cards) along with your Pro Tools|HD cards. In addition, to free up DSP for plug-ins and processing, select the minimum number of voices and DSPs needed to play back the current session.

3. Click OK.

**Default Sample Rate**

The Sample Rate setting appears as the default sample rate when you create a new session. (This setting is available only when there is no session open.)

⚠️ With Pro Tools HD, the Sample Rate setting can affect the number of available voices.

To change the default Sample Rate:


2. Select the sample rate from the Sample Rate pop-up menu.

3. Click OK.

⚠️ You can change the sample rate when creating a new Pro Tools session by selecting a different sample rate in the New Session dialog. (See “Creating a New Session” on page 45.)

**Delay Compensation Engine**

(Pro Tools HD Only)

The Delay Compensation Engine lets you manage DSP delays in the Pro Tools mixer.

There are three settings in the Playback Engine dialog for dedicating DSP resources for Delay Compensation:

- **None** Allocates no DSP resources for Delay Compensation.
- **Short** Allocates minimal DSP resources for Delay Compensation for each channel. This is the most efficient setting for Pro Tools|HD Accel systems.
Long Allocates maximum DSP resources for Delay Compensation for each channel. Long Delay Compensation uses the SRAM contained on DSPs used by higher-overhead plug-ins.

To configure the Delay Compensation Engine:
2. From the Delay Compensation Engine pop-up menu, select a Delay compensation setting.
3. Click OK.

The Delay Compensation setting is saved as a session and system preference.

For more information, see “Delay Compensation” on page 505.

DAE Playback Buffer Size

The DAE Playback Buffer Size determines the amount of memory DAE allocates for disk buffers. The optimum DAE Playback Buffer Size for most disk operations is Level 2.

- DAE Playback Buffer Size settings lower than Level 2 may improve playback and recording initiation speed, but may make it difficult to play or record tracks reliably with sessions containing a large number of tracks or a high density of edits, or running on slower or heavily fragmented hard drives.

- DAE Playback Buffer Size settings higher than Level 2 will allow for a higher density of edits in a session or a higher track count when using slower hard drives. However, a higher setting can also cause a time lag to occur when starting playback or recording, and result in a longer audible time lag while editing during playback.

💡 Using a larger DAE Playback Buffer Size leaves less system memory for other tasks. The default setting of Level 2 is recommended unless you are encountering -9073 (“Disk too slow or fragmented”) errors.

To change the DAE Playback Buffer Size:
2. From the DAE Playback Buffer pop-up menu, select a buffer size. Memory requirements for each setting are shown at the bottom of the Playback Engine dialog.
3. Click OK.
4. If Pro Tools needs more system memory for the DAE Playback Buffer, it will prompt you to restart your computer.

System Memory Allocation
(Pro Tools HD Only)

When you start your computer, Pro Tools automatically reserves a portion of system memory for the DAE Playback Buffer. This reserved memory is unavailable to other applications, even if Pro Tools is not running.

You can set Pro Tools to reserve only the minimum amount of required memory, so that system memory is available to other applications.
To minimize system memory allocation:
2. Select the “Minimize System Memory Allocation” option.
3. Click OK.
4. Do one of the following:
   - On Windows systems, restart your computer.
   - Or —
   - On Macintosh systems, enter your password when prompted, then restart your computer.

Configuring Pro Tools Hardware Settings

Pro Tools allows you to configure the signal routing, digital I/O format, default sample rate, clock source, and other hardware-based settings depending on your system configuration.

The following section outlines the configuration of a Pro Tools|HD system with one or more Pro Tools|HD interfaces (with one or more Legacy interfaces attached).

To configure a Pro Tools LE system, refer to the Getting Started Guide that came with that system.

Configuring Pro Tools|HD Hardware

On Pro Tools|HD systems, you configure Hardware settings for each audio interface connected to your system. For example, Pro Tools|HD systems can have 192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O audio interfaces connected to HD Core and HD Accel or HD Process cards in the system. The 192 I/O, 192 Digital I/O, and 96 I/O can have additional interfaces attached (including older Digidesign audio interfaces, or Legacy I/Os, such as the 888|24 I/O, 882|20 I/O or 1622 I/O). For more information, see Chapter 2, “Pro Tools System Configurations.”

Configuring Hardware Setup

The Main page of the Hardware Setup dialog is where you define which physical inputs and outputs on your audio interface are routed to available inputs and outputs in Pro Tools.

To configure audio interfaces on a Pro Tools|HD system:
1. Choose Setup > Hardware.
2. From the Peripherals list, select the Digidesign audio interface connected to the first card in your system. This will be the interface at the top of the list.
3. Click the Main tab.
4 From the Clock Source pop-up menu, select the appropriate clock source for the system. In many cases, you will use Internal. The other choices are for resolving Pro Tools to external clock sources. Depending on your audio interface, Clock Source options can include: AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 1–8, TDIF, ADAT, and Word Clock (optional Word Clock rates are available when operating at higher sample rates).

5 From the Ext. Clock Output pop-up menu, select the appropriate clock output to send to devices attached to your audio interface.

6 Select which digital I/O port on your audio interface enclosure is active under Digital Format. Choices include: AES/EBU, S/PDIF, and Optical (S/PDIF). Selecting Optical (S/PDIF) resets the Optical I/O port (which is, by default, eight channels of ADAT I/O) to two channels of S/PDIF Optical I/O.

7 For S/PDIF compatibility with Tascam DA-30 DAT recorders select the Tascam option under S/PDIF Format.

8 For the 96 I/O, click the Meters pop-up menu and select whether to meter the input or output signal.

9 From the Input and Output pop-up menus, select the physical ports (such as Analog 1–2 or Optical 1–2), that will be routed to the corresponding Pro Tools input and output channels (such as Ch 1–2 or Ch 3–4), listed on the left side of the Main page.

Inputs and outputs of similar format are differentiated in the input and output channel pop-up menus. For example, the AES/EBU inputs and outputs in the 192 I/O enclosure are listed as AES/EBU [Encl], while the AES/EBU inputs and outputs on the factory-installed Digital I/O card are listed (in pairs) as AES/EBU 1–2, AES/EBU 3–4, AES/EBU 5–6, and AES/EBU 7–8.

For 192 I/Os equipped with the optional Digital I/O Card, the additional AES/EBU I/O ports on the optional card are listed as AES/EBU 9–10, AES/EBU 11–12, AES/EBU 13–14, and AES/EBU 15–16.

10 Click other tabs (such as Analog In and Analog Out) for additional configuration options specific to the audio interface. These include:
   - On the 96 I/O, configuring the operating levels of analog inputs and outputs (+4 dBu or –10 dBV).
   - On the 96i I/O, configuring the operating levels of analog inputs and outputs (+4 dBu or –10 dBV).
   - On the 192 I/O analog input, setting the input connector and Soft Limit
   - On the 192 I/O, configuring the two sets of trims for analog inputs and outputs.
   - On the 192 I/O and 192 Digital I/O, configuring real-time Sample Rate Conversion for digital inputs.
   - On the 192 I/O and 192 I/O Digital, configuring inputs and outputs on any optional A/D card, D/A card, or Digital I/O cards installed in the unit.

For more information on Hardware Setup controls for each Pro Tools|HD audio interface, refer to the Pro Tools|HD Getting Started Guide or the guide for that audio interface.

11 Repeat the above steps for each additional Pro Tools|HD audio interface.

Use the Up and Down Arrow keys to scroll through peripherals in the Peripherals list.
Repeat the above steps for any Legacy I/Os connected to the Pro Tools|HD audio interfaces in your system. Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup (See “Initializing MIX-Series Legacy Peripherals (on a Pro Tools|HD System)” on page 44.)

13 Click OK.

Initializing MIX-Series Legacy Peripherals (on a Pro Tools|HD System)

Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup.

To initialize a Legacy I/O on a Pro Tools|HD system:

1 Start up your Pro Tools system. See “Starting Up or Shutting Down Your System” on page 37.

2 Make sure to lower the volume of your output devices. Very loud digital noise may be emitted before the Legacy I/O is initialized.

3 Turn on your Legacy I/O.

4 From the Peripherals list, choose the primary audio interface (the interface to which your Legacy I/O is connected).

5 In the Main page of the Hardware Setup dialog, select the Legacy I/O option under Port Settings.

6 In the Peripherals list, “No Interface” is listed twice, directly below the primary audio interface. Click the first “No Interface.” An Interface pop-up menu appears in the Hardware Setup dialog, listing supported I/O choices.

7 From the Interface pop-up menu, select the type of Legacy I/O you connected.

8 Set the External Clock Output on the Pro Tools|HD interface to 256x, which is the required clock speed for Legacy I/Os.

The Main page updates with controls that can be configured.

9 Repeat the above steps for each additional Legacy I/O.

For more information on Hardware Setup controls for each Legacy audio interface, refer to the guide that came with the interface.

Configuring I/O Setup

The I/O Setup dialog provides a graphical representation of the signal routing for each connected audio interface, with controls to route physical ports on the audio interface to Pro Tools inputs and outputs. These controls mirror the routing controls found in the Hardware Setup dialog—changes made to physical routing in one dialog are always reflected in the other.

The I/O Setup dialog lets you label and map Pro Tools input, output, insert, and bus signal paths. The I/O Setup dialog also provides important audition, meter, and surround settings. For more information, see Chapter 7, “I/O Setup.”

Routing a Pro Tools Output Pair to Multiple Destinations

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the Hardware Setup dialog. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).
To select multiple output ports for a Pro Tools output channel pair:

1. Choose Setup > Hardware.
2. From the Peripherals list, select an interface.
3. Click the Main tab.
4. Select an output port pair from an Output pop-up menu.
5. Start-click (Windows) or Control-click (Macintosh) the same pop-up menu a second time to choose an additional output port pair.

The output name updates with a plus sign (“+”) before it to indicate that multiple output ports are selected. In the pop-up menu, each physical port pair assigned to that Pro Tools output pair is indicated by a check mark.

6. Repeat the above steps to select additional output destinations. The only limit to output choices is the number of outputs available in your system.

Pro Tools output pairs can also be routed to multiple audio interface outputs in the I/O Setup dialog. For more information, see “Routing Hardware I/O to Pro Tools I/O” on page 73.

Creating a New Session

The first step in beginning a Pro Tools project is creating a new session.

To create a new session:


2. Choose the drive where you want to save the session. The session should be saved on a dedicated audio drive.
3. Select the audio file format for the session.
4. Select the bit depth (16 bit or 24 bit) and the sample rate.
5. Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can select a custom I/O Setting that you have created. See Chapter 7, “I/O Setup” for more information.
6. Name the Session.
7. Click Save.
Selecting Bit Depth and Sample Rate

When selecting a bit depth or sample rate for your session, consider fidelity, any compatibility issues with other systems, and storage space.

Bit depth and sample rate also have an effect on the amount of mixing power available in a session. Fewer mixer channels are available with 24-bit sessions and with sessions at higher sample rates. (For more information, see the Pro Tools|HD Getting Started Guide.)

It is not possible to combine different bit depths within a single Pro Tools session; files of different bit depths must be converted and imported into the session.

Session Files and Folders

When you create a new session, Pro Tools automatically creates a new folder named for your session. Within this folder is the session file, a WaveCache.wfm file, and several subfolders (an Audio Files folder, a Fade Files folder, a Region Group folder, and a Session File Backups folder).

Audio Files Folder

The Audio Files folder contains all audio recorded or converted during the session.

When you record a new audio track, the track is saved as a new audio file to the Audio Files folder. You can also import other audio files into the session, and work with them as well.

For details on allocating audio tracks to different hard drive locations, including shared media volumes, see “Disk Allocation” on page 159.

Fade Files Folder

The Fade Files folder contains any crossfaded audio data generated by the session.

Region Groups Folder

The Region Groups folder is the default directory for any region groups that you export from your Pro Tools session.

WaveCache File

The WaveCache.wfm file stores all of the waveform display data for the session. If you delete the WaveCache.wfm file, Pro Tools will create a new one the next time you open the session.

By storing waveform data in the WaveCache file, sessions are able to open more quickly. The session WaveCache file can be included whenever a session is transferred to another Pro Tools 7.0 system.

Pro Tools also maintains a distinct WaveCache file inside the local Digidesign Databases folder (C:\\Digidesign Databases) which retains waveform data for all files used on the system. Additional WaveCache files are created on each external hard drive attached to your system, and stored in the Digidesign Databases folder on each drive.
Deleting or trashing any of the WaveCache files will not harm the session or your system. Each session will merely need more time to open due to having to recalculate waveform data for associated audio (and store that data in a new WaveCache file).

Session File Backups Folder

The Session File Backups folder contains automatically-generated backups of your Pro Tools sessions. These files are created when working on a session and the Operations preference for Enable Session File Auto Backup is enabled. (See “Enable Session File Auto Backup” on page 61.)

Renamed Audio Files Folder

This folder includes file names that have been renamed when you open a session that contains audio file names with incompatible characters, or, in certain situations, save a copy of a session to a Pro Tools version that does not support long file name characters.

For more information, see “Renamed Audio Files” on page 142.

Opening a Session

When you open a session, Pro Tools looks in the session folder for audio and fade files linked to the session.

For more information on sharing sessions created with different versions of Pro Tools, see “Sharing Sessions Created on Different Pro Tools Software Versions” on page 147.

To open an existing session:

1. Choose File > Open Session.
2. Locate the session you want to open and click Open.

Opening a Session that Contains Unavailable Files

The DigiBase feature will prompt you if files are located but reside on Transfer volumes (such as CD-ROMs), or if any required files cannot be found. See “Locating Audio Files” on page 141 for more details.

Opening a Session from a Transfer Volume

When opening a session from a Transfer volume (such as a CD-ROM), the DigiBase feature will prompt you to save the session on a Performance volume, and copy and convert any referenced media files. See “Locating Audio Files” on page 141 for more details.
Opening a Session that Contains Unavailable Resources

Pro Tools prompts you when opening a session that contains unavailable voices, I/O paths, DSP resources, or plug-ins. This is common when transferring sessions to systems with different Digidesign hardware.

The Unavailable Resources dialog provides an initial report of the missing session components. To save a text (.txt) file containing a more detailed Notes report, along with the resulting action, click Yes. The Notes report will be named with the session name, followed by Notes.txt. You can choose to save this file in your Session folder, or in another location.

The following will occur when opening a session with unavailable items:

With all Pro Tools Systems:
- Inserts assigned to unavailable plug-ins are made inactive.
- Inputs, outputs, and sends that are assigned to unavailable paths are made inactive.

With Pro Tools HD Only:
- Any tracks beyond the maximum number of available voices on the current system are made inactive.

With Pro Tools LE and M-Powered Only:
- Any tracks beyond the maximum number of available voices on the current system are set to voice off.

Opening a Session with Audio File Names that Contain Illegal Characters

Pro Tools 7.0 does not support audio file names that contain certain ASCII characters (such as * and @).

When opening sessions that contain audio files with illegal characters, Pro Tools automatically creates a renamed copy of each file (replacing these characters with an underscore “_”). Renamed files are copied to the Renamed Audio Files folder. The original files are left intact in the Audio Files folder.

Before the session opens, you are prompted to save a detailed report of the renamed files and their original file names to a Notes text file. Follow the on-screen instructions. By default, the Notes text file is saved to the Session folder.

Opening a Session that Was Saved with +6 dB Fader Gain

All Pro Tools 7.0 sessions have a +12 dB fader gain level. However, when saving a Pro Tools 7.0 session to a lower version of Pro Tools that supports +6 dB and +12 dB fader gain, the new session can be saved with either a +6 dB or a +12 dB maximum fader gain.

When saving a +12 dB session as a +6 dB session, Pro Tools alerts you that any automation breakpoints over +6 dB will be lowered to +6 dB. See “Saving a Copy of the Session” on page 50.

In Pro Tools 7.0, when opening a session that was saved with a +6 dB maximum gain level, the session will update to a +12 dB range.
Saving a Session

You should save regularly while working on your session to ensure that your work is preserved on your hard drive.

Saving the Session File

The Save command saves the changes you have made to your session and writes them over the previously saved version of the session file. The Save command cannot be undone.

To save a session:
- Choose File > Save.

Revert to Saved Command

If you have made changes to a session since you last saved it, you can discard the changes and revert to its previously saved state.

To revert to the last saved version of a session:
- Choose File > Revert to Saved.

You can also open up a backup copy of your session, if you have enabled the Operation preference for AutoSave. This feature lets you specify the total number of incremental backups that are kept and how often the session is saved. See “AutoSave” on page 61.

Saving the Session File with a New Name

To save a copy of the current session with a new name or to a different hard drive location, you can use the Save As command. Because the Save As command closes the current session and lets you keep working on the renamed copy, it is useful if you are experimenting and want to save successive versions of the session.

By working this way, you can quickly retrace your steps if you want to go back to an earlier version of your session. The Save As command saves a new version of the session file only—not duplicate versions of the audio or fade files.

To save a session with a new name:

1. Choose File > Save As.
2. Enter a new name for your session.
3. Click Save.

Pro Tools 7.0 lets you name files with as many characters as your operating system supports.

The renamed session file is saved in the session folder along with the original session (unless you specify a different destination). Any new audio files that you record in your renamed session will be placed into the same Audio Files folder that was created for your original session.
**Saving a Copy of the Session**

To save a copy of the current session with or without its audio files and fade files, you can use the Save Copy In command. In addition, you can specify a session file format, audio file format, bit depth, and sample rate for the session copy.

Unlike the Save As command, Save Copy In does not close the original session, so subsequent edits are made to the original session. Session copies can be used to archive important sessions, or as a means to prepare sessions for transfer to another Pro Tools system.

Save Copy In can save only the audio being used in the session. Any audio that was recorded or imported and then later removed from the session will not be included in the new session copy.

Using the Save Copy In command is the only way to change the sample rate of a session.

When you save a copy of the session to a lower bit rate, Dither (and Noise Shaping) are applied. See the following table:

<table>
<thead>
<tr>
<th>Bit Rate</th>
<th>Dither</th>
<th>Noise Shaping</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 16-bit</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

The Dither setting used for any conversion is the Digidesign Dither plug-in with Noise Shaping enabled.

*For more information about using Dither, see “Dither” on page 509.*

**Session Format**

You can save the session copy in the following formats, depending on your platform:

**Windows:**
- Pro Tools Session (.ptf); supports Pro Tools 7.0
- Pro Tools 5.1 - 6.9 Session (.pts);
- Pro Tools 5.0 Session (.pt5)
- Pro Tools 4 24-Bit Session (.p24)
- Pro Tools 4 16-Bit Session (.p16)

**Macintosh:**
- Latest; supports Pro Tools 7.0
- Pro Tools 5.1 - 6.9 Session
- Pro Tools 5.0 Session
- Pro Tools 4 24-Bit Session
- Pro Tools 4 16-Bit Session
- Pro Tools 3.2 Session
When saving sessions to versions lower than 5.1, multichannel tracks (including stereo) and multi-mono plug-ins are lost. In this case, make sure to first separate the tracks and plug-ins to individual mono tracks.

To share sessions between different platforms, Pro Tools systems, or Pro Tools software versions, see Chapter 10, “File and Session Management and Compatibility.”

### Session Parameters

#### Audio File Type

You can save the session to reference BWF (.WAV) or AIFF audio files. On the Macintosh, you can also save the session to reference SD II audio files (at sample rates up to 48 kHz).

**SD II sessions are not supported with Pro Tools on Windows, or with sample rates higher than 48 kHz.**

#### Using Mixed File Types

A session can use mixed audio file types. If your original session has mixed file types, they are not converted to a different file type unless you specify that they be converted. However, when using mixed file types, audio performance will be reduced (due to additional file handling required for some file formats).

#### Bit Depth

You can save the new session at 16-bit or 24-bit depth. If your session is in a different bit depth, audio files are converted to the new session bit depth, and copied to the location you specify.

For more information, see “Dither and Bounce to Disk” on page 572.

### Sample Rate

You can save the new session at sample rates of 44.1 kHz or 48 kHz (on Mbox 2 and Mbox) and at sample rates up to 96 kHz (on Digi 002, Digi 002 Rack and Pro Tools|HD systems with a 96 I/O or 96I I/O) or up to 192 kHz (on Pro Tools|HD systems with a 192 I/O or 192 Digital I/O). If your session is at a different sample rate, audio files are converted to the new session sample rate, and copied to the location you specify.

The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

#### Fader Gain

When saving a Pro Tools 7.0 session to a lower version of Pro Tools that supports +6 dB and +12 dB fader gain, you can save the new session with either a +6 dB or a +12 dB maximum fader gain. When saving a +12 dB session as a +6 dB session, Pro Tools alerts you that any automation breakpoints over +6 dB will be lowered to +6 dB.

#### Enforce Mac/PC Compatibility

When saving a Pro Tools 7.0 session to a lower version of Pro Tools, this setting forces Windows or Macintosh versions of Pro Tools to create sessions and audio files that are usable on both platforms.

For more information, see “Saving Copies of Macintosh Sessions to be Compatible with Windows” on page 145.
Items to Copy

All Audio Files

When this option is selected, all audio files are copied to the new location.

This setting is automatically selected if you are changing the bit depth or sample rate of the session.

All (Non-Native) Audio Files

The name of this option varies depending on the audio file type you select. If you are changing the audio file type of the session, this option ensures that all files in the copied session are converted to the selected file type. Use this option to avoid the reduced performance of a session with mixed file types.

This option is automatically selected if you are changing bit depth or sample rate, or copying a session on the Macintosh from SD II format to AIFF or BWF (.WAV) format with Enforce Mac/PC Compatibility selected.

Don’t Copy Fade Files

When this option is selected, Fade Files are not copied to the new session Fade Files folder.

Pro Tools opens the session with all available media, then shows you how many files are missing (if any) and asks how you want to proceed. You can choose to locate the existing fades, using Manually Find Relink or Automatically Find Relink, or choose to Skip All to let Pro Tools recreate the fades from the session document. You can also select Regenerate Missing Fades to exclude fade files from the relink process and regenerate them instead.

Session Plug-In Settings Folder

When this option is selected, the session’s Plug-In Settings folder is copied to the new location. The references to these plug-in settings in the session are redirected to the copied settings files.

Root Plug-In Settings Folder

When this option is selected, the contents of the root-level Plug-In Settings Folder are copied into a folder named Place in Root Settings Folder, indicating that these files will need to be moved to the root level plug-in settings folder on the destination system before you can use them. The references to these settings files in the session are not redirected to point to the copied files.

Movie/Video Files

When this option is selected, session movie files (such as Avid or QuickTime video files) are copied to the new location, and session references are updated to point to the copied movie files.

To save a session copy in a new location:

1. Choose File > Save Copy In.
2. In the Save Copy In dialog, choose a destination and enter a name for the new session file.
3. Set the Audio File Type to BWF (.WAV) or AIFF, or SD II. If the audio files need to be compatible with either Windows or Macintosh, select or BWF (.WAV) or AIFF.
4. Set the session Sample Rate and Bit Depth.
5. Select “Enforce Mac/PC Compatibility” to create session and audio files that can be used on both Windows and Macintosh Pro Tools systems. See “Saving Copies of Macintosh Sessions to be Compatible with Windows” on page 145.
6. Select the Items to Copy to the new session.
7. Click Save.
Creating Custom Session Templates

You can create custom session documents that are pre-configured to the track setups, mixer setups, window arrangements, and zoom level memory locations that you use most frequently. Doing this will save you the trouble of having to create your studio setup from scratch every time you start a new session.

Creating Windows Templates

In Windows, you can create a session template by making a session file a Read Only document.

To create a custom session template in Windows:

1. Create a session and arrange its elements as you want them to appear in the template. You can also define elements such as signal routings, insert and send configurations, Track Views, ruler settings, and Preference settings.
2. Choose File > Save As.
3. Name the session and click Save.
4. Close the session.
5. Locate the session file that you just saved.
6. Right-click the file and choose Properties.
7. Under Attributes, select Read Only.

Making a session a Read Only file (Windows)

8. Click OK.

To use this template, double-click it or open it with the Open Session command. When you first save the session, Pro Tools will ask you to give the session a new name. Your original session template will remain unchanged.

To modify the session template, you will need to reopen its Properties, deselect the Read Only option, make your modifications, then change it back to a Read Only file.

Creating Macintosh Templates

On the Macintosh, you can create a session template by saving a session file as a Stationery Pad document. Once a session is saved as a Stationery Pad, it acts as a template that you can open and then resave as a normal session.
To create a custom session template on the Macintosh:

1. Create a session and arrange its elements as you want them to appear in the template. In addition to track setup, you can also define elements such as signal routings, insert and send configurations, Mix and Edit window views, ruler settings, and Preference settings.

2. Choose File > Save As.

3. Name the session and click Save.

4. Close the session.

5. Locate the session file that you just saved.

6. Click once on the file to select it.


8. If necessary, click the General expand/collapse triangle to display the General information and options.

9. Select the Stationery Pad option to save the file as a template, then close the information window.

To use this template, double-click it or open it with the Open Session command if you are already running Pro Tools. You can create several custom templates for studio setups that you frequently use.

When you open a session saved as a Stationery Pad, Pro Tools gives you the option of editing the template or starting a new session using the template settings. If you choose New Session, Pro Tools will create a new folder containing a copy of your session template and Audio and Fades folders.

---

Closing a Session

Because Pro Tools allows you to work on just one session at a time, you must close the current session if you want to work on another. The Close Session command closes your current Pro Tools session but leaves the Pro Tools application open. You can save your work using the Save or Save As command before closing the current session.

To close a session:

- Choose File > Close Session.

---

Quitting Pro Tools

Although Pro Tools will warn you before allowing you to quit without saving changes, you should generally save your work before quitting.

To exit Pro Tools in Windows:

- Choose File > Exit.

To quit Pro Tools on the Macintosh:

- Choose Pro Tools > Quit Pro Tools.
System Usage

About Processing Bandwidth

Meters in the System Usage window indicate how much of your system’s processing power is being used in processing audio, and when writing and playing back automation.

Pro Tools HD, LE, and M-Powered have three common meters, showing PCI bus activity, CPU processing activity, and Disk processing activity.

With Pro Tools HD, there are addition meters, showing TDM Time Slot usage and DSP usage of each Pro Tools|HD system card.

As these meters approach their limits, recording or playback of automation data may be affected.

To monitor the usage of resources during a Pro Tools session:

- Choose Window > System Usage.

To reduce processing load, try one of the following:

- Deselect the Faders Move During Playback option in the Automation Preferences page.
- Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 549.
- Turn off Sends View meters, if enabled, in the Display Preferences page. See “Individual Send Views and Meters” on page 491 for more information.

System Usage Views

(Pro Tools HD Only)

With Pro Tools HD, there are five different System Usage Views: Small, Large, Detailed, Gas Gauge, and Activity Only. The Detailed and Gas Gauge formats show the percentage of each DSP chip in use.

To change the System Usage View:

- Choose View > System Usage, and one of the System Usage View formats (such as Small).

For more information, see “Bounce to Disk” on page 574.

For information on using different views to monitor DSP usage, see the Pro Tools|HD Getting Started Guide.
Preferences

The Preferences dialog has several tabbed pages in which you can specify your preferred settings for various session parameters. Each new session will use these preferences.

Display Preferences

Basics Section

Edit Window Follows Bank Selection If you are using a supported control surface with Pro Tools, this option scrolls the Edit window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

Mix Window Follows Bank Selection If you are using a supported control surface with Pro Tools, this option scrolls the Mix window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

“Scroll to Tracks” Banks Controllers When using a control surface (such as D-Control or Pro Control) you can select this option to bank control surface faders to a numbered track when using the Track > Scroll to Track command.

Track Position Numbers Stay with Hidden Tracks When enabled, tracks keep their track numbers even when hidden. When not enabled, numbers are only assigned to tracks that are shown. In this case, active tracks are then numbered sequentially, and hidden tracks are un-numbered.

Show Meters in Sends View When the Sends View is displaying individual send controls, you can select this option to show send level meters. Deselecting this option can help speed up screen redraws and processing.

Draw Grids in Edit Window Adds grid lines to the Edit window. Grid line resolution is based on the zoom level of the Edit window.

Draw Waveforms Rectified Displays audio waveform data in rectified view. In this view, audio waveforms are displayed so that their positive and negative waveform excursions (the portions that fall above and below the center line) are summed together and viewed as a single positive-value signal. This view allows more waveform detail to be seen in either normal or reduced track height views. It can be particularly useful when editing volume automation data, since it depicts waveform levels as starting at the bottom of the track.

Recompute Invalid Overviews Prompts Pro Tools to look for missing or corrupted overview data (the data used to create waveform displays) when it opens sessions. If Pro Tools finds that overview data is missing or corrupted, it will re-create one or more overviews for the session. This may take some time if there are many tracks in the session. If you suspect that overview data for a session has become corrupted, or if you import audio files which have no overview data into a session, make sure this preference is enabled for the session, save and close the session, then reopen it. Pro Tools will recreate any overviews for the session when it opens.
Always Display Marker Colors Lets you choose to view Marker colors in the Markers ruler, regardless of the settings you choose for Default Region Color Coding.

Tool Tips Display

Function Configures Tool Tips to show the basic function of the item.

Details Configures Tool Tips to show the complete name of an abbreviated name or item. Details view can also show the hidden or abbreviated value of parameters, as well as input and output assignments.

Other Section

Edit Window Default Length Lets you set a default length for the Edit window in hours, minutes, seconds, and frames (Pro Tools HD or Pro Tools LE with DV Toolkit only). This is useful if you want to assemble a session of a particular length or leave extra room to expand the Edit window's work area in your session. The maximum length is 13 hours at 48 kHz, and proportionally less at higher sampling rates.

Delay Compensation Mode This option lets you choose whether information in the Delay Manager is displayed in milliseconds or samples. This option is only available when Delay Compensation is enabled (Options > Delay Compensation).

“Organize Plug-In Menus By” Option

This preference customizes how plug-in lists (plug-in menus) are organized in the Insert selector or Plug-In selector.

Flat List Orgaizes plug-ins in a single list, in alphabetical order.

Category Organizes plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. Plug-ins that do not fit into a standard category (such as the DigiRack Signal Generator), or third-party plug-ins that have not had a category designated by their developers, appear in the Other category. Plug-ins can appear in more than one category.

Manufacturer Organizes plug-ins by their manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus. Plug-Ins that do not have a Manufacturer defined will appear in the “Other” manufacturer folder.

Most Digidesign-distributed third party plug-ins will be grouped under Digidesign when view by Manufacturer is enabled.

Category and Manufacturer Organizes plug-ins in two levels of menus. The top menus display plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. The bottom menus display plug-ins by manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus.

Default Track Color Coding

These color coding options determine the default color coding assignment for tracks in the Edit and Mix windows. Choices are:

None Turns off color assignment for tracks.

Tracks and MIDI Channels Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI channel assignment.
Tracks and MIDI Devices Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI device assignment.

Groups Assigns a color to each track according to its Group ID. If groups are suspended using the Suspend Groups command, the tracks color bars are not shown.

Track Type Assigns a color to each track according to its type (audio, MIDI, Instrument, Auxiliary or Master Fader).

Default Region Color Coding
These color coding options determine the default color coding assignment for regions in the track playlist. Choices are:

None Turns off color assignment for regions. Regions are drawn with black waveform or MIDI notes on a light gray background.

Tracks and MIDI Channels Assigns a color to each region in the Edit window according to its voice or MIDI channel assignment.

Tracks and MIDI Devices Assigns a color to each region in the Edit window according to its voice assignment or MIDI device assignment.

Groups Assigns a color to each region according to the Group ID of its track. If groups are suspended using the Suspend Groups command, all regions display black waveforms or MIDI notes on a light gray background.

Track Color Assigns a region color based on the color assigned to the track.

Marker Locations Assigns a color to data across all tracks based on the nearest preceding marker.

Region List Color Assigns a color to each region based on its color in the Region List.

Peak Hold Options
These options determine how long the peak indicators on track meters stay lit after a peak is detected.

3 Second Peak Hold When selected, track meters display the last peak level for three seconds.

Infinite Peak Hold When selected, track meters display the last peak level until you click them to clear them.

No Peak Hold When selected, track meters do not hold the peak level.

Clip Indication Options
These options determine how long the clip indicators on plug-in, send, and track meters stay lit after a clip is detected.

3 Second Clip Hold When selected, meters display the last clip indication for three seconds.

Infinite Clip Hold When selected, meters display the last clip indications until you click them to clear them.

No Clip Hold When selected, meters do not hold the clip indication.
Operation Preferences

Basics Section

Timeline Insertion Follows Playback This option causes the screen’s play cursor to update its location to the point where playback stops.

Edit Insertion Follows Scrub/Shuttle When selected, the edit cursor automatically locates to the point where scrubbing stops.

Sends Default to \(-\infty\) When selected, the initial fader level of newly-created sends is set to \(-\infty\) (no audible signal level). When not selected, the initial fader level of newly-created sends is set to 0 dB.

Audio During Fast Forward/Rewind When selected, audio is audible during fast forward or rewind.

Convert Imported “WAV” Files To AES31/BroadcastWave When selected, this option applies to all newly imported WAV files, making them compliant with the AES31/EBU Broadcast standard.

Automatically Copy Files on Import When selected, Pro Tools copies all imported audio files to the current session’s Audio Files folder, regardless of whether they need to be converted to the current session’s file type, bit depth or sample rate.

Audio Track RecordLock This setting lets Pro Tools tracks be configured to either emulate a digital dubber, or to maintain legacy behavior for track record status.

- When the Audio RecordLock preference is enabled, the record-enabled audio tracks remain armed when playback or recording stops.
- When the Audio RecordLock preference is not enabled, record-enabled audio tracks are taken out of record enable when Pro Tools is stopped. This prevents tracks from remaining armed from pass to pass, emulating track record behavior of a digital dubber.

Transport RecordLock This setting lets the Transport Record (the Record Enable button in the Transport controls) be configured to either emulate a digital dubber, or to maintain legacy behavior for the Transport master Record.

- When not enabled, the Transport Record disarms when Pro Tools is manually stopped or stops due to a loss of time code. This replicates standard Pro Tools recording behavior.
- When enabled, the Transport Record remains armed when playback or recording stops. This saves having to re-arm the Transport between takes, emulating digital dubber behavior.

\(\text{The Transport RecordLock preference is automatically disabled and greyed out when Destructive record mode is enabled.}\)
**Latch Record Enable Buttons** When this option is deselected, it prevents multiple audio tracks from being record-enabled. Record-enabling an audio track takes any other audio track out of record-enabled mode.

**Link Mix and Edit Group Enables** When selected, it links enabling and disabling of Mix and Edit groups. For example, enabling Group A in the Mix Window automatically enables Group A in the Edit window.

**Use F11 Key for Wait for Note** When selected, pressing the F11 Function key puts MIDI recording in Wait for Note mode.

**Disable "Input" When Disarming Track (In “Stop”)** For flexibility, TrackInput monitoring can be customized to remain selected regardless of track record status, or to automatically switch to Auto Input monitoring after a recording pass. This lets you optimize monitoring for a typical dubbing workflow (in which you might want tracks to remain in Input Only mode until explicitly switched to Auto Input monitoring) or a typical music tracking workflow (in which leaving a track in Input Only monitoring mode after recording can result in accidental double-monitoring).

- When enabled, taking an audio track out of record enable (any mode) takes it out of Input Only mode, regardless of the global monitor mode, and switches it to monitor audio from disk only.
- When not enabled, audio tracks remain in Input Only monitoring mode until explicitly switched to Auto Input monitoring.

**Mute Record-Armed Tracks While Stopped** This setting determines monitor status of record-armed tracks.

- When enabled, Pro Tools mutes tracks that are record-enabled when the Transport is stopped. Input can still be monitored while stopped using the TrackInput Monitor button.
- When not enabled, Pro Tools monitors audio input on tracks that are record-enabled.

**Avid Video Errors Stop Playback** If selected, Pro Tools automatically stop playback of audio and video if a single frame of video is dropped.

If unselected, Pro Tools continues playback of audio even if frames are dropped. In most cases, video playback will recover within a few frames and continue playing audio and video in sync.

**Numeric Keypad Mode**

Numeric Keypad mode determines how the numeric keypad functions. You can always use the numeric keypad to select and enter values in the Event Edit Area, Edit Selection indicators, Main and Sub Counters, and Transport fields.

**Classic** Selects a Shuttle Lock mode that emulates the way Pro Tools worked in versions lower than 5.0. With the Numeric Keypad mode set to Classic, you can play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Macintosh), followed by 0–9 for different play speeds. Press Plus (+) or Minus (−) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by Period (.). To customize the highest fast-forward Shuttle Lock speed, see “Custom Shuttle Lock Speed” on page 262.
**Transport** Selects a Shuttle Lock mode that lets you set a number of record and play functions, and also operate the Transport from the numeric keypad. With the Numeric Keypad mode set to Transport, you can play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Macintosh), followed by 0–9 for different play speeds. Press Plus (+) or Minus (−) to reverse direction. Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again. To customize the highest fast-forward Shuttle Lock speed, see “Custom Shuttle Lock Speed” on page 262.

**Shuttle (Pro Tools HD Only)** Selects a type of shuttling different from that of Shuttle Lock mode. With the Numeric Keypad mode set to Shuttle, playback is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. You can also recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

**AutoSave**

This preference determines how the AutoSave feature functions.

**Enable Session File Auto Backup** When selected, Pro Tools automatically saves backups of your Pro Tools session file while you work. Backups are saved to in the Session Files Backup folder in your session folder. Use the Keep and Backup Every fields to specify the total number of incremental backups that are kept and how often the session is saved.

**Online Options**

**Record Online at Time Code (or ADAT) Lock** When selected, online recording begins as soon as Pro Tools receives and locks to time code or ADAT sync.

**Record Online at Insertion/Selection** When selected, online recording begins at the edit cursor location. Recording continues until Pro Tools stops receiving time code. If you make a selection, Pro Tools records online for the length of the selection.

**Open Ended Record Allocation**

This preference determines how much of your available hard drive space is allocated for recording.

**Use All Available Space** When selected, the drive’s entire available space is allocated. This can sometimes slow down the recording process for hard drives that use certain file systems, including HFS+ and NTFS.

**Limit To** Sets the maximum allowable recording duration. This can help reduce the time it takes to begin recording by allocating only a portion of your hard drive. The number of minutes specified is allocated for each record-enabled track. You may want to experiment with this number to achieve the recording performance you want.

**QuickTime Playback Priority Options**

**Normal** This is the default setting for QuickTime Movie Playback Priority. It gives no extra priority to movie playback over other screen update tasks such as metering, moving faders, and so on. In most cases you should use this setting. If, however, you are running QuickTime movies without a video capture card, you may need to use the Higher or Highest Playback Priority setting.

**Higher** This command gives QuickTime movie playback a higher priority relative to other Pro Tools screen update tasks. This yields better movie playback performance if you are running QuickTime movies without a video capture card.
**Highest** This command gives QuickTime movie playback highest priority. In this mode, Pro Tools disables screen activity such as metering during movie playback. This yields the highest movie playback performance if you are running QuickTime movies without a video capture card.

**Additional Options**

**Custom Shuttle Lock Speed** Sets the highest fast-forward Shuttle Lock speed (key 9) for Shuttle Lock modes (Classic or Transport). The range for this setting is 50–800%. For more information, see “Custom Shuttle Lock Speed” on page 262.

**Calibration Reference Level (Pro Tools HD Only)**
Sets a default calibration reference level in dB when Pro Tools is in Calibration mode. For audio interfaces that have trims (such as the 192 I/O), see the interface’s guide for calibration instructions.

**Auto Regions Fade In/Out Length** Sets a default length for fade-ins and fade-outs automatically applied to region boundaries. Using automatic fade-ins and fade-outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. Autofades are not written to disk. Value range is from 0–10 ms for the Auto Region Fade In/Out Length. A value of zero means that no auto-fading will occur. The Auto Fade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

**Back/Forward Amount** Sets the default length of Back, Back and Play, Forward and Forward and Play. The timebase of the Back/Forward Amount settings follows the Main Time Scale by default, or you can deselect Follow Main Time Scale and select another timebase format: Bars:Beats, Min:Sec, Time Code, Feet+Frames. or Samples

**Solo Latch Options**

This preference determines if solos are latched, unlatched, or added temporarily (Pro Tools HD only).

**Latch** When selected, pressing subsequent Solo buttons adds them to the soloed mix of tracks.

**Momentary (Pro Tools HD with Digidesign-Qualified Control Surface Only)** When selected, the Solo button is not sticky. When the Solo button is held down, the track is soloed. Additional tracks can be soloed by touching their Solo buttons (as long as at least one Solo button is held down). When no Solo button is held down, all soloed tracks will unsolo.

**X–OR (Cancels Previous Solos)** When selected, pressing subsequent Solo buttons cancels previous solos.
Editing Preferences

Recall Memory Location at Original Track When selected, Memory Locations that recall a selection also recall the track in which the selection was made.

Auto-Name Memory Locations When Playing When selected, Pro Tools gives new memory locations default names based on their time location in the session. The time units currently chosen in the View menu determine the units for the names.

Auto-Name Separated Regions When selected, Pro Tools automatically names newly separated regions by appending a number to the region’s name. Disabling this option can be useful when importing region groups, REX files, or ACID files, because these file types can contain so many separate regions that it becomes difficult to read the Region List.

Region List Selection Follows Edit Selection When selected, selecting a region in a track also selects it in the Region List.

Edit Selection Follows Region List Selection When selected, selecting a region in the Region List causes Pro Tools to highlight that region’s occurrence in a track.

Crossfade Preview Pre-Roll This option specifies the amount of pre-roll to be added when you are auditioning crossfades in the Fades dialog.

Crossfade Preview Post-Roll This option specifies the amount of post-roll to be added when you are auditioning crossfades in the Fades dialog.

Default Fade Settings

Fade In Selects the default envelope shape for fade-ins.

Crossfade Selects the default envelope shape for crossfades.

Fade Out Selects the default envelope shape for fade-outs.

Conversion Quality Selects the sample rate conversion quality. Sample rate conversion is used in a variety of Pro Tools processes including converting and importing audio files of different formats into a session, and bouncing and saving tracks to a different sample rate or bit depth. The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

“Matching Start Time” Takes List

When you Control-click (Windows) or Command-click (Macintosh) a region in a track, Pro Tools displays a list of regions whose time stamp matches the current Cursor location. The following preferences determine which regions, or takes, appear in this list:

Take Region Names That Match Track Names When selected, only regions that share the same root name with the track and playlist appear in the Takes List pop-up menu.
Take Region Lengths That Match When selected, only regions that match the length of the current selection appear in the Takes List pop-up menu.

“Separate Region” Operates On All Related Takes When selected, editing a region with the Separate Region command also affects all other related takes (recording passes) with the same User Time Stamp. This option helps you compare different sections from a group of related takes.

QuickPunch/TrackPunch Crossfade Length Specifies a default length for crossfades created by QuickPunch or TrackPunch recordings. Crossfades occur before the punch in and after the punch out.

Levels Of Undo Sets the maximum number of actions that can be undone with the multiple undo feature. Setting this to a lower number can speed up the performance of slower computers. Pro Tools supports up to 32 Levels of Undo.

Automation Preferences

Faders Move During Playback When selected, on-screen faders move if automation has been written for them. When deselected, on-screen faders do not move, but automation still functions. Deselecting this option can help speed up screen redraws and processing.

Smooth and Thin Data After Pass When selected, Pro Tools automatically smooths and then applies the specified amount of thinning to the automation data created in an automation pass. (See “Thinning Automation” on page 549.)

Mutes Follow Groups When selected, muting a track that belongs to a Mix group mutes all members of the group. When deselected, tracks are muted individually. You can also mute individual group members by Right-clicking (Windows) or Control-clicking (Macintosh) their Mute buttons.
**Solos Follow Groups** When selected, soloing a track that belongs to a Mix group solos all members of the group. When deselected, tracks are soloed individually. You can also solo individual group members by Right-clicking (Windows) or Control-clicking (Macintosh) their Solo buttons.

**Send Mutes Follow Groups** When selected, muting a Send on a track that belongs to a Mix group mutes the corresponding Send (A–J) on all members of the group. When deselected, Sends are muted individually. You can also mute individual group members by Right-clicking (Windows) or Control-clicking (Macintosh) their Solo buttons.

**Send Levels Follow Groups** When selected, adjusting the level of a Send on a track that belongs to a Mix group adjusts the level of the corresponding Send (A–J) on all members of the group. When deselected, Send levels are adjusted individually. You can also adjust individual group members by Start-dragging (Windows) or Control-dragging (Macintosh) their Send Level faders.

**LFEs Follow Groups** When selected, adjusting an LFE (Low Frequency Effects) control of a track or send that belongs to a Mix group adjusts the LFE controls of all members of the group. When deselected, LFE controls must be adjusted individually. You can also adjust individual group members by Start-dragging (Windows) or Control-dragging (Macintosh) their LFE controls. With send-based LFEs, grouping affects only that Send (A–J) on other tracks.

**After Write Pass, Switch To (Pro Tools HD Only)**
Selects the Automation mode that Pro Tools tracks automatically switch to after an automation pass in Write mode. You can choose to switch to Touch or Latch mode, or stay in Write mode by selecting No Change.

⚠️ *This setting affects Write/Trim mode. After an automation pass in Write/Trim mode, tracks automatically switch to the Trim version of the specified setting (Latch/Trim, Touch/Trim, or Write/Trim).*

**Degree of Thinning** Specifies the amount of thinning performed on automation data when you use the Thin Automation command, or if you have selected the Smooth and Thin Data After Pass option. (See “Thinning” on page 541.)

**Touch Timeout** If you are writing automation in Touch mode and you stop moving a non-touch sensitive control, Pro Tools continues to write automation for the Touch Timeout value.

After the Touch Timeout period, writing of automation stops and the automation data returns to its previous automation value at the rate specified in the *AutoMatch Time* setting.

**AutoMatch Time** If you are writing automation in Touch mode, when you release a fader or control, writing of automation stops and the automation data returns to its previous value. The rate of return to the previous value is the AutoMatch Time. See “AutoMatch Time” on page 541.

**AutoGlide Time** Specifies how quickly Pro Tools transitions (glides) from one automation value to another, when Automation Glide is used.

**Amount of memory to reserve for automation recording** Allocates memory for automation. See “Setting the Automation Buffer Size” on page 541 for details.
Processing Preferences

AudioSuite Dither

Use AudioSuite Dither When selected, applies a selectable dither plug-in to specific AudioSuite processing tasks (such as Gain and Normalize).

Dither Plug-In Specifies the plug-in used for dither processing when the Use AudioSuite Dither option is selected.

Edit Settings When a Digidesign dither plug-in is used, lets you apply either normal or noise-shaping dither.

Bit Depth

16-, 18-, 20-, and 24-Bit Lets you select a bit depth for the dithered audio.

AudioSuite Buffer Size

Audio Suite Buffer Size sets the size of the memory buffer used for audio processing and previewing with AudioSuite plug-ins. If AudioSuite preview stutters, set the buffer to Mini or Small. Processing is generally faster when the buffer is set to Larger or Jumbo.

TC/E

TC/E Plug-In Lets you choose the plug-in used for Time Compression and Expansion when you edit audio with the Time Compression/Expansion Trim tool. This Trim tool works by using Time Compression/Expansion to match an audio region to the length of another region, a tempo grid, a video scene, or other reference point.

Default Settings Specifies the default settings used by the chosen Time Compression/Expansion plug-in.
**MIDI Preferences**

![Image of MIDI Preferences dialog]

**Default Note On Velocity** Sets the default Note On velocity for MIDI notes inserted in the Edit window and the MIDI Event List.

**Pencil Tool Resolution When Drawing Controller Data** Sets the default resolution for MIDI controller data created with the Pencil tool. Setting this to a lower resolution helps avoid creating controller data that is unnecessarily dense. The value range is from 1 to 100 milliseconds.

**Global MIDI Playback Offset** Sets an offset in samples to compensate for MIDI latency. Entering a value here has the same effect as setting an offset with the MIDI Track Offsets command (Event > MIDI Track Offsets). Offset values can be positive (later) or negative (earlier).

**Default Thru Instrument** Sets the default MIDI Thru instrument. You can select a predefined device from your available MIDI instruments, or select "Follows First Selected MIDI Track" to use the assigned MIDI output of the first selected MIDI or Instrument track. When multiple MIDI or Instrument tracks are selected, the instrument in the selected track that is closest to the top of the Edit window (or closest to the left edge of the Mix window) will be used.

**General Section**

**Play MIDI Notes When Editing** When selected, causes MIDI notes to sound when you insert them with the Pencil tool or drag them with any of the Grabber tools.

**Use MIDI to Tap Tempo** When selected, you can tap a MIDI keyboard to enter a new tempo value into a tempo field.

**Display Events as Modified by Real-Time Properties** When selected, Pro Tools displays the effects of Real-Time Properties in both the Edit window and the MIDI Event List.

**MIDI Note Display Options**

These options set the reference for middle C as C3, C4, or MIDI note number 60.

**Delay for External Devices Options (Pro Tools HD Only)**

These options let you apply Delay Compensation to Pro Tools-generated MIDI Time Code or MIDI Beat Clock. Generally, this delay should be applied when the external MIDI instrument is mixed externally, and should not be applied when the external MIDI instrument is mixed through the Pro Tools mixer.

These options are only available when a Delay Compensation Engine is chosen in the Playback Engine dialog and Delay Compensation is enabled in Pro Tools.
Machine Control Preferences

These preferences determine how a connected transport responds to Pro Tools.

**Machine Control**

**Machine Chases Memory Location** When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track will cause a connected transport to chase to that location.

**Machine Cues Intelligently** When selected, if you navigate to a cue point that is more than 10 seconds from the current location, Pro Tools will command a connected transport to fast wind to the new location at full speed to within 10 seconds of the cue point. Cueing will then slow to normal speed until the point is reached. This can significantly speed up tape cueing with certain video transports.

**Stop at Shuttle Speed Zero** Causes Pro Tools to send a Stop command whenever you stop shuttling. This is useful if you have a machine that requires an explicit stop command to park correctly.

**Remote Mode (9-Pin Deck Emulation)** *(Pro Tools HD Only)*

**Punch In Frame Offset** Sets an offset (in frames) to compensate for punch in timing advances or delays.

**Punch Out Frame Offset** Sets an offset (in frames) to compensate for punch out timing advances or delays.

**Delay After Play Command** Sets an offset (in frames) to compensate for lockup time of external machines.

**Ignore Track Arming** Sets Pro Tools to ignore incoming track arming (record enable) commands. This is useful if you are using a master controller to arm tracks on other machines, but you do not want to arm tracks in Pro Tools.

**Set Servo Lock Bit at Play (Tamura Support)** Enable this option when using a Tamura synchronizer to control Pro Tools in Remote mode to minimize lock-up times during recording.
Chapter 7: I/O Setup

The I/O Setup dialog provides tools to label, format, and map Pro Tools input, output, insert, or bus signal paths for each session.

A signal path is a logical grouping of multiple inputs, outputs or busses that has a single name and (channel) format. In Pro Tools, paths are similar to stems, known to the film and video industries (see “Stems and Stem Mixes” on page 71). The I/O Setup dialog lets you define and name paths according to the needs of each project.

With Pro Tools HD, the I/O Setup dialog provides a graphical representation of the signal routing for each connected audio interface, with controls to route physical ports to Pro Tools inputs and outputs. These controls mirror the routing controls found in the Hardware Setup dialog—changes made to physical routing in one dialog are always reflected in the other.

Each Pro Tools system can have a different I/O Setup configuration, determined by:

- Whether it is a Pro Tools LE, Pro Tools M-Powered, or Pro Tools|HD system
- On Pro Tools|HD systems, the number and types of audio interfaces
- On Pro Tools|HD systems, the Mixer plug-in currently installed (Stereo, or Surround)

Each Pro Tools session retains its path configurations as I/O Settings. The I/O Settings saved with the session are loaded automatically when the session is opened. Unavailable items (including hardware, paths, or required resources) remain in the session as inactive items (see “Active and Inactive Paths” on page 79).

When you create a new session, you can specify a default I/O Setup configuration, including presets for stereo or multichannel mixing formats. Multichannel mixing requires a Pro Tools|HD system.

The I/O Setup dialog also lets you save and import I/O Settings files.

Navigating in the I/O Setup Dialog

To resize the I/O Setup dialog:
- Drag the lower-right corner of the window according to standard convention for your operating system (Windows or Macintosh).

To scroll up or down in the I/O Setup dialog:
- Press Page Up or Page Down.

To scroll left or right in the I/O Setup dialog:
- Press Alt+Page Up/Down (Windows) or Option+Page Up/Down (Macintosh).
**Paths in Sessions**

In sessions, audio is routed using the track Input, Output, Insert, Plug-in, and Send selectors. These selectors let you assign tracks to hardware inputs and outputs, internal busses, and other Pro Tools signal paths.

Paths comprise the lists of available signal routing choices in track Input, Output, Insert, and Send selectors.

**Paths and I/O Setup**

The signal routing choices available in a session are defined in the I/O Setup dialog.

**Main Paths and Sub-Paths**

Paths in the I/O Setup dialog include main paths and sub-paths.

**Main Paths**

Main paths are logical groupings of inputs, inserts, busses, or outputs. For example, a master stereo output path could be named Main Out. Path names in a stereo path are often appended with “.L” and “.R” for left and right.
Sub-Paths

A *sub-path* represents a signal path within a main path. For example, a default stereo output path consists of two mono sub-paths, left and right. Mono tracks and sends can be routed to either mono sub-path of the stereo output path.

> It is especially useful to define and name sub-paths for complex mixing setups, such as a 5.1 Surround mix.

Default I/O Settings

A default I/O Settings file is installed automatically by Pro Tools, so you have a set of default paths that will get you started, without the need to configure the I/O Setup dialog. You can then customize your I/O Setup configuration at any time, according to the needs of each project (see “The I/O Setup Dialog” on page 72).

Default Settings Files

The default Stereo settings file is available on all Pro Tools systems, and provides stereo main paths, each with its own mono sub-paths.

Multichannel settings files are available on Pro Tools|HD systems. These settings provide specialized path definitions for surround mixing. See “Configuring Pro Tools for Multichannel Sessions” on page 600.

Default Path Names

Default names for input, output, and insert paths are based on the type of system (Pro Tools LE systems) or type and number of interfaces (Pro Tools|HD systems) you are using.

Stems and Stem Mixes

The use of stems and stem mixes originated in the post production industry as a method to organize and manage elements of a mix by type or content.

For example, a film mix often requires a stem mix for Foley, a stem mix for sound effects, a stem mix for dialog, and another for music. In this scenario, the dialog stem would contain all the dialog elements mixed relative to each other. The dialog stem can then be mixed with the other stems during the final mix of the scene or reel. The final mix is simplified by the ability to control the level of each stem, rather than the multitude of individual tracks that comprise a typical film mix.

In Pro Tools, you can work with main and sub-paths as you would stem mixes. These can be assigned as needed, including the ability to assign multiple outputs to individual tracks and sends. For more information, see “Multiple Output Assignments” on page 487.
The I/O Setup Dialog

The I/O Setup dialog defines Pro Tools input, output, insert, and bus paths. Routing I/O ports to Pro Tools inputs and outputs can also be done here.

To open the I/O Setup dialog:

1. Make sure your audio interfaces are enabled and configured properly in the Hardware Setup. See “Configuring Pro Tools Hardware Settings” on page 42.

2. Choose Setup > I/O.

To open the Input, Output, Insert, Bus, Mic Preamps, or H/W Insert Delay page in the I/O Setup dialog:

- Click the corresponding tab at the top of the I/O Setup dialog.

Closing the I/O Setup Dialog

You can click Cancel at any time to close the I/O Setup dialog. When you click OK, Pro Tools checks several settings for routing validity (to prevent feedback loops). If there are any overlapping or invalid settings, you will be required to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 79.
I/O Setup Dialog Controls

This section provides an overview of the controls in the I/O Setup dialog.

Path Type Tabs Select the type of I/O control to configure. Choices are Input, Output, Insert, Bus, Mic Preamps, or H/W Insert Delay.

Input and Output Selectors Select the physical ports on your audio interface to route to Pro Tools inputs and outputs. Ports are selectable in channel pairs. Available ports for each displayed interface are based on Hardware Setup settings; for example, if the AES/EBU inputs and outputs of an interface are enabled in Hardware Setup, they are available for routing in I/O Setup. The functionality provided with the Input and Output selector is the same as that provided on the Main page of the Hardware Setup dialog.

Path Name Column Shows paths that are available for selection, including the name of each defined path.

Expand/Collapse Shows or hides the sub-paths associated with a main path.

Active/Inactive Status Shows and changes the active/inactive status of each path.

Path Format Selector Shows and selects the type/format (such as Mono, Stereo, Quad, or 5.1) of each defined path.

Channel Grid Maps paths to specific interfaces and channels.

Compensation for Input and Output Delays Allows automatic compensation for input and output delays caused by Digidesign analog-to-digital and digital-to-analog hardware.

Path Tools Customize the I/O Setup configuration. Buttons include: New Path, New Sub-Path, Delete Path, and Default.

Show Original Setup Appears in the I/O Setup dialog in certain session transfer situations. For details on this feature, see “Show Original Setup and Show Current Setup” on page 81.

Options Provide selectors with pop-up menus to set paths or orders for Controller Meter Path, Audition Paths (Region List previewing), New Track Default Output, and Default Path Order. See “I/O Setup Options” on page 83.

Routing Hardware I/O to Pro Tools I/O

The I/O Setup dialog lets you define which physical ports on your I/O peripheral are routed to available inputs and outputs in Pro Tools. Use the Input and Output selectors in the I/O Setup dialog to serve as a patchbay to route any of the physical inputs or outputs to your Pro Tools mixer.
To configure I/O routing in I/O Setup:

1. Choose Setup > I/O.

2. Click the Input or Output tab to display the corresponding path type.

3. Click the Input or Output selector for the first interface channel pair, located below the first audio interface icon.

4. From the pop-up menu, select a physical port pair (such as Analog 1–2), to route to a Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.

5. Repeat the above step for additional channel pairs.

6. Click OK.

Routing a Pro Tools Output Pair to Multiple Destinations

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the I/O Setup dialog. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).

The only limit to output choices is the number of outputs available in your system.

Pro Tools outputs pairs can also be routed to multiple audio interface outputs in the Hardware Setup dialog. For more information, see “Routing a Pro Tools Output Pair to Multiple Destinations” on page 44.

To route a Pro Tools output channel pair to multiple audio interface output ports:

1. Choose Setup > I/O.

2. Click the Output tab.

3. Click the Output selector for an interface channel pair, just below an audio interface icon.

4. From the pop-up menu, select a physical port pair (such as Analog 1–2) to route to the corresponding Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.

5. Start-click (Windows) or Control-click (Macintosh) the same Output selector and select an additional output pair from the same pop-up menu.

The output name updates with a plus sign (“+”) before it to indicate that multiple output ports are selected. In the pop-up menu, each physical port pair assigned to that Pro Tools output pair is indicated by a check mark.

6. Repeat the above steps to select additional output destinations.

7. Click OK.

Creating and Editing Paths

The I/O Setup dialog lets you create and customize signal path definitions.

Paths can be:

- Renamed, for easier identification after changing or renaming audio interfaces
• Remapped, to or from different sources or destinations
• Deactivated (or reactivated) to manage unavailable or unnecessary I/O resources
• Deleted

In addition, you can import and export your I/O Setup configurations as I/O Settings files, as well as set default path parameters.

The following table lists the available path attributes for each path type.

Path Options by Type

<table>
<thead>
<tr>
<th>Path Type</th>
<th>Path Options (Attributes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Names, formats, and source channel (analog or digital audio interface, or CPU input)</td>
</tr>
<tr>
<td>Output</td>
<td>Names, formats, and destination (audio interface output channel or internal send bus)</td>
</tr>
<tr>
<td>Insert</td>
<td>Names, formats and destination (audio interface channels)</td>
</tr>
<tr>
<td>Bus</td>
<td>Names and formats</td>
</tr>
</tbody>
</table>

Creating a Default Main or Sub-Path

You can set an I/O Setup path type to its default path configuration at any time.

To restore default paths and pathnames:
1. Choose Setup > I/O.
2. Click the Input, Output, Insert, or Bus tab to display the corresponding path type.
3. Click Default.

Creating New Paths

You can create new main path and sub-paths with custom names, format, and mapping. Custom path names appear in a session’s track Input, Output, Insert, and Bus selectors.

To create a new path:
1. Choose Setup > I/O.
2. Click the Input, Output, Insert, or Bus tab to display the corresponding path type.
3. Click New Path, or press Control+N (Windows) or Command+N (Macintosh).
   – or –
4. Double-click in the Name field and enter a name for the path.

Pro Tools creates all possible stereo main paths. Mono sub-paths are also auto-created for every stereo main path. These default path names appear in a session’s track Audio Input and Output Path selectors.
5 Press Tab to set the new path name and move to the next path’s Name Field, or press Enter (Windows) or Return (Macintosh) to set the new path name.

6 Choose a format from the Path Format selector (mono, stereo, or multichannel).

7 Repeat the previous steps to configure other path types (Input, Output, Insert, or Bus).

8 Click OK to close the I/O Setup dialog. If there are any overlapping or identically named paths, you will be instructed to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 79.

**Selecting and Arranging Paths**

Individual and multiple paths can be selected in the I/O Setup dialog Path Name column. Selected paths and sub-paths can be moved higher or lower in the Path Name column to change their menu order in track Input, Output, Insert, and Bus selectors. Paths can also be deleted. Sub-paths follow their main paths when they are moved in the I/O Setup dialog.

To select a main path or sub-path:

- Click the path name.

**Selecting paths in the I/O Setup dialog**

To select a range of paths:

1. Click the path name.
2. Shift-click an additional path name.

All paths that occur between the first path name selected and the additional path name will also be selected.

To select or deselect non-contiguous paths, do the following:

- Control-click (Windows) or Command-click (Macintosh) path names that are unhighlighted to select them.

  — or —

- Control-click (Windows) or Command-click (Macintosh) path names that are highlighted to deselect them.

To select all paths and sub-paths:

- Alt-click (Windows) or Option-click (Macintosh) any path name that is unhighlighted.

To deselect all paths and sub-paths:

- Alt-click (Windows) or Option-click (Macintosh) any path name that is highlighted.

To rearrange paths:

- Drag one or more path names up or down.
Resetting Paths

The Default button in the I/O Setup dialog provides two primary functions:

- Creates new default paths up to the capacity of your system’s available audio interfaces and resources. See “Creating a Default Main or Sub-Path” on page 75.
- Resets selected path names to matching or corresponding paths in the current I/O Setup configuration. For example, if you replace an audio interface on a Pro Tools|HD system, you can use the Default switch to update your I/O Setup definitions with the new hardware configuration.

To reset path names:

1. Click Default.

If there are matching paths available with the new system configuration, existing paths will be updated to include new audio interfaces (Pro Tools|HD systems).

Resetting Mix Busses
(Pro Tools HD Only)

Pro Tools supports up to 128 mix busses (Pro Tools HD 7.0 and Pro Tools TDM 6.9), 64 mix busses (Pro Tools TDM 6.7.x and lower), or 32 busses (Pro Tools 7.0 and 5.0.1 and lower). When you open a session created with a lower version of Pro Tools, only the number of busses supported on the lower system are initially available. You can reset the number of available busses to match your system’s capabilities.

To make all of your busses available in sessions created with a lower version of Pro Tools:

1. Open the I/O Setup dialog.

2. Click the Bus tab in the upper left.

3. Click Default.

Setting busses to the default setting will rename all busses to their default name.

Changing Interface Names

Audio interface names can be customized in the I/O Setup dialog. With Pro Tools HD only, the I/O Setup dialog then bases default Input and Output path names on the custom names.

To rename an audio interface in the I/O Setup dialog:

1. Double-click the label above an interface.

2. Enter a new interface name.

3. Press Enter (Windows) or Return (Macintosh).

Deleting Paths

Path definitions can be deleted from the current session to reflect changes to your hardware setup, or to clean up track selector menus by removing unwanted or unnecessary path definitions. After deleting a path, any tracks or send assignments to that path are reset to No Output.

To delete a main path or sub-path:

1. In the I/O Setup dialog, select the path you want to delete.

2. Click Delete Path.
To delete all paths:

1. Alt-click (Windows) or Option-click (Macintosh) any path name.
2. Click Delete Path.

**Channel Mapping**

Once a path has been created and formatted, it can be mapped to specific audio interface, or bus channels in the Grid.

**To map channels:**

1. Select a main or sub-path.
2. In the row for the selected path, click in the Grid column under an audio interface and channel. Other channels for the path type, if any, fill to the right.

For example, when mapping a new stereo path, clicking in the path row under output channel 1 fills both channel 1 and 2 (left to 1, right to 2).

**Remapping Channels**

You can move the individual assignments to different channels, to reorder the path’s definition (for example, changing a multichannel map to L-R-C-LF-LS-RS).

**To remap channels in a path:**

- Drag the channel to the new location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

**Channel Shuffling**

Moving a signal from right to left results in a shuffle of other signals after the new destination channel. Moving a signal from left to right shuffles any and all signals after the new destination channel and leaves the previous channel empty.

**Sub-Paths Follow Main Paths**

When a main path is remapped, its sub-paths (if any) will remap automatically to maintain consistent routing. For example, remapping a stereo path to different hardware outputs results in any of its sub-paths moving with it.
Initializing I/O Setup

To set the current I/O Setup configuration:

- Click OK in the I/O Setup dialog.

All paths must be valid before the I/O Setup configuration can be applied.

Valid Paths and Requirements

While configuring the I/O Setup dialog, certain rules apply for path definition and channel mapping.

Though it is possible to set up invalid mappings in the Channel Grid, Pro Tools will not accept an I/O Setup configuration unless all paths meet the path definition and channel mapping requirements, as follows:

Minimum Path Definitions All paths must have a name, be of a specific format, and have a valid I/O mapping.

Overlapping Channels and Valid Paths Channel mapping follows certain rules regarding overlapping paths.

- There can be no partial or complete overlaps between any two main Output paths, any two Insert paths, or any two main Bus paths.
- A newly-created Output or Bus path must either be completely independent of other maps (not mapped to any other available I/O interface/channels), or it must be a sub-path completely contained within a larger path (for example, an LCR sub-path within a larger 5.1 path).
- Output and Insert paths can overlap in I/O Setup, but only one or the other can be used at any given time in a session. (Inputs, however, can be routed to multiple tracks.)

Active and Inactive Paths

Pro Tools paths can be Active (on) or Inactive (off, or unavailable). You can manually switch paths between Active or Inactive on a track-by-track or session-wide basis. In addition, Pro Tools sets paths to Inactive automatically when I/O is unavailable.

Track Path Assignments Track input, output, and bus path assignments can be switched to Inactive using the corresponding selector on the track. This leaves track playlists intact, while disconnecting that particular track from the output or bus path. Use this to remove a track from a signal path.

Session-Wide Path Assignments Paths can be globally activated or deactivated in the I/O Setup dialog. Use this to turn off a signal path on any and all tracks currently assigned to it. Pro Tools also sets unavailable paths to inactive. Paths can be unavailable when hardware or other system resources are unavailable, such as when opening a session saved on a different system.

Track Path Assignments
(Mix and Edit Windows)

To toggle a track path assignment to be Active or Inactive:

- In the Mix or Edit window, Control-Start-click (Windows) or Command-Control-click (Macintosh) the track’s Input, Output, Insert, or Send selector.

Inactive track path assignments are listed in italics and are unhighlighted.
Toggling All or All Selected

The Alt (Windows) and Option (Macintosh) modifiers apply the path toggle to all tracks. The Alt+Shift (Windows) and Option+Shift (Macintosh) modifiers apply the path toggle to all selected tracks. However, Pro Tools will only apply the change to identical path assignments, if any, in the current track or tracks. Toggling multiple tracks only affects tracks that have the same path assignment as the one you are explicitly toggling.

Toggling Multiple Paths

If a track has only one main output assignment, you can Control-start-click (Windows) or Command-Control-click (Macintosh) the track’s Output Path selector to toggle the main output to inactive. When there are multiple assignments, the track selector will be displayed for you to specify the input, output, insert, or bus path.

If a Send (A–J) has multiple output assignments and one of those is toggled, then all of the output assignments for that Send (A–J) will be toggled.

Session-Wide Path Assignments

(I/O Setup Dialog)

Paths can be globally configured for Active or Inactive status in the I/O Setup Dialog.

Display of Active and Inactive Status

Unhighlighted (Italics) Indicates the path is inactive.

Highlighted (Non-Italics) Indicates the path is active.

Highlighted (Italics) Indicates the path is active, but there are not enough system resources available.

To globally activate or deactivate a path:

1. Choose Setup > I/O.
2. Select a path type using the tabs at the top of the window.
3. Set the Active/Inactive control for the path.

Any track path assignment can also be deactivated on a track-by-track basis. See “Track Path Assignments” on page 79.

Inactive paths are displayed in italics in the track path selectors.

Hardware Setup and Session Transfer

Pro Tools sessions store the type and order of audio interfaces connected and active when the session was last saved.
Unavailable I/O

When opening a session, Pro Tools checks to see if the hardware configuration has changed since the session was last saved. If the current hardware configuration differs from that saved in the session, paths associated with the unavailable I/O are made inactive.

Remapping

Remapping occurs when a session’s original I/O Setup does not match that of the current system and session paths are remapped to current hardware.

Systems of equivalent I/O capability are remapped directly. For example, a session tracked to a Pro Tools|HD system through two 192 I/O audio interfaces would include 32 input paths spread across the two 16-channel interfaces. The session is taken to a second Pro Tools system that has a 96 I/O audio interface (a 16-channel I/O unit) and a 1622 I/O (with its 16 analog inputs) connected to its Legacy Port. When the session is first opened on the second system, Pro Tools will map the 32 input paths to the inputs of the two interfaces.

When hardware is unavailable to a session being opened, assignments can either be replaced using the remap option, or opened as Inactive. Any tracks left assigned to an unavailable path will not be audible. This can be beneficial, however, when you want to reassign tracks into your system’s mix one at a time.

Show Original Setup and Show Current Setup

When a session is opened that contains path definitions for unavailable I/O interfaces, the I/O Setup dialog lists those paths in italics. The Show Original Setup button displays the audio interfaces used in the original session. This temporary display lets you check the original I/O configuration for reference while configuring the session for your system.

Once a session has been opened with unavailable I/O retained, you can then reassign tracks to available I/O paths.

To redefine the paths, see “Creating and Editing Paths” on page 74.

I/O Settings Files

I/O Settings can be managed when transferring sessions, and when developing I/O Setup configurations over the course of multiple sessions and projects.

Defaults, Settings Files, and Last Used Settings for New Sessions

When creating new sessions, you can set the session’s I/O Setup configuration using the following options:

Default I/O Setups The Pro Tools Installer provides factory presets for stereo and surround I/O Setups (surround mixing is only supported on Pro Tools|HD systems). See “Factory I/O Settings Files” on page 83 for more information.

Custom Presets You can store and recall custom presets using the export and import features of the I/O Setup dialog.

Last Used The most recent (or last used) I/O Setup configuration is saved as a Last Used settings file. See “Last Used I/O Settings” on page 82 for more information.
Default I/O Settings at First Launch

The first time you create a session, you can choose default Stereo Mix or Surround Mix settings, depending on your system and installation choices. See “Factory I/O Settings Files” on page 83.

Importing and Exporting I/O Settings Files

You can export and import I/O Setup configurations as I/O Settings files. This lets you save settings for different projects, import settings for reconfiguring I/O Setup, and manage path definitions and signal routing setups.

Exporting I/O Settings

To export and save an I/O Setup configuration:

1. Click Export Settings.
2. Name and save the settings file.

Importing I/O Settings

I/O Settings can be imported before you open a session, or you can import settings into a session that is already open (see “Default I/O Settings at First Launch” on page 82).

When you import I/O Settings in an existing session, you can choose to delete any unused path definitions before importing the new paths, or leave unused path definitions intact and add the new paths to the current I/O Setup configuration.

To import I/O Settings:

1. Click Import Settings in the I/O Setup dialog.
2. Select an I/O settings file in the Import Settings dialog and click Import.
3. A dialog appears asking whether you want to delete existing paths. Do one of the following:
   • Click Yes to remove any unused paths and add the imported paths to the current I/O Setup configuration. Any I/O assignments and automation data associated with the unused paths are also deleted.
   • Click No to add the imported paths to the current I/O Setup configuration.

If the import results in overlapping paths, the new paths will appear in the I/O Setup dialog as Inactive. (See “Active and Inactive Paths” on page 79.)

After importing I/O Settings, you can then reassign path routing definitions in the I/O Setup dialog by remapping, renaming, and deleting paths. (See “Creating and Editing Paths” on page 74.)

Last Used I/O Settings

If any changes are made to the I/O Setup dialog during a session, these changes are saved to the Last Used settings file when the I/O Setup dialog is closed (by clicking OK).

Changes to I/O Setup are saved along with the current session. User Presets files will not contain recent changes unless you export an updated settings file.

The Last Used settings are available as a choice when creating or opening sessions, in addition to the factory presets described below.
Factory I/O Settings Files

Pro Tools provides I/O Settings files for Stereo and Surround mixing. These files provide generic main and sub-path definitions for either mixing format.

Stereo Mix Settings File

The Stereo Mix preset consists of all possible stereo and mono paths for your session.

Using the “Stereo Mix” preset has the same effect as clicking Default for every individual tab in I/O Settings. See “Creating and Editing Paths” on page 74 for details.

Specifically, the Stereo Mix preset will create the maximum number paths of each type, as determined by the available system’s I/O Setup and hardware configuration.

Surround Mix Settings File (Pro Tools Only)

The Surround Mix provides additional, surround-specific Output and Bus presets. See “Surround Mix Settings Files” on page 601 for more information.

About Direct Outputs Mode

Direct Outputs mode, as found in older versions of Pro Tools, has been replaced by the default mono sub-paths available through all valid I/O in the I/O Setup dialog.

The Default switch creates main Output paths with appropriate mono sub-paths. These sub-paths provide discrete monophonic routing.

When a session is opened that was saved in Direct Outputs mode, Pro Tools maps all the output assignments to equivalent mono sub-paths (as available). See “Hardware Setup and Session Transfer” on page 80 for more information on remapping.

To convert a session so that it emulates Direct Outs mode, use the Auto Assign Ascending Outputs feature, as follows:

To auto assign track outputs for Direct Out:

1. Make sure that all tracks you want to assign are visible (hidden tracks will not be affected).
2. Select the tracks you want to assign.
3. Control-Alt-click (Windows) or Command-Option-click (Macintosh) the Output selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.

I/O Setup Options

Pro Tools systems have additional I/O Setup features. These include default signal routing for metering and auditioning, and default track layout for multichannel mix formats.

Controller Meter Path

(D-Control, D-Command, and ProControl Only)

The Controller Meter Path selector determines the path displayed across the Output meters of D-Control, D-Command, or ProControl control surfaces. For more details, refer to your control surface documentation.

Audition Paths

You can specify the output path through which files and regions are auditioned in the Region List or in DigiBase browsers.
Using the Default Audition Path

When you audition a file or region in the Region List, Pro Tools routes the audio output through the Audition Path. Pro Tools assigns a default Audition Path to the first available main Output path of the corresponding format. You can also select a different Audition Path in the I/O Setup dialog.

On Pro Tools|HD systems with more than one audio interface, you can only select the first audio interface as an audition path.

Configuring Audition Paths

You can specify the monitoring outputs for Region List auditioning using the Audition Paths menu.

Audition Paths Main Menu The main menu consists of all path format choices available on the current system (Mono and Stereo on all systems, and LCR and greater on Pro Tools|HD systems).

Audition Paths Submenus Each path format choice has a submenu listing Output paths of that given format. (The mono submenu lists Output paths of any format.)

To configure an Audition Path:

Select a path from the Audition Paths menu or submenus.

To audition regions in the Region List:

Alt-click (Windows) or Option-click (Macintosh) the region in the list.

Auditioning Discrete Signals in Multichannel Items

In the Region List, multichannel regions are auditioned through the current Audition Path. Signals can be auditioned “in-place,” or through all outputs, as described below.

Audition In-Place

When auditioning a mono component of a multichannel region, that mono component will by default be auditioned in-place. That is, it will play from the corresponding speaker channel of its parent multichannel region.

To audition in-place:

1. In the Region List, make sure the stereo or multichannel region is in expanded view (showing .L, .R, and other component channels).

2. Alt-click (Windows) or Option-click (Macintosh) the region for the channel you want to audition.

Audition to All Outputs

Mono regions can be routed equally to all outputs of the parent region’s Audition Path.

To audition through all channels of the main audition path:

Shift-Alt-click (Windows) or Shift-Option-click (Macintosh) on the signal in the Region List.

New Track Default Output Path

You can specify the default output path assignment for new tracks, in each available format.

The New Track Default Output can be set to bus paths, as well as output paths.

To specify a default output for new tracks in the I/O Setup dialog:

Click the New Track Default Output selector and select a format and Output.
Chapter 7: I/O Setup

AFL/PFL Path
(Pro Tools HD Only)

Tracks soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode are routed to the current AFL/PFL Path, as set with the AFL/PFL Path selector.

See “Solo Modes” on page 108 for more information on using AFL or PFL Solo modes.

To select the AFL/PFL Path output:

1. Choose Setup > I/O.
2. Click the Output tab to display the Output page.
3. Select a path from the AFL/PFL Path selector.
4. Click OK to close the I/O Setup dialog.

Setting AFL or PFL Path Levels

You can set a separate master AFL/PFL Path level for all AFL solos and all PFL solos.

Tracks do not need to be soloed to have the master AFL/PFL Path level adjusted.

To set the AFL/PFL Path level for AFL or PFL solos:

1. Choose Options > Solo Mode, and select a Solo mode, as follows:
   - If you want to set the level for AFL solos, select AFL.
   - or
   - If you want to set the level for PFL solos, select PFL.
2. In the Mix or Edit window, Control-click (Windows) or Command-click (Macintosh) a Solo button on any track.
3. Adjust the AFL/PFL Path fader.
4. Click on the new fader position (or press Esc) to close the fader display.

To set the AFL/PFL Path level to 0 dB, Control-Start-click (Windows) or Control-Command-click (Macintosh) any Solo button.

AFL/PFL Mutes (Output Path) Selector
(Systems without a D-Control or D-Command Control Surface)

If you are not using a D-Control or D-Command control surface, your regular Pro Tools output path can be muted when you send a signal to the AFL/PFL Path. The muted path is set with the AFL/PFL Mutes (Output Path) selector.

See “Solo Modes” on page 108 for more information on selecting and using AFL or PFL Solo modes.

To set which output path is muted when tracks are soloed in AFL or PFL Solo mode:

1. Choose Setup > I/O.
2. Click the Output tab to display the Output page.
3. Select a path from the AFL/PFL Mutes (Output Path) selector.
4. Click OK to close the I/O Setup dialog.
Default Path Order
(Pro Tools HD Only)

The Default Path Order selector lets you select the default track layout you want Pro Tools to follow when creating and mapping 5.1-format main or sub-paths in the I/O Setup dialog.

This setting does not affect existing path definitions or metering—it only specifies channel mapping in new 5.1-format paths.

To choose a Default Path Order:
■ Select the channel mapping from the Default Path Order menu.

For more information about multichannel mixing, see Chapter 30, “Pro Tools Setup for Surround (Pro Tools HD Only).”

H/W Insert Delay Compensation
(Pro Tools HD Only)

You can specify the latency of outboard hardware (such as effects devices) in the H/W Insert Delay page of the I/O Setup dialog. You can enter hardware insert latency, in milliseconds, in a field that corresponds to every input/output pair. These times will be used by the Delay Compensation Engine to time align input paths when a hardware insert is used.

To set an insert delay offset:
■ Enter a value, in milliseconds, in the field corresponding with the input where the hardware insert is connected.

⚠ Insert delay offsets only have an effect when the I/O is used for hardware inserts.
Chapter 8: Tracks

This chapter covers basic track management tasks such as creating and deleting tracks, assigning voices and output channels, and grouping tracks.

Track Types

In a Pro Tools session, you can have several different types of tracks. These can include audio tracks, Auxiliary Input tracks, Master Fader tracks, MIDI tracks, Instrument tracks, and Avid or QuickTime Movie tracks.

Audio Tracks, Auxiliary Input Tracks, and Master Fader Tracks

Pro Tools provides mono, stereo, and multi-channel format audio tracks, Auxiliary Input tracks, and Master Fader tracks.

Audio Tracks

Audio tracks contain arrangements of recorded (or imported) audio files.

Auxiliary Input Tracks

Auxiliary Input tracks (or Auxiliary Inputs) can be used as effects sends, destinations for submixes, as a bounce destination, as inputs to monitor or process audio (such as audio from MIDI sources), and for many other audio routing tasks.

Master Fader Tracks

Master Fader tracks (or Master Faders) control the overall level of the audio tracks that are routed to the session’s main output paths. For example, you could have 24 tracks in a session with channels 1–8 routed to Analog Output 1–2, channels 9–16 to Analog Output 3–4, and channels 17–24 to Analog Output 5–6. You could then create three master faders, one to control each of these output pairs.

Master Fader tracks have additional uses (such as controlling submix levels). For more information, see “Master Fader Tracks” on page 480.

MIDI Tracks

MIDI tracks store MIDI note, instrument, and controller data. You cannot select a track format when you create a MIDI track, because audio does not pass through it.
Instrument Tracks

Instrument tracks are a special type of track that provide MIDI and audio capabilities in a single channel strip. Instrument tracks simplify using software and hardware instruments to record MIDI and monitor audio from the instrument.

Track Formats

Mono Tracks

A mono audio, Auxiliary Input, Master Fader, or Instrument track controls volume, and, in some cases, panning, for a single channel of audio. A mono track uses a single voice.

Stereo Tracks

A stereo audio, Auxiliary Input, Master Fader, or Instrument track is a single channel strip that plays two channels of audio as a stereo pair. Stereo tracks use two voices.

Multichannel Tracks (Pro Tools HD Only)

A multichannel track is a single channel strip that plays multiple channels of audio (from 3–8 channels at a time). This allows Pro Tools to support multichannel mixing formats including LCRS, 5.1, 6.1, and others. Audio, Auxiliary Input, Master Fader, and Instrument tracks can all use any supported multichannel format.

For more information on surround mixing with Pro Tools, see the following chapters:

- Chapter 30, “Pro Tools Setup for Surround (Pro Tools HD Only)”
- Chapter 31, “Multichannel Tracks and Signal Routing (Pro Tools HD Only)”
- Chapter 32, “Surround Panning and Mixing (Pro Tools HD Only)”

Track Channel Strips

Audio Track Channel Strips

Each audio track has its own set of controls for volume, pan, output window, record enable, automation mode, solo, mute, and voice assignment. Audio tracks also have a Comments View to enter and display comments.
**Auxiliary Input Track Channel Strips**

Each Auxiliary Input track has its own set of controls for volume, pan, output window, automation mode, solo, and mute. Auxiliary Input tracks also have a Comments View to enter and display comments.

**Master Fader Track Channel Strips**

Each Master Fader track has its own set of controls for volume, output window, and automation mode. Master Fader tracks also have a Comments View to enter and display comments.
MIDI Track Channel Strips

Each MIDI track has its own set of controls for volume, pan, record enable, automation mode, solo, mute, MIDI patch assignment, and MIDI channel assignment. MIDI tracks also have a Comments View to enter and display comments.

![MIDI channel strip](image)

Instrument Track Channel Strips

Each Instrument track has its own set of controls for volume, pan, output window, automation mode, solo, and mute. Instrument tracks have an additional Instruments View that provides controls for MIDI input, output, mute, volume, and pan. Instrument tracks also have a Comments View to enter and display comments.

![Stereo instrument track channel strip](image)
**Track Controls and Indicators**

**Input/Output Selectors**

The I/O View shows Input and Output selectors on audio, Auxiliary Input, Master Fader (output only), MIDI, and Instrument tracks.

**Input Path selector**

**Output Path selector**

**Volume indicator**

**Pan indicator**

**Output Window button**

*Edit window I/O View (audio track)*

Input/Output Selectors

The I/O View shows Input and Output selectors on audio, Auxiliary Input, Master Fader (output only), MIDI, and Instrument tracks.

To show the I/O View in the Edit window:
- Select View > Edit Window > I/O.

For information on other track views, see “Views in the Mix and Edit Windows” on page 483.

**To toggle the Volume indicator display:**
- Control-click (Windows) or Command-click (Macintosh) the indicator to toggle it between the following modes:

**Volume Indicator (and Pop-Up Slider)**

Shows the current volume, or input level of a track as set by the track Volume fader. In I/O View (Edit window), click the Volume indicator to display the Volume pop-up slider, which can be used to adjust the volume.

**Peak Indicator**

Functions as a headroom indicator based on the last peak playback level. To reset the peak counter, click anywhere in the meter. Values range from –∞ (no signal) to 0 dB.

**Channel Delay Indicator**

Shows the total delay, in samples, incurred on the track from the use of any TDM plug-ins on that channel.

**Pan Indicator**

The Pan indicator displays the current pan setting of a track. Pan values range from <100 (full left) to >100> (full right). Pan controls are only available for stereo tracks or for mono tracks routed to a stereo output.

In I/O View (Edit window), click the Pan indicator to display the Pan pop-up slider, which can be used to adjust panning.

**Pan Slider**

The Pan slider controls the balance of a track between the assigned output pair. It only appears if you are using stereo tracks or mono tracks routed to a stereo output.

The Pan slider on a MIDI track is effective only if you are controlling a sound module that supports MIDI panning.
Volume Fader

The Volume fader controls the volume of a track when it is in playback, and the monitor level of the track when it is in record. You can link the record and monitor levels by enabling the Operation preference for “Link Record and Play Faders.”

The maximum fader gain for a volume fader is +12 dB.

MIDI Volume Fader

If your MIDI sound module supports volume, the volume fader on a MIDI or Instrument track can send a value of 0–127 to the MIDI volume controller.

Track Level Meter

On audio tracks, Level meters indicate the level of the signal being recorded or played back from the hard drive. On Auxiliary Input, Master Fader, and Instrument tracks, Level meters indicate the level of the signal being played through the channel output. Green indicates nominal levels; Yellow indicates pre-clipping (~6 dB below full scale); and Red indicates clipping. When an audio track is record-enabled, these meters indicate record levels.

On MIDI tracks, the level meter shows the MIDI velocity of the most recent MIDI event.

Pre- and Post-Fader Metering

You can globally set audio track level meters to indicate pre- or post-fader levels. When pre-fader metering is selected, the level meters show levels independent of fader position. With post-fader metering, the level meters respond to fader position.

To toggle track level metering between pre-fader and post-fader metering:

- Select Options > Pre-Fader Metering.

Peak Hold

Pro Tools meters provide a Peak Hold feature with three options: 3 Second, Infinite, or None.

To choose a Peak Hold setting:

1. Choose Setup > Preferences and click the Display tab.
2. Select a Peak Hold option.
3. Click Done.

To clear a meter:

- Click anywhere on the meter.

To clear all meters, do one of the following:

- Alt-click (Windows) or Option-click (Macintosh) any meter.
- Choose Track > Clear All Clip Indicators.
- Press Alt+C (Windows) or Option+C (Macintosh).

Clip Indication

Pro Tools meters provide Clip Indication with three options: 3 Second, Infinite, or None. If clipping occurs, the topmost LED will stay lit (red).

Clip indicators appear in plug-in, send, and track windows.

To choose a Clip Indication setting:

1. Choose Setup > Preferences and click the Display tab.
2. Select a Clip Indication option.
3. Click Done.
To clear a clip indicator:
- Click anywhere on the meter.

To clear all clip indicators, do one of the following:
- Alt-click (Windows) or Option-click (Macintosh) any meter.
- Choose Track > Clear All Clip Indicators.
- Press Alt+C (Windows) or Option+C (Macintosh).

Wide Meters View
Wide Meters View expands the width of the level meters for tracks in both the Mix and Edit windows, to make the track level meters easier to read. Wide Meters View also supports Narrow Mix View.

To enable Wide Meters View:
- Control-Start-Alt-click (Windows) or Command-Option-Control-click (Macintosh) the track level meters in either the Mix or Edit window.

To disable Wide Meters View:
- Control-Start-Alt-click (Windows) or Command-Option-Control-click (Macintosh) the track level meters a second time in either the Mix or the Edit window.

Adjusting Track Width

Mix Window
The Narrow Mix command lets you view all tracks/channels in the Mix window at a reduced width to conserve screen space in a large session. (See “Track Height” on page 224, to adjust track height in the Edit Window.)

To reduce the width of tracks in the Mix window:
- Select View > Narrow Mix.

To display tracks at normal width:
- Deselect View > Narrow Mix.

Creating Tracks
On all systems, you can create mono and stereo tracks. In addition, with Pro Tools HD, you can create multichannel tracks.

When new tracks are created, they are given a default name which can be changed at any time.

- To insert new tracks next to a specific track in a session, select that track by clicking the track’s name in the Mix or Edit window before opening the New Tracks dialog. The new tracks are added immediately after the selected track.
- To insert new tracks after the last tracks in a session, make sure that no track names are selected on-screen before opening the New Tracks dialog.
To create new tracks:

1. Choose Track > New.

2. Select the type of track you want to add from the Track Type pop-up menu.

3. Select the track format (mono, stereo, or one of the multichannel surround formats) from the Track Format pop-up menu. Surround formats are available on Pro Tools|HD systems only.

4. Select the timebase (samples or ticks) from the Track Timebase pop-up menu.

5. Enter the number of new tracks.

6. Do the following, if desired:
   - If you wish to add more tracks, click the Add/Remove Row button.
     - or -
   - If you wish to remove the previous track, click the Remove Row button.

7. To reorder tracks, click a Move Row icon and drag it up or down.

8. Click Create.

Naming Tracks

Track names are used to auto-name recorded audio files and regions (see “Default Track Names” on page 158).

To rename a track:

1. In the Mix or Edit window, double-click the Track Name button for the track you want to rename.

2. In the Track Name/Comments dialog, type a new track name.
3 Click Previous or Next to rename other displayed tracks.

4 Click OK.

Adding Comments to Tracks

To enter comments for a track:

■ From the track channel strip, click directly in the Comments area, type any comments for the track, and press Enter (Windows) or Return (Macintosh).

– or –

■ In the Edit or Mix window, double-click the Track Name button for a track. Then click directly in the Comments area, type any comments for the track, and press Enter (Windows) or Return (Macintosh).

To navigate directly to any track:

1 Choose Track > Scroll to Track.

– or –

Press Control+Alt+G (Windows) or Command+Option+G (Macintosh).

2 In the Scroll To Track dialog, enter the Track Position Number.

3 Click OK.

The track is selected, and the windows scroll as follows:

• The Mix window tracks scroll to bring the selected track as close to the left as possible.

• The Edit window tracks scroll to bring the selected track as close to the top as possible.

Selecting Tracks

Tracks need to be selected for operations such as duplicating tracks or adding tracks to a group. One or more tracks can be selected at a time.

To select a track:

■ Click the name of an unhighlighted track in its track channel strip.

To select a range of tracks:

1 Click the name of an unhighlighted track in its track channel strip.

2 Shift-click an additional Track Name button.
All tracks between the first track selected and the additional track will also be selected.

**To select or deselect non-contiguous tracks, do the following:**

- Control-click (Windows) or Command-click (Macintosh) Track Name buttons that are unhighlighted to select them.
- or —
- Control-click (Windows) or Command-click (Macintosh) Track Name buttons that are highlighted to deselect them.

**To select all tracks:**

- Alt-click (Windows) or Option-click (Macintosh) any Track Name button that is unhighlighted.

**To deselect all tracks:**

- Alt-click (Windows) or Option-click (Macintosh) any Track Name button that is highlighted.

**Deleting Tracks**

When you delete tracks, your audio or MIDI region data will remain in the Region List, but your arrangement of the regions on the deleted track (the track’s playlist) will be lost.

If the track contains playlists that are not assigned to any track, you will be prompted to delete or retain them.

⚠️ *The Delete Track command cannot be undone.*

**To delete a track:**

1. Click the name of the track in its track channel strip to select it.

   - To select multiple tracks, Control-click (Windows) or Command-click (Macintosh) additional Track Names.

   **To select a range of tracks, Shift-click additional Track Names.**

2. Choose Track > Delete.

3. Click OK to remove the selected tracks from the session.

**Duplicating Tracks**

The Duplicate Track command lets you duplicate one or more tracks, including their audio or MIDI data, playlists, automation, and other attributes.

When duplicating multiple tracks, you can also choose to have the new tracks follow the last selected track (or have each new track follow its source track).

**To duplicate one or more tracks:**

1. Click the name of the track (in its track channel strip) to select it.

   - To select multiple tracks, Control-click (Windows) or Command-click (Macintosh) additional Track Names.

   **To select a range of tracks, Shift-click additional Track Names.**
2 Choose Track > Duplicate.

– or –

Press Alt+Shift+D (Windows) or Option+Shift+D (Macintosh).

3 In the Duplicate Tracks dialog, configure the following options as needed:

- Enter how many copies you want to create by typing into the Number of Duplicates field.
- To copy the currently active (visible) Edit playlist from the source track, enable Active Playlist.
- To copy all Edit playlists on the source track, enable Alternate Playlists.
- To copy all automation from the source track, enable Automation.
- To copy all plug-in and insert assignments, enable Inserts.
- To copy all sends and send assignments, enable Sends.
- To maintain all Mix and Edit Group assignments, enable Group Assignments.

4 If duplicating multiple tracks, do one of the following:

- If you want all the newly created tracks to follow the last selected source track (to the far-right of the Mix window, and at the bottom of the Edit window), enable the Insert after Last Selected Track option.

– or –

- If you want each newly-created track to be inserted directly after its source track, disable the option.

5 Click OK to duplicate tracks according to the settings in the Duplicate Tracks dialog. Click Cancel to close the dialog and not create duplicate tracks.

In the Mix window, each duplicate track is created to the right of its original track. In the Edit window, each duplicate track is created below its original track.
The Track List

The Track List (at the left of both the Mix and Edit windows) lists all tracks in the session. It allows you to show or hide a track in the Mix and Edit windows, by selecting or deselecting its name. Even though a track is hidden, the material on the track will still play as part of the session. Inactive tracks appear in italics in the Track List.

💡 The Track List can also be used to create new tracks while importing media from DigiBase. See the DigiBase Guide.

When a track that is a member of an active group is hidden from view, editing operations performed on other members of the group in the Edit window will not affect the hidden track. In the Mix window, however, all operations other than record-enable will affect a hidden track that is a member of an active group.

⚠️ With Pro Tools HD, even if a track is hidden from view, its position relative to other tracks still affects its voiceable track playback priority (see “Voice Borrowing” on page 104 for details).
To hide a track:
■ Click the highlighted name of the track in the Track List.

To show a track that is currently hidden:
■ Click the unhighlighted name of the track in the Track List.

To show all tracks:
■ Click the Track List pop-up menu and choose Show All Tracks.

You can also show all tracks by Alt-clicking (Windows) or Option-clicking (Macintosh) the name of any track that is unhighlighted.

To hide all tracks:
■ Click the Track List pop-up menu and choose Hide All Tracks.

You can also hide all tracks by Alt-clicking (Windows) or Option-clicking (Macintosh) the name of any track that is highlighted.

To reorder tracks on-screen, drag the track names to new positions within the Track List.

To show a range of tracks:
1. Click the name of an unhighlighted track name in the Track List.
2. Shift-click an additional track name.

All track names that occur between the first track name selected and the additional track name will also be selected.

You can also select a range of tracks by moving the cursor to the left of the track names, so the Marquee appears, and dragging around the track names you want to select.

To show or hide a range of tracks in the Track List with the Marquee:
1. Press and hold Control (Windows) or Command (Macintosh).
2. Move the cursor to the left of a track name until the Marquee with a small “+” symbol appears.
   • To show tracks, the Marquee should be to the left of an unhighlighted track name.
   • To hide tracks, the Marquee should be to the left of a highlighted track name.
3. Click on the track name and drag up or down (to show or hide the track and the tracks immediately above or below it).

To show or hide non-contiguous tracks, do the following:
■ Control-click (Windows) or Command-click (Macintosh) track names that are unhighlighted to select them.
   – or –
■ Control-click (Windows) or Command-click (Macintosh) track names that are highlighted to deselect them.

You can also show all tracks by Alt-clicking (Windows) or Option-clicking (Macintosh) the name of any track that is unhighlighted.

You can also hide all tracks by Alt-clicking (Windows) or Option-clicking (Macintosh) the name of any track that is highlighted.
About Mix/Edit Groups and Hidden Tracks

Even if a track is hidden, if it is a member of an enabled group, all Mix window operations performed on other members of the group will also affect the hidden track—with the exception of audio or MIDI record-enabling. If you solo, mute, or automation write-enable a grouped track, any group members that are hidden will be soloed, muted, or automation write-enabled as well.

In the Edit window, however, editing operations performed on members of an enabled group will not affect hidden tracks that are also members of the enabled group.

About Clipping and the Track List
(Pro Tools HD Only)

When a track, send, or plug-in clips, the Track List displays the track’s name in red. Both shown and hidden tracks display clipping indication.

About Track Numbering and Hidden Tracks

There are two ways to display Track Position Numbers when tracks are hidden.

- Numbers are only assigned to tracks that are shown (when Track Position Numbers Stay with Hidden Tracks is not enabled in the Display Preferences page). In this case, active tracks are then numbered sequentially. Hidden tracks are un-numbered.

  - or -

- Tracks keep their Track Position Numbers even when hidden (when Track Position Numbers Stay With Hidden Tracks is enabled in the Display Preferences page).

Assigning Inputs and Outputs to Tracks

Inputs for audio tracks and Auxiliary Input tracks can be assigned to audio interface channels or busses. Outputs for audio tracks, Auxiliary Input tracks, and Master Fader tracks can be assigned to audio interface channels or busses.

Input/output assignments for three mono audio tracks

For stereo and multichannel surround tracks, inputs and outputs appear as stereo pairs and multichannel groups. The available inputs, outputs, and busses are defined as paths in the I/O Setup dialog (see Chapter 7, “I/O Setup”).

Automatic Input and Output Assignments

When adding tracks to a new session, inputs are automatically assigned in ascending order. For example, if you have an audio interface with eight inputs, creating four new mono audio tracks will automatically add four audio tracks with inputs assigned to the first four paths defined in the I/O Setup dialog. When creating stereo tracks, inputs are automatically assigned to ascending input pairs.

The outputs automatically assigned to new tracks are determined by the New Track Default Output defined in the I/O Setup dialog.
Assigning Audio Track Inputs
(Audio Tracks, Auxiliary Inputs, Instrument Tracks)

⚠️ Instrument tracks set their input automatically to any inserted Instrument plug-in.

To assign an audio track input:

1. In order to assign audio track inputs in the Edit window, select View > Edit Window > I/O.
2. In the Mix or Edit window, click the track’s Input Path selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have inputs available as pairs and multichannel groups.

The Input Path selector allows you to route any audio input or any of the Pro Tools internal busses to an audio track or an Auxiliary Input track. The choices available in this pop-up menu are determined by the I/O Setup configuration. Inputs in use by another track appear as bold in the selector.

To remove an input assignment:

- Select No Input from the Input Path selector.

Assigning Audio Track Outputs
(Audio Tracks, Auxiliary Inputs, Instrument Tracks, Master Faders)

To assign an audio track output:

1. In order to assign audio track outputs in the Edit window, select View > Edit Window > I/O.
2. In the Mix or Edit window, click the track’s Output Path selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have outputs available as pairs and multichannel paths.

The Output Path selector lets you route a track to any configured audio output or internal bus. The choices available in this pop-up menu are determined by the I/O Setup configuration. Outputs in use by another track appear as bold in the selector.

To auto-assign all visible tracks to unique mono sub-path outputs in ascending order:

1. Make sure you have enough mono sub-paths defined in I/O Setup (see Chapter 7, “I/O Setup”).
2. Control-Alt-click (Windows) or Command-Option-click (Macintosh) the Output Path selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.
To remove an output assignment:

- Select No Output from the Output Path selector. Playlists become dimmed for tracks with no output assignment.

⚠️ Assigning an audio track, Auxiliary Input, Master Fader, or Instrument track to “No Output” will cause its automation data for pan and plug-in controls to be lost.

---

**Track Priority and Voice Assignment**

Pro Tools LE systems provide up to 32 voices of simultaneous audio playback and recording, depending on the system. For details on LE system capabilities, see Table 5 on page 10.

Pro Tools HD provides a certain number of voices (simultaneous channels of audio playback and recording), depending on the system. For example, a Pro Tools HD 1 system can provide up to 96 voices of audio playback and recording, at 44.1 or 48 kHz. For details on Pro Tools system capabilities, see Table 3 on page 7.

**Track Priority**

While your Pro Tools hardware allows a fixed number of voices, Pro Tools software allows for additional audio tracks beyond that fixed number of voices. While all of these tracks can be recorded or imported, arranged, and cued for playback, not all of them can be played back simultaneously.

When the number of tracks exceeds the number of available voices, tracks with lower priority may not be heard. For these situations, Pro Tools assigns priorities to tracks that compete for the available voices. Because there can be more tracks than available voices, Pro Tools provides multiple ways of adjusting the playback priority of audio tracks. See “Changing a Track’s Playback Priority” on page 102 and “Freeing up Voices on a Track” on page 103.

With Pro Tools HD, you can also assign specific voices to multiple tracks so that those voices are shared by more than one track. This feature is called voice borrowing. The combination of playback/record tracks and shared voiced tracks comprises the total number of voiceable tracks on a Pro Tools HD system.

To set multiple tracks to the same voice, see “Setting Voice Assignment” on page 103. For additional information on voice borrowing, see “Voice Borrowing” on page 104.

**Changing a Track’s Playback Priority**

Tracks with higher positions (leftmost in the Mix window or topmost in the Edit window) have priority over tracks in lower positions in a session.

To increase a track’s priority, do any of the following:

- In the Mix window, drag the Track Name button to the left of other tracks in the session. Tracks at the left of the Mix window have higher priority than those on the right.
- In the Edit window, drag the Track Name button above other tracks in the session. Tracks at the top of the Edit window have higher priority than those below.
- In the Track List, drag the Track Name button to a higher position in the list. Tracks at the top of this list have higher priority than those below.
Freeing up Voices on a Track

You can also adjust the relative priority of tracks by freeing up the voices of individual tracks, making them available to other tracks in the session.

To free up the voice of a track, do one of the following:

- Click the Voice selector of the track and set it to Off. See “Setting Voice Assignment” on page 103.
- Deactivate the track by Control-Start-clicking (Windows) or Command-Control-clicking (Macintosh) its track type icon in the Mix window.
- Make sure the track does not have an output or send assignment.
- With Pro Tools HD, you can temporarily free a track’s voice during playback by muting it (see “Mute Frees Assigned Voice” on page 111).

Setting Voice Assignment

A track’s voice assignment can be turned off or set to be dynamically allocated, and with Pro Tools HD, can also be assigned to a specific voice number.

On all Pro Tools systems, you can use Dynamically Allocated Voicing to automatically take care of voice management in the background, assigning voices not in use by other tracks.

⚠️ Pro Tools LE supports Dynamically Allocated Voicing only; it does not support individual voice assignments.

With Pro Tools HD, tracks assigned to a specific voice number take priority over dynamically allocated tracks and support voice borrowing (see “Voice Borrowing” on page 104). To ensure a track is heard, or that it is available for Quick-Punch or TrackPunch recording, assign a voice number to that track.

⚠️ With Pro Tools HD, the initial insert of an RTAS plug-in uses additional voices in certain situations. See “Voice Usage and Total Latency for RTAS Plug-Ins” on page 513.

For stereo and multichannel tracks, voices appear in pairs and multichannel groups. Voices already assigned to another track appear in bold in the Voice selector pop-up menu.

To set the voice assignment for a track:

- Click the Voice selector and set the track to Dyn, Off, or select a voice number (Pro Tools HD only).
Automatic Assignment of Ascending Voices
(Pro Tools HD Only)

You can automatically assign all tracks or all selected tracks to successive voices. For example, you may want to select eight audio tracks and reassign them to voices 9–16.

To assign all audio tracks to successive voices:
- While pressing Control+Alt (Windows) or Command+Option (Macintosh), select the starting voice number from the Voice selector for the track at the far left of the Mix window, or at the top of the Edit window.

The voice is assigned to the first track, with successive voices assigned to tracks (with the same format) of lower priority.

To assign all selected audio tracks to successive voices:
1 Select the audio tracks by Control-clicking (Windows) or Command-clicking (Macintosh) their names.

To select multiple tracks, Control-click (Windows) or Command-click (Macintosh) additional Track Names.

To select a range of tracks, Shift-click additional Track Names.

2 While pressing Control+Alt+Shift (Windows) or Command+Option+Shift (Macintosh), select the starting voice number from the Voice selector for the left (Mix window) or top (Edit window) selected track.

The voice is assigned to the starting track, with successive voices assigned to currently selected tracks (with the same format) of lower priority.

Voice Borrowing
(Pro Tools HD Only)

Pro Tools HD features voice borrowing, which lets you assign more than one track to the same voice. The track with the highest priority takes over that voice, but when a hole opens up in the higher-priority track, its shared voice is temporarily available, and the track with the next highest priority “pops through” and begins to play. When the original track returns, the track that had popped through relinquishes the shared voice to the higher priority track.

The following example demonstrates the concept of voice borrowing:

In the above illustration, the two visible tracks are assigned to the same voice. There is an open area in the top track where no region appears. At this point, the voice is free since it is not being used, and the next highest priority track assigned to that voice (the bottom track) pops through the open area and plays.

By experimenting with track priority, voice assignment, and arranging regions so that they are positioned to “pop through” holes in higher priority tracks, you can find many useful ways to maximize voiceable tracks with Pro Tools HD.
Setting MIDI Input and Output

MIDI is supported on MIDI tracks and Instrument tracks.

Assigning MIDI Track Input

Pro Tools lets you assign specific MIDI ports and channels to a MIDI track input. The default selection of All receives all incoming MIDI data from all ports on all channels. Use the MIDI Input selector to specify a MIDI port and channel for input.

For information on assigning MIDI input to Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 106.

To assign a MIDI track input:

- Click the track’s MIDI Input selector and assign a port and channel for MIDI input. Channels already assigned to another track appear in bold.

- In the Edit window, select View > Edit Window > I/O to access any track’s Input selector.

Assigning MIDI Track Output

Pro Tools lets you assign specific MIDI ports and channels to a MIDI track output. The default selection of none sends MIDI data to no port on any channel. Use the MIDI Output selector to specify a MIDI port and channel for output.

For information on assigning MIDI output to Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 106.

To assign a MIDI track (and all its regions) to a specific MIDI device channel:

- Click the track’s MIDI Output selector and assign a port and channel for MIDI output. Channels already assigned to another track appear in bold.

- In the Edit window, select View > Edit Window > I/O to access any track’s Output selector.
To assign multiple destinations to a single MIDI track:

- Right-click (Windows) or Control-click (Macintosh) the MIDI Output selector and select additional channels from any device.

Assigning MIDI Input and Output for Instrument Tracks

Instrument tracks have a specific view for MIDI controls, including MIDI Input and Output selectors.

To view instrument track MIDI controls, do one of the following:

- Select View > Mix Window > Instruments.
  - or -
- Select View > Edit Window > Instruments.

Instrument Track MIDI Input

Pro Tools lets you assign specific MIDI ports and channels to an Instrument tracks’ MIDI input. The default selection of All receives all incoming MIDI data from all ports on all channels. Use the MIDI Input selector to specify a MIDI port and channel for input.

Channels in use by another track input appear as bold in the MIDI Input Selector pop-up menu.

Instrument Track MIDI Output

Pro Tools lets you assign specific MIDI ports and channels to an Instrument tracks’ MIDI output. The default selection of none sends MIDI data to no device, port, or node on any channel. Use the MIDI Output selector to specify a MIDI port and channel for output.

Channels in use by another track input appear as bold in the MIDI Input Selector pop-up menu.
To assign an Instrument track MIDI output:

- Click the track’s MIDI Output selector and assign a port and channel for MIDI output. Channels already assigned to another track appear in bold.

**Inserting Instrument Plug-Ins on Instrument Tracks**

To insert an instrument plug-in on an Instrument track:

- Click the Insert Selector on the Instrument track and select the instrument plug-in that you want to use.

A MIDI node (virtual MIDI port) is automatically created and assigned the track’s MIDI output.

**Soloing and Muting Tracks**

The Solo and Mute buttons can be engaged at any time during playback. The Solo and Mute buttons affect MIDI as well as audio tracks. It is possible to have more than one track soloed or muted at the same time in a session.

- Instrument tracks have separate sets of Solo and Mute buttons for MIDI and audio monitoring.

Track grouping affects mute and solo behavior as well. Normally, muting or soloing a track that is a member of an active Mix Group will mute or solo all other tracks that are a member of that active Mix Group as well. However, by changing the Mute and Solo settings in the Automation Preferences page, you can disable this behavior.

**To disable group muting of tracks:**

1. Choose Setup > Preferences and click the Automation tab.
2. Deselect the Mutes Follow Groups option, and click Done.

With this option deselected, muting a track that is a member of an active group does not affect other members of the group.

- You can also mute or solo individual members of a group by holding down the Start key (Windows) or Control key (Macintosh) while selecting the track’s Mute or Solo button.

**To disable group soloing of tracks:**

1. Choose Setup > Preferences and click the Automation tab.
2. Deselect the Solos Follow Groups option, and click Done.

With this option deselected, soloing a track that is a member of an active group does not affect other members of the group.

**Solo Button**

The Solo button normally mutes other tracks so that the chosen track can be auditioned alone.

With Pro Tools HD, this behavior is selected as a Solo mode, called “Solo In Place.” Additional Solo modes are provided to change how the Solo button works. See “Solo Modes” on page 108.
To solo tracks:

1. Click the Solo button on a track. The button is highlighted and all other tracks are muted.
2. Click the Solo button on another track. The buttons for both tracks are highlighted and all other tracks are muted.

To un-solo tracks:

- Click the Solo button on soloed tracks.

Solo Modes

(Pro Tools HD Only)

With Pro Tools HD, the Solo button can be used to:

- Mute other tracks so that the chosen track can be auditioned alone.
- Route a chosen track to a separate output.

Solo button behavior is defined by the Solo mode, as follows:

**SIP (Solo In Place)** The Solo button mutes other tracks. When this mode is enabled, tracks can be solo safed (see “Solo Safe Mode” on page 110).

**AFL (After Fader Listen)** The Solo button routes the track’s post-fader/post-pan signal to the AFL/PFL Path output. The AFL/PFL Path is configured in the Output page of the I/O Setup dialog (see “AFL/PFL Path” on page 85).

With AFL, the level you hear is dependent on the fader level for that track. Additionally, there is a separate master level setting for AFL that affects the output of any or all tracks you solo in AFL mode (see “AFL/PFL Path” on page 85). This level setting is independent of the PFL level setting.

**PFL (Pre Fader Listen)** The Solo button routes the track’s pre-fader/pre-pan signal to the AFL/PFL Path output. The AFL/PFL Path is configured in the Output page of the I/O Setup dialog (see “AFL/PFL Path” on page 85).

With PFL, the fader level and pan are ignored, and the level you hear is dependent on the signal’s recorded level. Additionally, there is a separate master level setting for PFL that affects the output of any or all tracks you solo in PFL mode (see “AFL/PFL Path” on page 85). This level setting is independent of the AFL level setting.

AFL and PFL Solo modes require the Surround Mixer plug-in (see the Pro Tools|HD Getting Started Guide).

AFL and PFL Solo modes require the Surround Mixer plug-in.

If Mutes Frees Assigned Voice is enabled, muted tracks will not be audible in PFL mode.
To select a Solo mode:

- Choose Options > Solo Mode, and select SIP, AFL, or PFL.

The Solo mode for all soloed tracks can be changed “on-the-fly” from any Solo mode to either SIP or AFL. Previously soloed tracks will switch their solo behavior to the new mode.

Switching the Solo mode for all soloed tracks “on-the-fly” to PFL will clear all previously soloed tracks before entering PFL mode. This will prevent potentially large boosts in level.

DSP Usage when Using AFL or PFL Mode

AFL and PFL are accomplished by Pro Tools creating a “behind the scenes” mixer to route the signal to the chosen AFL/PFL Path. Depending on the size of your main mixer, Pro Tools will devote a substantial portion of its available DSP when using AFL/PFL mode.

Un-declaring the AFL/PFL Path will free up all DSP resources previously used for AFL/PFL mode.

Using AFL/PFL on Pro Tools Systems with a D-Control or D-Command

AFL/PFL is optimized for Pro Tools systems using a D-Command or D-Control control surface, where the XMON automatically switches its monitor source between the main output and the AFL/PFL output from Pro Tools.

For more information on using XMON and AFL/PFL, see your control surface guide.

Using AFL/PFL on Pro Tools Systems without D-Control or D-Command

If you are not using a D-Control or D-Command control surface, your regular Pro Tools output path is not necessarily muted when you send a signal to the AFL/PFL Path. If you need the main signal to automatically mute when an AFL/PFL signal is invoked, you need to do the following:

1. Configure the output path for AFL or PFL soloed tracks.

2. Select the main output path that will mute when you solo a track in AFL or PFL mode (see “AFL/PFL Mutes (Output Path) Selector” on page 85).

3. Set up your hardware to monitor both the main and AFL/PFL paths simultaneously.

When AFL or PFL is selected as a Solo mode and a track is soloed, the main output path will mute and the AFL/PFL signal will appear at the AFL/PFL Path for monitoring.

Solo Latch Options

Solos can be latched (where pressing subsequent buttons adds them to the soloed mix of tracks), unlatched, or temporarily latched (Pro Tools HD only). Solo latching is set in the Operation Preferences page.

To select a Solo Latch option:

1. Choose Setup > Preferences and click the Operation tab.

2. Select a Solo Latch option.

Latch When selected, pressing subsequent Solo buttons adds them to the soloed mix of tracks.
**X–OR (Cancels Previous Solos)** When selected, pressing subsequent Solo buttons cancels previous solos.

Tip: To override X–OR mode and solo more than one track at a time, press and hold the Solo button on the first track. Subsequently pressed Solo buttons will latch.

**Momentary (Pro Tools HD with Supported Control Surfaces Only)** When selected, the Solo button is not sticky. When the Solo button is held down, the track is soloed. Additional tracks can be soloed by touching their Solo buttons (as long as at least one Solo button is held down). When no Solo button is held down, all soloed tracks will unsolo.

**Using Momentary Solo Latch**

(Pro Tools HD Only)

**To temporarily latch solos:**

1. Choose Setup > Preferences and click the Operation tab.
2. In the Solo Latch section, select Momentary, and click Done.
3. Press and hold the Solo button on the first track that will be soloed.
4. While still holding the first Solo button, press additional Solo buttons. Solo buttons will remain soloed as long as one Solo button is held.

Tip: As long as at least one Solo button is held down, all the solos will remain latched.

**Solo Safe Mode**

Pro Tools lets you solo safe a track. This prevents the track from being muted even if you solo other tracks. This feature is useful for tracks such as Auxiliary Inputs that are being used as a sub-mix of audio tracks, or effects returns, allowing the audio or effects track to remain in a mix even when other tracks are soloed. It is also useful to solo safe MIDI tracks so that their playback is not affected when you solo audio tracks.

Caution: AFL or PFL soloed tracks (Pro Tools HD only) cannot be solo safed.

**To solo safe a track:**

- Control-click (Windows) or Command-click (Macintosh) the Solo button on the track. This prevents the track from being muted even if you solo other tracks. The Solo button changes to a transparent color in Solo Safe mode.

**To return a solo safe track to normal:**

- Control-click (Windows) or Command-click (Macintosh) the Solo button on the track again.

**Mute Button**

The Mute button silences a chosen track. More than one track can be muted at one time. If Options > Mute Frees Assigned Voice (Pro Tools HD only) is enabled, muting a track will allocate its voice to the next highest priority voiceable track (assigned to the same voice).

**To mute a track:**

- Click the Mute button on the track. The track is grayed-out and muted.

**To unmute a track:**

- Click the Mute button again.
**Mute Frees Assigned Voice**
*(Pro Tools HD Only)*

Selecting Options > Mute Frees Assigned Voice and muting a track disables playback of that track, and surrenders control of its voice to the next highest priority track with the same voice assignment.

⚠️ **Muting a track with Mute Frees Assigned Voice enabled does not free up the voice for QuickPunch or TrackPunch recording.**

With this option enabled, there may be a delay (ranging in length from one to several seconds depending on the processing power of your system) between the time you mute or unmute a track and when you hear the effect on playback.

💡 **Larger DAE Playback Buffer Sizes can also increase the lag time between the time you click the Mute button and the onset of muting.** See “DAE Playback Buffer Size” on page 41.

**Making Tracks Inactive**

Audio, Auxiliary Input, Master Fader, and Instrument tracks can be made inactive. Inactive tracks use no DSP or voices. Plug-ins, sends, voices, and automation on inactive tracks are all disabled. Tracks may also be automatically made inactive if a session is opened on a system with less DSP power than the system that it was created on.

⚠️ **MIDI tracks cannot be made inactive.**

To toggle a track active/inactive:

- Control-Start-click (Windows) or Command-Control-click (Macintosh) the Track Type indicator in the Mix window.

Playlists for inactive tracks are dimmed and track controls are grayed out.

To make one or more tracks inactive:

1. Click the name of the track (in its track channel strip) to select it.

   ⚠️ **To select multiple tracks, Control-click (Windows) or Command-click (Macintosh) additional Track Names.**

   **To select a range of tracks, Shift-click additional Track Names.**

2. Choose Track > Make Inactive.

---

**Color Coding for Tracks, Regions, Markers and Groups**

Separate colors can be assigned to audio and MIDI regions, tracks, markers, and groups.

Regions shown in Waveform and Block Views in the Edit window are drawn in color. Tracks shown in the Track List, Group List, and Mix and Edit windows have associated color bars.

**Color Bars**

Color coding at the track level is displayed using color bars, as follows:

**Mix Window** Track colors are displayed in horizontal color bars that appear above each channel strip, and below the track name.
Pro Tools Reference Guide

Edit Window  Track colors are displayed in vertical color bars that appear to the left of each track.

Track List  Track colors are displayed in vertical color bars that appear to the left of each track name.

Group List  Track colors are displayed in vertical color bars that appear to the left of each Group Name.

Default colors are automatically assigned to tracks, but you can override those colors by choosing from a color palette of 96 possible colors. For more information, see “Color Palette” on page 113.

Display Page Preferences for Color Coding

Color Coding options determine how colors are assigned to the display of tracks and regions.

To change Color Coding options:
1. Choose Setup > Preferences.
2. Click Display.
3. Select a Default Track Color Coding option.
4. Select a Default Region Color Coding option.
5. Select or deselect the Always Display Marker Colors option.
6. Click Done.

Always Display Marker Colors

This setting lets you choose to view Marker colors in the Markers ruler, regardless of the settings you choose for Default Region Color Coding.

Default Track Color Coding

The Default Track Color Coding options determine how colors are assigned to the display of tracks.

- Default Track Color Coding: None, Tracks and MIDI Channels, Tracks and MIDI Devices, Groups, Track Type

Default Region Color Coding options

- None: Turns off default color assignment for tracks.
- Tracks and MIDI Channels: Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI channel assignment.
- Tracks and MIDI Devices: Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI device assignment.
- Groups: Assigns a color to each track according to its Mix or Edit Group ID. If groups are suspended using the Suspend Groups command, the tracks color bars are not shown.
**Track Type** Assigns a color to each track according to its type (audio, Auxiliary Input, Instrument, MIDI, or Master Fader).

**Default Region Color Coding**

The Default Region Color Coding options determine how colors are assigned to the display of regions.

- **None** Turns off default color assignment for regions. Regions are drawn as black waveforms or black MIDI notes on a light gray background.

- **Tracks and MIDI Channels** Assigns a color to each region in the Edit window according to its voice or MIDI channel assignment.

- **Tracks and MIDI Devices** Assigns a color to each region in the Edit window according to its voice assignment or MIDI device assignment.

- **Groups** Assigns a color to each region according to the Group ID of its track. If groups are suspended (using the Suspend Groups command) all regions display black waveforms or MIDI notes on a light gray background.

- **Track Color** Assigns a region color based on the color assigned to the track. (See “Color Palette” on page 113.)

- **Marker Locations** Assigns a color to data across all tracks based on the nearest preceding marker.

- **Region List Color** Assigns a color to each region based on its color in the Region List. When this Default Region Color Coding option is enabled, the assigned region color is maintained even if the region is placed in a track set to a different color coding.

**Tips** Enabling any Default Region Color Coding option other than Region List Color will override Region List Color and reassign the parent track color to copies of the region placed in tracks. Copies of the region in the Region List will retain their unique color, if any.

**Color Palette**

The Color Palette lets you make color selections for tracks, regions, groups and markers.

- **Apply to Selected**
- **Hold**
- **Default**
- **None**

The Color Palette supports independent region color coding in the Region List and in tracks.
To apply a color from the Color Palette:

1. Choose Window > Color Palette.

2. Do one of the following:
   - In the Apply to Selected pop-up menu, select the destination for color coding:
     Tracks, Marker, Group, Regions in Tracks, or Regions in Region List.
   - or –
   - Select a track, marker, group, track region, or Region List region in the appropriate Pro Tools window. The Apply to Selected menu will display the type of item you have selected.

3. Select a color from the palette, or select one of the following:

   **Default** Removes any custom coloring and restores the color to the default color orientation. See “Display Page Preferences for Color Coding” on page 112 for more information.

   **None** Turns off color assignment. Affected regions are drawn with black waveform or MIDI notes on light gray background. Affected tracks and groups no longer show their color bars.

   **Using the Hold Button**

   The Color Palette provides a Hold button to simplify the process of assigning the same colors to multiple items (such as track and regions).

   By default, the Hold button is off. When off, the Color Palette automatically highlights the assigned color (if any) of items as you select them.

   When the Hold button is enabled, the assigned color selected in the Color Palette persists and does not change when a different track or region is selected.

   To use the Hold button to assign the same color to multiple items:

   1. Click the Hold button to enable it. The Hold button becomes white, and the currently selected color is now highlighted with a wider white outline.

   2. Select additional tracks or regions to which you want to assign the same color. Because the Hold button is enabled, the Color Palette does not follow item selection; it remains (or “holds”) at the last currently assigned color.

   3. Click the assigned color again to assign it to the new selection of tracks or regions. Use the Apply to Selected popup menu to determine which selected elements are affected.

   4. To turn off Hold and return the Color Palette to its default mode, click the Hold button until it turns off.

---

**Grouping Tracks**

Pro Tools provides a relative grouping function for linking tracks and their controls. Groups can be applied to either the Mix or Edit window, or both.

Groups are useful for editing several tracks in exactly the same way, or for mixing several tracks (such as a pair of stereo tracks or a submix) while keeping them at the same relative volume level.
Pro Tools provides the following grouping features:
- Up to 26 different groups
- Nested groups (subgroups within groups)
- Grouped faders or controllers preserve their levels relative to each other

Grouping can affect the following track parameters:
- Track Timebase
- Volume levels
- Solos
- Mutes
- Automation modes
- Send levels
- Send mutes
- Track View
- Track height
- Editing functions

Grouping does not affect these parameters:
- Record enables
- Panning
- Send panning
- Voice assignment
- Output assignment
- Inserting plug-ins

Using the Group List

The Pro Tools track grouping functions are located at the left side of the Mix or Edit window in the Group List. This scrolling window contains the names of all the groups in your session, as well as a pop-up menu for accessing grouping commands. From this menu, you can select and enable groups.

By default, every session has a group named All, which includes every track in the session. The All group cannot be edited or deleted.

To the left of each name in the Group List is a letter denoting its Group ID (“a” through “z”), and to the left of that, a symbol indicating whether that group is selected in the current window (either the Mix or Edit window).
**Group Symbols**

There are three types of Group symbols, as shown in the following figure:

- **Filled-in Circle**: Indicates that all members of the group are currently selected, and no members from outside the group are selected.
- **Hollow Circle**: Indicates that only some members of the group are currently selected.
- **Circle with a Dot**: Indicates that all members of the group are currently selected, plus additional members outside the group.

**Group List Pop-Up Menu**

The Group List pop-up menus for Mix and Edit Groups let you show or hide the tracks in a group, or show only the tracks in a group. Click The Group List selector and select a Show/Hide option from the pop-up menu.

**Group List Commands**

The Group List selector contains commands that allow you to create, delete and suspend groups, as follows:

- **Create New Group**: This command lets you create a new group. You must first select two or more tracks/channel strips on-screen to do this.
- **Display**: This command lets you toggle the Group List display to either Mix Groups or Edit Groups. If all of your groups apply to both Editing and Mixing, the Group List will be the same for both.
- **Suspend All Groups**: This command allows you to temporarily toggle all active groups off.
- **Delete Group**: This command lets you permanently remove a group from the Group List. You must first select a Group Name in the Group List to do this.

**Creating Groups**

To create a group:

1. Control-click (Windows) or Command-click the Track Name buttons for the tracks you want to include in the group to select them.
2 Choose New Group from the Group List pop-up menu, or choose Track > Group.

3 Enter a name for the group.

4 Choose the type of group to create: Edit Group, Mix Group, or Edit and Mix Group.

5 Choose a Group ID (“a”–“z”).

6 Click OK to add the new group to the Group List.

Editing Groups

Changing the Members of a Group

You can add or remove members from a group at any time.

To change the members of a group:

1 Control-click (Windows) or Command-click (Macintosh) the Track Name buttons for the tracks you want to include in the group to select them.

2 Choose New Group from the Group List pop-up menu, or choose Track > Group.

3 In the dialog that appears, select the Group ID that you want to update.

4 Click OK.

Renaming a Group

You can rename a group at any time.

To rename a group:

1 In the Group List, double-click to the left of the group’s name (in the area with the circular symbols).

2 In the dialog that appears, enter a new name for the group. (You can also change the group’s type.)

3 Click OK.

Deleting a Group

A group can be deleted at any time. You cannot undo this action.

To delete a group:

1 In the Group List, select the name of the group (or groups) you want to delete.

2 Click the Group List pop-up menu and choose Delete Group.

Linking Mix and Edit Groupings

The “Link Mix and Edit Group Enables” option links group enabling between the Mix and Edit windows.

Pro Tools allows you to create groups that are both Mix and Edit groups, but in some cases you may prefer not to link enabling of Mix and Edit groups. For example, when you are using the Mix window for mixing, you may prefer to work with large, nested groups. However, in the Edit window, you may want to perform editing tasks within a smaller group. You could disable the Link Mix and Edit Group Enables preference. This would allow you to work with different groups in the two windows.
To unlink Mix and Edit groups:

1. Choose Setup > Preferences and click the Operation tab.
2. Deselect the “Link Mix and Edit Group Enables” option and click Done.

Enabling Groups

Editing operations are not applied to members of a group that are hidden with the Track List. Mix operations (with the exception of record-enabling of tracks) are applied to hidden tracks.

Pro Tools lets you create separate groups for editing and mixing. You set this option when you use the New Group command. Groups that apply to both editing and mixing can be decoupled.

To enable a group:

- In the Group List, click the name of the group you want to enable. The Group Name is highlighted to indicate that it is enabled.

To enable additional groups, click their names in the Group List.

Moving a fader of a group member will cause all other group members to move relative to it. If a fader belongs to multiple groups, and the groups conflict when faders are moved, the fader will follow the topmost or “parent” group that it belongs to.

To disable a group:

- In the Group List, click the name of the group you want to disable. The Group Name is un-highlighted to indicate that it is not enabled.

Keyboard Selection of Groups

The Group List Keyboard Focus allows you to type a Group ID letter to automatically toggle that group’s enable status.

- In the Mix window, the Group List Keyboard Focus is always enabled.
- In the Edit window, you need to enable the Group List Keyboard Focus to use it.

To enable the Edit Group List Keyboard Focus:

- Click the Keyboard Focus button in upper right of the Edit Group List.
- or –
- Press Control+Alt+3 (Windows) or Command+Option+3 (Macintosh).

To enable and disable groups using the Edit and Mix Group List Keyboard Focus:

- With Group List Keyboard Focus enabled, type the Group ID letter (a–z) to automatically enable or disable the corresponding group.
Chapter 9: Importing and Exporting Session Data

Pro Tools lets you import a variety of data into a session, including audio and MIDI files, region groups, video files, track playlists, I/O configurations, and signal routing configurations.

You can import audio and MIDI files into a session, or transfer entire audio or MIDI tracks, along with all of their attributes, from another session. Additionally, with Pro Tools HD, you also have the option of importing any combination of track attributes from another session, such as a track’s audio or MIDI playlists, signal routing, plug-ins, or automation. See “Importing Audio” on page 119 and “Importing Tracks and Track Attributes” on page 124.

Importing Audio

Audio files and regions can be imported to new tracks, or they can be imported into the Region List, where they can be dragged to existing tracks.

Files of types that are not supported in the session must be converted when importing. Files with sample rates that are different from the sample rate of the current session must be converted in order for the files to play back at the correct pitch and speed.

Supported files and regions can be auditioned before they are imported.

If region definitions are present in an audio file, you can convert and import the audio for a region without importing the entire parent audio file.

⚠️ Pro Tools 7.0 does not support audio file names that contain certain ASCII characters (see “Opening a Session that Contains Audio File Names with Illegal Characters” on page 143).

Audio files of the following types can be imported into Pro Tools sessions:

- AIFF
- WAV or BWF (.WAV)
- SD II
- SD I
- MP3
- AAC audio (including audio with AAC, Mp4, and M4a file extensions)

⚠️ Pro Tools cannot import protected AAC or MP4 files with the .M4p file extension. These files are protected under the rules of digital rights management, and cannot be imported.

- Sound Resource (AIFL—Macintosh only)
- WMA (Windows Media—Windows only)
- QuickTime (Macintosh only)
- RealAudio
Copying, Adding, and Converting Audio

Depending on the properties of the audio files you are importing, you can add, copy, or convert the files. The following options appear in the Import Audio dialog when they are applicable to the selected audio file.

Add

Audio files that are of the same file type and bit depth as a session can be added directly to the session. When you add an audio file, the session references the original audio file in its original location. Use this option when you do not want to use extra hard drive space for audio files that are already of the same bit depth and sample rate as your session.

Pro Tools does allow audio files that are not the session’s native file type to be added to the session. For example, Windows sessions allow AIFF or WAV files to be added to any session, and Macintosh sessions allow SD II, AIFF, or WAV files to be added to any session. However, sessions with mixed file types will have reduced performance.

Audio files that are of a different bit depth than the session must be converted before they can be imported.

Copy

If a file can be added to your session, you will also be given the option to copy it. This option creates a copy of the audio file and places it in a folder you choose. When you copy an audio file, the session references the copied file in its new location.

Use Copy to move audio from an unsupported or removable drive to an audio drive, or to archive audio files for a session to a specific location.

Convert

Audio files that are not of the same bit depth or sample rate as a session, or audio files that are of an incompatible file type (such as SD II files in Windows) must be converted to be used with the session. When an audio file is converted, a new file with the correct bit depth, file type, and sample rate is created and placed in a folder you choose.

The quality of sample rate conversion used by Pro Tools is determined by the preference for Conversion Quality. For details, see “Conversion Quality” on page 121.
Importing Stereo Files

When using the Import Audio to Track command, interleaved stereo files are automatically imported to stereo tracks.

Split stereo (dual mono) audio files can be automatically imported to stereo tracks. Split stereo audio files must have the channel identifiers “.L” and “.R” in their names (for example, filename.L and filename.R), and the files must be the same length. In Windows, or in Mac/PC Compatibility mode, these files will have a 3-letter file extension appended after the “.L” or “.R” channel identifier.

Pro Tools also lets you import multichannel interleaved files of any supported file type.

Conversion Quality

The Conversion Quality preference determines the quality of sample rate conversion used when converting and importing audio into a session. There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality, and the larger the conversion, the longer it will take.

To set the sample rate conversion quality:

1. Choose Setup > Preferences and click the Editing tab.

2. From the Conversion Quality pop-up menu, select a quality setting.

Conversion Quality preference

For most applications, the Good or Better setting will yield very good results.

3. Click Done.

Importing Audio Files and Regions

Pro Tools provides several ways to import audio files and regions into an open session.

- “Importing Audio Files and Regions Using Pro Tools Menu Commands” on page 122
- “Importing Audio Files Using the Pro Tools Application Icon or Alias” on page 123
- “Importing Audio Files and Regions with Drag & Drop” on page 123
- “Importing Audio from Audio CDs” on page 124
Importing Audio Files and Regions Using Pro Tools Menu Commands

Pro Tools provides menu commands to import audio files or regions.

To import audio files or regions into a session from the Pro Tools File menu:

1. Do one of the following:
   - To import audio files and automatically place them in new tracks, choose File > Import > Audio to Track.
   - or –
   - To import audio into the Region List without automatically creating new tracks, choose File > Import > Audio to Region List.

To import entire tracks from other sessions, see “Importing Tracks and Track Attributes” on page 124.

2. At the top of the Import Audio dialog, select an audio file to display its properties and associated regions.

   ![Figure 6. Import Audio dialog](image)

   You can choose to display only a certain file type (such as AIFF) by selecting the type from the Show pop-up menu. To display all supported file types, select All Documents from the Show pop-up menu.

   **On the Macintosh, Sound Resource files must have the “.SFIL” extension to be imported by Pro Tools.**

3. To audition a selected file or region before you import it, click the Play and Stop buttons.

   Adjust playback volume with the vertical slider. To navigate to a particular location in the file, use the horizontal slider under the Play and Stop buttons.

   The audition output defaults to channels 1–2. With Pro Tools HD, the audition output channels can be changed in I/O Setup or Hardware Setup.

4. To place a file or region in the import list (on the right in Windows, or in the lower right of the dialog on a Macintosh), select the file (Shift-click to select multiple files) and click Add or Convert. You can also click Add All or Convert All to import all regions and files in the current directory.

   In the import list, audio files are distinguished from regions by their icons.

   ![Audio File icon](image)

   ![Audio Region icon](image)

   **File and Region icons in the Import Audio dialog**

5. To remove a file or region from the import list on the right, select it and click Remove. To remove all regions or files, click Remove All.
6 Once the audio files and regions have been added to the import list, click Done.

7 If you are copying or converting files, you are prompted to choose a location for the new audio files. Choose a folder on a valid audio drive, such as the Audio Files folder for your current session.

If you chose File > Import > Audio to Track, the files and regions are imported to new audio tracks, and also appear as regions in the Region List.

If you chose File > Import > Audio to Region List, the files and regions appear as regions in the Region List.

**Importing Audio Files Using the Pro Tools Application Icon or Alias**

Audio files can be imported into a session using the Pro Tools application icon or alias.

**To import audio files into a session, using the Pro Tools application icon or alias:**

1. Open or create a new session.
2. From Windows Explorer or Macintosh Finder, locate the audio files you want to import.

Audio files must be in WAV, SD II, or AIFF/AIFC format in order to be dropped into Pro Tools.

Audio files will be converted if they are not of the correct bit depth or number of channels. They will be converted to mono files of the default audio file format, with the session’s bit depth and sample rate.
3. Drag the audio files onto the Pro Tools application icon or alias.

**Importing Audio Files and Regions with Drag & Drop**

You can drag and drop audio files or regions from a DigiBase browser or from Windows Explorer or the Macintosh Finder to the Timeline, a track, the Track List, or the Region List.

**To import audio into the Region List:**

1. Select files in a DigiBase browser, Windows Explorer, or Macintosh Finder.
2. Drag the files onto the Region List of the current session.

**To import audio into an existing track:**

1. Select audio files in a DigiBase browser or on the desktop.
2. Drag the files onto an existing track in the Edit window of the current session.

**To import audio into new tracks:**

1. Select audio files in a DigiBase browser, Windows Explorer or Macintosh Finder.
2. Do one of the following:
   - Shift-drag the files and drag them anywhere in the Edit window of the current session.
   - Drag the files onto any empty space in the Edit window of the current session.
   - Drag the files to the Track List.

For more information on using DigiBase browsers, refer to the DigiBase Guide.
Importing Audio from Audio CDs

Pro Tools lets you import tracks from audio CDs using the same methods that you use to import audio files, as follows

- Drag and drop CD audio from the CD folder.
- Drag and drop files from DigiBase Browser.
- Use the Import Audio to Track command.
- Use the Import Audio to Region List command.

Since the transfer is made in the digital domain, there is no signal loss.

The sample rate for audio CDs is 44.1 kHz. Therefore, if your session’s sample rate is set to 48 kHz or higher, Pro Tools will convert the sample rate for the imported audio. Before importing CD audio, set the Conversion Quality preference accordingly. See “Conversion Quality” on page 121 for details.

Before importing CD audio, make sure your hard drive has enough space for the converted audio files.

To import a CD audio track using the DigiBase Browser:

1. Insert the audio CD into your CD-ROM drive.

   If Autoplay is enabled, stop playback and close the application that is configured for Autoplay.

2. Choose Window > Workspace.

3. In the DigiBase browser, click on the CD and select the audio track.

4. Do one of the following:
   - Drag the file to the Region List to add it to the session.
   - Drag the file to a track to place (or spot) it in the track.
   - Drag the file to the Track List to add and create a new track.

   Pro Tools converts the CD audio track to the session’s audio file format, bit depth, and sample rate, and saves it on your hard drive.

The imported audio file appears in the Region List. From there you can drag the region to a track in your session.

Importing Tracks and Track Attributes

You can import entire tracks from other Pro Tools sessions into the current Pro Tools session using the Import Session Data command. With Pro Tools HD, you can choose which attributes of those tracks you want to import.

For example, with Pro Tools HD, you can choose to import only the track’s audio into your current Pro Tools session. This is analogous to “changing the tape reel” in a traditional studio setup with a tape machine and mixing console. Or, you can choose to import all of a track’s...
mixer settings without its audio, effectively importing a channel strip and using it on a track in your current session. By importing mixer settings for all of the tracks in a session or session template, you can reuse an entire Pro Tools mixer on all the sessions in a project.

To import tracks or their attributes:
1. Open or create a new session.
2. Choose File > Import > Session Data, select the session to import data from, and click Open.
   – or –
3. Drag the session file whose tracks or attributes you want to import from a DigiBase browser into the track playlist area in the current session’s Edit window or to the Track List.
4. In the Source Tracks section, select tracks to import by clicking the pop-up menu to the right of each track name and selecting Import As New Track.
5. With Pro Tools HD, for each track you select, you can choose to import it as a new track, or choose a destination track from the corresponding pop-up menu. Click Match Tracks to automatically match source and destination tracks with the same names.
6. With Pro Tools HD, select from among the Track Playlist options to choose how you want to import the source tracks.
7. If applicable, choose options for how media files should be imported from the Audio Media Options and the Video Media Options pop-up menus.
8. Choose the Time Code Mapping option for imported data.
9. If the sample rates of the sessions are different, select the sample rate for the source session from the Source Sample Rate pop-up menu.
10. To import the meter and tempo maps from the source session, select the Import Tempo/Meter Map option.
11. To import Markers and Memory Locations from the source session, select the Import Marker/Memory Locations option.
12. With Pro Tools HD, to import any Mix or Edit Groups from the source session, select the Import Mix/Edit Groups option.
13. With Pro Tools HD, to import any mic pre settings from the source session, select the Import Mic Pre Settings option.
14. Click OK when you are finished.
15. If you chose to copy or consolidate media, choose a location to place the media files.

⚠️ Imported tracks are made inactive if their source media is unavailable, or if the current session does not contain an equivalent output path.

⚠️ If the current Pro Tools system does not support surround mixing, surround tracks are not displayed in the Source Tracks list.
Importing Grouped Playlists from Other Sessions

You can import tracks that use Grouped Playlists from another Pro Tools session, and the playlist grouping function will remain intact for those imported tracks. There is, however, a restriction for importing from pre-Pro Tools 6.1 sessions: After importing a partial set of grouped playlists (such as tracks 1–7 of a 10-track group), you cannot subsequently import tracks 8–10 and have them “rejoin” the playlist group for tracks 1–7.

Import Session Data Dialog

The Import Session Data dialog lets you view the properties of the source session, select which tracks to import, and with Pro Tools HD, choose which attributes of those tracks you want to import into the current session.

Source Properties

The Import Session Data dialog displays properties for the source session. These properties include source session name, session type, start time of the session, audio bit depth, and sample rate. For Pro Tools 5.1 or higher sessions, the program that created the session and the session’s audio file type are listed.

Audio Media Options

Refer to Source Media (Where Possible) This option lets you avoid duplicating audio files by referring to the original files when possible. If the source files do not reside on supported playback media (such as a CD-ROM), or if they require bit depth or sample rate conversion, the source files are copied instead. This option allows the current session to refer to files that do not match the current session’s audio file format.
Copy from Source Media This option copies all audio files related to the imported tracks from the source media to a new specified location, and converts the files to the current session’s audio file format, bit depth, and sample rate if necessary. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place the audio files on a different hard drive.

Consolidate from Source Media This option consolidates audio while copying it. This is useful if you want to copy only the regions of the audio files used in the source tracks, without copying unused audio. This option copies and converts consolidated audio to the current session’s audio file format, bit depth, and sample rate if necessary.

When you choose this option, you can also choose the size of the handle (in milliseconds) applied to consolidated audio. Handle is the amount of the original audio file that is preserved before and after each region in case you need to make any edits to the new regions.

Force to Target Session Format This option copies and converts any files that do not match the current session’s file format, bit depth, and sample rate. Files that do match the current session’s file type, bit depth and sample rate are referred to directly and not copied.

Video Media Options
You can either choose to leave video media files in their original locations or copy them to a new location. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place video files on a different drive.

Time Code Mapping Options
You can specify where the imported tracks are placed in the current session. Times are indicated in time code for Pro Tools|HD and Pro Tools LE with DV Toolkit, and minutes:seconds for other Pro Tools LE systems.

Maintain Absolute Time Code Values This option places tracks at the locations where they were located in the source session. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session is 9 hours and 59 minutes after the start of the session.

Maintain Relative Time Code Values This option places tracks at the same offset from session start as they had in the source session. For example, if the source session starts at 01:00:00:00 and contains a track that starts at 01:01:00:00, and the current session start is 02:00:00:00, the track will be placed at 02:01:00:00 in the current session.

Map Start Time Code To This option places tracks relative to their original session start time. (With Pro Tools|HD or Pro Tools LE with DV Toolkit systems, times are expressed in hh:mm:ss:ff, and on Pro Tools LE systems, times are expressed in hh:mm:ss.) For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can reset the start time code to 00:01:00:00, to avoid placing files 9 hours and 59 minutes from the start of your session.
Track Offset Options

You can specify a track offset in addition to any offset incurred with the Time Code Mapping options. Any imported audio is offset in the current session’s timeline by the specified amount. You can enter values in Minutes:Seconds, Bars|Beats, Samples, Time Code, or Feet/Frames.

Sample Rate Conversion (SRC) Options

You can set options that control how sample rate conversion is applied to imported audio files. If the source session and the current session have the same sample rate, this portion of the dialog is unavailable.

Source Sample Rate For audio files created in any session, no matter what the session sample rate is, you can have the sample rate conversion process treat the files in several ways to compensate for pull-up, pull-down, and NTSC or PAL frame rates. This setting allows you to choose the sample rate from which you want the sample rate conversion process to start.

Destination Sample Rate The destination sample rate is always set to the sample rate of your current session.

Conversion Quality This option lets you set the quality of the sample-rate conversion process. See “Conversion Quality” on page 121.

Source Tracks This area of the dialog lists the tracks in the source session that can be imported, each with a corresponding pop-up menu.

Operation/Destination Track Pop-Up Menus

For each source track, there is a corresponding pop-up menu that lists options for importing the track and, with Pro Tools HD, possible destination tracks in the current session. The pop-up menus display the following items:

Do Not Import Neither the source track nor any of its attributes are imported.

Import as New Track The source track and all attributes selected in the Session Data to Import menu are imported into a new track in the current session.

(Destination Track Names) (Pro Tools HD Only)

The names of possible destination tracks in the current session are listed at the bottom of the pop-up menu. Imported playlists and all attributes selected in the Session Data to Import will be placed in the destination track you choose.

Only destination tracks that match the track type (audio, MIDI, Auxiliary Input, or Master Fader) and the channel format (mono, stereo, or any of the supported multichannel formats) of the source track appear in the pop-up menu.

Find Matching Tracks (Pro Tools HD Only)

If you are importing playlists from source tracks with the same name as destination tracks in the current session, click Find Matching Tracks to automatically match the track names. Tracks must have the same name, track type, and channel format to be automatically matched.
Session Data to Import
(Pro Tools HD Only)

The Session Data to Import menu is where you select which attributes of the selected tracks you want to import into the current session.

Replacing Track Attributes

When you import an attribute of the source track into an existing track in the current session, it replaces the corresponding attribute in the destination track. If you choose not to import an attribute of the source track, the corresponding attribute in the destination track is retained.

Selecting Track Attributes to Import

You can select All, None, or any combination of the listed attributes to import. The following attributes are available to import:

- All
- None
- Alternate PlayLists
- Regions and Media
- Volume Automation And Setting
- Pan Automation And Setting
- Mute Automation And Setting
- Main Output Assignments
- Send Output Assignments
- Plug-In Assignments
- Plug-In Settings And Automation
- HW Insert Assignments
- Voice Assignments
- Input Assignments
- Sidechain Assignments
- Track Active State
- I/O Labels
- Track Comments
- Record Safe / Solo Safe Settings
- Track View Settings
- Mix / Edit Groups

Replacing Track Path Names

When you import a track’s input, output, send output or hardware insert assignments, any custom path names and I/O configurations from the source session are not imported. You can import path names and I/O configurations by importing I/O Setup settings. See “I/O Settings Files” on page 81 for more information.

Session Data options in the Import Session Data dialog

The selected attributes are applied to all tracks that you choose to import into the current session.

Chapter 9: Importing and Exporting Session Data 129
**Mute Automation and Setting** Imports the source track’s Mute setting and any automation data on the track’s Mute Automation playlist. The Mute setting and any Mute automation data in the destination track are replaced.

**Main Output Assignments** Imports the source track’s channel output assignments, including any multiple output assignments. The channel output assignments in the destination track are replaced.

**Send Output Assignments** Imports the source track’s send output assignments. Any Send output assignments in the destination track are replaced.

**Plug-In Assignments** Imports the source track’s plug-in assignments. Any plug-ins in the destination track are removed, and their associated settings and automation are lost.

If the source track uses a plug-in that is not available on the destination system, it appears in the destination track and is made inactive.

**Plug-In Settings and Automation** When the source track’s plug-in assignments are imported, this option imports the track’s plug-in settings and any automation data associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**Hardware Insert Assignments** Imports the source track’s hardware Insert assignments. Any Insert assignments in the destination track are replaced.

**Voice Assignments** Imports the source track’s voice assignment from the source session. Any voice assignments in the destination track is replaced.

**Input Assignments** Imports the source track’s channel input assignment. The Input assignment in the destination track is replaced.

**Side-Chain Assignments** When the source track’s plug-in assignments are imported, this option imports any side-chain assignments associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**I/O Labels (Path Names)** Imports the source track’s path names.

**Track Active State** Imports the active/inactive state of the source track from the source session.

**Track Comments** Imports the track comments associated with the source track. Any comments in the destination track are replaced.

**Record Safe/Solo Safe Settings** Imports the record safe and solo safe settings of the source track from the source session. Any record safe or solo safe settings in the destination track are replaced.

**Track View Settings** Imports the track height and playlist view of the source track from the source session.

**Mix/Edit Groups:** Imports track groups from source track.

**Track Playlist Options** *(Pro Tools HD Only)*

You can select from the following options to control how the main playlist from each source track is imported to the destination track in the current session.

**Import Main Playlists — Replacing Destination Main Playlists** Imports the main playlist from the source track. When you import the playlist into an existing track, the main playlist in the destination track is deleted and replaced with the imported playlist.
Chapter 9: Importing and Exporting Session Data

If you select the above option and import all of the source track’s attributes, this is equivalent to importing the entire track.

If you select the above option and do not import any of the source track’s attributes, you replace the audio playlists while keeping your current mixer settings.

**Import Main Playlists—Overlaying New with Existing, Trimming Existing Regions** Imports the main playlist from the source track. When you import the playlist into an existing track, any existing playlist data that overlaps data imported from the source track is trimmed and replaced with the imported data. Any playlist data in the destination track that does not overlap remains in the destination track.

**Do Not Import Main Playlists—Leaving Destination Playlists Intact** Does not import the main playlist from the source track. No audio is imported; only the attributes selected in the Session Data to Import list are imported to the selected tracks.

If you select the above option and import all of the source track’s input, output, send, insert and plug-in attributes, this is equivalent to importing a channel strip.

**Import Tempo/Meter Map** Imports the meter and tempo maps, as they appear in the Tempo and Meter Conductor rulers, from the source session. Any Tempo or Meter events in the destination session are replaced.

**Import Marker/Memory Locations** Imports markers and Memory Locations as they appear in the Marker ruler, from the source session. Any markers and Memory Locations in the destination session are retained. Imported marker and Memory Locations are assigned the next available Marker/Memory Location numbers.

---

**Exporting Audio**

Pro Tools supports exporting regions as audio files, exporting left and right audio files as stereo interleaved files, and exporting region information.

You can also export audio from Pro Tools by bouncing or consolidating audio tracks. For more information, see “Consolidate Command” on page 348 and “Bounce to Disk” on page 574.

**Exporting a Region as a New Audio File**

You can export regions as audio files with the Export Regions as Files command. Use this command if you intend to use a region in other sessions (or other audio applications) without using its parent source file.

This command also provides a way to convert regions to a different audio format, sample rate, or bit depth.

To export regions as new audio files:

1. In the Region List, select the regions you want to export.

2. From the Region List pop-up menu, choose Export Regions as Files. The Export Selected dialog appears.
In the Export Selected dialog, set the file type, format, bit resolution, and sample rate. In addition, specify the Conversion Quality, and choose the destination directory.

When you export regions to a lower bit rate, Dither (with or without Noise Shaping) is applied as shown in Table 10.

The Dither setting used for any conversion is the Digidesign Dither plug-in (with or without Noise Shaping enabled, as noted in Table 10).

For more information about using Dither, see “Dither” on page 509.

Select an option for how Pro Tools should resolve duplicate file names.

**Prompting for Each Duplicate** Prompts you for a file name for any file that has the same name as a file in your destination directory.

**Auto Renaming** Automatically changes the name of any duplicate file by adding a number at the end of the file name (such as file_01).

**Replacing with New Files** Replaces files with the same name with the new files.

Once the Export Options are configured, click Export to export the new audio files.

### Exporting Stereo or Multichannel Interleaved Files

You can use the Export Regions as Files command to export audio regions to stereo or multichannel interleaved files for use in other applications. (Pro Tools cannot use interleaved files directly in the timeline—these must be converted into multi-mono files.) For example, for this to work with a stereo file, the selected re-
regions must have identical names with “.L” and “.R” suffixes (for instance, vocals_01.L and vocals_01.R). These regions appear as a stereo region in the Region List.

Pro Tools HD also lets you bounce multichannel interleaved files of any supported file type.

**To export regions as a stereo or multichannel interleaved file:**
1. Select the stereo or multichannel audio region in the Region List or in the track playlist. If the regions appear on mono tracks in the session, select the two mono regions.
2. From the Region List pop-up menu, choose Export Regions as Files.
3. In the Export Selected dialog, select “Stereo Interleaved” in the Format pop-up menu. For multichannel regions, the Stereo Interleaved option produces a multichannel interleaved file.
4. Configure any other output settings, then click Export to export the new stereo interleaved file.

**Exporting Region Definitions**

Pro Tools stores region definitions for audio files within each session. If you want to use an audio file’s regions in another session, or with another application that supports them, you can export the region information.

*If you plan to transfer Pro Tools session data to another session, you should export region definitions for sessions containing multiple takes created with Loop Record.*

The Export Region Definitions command does not export regions as audio files (unlike the Export Regions as Files command). Instead, it stores pointers to the regions within the parent source file.

**To export region definitions for an audio file:**
1. In the Region List, select any regions or region groups for which you want to export definitions. You do not have to select the parent file audio region.
2. Choose Export Region Definitions from the Region List pop-up menu.
3. Click Export.

**Exporting Pro Tools Tracks as OMFI or AAF Sequences**

With the DigiTranslator Integrated Option (DigiTranslator 2.0 or higher), Pro Tools lets you export individual tracks in OMFI format or AAF format. Use the Export Selected Tracks as OMF/AAF command.

*Pro Tools with DigiTranslator does not support AAF files with embedded media.*

*For more information on installing, using, or removing DigiTranslator with Pro Tools, refer to the DigiTranslator Guide.*

**Exporting Sessions as Text**

*(Pro Tools HD Only)*

You can use the Export Session Info as Text command to create a text file that contains extensive information about your session.

This text file can contain a list of audio files, audio regions, audio track EDL (Edit Decision List) information, extended timestamp information, and information about crossfades.
Track EDLs are exported as tab-delimited text—that is, with tabs between each column heading, and tabs between each event parameter. You can use this data in a program for reading EDLs, or you can format the EDL data into tables using a word processor or spreadsheet application.

### Export Session Info as Text Options

You can choose to export a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.

#### Include File List/Region List

You can choose to export a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.

#### Include Track EDLs (Playlists)

You can export track EDLs (playlists). Track EDLs can be used to spot-check region placement and edits, or in a conforming program for post applications. In extreme circumstances the EDL can be used to recreate the entire session.

**MIDI track EDLs are not exported.**

When exporting track EDLs, the following options are available:

**Show Subframes** This option allows you to export subframe time information with track EDLs, if used in your session.

**Include User Timestamps** You can include user timestamps with track EDLs. User timestamps indicate a user-defined session location for the region, or the original location of the region when recorded.

**Fade Handling** For track EDLs, you can choose whether to show crossfades, not to show them, or to combine crossfaded regions. When regions are combined, their durations and locations are listed up to the center of the crossfade (for the leading region) and from the center of the crossfade (for the following region).

**Time Format** You can select the appropriate time format that exported EDL information is based on. For example, for post work, you might select SMPTE time, but for music creation locked to a grid, you might select Bars & Beats.

#### File Format

You can choose to export to any of several different text formats. These include standard text formats, and Microsoft Word and Excel formats.
Exported Session Text

Session Information

The session text file starts with basic information about the session. This information includes the session name, sample rate, bit depth, time code format, and number of audio tracks, audio regions, and audio files, as shown in the following example.

<table>
<thead>
<tr>
<th>Session Information example</th>
</tr>
</thead>
<tbody>
<tr>
<td>SESSION NAME: Ripleys II-092700</td>
</tr>
<tr>
<td>SAMPLE RATE: 48000.000000</td>
</tr>
<tr>
<td>BIT DEPTH: 24-bit</td>
</tr>
<tr>
<td>TIME CODE FORMAT: 30 Frame</td>
</tr>
<tr>
<td># OF AUDIO TRACKS: 19</td>
</tr>
<tr>
<td># OF AUDIO REGIONS: 203</td>
</tr>
<tr>
<td># OF AUDIO FILES: 54</td>
</tr>
</tbody>
</table>

File List and Region List

Next, if you choose to include them, are the lists of audio files and regions.

Track EDLs

The final item, if exported, is the list of track EDLs. A track EDL lists the track name, and all edits, including the event number, the region name, region start and end time, and region duration. The region timestamp is also exported, if you select this option. Subframes are shown in each time field if you select this option.

To export a session as text:

1. Choose File > Export > Session Info as Text.
2. Select whether to include the File List, Region List, and track EDLs.
3. If you choose to include track EDLs, select whether to show subframes, and whether to include user timestamps. Also select an option for crossfade handling.
4. If you choose to include track EDLs, select the Time Format for the exported session text from the pop-up menu.
5. Select the File Format for exported text using the pop-up menu.
6. When you have set your options, click OK.
7. Select a location and enter a filename for the exported text file. In Windows, Pro Tools adds the correct 3-letter filename extension, while on the Macintosh, the file extension “.txt” is added.

Send via DigiDelivery

DigiDelivery is Digidesign’s system for efficient and reliable transfer of digital media files over the Internet. Send via DigiDelivery lets you send a Pro Tools session and all of its related files using DigiDelivery from within Pro Tools.

Anyone can send and receive files from a DigiDelivery system, even if they do not own a DigiDelivery network appliance, as follows:

- To send a delivery, senders must have an Internet connection, an account on a DigiDelivery network appliance, and the DigiDelivery client application.
To receive a delivery, recipients only need an Internet connection and the DigiDelivery client application. An account on the network appliance is not needed.

For more information, see the DigiDelivery Guide, or refer to the DigiDelivery Web site (www.digidesign.com/digidelivery).

To send a session from Pro Tools using DigiDelivery:

1. Choose File > Send via DigiDelivery.

2. If the DigiDelivery client is not installed on your system, Pro Tools will launch your Web browser, and connect to the DigiDelivery site where you can download the current DigiDelivery client.

   – or –

   If the DigiDelivery client is installed on your system, the Send to DigiDelivery dialog will open.

3. In the Send to DigiDelivery dialog, select which files to include.

   You have the option to include:
   • Audio files
   • Fade files
   • Video files
   • Plug-in settings files
   • Timeline files only (files that are referenced in the current session timeline)

4. Click OK. The DigiDelivery client will launch, and the DigiDelivery Send Wizard (Page 1) will open. On this page you can name the delivery and add or remove files.

5. Complete the remaining DigiDelivery Send Wizard pages and send the file, following the instructions that came with the DigiDelivery client software.

Importing MIDI Files

You can import Standard MIDI Files (SMF) into your Pro Tools sessions. Use the Import MIDI to Track command to place the imported MIDI onto new tracks; or use the Import MIDI to Region List command to place the data in the Region List, where it can be dragged to existing tracks.

Pro Tools does not import proprietary sequence files. To use sequences from other MIDI applications in a Pro Tools session, you will need to first save them as Standard MIDI Files. Refer to the manufacturer’s documentation for details on saving Standard MIDI Files.

There are two types of Standard MIDI Files, both of which are supported by Pro Tools:

• Type 0 MIDI files store data for all MIDI channels in a single track. When importing these files, Pro Tools separates the data by channel and places each track’s data in separate regions and tracks.

• Type 1 MIDI files, sometimes referred to as multitrack MIDI files, contain multiple tracks of MIDI data. When importing these files, each track’s data is placed on its own new MIDI track in the Pro Tools session.
To import a Standard MIDI File to new tracks:

1. Do one of the following:
   - Choose File > Import > MIDI to Track and select the MIDI file you want to import.
   - or –
   - Drag and drop a MIDI file from a DigiBase browser, Windows Explorer, or Macintosh Finder to the Track List, Timeline, or onto an existing track.

2. From the MIDI Input Settings dialog, configure the Import MIDI Settings as desired.

   ![Import MIDI Settings dialog]

   **Import Location** Select Session Start or Song Start. This option is available only if the Song Start Marker is not located at the session start (sample zero). The imported MIDI sequence will start at either at the Session Start time or the Song Start time accordingly.

   **Import Tempo Map From MIDI File** Enable this option to overwrite any existing tempo map with tempo information read from the MIDI file.

   **Remove Existing Instrument Tracks** Enable this option to delete any existing Instrument tracks. Enabling this option does not remove any current Instrument tracks. All existing MIDI regions will be left in the region bin.

   **Remove Existing MIDI Tracks** Enable this option to delete any existing MIDI tracks. Enabling this option does not remove any current Instrument tracks. All existing MIDI regions will be left in the region bin.

   **Remove Existing MIDI Regions** Enable this option to delete existing MIDI regions (thus all data on all MIDI and Instrument tracks) but leave existing MIDI and Instrument tracks in place.

3. Click OK.

   The MIDI file will be imported according to the settings in the Import MIDI Settings dialog.

   **If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.**

4. In the Mix window, click the MIDI Output selector for each new track and assign a MIDI instrument and channel.

To import a Standard MIDI File into the Region List, do one of the following:

- Choose File > Import > MIDI to Region List and select the MIDI file you want to import.
- or –
- Drag and drop a MIDI file from a DigiBase browser, Windows Explorer or the Macintosh Finder to the Region List.
Exporting MIDI Files

To export a session’s MIDI tracks for use in another MIDI application, or for playback with an external (hardware) MIDI sequencer, you can export Pro Tools MIDI and Instrument tracks as a Standard MIDI File.

MIDI can be exported from Pro Tools as a merged, single, multichannel track (Type 0), or as multiple tracks (Type 1).

To export all MIDI and Instrument tracks in the current session:

1. Make sure to unmute any MIDI tracks in the session that you want included in the exported MIDI file. (Or, conversely, mute any MIDI tracks you do not want included in the exported MIDI file.) For Instrument tracks, enable or disable the MIDI mute button (Instruments view) as desired.

2. Choose File > Export > MIDI. The Export MIDI Settings dialog opens.

3. From the MIDI File Format pop-up menu, select 1 (multi-track) or 0 (single-track).

4. If the Song Start time is different from the Session Start time, select Session Start or Song Start from the Location Reference pop-up menu.

5. Enable or disable the Apply Real-Time Properties option as desired.

6. Click OK. A Save dialog opens.

7. Specify a folder destination and name for the MIDI file.

8. Click Save.

Pro Tools exports all unmuted MIDI and Instrument tracks in the current session to a Standard MIDI File and writes it to your hard drive. Exported MIDI information includes notes, controller events, program changes, and System Exclusive data, as well as events for tempo, meter, and markers.

The SMPTE start time for the session or the song (depending on the selection from the Location Reference pop-up menu) is also exported. This ensures that the exported tracks, when played from another MIDI application, will align with the correct SMPTE frames, and also synchronize correctly to tape and video devices, or Pro Tools.

Refer to your third-party MIDI sequencer documentation to determine whether it supports importing SMPTE start times from MIDI files.

Not Exported with MIDI Files

Mute automation and muted regions do not affect exported MIDI. As long as a MIDI track is not muted by clicking its Mute button, or an Instrument track is not muted by clicking its MIDI mute button (Instruments view), all of its MIDI data is exported.

When exporting MIDI files from Pro Tools, device assignments for tracks are not retained (though channel assignments are). If you export MIDI or Instrument tracks from Pro Tools and later re-import them, you will need to reassign the tracks to devices in your studio.

All playlist information for MIDI and Instrument tracks is lost when exporting. For example, tracks that previously contained dozens of MIDI regions will be flattened and only contain single regions after exporting and re-importing.
Importing and Exporting Region Group Files

Pro Tools can export and import the new region group file format (.rgrp). This lets you do the following:

- Separate region group metadata from audio files to avoid unnecessary file copy operations when exporting audio region groups composed from multiple source files
- Export MID data as part of a region group
- Create multitrack loops

Region group files store the following metadata:

- References to all audio files within the region group
- Region names and relative location in tracks
- Fades and crossfades
- Region group names and format (single or multitrack)
- All MIDI data present in the region group (such as notes, controllers, and Sysex)
- Track names

Region group files do not store the following:

- Audio
- Automation
- Plug-ins
- Track routing
- Tempo and Meter map
- Region List information

To export a region group:

1. Select one or more region groups in the Region List.
2. From the Region List pop-up menu, choose Export Region Groups. The Export Region Groups dialog opens.

   ![Export Region Groups dialog]

3. The Destination Directory defaults to the auto-created Region Groups folder in the session folder. You can change the Destination Directory by clicking the Choose button, navigating to the desired location, and clicking Choose. Click Reset to reset the Destination Directory to the default location.

4. Enable one of the following options for resolving duplicate region group file names:
   - Prompting for Each Duplicate (default)
   - Auto Renaming
   - Replacing with New Files

5. Click OK.
To import a region group:

1. Choose File > Import > Region Groups.
2. Navigate to and select the desired region group for import.
3. Click Import.
   – or –

Drag and drop the region group file from a DigiBase browser or from the Windows Explorer or the Macintosh Finder to the Timeline, a track, the Track List, or the Region List.

Dropping a region group has the following different results depending on where you drop it:

- When dropping a region group in a track, Pro Tools checks for the matching track format, number of channels, and (in the case of multitrack region groups) if there are enough matching adjacent tracks to import the region group file. If these criteria match, the region group is imported and spotted to the drop location in the track or tracks.
- Dropping a region group on the Timeline or on the Track List creates new tracks for the imported region group.
- Dropping a region group in the Region List adds a new region group in the Region List. All audio and MIDI regions, and even other region groups, contained within the dropped region group also appear in the Region List.

Exporting Region Groups to Another Hard Drive

Generally, if you are exporting region groups to another hard drive, you should copy any referenced audio files. This way you can move region groups not only from one session to another, but from one system to another.

To export a region group to a different hard drive and include its audio files:

1. Export one or more region groups to the desired drive.
2. Create a new session on the new drive and enable the Automatically Copy Files on Import preference.
3. Import all previously exported region groups.

The audio files folder of the new session now contains all files referenced by the region groups.
Chapter 10: File and Session Management and Compatibility

When you work with Pro Tools, you will encounter several different kinds of computer files. Pro Tools systems require that you keep certain files in specific hard drive locations in order to function properly.

- Pro Tools software files should be located on your Startup drive (the drive that contains your operating system and other system-related files).
- On Pro Tools|HD systems, data files (session files, audio files and fade files) can be located on any compatible drive connected to the internal SCSI bus or the external SCSI bus of your computer, or to a SCSI host bus adapter card in your computer. For maximum performance, SCSI drives are recommended for Pro Tools|HD systems. FireWire and ATA/IDE drives are also supported. See the Digidesign Web site for more information (www.digidesign.com/compato).
- On Pro Tools LE systems, data files can be located on any compatible hard drive connected to your computer’s internal or external ATA/IDE, FireWire, or SCSI busses.

⚠️ Although Pro Tools will let you record to your system drive, this is generally not recommended. You should record to system drives only when necessary—for example, if your computer system has just one hard drive, or if your other hard drives are completely out of space.

Audio File Management

Unique File IDs

Pro Tools tags each audio file in a session with a unique identifier that allows it to distinguish a particular file even if its name or location has changed.

Locating Audio Files

With Pro Tools, you manage links to audio and other media files with the Relink window. In addition, Pro Tools classifies storage volumes according to their suitability for performance (recording or playback) or transfer (storage or copying) of audio and other media files. Audio files must be stored on suitable Performance volumes and be properly linked in order to be playable in a Pro Tools session.

For complete information on storage volume classifications, refer to the DigiBase Guide.

When you open a session, if Pro Tools determines that audio files are not located on a Performance volume, or if it is unable to locate audio files contained in the session, you can locate or copy the files in order to play back the session. This process is called relinking.
Transfer Files

Transfer files reside on volumes unsuitable for playback, such as CD-ROMs or network drives.

To open a session containing Transfer files:
1. Open the Pro Tools session. If any files are on a volume unsuitable for playback, Pro Tools posts a warning.
2. Do one of the following:
   - Click Yes to open the Copy and Relink dialog.
   - or –
   - Click No to open the session with all Transfer files offline.

To make Transfer files playable in the current session:
1. Choose Window > Project.
2. Double-click the Audio Files folder to display all of the audio files.
3. Choose Select Transfer Files from the Browser menu.
4. Choose Copy and Relink from the Browser menu.
5. Specify a location for the copied files on a valid Performance volume.
6. Click OK.

For complete information on relinking Transfer files, refer to the DigiBase Guide.

Missing Files

A file is missing if it is not found in the same location as when the session was last saved.

To open a session with missing files:
1. Open the Pro Tools session. If any files are missing, Pro Tools posts a Missing Files warning.
2. Choose one of the following options:
   - Skip All Ignores all missing files and fades. The missing files will be offline in the session.
   - Manually Find and Relink Opens the Relink window, where you can search, compare, verify, and relink missing files.
   - Automatically Find and Relink Searches all Performance volumes for all missing files with matching name, unique file ID, format, and length, and automatically commits links to missing files where possible.
3. To exclude fades from the relinking process, and have them recalculated instead, select Regenerate Missing Fades.
4. Click OK.

For complete information on relinking missing files, refer to the DigiBase Guide.

Renamed Audio Files

This folder includes file that have been renamed. Files can be renamed when you open a session that references audio file names with incompatible characters. Files can also be renamed in certain situations when saving a copy of a session to a Pro Tools version that does not support long file names.
Opening a Session that Contains Audio File Names with Illegal Characters

Pro Tools 7.0 does not support audio file names that contain certain ASCII characters (such as * and @).

When opening sessions that contain audio file names with illegal characters, Pro Tools automatically creates a renamed copy of each file that contains illegal characters (replacing these characters with an underscore "_"). Renamed files are copied to the Renamed Audio Files folder. The original files are left intact in the Audio Files folder.

Before the session opens, you are prompted to save a detailed report of the renamed files and their original file names to a Notes text file. Follow the on-screen instructions. By default, the Notes text file is saved to the Session folder.

⚠️ It is possible to have a Pro Tools 7.0 session that contains audio file names with illegal characters. In this case, if you Save Copy In the session to Pro Tools 6.9.x or lower with Mac/PC Compatibility on, the tracks will be renamed with legal characters. If you Save Copy In the session to Pro Tools 6.9.x or lower with Mac/PC Compatibility off, the characters are not changed.

Saving a Copy of a Session that Contains Long Audio File Names

When saving files to Pro Tools 6.9.x and lower (using Save Copy In), audio files with file names that exceed the limits of the destination format will be truncated and located in the Session folder, as follows:

- If the new session is saved to the same directory as the original the All Audio Files option is not checked, a new Session folder is created, which includes an Audio Files folder and a Renamed Audio Files folder. Renamed audio file will be included in the Audio Files folder.
- If the new session is saved to a different directory than the original and the All Audio Files option is checked, a new Session folder is created, which includes an Audio Files folder. Renamed audio files will be included in the Audio Files folder.

WAV File Compatibility

Convert Imported WAV files to AES31/BroadcastWave

Pro Tools always creates AES31/Broadcast compliant BWF (.WAV) files when the file originates in Pro Tools. This option makes imported WAV files compliant with the AES31/EBU Broadcast standard.

AES31/Broadcast Wave is a variant of the standard audio WAV file type. The AES31 format contains SMPTE time stamps and other information beyond the raw PCM audio data.

This variant complies with standards set by the EBU (European Broadcasters Union), and the AES (Audio Engineering Society). Choose this option to ensure compatibility with other workstations that recognize this file type.

To make imported WAV files compliant with the AES31/EBU Broadcast standard:

1. Choose Setup > Preferences and click the Operation tab.

2. Select Convert imported “wav” files to AES31/BroadcastWave, then click Done.
Sharing Sessions Created on Different Computer Platforms

Moving Windows-Based Sessions to Macintosh Systems

There are specific steps for transferring session files from Windows-based NTFS drives to Macintosh-based HFS+ drives.

Macintosh systems can read (but not write to) sessions located on Windows-based Fat 32 formatted drives.

To transfer Pro Tools Windows sessions from NTFS drives to HFS+ drives:

1. Set the MacDrive 6 Options to Backup/File Transfer.
2. Do one of the following:
   - Drag the session folder from the NTFS drive to the HFS+ drive.
   - Open the Windows session on the NTFS drive, choose Save Copy In, and save a copy of the session to the HFS+ drive.

Moving Macintosh-Based Sessions to Windows Systems

There are specific steps for transferring files from Macintosh-based HFS+ drives to Windows-based NTFS drives.

To save (or create) Macintosh sessions to be compatible on Windows systems, see “Saving Copies of Macintosh Sessions to be Compatible with Windows” on page 145.

The MacDrive 6 Utility is required to mount HFS+ drives on an NTFS system.
When transferring Pro Tools sessions from HFS+ drives to NTFS drives, the Pro Tools sessions are unable to relink to audio files and fades that have Macintosh characters that are illegal in Windows. These characters will automatically be converted to underscore ("_") characters. These files will be saved to the Renamed Audio Files folder. You will need to manually relink each file by File ID. See “Missing Files” on page 142.

To save session with no illegal characters, see “Saving Copies of Macintosh Sessions to be Compatible with Windows” on page 145.

If the session previously used SD II files, the files are converted to the new audio file format.

**Saving Copies of Macintosh Sessions to be Compatible with Windows**
*(Save Copy In to Pro Tools 6.9.x and Lower Only)*

Sessions created and saved as Pro Tools 7.0 sessions are always compatible on both Windows and Macintosh systems.

If you create a Pro Tools 6.9.x or lower session on a Macintosh system, the session will only be compatible on Windows systems if the Enforce Mac/PC Compatibility option is selected during the Save Copy In. In addition, there are cross-platform limits to consider when completing the Save Copy In.

**Cross-Platform Session Limits**

When saving (or creating) a copy of a Pro Tools session that you want to be compatible on both Macintosh and Windows, keep in mind the following limits and how Pro Tools deals with them:

### Audio File Types

The recommended file format for cross-platform interoperability is BWF (.WAV). To support optimal session interchange, Pro Tools defaults to BWF format for new sessions.

Pro Tools lets you save, bounce, and export in a variety of file formats. If you attempt to create a session and use the SD II format, however, a warning dialog will appear reminding you of its limitations:

- SD II is not supported on Windows XP
- The maximum sample rate for SD II files is 48 kHz.

### File Name Extensions

For cross-platform compatibility, all files in a session must have a 3-letter file extension added to the file name. Pro Tools 5.1 to 6.9.x session files have the extension ".pts," and Pro Tools 5 sessions have the extension ".pt5." Wave files have the ".wav" file extension, and AIFF files have the ".aif" file extension.

### Incompatible ASCII Characters

Region names, track names, file names, and plug-in settings cannot use ASCII characters that are incompatible with either system.

When you import files into a session, incompatible characters are converted to underscores ("_") and the renamed files are placed in the Renamed Files folder.

The following characters cannot be used in Windows sessions:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
Saving Cross-Platform Sessions

To save an existing session to Pro Tools 6.9.x or lower and maintain Macintosh and Windows compatibility:

1. Choose File > Save Copy In.

2. In the Save Copy In dialog, choose a destination and enter a name for the new session file.

3. Set the Audio File Type to AIFF or BWF (.WAV). These file formats are compatible with either platform.

4. Set the Sample Rate and Bit Depth for the session.

5. Select “Enforce Mac/PC Compatibility.” This option must be selected to make the session cross-platform compatible.

6. Select the Items to Copy to the new session.

7. Click Save.

If the session previously used SD II files, the files are converted to the new audio file format.

Pro Tools can convert a file created on a Macintosh and saved without the “Enforce Mac/PC compatibility” option selected to a Windows compatible file. For more information, see “Sharing Sessions Created on Different Computer Platforms” on page 144.

Sharing Sessions Created on Different Pro Tools Systems

(Pro Tools|HD, Pro Tools LE, and Pro Tools M-Powered)

Pro Tools makes it easy to share sessions between Pro Tools|HD systems and Pro Tools LE or M-Powered systems. There are some important differences between the three types of systems that can affect how session material is transferred.

Differences between Pro Tools systems

<table>
<thead>
<tr>
<th>Feature</th>
<th>Pro Tools</th>
<th>HD systems</th>
<th>Pro Tools LE or M-Powered systems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of audio tracks</td>
<td>up to 256</td>
<td>up to 128 tracks (32 voiceable)</td>
<td></td>
</tr>
<tr>
<td>Maximum number of Instrument tracks</td>
<td>128</td>
<td>32</td>
<td></td>
</tr>
<tr>
<td>Maximum number of mix busses</td>
<td>128 busses (Pro Tools 6.9 and higher)</td>
<td>32 busses (Pro Tools 7.0)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>64 busses (Pro Tools 6.7.x and lower)</td>
<td>16 busses (Pro Tools 6.9.x and lower)</td>
<td></td>
</tr>
<tr>
<td>Inserts per track</td>
<td>up to 5 inserts</td>
<td>up to 5 inserts</td>
<td></td>
</tr>
<tr>
<td>Sends per track</td>
<td>up to 10 sends (Pro Tools 7.0)</td>
<td>up to 10 sends (Pro Tools 7.0)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>up to 5 sends (Pro Tools 6.9.x and lower)</td>
<td>up to 5 sends (Pro Tools 6.9.x and lower)</td>
<td></td>
</tr>
</tbody>
</table>
Opening a Pro Tools HD Session in Pro Tools LE or M-Powered

When opening a Pro Tools HD session in Pro Tools LE or M-Powered, the following rules apply:

In Pro Tools LE or M-Powered 7.0:
- Any tracks beyond the first 32, as well any inactive tracks, are set to voice off.
- Any assignments to busses beyond 32 are made inactive.
- Any Instrument tracks beyond 32 are made inactive.
- TDM plug-ins with RTAS equivalents are converted; those without equivalents are made inactive.
- Multichannel surround tracks are removed from the session.
- Any sends beyond the first five are removed.
- Unavailable input and output paths are made inactive.

In Pro Tools LE 6.x and higher (Windows or Macintosh) or Pro Tools 5.3.1 and higher (Windows):
- Any tracks beyond the first 32, as well any inactive tracks, are set to voice off.
- Multichannel surround tracks are removed from the session.
- Any assignments to busses beyond 16 are made inactive, except for Pro Tools 7.0, which supports up to 32 busses.
- Any sends beyond the first five are ignored.
- Unavailable input and output paths are made inactive.
- TDM plug-ins with RTAS equivalents are retained; those without equivalents are made inactive.

Sharing Sessions Created on Different Pro Tools Software Versions

A Pro Tools 7.0 format session cannot be played on Pro Tools versions 6.9.x or lower. To save a Pro Tools 7.0 session that is compatible with previous versions of Pro Tools, use the File > Save Copy In command to choose the destination session format. “Saving a Copy of the Session” on page 50.

When saving a session to Pro Tools 5.1 -> 6.9 format, the following occurs:
- Fader Gain levels and automation breakpoints higher than +6 dB will be changed to +6 dB.
- Long names will be shortened to 31 characters.
- Instrument tracks will be split into separate Auxiliary Input and MIDI tracks.
- The following attributes will be dropped.
  - Region groups
• Region loops
• Sample-based MIDI regions
• Sample-based MIDI tracks
• Sends F–J and any associated automation
• Marker/Memory Locations 201–999
• Busses 17–32 (Pro Tools LE and Pro Tools M-Powered)

When saving a session to Pro Tools 5.0 format, the following occurs:
• Long names will be shortened to 31 characters.
• Instrument tracks will split into separate Auxiliary Input and MIDI tracks.
• The following attributes will be dropped.
  • Region groups
  • Region loops
  • Sample-based MIDI regions
  • Sample-base MIDI tracks
  • Sends F–J and any associated automation
  • Marker/Memory Locations 201–999
  • Busses 17–32 (Pro Tools LE and Pro Tools M-Powered)
  • Multi-mono plug-in instances
  • Multichannel tracks (Pro Tools HD only)
  • Sends assigned to multichannel paths or subpaths of multichannel paths
• Tracks assigned to “No Output” will be routed to Busses 31 and 32.
• Tracks/sends assigned to Busses 33–64 will be routed to Busses 31 and 32.
• Tracks assigned to multichannel paths or subpaths of multichannel paths will be routed to Busses 31 and 32.
• Tracks/sends assigned to stereo paths referring to even/odd channels (such as 2–3) will be routed to Busses 31 and 32.

---

**Multilingual Application Support for Pro Tools|HD Systems**

*(Localized OS on Mac OS X Only)*

An English and localized version of Pro Tools (such as Pro Tools Korean, simplified Chinese, or Japanese) can now be opened on a Digidesign-qualified Macintosh that can run English and the localized language versions of Mac OS X. Only one language version of Pro Tools can be open at a time.

**To change to a different language version of Pro Tools:**

1. Close Pro Tools if it is currently open.
2. Launch Apple System Preferences.
3. Double-click International (the “flag” icon).
4. Click the Language tab if the Language page is not the current page.
5. In the Languages column, click the language you want to change to, and drag the language to the top of the list.
6. Close the International window.
7. Do one of the following:
   • If you are changing from a localized language to English, launch Pro Tools.
     – or –
   • If you are changing from one localized language to another (or from English to a localized language), log out and log in from the Apple menu, then launch Pro Tools.

*If you want your computer to start with the previous language (after working on a different language version) follow the above steps and change the International preference back to the previous language.*
Part III: Recording
Chapter 11: Record Setup

Before you start recording, make sure your Pro Tools system is connected and configured properly. For details on connecting Pro Tools to your studio, refer to the Getting Started Guide that came with your system.

While some of the information in this chapter is relevant to recording MIDI, there are more specific setup details for MIDI recording in Chapter 13, “MIDI Recording.”

Input Connections and Audio Levels

Pro Tools|HD audio interfaces operate as line-level devices and offer no pre-amplification. Low-level sources like microphones and electric guitars need to be pre-amplified. You can do this with a quality mixing board or dedicated preamp (such as the Digidesign PRE).

The Digidesign PRE can be used as a stand-alone preamp with all Pro Tools systems, or it can be remote-controlled from within a Pro Tools session when used with a Pro Tools|HD system.

The Digi 002 and Digi 002 Rack have four inputs with preamps, to which you can connect low-level signals, and four additional line-level inputs with switchable gain.

Mbox 2 and Mbox have two inputs with preamps, to which you can connect low-level signals.

For input information on Digidesign-qualified M-Audio units, refer to your M-Audio documentation.

For all systems, volume and pan controls for tracks in Pro Tools only affect monitoring levels—not the recording input gain. The LED meters on Digidesign audio interfaces indicate both full-code (highest level before clipping) and true clipping of Pro Tools output signals. The on-screen meters in Pro Tools indicate only true clipping.

Digital Clipping

Clipping occurs when you feed a signal to a recorder or mixer that is louder or “hotter” than the device allows. On many analog tape decks, a little clipping adds a perceived warmth to the sound due to tape compression. In digital recording, however, clipping causes digital distortion, which is undesirable and should always be avoided.
Set Input Levels High But Not High Enough to Clip

When you feed a signal into any audio recording system, including Pro Tools, make sure to adjust the input level to optimize the dynamic range and signal-to-noise ratio of the recorded file. If the input level is too low, you will not take full advantage of the dynamic range of your Pro Tools system. If the input level is too high, the waveform will be clipped, distorting the recording.

Try to set levels so that they register within the top 6 dB of the input meter without triggering the clipping indicator on your audio interface.

Calibration Mode

(Pro Tools HD Only)

You can use the Calibration mode in Pro Tools to adjust the input and output levels for your audio interface so they match those of your mixing console and other audio devices in your studio.

The 192 I/O has two sets of adjustable trim pots for its inputs, and two sets of adjustable trim pots for its outputs. Additionally, the reference level for the input can be set to +4 dBu or −10 dBV. The 888|24 I/O has adjustable trim pots for its inputs and outputs.

Record Enabling Tracks

To record to a track you must first record enable it with the Record Enable button. To record simultaneously to multiple tracks, you can record enable multiple audio, Instrument, or MIDI tracks.

When one or more tracks are record-enabled, you can click the Record and Play buttons in the Transport window to start recording.

MIDI and Instrument tracks can be record-enabled during playback or record. To record enable audio tracks, the Transport must be stopped, or TrackPunch or QuickPunch must be enabled. For information on TrackPunch, see “TrackPunch Audio Recording” on page 208. For information on QuickPunch, see “QuickPunch Audio Recording” on page 205).
To record enable an audio, MIDI, or Instrument track:

■ From either the Mix or Edit window, click the track’s Record Enable button to toggle record enable on or off for the track. The Record Enable button is lit when on; also, in the Mix window, the track’s fader is highlighted.

To record enable multiple audio tracks:

■ From either the Mix or Edit window, click each audio track’s Record Enable button to toggle record enable on or off for each track.

To record enable multiple MIDI and Instrument tracks:

■ From either the Mix or Edit window, Shift-click each MIDI or Instrument track’s Record Enable button to toggle record enable on or off for each track.

To record enable MIDI and Instrument tracks using the Up/Down Arrows:

■ While pressing Control (Windows) or Command (Macintosh), press the Up/Down Arrows to record enable the previous or next MIDI or Instrument track. The previous (or next) record track is no longer record-enabled.

To record enable all audio, or MIDI and Instrument tracks:

■ Alt-click (Windows) or Option-click (Macintosh) the Record Enable button to toggle record enable on or off for all audio, or Instrument and MIDI tracks.

For record-enable, Pro Tools treats MIDI and Instrument tracks as the same type. Consequently, Alt-clicking (Windows) or Option-clicking (Macintosh) the Record Enable button on any MIDI or Instrument track will record enable all MIDI and Instrument tracks.

To record enable all selected audio, or MIDI and Instrument tracks:

■ Alt-Shift-click (Windows) or Option-Shift-click (Macintosh) the Record Enable button on any selected audio, or MIDI or Instrument track to toggle record enable on or off for all selected audio, or MIDI and Instrument tracks.

Record-enabled audio track in Mix and Edit windows

To keep the previous track record-enabled while enabling new tracks, press Shift+Control+Up/Down (Windows) or Shift+Command+Up/Down (Macintosh).

To record enable multiple MIDI and Instrument tracks:

■ From either the Mix or Edit window, Shift-click each MIDI or Instrument track’s Record Enable button to toggle record enable on or off for each track.

If Latch Record mode is not enabled, Shift-click each track’s Record Enable button to toggle record enable on or off for each track.

See “Latch Record Enable Buttons Preference” on page 154.

To record enable multiple MIDI and Instrument tracks:

■ From either the Mix or Edit window, Shift-click each MIDI or Instrument track’s Record Enable button to toggle record enable on or off for each track.

While record enabling does not affect audio tracks that are grouped, you can select all tracks in a group by clicking directly to the left of the group’s name in the Group List. Then you can Shift-Alt-click (Windows) or Shift-Option-click (Macintosh) the Record Enable button of one of the tracks to record enable all selected tracks.
Latch Record Enable Buttons Preference

When the Latch Record Enable Buttons preference is selected, you can record enable additional audio tracks by clicking their Record Enable buttons. Previously record-enabled tracks will remain enabled. The Latch Record Enable Buttons preference affects audio tracks only.

When Latch Record Enable Buttons is deselected, record enabling a subsequent audio track will make the previously record-enabled audio track no longer record-enabled.

To enable the Latch Record Enable Buttons preference:
1. Choose Setup > Preferences and click the Operations tab.
2. Select Latch Record Enable Buttons.

Record Safe Mode

Pro Tools provides a Record Safe mode on a per track basis that prevents tracks from being record-enabled. Use Record Safe mode to protect important track recordings.

To put an audio or MIDI track in Record Safe mode:
- Control-click (Windows) or Command-click (Macintosh) the track’s Record Enable button. The Record Enable button is greyed out.

Control-click (Windows) or Command-click (Macintosh) again to take the track out of Record Safe mode.

To put all tracks in Record Safe mode:
- Control-Alt-click (Windows) or Command-Option-click (Macintosh) the Record Enable button on any track.

Control-Alt-click (Windows) or Command-Option-click (Macintosh) again to take all tracks out of Record Safe mode.

To put all currently selected tracks into Record Safe mode:
- Control-Alt-Shift-click (Windows) or Command-Option-Shift-click (Macintosh) the Record Enable button on any of the selected tracks to toggle them in and out of Record Safe mode.

Record Monitoring Modes

Pro Tools offers two modes of input monitoring: Auto Input and Input Only. These monitoring modes determine how input signals are monitored during playback, record, or while the transport is stopped.

Auto Input Monitoring

In Auto Input mode, when session playback is stopped, Pro Tools monitors audio input. When playback is started for a punch-in, Pro Tools monitors existing track material up until the punch point. While punched in, the input signal is monitored. On punch-out, monitoring switches back to the existing track material. This is similar to the auto-switching logic found on digital and analog multitrack tape machines.

When using Auto Input, the switch back to monitoring track material on punch-out is not instantaneous.

With Pro Tools HD, tracks are in Auto Input mode by default, and a monitoring control (TrackInput button) is provided for each track. See “Selecting Record Monitor Modes with TrackInput Monitoring” on page 155.
Input Only Monitoring

In Input Only mode, when a track is record-enabled, Pro Tools monitors audio input only, regardless of any punch-in/out selection or state.

For Pro Tools LE, the Input Monitor Enabled Status indicator (in the Transport window) lights green when Input Only mode is enabled.

For Pro Tools HD, the indicator lights green when one or more tracks have TrackInput enabled.

Selecting a Record Monitor Mode in Pro Tools LE

For record-enabled tracks to use Auto Input Monitoring:
■ Select Track > Auto Input Monitoring.

For record-enabled tracks to use Input Only Monitoring:
■ Select Tracks > Input Only Monitoring.

To toggle between Auto Input and Input Only monitoring, press Alt+K (Windows) or Option+K (Macintosh).

Selecting Record Monitor Modes with TrackInput Monitoring

(Pro Tools HD Only)

TrackInput monitoring lets you toggle individual audio tracks between Auto Input and Input Only monitoring modes at any time, during playback, recording, stop, and even when a track is not record-enabled. TrackInput monitoring provides the monitoring flexibility needed in overdubbing and mixing, and is similar to the input switching on analog multitrack recorders and similar machines.

When the TrackInput button in a track is enabled (green), the track monitors audio in Input Only mode.

When the TrackInput button in a track is disabled, the track monitors in Auto Input mode.

To toggle the monitoring mode of audio tracks do one of the following:
■ To toggle individual tracks, click the TrackInput Monitor button for each track you want to toggle.
■ To toggle all tracks in the session, Alt-click (Windows) or Option-click (Macintosh) a TrackInput Monitor button.
■ To toggle all selected tracks in the session, Alt-Shift-click (Windows) or Option-Shift-click (Macintosh) a selected track’s TrackInput Monitor button.
To toggle the TrackInput button states of all record-enabled tracks, do one of the following:

- To change all record-enabled tracks to Auto Input monitoring, select Track > Set Record Tracks to Auto Input.
- To change all record-enabled tracks to Input Only monitoring, select Tracks > Set Record Tracks to Input Only.

To toggle record-enabled tracks between Auto Input and Input Only monitoring, press Alt+K (Windows) or Option+K (Macintosh).

Disable “Input” When Disarming Track

With this Operation preference checked, Track-Input monitoring will be disabled whenever deselecting a track’s record Enable button. This is useful for certain workflows, such as when you are recording on a series of tracks, one at a time.

Disabling this option allows TrackInput buttons to remain enabled when deselecting the track’s Record Enable button.

Monitor Levels for Record and Playback

Pro Tools remembers two different fader levels for monitoring each audio track: one for when the track is record-enabled, and one for when it is not record-enabled.

Pro Tools remembers these two states for fader levels automatically. If you adjust a fader when a track is record-enabled and then turn off record enable for the track, the fader returns to its playback level.

When audio tracks are record-enabled, their volume faders in the Mix window turn red, indicating that the record monitor level is active.

Link Record and Play Faders

When the Operation preference for “Link Record and Play Faders” is selected, Pro Tools does not keep track of record and play levels for audio tracks. In this case, record enabling an audio track has no effect on the fader level for the track. This lets you maintain a consistent mix regardless of whether you’re recording or just listening.

Monitoring Latency

(Pro Tools LE)

Because Pro Tools LE uses the host processor in your computer for all audio processing, playback and recording, there is a small amount of audio delay, or latency, in the system. This latency amount is related to the H/W Buffer Size—the larger the buffer size the larger the latency.

You can reduce the amount of monitoring latency for Pro Tools LE systems by reducing the H/W Buffer Size. However, even at the smallest buffer size, there is still some latency. In addition, reducing the buffer size limits the number of simultaneous audio tracks you can record without encountering performance errors.

While there may be times when you want a larger buffer size, for the sake of higher track counts with more plug-ins, you’ll generally want a smaller buffer size when recording audio that is monitored through your Pro Tools LE system.

If you are monitoring the recording source with an external mixer, before it is routed to Pro Tools, you will not hear any latency.
To set the Hardware Buffer Size:

2. Choose the number of samples from the H/W Buffer Size pop-up menu.
3. Click OK.

⚠ Computers with slower CPUs may not be able to use the 128 buffer size without encountering performance errors.

Zero Latency Monitoring
(Mbox 2 and Mbox Only)

Mbox 2 and Mbox give you the ability to monitor your analog input signals while recording, without hearing any latency. This zero-latency analog monitoring is controlled by the front panel Mix knob, which you can use to blend and adjust the ratio between the interface’s analog input and Pro Tools playback. For more information, refer to your system’s Basics Guide or its Getting Started Guide.

Low Latency Monitoring
(Digi 002 and Digi 002 Rack Only)

Digi 002 and Digi 002 Rack systems can use the Low Latency Monitoring option to record with an extremely small amount of monitoring latency, to as many tracks as each system supports.

To use Low Latency Monitoring:

1. Record enable audio tracks by clicking their Record Enable buttons. Only tracks with inputs set to an audio interface (not a bus) use Low Latency Monitoring.
2. From the Output Path selector, assign each track to either Output 1 or Output 2. Only tracks assigned to these outputs use Low Latency Monitoring.
3. Select Options > Low Latency Monitoring.

When Low Latency Monitoring is enabled, any plug-ins and sends assigned to record-enabled tracks (routed to Outputs 1–2) are automatically bypassed, and must remain bypassed. Also, these tracks will not register on meters for Master Faders.

Low Latency Monitoring and Bounce To Disk

With Low Latency Monitoring enabled, only audio tracks are included with the Bounce to Disk command—Auxiliary Input and Instrument tracks are ignored. To include Auxiliary Input and Instrument tracks, turn off Low Latency Monitoring before the Bounce to Disk.

⚠ External input cannot be recorded during a Bounce to Disk. To include external input in your bounce, it must be recorded to new audio tracks before the Bounce to Disk (see “Recording to Tracks” on page 573).

Low Latency Monitoring with Delay Compensation
(Pro Tools HD Only)

If you choose to record with Delay Compensation active, Pro Tools automatically suspends Delay Compensation for tracks that are “punched in” or monitoring input. In either of these cases, no compensating delay is added to the track, and the Track Compensation indicator displays zero.

Delay Compensation should be enabled whenever possible during mixing and playback. In some cases when recording, Delay Compensation should be turned off.
The automatic suspension of Delay Compensation on record-enabled tracks during recording can be defeated on a per-track basis, regardless of record status or input mode.

For information about defeating suspended Delay Compensation, see “Low Latency Monitoring During Recording” on page 507.

**Default Track Names**

When creating new audio, Auxiliary Input, Master Fader, MIDI, and Instrument tracks, Pro Tools names them as “Audio,” “Aux,” “Master,” “MIDI,” or “Inst” accordingly and numbers them consecutively. For example, when you create two new audio tracks, their default names are “Audio 1” and “Audio 2.” You can rename tracks and also log comments for each track.

Track names define new file and region names when recording to a track. See “Naming Tracks” on page 94.

**Default Names for Audio Files and Regions**

When recording to an audio track, the resulting file and region names are based on the name of the track. For example, after recording for the first time on a track called “Electric Gtr,” an audio file is created with the name “Electric Gtr_01.” In addition, a region appears in the Region List with the name “Electric Gtr_01.” This region is a whole-file region.

Subsequent record takes on the same track are named identically, but the digits (indicating the take number) are incremented (for example, “Electric Gtr_02.”) A second set of digits (such as used in “Electric Gtr_01-01”) indicates a region auto-created from an edit.

TrackPunch and QuickPunch modes use a different method for numbering regions. For details, see “Region and Take Numbering with QuickPunch” on page 208.

When recording MIDI tracks, a similar naming scheme is used, though with only one set of digits. For example, after recording to a track called “Synth 1,” a region is created called “Synth 1-01.” Subsequent regions for that track, generating either from additional record takes or region edits, are numbered sequentially (for example, “Synth 1-02”).

**Names for Stereo Audio Tracks**

When recording to stereo audio tracks, audio file and region names for the left and right channels are appended with a “.L” and “.R” suffix.
**Names for Multichannel Tracks**  
*(Pro Tools HD Only)*

When recording to multichannel surround tracks, audio file and region names for each channel are appended with the following suffixes.

<table>
<thead>
<tr>
<th>Multichannel Format</th>
<th>File and Region Suffixes</th>
</tr>
</thead>
<tbody>
<tr>
<td>LCR</td>
<td>L, C, R</td>
</tr>
<tr>
<td>Quad</td>
<td>L, R, Ls, Rs</td>
</tr>
<tr>
<td>LCRS</td>
<td>L, C, R, S</td>
</tr>
<tr>
<td>5.0</td>
<td>L, C, R, Ls, Rs</td>
</tr>
<tr>
<td>5.1</td>
<td>L, C, R, Ls, Rs, LFE</td>
</tr>
<tr>
<td>6.0</td>
<td>L, C, R, Ls, Cs, Rs, LFE</td>
</tr>
<tr>
<td>6.1</td>
<td>L, C, R, Ls, Cs, Rs</td>
</tr>
<tr>
<td>7.0</td>
<td>L, Lc, C, R, Rc, Ls, Rs</td>
</tr>
<tr>
<td>7.1</td>
<td>L, Lc, C, R, Rc, Ls, Rs, LFE</td>
</tr>
</tbody>
</table>

**Disk Allocation**

By default, Pro Tools records audio files to the Audio Files folder inside the session folder. You can use the Disk Allocation window to specify other locations for your audio files for each audio track.

Hard drives that are full do not appear in the Disk Allocation window.

To increase system performance, Pro Tools can record and play each track from a different hard drive. You can also automatically distribute any newly created tracks to multiple audio drives with Round Robin Allocation.

**Navigating in the Disk Allocation Window**

To resize the Disk Allocation window:

- Drag the lower-right corner of the window according to standard convention for your operating system (Windows or Macintosh).

To scroll up or down in the Disk Allocation window:

- Press Page Up or Page Down.

**Allocating Audio Drives in Your System**

To allocate the audio drives in your system:

2. In the Disk Allocation window, assign a hard drive for each track by clicking in the Root Media Folder column and selecting a volume from the Disk Allocation pop-up menu.

**Disk Allocation window**

Only drives designated as R (Play and Record) can be selected in the Disk Allocation window. For more information, see the *DigiBase Guide*.

**Disk Allocation pop-up menu**
A folder with the session name is created on each hard drive, containing subfolders for audio and fade files.

- To assign a track to a different hard drive, click the track and select a drive name.
- To assign all tracks to the same hard drive, press Alt (Windows) or Option (Macintosh) while selecting a drive name.
- To make a continuous selection, Shift-click a track name (in the Track column) to extend the selection to include already-selected tracks and all tracks in between.
- To make a non-contiguous selection, Control-click (Windows) or Command-click (Macintosh) a track name in the Track column to extend the selection to include already-selected tracks without including tracks in-between.

3 To save recorded audio files to an existing folder (without creating another session folder), select Customize Allocation Options, then click the Change button and choose the folder. To create subfolders in this folder, select “Create Subfolders for audio, video, and fade files.”

4 To automatically distribute any newly created tracks among the drives connected to your system, select “Use Round Robin Allocation for New Tracks.”

If you are using Round Robin Allocation and want audio to be recorded to your system’s start-up drive, do the following:

- Open the Workspace browser (Window > Workspace) and set the Volume Designator for your system volume to R (Record and Playback). See “Workspace Volume Designation” on page 161.

⚠️ Round Robin Allocation is not supported with partitioned hard drives.

If you want to exclude individual, valid, mounted volumes from Round Robin Allocation passes, open the Workspace browser and make the volume safe, by designating it as P (Playback only) or T (Transfer).

5 When you are finished, click OK.

**Saving Disk Allocation Settings**

To save Disk Allocation settings for use with future sessions, save the session as a template. For details, see “Creating Custom Session Templates” on page 53.

**Disk Allocation and Cross-Platform Sessions**

To ensure cross-platform operation, it is required that Macintosh Pro Tools sessions and their associated audio files be on Macintosh-formatted (HFS or HFS+) drives. Windows Pro Tools sessions and their associated audio files must be on Windows-formatted (NTFS or FAT32) drives.

⚠️ See “Saving Copies of Macintosh Sessions to be Compatible with Windows” on page 145 and “Sharing Sessions Created on Different Computer Platforms” on page 144.
Reallocation Tracks

When opening a session where some of the previously assigned hard drives are no longer available (or do not match the current session platform), Pro Tools automatically reassigns tracks to the volume where the session file is stored. In such cases, use Disk Allocation if you need to reallocate tracks to other drives.

Workspace Volume Designation

The Workspace volume designation can alter disk availability, thus affecting Disk Allocation. From the Workspace browser, you may designate volumes as Record, Playback, or Transfer. If you change a drive’s designation, making it read-only (Play Only or Transfer), you will need to check the Disk Allocation for any tracks formerly allocated to that drive. For more information, see the DigiBase Guide.

Recording to the System Volume

Though Pro Tools will let you record to your system volume, this is generally not recommended. Performance for audio recording and playback on system drives is worse than on non-system hard drives.

You should record to system drives only when absolutely necessary—if your computer system has just the one hard drive, or if your other hard drives are completely out of space.

By default, the system volume is not included in Round Robin Allocation (regardless of volume designation in the Workspace browser). To include the System Volume in Round Robin Allocations, see “To allocate the audio drives in your system:” on page 159.

Allocating Hard Drive Space for Recording

The Operation preference for Open Ended Record Allocation determines how much of your available hard drive space is allocated whenever you record into one or more tracks in Pro Tools.

When this allocation preference is set to Use All Available Space, the drive’s entire available space is allocated. This setting lets you record lengthy takes, or longer sessions.

However, when allocating all available space, Pro Tools may take a little longer to begin recording. You can reduce this delay by allocating a specific amount of time for recording.

You can also avoid recording delays by putting Pro Tools in Record Pause mode before beginning to record. See “Record Pause Mode” on page 173.

In general, the Use All Available Space preference makes hard drives work harder. In addition to record and punch lag times, many system see better overall recording performance when the Open Ended Record Allocation is limited.
To allocate a specific amount of time to recording:

1. Choose Setup > Preferences and click the Operation tab.
2. Under the Open Ended Record Allocation option, select Limit To and enter the number of minutes to be allocated.
3. When you are finished, click Done.

Monitoring Drive Space

To monitor available space on your drive during a Pro Tools session:

- Choose Window > Disk Space.

To display available drive space in different view formats:

- Choose View > Disk Space, and select a format (Text View or Gas Gauge).

Record Modes

For recording audio, Pro Tools has the following record modes:

- Nondestructive Record (default)
- Destructive Record
- Loop Record
- QuickPunch
- TrackPunch (Pro Tools HD only)

To enable Destructive Record, Loop Record, QuickPunch or TrackPunch, select them from the Options menu. If none of these record modes are selected, Pro Tools is in normal Nondestructive Record mode.

Nondestructive Record Mode

In normal Nondestructive Record mode, Pro Tools records audio nondestructively, which means that if you record over a track's existing regions, the audio is not erased from your hard drive. Both the new and old audio files remain on your hard drive, available as regions from the Region List.

When recording, you can preserve disk space by removing unwanted record takes (see “Removing Unwanted Regions” on page 352) and compacting audio files (see “Compacting an Audio File” on page 349).
In Nondestructive Record mode, the record range can be defined by selecting a range in a ruler or in a track’s playlist, or by specifying start and end points in the Transport window. If there is no selection, recording begins from the current Cursor location and continues until the Transport’s Stop button is clicked.

To set a record range by selecting within a track’s playlist, the Timeline and Edit selections must be linked. See “Linking or Unlinking Timeline and Edit Selections” on page 272.

The pre- and post-roll settings allow material to be heard up to and after the start and end points, which is useful when punch recording (see “Punch Recording Audio” on page 176).

Destructive Record Mode

In Destructive Record mode, recording over existing regions replaces the original audio permanently, which allows you to keep disk use to a minimum. However, if you have sufficient drive space, it is usually best to use Pro Tools in Nondestructive Record mode, to avoid losing any previously recorded material.

When defining the record range and setting pre- and post-roll, Destructive Record mode works the same as Nondestructive mode.

Unlike the other record modes, it is not possible to cancel or Undo record takes when using Destructive Record mode (see “Canceling a Record Take” on page 172).

In Destructive Record mode, the waveform overview is not redrawn until you stop recording.

Loop Record Mode

Loop Record mode allows you to record take after take (nondestructively) while the same section of audio repeats. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

The time range that is looped and recorded—which must be at least one second in length—is defined by selecting a range in a ruler or in a track’s playlist, or by specifying start and end points in the Transport window. The pre-roll setting, if enabled, is used during the first record pass, but on each successive loop the pre- and post-roll times are ignored.

To set a record range by selecting within a track’s playlist, the Timeline and Edit selections must be linked. See “Linking or Unlinking Timeline and Edit Selections” on page 272.

When using Loop Record mode, each successive take appears as a region in the Region List and each is numbered sequentially. The various takes, which are identical in length and start time, are easily auditioned and placed in the track at the correct location with the Takes List pop-up menu (see “Auditioning Different Record Takes in the Timeline” on page 178).

In Loop Record mode, the waveform overview is not redrawn until you stop recording.

QuickPunch

QuickPunch gives you the ability to manually and instantaneously punch in (initiate recording) and punch out (stop recording) on record-enabled audio tracks during playback by clicking the Transport’s Record Enable button. Recording with QuickPunch is nondestructive.
When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating regions in that file at each punch in/out point. These regions appear in the track’s playlist; and the complete audio file appears in the Region List along with the QuickPunch created regions. Up to 200 of these “running punches” can be performed in a single pass.

Though you can punch record in the other record modes by manually specifying the record range, only QuickPunch provides instantaneous monitor switching on punch-out.

⚠️ In QuickPunch mode, the waveform overview is not redrawn until you stop recording.

**TrackPunch (Pro Tools HD Only)**

TrackPunch lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

TrackPunch is a non-destructive recording mode. When a track is TrackPunch-enabled, Pro Tools begins recording a new file when playback begins. During playback, you may record arm or disarm, or punch in or out a combination of any or all TrackPunch enabled tracks.

TrackPunch automatically creates regions in that file at each punch-in and punch-out point. These regions appear in the track’s playlist, and the complete audio file appears in the Region List along with the TrackPunch created regions. Up to 200 of these “running punches” can be performed in a single pass.

---

**Record Modes and MIDI**

In addition to the various record modes, there is also a MIDI Merge button in the Transport window that determines how MIDI is recorded. When enabled (Merge mode), recording over existing MIDI regions results in the new data being merged with the old. When the MIDI Merge button is disabled (Replace mode), the new material replaces the old.

MIDI recording works the same whether using Nondestructive or Destructive Record mode. In addition, neither QuickPunch nor TrackPunch need to be enabled to punch on-the-fly with MIDI—this capability is available in Nondestructive and Destructive Record modes.

Unlike audio loop recording, the state of the MIDI Merge toggle determines whether existing material is replaced or merged.

Unless MIDI Merge is enabled, MIDI recording is destructive (though you can undo a MIDI record pass), either overwriting or adding to region material. One exception to this rule is when Loop Record mode is enabled; in this mode, existing track regions are replaced with new regions when new material is recorded. The old regions remain intact and available from the Region List, and from the Takes List pop-up menu. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.
Recording with a Click

If you intend to work with MIDI or Instrument tracks in your session, or if the audio you're working with is bar and beat-oriented, you can record your tracks while listening to a click. This ensures that recorded material, both MIDI and audio, will align with the session's bar and beat boundaries.

When your track material lines up with the beats, you can take advantage of some useful editing functions in Pro Tools, such as quantizing MIDI and audio regions, quantizing individual MIDI notes, and copying and pasting measures and song sections in Grid mode.

Material that is recorded without listening to a click can still be aligned to bar and beat boundaries in Pro Tools with Beat Detective (see Chapter 21, “Beat Detective”), or use the Identify Beat command to determine the tempo (see “Identify Beat Command” on page 370).

You can also record MIDI with or without a click and manually add Bar|Beat markers or generate a tempo and meter map from it by using Beat Detective. See Chapter 21, “Beat Detective.”

Pro Tools provides a built-in click generator, the DigiRack Click plug-in. Click includes presets with different click sounds, supports accented and unaccented click sounds, and lets you adjust their volumes. Click is integrated directly into Pro Tools, avoiding MIDI time delays. Refer to the DigiRack Plug-Ins Guide for details.

Pro Tools also provides options and controls for driving a click using MIDI. The following steps are for configuring and enabling a click using MIDI.

To configure click options:

1. Choose Setup > Click.
   – or –

Double-click the Metronome Click or Countoff button in the Transport window.

2. In the Click/Countoff Options dialog, do one of the following:
   • If using the DigiRack Click plug-in, select None in the Output pop-up menu. (For information on using the Click plug-in, see the DigiRack Plug-Ins Guide.)
   – or –
   • If driving a click using MIDI, select the port number (device) and channel that will play the click from the Output pop-up menu.

3. For the accented and unaccented notes, specify the note, velocity, and duration with the numeric keypad. If connected, you can also play new note values on your MIDI controller keyboard.

When listening to the click in your Pro Tools sessions, the accented note sounds on the first beat of each measure and the unaccented note sounds on the remaining beats.
Select whether the click is heard "During play and record," or "Only during record," or "Only during countoff."

If using a countoff, specify the number of Bars to be counted off. To hear the countoff only when recording, select that option.

Click OK.

To enable a click from the MIDI menu:
- Select Options > Click.

To enable a click in the Transport:
1. To view the MIDI controls in the Transport, do one of the following:
   - Select View > Transport > MIDI Controls.
   - Control-click (Windows) or Command-click (Macintosh) the Expand/Collapse “+” button in the Transport window to display the MIDI controls.
   - Alt-click (Windows) or Option-click (Macintosh) the Expand/Collapse “+” button in the Transport window to display the MIDI controls and the Counters.

2. In the Transport, click the Metronome Click button so it becomes highlighted.

To use a countoff when recording or playing, click the Countoff button in the Transport so it too becomes highlighted.

Hearing the countoff before recording is helpful in getting the feel for the tempo before you begin playing. The Countoff button in the Transport window displays the number of bars to be counted off.

- The countoff is ignored when Pro Tools is online and syncing to SMPTE time code.

Wait for Note and Countoff

Wait for Note and Countoff are mutually exclusive and cannot both be enabled at the same time. If, for instance, Countoff is enabled and you click the Wait for Note button, Countoff is disabled.

Setting the Default Meter and Tempo

Setting the Default Meter

When opening a new session in Pro Tools, the meter defaults to 4/4. If you intend to record with a click and are working with a different meter, make sure to set the default meter accordingly.
If a session’s meter does not match the music you’re recording, the accented clicks will not line up with what you’re playing, and, as a result, the recorded material may not align with the bars and beats in the Edit window.

⚠️ Be sure to work with DigiGrooves. For example, if Beat Detective extracts the feel from a bar of 3/4, it can only be applied to another bar of 3/4.

Meter events, which can occur anywhere within a Pro Tools session, are stored in the Meter Track and appear in the Meter ruler. For more information on inserting and editing meter events, see “Meter Events” on page 374.

To set the default meter for a session:

1. Double-click the Current Meter button in the Transport window.
2. Enter the Meter you will use for the session and set the Location to 1|1|000 (so the inserted meter event replaces the default one).
3. Choose a note value for the number of clicks to sound in each measure.
4. Click OK to insert the new meter event.

Setting the Default Tempo

When opening a new session in Pro Tools, the tempo defaults to 120 BPM. If you intend to record with a click and are working with a different tempo, make sure to set the default tempo accordingly. If you know the tempo you will use for the session, you can insert a tempo event at the beginning of the Tempo track.

Tempo events, which can occur anywhere within a Pro Tools session, are stored in the Tempo track and appear in the Tempo ruler. For more information on inserting and editing tempo events, see “Tempo” on page 354.

To insert a default tempo event:

1. Double-click the Song Start Marker in the Edit window.
2. Enter the BPM value you will use for the session and set the Location to 1|1|000 (so the inserted tempo event replaces the default tempo).
3. To base the BPM value on something other than the default quarter-note, select another note value from the Resolution pop-up menu.
4. Click OK to insert the new tempo event.

See “Song Start Marker” on page 353 for more information on the default tempo.
Using Manual Tempo Mode

In Manual Tempo mode, Pro Tools can ignore the tempo events in the Tempo track and instead play back a Manual Tempo. This tempo can be set with the Tempo slider, or if you are not sure of the actual tempo, by tapping in the tempo.

While you can adjust the Manual Tempo during playback, doing so will momentarily interrupt playback.

To set the Manual Tempo with the Tempo slider:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.

   In the Transport window, click the Tempo Ruler Enable button (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.

2. To base the BPM value on something other than the default quarter-note, click the Tempo Resolution selector and select a different note value.

3. To enter a new tempo, drag the horizontal Tempo slider in the Transport window.

   For finer resolution with the Tempo slider, press Control (Windows) or Command (Macintosh) while dragging.

To exit Manual Tempo mode and enable the Tempo track:

- Click the Tempo Ruler Enable (Conductor) button in the Transport window so it becomes highlighted.

To set the Manual Tempo by tapping:

1. To view the MIDI controls in the Transport window, select View > Transport Window > MIDI Controls.

2. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.

3. Click in the Tempo field so it becomes highlighted and tap the “T” key on your computer keyboard repeatedly at the new tempo.

   – or –

   Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the new tempo on your MIDI keyboard controller.

   To compute the new tempo, Pro Tools averages the last eight (or fewer) taps to determine the correct tempo. The computed BPM value appears in the Transport’s Tempo field.

To lock in the new tempo:

- Take Pro Tools out of Manual Tempo mode by clicking the Tempo Ruler Enable (Conductor) button, then set the default tempo for the Song Start Marker to the new tempo.
Chapter 12: Basic Audio Recording

Recording an Audio Track

When recording from a mono source, record to a single, mono audio track in Pro Tools. A single, mono audio file is written to disk; the region appears in the playlist and in the Region List.

To record a stereo audio source in Pro Tools, record to a single, stereo audio track. A single, mono audio file is written to disk for each channel of a stereo track; one for the left channel, and one for the right channel; regions appear in the playlists for both channels. In addition, a multichannel (stereo) region appears in the Region List.

Recording multichannel tracks (Pro Tools HD only) is very similar to recording stereo audio tracks. A single, mono audio file is written for each channel in the track, and regions appear in the playlists for each channel. In addition, a multichannel region for each track appears in the Region List.

For more information on multichannel tracks, see “Multichannel Audio Tracks” on page 606.

To configure an audio track for recording:

1. Connect a mono or stereo sound source to the appropriate input of your audio hardware.

2. Make sure to specify the format (analog or digital) of the inputs of the audio interface you will be using. Choose Setup > Hardware, choose the audio interface, and select the format for the channel pair.

Some Digidesign I/O units (such as Mbox 2), have only two channels that can be set for analog or digital.

3. If a track does not already exist, choose Track > New and specify 1 Mono or Stereo Audio Track, then click Create.

To auto-scroll the Track Type pop-up in the New Tracks dialog, press Control (Windows) or Command (Macintosh) and use the Up/Down Arrow keys.

To auto-scroll the Track Formats pop-up in the New Tracks dialog, press Control (Windows) or Command (Macintosh) and use the Left/Right Arrow keys.

4. Rename the track. Track names are used to auto-name recorded audio files and regions. For more information, see “Default Track Names” on page 158.
5 In the Mix window, use the track’s Input Path selector to assign a hardware input.

- or -

In the Edit window, with I/O View enabled, use the track’s Input Path selector to assign a hardware input.

6 In the Mix window, click the track’s Output Path selector and assign a hardware output.

- or -

In the Edit window, with I/O View enabled, use the track’s Output Path selector to assign a hardware output.
7 In the Mix window, click the audio track’s Record Enable button to record enable the track. The Record Enable button flashes red, while the fader stays solid red, and the Transport Window Record Enable button turns red (indicating at least one track is record-enabled).

8 Adjust the output level of your sound source (instrument, mixer, or preamp). Monitor the track’s meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.

9 In the Mix window, adjust the track’s volume and pan faders. These settings are for monitoring purposes only and do not affect the recorded material.

– or –

In the Output window for the track, adjust the track’s Volume fader and Pan sliders. These settings are for monitoring purposes only and do not affect the recorded material. (See “Output Windows for Tracks and Sends” on page 494.)

To record to an audio track:

1 With Pro Tools HD, make sure that Delay Compensation is deselected in the Options menu.

⚠️ Digidesign recommends recording without Delay Compensation in some cases. For more information, see “Delay Compensation” on page 505.

2 In the Options menu, deselect Destructive Record, Loop Record, QuickPunch, and Track-Punch.

3 Enable Click and Countoff in the Transport window if you want to use these features. For details, see “Recording with a Click” on page 165.

4 If you are using meter and tempo information, specify the session’s default meter and tempo. For details, see “Setting the Default Meter and Tempo” on page 166.

5 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

6 Click Record in the Transport window to enter Record Ready mode. The Record Enable button flashes.
When you are ready to begin recording, click Play. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.

When you have finished recording, click Stop in the Transport window.

The newly recorded audio is written to disk and appears as an audio region in the track’s playlist. The new audio region also appears in the Region List.

To play back the audio track:

1. Click the Record Enable button for the audio track so that it is no longer record-enabled. Track volume faders now function as playback level controls.

   If a record-enabled track is in Auto Input Monitor mode, you will hear “through” the input while the Transport is stopped. The track automatically switches to playback when you press play, then back to Input mode when you either stop, or punch into record. For more information, see “Auto Input Monitoring” on page 154.

2. In the Transport window, click Return to Zero to start playback from the beginning of the session.

3. Click Play in the Transport window to start playback. Adjust the track’s volume and pan faders.

Undo or Cancel Audio Recording

Once you’ve recorded an audio track and the transport is stopped, you can undo the previous record take.

To undo an audio recording:

- Once the Transport has been stopped, choose Edit > Undo Record Audio.

The track’s playlist is restored to its previous state, and the following material is discarded:

- When in normal Record mode, the previous take is discarded.
- When in Loop Record mode, all takes from each record pass are discarded.
- When using TrackPunch or QuickPunch mode, all punches from the last recording pass are discarded.

If you undo a record pass during recording, Pro Tools will remove any previously undone record pass from the session, and gives you the option of deleting the previous record pass from your hard drive.

Canceling a Record Take

While recording, it is possible to discard the current record take. This removes the audio (recorded up to that point) from your hard drive and deletes the region from the track’s playlist. This capability is not available in Destructive Record mode.

To cancel a record take while recording:

- Press Control+Period (.) (Windows) or Command+Period (.) (Macintosh) before the Transport is stopped.

When using Loop Record mode, all takes from each record pass are discarded.
Recording Multiple Audio Tracks

Pro Tools can record multiple audio tracks simultaneously, up to the track recording limits of your system. To record to multiple tracks, configure and record enable each track, then record. Follow the same steps as in “Recording an Audio Track” on page 169.

For each record-enabled track, a new audio file is written to disk and a new region is created and appears in the playlist. The new audio regions appear in the Region List.

Record Shortcuts

In addition to clicking the Record Enable button in the Transport window, you can also begin recording with the following keyboard shortcuts:

- Press F12 to start recording immediately.

  \textbf{On Macintosh systems, to use F12 for recording, the Macintosh “Spotlight” feature must be remapped. See your Getting Started Guide for details.}

- Press Control+Spacebar (Windows) or Command+Spacebar (Macintosh) to start recording.

- Press 3 on the numeric keypad (when the Numeric Keypad mode is set to Transport) to start recording.

  \textbf{To initiate recording at half-speed, press Control+Shift+Spacebar (Windows) or Command+Shift+Spacebar (Macintosh). For details, see “Half-Speed Recording and Playback” on page 186.}

Record Pause Mode

When recording a large number of tracks or channels, or playing back a large number of tracks while recording, Pro Tools may take a little longer to begin recording. To avoid this delay, put Pro Tools in Record Pause mode before beginning to record.

\textbf{To record from Record Pause mode:}

1. Click Record Enable in the Transport window. The Record Enable button flashes.

2. Alt-click (Windows) or Option-click (Macintosh) Play in the Transport window to put Pro Tools in Record Pause mode. The Play and Record Enable buttons flash.

3. To begin recording instantaneously, click Play. When you have finished recording, click Stop in the Transport window.

  \textbf{Use Pause mode when recording or playing large numbers of tracks to speed up lock-up time when synchronizing to time code.}

Recording Additional Takes

After recording to an audio track, you can record additional takes to the same track. However, if you record these additional takes in Destructive Record mode, the audio residing on your hard drive from the previous takes will be permanently lost.

To keep the audio from previous takes, record the new takes nondestructively in Nondestructive Record mode.

\textbf{For details on audio file and region names for new takes, see “Default Track Names” on page 158.}
To nondestructively record a new take on the same track:

1. Put Pro Tools in Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, QuickPunch or Track-Punch if selected.

2. Make sure the track containing the previous take is still record-enabled.

3. To record from the beginning of the track, click Return to Zero in the Transport window.
   – or –

   If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

4. Click Record Enable in the Transport window. When you are ready to begin recording, click Play.

5. When you have finished recording, click Stop in the Transport window.

An audio file for the new take is written to disk and appears as an audio region in the track’s playlist. The new audio region appears in the Region List.

The audio from the original take remains on your hard drive, and is still available as a region in the Region List.

To destructively record over a previous take:

1. Select Options > Destructive Record. When using Destructive Record mode, a “D” appears in the Record Enable button.

2. Make sure the track containing the previous take is still record-enabled.

   If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

3. To record from the beginning of the track, click Return to Zero in the Transport window.
   – or –

   If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

4. Click Record Enable in the Transport window. When you are ready to begin recording, click Play.

5. When you have finished recording, click Stop in the Transport window.

The audio for the new take is written to disk, permanently overwriting the original. The new material replaces the original material within the existing region and the region is not renamed.
Appending New Material to the End of a Track

You can also append new material to the end of a track. To do this, locate to the end of the track with the Go to End button in the Transport window (this will locate the end of the session), or tab to the end point of the last region on the track. From there, begin recording and Pro Tools will add the new material to the end of the track. If using Destructive Record mode, the new audio is appended to the audio file and region from the first take. In Nondestructive Record mode, a new file and region are created.

Recording to a New Playlist

Instead of recording over existing audio regions, there is another way to nondestructively record new takes to the same track. Do this by creating a new playlist for the track, then record just as before.

Tracks can have multiple edit playlists, each of which stores a list of regions strung together in a particular order. Also, since playlists follow groups, duplicating or selecting alternate playlists for a track in an enabled group will affect all tracks in the group.

To record to a new playlist for a track:

1. Click the track’s Playlist selector and choose New.
2. Enter a name for the new playlist and click OK.

When a new playlist is created, its name replaces the track name. With this playlist active, names for new audio files and regions are based on its name.

3. Make sure the track is still record-enabled.
4. In the Transport window, click Return to Zero.
5. Click Record in the Transport window. When you are ready to begin recording, click Play.
6. When you have finished recording, click Stop in the Transport window.

An audio file for the new take is written to disk and appears as an audio region in the track’s playlist. The new audio region appears in the Region List.

7. To audition the new take, click Play in the Transport window.
8. To go back to a previous playlist to compare it to the new take, click the track’s Playlist selector and select the previous playlist.

Selecting a playlist recalls its regions as they previously appeared in the track. At any time, all regions from all playlists are available in the Region List, and can be mixed and matched between playlists and tracks.

For more information on playlists and playlist editing, see “Playlists” on page 236.
Punch Recording Audio

To define a record range in the playlist, or replace a portion of a recorded track, you can **punch in** by specifying the record range before recording.

To manually punch in and out on record-enabled audio tracks during playback, refer to “QuickPunch Audio Recording” on page 205, or “TrackPunch Audio Recording” on page 208.

Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 180), perhaps the easiest is to select within the track’s playlist the range for recording.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Options > Link Timeline and Edit Selection).

During the recording process, playback begins at the pre-roll time (if enabled) and proceeds to the start time (the punch-in point), where recording begins. When the end time (the punch-out point) is reached, Pro Tools automatically switches out of Record mode and continues playing through the specified amount of post-roll. This automated punch-in/out feature is a powerful and precise way of recording or re-recording a portion of a track.

To punch record on an audio track:

1. To record nondestructively, make sure that Options > Destructive Record is not selected.
   - or –

   If you do want to permanently record over the specified record range, select Options > Destructive Record.

   If you are recording in any mode other than Destructive Record mode, punches do not permanently replace the previously recorded material. If you do want to permanently record over the specified record range (and keep only the last, or most recent take), select Options > Destructive Record.

2. Make sure the track to which you want to record is record-enabled.

3. Make sure to select Options > Link Timeline and Edit Selection.

4. With the Selector tool, drag in the track’s playlist until the selection encompasses the punch range. For other methods of setting the record range, see “Setting Punch/Loop Points” on page 180.

5. To hear any existing track material up to the start point, or after the end point, enable and set pre- and post-roll times. For details, see “Setting Pre- and Post-Roll” on page 183.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

When the punch-in (start) point is reached, Pro Tools begins recording. Recording continues until the punch-out (end) point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

If recording nondestructively, a new audio file is written to your hard drive and a new audio region appears in the record track and Region List.

If recording in Destructive Record mode, the new audio overwrites the previous material in the existing audio file and region.
Monitoring During Punch-Ins

Pro Tools provides two monitoring modes for recording: Auto Input monitoring and Input Only monitoring. For details, see “Auto Input Monitoring” on page 154.

Loop Recording Audio

Pro Tools provides a loop recording feature that allows you to record take after take while the same section of audio repeats over and over. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

When loop recording, you must first specify the start and end points for the loop. Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 180), perhaps the easiest is to select within the track’s playlist the material to be looped.

The pre-roll setting, if enabled, is used only during the first record pass, and the post-roll setting, if enabled, is used only on the last pass. Pre- and post-roll times are ignored on each successive loop. To compensate for this, you may want to make the loop range slightly longer. Later, you can trim back the recorded takes to the proper length with the Trim tool (see “Trimming” on page 254).

When loop recording audio, Pro Tools creates a single audio file that comprises all takes. Takes appear as individual regions in the Region List and are numbered sequentially. Once you stop recording, you can audition any of the recorded takes.

To use alternate takes created with Loop Record in other sessions (such as when using Import Session Data), export region definitions (see “Exporting Region Definitions” on page 133). If region definitions are not exported, alternate takes created with Loop Record will be inaccessible when imported into another session.

To loop record an audio track:

1. Select Options > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record Enable button.

2. Record enable the audio track by clicking its Record Enable button.

3. Make sure to select Options > Link Timeline and Edit Selection.

4. With the Selector tool, drag in the track’s playlist until the selection encompasses the loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 180.

5. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre- and Post-Roll” on page 183.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record Enable button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start time and continues playing and recording.
To cancel all recorded takes while loop recording, press Control+Period (.) (Windows) or Command+Period (.) (Macintosh).

When you have finished recording, click Stop in the Transport window.

If you stop recording before you reach the midpoint of the loop, Pro Tools discards that take. If you record more than half of the looped take, Pro Tools will leave the take in the track when you stop recording.

The recorded takes appear as regions in the Region List and are numbered sequentially. The most recently recorded take is left in the record track. For details on auditioning the various takes, see “Auditioning Different Record Takes in the Timeline” on page 178.

Loop Playback and Audio Recording

Pro Tools ignores “loop playback” when recording. The only way to loop while recording is to enable Loop Record mode.

Auditioning Different Record Takes in the Timeline

After recording multiple takes with loop or punch recording, you can replace the take currently residing in the track with previous takes to audition them in the Timeline, within the context of the session. (Takes must have the same start time to be available.) Takes can also be auditioned on their own, from the Region List, or from the Takes List pop-up menu.

All takes are numbered sequentially.

Selecting a Different Take from the Region List

To select a take from the Region List:

1. In the Edit window, select the current take with the Time Grabber tool.
2. Control-drag (Windows) or Command-drag (Macintosh) another take from the Region List into the playlist.

The region replaces the previous take and snaps precisely to the correct location.

3. Repeat the above steps to audition other takes.

Selecting a Different Take from the Takes List Pop-Up Menu

Each region resulting from a punch or loop record pass has an identical start time (the User Time Stamp). This allows you to easily select and audition takes from the Takes List pop-up menu—even while the session plays or loops.

To select a take from the Takes List pop-up menu:

1. Control-click (Windows) or Command-click (Macintosh) with the Selector tool at the precise beginning of the loop or punch range.

2. – OR –

If the take currently residing in the track is selected, Control-click (Windows) or Command-click (Macintosh) it with the Selector tool.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.
2 Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

3 Repeat the above steps to audition other takes.

One way to ensure that future takes have the same User Time Stamp (and appear in the Takes List pop-up menu) is to store punch and loop record selections as Memory Locations. Then if you later need to record additional takes, simply recall the Memory Location. For more information, see “Memory Locations” on page 182.

To change the User Time Stamp of other regions so that they appear in the Takes List pop-up menu for a certain location, use the Time Stamp command in the Region List pop-up menu. For more information, see “Time Stamping” on page 664.

Takes List and Multiple Tracks

If you have recorded multiple tracks, and each contains takes with identical User Time Stamps, you can use the Takes List pop-up menu to replace all takes simultaneously.

To replace the takes for multiple tracks:
1 Choose Setup > Preferences and click the Editing tab.
2 Enable the following options:
   • Take Region Name(s) That Match Track Names
   – and –
   • Take Regions Lengths That Match
3 Click Done to close the Preferences dialog.
4 With the Selector tool, select the take range for each track you want to replace.
5 Control-click (Windows) or Command-click (Macintosh) any of the select takes with the Selector tool.

A pop-up menu appears containing a list of regions that share the same User Time Stamp for that track.

6 Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location. The same take numbers for the other selected tracks are also automatically selected.

Editing Preferences for Takes

In addition to having the same User Time Stamp, regions that appear in the Takes List pop-up menu are also restricted according to options in the Preferences dialog.

To set Editing preferences for takes:
1 Choose Setup > Preferences and click the Editing tab.
2 Enable or disable the following options in the “Matching Start Time” Take List section:

Take Region Name(s) That Match Track Names When selected, only regions that share the same root name with the track/playlist appear in the Takes List pop-up menu. For example, the Takes List for a track named “Gtr.L” would show the regions “Gtr.L_01” and “Gtr.L_02-01,” but not “Guitar.L_01.”

Take Region Lengths That Match When selected, only regions that match the length of the current selection (even if it is not an entire region) appear in the Takes List pop-up menu. If there is no selection, all takes with the same User Time Stamp are displayed.

“Separate Region” Operates On All Related Takes When selected, editing a region with the Separate Region command also affects all other related takes with the same User Time Stamp.
This option helps you compare different sections from a group of related takes. For example, you can quickly separate an entire group of related vocal takes into sections, then audition and select the best material from each section independently.

If this option is selected, make sure the “Take Region Names That Match Track Name(s)” and “Take Region Lengths That Match” options are also selected. If they are not, all regions in the session that have the same User Time Stamp will be affected.

In most instances, you’ll want to deselect the “Separate Region Operates On All Related Takes” option, to prevent a large number of regions from being created when you use the Separate Region command.

### Setting Punch/Loop Points

The start and end points of a record range for punch and loop recording can be set by the following methods:

- Select a range in a track’s playlist.
- Select a range in a Timebase ruler.
- Drag the Playback Markers in the ruler.
- Enter start and end times in the Transport window.
- Recall a Memory Location.

#### To set the record range in a track’s playlist:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Make sure to select Options > Link Timeline and Edit Selection.

3. With the Selector tool, drag in a track’s playlist until the selection encompasses the record range.

![Playlist selection](image)

   - or –

If a region’s start and end points define the record range, click the region with the Time Grabber tool.

💡 You can also enter a start and end point during playback. Press the Down Arrow to set the start point, and press the Up Arrow to set the end point. Note that when in Grid mode, entering start and end point in this manner will not snap to the grid.

#### To set the record range in a Timebase ruler:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in any Timebase ruler until the selection encompasses the record range.

![Timeline selection](image)

💡 If the Selector tool is not active, you do not need to manually select it. Other Edit tools (such as the Time Grabber tool) automatically turn into the Selector tool when used in the Timebase ruler.
Playback Markers

When tracks are record-enabled, Playback Markers for start and end times appear as red up/down arrows in the Main Timebase ruler. If no tracks are record-enabled, the Playback Markers are blue.

The Playback Markers can be moved, either separately or at the same time, to set record and play ranges.

To set the record range by dragging the Playback Markers:

1. If you want the dragged Playback Markers to snap to the current Grid value, set the Edit mode to Grid.
2. Drag the first Playback Marker (down arrow) to the start point of the range.
3. Drag the second Playback Marker (up arrow) to the end point of the range.

If the current record range is already the right length and the range needs only to be moved, Alt-drag (Windows) or Option-drag (Macintosh) either Playback Marker to move both to a new location (while keeping the same length).

Start, End, and Length Fields

In its Expanded View, the Transport window can display start, end, and length times, and pre- and post-roll settings. When setting a record or play range, the range is reflected in these fields.

You can enter locations in the start and end fields to set the record or play range. The Playback Markers in the Main Timebase ruler are updated accordingly.

To set the record range by entering start and end times in the Transport window:

1. To see the start, end, and length times, do one of the following:
   - Select View > Transport > Expanded.
   - or –
   - Shift-click the Expand/Collapse “+” button in the Transport window.
2. In the Transport window, click in the start field.
   - or –
   Press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Macintosh) on the numeric keypad to select the start field in the Transport window.
3. Type in the start location and press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Macintosh) on the numeric keypad to enter the value and automatically move to the end field.
4. Type in the end location and press Enter to accept the value.

Use the Period (.) or Left/Right Arrow keys to move through the different time fields for start/end. Use the Up/Down Arrow keys to increase or decrease the numerical values.
Memory Locations

You can store Edit selections as Memory Locations, which can include current pre- and post-roll values.

For more information on Memory Locations, see “Memory Locations and Markers” on page 382.

To save an Edit selection with a Memory Location:

1. Make sure to select Options > Link Timeline and Edit Selection.

2. Set the record range by making a playlist or ruler selection, or by entering start and end times in the Transport window.

3. To save the pre- and post-roll values, enable and set the pre- and post-roll amounts by entering them in the Transport window, or by dragging the Pre- and Post-Roll Flags in the ruler that represents the Main Time Scale. (For details, see “Setting Pre- and Post-Roll” on page 183.)

4. Press Enter on the numeric keypad or click the Add Marker/Memory Location button in the Edit window.

5. In the New Memory Location dialog, set Time Properties to Selection, and if saving pre- and post-roll values, select the General Properties option for Pre/Post Roll Times.

6. Enter a name for the new Memory Location and click OK to save it.

To recall an Edit selection with a Memory Location:

1. Make sure to select Options > Link Timeline and Edit Selection.

2. Choose Windows > Memory Locations.

3. Do one of the following:
   - In the Memory Locations window, click the name or number of the Memory Location.
   - Recall the Memory Location by typing Period (.), the Memory Location number, and Period (.) again on the numeric keypad. (See “Numeric Keypad Modes” on page 33).

The start and end times and pre- and post-roll settings stored with the Memory Location are recalled.
Setting Pre- and Post-Roll

Pre- and post-roll times appear as flags in the ruler that represents the Main Time Scale. When pre- and post-roll are enabled, the flags are green, otherwise they are gray.

Setting Pre- and Post-Roll in the Transport Window

Pre- and post-roll can be enabled and set from the fields in the Transport window.

To set and enable the pre- and post-roll times in the Transport window:

1. Select View > Transport > Expanded.
2. In the Transport window, click in the pre-roll field.
3. Type in the pre-roll amount and press Forward Slash (/) on the numeric keypad to enter the value and automatically move to the post-roll field.
4. Type in the post-roll amount and press Enter to accept the new value.
5. To enable either pre- or post-roll, click the appropriate button so it becomes highlighted.

For the period (.) or Left/Right Arrow keys to move through the different time fields for pre and post-roll. Use the Up/Down Arrow keys to increase or decrease the numerical values.

Setting Pre- and Post-Roll in a Playlist

You can use the Selector tool to enable and disable pre- and post-roll by clicking in a track’s playlist.

To set and enable the pre- and post-roll by clicking in a playlist:

1. Make sure that Options > Link Timeline and Edit Selection is enabled.
2. With the Selector tool, drag in the track’s playlist until the selection encompasses the record range.
3. With the Selector tool, Alt-click (Windows) or Option-click (Macintosh) in the track’s playlist before the selection to enable the pre-roll at that location.
4. With the Selector tool, Alt-click (Windows) or Option-click (Macintosh) in the track’s playlist after the selection to enable the post-roll at that location.

To disable the pre- and post-roll by clicking in a playlist:

1. With the Selector tool, Alt-click (Windows) or Option-click (Macintosh) within a track selection near the start to disable the pre-roll.
2. With the Selector tool, Alt-click (Windows) or Option-click (Macintosh) within a track selection near the end to disable the post-roll.

In the timeline, you can reset the pre- and post-roll to zero. First, drag the Pre-Roll Flag to the Playback Marker at the start point of the range, then drag the Post-Roll Flag to the Playback Marker at the end point of the range.

1. Drag the Pre-Roll Flag to the Playback Marker at the start point of the range.
4 Drag the Post-Roll Flag to the Playback Marker at the end point of the range.

Enabling Pre/Post-Roll from the Options Menu

Pre- and post-roll (as a pair) can be enabled and disabled from the Options menu.

To enable both pre/post-roll from the Options menu:

- Select Options > Pre/Post-Roll.

Dragging Pre- and Post-Roll Flags in the Timebase ruler

The Pre- and Post-Roll Flags can be moved in the ruler, either separately or at the same time, to set their location.

To set the pre- and post-roll amounts by dragging in the ruler:

1. If you want the dragged flags to snap to the current Grid value, set the Edit mode to Grid.
2. Drag the Pre-Roll Flag to a location in the ruler.
3. Drag the Post-Roll Flag to a location in the Timebase ruler.

Recording from a Digital Source

If you plan to use a DAT player, digital-output CD recorder, or other digital input and output device with your Pro Tools system, make sure it supports the correct digital format. For example, your interface’s AES/EBU inputs and outputs should only be connected to another AES/EBU device.

Pro Tools|HD Digital Options

The 192 I/O, 192 Digital I/O, and 96 I/O include AES/EBU, S/PDIF, and ADAT digital options. Additionally, the 192 I/O and 192 Digital I/O include TDIF digital I/O options. The 96i I/O includes only the S/PDIF digital option.

On a 192 I/O, 192 Digital I/O, or 96 I/O, Pro Tools can receive digital audio from the factory-installed Optical (ADAT) I/O at any time (if it is not set to S/PDIF). However, Pro Tools can only receive digital audio from one of its enclosure [Encl] digital sources—AES, S/PDIF or Optical (S/PDIF) at a time.

Enclosure digital sources come standard with Pro Tools|HD I/Os and are labelled on-screen as [Encl] versions, to differentiate them from digital inputs and outputs available on the 192’s Digital I/O card. For example, the AES/EBU inputs and outputs that come standard in the 192 I/O enclosure are identified as AES/EBU [Encl].

The additional digital ports on the 192 I/O and 192 Digital I/O are TDIF, AES/EBU, and ADAT. Pro Tools can only receive digital audio from one of these ports at a time.
However, inputs on both the 192 I/O enclosure I/O and Digital card can be used simultaneously. For example, on a 192 I/O, it is possible to clock off a source from one of the enclosure inputs and have another digital input from the digital ports doing a sample rate conversion, thus having two digital sources.

**Pro Tools LE Digital Options**

The Digi 002 and Digi 002 Rack include S/PDIF and ADAT digital I/O.

Mbox 2 and Mbox include only the S/PDIF digital option.

All digital outputs are active at all times, so you can actually send digital audio to different digital devices simultaneously at mix time.

**Recording from Digital Sources**

To record from a digital source with Pro Tools (in this example, from a DAT recorder):

1. Connect the digital output of the DAT recorder to the appropriate digital input of your audio hardware.

2. If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Click Save.

3. Make sure to specify the format (digital) of the inputs of the audio interface you will be using. Choose Setup > Hardware, choose the audio interface, and select the format for the appropriate channel pair.

Some Digidesign I/O units only have two channels that can be set for analog or digital. For example, Mbox 2 has S/PDIF L–R (Stereo) digital inputs and In 1–2 analog inputs. Mbox 2 can record through analog and digital inputs simultaneously.

Also, if your audio hardware supports different digital formats (such as AES/EBU and S/PDIF), select the digital format you will use.

4. For Pro Tools|HD systems, choose Setup > Hardware and select the appropriate Clock Source connected to the appropriate I/O audio interface; or use the Session Setup window to select the appropriate Clock Source.

5. Click OK to close the Hardware Setup dialog.

6. Choose Track > New and specify 1 Stereo Audio Track, then click Create.

7. Assign the Input Path selector for the track to the appropriate input. Since this is a digital-domain transfer, you do not need to worry about input levels.

8. In the Mix window, click the track’s Output Path selector and assign a stereo hardware output.

   – or –

   In the Edit window, with I/O View enabled, use the track’s Output Path selector to assign a hardware output.

9. In the Options menu, deselect Destructive Record, Loop Record, QuickPunch and Track-Punch.

10. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

11. In the Mix or Edit window, record enable the new audio track by clicking its Record Enable button.

12. Click Record in the Transport window. When you are ready to begin recording, click Play.

13. Start playback on the DAT deck.
When the material from the DAT has finished, click Stop in the Transport window.

For more information on configuring your particular Pro Tools system for recording from a digital source, see your Getting Started Guide.

After a Digital Transfer

After you have finished recording digitally, set the Clock Source pop-up menu in the Session Setup window back to Internal. Otherwise, Pro Tools will not switch back to its own internal clock and will not record or play audio properly. Failure to switch back to Internal sync typically results in pitch problems (fast or slow playback) clicks and pops, or DAE errors, since a DAT recorder or CD Recorder that is idle can default to a different sample rate or stop outputting a sample rate clock altogether.

Half-Speed Recording and Playback

Pro Tools lets you play and record at half-speed. This capability is similar to that of a tape deck where you can record material at half-speed and then play it back at normal speed (up an octave) for special effects.

To record at half-speed:

1. Press Shift+Control+Spacebar (Windows) or Shift+Command+Spacebar (Macintosh). Recording begins and all existing track material plays at half-speed.
2. When you have finished recording, click Stop.

When played at normal speed, the material recorded at half-speed plays twice as fast (up an octave).

💡 Use half-speed recording to record difficult to play MIDI tracks or to record complex automation moves.

To play at half-speed

1. Press Shift+Spacebar. Playback begins and track material plays at half-speed. Any audio tracks recorded at normal speed will sound half as fast and an octave lower, and any audio tracks playing back that were recorded at half-speed will sound like they are playing back at normal speed.
2. Click Stop in the Transport window to stop playback.

💡 You can also play at half-speed by Shift-clicking the Play button.

💡 Use half-speed playback to learn or transcribe difficult passages in recorded tracks.
Although recording MIDI in Pro Tools is similar to recording audio, there are some important differences:

- Unlike audio, MIDI recording is almost always destructive. See “Record Modes and MIDI” on page 164 for details.
- Unlike audio tracks, MIDI and Instrument tracks can be record-enabled on-the-fly during playback or recording.
- MIDI and Instrument tracks have an Input selector that determines which port on your MIDI interface (devices) and which MIDI channel is routed and recorded to the track. If the MIDI Input selector is set to All, all channels for all devices are routed to the track.
- Similar to Auxiliary Inputs, Instrument tracks have an audio Input selector. This selector is different than the Instrument track’s selector for MIDI Input.
- It is not necessary to use QuickPunch or TrackPunch to punch in on-the-fly with MIDI or Instrument tracks. This capability is available in normal Nondestructive Record mode, and in Destructive Record mode.

Recording from MIDI Devices

The MIDI Inputs for record-enabled MIDI and Instrument tracks determine which MIDI data is recorded in Pro Tools. MIDI Inputs can be set to a specific device (port) and channel, or they can be set to “All,” where all channels for all devices are merged to the track.

MIDI and Instrument tracks in Pro Tools do not contain multiple channels and always play back on the track’s assigned MIDI output devices and channels. Multiple MIDI channels can be simultaneously recorded to multiple tracks.

The following Pro Tools options determine whether you can record from a MIDI controller device:

- Devices that are assigned as a MIDI Controller in the Peripherals dialog are ignored when MIDI tracks are recorded. This is to avoid recording data from MIDI control surfaces (such as the Digidesign Command|8).
- To record and play MIDI, the device must be enabled in the Input Devices dialog (Macintosh Only). For more information, see “Enabling Input Devices” on page 188.
In addition, the following options affect how MIDI data is recorded in Pro Tools.

- The MIDI Input Filter can filter out MIDI messages that you may not want to record, such as Polyphonic Aftertouch or System Exclusive data. For more information, see “MIDI Input Filter” on page 190.

- Input Quantize, when enabled, automatically quantizes (time corrects) all MIDI notes that are recorded. For more information, see “Input Quantize” on page 190.

---

**Enabling Input Devices**

To record from a MIDI controller in Pro Tools, the device must be enabled in the Input Devices dialog. You can also use this dialog to make sure unwanted notes from certain devices, such as drum machines or arpeggiators, are not recorded.

**MIDI Control Surfaces** In order to use any MIDI control surfaces (such as the Digidesign Command][8), they must be enabled in the Input Devices dialog.

**MMC** In order for Pro Tools to sync to MMC, the MMC source must be enabled in the Input Devices dialog.

---

**To enable input devices:**

2. In the MIDI Input Enable dialog, select the MIDI devices you will record from. Also, make sure any devices that will be used as a control surface are also selected.

3. Deselect any input devices you want to ignore while recording MIDI.

4. When you are finished, click OK.

* Devices do not need to be selected to send MIDI data through them. For example, a device used exclusively as a sound module does not need to be selected in the MIDI Input Enable dialog.
MIDI Thru

To monitor MIDI tracks while recording, enable MIDI Thru. When enabled, Pro Tools routes MIDI from your controllers to the device and channels assigned to the MIDI track currently record-enabled.

- The MIDI preference for Global MIDI Playback Offset and individual MIDI track offsets do not affect MIDI routed with MIDI Thru.

- When MIDI Thru is enabled, System Exclusive events are echoed to the MIDI device assigned to the record-enabled track—but only if the SysEx events are smaller than 256 bytes.

To enable MIDI Thru:
- Select Options > MIDI Thru.

The Default Thru Instrument

In addition to any MIDI tracks that are record-enabled, you can also route MIDI to the Default Thru Instrument. This saves you the trouble of creating a MIDI track and record enabling it to hear a particular MIDI device and channel.

Unlike MIDI tracks, which only listen to the device and channel assigned to its MIDI Input selector, all incoming MIDI data is routed to the Default Thru Instrument.

If the Default Thru Instrument is assigned to a record-enabled MIDI track, Pro Tools only routes to the record-enabled track.

To configure a default Thru instrument:
1. Choose Setup > Preferences.
2. Click the MIDI tab.
3. Do one of the following:
   - Select a specific device from the Default Thru Instrument pop-up menu to define a consistent preview sound source.
   - Select “Follows First Selected MIDI Track” to have MIDI preview assignment follow MIDI track selection. When multiple MIDI tracks are selected, previewing will use the top track/left track in the Edit and Mix windows.
   - To disable the Default Thru Instrument, select None.

- The Default Thru Follows First Selected MIDI Track Selection also lets you play an instrument without having to create and record-enable a MIDI or Instrument track.
**MIDI Input Filter**

Use the MIDI Input Filter to prevent certain MIDI messages from being recorded. The MIDI Input Filter can be set to record “All” messages, “Only” the specified messages, or “All Except” the specified messages.

**For example, to filter out Polyphonic Aftertouch:**

2. In the MIDI Input Filter dialog, select the All Except option.
3. Select the option for Polyphonic Aftertouch. Leave all other messages deselected.
4. Click OK.

When using the All Except option, the selected MIDI messages will not be recorded. Conversely, when using the Only option, only the MIDI messages that are selected will be recorded.

---

**Input Quantize**

When Input Quantize is enabled, all recorded MIDI notes are quantized automatically. To preserve the original “feel” of your recorded MIDI tracks, make sure to disable this option.

**To enable Input Quantize:**

1. Choose Event > MIDI > Input Quantize.
2. In the Input Quantize page, select Enable Input Quantize.

Configure the other options in the Input Quantize page. For details on the various Quantize options, see “Input Quantize” on page 456. When finished, close the MIDI Operations window.

For *drum machine* style loop recording, use Input Quantize while loop recording MIDI in Merge mode (see “Loop Recording with Merge Mode” on page 197).
**Wait for Note**

The Wait for Note button, located in the Transport window, determines how Pro Tools begins recording. When enabled, Pro Tools will not begin recording until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range (start time).

Wait for Note can be used when recording normally, when punching in, or when loop recording. If pre-roll is enabled, it occurs after the MIDI event is received and before recording begins.

**To enable Wait for Note:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the Wait for Note button so it becomes highlighted.

With the Operation preference for “Use F11 for Wait for Note” enabled, you can press F11 to turn on Wait for Note.

**MIDI Merge/Replace**

The MIDI Merge button, located in the Transport window, determines how MIDI is recorded when overdubbing or punching in. When MIDI Merge is on (Merge mode), recorded MIDI is merged with existing track material. When MIDI Merge is off (Replace mode), existing data within the punched region is replaced by the newly recorded material.

The MIDI Merge button can be turned on and off while playing or recording. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.

**To enable MIDI Merge:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the MIDI Merge button so it becomes highlighted.

You can also paste and merge MIDI notes using Paste Special commands. See “Special Paste Function for Automation Data” on page 559.

**To enable MIDI Merge:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the MIDI Merge button so it becomes highlighted.
Configuring MIDI or Instrument Tracks for Recording

To configure one or more MIDI or Instrument tracks for recording:

1. If you do not have a MIDI or Instrument track to record to, choose Track > New and specify 1 MIDI Track or 1 Instrument Track, then click Create.

2. For Instrument tracks, be sure that Instruments view is selected (View > Mix Window > Instruments, or View > Edit Window > Instruments).

3. In the Mix window, click the track's MIDI Input selector and assign the device and channel to be recorded. For Instrument tracks the MIDI Input selector is available in Instruments view.

   - or -

   For MIDI tracks In the Edit window, choose View > Edit Window > I/O, then click the track’s MIDI Input selector and assign the device and channel to be recorded. For Instrument tracks, the MIDI input is available by choosing View > Edit Window > Instrument.
4 In the Mix window, click the track’s MIDI Output selector and assign a device and channel from the pop-up menu. For Instrument tracks the MIDI Output selector is available in Instruments view. Channels already assigned to other tracks appear bold in this menu.

In the Edit window, with I/O View enabled, click the track’s MIDI Output selector and assign a device and channel from the pop-up menu. For Instrument tracks the MIDI Output selector is available in Instruments view. Channels already assigned to other tracks appear bold in this menu.

5 To assign multiple destinations to a single MIDI or Instrument track, Start-click (Windows) or Control-click (Macintosh) the MIDI Output selector and select additional channels from any device. When multiple destinations are selected for a single MIDI track, a “*” sign will appear next to the first destination name in the track’s MIDI Output selector.

6 If you want to assign a default program change to the track, click the Patch Select button, make the necessary selections for program and bank select, then click Done.

Default program changes are sent whenever the track is played. For more information, see “Patch Select (Program and Bank Changes)” on page 429.

7 If recording to multiple MIDI or Instrument tracks, repeat the above steps for each track, then continue to the next step.

8 If you want to use a click, enable and configure the click, and set a default tempo and meter for the session. For details, see “Recording with a Click” on page 165.

9 Enable Wait for Note or Countoff in the Transport window if you want to use these features.

10 To replace existing track material, disable MIDI Merge in the Transport window.

11 If you want to automatically quantize material as it is recorded, enable Input Quantize (see “Input Quantize” on page 190).
12 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you'll start recording from the beginning of the track.

13 In either the Mix or Edit window, click the MIDI or Instrument track’s Record Enable button to record enable the track.

14 Make sure Options > MIDI Thru is selected, then play some notes on your MIDI controller. The MIDI instrument assigned to the track should sound, and the track’s meters should register MIDI activity.

You are now ready to record MIDI data to the record-enabled MIDI and Instrument tracks. See “Recording to MIDI and Instrument Tracks” on page 194.

---

**Recording to MIDI and Instrument Tracks**

In Pro Tools, you can record to one or more MIDI and Instrument tracks. Recording simultaneously to multiple tracks allows you to:

- Record from multiple MIDI devices at the same time, capturing material from several performers
- Record multiple channels from the same device, capturing data from a split keyboard
- Transfer MIDI tracks from an external MIDI sequencer

To take full advantage of the MIDI editing capabilities in Pro Tools, make sure to record with the click enabled. This ensures that recorded data aligns with the session’s bar and beat boundaries. You can also record to MIDI tracks without a click and derive the tempo and meter from the performance.

---

**To record to one or more MIDI or Instrument tracks:**

1. With Pro Tools HD, make sure that Delay Compensation is disabled in the Options menu.

   ! Digidesign recommends recording without Delay Compensation in most cases. For more information, see “Delay Compensation” on page 505.

2. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 192.

3. Record enable the track you want to record by clicking its Record Enable button.

   To record enable additional MIDI and Instrument tracks, shift-click their Record Enable buttons.

4. Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.

5. Click Record in the Transport window to enter Record Ready mode. The Record Enable Status indicator lights red.

   ![Record Enable button]

6. When you are ready to begin recording, click Play. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.

   – or –

   If using Wait for Note, the Play, Record, and Wait for Note buttons flash. Recording begins when a MIDI event is received.
When you have finished recording, click Stop in the Transport window.

For each record-enabled track, a new MIDI region is created and appears in the playlist. The new MIDI regions also appear in the Region List.

**There are several keyboard shortcuts you can use to begin recording.** See “Record Shortcuts” on page 173 for details.

To record the audio from a MIDI instrument, bus the audio output of the Instrument track or Auxiliary Input track that is monitoring the MIDI instrument to an audio track. Record enable the audio track and begin recording.

**To play back recorded MIDI and Instrument tracks:**

1. In the Transport window, click Return to Zero.
2. Click Play in the Transport window to begin playback.

The recorded MIDI data plays back through each track’s assigned device (port) and channel.

**Undo and MIDI Recording**

You can undo previous MIDI record takes.

**To undo a MIDI recording:**

- Once the Transport has been stopped, choose Edit > Undo MIDI Recording.

The track’s playlist is restored to its previous state. However:

- If you punched in and out several times before stopping the Transport, only the last punch is undone.
- When using Loop Record mode, all takes from each record pass are discarded.

**Canceling a Record Take**

It is also possible to discard the current record take before the Transport is stopped.

**To cancel a record take while recording:**

- Press Control+Period (.) (Windows) or Command+Period (.) (Macintosh) before the Transport is stopped.

If using Loop Record mode, all takes from each record pass are discarded.

**Punch Recording MIDI**

To replace a portion of a MIDI or Instrument track, you can punch in by specifying the record range before recording.

**To punch in on a MIDI or Instrument track:**

1. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 192.
2. Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.
3. In the Transport window, disable Wait for Note and Countoff.
4. Select Options > Link Timeline and Edit Selection.
5. With the Selector tool, drag in the track’s playlist until the selection encompasses the punch range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 180.
To hear existing track material up to the start point, or after the end point, enable and set pre- and post-roll times. For details, see “Setting Pre- and Post-Roll” on page 183.

7 Record enable the track containing the previous take by clicking its Record Enable button.

8 Click Record in the Transport window to enter Record Ready mode. The Record Enable button flashes.

9 When you are ready to begin recording, click Play.

If pre-roll is enabled, the track material leading up to the punch-in point plays. You can start playing during the pre-roll to get the “feel.” Material is not recorded until the start point is reached.

When the start point is reached, Pro Tools begins recording. Recording continues until the end point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

10 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears in the track.

**Punch Recording During Playback with MIDI**

You do not have to set a record range to punch in on a MIDI or Instrument track. In fact, you can punch in and out on-the-fly at any time during playback. Unlike audio tracks, it is not necessary to enable QuickPunch to perform real-time punch recording.

**To punch record on-the-fly with MIDI:**

1 Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 192.

2 Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 In the Transport window, disable Wait for Note and Countoff.

4 Record enable the track containing the previous take by clicking its Record Enable button.

5 Start playback by clicking Play in the Transport window.

6 When you reach the punch-in point, click Record in the Transport window.

   – or –

For Digi 002 and Digi 002 Rack systems (or Digidesign controllers) with a connected footswitch, press the footswitch at the punch-in point.

The Record Enable button stops flashing and stays lit during recording.

7 To punch out, click Record again (or press the footswitch).

Pro Tools exits Record mode and continues playing. You can perform additional punches during the same pass.
Regions and Punch Recording

Depending on the record range, new regions may be created after punch recording. For example, Figure 7 shows two existing regions before recording. Since the start and end times occur within both of the existing regions, a new region is created to fill the space between them.

However, when selecting an entire region, or a section within a region, before punching, no new regions are created. In this instance, only the material residing within the existing region changes, with no new material recorded outside the region.

Unlike audio recording, MIDI recording in this scenario is destructive. If a region is altered because of a record take, the original material is lost (unless you choose Edit > Undo MIDI Recording), or combined with new material (if MIDI Merge was enabled during recording). If an existing region contains important material, use Duplicate to make a copy of the region (“Duplicate Command” on page 317) or the track’s playlist (see “Working with Playlists” on page 236).

Loop Recording MIDI

Loop recording with MIDI is supported by two methods:

- In normal Nondestructive Record mode, enable Loop Playback and MIDI Merge for drum machine style loop recording.
  - or -
- Use Loop Record mode to record multiple takes on each record pass. This is similar to loop recording audio.

Loop Recording with Merge Mode

For drum machine style loop recording, use normal Nondestructive Record mode with Loop Playback and MIDI Merge enabled. With this method, MIDI is recorded and merged to the same region with each new record pass—thereby allowing you to, for example, record hi-hats on the first pass and kick and snare on the next.

Make sure that MIDI Merge is enabled in the Transport window, otherwise (in Replace mode) each subsequent take will destructively replace the previous.

You can record enable a different MIDI or Instrument track on-the-fly while loop recording. While pressing Ctrl (Windows) or Command (Macintosh), use the Up/Down Arrows to record enable the previous or next MIDI or Instrument track.

To loop record with MIDI Merge:

1. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 192.
2 Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 Select Options > Loop Playback. When Loop Playback is enabled, a loop symbol appears in the Play button.

4 Record enable the MIDI or Instrument track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.

5 In the Transport window, click the MIDI Merge button so it becomes highlighted.

6 Disable Wait for Note and Countoff in the Transport window.

7 Select Options > Link Timeline and Edit Selection.

8 With the Selector tool, drag in the track’s playlist until the selection encompasses the loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 180.

9 To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre- and Post-Roll” on page 183.

10 Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record Enable button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

11 Play some notes on your MIDI controller. Newly recorded MIDI data appears as a region in the record track. On each successive take, recorded material shows up in the region, without replacing material from previous takes.

12 If you want to switch to a new record track, press Control (Windows) or Command (Macintosh), and press the Up/Down Arrow keys to record enable the previous or next MIDI or Instrument track.

13 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the Region List.

**Loop Recording Multiple Takes**

When recording MIDI in Loop Record mode, new regions are created each time new material is received during a record pass. This differs somewhat from loop recording audio, where Pro Tools creates a single audio file that comprises all takes, which appear as individual regions in the Region List.

You can use MIDI loop recording to record successive takes without stopping the record process, thereby capturing your creative spontaneity. Another advantage with this method of recording MIDI, which is nondestructive, is that existing and newly recorded regions remain intact (and available in the Region List).

**To record MIDI in Loop Record mode:**

1 Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 192.
2 Select Options > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record Enable button.

3 If you have not done so already, record enable the MIDI or Instrument track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.

4 Disable Wait for Note and Countoff in the Transport window.

5 Select Options > Link Timeline and Edit Selection.

6 With the Selector tool, drag in the track’s playlist until the selection encompasses the loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 180.

7 To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre- and Post-Roll” on page 183.

8 Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record Enable button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

9 Play your MIDI controller. A new MIDI region containing the newly recorded material is automatically created and appears in the track’s playlist, replacing the previous region.

Regions are replaced (nondestructively) during subsequent record passes when new MIDI material is received.

10 When you have finished recording, click Stop in the Transport window. The most recently recorded take is left in the record track.

The recorded takes appear as regions in the Region List and are numbered sequentially. The takes, which are the same length and easily interchangeable, can be auditioned from the Takes List pop-up menu—even while the session plays or loops.

To audition the various record takes:

1 Control-click (Windows) or Command-click (Macintosh) with the Selector tool at the precise beginning of the loop record range.

– or –

If the take currently residing in the track is selected, Control-click (Windows) or Command-click (Macintosh) it with the Selector tool.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.

2 Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

For more information on auditioning and managing takes, see “Auditioning Different Record Takes in the Timeline” on page 178.
MIDI Step Input

Step Input lets you use a MIDI controller to enter notes individually, one step at a time. This gives you precise control over note placement, duration, and velocity. With MIDI Step Input you can also create musical passages that might be difficult to play accurately, or at a fast tempo.

To enter MIDI notes with Step Input (using an external MIDI Instrument):

1. Make certain your external MIDI keyboard is properly connected and working with Pro Tools.
2. Choose Event > MIDI > Step Input.
3. Select the Enable option.

![Warning]

When Step Input is enabled, each previously record-enabled MIDI track is taken out of record enable, and if a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled.

4. Choose the MIDI track you wish to record on from the Destination pop-up menu.
5. Choose the note value you wish to enter from the Step Increment section.
6. Play a note or chord on your MIDI instrument. This enters the note and moves to the next step of the insertion point.

To increase a note’s length while using Step Input:

1. Play and hold a note on your MIDI instrument.

![Warning]

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment.”

2. Choose the note value that you would like to add and press the Increment button.

Release the note on your MIDI keyboard to move to the next step insertion point.

Step Input Controls

The Step Input page has the following controls:

Enable When selected, MIDI events are added to the destination track when you play your external MIDI keyboard. Additionally, each previously record-enabled MIDI track is taken out of record enable.

If a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled when Step Input is enabled, and is re-enabled when Step Input is no longer disabled.
**Destination** Lets you select the destination track for the Step Input from a pop-up list of all the MIDI tracks in your session.

**Step Increment**

The options in the Step Increment section let you set the spacing and duration of MIDI events entered using the Step Input operation. You can select any size from whole notes to sixty-fourth notes (including dotted values).

**Tuplet** Lets you input irregular note groupings (such as triplets or quintuplets). The tuplet length is calculated from the note spacing selection and the Tuplet values. For example, an eighth note equals 480 ticks, so tuplet eighth notes with 3 in time of 2 would yield a note spacing of 320 ticks (480 ticks / 3 * 2).

**Note Length** Lets you select the note length as a percentage of the spacing value. For example, an eighth note equals 480 ticks, so an eighth note with an 80% duration would be 384 ticks long.

**Options**

**Use Input Velocity** When selected, MIDI notes are recorded using the velocity that you play on your MIDI keyboard.

**Set Velocity To** When selected, MIDI notes are recorded with the velocity that you specify in the Velocity field. This value can be set with the Velocity slider.

**Enable Numeric Keypad Shortcuts** When selected, Step Input options can be selected from the numeric keypad. See “Numeric Keypad Shortcuts” on page 202.

**Undo Step, Next Step (or Increment), and Redo Step**

Use the Undo Step and Next Step buttons to do the following:

- Move the step insertion point, by either removing the previous note or by advancing the insertion point by the Step Increment value.
- Lengthen and shorten notes that are being held on the MIDI controller, by adding or removing Step Increment values. The Step Increment value can be changed mid-note to create a note with a hybrid note length.

Use the Redo Step button to sequentially redo any previously undone steps.

**Undo Step** When the previous note has been released from the MIDI keyboard, and the insertion point has moved forward to the next note, Undo Step will remove the entire last note.

When a note is being held on the MIDI keyboard, Undo Step changes to read “Decrement,” and removes the last Step Increment length that was added to the held note.

**Next Step (or Increment)** When no note is being held on the MIDI keyboard, Next Step moves the insertion point by the Step Increment value, essentially inserting a musical rest.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment” and adds the Step Increment value to the held note, increasing its length by the Step Increment value.

---

*Note Length percentages*
While the note is being held, the Step Increment value can be changed, allowing you to create notes of any musical length.

**Redo Step** Reinserts the last note that was removed by the Undo Step operation.

The Undo Step, Next Step and Redo Step buttons can be set to be triggered by an external MIDI synth, drum pad, or other controller.

**To set Undo Step, Next Step and Redo Step MIDI triggers:**

1. Choose Event > MIDI > Step Input.
2. Locate the button you want to assign a MIDI event to, and click in the field below the button.
3. Play the MIDI event you wish to use as a trigger.
4. Press Enter to confirm the MIDI trigger assignment.

**Numeric Keypad Shortcuts**

When Enable Numeric Keypad Shortcuts is selected, you can choose many of the controls in the Step Input page, as well as several selection controls.

<table>
<thead>
<tr>
<th>Step Input Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole note</td>
<td>1</td>
</tr>
<tr>
<td>1/2 note</td>
<td>2</td>
</tr>
<tr>
<td>1/4 note</td>
<td>4</td>
</tr>
<tr>
<td>1/8 note</td>
<td>5</td>
</tr>
<tr>
<td>1/16 note</td>
<td>6</td>
</tr>
<tr>
<td>1/32 note</td>
<td>7</td>
</tr>
<tr>
<td>1/64 note</td>
<td>8</td>
</tr>
<tr>
<td>Dotted note</td>
<td>. (decimal key)</td>
</tr>
<tr>
<td>Toggle Tuplet on/off</td>
<td>3</td>
</tr>
<tr>
<td>Next step</td>
<td>Enter</td>
</tr>
<tr>
<td>Undo step</td>
<td>0</td>
</tr>
<tr>
<td>Nudge forward</td>
<td>+</td>
</tr>
<tr>
<td>Nudge back</td>
<td>-</td>
</tr>
<tr>
<td>Select Main Counter</td>
<td>=</td>
</tr>
<tr>
<td>Edit Selection indicators</td>
<td>/</td>
</tr>
</tbody>
</table>

If you use a continuous controller such as Pitch Bend as a trigger, you should make certain to use an extreme controller value to avoid erroneous data input.
Recording System Exclusive Data

Pro Tools supports recording and playing System Exclusive data (Sysex) with MIDI tracks. This allows you to use MIDI tracks in Pro Tools to store patch and configuration data for your MIDI devices, or to record real-time Sysex changes for a particular parameter of a MIDI device that cannot be controlled by a standard MIDI controller.

To record a Sysex dump at the beginning of a MIDI track:

1. Make sure that the MIDI OUT for the device sending the Sysex is connected to your MIDI interface’s MIDI IN.
2. Configure a MIDI track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 192.
3. Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.
4. In the MIDI Input Filter dialog, enable recording of System Exclusive data.
5. If you have not done so already, record enable the MIDI track by clicking its Record Enable button.
7. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.
8. When you are ready to begin recording, click Record in the Transport window.

The Record, Play, and Wait for Note buttons flash, indicating that Pro Tools is waiting for MIDI data.

9. Initiate the Sysex transfer from the MIDI device, according to the instructions in the guide for your MIDI device. When receiving the MIDI data, Pro Tools automatically begins recording.

10. When the transfer is complete (as defined in the guide for your MIDI device), click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the Region List. MIDI regions that contain System Exclusive data appear blank when the MIDI Track View is set to Regions.

To see the Sysex event blocks, which indicate the location of the data, set the MIDI Track View to display Sysex (see “Regions View for MIDI and Instrument Tracks” on page 229). For details on moving and copying of Sysex data, see “System Exclusive Events” on page 432.

To resend the Sysex from Pro Tools:

1. For the device receiving the System Exclusive data, make sure its MIDI IN is connected to your MIDI interface’s MIDI OUT. Also, make sure the device is set to receive Sysex. Some devices require that memory protect be off.
2. For the previously recorded track, click its Record Enable button so that it is no longer record-enabled.
3. Click the track’s MIDI Output selector and assign the device from the pop-up menu.
4. In the Transport window, click Return to Zero.
5. Click Play in the Transport window to begin playback. Pro Tools begins playing and transmits the previously recorded Sysex to the assigned MIDI device.
Chapter 14: Advanced Recording

There are two advanced recording methods that differ from basic recording, QuickPunch and TrackPunch.

**QuickPunch** A nondestructive recording mode that lets record-enabled tracks be punched in and punched out during playback by clicking the Transport’s Record Enable button.

**TrackPunch (Pro Tools HD Only)** A nondestructive recording mode that lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

---

**QuickPunch Audio Recording**

Pro Tools features an on-the-fly punch capability called QuickPunch. QuickPunch lets you instantaneously punch in and out on record-enabled audio tracks during playback by merely clicking the Record Enable button in the Transport window.

For Digi 002 and Digi 002 Rack systems, and Digidesign control surfaces, you can use a footswitch to punch in and out when recording with QuickPunch.

When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating regions in that file at each punch-in and punch-out point. These regions appear in the track’s playlist; and the complete audio file appears in the Region List along with the QuickPunch created regions. Up to 200 of these “running punches” can be performed in a single pass. Unlike normal punch recording (see “Punch Recording Audio” on page 176), QuickPunch provides instantaneous monitor switching on punch-out. All QuickPunch recording is nondestructive.

**QuickPunch/TrackPunch Crossfade Length**

Pro Tools can automatically write a crossfade for each punch point when using QuickPunch. The length for these crossfades is set with the QuickPunch Crossfade/TrackPunch Length option in the Editing Preferences page.

To set the QuickPunch Crossfade Length:

1. Choose Setup > Preferences and click the Editing tab.
Enter a new value (in msec) for the QuickPunch /TrackPunch CrossFade Length.

A good general-purpose crossfade length for punches is 10 milliseconds. If you set the preference to zero, Pro Tools will not create any crossfades at the punch-in/out points.

Click Done.

If a value other than zero is specified for the QuickPunch/TrackPunch Crossfade Length, Pro Tools writes a pre-crossfade at the punch-in point (which occurs up to but not into the punched region boundary), and a post-crossfade at the punch-out point (which occurs after the punched region).

Even if the QuickPunch/TrackPunch Crossfade Length is set to zero, Pro Tools always executes a 4 millisecond “monitor only” crossfade (which is not written to disk) to avoid distracting pops or clicks that might occur as you enter and exit record mode.

QuickPunch crossfades can later be edited in the same manner as standard crossfades. For details, see “Using Crossfades” on page 333.

**QuickPunch Guidelines for Pro Tools HD**

When using QuickPunch with Pro Tools HD, two voices are required for each record-enabled, mono track. This means that you can record up to half the total number of voices available on your system. For example, a Pro Tools|HD Accel system configured for 192 voices can simultaneously record on up to 96 mono tracks with QuickPunch (or 48 stereo tracks).

If the required number of voices for the record-enabled tracks is not available when switching to QuickPunch mode, you will be prompted to free up the necessary voices.

To free up voices on tracks that are not record-enabled, and do not need to be heard while recording, do one of the following:

- Set voice assignments for tracks to Off.
- Make tracks inactive.
- Group all RTAS plug-ins before TDM plug-ins.

As necessary, voices in use by other tracks, which are not record-enabled, may be “stolen” while recording with QuickPunch. Priority for tracks while recording with QuickPunch are as follows:

- Tracks with assigned voices that are not record-enabled
- Tracks with assigned voices that are record-enabled
- Tracks with Dynamically Allocated Voicing that are not record-enabled
- Tracks with Dynamically Allocated Voicing that are record-enabled

If the session has plenty of available voices, you may have no trouble using QuickPunch with tracks using Dynamically Allocated Voicing. However, if you are running out of voices, and want to ensure that a track will be heard when recording with QuickPunch, assign it a voice.

**QuickPunch and Dynamically Allocated Voicing**

*(Pro Tools HD Only)*

When using QuickPunch with a Pro Tools|HD system configured for its maximum number of voices, make sure to set the voice assignment for each audio track to Dyn (for Dynamically Allocated Voicing). This ensures that Pro Tools will automatically handle the distribution of voices between each set of voices. For example, for a

If you do not use Dynamically Allocated Voicing, the voices must be evenly distributed between all DSP engines. For example, to use QuickPunch on 32 tracks without Dynamically Allocated Voicing, tracks 1–16 must be assigned to voices 1–16 and tracks 17–32 must be assigned to voices 33–48.

**QuickPunch Guidelines for Pro Tools LE**

For Pro Tools LE systems, 16 audio tracks can be simultaneously recorded with QuickPunch in addition to the maximum number of mono tracks supported by your specific Pro Tools LE system (see “Pro Tools LE System Capabilities” on page 10).

To simultaneously record more tracks than this with QuickPunch, you’ll need to reduce the number of tracks in the session.

> **With Pro Tools LE, QuickPunch uses CPU processing power, and may reduce the number of tracks and plug-ins you can use.**

**Recording with QuickPunch**

**To punch on-the-fly with QuickPunch:**

1. With Pro Tools HD, make sure that Delay Compensation is deselected in the Options menu.

> **Digidesign recommends recording without Delay Compensation. For more information, see “Delay Compensation” on page 505.**

2. Select Options > QuickPunch. When QuickPunch is enabled, a “P” appears in the Record Enable button.

3. To change the automatic crossfade used by QuickPunch, configure QuickPunch Crossfade Length option in the Editing Preferences page (see “QuickPunch/TrackPunch Crossfade Length” on page 205).

4. Record enable the tracks you want to punch in on. Make sure there are enough available voices on your system.

5. Prepare to record by cueing Pro Tools to an appropriate location. If you want to use pre-roll, enable a pre-roll value in the Transport window.


7. When you reach the punch-in point, click Record in the Transport window.

> – or –

For Digi 002 and Digi 002 Rack systems with a connected footswitch, press the footswitch at the punch-in point.

The Record Enable button stops flashing and stays lit during recording.

8. To punch out, click Record again (or press the footswitch).

As Pro Tools continues playing, you can perform additional punches (up to 100). When recording multiple punches during a single pass, a single audio file is recorded from which Pro Tools creates the appropriate regions.
QuickPunch with an Edit Selection

If you make an Edit selection and use QuickPunch, the following rules apply:

- If the Transport is not online, recording begins and stops whenever you click the Record Enable button—regardless of the selection’s start or end point.
- If the Transport is online, punch-in/out behavior is controlled by the Online Options setting in the Operation Preferences page. If you select Record Online at Insertion/Selection, QuickPunch punches in and out only within the selection (or in the case of an insertion point, only after the insertion point). If you select Record Online at Time Code Lock, QuickPunch disregards the selection and punches in and out whenever you want (after Pro Tools has locked to time code).

Region and Take Numbering with QuickPunch

After recording with QuickPunch, the new audio regions appear in the Region List. This includes the whole-file audio region encompassing all punches from the record pass, along with the regions derived for each punch.

Names for the punched regions are numbered consecutively starting with “01.” For example, if QuickPunch is used to punch in twice on a track called “Lead Gtr,” a region for the parent audio file appears and is named “Lead Gtr_01,” and two regions for the punches are named “Lead Gtr_01-01” and “Lead Gtr_01-02.”

If you stop playback and record additional punches with QuickPunch, subsequent regions are named by incrementing the first two digits in the name. For example, on the second pass, the punched regions are named “Lead Gtr_02-01,” “Lead Gtr_02-02,” and so forth.

TrackPunch Audio Recording

(Pro Tools HD Only)

TrackPunch makes Pro Tools more useful as a digital dubber for film re-recording (dubbing) and mixing. Keyboard shortcuts and preference settings for recording and input monitoring provide flexibility that makes TrackPunch equally useful for loading dailies and recording Foley, as well as over-dubbing and tracking in music sessions.

TrackPunch Usage Guidelines

TrackPunch and Dynamically Allocated Voicing

When using TrackPunch with a Pro Tools|HD system configured for maximum voices, make sure to set the voice assignment for each audio track to dyn for Dynamically Allocated Voicing (this mode was previously known as Auto Voice mode). This ensures that Pro Tools can automatically manage voices most efficiently.

Audio Files and TrackPunch

After a TrackPunch recording pass, the punched track’s playlist in the Edit window displays the regions created by punching. You can use any of the Trim tools after punch recording to open up the head or tail of TrackPunch (and QuickPunch) recorded regions, or to reveal the parent audio file that was recorded in the background. This lets you compensate for any late or missed punches.

Voice Requirements for TrackPunch Recording

TrackPunch requires two voices for each record-enabled, mono track. This means that you can record up to half the total number of voices available on your system.
When switching to TrackPunch mode, you will be prompted to free up additional voices if not enough are available.

**To free up voices on tracks that are not record-enabled, and do not need to be heard while recording, do one of the following:**

- Set voice assignments for tracks to Off.
- Make tracks inactive.
- Group all RTAS plug-ins before TDM plug-ins.

As necessary, voices in use by other tracks may be “stolen” while recording with TrackPunch (thus silencing some tracks).

TrackPunch voice playback priority follows the same guidelines as QuickPunch, as follows (from highest to lowest playback priority):

- Tracks with assigned voices that are not record-enabled
- Tracks with assigned voices that are record-enabled
- Tracks with Dynamically Allocated Voicing that are not record-enabled
- Tracks with Dynamically Allocated Voicing that are record-enabled

If the session has plenty of available voices, you may have no trouble using TrackPunch with tracks that use Dynamically Allocated Voicing. However, if you are running out of voices, and want to ensure that a track will be heard when recording with TrackPunch, assign it a voice.

**Overview of TrackPunch Recording**

Before using TrackPunch, configure Pro Tools and TrackPunch as follows:

**To configure Pro Tools and TrackPunch:**


2. If necessary, configure Pro Tools synchronization settings for online recording and track arming (see “Configuring Synchronization and Track Arming” on page 211).

**To use TrackPunch:**

1. Make sure Pro Tools is not recording or playing back (the Transport is stopped).

2. Make sure that Delay Compensation is deselected in the Options menu.

**Digidesign recommends recording without Delay Compensation. For more information about using Delay Compensation, see “Delay Compensation” on page 505.**

3. Enable TrackPunch mode (see “Enabling TrackPunch Mode” on page 212).

4. TrackPunch enable all audio tracks that you want to punch during the record pass (see “TrackPunch Enabling Tracks” on page 212).

5. Configure monitoring for record-enabled tracks by selecting the appropriate mode from the Track menu, as appropriate. Choices include:
   - Set Record Tracks to Auto Input
   - Set Record Tracks to Input Only

Choosing either monitoring mode only affects tracks that are record-enabled.

**You can also use the TrackInput buttons to switch the monitor source for record-enabled tracks, as explained below.**

7 If you want to compare levels of the input source with audio on disk, click the TrackInput button. When lit (green), the track is monitoring input. When unlit (grey), the track is monitoring from disk. (For more information see “Selecting Record Monitor Modes with Track-Input Monitoring” on page 155.)

8 To punch tracks one at a time, arm the Transport Record and then use the individual Track Record Enable buttons to punch each track in and out on-the-fly.

9 To punch multiple tracks simultaneously, do one of the following:
   • Record enable as many as 16 TrackPunch enabled audio tracks, then use the Transport Record Enable button to punch them in and out simultaneously.
   – or –
   • Arm the Transport Record first, then use Alt+Shift (Win) or Option+Shift (Macintosh) to simultaneously punch on all currently selected TrackPunch enabled tracks.

10 While continuing local or remote playback, do any of the following:
   • Punch in on other TrackPunch enabled tracks individually.
   • After punching out, take tracks out of record enable then record enable different TrackPunch enabled tracks.
   • Repeat as needed to punch other stems, tracks, or takes.

**TrackPunch Preferences**

The following preference settings let you customize TrackPunch performance.

**QuickPunch/TrackPunch Crossfade Length**

Pro Tools can automatically write a crossfade for each punch point when using TrackPunch. The length for these crossfades is set with the QuickPunch Crossfade/TrackPunch Length option in the Editing Preferences page.

**To set the TrackPunch Crossfade Length:**

1. Choose Setup > Preferences and click the Editing tab.
2. Enter a new value (in msec) for the QuickPunch/TrackPunch CrossFade Length.

**Transport and Track Record Settings**

The TrackPunch preferences appear on the Operation Preferences page. These preferences specify how track and Transport record status respond when the Transport is stopped (during playback and recording), and let you optimize Pro Tools for film, video, and music production workflows.

> Use groups for single-click selection of multiple tracks (click to the left of the Group Name in the Group List).

![TrackPunch preferences](image-url)
Transport RecordLock

This setting lets the Transport Record be configured to either emulate a digital dubber, or to maintain legacy behavior for the Transport master Record.

- When not enabled, the Transport Record disarms when Pro Tools is manually stopped or stops due to a loss of time code. This replicates legacy Pro Tools recording behavior.
- When enabled, the Transport Record remains armed when playback or recording stops. This saves having to re-arm the Transport between takes, emulating digital dubber behavior.

Destructive Recording and Transport RecordLock

As a precaution against accidentally recording over previous material, the Transport RecordLock preference is automatically disabled and greyed out when Destructive record mode is enabled.

Audio Track RecordLock

This setting lets Pro Tools tracks be configured to either emulate a digital dubber, or to maintain legacy behavior for track record status.

- When the Audio RecordLock preference is enabled, the record-enabled audio tracks remain armed when playback or recording stops.
- When the Audio RecordLock preference is not enabled, record-enabled audio tracks are taken out of record enable when Pro Tools is stopped. This prevents tracks from remaining armed from pass to pass, emulating track record behavior of a digital dubber.

Destructive Recording and Transport RecordLock

As a precaution against accidentally recording over previous material, the Transport RecordLock preference is automatically disabled and greyed out when Destructive record mode is enabled.

Configuring Synchronization and Track Arming

For online recording and punching, configure the following Peripheral and Session Setup settings. For best lockup times when synchronizing, it is recommended that no more than 16 tracks be TrackPunch-enabled at a time.

To record online using TrackPunch switching:

1. Choose Setup > Peripherals, and make sure the SYNC I/O is the selected synchronization peripheral, and is communicating with Pro Tools.
2. Choose Setup > Session, and do the following:
   - Select a Clock and Positional reference.
   - If you want Pro Tools to be the time code master, enable Using SYNC/USD. This option is located in the Generator controls in the Time Code Settings section of the Session Setup window.
3. If you are controlling Pro Tools using 9-pin protocol, do the following:
   - Click the Machine Control tab to display the Machine Control page of the Peripherals dialog.
   - Configure Remote 9-pin Deck Emulation mode settings (see the MachineControl Guide for details).
   - Click OK to close the Peripherals dialog.

Consult the manufacturer of your controller for the most recent machine profiles and updates available for Pro Tools support.
Enabling TrackPunch Mode

Before you can enable individual audio tracks for TrackPunch recording, TrackPunch mode must be enabled in the Pro Tools transport.

To enable TrackPunch mode:

1. Make sure Pro Tools is not recording or playing back (the Transport is stopped).

2. Do one of the following:
   - Select Options > TrackPunch.
   - Right-click (Windows) or Control-click (Macintosh) the Transport Record Enable button to cycle through available Record modes until TrackPunch mode is selected (a “T” indicates TrackPunch mode).
   - Press Control+Shift+T (Windows) or Command+Shift+T (Macintosh).

Transport Record Enable Button

The Transport Record Enable button indicates TrackPunch and Record status as follows:

When TrackPunch mode is enabled:

- A “T” appears in the Transport Record Enable button.
- If at least one track is TrackPunch-enabled, the Transport Record Enable button lights solid blue.

When TrackPunch mode is enabled and the transport is armed for recording:

- If no tracks are TrackPunch-enabled, the Transport Record Enable button flashes gray and red.
- If at least one track is TrackPunch-enabled, the Transport Record Enable button flashes blue and red.
- If at least one TrackPunch-enabled track is also record-enabled, the Transport Record Enable button flashes blue and red, and the record LED lights.
- Whenever at least one audio track is recording, the Transport Record Enable button lights solid red.

TrackPunch Enabling Tracks

You can TrackPunch enable tracks without record enabling them, which lets you punch in individual tracks after you start playback.

To TrackPunch enable or disable an audio track:

- Start-click (Windows) or Control-click (Macintosh) the track’s Record Enable button to toggle the button to solid blue.
To TrackPunch enable or disable all audio tracks:
- Alt-Start-click (Windows) or Option-Control-click (Macintosh) a track’s Record Enable button to toggle the all Record Enable buttons to solid blue.

To TrackPunch enable or disable all selected audio tracks:
- Start-Alt-Shift-click (Windows) or Control-Option-Shift-click (Macintosh) a track’s Record Enable button to toggle the Record Enable buttons for the selected audio tracks solid blue.

Create track groups for each stem or set of tracks on which you plan to punch. Use the Group List to quickly select all tracks in the group. This makes it easier and faster to take multiple tracks in and out of TrackPunch enable simultaneously.

Track Record Status Display
Each track’s Record Enable button indicates its TrackPunch and record enable status as follows:
- When a track is both TrackPunch-enabled and record-enabled, its Record enable button flashes blue and red.
- When a track is TrackPunch-enabled but not record-enabled, its Record Enable button lights solid blue.
- When a track is record-enabled only, its Record Enable button flashes red.
- While a track is recording (in any mode), its Record Enable button lights solid red.

TrackPunch Recording
After you have put Pro Tools in TrackPunch mode, and enabled tracks for TrackPunch recording, you can record with TrackPunch in several ways.

Punching In on Individual Tracks
To punch in on individual tracks:
1. Put Pro Tools in TrackPunch mode.
2. Start-click (Windows) or Control-click (Macintosh) the Record Enable button for each track you want to punch in, so that the track is TrackPunch-enabled only. The track’s Record Enable button should light solid blue.
3. Click Record in the Transport window to enter the TrackPunch Record Ready mode. The Record Enable button flashes blue and red.
4. Click Play in the Transport window to begin playback.
5. During playback, punch in and out on individual TrackPunch-enabled tracks by clicking their Record Enable buttons.
6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current TrackPunch preference settings.
Punching In on Multiple Tracks Simultaneously

To punch in on multiple tracks simultaneously:

1. Put Pro Tools in TrackPunch mode.

2. Click the Record Enable button on each track you want to punch in, so that the track is both TrackPunch- and Record-enabled. The track’s Record Enable button should flash blue and red.

3. Click Play in the Transport window to begin playback.

4. During playback, click Record in the Transport window to punch in and out on all TrackPunch-enabled tracks simultaneously.

5. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current TrackPunch preference settings.

Start Recording on All Tracks

1. Put Pro Tools in TrackPunch mode.

2. Click the Record Enable button on each track you want to punch in, so that the track is both TrackPunch- and Record-enabled. The track’s Record Enable button should flash blue and red.

3. Click Record in the Transport window to enter the TrackPunch Record Ready mode. The Record Enable button flashes blue and red.

4. Click Play in the Transport window to begin playback.

5. During playback, punch out and back in on individual TrackPunch-enabled tracks by clicking their Record Enable buttons.

6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current TrackPunch preference settings.

Example TrackPunch Workflows

With TrackPunch, Pro Tools emulates and enhances the following four types of production work (or “workflows”) commonly performed in film, video, and music production:

- Dubbing and mixing film (see “Film Dubbing and Mixing with TrackPunch” on page 214)
- Loading dailies (see “Loading Dailies Using RecordLock” on page 215)
- Recording Foley (see “Foley Recording with TrackPunch” on page 216)
- Tracking and overdubbing in music production and any other recording situation (see “Tracking and Overdubbing Music with TrackPunch” on page 216)

Each of these workflows takes advantage of TrackPunch features and options.

In the following example workflows, it is assumed you are familiar with routing, selecting, and grouping Pro Tools tracks. If you are not, see the appropriate topic in Pro Tools Reference Guide.

Film Dubbing and Mixing with TrackPunch

By providing all the essential online punch recording and monitor switching capabilities of a digital dubber, TrackPunch optimizes Pro Tools for re-recording and mixing for film.
Film dubbing and mixing features of TrackPunch let you do the following:

- Arm and punch Pro Tools audio tracks remotely from a master synchronizer such as SoundMaster through P2 commands at any time, without having to stop playback and while maintaining time code lock. (Requires Digidesign MachineControl.)
- Toggle Pro Tools audio tracks between input and disk monitoring.
- Use TrackPunch when Pro Tools is the time code master (generating) and when slaving.
- Because Pro Tools can be networked, TrackPunch (and all other) audio files and whole sessions can be available for secure transfer to other systems for review, editing, and archiving.

**A typical pre-dub session using TrackPunch includes the following steps:**

1. Configure synchronization between Pro Tools and other devices as appropriate.
2. Choose Setup > Preferences and click the Operation tab.
3. Select (enable) Transport RecordLock. This will keep the Transport Record armed after the transport stops.
4. Deselect Audio Track RecordLock. This will cause the audio track record to disarm when the transport stops.
5. Choose Options > TrackPunch to enable TrackPunch mode.
6. Create 32 new tracks, then do the following:
   - Assign their inputs
   - Group them into eight-track groups.
7. Click the record enable buttons in the first eight tracks to TrackPunch enable the first eight tracks (or, the group for the first pre-dub).
8. Assign the console paddles to the first eight-track group in the session.
9. Begin the pre-dub pass. Use the console paddles to arm Pro Tools, and to punch in and out on the first group.
10. When the first pre-dub is over and all tracks are punched out, clear all TrackPunch enabled tracks.
11. Select the next group of tracks and TrackPunch-enable them.
12. Punch in and out on the second group of tracks.
13. Repeat as needed.

**Loading Dailies Using RecordLock**

In addition to its uses on dub and mix stages, Pro Tools makes it easy to load dailies. Dailies and similar types of transfers are comprised of multiple takes or scenes, each recorded while locked to unique time-of-day time code. In between each take, time code does not continue but stops completely. Because of this, the time code on dailies and similar source material is said to be “discontiguous” or discontinuous (also known as broken time code).
When a session is taken offline while recording due to broken time code, Pro Tools remains armed and waits for time code to resume. Pro Tools begins recording again when lock is re-established with the time code of the next take. Each take is recorded to its own audio file.

**To configure RecordLock for loading:**

1. Choose Setup > Preferences and click the Operation tab.
2. Select (enable) Transport RecordLock.
3. Select (enable) Audio Track RecordLock.
4. Configure synchronization and other settings as required. Put Pro Tools online, and start the external source player.
5. Whenever time code drops out or stops, Pro Tools remains online and waits to receive new time code. The Transport and record-enabled tracks remain record-enabled (or TrackPunch enabled). When time code resumes, Pro Tools begins recording to a new audio file (properly time stamped based on the incoming code).

⚠️ Because Pro Tools has a 13-hour timeline limit, you will have to use multiple sessions to load dailies if the span is more than 13 hours.

**Foley Recording with TrackPunch**

Foley recording is one of the more specialized forms of recording in film production with unique monitoring requirements. Between punches and takes, inputs must be muted while Foley artist move themselves and equipment as they progress through a scene.

TrackInput monitoring can be configured to support Foley style TrackPunch recording using the Mute Record-Armed Tracks While Stopped preference.

**To configure Pro Tools for Foley-style punch record monitoring:**

1. Choose Setup > Preferences and click the Operation tab.
2. Enable Mute Record-Armed Tracks While Stopped.
3. Configure synchronization and other settings for Pro Tools and your other devices, then enable TrackPunch mode and proceed with punch recording. (See “Overview of TrackPunch Recording” on page 209 for the complete steps.)

While Mute Record-Armed Tracks While Stopped is enabled, and while recording online, record-enabled tracks mute when the Transport is stopped. Input can still be monitored at any time by using the TrackInput switch.

**Tracking and Overdubbing Music with TrackPunch**

Modern multitrack recording requires the flexibility to “capture the moment” by allowing on-the-fly record enabling and punch recording, as provided by TrackPunch. Features of TrackPunch for all tracking, overdubbing, and punching situations include the following:

- Record enable tracks on-the-fly.
- Punch tracks in and out using on-screen Record Enable buttons, remotely from a synchronizer, from a control surface, or using a foot switch.
- Compare and match levels using TrackInput switching.
Part IV: Editing
Chapter 15: Editing Basics

Pro Tools Editing

The Edit window in Pro Tools provides a powerful collection of tools for editing and assembling audio and MIDI. Track material can be edited nondestructively and in real time during playback.

The Edit window also lets you graphically edit track automation. For more information on Automation in the Edit window, see Chapter 27, “Automation.”

Nondestructive Editing

The vast majority of audio editing in Pro Tools is nondestructive. Whether cutting, pasting, trimming, separating, or clearing regions, you are only performing these functions on a map of the actual audio data. The source audio files remain untouched. If a particular process or tool works destructively (that is, if it can permanently change audio files on your hard disk), this guide alerts you.

While editing for MIDI tracks is in some instances destructive, with a few precautions you can keep important MIDI tracks and regions safe when performing edits (see “Nondestructive MIDI Editing” on page 230).

Editing During Playback

Pro Tools lets you perform many editing tasks while the session plays. This powerful capability allows you to interactively modify and edit a session, hearing the changes as you make them. You’ll find many instances where you can use this capability to increase your productivity when working with a session.

Following are just a few examples of editing that can be performed while your tracks loop or play:

- Capture, separate, and trim regions
- Place, spot, or rearrange regions
- Add fades or crossfades to audio regions
- Transpose, quantize (including Groove Quantize), and otherwise modify MIDI tracks
- Nudge audio or MIDI regions
- Audition different playlists
- Adjust or scale automation data
- Insert a real-time plug-in
- Process audio with an AudioSuite plug-in
- Automation breakpoint editing

There are a few things that cannot be changed while Pro Tools plays, as noted throughout this guide. These include routing to sends and assigning outputs.
Track Material

Each time you record or import audio and MIDI, Pro Tools creates regions for the new track data, which not only indicate where the material begins and ends, but also provides good feedback on its general shape and content. When you record additional takes, or "punch in" on a specific location within a track, Pro Tools creates additional regions.

Regions are also created by cutting and pasting, resizing, separating, and re-capturing existing regions. Regions in a session are listed in the Region List, where they can be dragged to existing tracks. A track can contain any number of regions, in any arrangement. The order and location of regions in a track define its playlist.

Region Types

There are different types of audio and MIDI regions, based on how they are created:

Whole-File Audio Regions These audio regions are created when recording or importing audio, consolidating existing regions, and when non-destructively processing with an AudioSuite plug-in. Whole-file audio regions reference an entire audio file that resides on your hard drive. Whole-file audio regions are displayed in bold in the Region List (see “The Region List” on page 240). Normal regions often reference only a portion of the parent audio file and are created in the course of editing and, in some instances, when punch recording.

User-Defined Regions These are regions that are explicitly defined, such as when you record or import audio or MIDI; capture, separate, or consolidate a selection; trim a whole-file audio region; and rename an existing region.

Auto-Created Regions These regions are automatically created in the course of editing, and, in some instances, when punch recording over existing regions. Since these regions can accumulate rapidly in a session, you can hide them so they do not appear in the Region List (see “Naming and Displaying Regions” on page 350). Auto-created regions can be turned into user-defined regions by renaming them.

Offline Regions Regions are offline when their parent audio files cannot be located, or are not available, when opening a session or importing a track. Offline regions appear in the Region List as italicized and dimmed; they appear in playlists as light blue regions with italicized names. Offline regions can be edited like other regions, but they cannot be processed with AudioSuite plug-ins.

Multichannel Regions These regions, which are displayed as a single region in the Region List, reference multiple regions and audio files for stereo and surround tracks. Multichannel regions can be expanded (by clicking the triangle next to their name) to see the individual channels, which can be dragged independently to tracks.

Region Groups A region group is a collection of any combination of audio and MIDI regions that looks and acts like a single region. Region groups are essentially containers holding one or more regions. Region groups can be created on a single or on multiple adjacent audio, MIDI, and...
Instrument tracks. Region groups let you “nest” multiple regions into “macro” regions for groove and tempo manipulation, editing, and arranging.

For more information on region groups, see “Region Groups” on page 321.

Track View

The Track View determines which data is displayed and edited in the track's playlist area. Track View data can be set to Blocks, Waveform, Volume, Pan, Mute, or an automated control or continuous controller, based on the track type:

Audio Tracks These tracks can be set to Blocks, Waveform, Volume, Pan, Mute, or any plug-in controls that have been automated. Except when editing automation data, audio tracks are by default set to Waveform, where track material is graphically drawn with amplitude waveforms (a time-domain representation of sound). This Track View provides the necessary detail for important region edits.

Auxiliary Input Tracks These tracks can be set to Volume, Pan, Mute, or any plug-in control that has been automated.

Master Fader Tracks These tracks can be set to Volume, or any plug-in control that has been automated.

MIDI Tracks These tracks can be set to Blocks, Regions, Notes, Volume, Pan, Mute, Velocity, Pitch Bend, After Touch, Program, Sysex, and any continuous controller type. Except when editing controller data, program changes, or Sysex events, MIDI tracks are commonly set to Notes or Regions, each of which displays notes in a “piano roll” format. Use Notes View for inserting, editing, and copying and pasting MIDI notes; use Regions View to arrange, capture, or consolidate regions.

With the Track View set to Blocks, audio and MIDI regions are displayed as empty blocks bearing the region's name. This mode is most useful once you have finished capturing and editing regions at the waveform or MIDI event level and are moving and rearranging them. Screen redraws are fastest with this format.

When an audio or Instrument track is displayed as Volume, Pan, or another automated control, or when a MIDI or Instrument track is set to one of the continuous controller types (Volume,
Pitch Bend, After Touch), the data for that track appears in the form of a line graph with a series of editable breakpoints. The breakpoints can be dragged to modify the automation data, and new breakpoints can be inserted with the Pencil tool or a Grabber tool.

For details on editing automation data for audio tracks, see Chapter 27, “Automation.” For details on inserting and editing controller data for MIDI tracks, see “Continuous Controller Events” on page 426.

To set the Track View:
- Click the Track View selector for the track and choose the format from the pop-up menu.

Changing Track Views

For audio, Auxiliary Input, MIDI, and Instrument tracks, you can change to the next or previous Track View, or toggle between pre-defined common views.

Changing to Previous or Next Track View

When changing to the next or previous Track View, Track View list ordering is maintained as shown in the Track View selector.
To change to the previous or next Track View:

1. Click in the track you want to change. To change views on multiple tracks, Shift-click or drag the Selector tool to select additional tracks, or select a group.

2. Do one of the following:
   - To change to the previous or next Track View on all selected tracks, press Control+Start (Windows) or Control+Command (Macintosh) and the Left or Right Arrow.
   - or –
   - To change to the previous or next Track View on all tracks, press Control+Alt+Start (Windows) or Control+Option+Command (Macintosh) and the Left or Right Arrow.

To toggle Track Views on selected tracks:

1. Click in the track you want to toggle. To toggle multiple tracks, Shift-click or drag the Selector tool to select additional tracks.

2. Do one of the following:
   - Press Start+Minus (Windows) or Control+Minus (Macintosh) on the QWERTY keyboard.

   – or –
   - With Commands Keyboard Focus enabled, press Minus on the QWERTY keyboard.

To toggle Track Views for all tracks, press Start+Alt+Minus (Windows) or Control+Option+Minus (Macintosh) on the QWERTY keyboard.

Audio tracks are toggled between Waveform and Volume View. MIDI and Instrument tracks are toggled between Notes and Regions View.

Master Views for Tracks

Audio, MIDI, and Instrument tracks have Track Views that act as “master.” When a track is displayed in its Master View, any edits performed apply to all data in the track. For instance, when an audio track is set to Waveform, copying and pasting affects not just the waveform information, but all of the automation data as well.

The Master View is based on the type of track, as follows:

- Audio tracks: Waveform and Blocks
- MIDI and Instrument tracks: Regions, Blocks, and Notes (when using the Selector tool)

Auxiliary Inputs and Master Fader tracks also have a Master View (Volume). When an Auxiliary Input or Master Fader track is displayed in its Master View, any edits performed apply to all automation data in the track.
**Track Height**

Tracks can be viewed in the Edit window at any of six heights: Mini, Small, Medium, Large, Jumbo, and Extreme. Larger track heights are particularly useful for precise editing, especially for MIDI. Smaller track heights are useful for conserving screen space in a large session.

You can adjust track heights on an individual track basis or set all tracks to the same height. Track heights can be adjusted during playback.

**To set the Track Height:**
- Click the small arrow next to the Track View selector to get the Track Height pop-up menu.
- Click in the area just to the right of the track controls and choose the height from the pop-up menu.

The track is resized to the new height. If the track is part of an Edit Group, all tracks in the group are set to the new height.

Press Start+Up/Down Arrow key (Windows) or Control+Up/Down Arrow key (Macintosh) to increase/decrease track height of any track that contains a selection or in which the edit cursor is currently placed.

**Expanded Track Display**

Stereo and multichannel tracks share a single playlist for volume and mute. This shared playlist normally occupies the entire height of the track, extending across all channels.

With Expanded Track Display, you can display playlists individually for each channel, thereby allowing for more accurate breakpoint editing. This is also useful for editing pan or multi-mono plug-in data, both of which can be different for each channel.

Expanded Track Display also provides for a larger waveform display (equal to mono tracks), as well as a separate Track View selector and meter for each channel.

**To turn on Expanded Track Display:**
- From the Track Height selector, click Expanded Track Display.
Track Controls and Track Height

The Track Height affects how the various track controls appear in the Edit window. For instance, when a track's height is set to Small, most of the buttons are reduced in size.

Track Height set to Small

When the Track Height is set to Mini, only controls for Record, Solo, and Mute appear, and the menus for Playlist, Track Timebase, Track Height, and Track View are accessed from the same selector.

Track Height set to Large

When the Track Height is set to Large, Jumbo, or Extreme, all track controls are displayed at their full size.

Displaying Region Names, Region Times, and Other Data in Playlists

Region names and times can sometimes get in the way of editing audio waveforms and MIDI data. In these instances you may want to disable their display. In other instances, such as arranging or spotting Foley, displaying region names and times is extremely useful.

To enable or disable the display of region names in playlists:
- Select or deselect View > Region > Name.

To display region times:
- From View > Region, select one of the following options:
  - **No Time** Disables display of region times.
  - **Current Time** Displays start and end times for regions.
  - **Original Time Stamp** Displays the Original Time Stamp for each region. The Original Time Stamp is the original time code location for the region when it was first recorded or created.
  - **User Time Stamp** Displays the User Time Stamp for each region. The User Time Stamp, which defaults to the Original Time Stamp, can be redefined with the Time Stamp command.
Region and region group Sync Points can be displayed (see “Sync Points” on page 303). This is useful when visually spotting to timecode or in arranging in Grid mode.

Region Overlaps can also be displayed. This is useful for arranging and when working with tick-based audio tracks (see “Region Overlap and Underlap” on page 292).

Audio Regions and Waveforms

When the Track View for audio tracks is set to Waveform, Pro Tools draws a waveform diagram of the audio. Audio waveforms tell you several things about the recorded sound.

In Figure 8, the “peaks” represent places in the recording where the attack of the sound causes the volume to increase momentarily. These are followed by “valleys,” where the volume decreases.

Different types of sounds produce different types of waveforms. Drums, for example, generally produce waveforms with sharp transients (peaks of short duration) that are clearly defined. A drum hit has a loud, sharp attack and a rapid decay.

Other sounds, such as vocals or sustained keyboard sounds, produce very different waveforms, ones that have less pronounced peaks and valleys. That’s because these sounds generally have softer attacks and longer decays.

Draw Waveforms Rectified Preference

When the Display preference for Draw Waveforms Rectified is selected (in the Display Preferences page), audio waveforms are displayed so that their positive and negative waveform excursions are summed together and viewed as a single positive-value signal. However, even when this preference is enabled, zooming in beyond a certain point will cause the waveforms to be displayed normally.

Rectified mode displays more detailed waveforms when using track heights of Medium or Small, and can be particularly useful when editing volume automation data, since it depicts waveform “levels” as starting at the bottom of the track.

Guidelines for Editing Waveforms

With the Selector tool in the Edit window, you can select portions of audio waveforms and divide them into segments called regions, so that you can rearrange and manipulate them in tracks.
While editing, try to create regions that allow you to maintain a consistent beat. If you always define regions so that they contain a whole number of beats, you will be able to string the regions together and maintain a smooth, steady rhythm.

It’s sometimes useful to have a steady, well-defined waveform (such as a drum track) as a guide when selecting and defining other regions. If you have played in time with the beat, it should be easier to create rhythmically accurate regions by referring to the drum waveform.

Some important rules to keep in mind when defining regions:
- Whenever possible, begin a region precisely before a volume peak, and end it immediately before another volume peak.
- Whenever possible, make sure a region starts and ends on exactly the same part of a beat.
- Use the following Pro Tools features to help you edit rhythmic material or audio with clear transients into precise regions:
  - Tab to Transients (see “Tabbing to Transients” on page 283.)
  - Beat Detective (see Chapter 21, “Beat Detective”)
  - Editing to a Grid (see “Grid” on page 247)

Avoiding Clicks and Pops

If an edited region begins or ends at a point of high amplitude, you may hear an unpleasant click when Pro Tools plays from one region to another. In order to avoid clicks or pops do any of the following:
- Make sure that the start and end points of your selection are as close as possible to the point where the amplitude of the waveform tapers down to meet the zero-crossing line (the center line of the track’s waveform display). If necessary, use the zooming tools in the Edit window (see “Zooming” on page 249) to display waveforms in greater detail.

Selection that begins and ends at zero crossings

- With Pro Tools HD, use the AutoFade feature to apply real-time fade-ins/outs to all region boundaries that do not touch or overlap other regions. See “Using AutoFades” on page 343 for details.

- Apply a crossfade between regions where a click or pop occurs. See “Creating a Crossfade” on page 340 for details.

Nondestructive Audio Editing

When editing an audio track’s playlist in Pro Tools, you’re not actually cutting and moving pieces of sound as you would if you were cutting and splicing analog tape. Instead, Pro Tools creates a map of the audio file on your hard disk, which describes the order in which to play the track portions.

When trimming audio regions with any of the Trim tools, or when editing the placement or order of regions within a track, use multiple playlists to easily return to a track’s previous state. See “Playlists” on page 236 for details.
Audio Regions and Automation Data

Automation data for audio resides in tracks and not in the Region List. This means that when you drag an audio region from the Region List to a new track, no automation data is placed in the track. However, if you drag an audio region from an existing track (that contains automation data) to another track, the automation from the source track is placed in the destination track.

MIDI Regions and MIDI Data

The two most common Track Views you will use for MIDI and Instrument tracks are Notes and Regions.

Use Notes View for inserting and editing individual MIDI notes, and for working with and affecting groups of notes.

Use Regions Views when you need to experiment with the arrangement of regions, or define new ones.

For more information on setting Track View, see “Track View” on page 221.

To toggle the Track View, click in the track you want to toggle and press Start+Minus (Windows) or Control+Minus (Macintosh) on the QWERTY keyboard.

Notes View for MIDI and Instrument Tracks

When a MIDI or Instrument track’s Track View is set to Notes, MIDI notes are displayed in a “piano roll” format. Each note is displayed as a small rectangle with its vertical placement indicating pitch and its horizontal placement indicating location (and duration).

For more information on setting Track View, see “Track View” on page 221.

To toggle the Track View, click in the track you want to toggle and press Start+Minus (Windows) or Control+Minus (Macintosh) on the QWERTY keyboard.

Figure 9. MIDI track displaying notes

To the left of the MIDI or Instrument track’s playlist is a vertical mini-keyboard, complete with octave numbering, for pitch reference. You can Control-click (Windows) or Command-click (Macintosh) the mini-keyboard to audition pitches. Arrows at the top and bottom of the mini-keyboard (not available in the smaller track heights) are used to scroll the Notes display up and down.

In Notes View, the pitch range of MIDI notes that can be displayed depends on the track height, and on the current zoom value. Any time a track’s notes do not fit within its current height, notes above or below the viewed area are displayed as single-pixel lines at the very top and bottom of the range (see Figure 9 on page 228).
To scroll the Notes display up or down for a MIDI or Instrument track:

- Click either the up or down arrow of the mini-keyboard.

- With any of the Edit window tools (such as the Time Grabber tool) selected, press Control+Alt+Start (Windows) or Command+Option+Control (Macintosh) and click and drag up or down on the track.

Using the Edit window tools, notes can be inserted, transposed, trimmed, and moved. For more information, see “Manually Editing MIDI Notes” on page 419.

**Regions View for MIDI and Instrument Tracks**

MIDI and Instrument tracks can also be viewed as Regions, which is similar to Waveform View for audio tracks. While a track's notes are visible in Regions View, individual note editing is not available in this view. Instead, all editing occurs across a time range encompassing all track data, including continuous controller events, program changes, and System Exclusive events.

Use Regions View to define regions that represent song sections and clips, or to rearrange or assemble track material.

In Regions View, the vertical Zoom is automatically scaled to fit the entire range of pitches (tes-titura) of MIDI notes on a track.

For more information on setting Track View, see “Track View” on page 221.

To toggle Track View between notes and regions, click in the track you want and press Start-Minus (Windows) or Control-Minus (Macintosh) on the QWERTY keyboard, or press Control-Alt (Windows) or Command-Option (Macintosh) and use the Left and Right Arrow keys to cycle between Track Views.

There are a few things to consider when selecting, copying and cutting, and trimming MIDI regions:

- When cutting or clearing a region or region group selection that includes a note's start point, the entire note is removed. This is even the case when only a portion of the note (that includes its start point) is selected.

- When copying or cutting a region or region group selection that includes a note's end point (but not its start point), the note remains and overlaps the edge of the region.

If you have a mouse with a scroll wheel, you can use it to scroll a MIDI or Instrument track's Notes display. Place the mouse over a MIDI or Instrument track in the Edit window, and Alt-Start-Control-scroll (Windows) or Command-Control-Option-scroll (Macintosh) the scroll wheel to scroll the Notes display for that track.
Similar rules also apply when MIDI regions or region groups containing MIDI regions are trimmed with any of the Trim tools. If the MIDI region’s start point is moved beyond a note’s start point, the note is removed. If the region’s end point is trimmed so that a note’s start point is within the region but its end point is not, the note remains and overlaps the edge of the region.

When moving and placing MIDI regions with overlapping notes, the notes always move with the regions. When placing MIDI regions with overlapping notes next to or near another region, the overlapping notes extend into the adjacent region.

Nondestructive MIDI Editing

While editing audio regions is usually non-destructive, this is not always the case for MIDI regions. For instance, if a MIDI region resides in just one track at a single location, editing for that region is destructive. This means that altering the pitch, duration, or placement of notes in Notes View permanently alters the region.

However, when editing a MIDI region that appears elsewhere, in the same track (at another location or in a different playlist) or in another track, the editing is nondestructive and creates a new auto-created region. To go back to the previous material, drag the original region from the Region List, or return to a previously saved playlist.

One way to safely return to a track’s previous state is with playlists. Before you edit notes, trim regions, or rearrange the order of regions, make a duplicate of the track’s existing playlist and instead work with it (see “Playlists” on page 236).

To apply edits to all instances of a MIDI region, enable Mirrored MIDI Editing mode (see “Mirrored MIDI Editing” on page 415).

MIDI Regions and Continuous Controller Events

Continuous controller events reside in MIDI regions and not in tracks. This means that when dragging regions that contain controller data from either a track or the Region List, the controller data is written to the destination track.

Unlike continuous controller events, which represent nuances that are part of a MIDI performance, Mute in Pro Tools is an automation playlist that actually mutes the MIDI engine. Mute automation does not correspond to actual MIDI events and is therefore not exported when saving as a Standard MIDI File.
Timebase Rulers and Conductor Rulers

Any or all of the following Timebase rulers can be displayed at the top of the Edit window:

- Bars:Beats
- Minutes:Seconds
- Time Code (Pro Tools HD and Pro Tools LE with DV Toolkit only)
- Feet+Frames (Pro Tools HD and Pro Tools LE with DV Toolkit only)
- Samples

In addition to providing a timing reference for track material, the Timebase rulers are also used to define **Edit selections** for track material, and **Timeline selections** for record and play ranges.

With the Selector tool, drag in any Timebase ruler to select material across all tracks in the Edit window. To include the Conductor tracks in the selection, press Alt (Windows) or Option (Macintosh) while dragging.

Any or all of the following Conductor rulers can be displayed:

- Tempo (and Tempo Editor)
- Meter
- Markers

The Meter and Tempo rulers indicate changes in meter and tempo within the Session. The Markers ruler displays markers to important track locations.

- For more information on Tempo rulers, see “Tempo” on page 354.
- For more information on Meter rulers, see “Meter Events” on page 374.
- For more information on markers, see Chapter 20, “Conductor Tracks and Memory Locations.”

To display all rulers:
- Select View > Rulers > All.

To remove a ruler from the display:
- Option-click the ruler’s name (to the left of the ruler display).
- or –
- Choose View > Rulers, and select a ruler option.

To display only the Main Time Scale in the Timebase ruler:
- Select View > Rulers > None. (See “Main Time Scale” on page 232.)

To add a specific ruler to the display, such as the Markers ruler, for instance:
- Select View > Rulers > Marker.
To change the display order for the rulers:
■ Click a ruler’s name and drag up or down to the new location.

Ruler View Selector
The Timebase and Conductor rulers can also be configured with the Ruler View selector.

Main Time Scale
While all Timebase rulers can be displayed simultaneously in the Edit window, there is only one that represents the Main Time Scale. This ruler is also called the Main Timebase ruler.

The Main Time Scale determines the time format used for:
• The Main Counter in the Transport window
• The Main Counter at the top of the Edit window
• Start, end, and length values
• Pre- and post-roll amounts
• Grid and Nudge values

The Main Time Scale can be set to the following formats:

Bars:Beats Displays the Time Scale in bars and beats. Use this Time Scale if you are working with musical material that must align with bars and beats.

To ensure your tracks align with the bars and beats in your session, record with a click (see “Recording with a Click” on page 165). Material that is recorded without listening to the click can still be aligned to bar and beat boundaries in Pro Tools with the Identify Beat command (see “Identify Beat Command” on page 370), or with Beat Detective (see Chapter 21, “Beat Detective”).

Minutes:Seconds Displays the Time Scale in minutes and seconds. As you zoom in farther with the Zoomer tool, the Time Scale begins to display tenths, hundredths, and thousandths of a second.

Time Code (Pro Tools HD and Pro Tools LE with DV Toolkit Only) Displays the Time Scale in SMPTE frames. The Time Code Rate and Session Start time are set from the Session Setup window.

Pro Tools supports the following frame rates: 23.976, 24, 25, 29.97 Non-Drop, 29.97 Drop, 30 Non-Drop, and 30 Drop frames per second.

Feet+Frames (Pro Tools HD and Pro Tools LE with DV Toolkit Only) Displays the Time Scale in feet and frames for referencing audio-for-film projects. The Feet+Frames time display is based on the 35 millimeter film format.

Samples Displays the Time Scale in samples. This format is very useful for high-precision sample editing.
Setting the Main Time Scale

To set the Main Time Scale, do one of the following:

- Choose View > Rulers, and select a Time Scale.
- Click a Main Counter selector (located at the top of the Edit window and also in the Transport window, when it is set to display Counters) and select a Time Scale.
- If a Timebase ruler is displayed, click its name so it becomes highlighted.

Setting the Main Time Scale to the timebase currently displayed in the Sub Counter switches the two Time Scales, setting the Sub Time Scale to the previous timebase of the Main Time Scale.

Navigating with the Main Counters

The Main Counters (at the top of the Edit window and in the Transport window) provide a convenient way to navigate to a specific time location.

To navigate with a Main Counter:

1. Click in a Main Counter.
2. Type in a location.
3. Press Enter (Windows) or Return (Macintosh) to automatically locate to a new location.

Setting the Sub Counter Time Scale

Below each Main Counter is a Sub Counter, which provides an additional timing reference.

To set the Time Scale for the Sub Counter:

- Click a Sub Counter selector and select a Time Scale.
Tick-Based Timing

Pro Tools is a sample-based program with an internal MIDI resolution of 960,000 pulses per quarter note (ppq). However, when the Time Scale is set to Bars|Beats, the display resolution in Pro Tools is 960 ppq.

In Bars|Beats, Pro Tools is tick-based (960 ticks to a quarter note), which means that some amount of sample-rounding may occur when placing events at certain locations (see “Sample Rounding and Edit Operations” on page 236).

When working in Bars|Beats, you will often want to specify tick values for a number of operations, including:

- Placing and spotting regions
- Setting lengths for regions or MIDI notes
- Locating and setting play and record ranges (including pre- and post-roll)
- Specifying settings in the Grid/Groove Quantize and Change Duration pages of the MIDI Operations window
- Setting the Grid and Nudge values

The following table lists the number of ticks for each of the main note sizes:

<table>
<thead>
<tr>
<th>Note Value</th>
<th>Normal</th>
<th>Dotted</th>
<th>Triplet</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2 note</td>
<td>1920</td>
<td>2880</td>
<td>1280</td>
</tr>
<tr>
<td>1/4 note</td>
<td>960</td>
<td>1440</td>
<td>640</td>
</tr>
<tr>
<td>1/8 note</td>
<td>480</td>
<td>720</td>
<td>320</td>
</tr>
<tr>
<td>1/16 note</td>
<td>240</td>
<td>360</td>
<td>160</td>
</tr>
<tr>
<td>1/32 note</td>
<td>120</td>
<td>180</td>
<td>80</td>
</tr>
<tr>
<td>1/64 note</td>
<td>60</td>
<td>90</td>
<td>40</td>
</tr>
</tbody>
</table>

Tick- and Sample-Based Timebases

Pro Tools lets you set any track timebase to either sample-based or tick-based.

Audio in Pro Tools is sample-based by default. This means that if an audio region is located at a particular sample location, it will not move from that location if the tempo changes in the session—though its bar and beat location will change.

MIDI data in Pro Tools is tick-based by default. This means that if a MIDI region is located at a particular bar and beat location, it will not move from that location if the tempo changes in the session—though its sample location will change.

Sample-Based Audio and MIDI

If you make an audio track sample-based, all audio regions in the track have an absolute location on the timeline. Audio stays fixed to the sample time, regardless of where tempo or meter changes occur in a session.

If you make a MIDI track sample-based, all MIDI events in the track have an absolute location on the timeline. MIDI events stay fixed to the sample time, regardless of where tempo or meter changes occur in a session.

Tick-Based Audio and MIDI

Tick-based audio is fixed to Bars|Beats, and moves relative to the sample timeline when tempo and meter changes occur. However, MIDI events and tick-based audio respond differently to tempo changes in respect to duration. MIDI note events change length when tempo or meter is adjusted, while audio regions do not. Meter and tempo changes affect only the start point (or sync point) for each audio region in a tick-based track.
You can select whether a track is sample-based or tick-based when you create it, or change timebases later.

**Switching Timebases**

All Pro Tools tracks can be switched between being sample-based or tick-based.

Track height affects how various track controls appear in the Edit window. The Timebase selector is only visible in Small or larger track heights.

**To switch the timebase of a track, do one of the following:**

- If the track's height is set to Small or larger, click the Timebase selector for the track and select the desired timebase. The Timebase selector icon changes to reflect your choice.
- If the track's height is set to Mini, click the small arrow next to the Track View selector to get the Track Height pop-up menu, and select the desired timebase from the Track Timebase sub-menu.

- **Alternate Playlist Timebases**

  When you change a track's timebase, you can choose to apply the timebase change to the active Playlist on that track only, or to that track and all the alternate playlists for that track.

  **To configure a timebase change to affect timebases of all playlists in a track:**

  - Click the Timebase selector and enable the “Selection Changes Alternate Playlists” option.

- **Groups**

  When you change the timebase for an audio track that is part of an active group, all the tracks in the group will change to the same timebase.
Audio Region Location

In tick-based audio tracks, the location of an audio region is determined by the region’s start point, unless the region contains a sync point.

If the region contains a sync point, the sync point determines where the audio region is fixed to the grid.

Marker Location

When creating markers and Selection Memory Locations, you can specify whether they have an Absolute (sample-based) or Bar|Beat (tick-based) reference. For more information, see “Bar|Beat and Absolute Reference” on page 383.

Sample Rounding and Edit Operations

When audio material in Pro Tools is sample-based, some amount of sample-rounding may occur with some edits when the Main Time Scale is set to Bars|Beats. This is most evident when you need audio regions to fall cleanly on the beat (as when looping) and notice that the material is sometimes a tick or two off. With a few simple precautions, this can be avoided.

When selecting audio regions to be copied, duplicated, or repeated, make sure to select the material with the Selector tool (enable Grid mode for precise selections), or set the selection range by typing in the start and end points in the Event Edit area. Do not select the material with any of the Grabber tools (or by double-clicking with the Selector tool). This ensures that the selection is precise in terms of the grid (and not based on the length of the material in samples).

Playlists

The ability to create playlists is one of the most powerful features of Pro Tools, and one reason why it is infinitely more versatile than traditional multitrack recorders.

Each track maintains a “main” playlist and any number of “alternate” edit playlists.

Edit playlists let you take a snapshot of a track’s current arrangement of regions, thereby freeing you to experiment with alternate arrangements, returning as necessary to previously saved playlists.

A playlist, which can consist of a single region or many regions, can only be assigned to a track if it is not in use by another track. While you can create an almost unlimited number of edit playlists, which are shared among all tracks, each track has its own set of dedicated automation playlists.

Automation playlists for audio tracks store data for volume, pan, mute, and plug-in controls. Automation playlists for MIDI tracks, however, store only mute information; continuous controller events, program changes, and Sysex events are stored in MIDI regions and therefore reside within edit playlists.

Working with Playlists

When you create a new track, it contains a single, empty playlist until you record, import, or drag and drop material to it.

Audio material can be dragged and dropped onto a track from the Region List, DigiBase browsers, from Windows Explorer or the Macintosh Finder.
New playlists can be created that are empty or duplicates of the current playlist. Once created, you can recall, rename, and delete playlists as needed by using the Playlist selector.

Creating a Playlist

You can create new playlists for recording or importing audio and MIDI. This can be useful for creating alternate takes of audio or MIDI, or for constructing alternate arrangements.

To create a new (empty) playlist:

1. Click the track’s Playlist selector and choose New.
2. Enter a name for the new playlist and click OK. An empty playlist with the specified name appears in the track.

Assigning a Playlist to Another Track

By default, a playlist is typically available only for the track on which it was created. However, using the Other Playlists feature, you can assign an unassigned playlist to any track. When a playlist is reassigned to another track (assigned on any track), it is unavailable to other tracks including the track on which it originated.

An audio playlist’s timebase is saved with the playlist. When assigning an unassigned playlist to any track, the track assumes the saved timebase of the playlist.

To assign a track playlist:

- Click the track’s Playlist selector and do one of the following:
  - Select one of the track’s playlists.
  - or –
  - Select a playlist from a different track by clicking the Other Playlists menu, and selecting the desired playlist.

The selected playlist appears in the track and the track’s name is updated to that of the selected playlist.
Renaming a Playlist

You can rename a playlist by renaming the track to which it is assigned.

To rename a track’s assigned playlist:

1. Double-click the track’s name.
2. Enter a new name and click OK. Both the track and playlist names are updated.

Deleting a Playlist

You can delete a playlist from a session entirely. However, since playlists require minimal disk space, you do not need to delete them to conserve storage.

To delete one or more playlists from a track:

1. Click the track’s Playlist selector and choose Delete Unused.
2. Select the unassigned playlists you want to delete. Shift-click to select multiple playlists.
3. Click OK to delete the selected playlists. This operation cannot be undone.

“Empty” playlists will be automatically created to keep the playlist takes synchronized when switching back to the earliest playlist takes in the group.

To keep your playlist names and performances synchronized (example workflow):

1. Create new tracks and group them together.
2. Make sure the group is enabled.
3. Create a new playlist (by clicking the Playlist selector in one of the tracks in the group and choosing New). The default suffix will now be “.01”—signifying take 1.
4. Record take 1, then create a new playlist. The playlists on all tracks in the group increment to “.02.”
5. Create new tracks (for example, for an additional musician or microphones), then add these tracks to the group (or create a new group with all the tracks).
6. Increment all the playlists by clicking the Playlist selector in one of the tracks in the group and choosing New.

All the playlists will now have the same suffix appended to them. (Creating additional playlists in any of the group tracks will increment their playlists to keep them synchronized.)

7. If you want to hear the .01 take on the first group of tracks, you can switch any playlist in the group back to playlist .01.

All tracks in the group have playlists numbered with .01 suffixes (even those tracks that were added to the original group after the earlier takes). Empty playlists are automatically created on these newly-added members so that playlist numbers match across all members of the group.

Playlists and Groups

Creating new playlists with grouped tracks automatically increments the suffixes of the playlist names for each track of the active group. This lets you revert back to an earlier take by switching the playlist takes by group.

Using this method, you can add new tracks to the existing group and the suffixes for their playlist names will be synchronized with the original tracks.
Multiple Undo

Pro Tools can keep track of up to 32 of the last undoable operations, allowing you to return to a previous editing state.

The Undo operations in Pro Tools are stored in a queue, in the order in which they were invoked. When choosing Edit > Undo, the most recent operation is undone. If you choose Undo again, the next operation in the queue is undone. You can also choose Edit > Redo to redo an operation, which moves back through the Undo queue by one step.

When the number of operations in the Undo queue reaches the maximum Level of Undo, performing another undoable operation will remove the oldest operation at the top of the queue.

To undo the last operation:
- Choose Edit > Undo.
- or –
- Press Control+Z (Windows) or Command+Z (Macintosh).

To redo the last undone operation:
- Choose Edit > Redo.
- or –
- Press Shift+Control+Z (Windows) or Shift+Command+Z (Macintosh).

Undo History Window

You can use the Undo History window to view the queue of the undoable and redoable operations and return to any previous state. The Undo History can show edit creation times, enabling you to revert to the state a session held at a particular time.

To show (or hide) the Undo History window:
- Choose Window > Undo History.

To undo operations in the Undo History window:
- Click the operation (bold) you wish to undo in the list.

All operations in the queue that were performed after the operation you select will also be undone. In the Undo History window, undoable operations are shown in bold and redoable operations (operations that have already been undone) are shown in italics.

To redo operations in the Undo History window:
- Click the operation (italics) you wish to redo in the list.

The operation you choose, as well as all the operations in the queue before it, will be redone.
To toggle display of creation times in the Undo History window:
- Click the Options pop-up menu and choose Show Creation Times.

To undo all the operations in the Undo Queue:
- Click the Options pop-up menu and choose Undo All.

To redo all the operations in the Redo Queue:
- Click the Options pop-up menu and choose Redo All.

To clear the Undo Queue
- Click the Options pop-up menu and choose Clear Undo Queue.

Other operations that will clear the Undo Queue include:
- Deleting a track, or clearing a region from the Region List
- Selecting “Select > Unused,” or “Select > Unused Audio Except Whole Files” in the Region List pop-up menu
- Importing tracks or session data

When the number of operations in the Undo History reaches the maximum level of Undo, performing another undoable operation will remove the oldest operation at the top of the Undo History queue. When the oldest operation is one operation away from being pushed out of the queue, it is shown in red.

Levels of Undo and Memory

Because Pro Tools needs to keep track of the playlists for all tracks that are edited, the use of multiple Levels of Undo can be memory intensive. You can lower the Levels of Undo in Pro Tools to reduce the amount of system memory (RAM) used by the Undo queue. If you have plenty of memory available for Pro Tools, you can use higher Levels Of Undo.

Use the Undo History window to view a queue of undo operations and return to a previous state.

To set the Levels of Undo in Pro Tools:
1. Choose Setup > Preferences and click the Editing tab.
2. Click in the Levels of Undo field and enter a value of between 1–32.
3. Click Done to close the Preferences dialog.

The Region List

The Edit Window displays all audio regions, MIDI regions, and region groups in a single, comprehensive Region List.

All regions of all types that are recorded, imported, or created by editing appear in the Region List. Items can be dragged from the list to tracks and arranged in any order. All types of regions can be auditioned from the Region List by Alt-clicking (Windows) or Option-clicking (Macintosh) them.

At the top of the Region List is the Region List pop-up menu, which provides commands and tools for managing the contents of the list.
Region List Pop-Up Menu

The Region List pop-up menu provides tools to search, select, sort, export, clear, and manage items in the Region List.

To access the Region List pop-up menu:
- In the Edit window, click the Region List pop-up menu.

Displaying Regions in the Region List

In the Region List, whole-file audio regions are displayed in bold, and stereo and multichannel regions can be expanded to display individual channels.

Because region names can become lengthy, the Region List can be scrolled or resized as necessary (see Figure 10 on page 241).

If the Editing preference for "Region List Selection Follows Edit Selection" is enabled, selecting a region or region group in the Region List selects it on any track where it is present in assigned playlist. Likewise, selecting a region or region group on a track selects it in the Region List.

⚠️ Use the Region List as a bin for storing your favorite audio loops and MIDI clips. Save the session as a template and the regions are available for future sessions (see “Creating Custom Session Templates” on page 53).

Displaying File Info for Audio Regions

In addition to region names, the Region List can also display information about the region’s color coding, type (audio, MIDI, and region group), timebase, and parent file:

- **Color** Displays the color coding for regions.
- **Icon** Displays the icon for audio and MIDI regions, and region groups.
- **Timebase** Displays the timebase for audio and MIDI regions, and region groups.
- **Disk Name** Displays the name of the hard drive on which referenced file resides.
- **File Name** Displays the parent file name.
- **Full Path** Displays the full directory path of the region’s parent file.
Sorting and Searching in the Region List

Most sessions will contain many regions, which can make it challenging to swiftly locate a particular region in the Region List. Pro Tools lets you sort and search regions in the Region List to quickly locate any region you want.

To sort regions in the Region List:

1. Click the Region List pop-up menu (at the top of the Region List) and choose Sort By.

2. Select a basis for sorting from the submenu:
   - Region Type (audio regions, region groups, MIDI regions)
   - Name
   - Length
   - Original Time Stamp
   - User Time Stamp
   - Timebase

- Start in Parent
- End in Parent
- File Name
- File Length
- File Creation Date
- File Modification Date
- Disk Name (audio and region groups only)
- Track Format/Width

Finding Regions

Use the Find command to display all regions in a list whose names contain a particular word or phrase.

To find and display regions that match a word or phrase, do one of the following:

1. Click the Region List pop-up menu, choose Find.
   - or -

Press Control+Shift+F (Windows) or Command+Shift+F (Macintosh).

Find Regions dialog

2. Type the name, or any portion of the name, for the region or regions you want to find.
As you enter search text, it is displayed at the top of the Region List. Matching results appear in the list as they are found.

3 Click OK. Regions of any type whose name match the word or phrase you searched are displayed in the Region List. The search string is displayed at the top of the Region List in brackets.

Text entered into the Find dialog is saved in a Find History, letting you quickly repeat previous searches with a minimum of retyping.

To repeat a previous search:
1. Click the Region List pop-up menu, and choose Find.
2. Click the small arrow to the right of the text field in the Find dialog and select a text string from the Find History pop-up menu.

To compile a Find History without performing each search:
1. Click the Region List pop-up menu, and choose Find.
2. Type the name, or any portion of the name, for the regions you want to find.
3. Click and hold the double arrow to the right of the text field in the Find dialog and choose Insert Entry from the pop-up menu.

4 Type another entry and choose Insert Entry again to add additional search strings to the history.

To remove an entry from the history:
1. Select it from the Find History pop-up menu so it is displayed in the text field.
2. Choose Remove Entry from the Find History pop-up menu.

To clear the Find History:
- Choose Remove All Entries from the Find History pop-up menu.

An example of a Find history

The Find History is saved with the session.

In addition to storing each text string previously entered, you can insert multiple entries into the Find History manually (without having to perform each Find in order to store words or phrases).
Selecting Regions in the Region List

In the Region List, you can select regions so they can be dragged to tracks, processed with AudioSuite plug-ins, or exported.

To select or deselect a region in the Region List:

- Click a region name that is unhighlighted to select it.
- or -
- Click a region name that is highlighted to deselect it.

To select a range of regions in the Region List, do one of the following:

- Move the cursor to the left of the region names, so the Marquee appears, and drag around the regions you want to select.
- Click the name of a region in the Region List, and Shift-click an additional region name. All regions that occur between the first region selected and the additional region will also be selected.

To select or deselect a range of regions with the Marquee:

1. Press and hold Control (Windows) or Command (Macintosh).
2. Move the cursor to the left of the region name until the Marquee icon with a small “+” symbol appears.
   - To select regions, the Marquee should be to the left of an unhighlighted region name.
   - To deselect regions, the Marquee should be to the left of a highlighted region name.
3. Click on the region name and drag up or down (to select or deselect regions immediately above or below the region name).

To select or deselect non-contiguous regions, do one of the following:

- Control-click (Windows) or Command-click (Macintosh) region names that are unhighlighted to select them.
- or -
- Control-click (Windows) or Command-click (Macintosh) region names that are highlighted to deselect them.

Keyboard Selection of Regions

If the Region List Keyboard Focus is enabled, you can type the first few letters of a region’s name and Pro Tools will automatically locate and select the region in the Region List.
To enable and use the Region List Keyboard Focus:

1. Click the Keyboard Focus button in the upper right of the Region List.

2. Type the first or first few letters of the region to automatically locate and select it. Once a region is located and selected, it can be dragged to a track.

Keyboard selection of audio regions locates regions based on their region name, not on the names for their parent audio files or the volumes on which they reside.

Auditioning Regions in the Region List

In the Region List, you can audition regions by double-clicking on the region name.

Stereo and Multichannel Tracks in the Region List

Stereo and multichannel regions, whether imported or recorded into Pro Tools, are displayed as single items in the Region List. For example, two mono source regions named “Main Piano.L” and “Main Piano.R” are listed as “Main Piano (Stereo).” An expand/collapse triangle indicates stereo and multichannel regions.

Stereo and multichannel regions are displayed in the Region List by default in collapsed view. The individual regions can be displayed by clicking the arrow to the left of the region to expand the name.

To expand or collapse all stereo and multichannel regions:

- Press Alt (Windows) or Option (Macintosh) while clicking the expand/collapse triangle.

Individual items of an expanded-view stereo or multichannel region can be selected independently of the other associated regions in the Region List.

Rules for Stereo and Multichannel Regions

For stereo and multichannel audio regions to be shown as collective regions, the component regions must be the same length. If an existing stereo or multichannel region has been dragged onto multiple mono tracks and edited such a way that one or more components are no longer the same length, the stereo display is removed and the regions are displayed as individual regions in the Region List.
Edit Modes

Pro Tools has four Edit modes: Shuffle, Spot, Slip, and Grid. Grid mode provides two modes of operation, Relative and Absolute, explained below. The Edit mode is selected by clicking the corresponding button in the upper left of the Edit window.

When using any of the Trim tools in Shuffle mode, changing a region’s start or end point automatically moves the adjacent regions as necessary. The placement and insertion of MIDI notes is not affected by Shuffle mode.

Slip

In Slip mode, regions can be moved freely within a track or to other tracks. In this mode, it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

Use Slip mode when you want the Trim, Selector, Grabber, and Pencil tools to work without any restrictions to placement in time.

Spot

Use Spot mode to place regions at precise locations. In Spot mode you can specify a frame location (or a location based on any of the other time formats), capture an incoming Time Code address, or use a region’s time stamps as reference points for spotting. This can be particularly useful when performing post production tasks around SMPTE frame locations.

When Spot mode is enabled, Pro Tools asks you to specify a destination location when a region is dragged from the Region List, or from a supported DigiBase browser.
Grid

In Grid mode, regions and MIDI notes that are moved, trimmed or inserted “snap” to the currently selected Grid value, or to precise increments on a user-definable time grid.

Grid mode can be applied in Absolute or Relative mode.

- In Absolute Grid mode, moving any region snaps the region start to Grid boundaries. If a region’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the region will snap its start time to the nearest 1/4 note (the current absolute Grid value).

- In Relative Grid mode, regions can be moved by Grid (or Nudge) units. If a region’s start point falls between beats and the Grid is set to 1/4 notes, dragging the region will be constrained to 1/4 notes, preserving the region’s relative position to the nearest beat.

To select Absolute or Relative Grid mode:

■ Click the Grid mode selector and choose Absolute or Relative.

To temporarily suspend Grid mode and switch to Slip mode while dragging a region, hold down the Control key (Windows) or Command key (Macintosh).

For more information on Relative Grid mode, see “Sliding Regions in Grid Mode” on page 302.

Configuring the Grid

The actual Grid size, chosen from the Grid value pop-up menu can be based on a time value using the Main Time Scale; or, if Follow Main Time Scale is deselected, another time format can be used for the Grid size.

The Grid Value indicator and pop-up menu are located in the Edit window.

Grid Value indicator and pop-up menu

The current Grid value is also used for the Quantize to Grid command (see “Quantizing Regions to Grid” on page 308) and Separate Region At Grid command (see “Separated Region Commands” on page 290).
Also available in the Grid Value pop-up is an option for Regions/Markers. When selected, events can be placed freely (as in Slip mode) but will snap to region locations (start, end, and sync points), markers, and Edit selections when placed near them.

MIDI notes inserted with the Pencil tool ignore the Regions/Markers option, and instead snap to the time value selected in the Grid Value pop-up menu.

**To display the Grid lines in the Edit window:**

- Choose Setup > Preferences and click the Display tab, then Enable Draw Grids in Edit Window.

---

**Edit Tools**

Pro Tools has several Edit tools: the Zoomer, Trim, Selector, Grabber, Scrubber, and Pencil tools, and the multifunctional Smart Tool. Select an Edit tool by clicking it in the Edit window. The Zoom, Trim, Grabber, and Pencil tools have multiple modes, which you can select from a pop-up menu when you click the tool.

**Zoom buttons and Edit tools**

**Zoom Buttons** Use the Zoom buttons to zoom in and out vertically and horizontally on MIDI and audio track material. You can also store and recall five Zoom presets.

**Zoomer Tool** Use the Zoomer tool to select a zoom view in a track.

**Zoom Toggle** Use the Zoom Toggle to switch between the current zoom view and a defined zoom view.

**Trim Tools** Use the Trim tools to trim regions and region groups.

**Selector Tool** Use the Selector to make selections on tracks.

**Grabber Tools** Use the Grabber tools to select, separate, or move regions on tracks.

**Smart Tool** Use the Smart tool to Trim, Select, or Grab regions in tracks.

**Scrubber Tool** Use the Scrubber tool to scrub through track material.
**Pencil Tool** Use the Pencil tool to draw automation and MIDI data.

Open the Pencil tool by clicking on the pencil icon or pressing the `P` key.

> Press the Escape key to toggle through the Edit tools.

---

**Zooming**

Zooming options in Pro Tools include Zoom buttons, the Zoomer tool, the Zoom Preset buttons, and the Zoom Toggle command.

---

**Zoom Buttons**

Pro Tools include different Zoom buttons for zooming on track data.

---

**Horizontal Zoom In and Out Buttons**

The Horizontal Zoom In and Out buttons let you zoom in and out horizontally on track data.

To zoom in horizontally for all tracks, do one of the following:

- Click the Horizontal Zoom In button.
- Press Control+\[ (Windows) or Command+\[ (Macintosh).
- Click and drag on the Horizontal Zoom In button to zoom in continuously.

To zoom out horizontally for all tracks, do one of the following:

- Click the Horizontal Zoom Out button.
- Press Control+\[ (Windows) or Command+\[ (Macintosh).
- Click and drag on the Horizontal Zoom Out button to zoom out continuously.

---

**Audio and MIDI Zoom In and Out Buttons**

The Audio and MIDI Zoom buttons let you zoom in and out vertically on audio and MIDI data respectively.

---

To zoom in vertically for all audio tracks, do one of the following:

- Click the Audio Zoom In button.
- Press Control+Alt+\[ (Windows) or Command+Option+\[ (Macintosh).
- Click and drag on the Audio Zoom In button to zoom continuously.

To zoom out vertically for all audio tracks, do one of the following:

- Click the Audio Zoom Out button.
- Press Control+Alt+\[ (Windows) or press Command+Option+\[ (Macintosh).
- Click and drag on the Audio Zoom Out button to zoom out continuously.

To zoom in vertically for all MIDI and Instrument tracks, do one of the following:

- Click the MIDI Zoom In button.
- Press Control+Shift+\[ (Windows) or Command+Shift+\[ (Macintosh).
- or –
- Press Control+Shift+\[ (Windows) or Command+Shift+\[ (Macintosh).
To zoom out vertically for all MIDI and Instrument tracks, do one of the following:

- Click the MIDI Zoom Out button.
  - or -
- Press Control+Shift+[ (Windows) or Command+Shift+[ (Macintosh).

To zoom in or out vertically for a single MIDI or Instrument track:

1. Make sure the Track View is not set to Regions View.
2. Hold Start (Windows) or Control (Macintosh) and click and drag upwards to zoom in, or downward to zoom out.

Additional Zoom Button Features

To return to the previous zoom level, do one of the following:

- Alt-click (Windows) or Option-click (Macintosh) any of the Horizontal, Audio, or MIDI Zoom buttons.
- Press Control+Alt+E (Windows) or Command+Option+E (Macintosh).

To zoom in on a selection:

- Press Alt+F (Windows) or Option+F (Macintosh).

To zoom so that all regions are visible in the Edit window:

- Double-click the Zoomer tool in the toolbar.
- Press Alt+A (Windows) or Option+A (Macintosh).

Zoomer Tool

Use the Zoomer tool to zoom in and out around a particular area within a track. The Zoomer tool offers two modes: Normal, and Single Zoom mode.

- In Normal Zoom mode, the Zoomer tool remains selected after zooming.
- In Single Zoom mode, the previously selected Edit tool is automatically reselected after zooming.

Normal Zoomer Tool

To zoom around a certain track point:

1. Click the Zoomer tool pop-up menu and select Normal Zoom mode.
  - or -
Press the F5 key to toggle to Normal Zoom mode.

2. Click once with the Zoomer tool at the point within the track. All tracks are zoomed in by one level and the Edit window is centered around the zoomed point.

3. To zoom back to the previous level, Alt-click (Window) or Option-click (Macintosh) with the Zoomer tool.

To zoom into a particular track area:

1. Click the Zoomer tool pop-up menu and select Normal Zoom mode.
  - or -
Press the F5 key to toggle to Normal Zoom mode.
2 To zoom horizontally, drag with the Zoomer tool in the track’s playlist.

– or –

To zoom horizontally and vertically, press Control (Windows) or Command (Macintosh) while dragging in the track’s playlist.

The zoomed area fills the entire Edit window.

Single Zoom Mode

Single Zoom mode returns you to the previously selected tool after a zoom has been performed.

For example, when using the Smart Tool you can click the Single Zoomer tool, and once the Zoom operation has been performed, Pro Tools automatically switches back to the Smart Tool.

To use Single Zoom mode:

■ Click the Zoomer tool pop-up menu and select Single Zoom mode.

– or –

■ Press the F5 key to toggle to Single Zoom mode.

Single Zoom is identified with an arrow to the right of the Zoomer icon.

Normal Zoom mode does not have the arrow.

Zooming in a Ruler

To zoom horizontally in a ruler:

1 Press Control+Alt (Windows) or Command+Control (Macintosh) and move the cursor into the ruler area, so the Zoomer tool appears.

2 Click once to zoom in one level around a certain point.

– or –

Drag to zoom in around a particular ruler range.
Continuous Zoom with the Zoomer Tool

Use the Zoomer tool to zoom in or out continuously.

To use continuous zoom on one track or a group of tracks:

1. Select the Zoomer tool.
2. Hold the Start key (Windows) or Control (Macintosh) and do one of the following:
   - Drag up to zoom in vertically
   - Drag down to zoom out vertically
   - Drag to the right to zoom in horizontally
   - Drag to the left to zoom out horizontally

For horizontal zoom, all tracks zoom together. Tracks will zoom in or out centered horizontally on the location where you click.

Vertical Zooming In or Out of All Audio Tracks Continuously

The continuous zoom feature usually only affects the track or group of tracks in which you click and drag up or down to zoom out or in. When using continuous zoom on audio tracks, you can choose to have all shown audio tracks zoom as one.

To vertically zoom in or out of all audio tracks using continuous zoom:

1. Select the Zoomer tool.
2. Press Start+Shift (Windows) or Control+Shift (Macintosh) and drag up or down. When you release the mouse, all shown audio tracks will zoom to the same zoom level.

Zoom Preset Buttons

Pro Tools lets you save up to five horizontal Edit window Zoom presets, which can be recalled by typing a number or by clicking a Zoom Preset button.

To store a view as a Zoom preset:

1. Use the Zoomer tool to configure the Track View as desired.
2. Click and hold one of the Zoom Preset buttons (1–5) and choose Save Zoom Preset from the Zoom Preset pop-up menu. The preset button flashes momentarily, and any previously stored Zoom preset at that number is replaced.

To recall a saved Zoom preset:

- Click the appropriate Zoom Preset button (1–5).
- or –
- Click and hold the Zoom Preset button and choose Recall Zoom Preset from the Zoom Preset pop-up menu.
Chapter 15: Editing Basics

Zoom Toggle

The Zoom Toggle lets you define and toggle between zoom states directly from the Edit window, with enough flexibility and control to provide separate track views for audio (audio, Auxiliary Input, and Master Fader tracks) and MIDI (MIDI and Instrument tracks).

Zoom Toggle Parameters

The Zoom Toggle stores and recalls the following parameters:
- Track Height
- Edit Window View
- MIDI and Audio Zoom In or Out
- Grid setting

The Zoom Toggle lets you have separate track heights for track views for audio (audio, Auxiliary Input, and Master Fader tracks) and MIDI (MIDI and Instrument tracks).

Using Zoom Toggle

The Zoom Toggle button in the Edit window lets you define a zoom state and toggle between it and the current zoom state. When Zoom Toggle is enabled, the Edit window displays the stored zoom state. Additionally, any changes made to the view while Zoom Toggle is enabled are also stored in the zoom state.

When Zoom Toggle is disabled, the Edit window reverts to the last zoom state.

To store a zoom state using Zoom Toggle:

1. Make an Edit selection.
2. Click the Zoom Toggle button. It will light to indicate that Zoom Toggle is enabled.
3. Adjust Track Height, Vertical Zoom, Track View, and the Grid as desired.
4. Click the lit (enabled) Zoom Toggle button again to revert to the last zoom state.
5. Make another Edit selection and click the Zoom Toggle button to recall the stored zoom state and continue editing.

To modify the stored Zoom Toggle state:

1. Make sure the Zoom Toggle button is lit (enabled).
2. Adjust Track Height, Vertical Zoom, Track View, and the Grid as desired. As you adjust settings they are stored as the new Zoom Toggle state.

To clear the stored Zoom Toggle state:

1. Make sure the Zoom Toggle button is lit (enabled).
2. Alt-click (Windows) or Option-click (Macintosh) the Zoom Toggle button.

In Commands Keyboard Focus mode, press the E key to enable or disable Zoom Toggle.
To use Zoom Toggle without changing playlist views:
1. Make a selection on one or more tracks.
2. Press Alt+Start+E (Windows) or Option+Control+E (Macintosh).
   – or –
With Commands Keyboard Focus enabled, press Alt+E (Windows) or Option+E (Macintosh).

Using the Zoom Toggle

**Zooming with a Scroll Wheel**

If you have a mouse with a scroll wheel, you can use the scroll wheel to zoom in and out of tracks, both vertically and horizontally.

**To zoom in and out horizontally in the Edit window:**
1. Place the mouse over the tracks in the Edit window.
2. Alt-scroll (Windows) or Option-scroll (Macintosh) the scroll wheel up or down to zoom in or out horizontally.

**To zoom in and out vertically in the Edit window:**
1. Place the mouse over the tracks in the Edit window.
2. Alt-Shift-scroll (Windows) or Option-Shift-scroll (Macintosh) the scroll wheel up or down to zoom tracks in or out vertically.

---

### Trimming

Trim tools provide region, note, and data trimming functions. The following Trim tools are available:
- Trim tool; also called Standard Trim tool
- Time Compression/Expansion Trim tool; also called TC/E Trim tool
- Scrub Trim tool (Pro Tools HD only)

Trimming tools are constrained by boundary regions, regardless of the current Edit mode, as follows:
- Trimming towards the left is constrained by the adjacent region’s left-most boundary (region start).
- Trimming towards the right is constrained by the region’s right-most boundary (region end).
- The Trim tool provides special functions when used on looped regions and region groups. For more information, see “Region Groups” on page 321 and “Region Looping” on page 328.

### Trim Tool

With the Trim tool, you can quickly shorten or expand a region (up to the entire length of the source audio file). The first time you trim a region, Pro Tools automatically adds it to the Region List as a new region (with a name derived from the original) in order to differentiate it from the original.

The Trim tool is a nondestructive tool and doesn’t actually modify the original audio or MIDI data (when working on regions). To return to the length of the original region, drag it from the Region List, or resize the edited region with the Trim tool to its original length.
Use of the Trim tool is affected by the current Edit mode: Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 246 for more information.

The Trim tool can also be used to lengthen and shorten MIDI notes (see “Trimming Note Start and End Times” on page 421), and also to scale automation and controller data up or down “Drawing Automation” on page 550.

To trim a region with Trim tool:

1. Select the Trim tool. With Pro Tools HD, click the Trim tool pop-up menu and select “Standard.”

2. Move the cursor near the start or end of the region, so the Trim tool appears.

To reverse the direction of the Trim tool, press Alt (Windows) or Option (Macintosh).

3. If trimming the end, drag left to shorten the region, right to lengthen.
   – or –
   If trimming the start, drag right to shorten the region, left to lengthen.
   
   When working with audio, you cannot trim past adjacent regions.

When trimming regions in a stereo or multi-channel track, all channels are trimmed.

When using Shuffle mode, adjacent regions are slid as necessary to make room for the edited region. If using Grid mode, the dragged start/end times snap to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the region’s start or end point.

**Time Compression/Expansion Trim Tool**

The Time Compression/Expansion Trim tool is a convenient tool for matching an audio region to the length of another region, a tempo grid, a video scene, or to practically any other reference point you want.

The Time Compression/Expansion Trim tool works by using the Time Compression/Expansion (TC/E) AudioSuite plug-in (or a third party plug-in) to create a new audio file. You use this tool by dragging the region’s start or end point to expand or compress the region.

To match an Edit selection to the length of a Timeline selection, you can also use the Edit > TCE Edit to Timeline Selection command (see “TCE (Time Compression and Expansion) Edit To Timeline Selection” on page 287).
**Time Compression/Expansion Plug-In Preferences**

You can select settings for the Time Compression/Expansion AudioSuite plug-in by choosing from the Default Settings pop-up list in the Processing Preferences page, under “TC/E.” The settings available are presets included with Pro Tools; in addition, if you save your own presets for the Time Compression/Expansion plug-in, they will also appear here.

Refer to the DigiRack Plug-Ins Guide for more information about AudioSuite plugins.

**Using the Time Compression/Expansion Trim Tool in Grid Mode**

The Time Compression/Expansion Trim tool can be used in Grid mode to match a region to the tempo of a session or a section of a session. For example, you might import a one-bar drum loop with a tempo of 90 BPM into a session with a tempo of 120 BPM. In Grid mode, you can use this tool to simply and quickly “time compress” the drum loop to the length of one measure, with minimal loss of audio fidelity.

Trimming regions while in Relative Grid mode will trim the regions in grid increments while maintaining their relative offset (if any) from the grid.

To use the Time Compression/Expansion Trim tool in Grid mode:

1. Set the Edit mode to Grid.
2. Click the Trim tool pop-up menu and select “TCE.”

**Time Compression/Expansion Trim tool**

3. With the Time Compression/Expansion tool, drag the audio region’s start or end point to compress or expand the region to the Grid (for example, by quarter notes). The audio region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new audio region appears in the playlist and in the Region List.

**Using the Time Compression/Expansion Tool in Slip Mode**

To use the Time Compression/Expansion tool in Slip mode:

1. Set the Edit mode to Slip.
2. Click the Trim tool pop-up menu and select “TEC.”
3. With the Time Compression/Expansion Trim tool, drag the region’s start or end point to compress or expand the region freely. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Region List.

**Using the Time Compression/Expansion Trim Tool in Spot Mode**

In Spot mode, clicking with the Time Compression/Expansion Trim tool in a region opens the Spot Dialog. You can specify the location you want the region to start or end at, or the duration of the region, and the region is automatically compressed or expanded as specified.

To use the Time Compression/Expansion Trim tool in Spot mode:

1. Set the Edit mode to Spot.
2. Click the Trim tool pop-up menu and select “TCE.”
Chapter 15: Editing Basics

3 Click the region near its start or end point. The Spot Dialog opens. Using any Time Scale, enter a new start or end time (or duration) for the region, then click OK. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Region List.

The Scrub Trim Tool
(Pro Tools HD Only)

The Scrub Trim tool is a convenient tool for auditioning material (on up to two tracks) to find a trim point. You can drag in a track to hear the audio information, then trim at a specific location by releasing the mouse button.

This action creates a new region. Note that the Scrub Trim tool changes into a “right trim” or “left trim” shape as it is placed over the right or left side of a region. To reverse the direction of the Scrub Trim tool, press Alt (Windows) or Option (Macintosh) before you click the region.

Scrub playback speed and direction vary with controller movement. Scrubbed audio is routed through the track signal path, so you hear any effects in the signal path.

To scrub trim a track:
1 Click the Scrub Trim tool. The tool changes to a speaker with a bracket.
2 Drag within a track to the left or right. Audio from a scrubbed track is routed through the track signal path, including any TDM effects. When you locate the trim point, release the mouse button to trim the region.

To scrub trim two tracks, click with the Scrub Trim tool between two adjacent tracks and drag.

To scrub with finer resolution (without having to zoom in), press Control (Windows) or Command (Macintosh) while scrubbing.

Using the Selector Tool

Use the Selector tool to place the edit cursor in a track or Timebase ruler, or to make Edit selections on tracks. For more information on selecting, see “Selecting Track Material” on page 274.

Placing the Edit Cursor

To place the edit cursor with the Selector tool:
1 Select the Selector tool in the Edit window.
2 Click the desired location in a track or on a Timebase ruler.
Making an Edit Selection with the Selector Tool

To make a selection with the Selector tool:

1. Select the Selector tool in the Edit window.
2. Click and drag in a track, across multiple tracks, or on Timebase ruler.

To select an entire region with the Selector tool:

1. Select the Selector tool in the Edit window.
2. Double-click the desired region on a track.

To select an entire track with the Selector tool:

1. Select the Selector tool in the Edit window.
2. Triple-click the desired track.

Grabbing

Use the Grabber tools to select, move, separate, and arrange regions on tracks. There are three modes for the Grabber tool: Time Grabber, Separation Grabber, and Object Grabber.

**Time Grabber** Selects an entire region on a track with a single click. For more information on selecting, see “Selecting Track Material” on page 274.

**Separation Grabber** Cuts and pastes an Edit selection from one location to another by clicking and dragging. For more information, see “Separation Grabber Tool” on page 291.

**Object Grabber** Lets you select multiple, non-adjacent regions. For more information, see “Object Selections” on page 276.

To select one of the Grabber tools:

1. Click and hold the Grabber tool in the Edit window.
2. From the Grabber tool pop-up menu, select the desired Grabber tool.
Using the Smart Tool

With the Smart Tool you can instantly access the Selector, Grabber, and Trim tools, and you can also perform fades and crossfades. The position of the cursor in relation to a region or note, or within an automation playlist, determines how the Smart Tool functions.

To select the Smart Tool, click its icon in the upper left of the Edit window, or press F6+F7 (or F7+F8) simultaneously.

The Smart Tool in Waveform View (or MIDI Track Regions View)

◆ For the Selector tool, position the cursor over the middle of the region, in the upper half.
◆ For the Grabber tools, position the cursor over the middle of a region, in the lower half.
◆ For the Trim tools, position the cursor near the region's start or end point.
◆ For a fade-in or fade-out, position the cursor near an audio region's start or end point, near the top. Once the Fade cursor appears, drag into the region to set the fade length. The fade is created automatically with the Default Fade Settings (in the Editing Preferences page).
◆ For a crossfade, position the cursor between two adjacent audio regions, near the bottom. Once the Crossfade cursor appears, drag left or right to set the crossfade length. The crossfade is created automatically with the Default Fade Settings (in the Editing Preferences page).

To temporarily switch the Smart Tool to the Scrubber, place the cursor over the region so that the Selector tool is enabled, then press the Start key (Windows) or Control (Macintosh), or right-click the mouse.

The Smart Tool in Notes View

◆ For the Selector tool, position the cursor so it does not cover any notes.
To get the Selector tool while positioning the cursor over notes, press Control (Windows) or Command (Macintosh).
◆ For the Grabber tools, position the cursor over notes, press Control (Windows) or Command (Macintosh).
◆ For the Grabber tools, position the cursor over the note, near its middle.
To get the Marquee so you can select a group of notes, position the cursor so it does not cover any notes and press Control (Windows) or Command (Macintosh).

- For the Trim tools, position the cursor near the note’s start or end point.

To temporarily switch the Smart Tool to the Eraser, place the cursor over the region so that the Selector tool is enabled, then press Start+Alt (Windows) or Control+Option (Macintosh).

The Smart Tool in Automation and Controller Views

The following capabilities are available with the Smart Tool when working in both automation and controller views:

- For the Selector tool, position the cursor anywhere in the bottom 75% of the playlist for the Selector tool. Drag with the Selector tool to select breakpoints.

- For Trim tools, position the cursor in the top 25% of the playlist for the Trim tool. Drag with the Trim tool to trim breakpoints. Press Control (Windows) or Command (Macintosh) while trimming for fine control.

- For Grabber tools, Control (Windows) or Command (Macintosh) for the Grabber tool, then click in on the automation line to create breakpoints

To edit existing breakpoints, move the cursor near a breakpoint for the Grabber tool.

For fine control with the Grabber tool, press Control (Windows) or Command (Macintosh)— or continue to hold the key if you are creating a new breakpoint.

To vertically constrain Grabber tool movement, press Shift.

To vertically constrain Grabber tool movement with fine control, press Control+Shift (Windows) or Command+Shift (Macintosh).

The Smart Tool with Stereo and Multichannel Tracks

When using the Smart Tool on stereo and multichannel tracks, individual channels cannot be independently edited. All edits affect all channels as a whole.

The tool switching for the Smart Tool in stereo and multichannel tracks is determined by the position within the entire track, and not within individual channels.

Scrubbing

The Scrubber tool lets you “scrub” up to two tracks of audio in the Edit Window. Scrubbing is a technique that originated in tape editing, where the tape was rocked back and forth past the playhead at slower than normal speeds to find a particular location (usually for the sake of performing splices).

While viewing an audio waveform in Pro Tools can be helpful in visually finding an edit point, sometimes a waveform display (because of its sonic characteristics) may not reveal the desired spot in the audio material. By scrubbing back and forth over an edit point in Pro Tools, you can listen and zero in on the exact edit point you’re looking for.

When the Operation preference for “Edit Insertion Follows Scrub/Shuttle” is enabled, the edit cursor automatically locates to the point where scrubbing stops.
When the Scrolling option is set to Continuous or Center Playhead, clicking with the Scrubber in a track’s playlist centers the Edit window around that point, and moves the Playhead there. With these Scrolling Options, scrubbed material moves past the Playhead, which remains stationary and centered.

![Scrubbning is only supported for audio tracks. MIDI and Instrument tracks cannot be scrubbed.](image1)

**To scrub a single audio track:**
- With the Scrubber tool selected, drag within the track—left for reverse, right for forward.

![Scrubbing an audio track with the Scrubber](image2)

The distance and speed with which you drag (with either the mouse, or an external MIDI controller wheel) determine the length and speed of the scrubbed audio. Audio from the scrubbed track is routed to its output, along with any effects assigned to the track.

The resolution for the Scrubber is dependent upon the zoom factor for the scrubbed track.

![You can temporarily switch the Selector tool to the Scrubber tool by Right-clicking (Windows) or Control-clicking (Macintosh). For finer resolution, Control-Right-click (Windows) or Command-Control-click (Macintosh).](image3)

**To scrub multiple audio tracks:**
- With the Scrubber selected, drag between two adjacent tracks.

![Scrubbing between two audio tracks](image4)

- or -
- Scrub within a selection that contains multiple tracks. Only the first two tracks are heard.

**Scrub/Shuttle Mode**

When scrubbing normally, you can scrub at normal playback speeds or slower. Scrub/Shuttle mode, however, lets you scrub at several times normal speed, which is helpful in playing through large ranges and locating material.

**To scrub in Shuttle mode (at several times normal speed):**

1. Select the Scrubber tool.
2. While pressing Alt (Windows) or Option (Macintosh), drag within the track—left for reverse, right for forward. The Fast Forward and Rewind buttons in the Transport window engage.

The distance and speed dragged determine the speed for the scrubbed audio.
Shuttle Lock Mode

Shuttle Lock mode lets you use the numeric keypad to shuttle up to two tracks forward or backwards at specific speeds: 5 is normal speed, numbers from 6 up to 9 provide increasingly faster fast-forward speeds, and numbers from 4 down to 1 provide progressively faster rewind speeds (4 is the slowest rewind Shuttle Lock speed, 1 is the fastest). If multiple tracks are selected, only the first two tracks are shuttled.

To play one or two tracks with the shuttle lock:

1. With Pro Tools HD, make sure the Operation preference for Numeric Keypad mode is not set to Shuttle (see “Operation Preferences” on page 59).
2. With the Selector tool, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
3. Press the Start key (Windows) or Control (Macintosh) and a number on the numeric keypad: 0–9 (9 is fastest, 5 is normal speed, and 0 stops shuttling).

Once Shuttle Lock mode is initiated, Fast Forward and Rewind become highlighted in the Transport window.

4. Press additional keys to change the playback speed, or press Plus (+) or Minus (–) to switch the playback direction (plus for forward, minus for backward).
5. To stop playback, press Start+0 (Windows) or Control+0 (Macintosh).

To exit Shuttle Lock mode:

- Press Stop in the Transport window.
- or –
- Press the Spacebar.

Custom Shuttle Lock Speed

Use the Custom Shuttle Lock Speed preference to customize the highest fast-for-ward Shuttle Lock speed (key 9) to better match your editing and auditioning needs.

To configure Custom Shuttle Lock Speed:

1. In Pro Tools, select Setup > Preferences and click the Operation tab.
2. Be sure that the Numeric Keypad mode is set to Transport or Classic (see “Operation Preferences” on page 59).
3. Enter a desired percentage for the Custom Shuttle Lock Speed setting. The range for this setting is 50–800%. You can use the Up and Down Arrow keys to increase or decrease the setting.
4. Click OK.

The Custom Shuttle Lock Speed will be saved with your Pro Tools preferences (not with the session).

To enable Custom Shuttle Lock Speed:

- Press Start+9 (Windows) or Control+ 9 (Macintosh) on the numeric keypad.

Numeric Keypad Set to Shuttle

(Pro Tools HD Only)

Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.
To shuttle with the Numeric Keypad mode set to Shuttle:

1. Choose Setup > Preferences and click the Operation tab.

2. Set the Numeric Keypad mode to Shuttle and click Done.

3. With the Selector tool, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.

4. Press and hold any of the following keys (or key combinations) on the numeric keypad to trigger playback.

<table>
<thead>
<tr>
<th>Shuttle Speed</th>
<th>Rewind Key</th>
<th>Forward Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 X Speed</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td>4 X Speed</td>
<td>7</td>
<td>9</td>
</tr>
<tr>
<td>1/4 X Speed</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>1/2 X Speed</td>
<td>4+5</td>
<td>5+6</td>
</tr>
<tr>
<td>2 X Speed</td>
<td>7+8</td>
<td>8+9</td>
</tr>
</tbody>
</table>

5. Press a different key to switch the playback direction or speed. Release to stop.

Using the Pencil Tool

The Pencil tool lets you draw automation, MIDI data, tempo changes, and audio waveforms (at the sample level).

For information on drawing automation, see “Drawing Automation” on page 550.

For information on drawing MIDI data, see “The Pencil Tool” on page 416.

The Universe Window

(Pro Tools HD Only)

The Universe window displays an overview of the entire session, representing audio and MIDI material on all tracks that are not hidden (including tracks that are inactive, or that contain offline regions). The order in which material is displayed in the Universe window corresponds to the track order in the Edit window.

To open the Universe window:

- Choose Window > Universe.

Audio material residing in audio tracks is represented by a single, horizontal line in the Universe window. Each channel in a stereo or multichannel track is represented individually.

Since Auxiliary Input and Master Fader tracks do not contain audio, they are displayed as blank areas in the Universe window.

MIDI tracks containing note material are represented by single, horizontal lines.
Resizing the Universe Window

Even though the Universe window can be resized horizontally and vertically, the length of the entire session is always displayed in the Universe window. If the Universe window is resized so some of the session’s track are not displayed, a vertical scroll bar becomes available.

Highlighted Material in the Universe Window

The highlighted, shaded area in the Universe window represents the material displayed in the Edit window. If you change what’s displayed in the Edit window—by zooming, scrolling horizontally or vertically, hiding or unhiding tracks, or changing track heights—the highlighted area in the Universe window updates.

During playback, if the Edit window is set to scroll, the highlighted area in the Universe window also scrolls.

Scrolling in the Universe Window

By clicking in the Universe window, you can automatically scroll, either horizontally or vertically, the material displayed in the Edit window. This provides a convenient method of locating anywhere in the session, or adjusting which shown tracks are visible in the Edit window.

To move the highlighted area in the Universe window:

1. Choose Window > Universe.

2. Drag the highlighted area to a different position in the Universe window to affect which tracks are displayed in the Edit window.

When all tracks are visible in the Edit window and the session is zoomed all the way out, with all regions visible, the entire Universe window is shaded.
Chapter 16: Playing and Selecting Track Material

Playing Tracks

After recording or importing audio or MIDI to tracks, you will want to listen to the material for editing and mixing.

To set where playback begins, you can click anywhere in a track with the Selector tool (as long as the Timeline and Edit selections are linked). See “Linking or Unlinking Timeline and Edit Selections” on page 272).

Playback Cursor

The playback cursor is a solid unblinking line that moves across the Edit window to indicate the current playback location.

The selected Scrolling Option determines how the Edit window scrolls during playback, and how the playback cursor functions. See “Scrolling Options” on page 271 for details.

Playback Location

The playback location is displayed in the counters at the top of the Edit window and in the Transport window, and in the Big Counter window.

To display the Counters in the Transport window:

- Choose View > Transport > Counters

Transport with Counters displayed

To display the Big Counter:

- Choose Window > Big Counter.

Big Counter window

Edit Cursor

The edit cursor is a flashing line that appears when you click with the Selector tool in a track’s playlist. The blinking edit cursor indicates the start point for any editing tasks performed. If you make a selection and perform an edit, the selection is the target of the edit.
Basic Playback from a Specific Point

To begin playing from a specific point within a track:

1. Make sure that Options > Link Timeline and Edit Selection is enabled.
2. With the Selector tool, click in the track where you want playback to begin.
3. Click Play in the Transport window to begin playback.
4. Click Stop in the Transport window to stop playback.

To jump to a different location and begin playing from there:

- Click with the Selector tool at that point and click Play in the Transport window.
  - or -
- Click the desired location in a Timebase Ruler during playback.

With the Timeline and Edit selections linked, you can click a region or MIDI note with the Time Grabber tool to automatically update the Timeline with the selection’s start time, allowing you to easily play from that point.

Page Scrolling During Playback

You can set Pro Tools to scroll the track display while playing, and also have the edit cursor appear wherever playback stops.

To make the track display and the edit cursor follow playback:

1. Select Options > Scrolling > Page.
2. Choose Setup > Preferences and click the Operation tab.
3. Select the option for “Timeline Insertion Follows Playback,” then click Done.

Pressing Start+N (Windows) or Control+N (Macintosh) toggles Timeline Insertion Follows Playback.

4. Make sure to select Options > Link Timeline and Edit Selection.
5. With the Selector tool, click in the track where you want playback to begin.
6. Click Play in the Transport window to begin playback. The playback cursor scrolls across the Edit window, indicating the current playback location.
7. Click Stop in the Transport window to stop playback. The edit cursor appears at the location where playback stops.

Locating and Auditioning with Fast Forward/Rewind

You can use the Fast Forward and Rewind buttons in the Transport window to locate material in your tracks. If the Operation preference for “Audio During Fast Forward/Rewind” is selected, you will actually hear the scanned audio (similar to a CD player) when clicking the Fast Forward and Rewind buttons.
You can also fast forward or rewind incrementally by repeatedly clicking the appropriate button. The size of these increments is determined by the Main Time Scale:

**Bars:Beats** Moves to the beginning of the previous or next bar.

**Min:Sec** Moves back or forward in one-second steps.

**Time Code** Moves back or forward in one-second steps (while adjusting for current SMPTE format).

**Feet+Frames** Moves back or forward in one-foot steps.

**Samples** Moves back or forward in one-second steps.

### Locating with Back and Forward Commands

*(Pro Tools HD Only)*

Pro Tools provides four Back/Forward commands (sometimes called “rollback”) for moving the playback location in the Edit window. The length of the move is defined by the Back/Forward Amount set in the Operation page of the Setup > Preferences window.

You can also move the playback location in multiple increments by repeating the command (See “Repeating Back/Forward Commands” on page 268).

- **Back** Moves the playback location backward by the Back/Forward Amount.
- **Back and Play** Moves the current playback location backward by the Back/Forward Amount and automatically begins playback.
- **Forward** Moves the playback location forward by the Back/Forward Amount.
- **Forward and Play** Moves the current playback location forward by the Back/Forward Amount and automatically begins playback.

### Setting the Back/Forward Amount

The length of the Back/Forward move is determined by the Back/Forward Amount in the Operation page of the Setup > Preferences window.

### To configure the Back/Forward Amount:

1. Choose Setup > Preferences and click the Operation tab.

The timebase of the Back/Forward Amount settings follows the Main Time Scale by default, or you can deselect Follow Main Time and select any of the following timebase formats:

- **Bars:Beats**
- **Min:Sec**
- **Time Code**
- **Feet+Frames**
- **Samples**

2. Do one of the following:

   - Select a preset amount in the Back/Forward Amount pop-up menu.
   - In the Back/Forward Amount field, enter a custom amount.

---

*Back/Forward commands also work when controlling a 9-pin device. See the Machine-Control Guide for details.*
Using Back or Forward Commands

To move the playback location backward by the Back/Forward Amount:

- Press Control (Windows) or Command (Macintosh), and click Rewind in the Transport window.

To move the playback location forward by the Back/Forward Amount:

- Press Control (Windows) or Command (Macintosh), and click Fast Forward in the Transport window.

To move the playback location backward by the Back/Forward Amount and then begin playback:

- Press Control+Alt (Windows) or Command+Option (Macintosh), and click Rewind in the Transport window

To move the playback location forward by the Back/Forward Amount and then begin playback:

- Press Control+Alt (Windows) or Command+Option (Macintosh), and click Fast Forward in the Transport window

Repeating Back/Forward Commands

All the Back/Forward commands can be repeated in order to increase the amount of the total Back or Forward move.

To repeat Back/Forward moves:

1. Press and hold Control (Windows) or Command (Macintosh).
2. Click Rewind or Fast Forward the number of times you want to repeat moving the playback location backwards or forwards by the Back/Forward Amount.

Extending Selections with Back or Back and Play Commands

The Back or Back and Play commands can be used to extend a selection backwards by the length of the Back/Forward Amount.

Although you cannot extend a selection with the Forward or Forward and Play commands, you can use the following procedures with Forward or Forward and Play to move the start point of a current selection.

To extend a selection with Back or Back and Play commands:

1. Configure the Back/Forward Amount. (See “Setting the Back/Forward Amount” on page 267.)
2. With the Selector tool, drag within a track to make a selection.
3. Do one of the following:
   - To extend the selection backwards by the Back/Forward Amount, press Shift+Control (Windows) or Shift+Command (Macintosh) and click Rewind in the Transport window.
   - or –
   - To extend the selection backwards by the Back/Forward Amount and then begin playback, press Shift+Control+Alt (Windows) or Shift+Command+Option (Macintosh) and click Rewind in the Transport window.
Edit Window Counters and Indicators

The counters and indicators at the top of the Edit window display the current playback location and Edit selection. These include the Main and Sub Counters, and the Edit Selection Start, End, and Length indicators.

All Edit window counters and indicators (except the Sub Counter) let you enter a location in their counter display to navigate to a specific time location.

1. Click in one of the counters.
2. Type in the new location. Press Period (.) to cycle through to the different time fields.
3. Press Enter to accept the new value and automatically locate there.

Scrolling in a Timebase Ruler

You can scroll the contents of the Edit window by clicking and dragging in a ruler. While this does not actually update the session’s Current Location, it does let you conveniently shift the display left or right for the sake of finding and editing material.

This method of scrolling is especially useful when using the Continuous Scrolling option (Pro Tools HD only), which does not update or follow Timeline selections.

To scroll the entire contents of the Edit window from a ruler:
- While pressing Control+Alt+Start (Windows) or Command+Option+Control (Macintosh), drag left or right in any of the Timebase rulers.

Scrolling with a Scroll Wheel

If you have a mouse with a scroll wheel, you can use the scroll wheel to scroll vertically or horizontally in any Pro Tools window that has a scroll bar (such as the MIDI Event List).

To scroll a Pro Tools window vertically:
1. Place the mouse over the window you want to scroll (for example, in the Edit window you might want to scroll either the track display or the Region List).
2. Scroll the scroll wheel up or down to scroll the window up or down.
To scroll a Pro Tools window horizontally:

1. Place the mouse over the window you want to scroll (for example, in the Edit window you might want to scroll either the track display or the Region List).

2. Shift-scroll the scroll wheel up or down to scroll the window to the left or right.

Locating the Playback Cursor

Use the Playback Cursor locator to locate the playback cursor when it is off-screen. The Playback Cursor locator will appear on the right edge of the Main Timebase ruler if the playback cursor is located beyond the time visible in the Edit window. If the playback cursor is located before the time visible in the Edit window, the Playback Cursor locator will appear on the left edge of the Main Timebase ruler.

The Playback Cursor locator is red when a track is record-enabled and blue when no track is record-enabled.

For example, if the Scrolling option is set to None, the playback cursor will move off-screen after it has played past the time currently visible in the Edit window. The Playback Cursor locator will appear on the right edge of the Main Timebase ruler after the playback cursor moves beyond the time visible in the Edit window.

To locate the playback cursor when it is off-screen:

- Click the Playback Cursor locator in the Main Timebase ruler.

The Edit window changes to center the playback cursor on-screen.

Auto-Scrolling Tracks in the Mix and Edit Windows

(Pro Tools HD Only)

If you are working with more tracks than can be displayed at one time in the Mix or Edit windows, you can select a track in one window and Pro Tools will automatically scroll to that track in the other window.

To auto-scroll the Mix window to show a selected track in the Edit window:

- In the Edit window, Start-click (Windows) or Control-click (Macintosh) the track name.

The track becomes selected, and the Mix window scrolls to display the selected track.

To auto-scroll the Edit window to show a selected track in the Mix window:

- In the Mix window, Start-click (Windows) or Control-click (Macintosh) the track name.

The track becomes selected, and the Edit window scrolls to display the selected track.
Navigating to Tracks Using Track Position Numbers

With Track Number View enabled, each track is assigned a number corresponding to its position in the Mix and Edit Windows. You can scroll directly to any track by its positional number.

When tracks are reordered, Track Position Numbers are reassigned to keep them in numerical sequence.

To navigate directly to any track using Track Position Numbers:

1. Choose View > Track Number.
2. Choose Track > Scroll to Track.
   – or –
3. Press Control+Alt+F (Windows) or Command+Option+F (Macintosh).
   4. In the Scroll To Track dialog, enter the Track Position Number.
5. Click OK.

The track is selected, and the windows scroll as follows:

- The Edit window tracks scroll to bring the selected track as close to the top as possible.
- The Mix window tracks scroll to bring the selected track as close to the left as possible.

Scrolling Options

You can configure how contents of the Edit window scroll during playback and recording.

To configure Scrolling options:

- Choose Options > Scrolling and select one of the following options:

  None The Edit window does not scroll during or after playback. The playback cursor moves across the Edit window, indicating the playback location.

  After Playback The playback cursor moves across the Edit window, indicating the playback location. When playback has stopped, the Edit window scrolls to the final playback location.

  Page The playback cursor moves across the Edit window, indicating the playback location. When the right edge of the Edit window is reached, its entire contents are scrolled, and the playback cursor continues moving from the left edge of the window.

  Continuous (Pro Tools HD Only) See “Continuous Scrolling During Playback” on page 272.

  Center Playhead (Pro Tools HD Only) See “Center Playhead Scrolling” on page 272.

Making a selection in the Timeline or a playlist, or manually scrolling the Timeline while in Page Scroll or Continuous Scroll mode will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 270).
Continuous Scrolling During Playback  
(Pro Tools HD Only)

This scrolling option causes the Edit window’s contents to scroll continuously past the playback cursor, which remains in the center of the window. With this option, playback is always based on the Timeline selection (unlike the Center Playhead Scrolling option).

Center Playhead Scrolling  
(Pro Tools HD Only)

This scrolling option causes the Edit window’s contents to scroll continuously past the Playhead, which is a blue line in the center of the window (red when recording).

The Playhead indicates where playback begins when clicking Play in the Transport window.

With the Playhead enabled, you can jump to and play an Edit or Timeline selection. For details, see “Playing Timeline and Edit Selections with the Playhead” on page 288.

Half-Screen Edit Window

When the Scrolling option is set to Continuous or Center Playhead, a half-screen appears at the far left of the Edit window (before the beginning of the session).

Linking or Unlinking Timeline and Edit Selections

Pro Tools lets you link or unlink the Timeline and Edit selections.

When the Timeline and Edit selections are linked, selecting in a track’s playlist (making an Edit selection) also defines the play and record range (the Timeline selection).

Unlinking Timeline and Edit selections lets you make a selection within a track for editing purposes that is distinct from the selection in the Timeline (which determines the playback and recording range).
To link or unlink the Timeline and Edit selections:

- Select or deselect Options > Link Timeline and Edit Selection.
  – or –
- In the upper left of the Edit window, click the Link Timeline and Edit Selection button so it becomes highlighted (selected) or un-highlighted (not selected).

While you could theoretically do this with the Timeline and Edit selections linked, as soon as playback is stopped, the playback range would then be updated to that of the more recent edit range, or to a single note when editing MIDI.

**Playback/Edit Markers**

Timeline selections are displayed in the Main Timebase ruler with Playback Markers, which appear as blue arrows (red when recording). In addition, there are Pre- and Post-Roll Flags (which are green when enabled) indicating the location for pre- and post-roll.

When the Timeline and Edit selections are unlinked, Edit selections are displayed in the ruler with Edit Markers, which appear as black brackets.

Figure 11. Timeline and Edit selections unlinked

Figure 12. Edit Markers

If the Timeline and Edit selections are linked, Edit selections are represented by the blue Playback Markers.

See the following sections for details on working with Timeline and Edit selections:

- “Selecting Track Material” on page 274
- “Timeline Selections” on page 285
- “Setting Punch/Loop Points” on page 180
- “Setting Pre- and Post-Roll” on page 183

Press Shift+Forward Slash (/) to toggle Link Timeline and Edit Selection on and off.

Figure 11 illustrates another reason you’d want to unlink the Timeline and Edit selections. In this example, the Timeline selection sets a range to be looped on playback, while a MIDI region (residing within the loop) is selected for editing purposes. During playback, the Edit selection can be nudged, quantized, or transposed while the loop plays back completely independent and uninterrupted.
**Linking or Unlinking Track and Edit Selections**

Pro Tools lets you link or unlink Track selection with Edit selections.

When Track and Edit selections are unlinked, you can make a selection within a track or across multiple tracks for editing and each associated track is selected (track names automatically highlight). This lets you quickly apply track-level commands (such as Track View toggle, change track heights) and have the command apply to all tracks you are working on.

When Track and Edit selections are unlinked, making an Edit selection does not automatically select all associated tracks.

**To link or unlink Track and Timeline selections:**
- Select or deselect Options > Link Track and Edit Selection.
- or -
- In the upper left of the Edit window, click the Link Track and Edit Selection button so it becomes highlighted (selected) or un-highlighted (not selected).

**Selecting Track Material**

Before audio and MIDI material can be edited, it must first be selected. The Track View determines how the material is viewed and selected.

When you make a selection, it appears as a highlighted area of the tracks, and is also indicated by blue start and end arrows (*Playback Markers*) in the Main Timebase ruler. If any track (audio or MIDI) in the session is record-enabled, even if it is hidden, these markers appear red.

If the Timeline and Edit selections are unlinked, the Edit selection range is indicated by Edit Markers in the Main Timebase ruler. See “Linking or Unlinking Timeline and Edit Selections” on page 272 for details.

**Selections and Edit Groups**

When making selections on tracks that are part of an Edit Group, all tracks within the group become selected.

**Selections and Hidden Tracks**

When editing tracks that are part of an active Edit Group, any tracks within the group that are hidden are not affected by the edits. To edit all members of a group, make sure they are visible by highlighting their names in the Track List.
Selections in Multiple Tracks

To make a selection in multiple tracks:

- With the Selector tool, click and drag horizontally to include adjacent tracks in a selection (drag vertically to define the time range).

Selecting Regions

To select a portion of a region:

- With the Selector tool, drag within a region (left or right) to select the material on a single track. (You can also use the Selector tool across multiple, adjacent tracks to make multitrack selections.)

To select an entire region:

- Click the region with the Time Grabber tool.
  - or -
- Double-click the region with the Selector tool.

To select two regions and the time range between them:

1. With the Time Grabber, click the first region.
2. Shift-click the second region. Both regions are selected, along with the time range between them (including any other regions).

To select an entire track:

- Click in the track with the Selector tool and then choose Edit > Select All.
  - or -
- Triple-click with the Selector tool in the track.

To select all regions in all tracks:

1. Select the “All” Edit Group in the Group List pop-up menu.
2. Click in any track with the Selector tool and choose Edit > Select All.
  - or -

   Triple-click with the Selector tool in any track.

   Another way to select all regions in all tracks, without having to select the “All” Edit Group, is to press Enter (Windows) or Return (Macintosh), then press Control+A (Windows) or Command+A (Macintosh). The Link Timeline and Edit Selection option must be enabled.

Region List Selection Follows Edit Selection

When the Editing preference for “Region List Selection Follows Edit Selection” is enabled, selecting a region in a track also causes the region to become selected in the Region List.

Conversely, if the Editing preference for “Edit Selection Follows Region List Selection” is enabled, selecting a region in the Region List causes the initial occurrence of that region to become selected within the track.

Selecting All from Timebase Rulers

To select all material in all displayed audio and MIDI tracks:

1. Make sure the Timeline and Edit selections are linked.
2. Double-click in any Timebase ruler. All regions in all displayed audio and MIDI tracks are selected. Tracks that are hidden are not selected.
To select all material in all tracks, along with Conductor events:

1. Make sure the Timeline and Edit selections are linked.

2. While pressing Control (Windows) or Option (Macintosh), double-click in any Timebase ruler. All regions in all displayed audio and MIDI tracks are selected, along with all events in each of the Conductor tracks.

Making Selections While Playing

Pro Tools lets you make on-the-fly selections with the Up and Down Arrow keys.

To make a selection while playing:

1. Make sure to select Options > Link Timeline and Edit Selection.

2. With the Selector tool, click somewhere near the beginning of the track in which you want to make the selection.

3. Click Play in the Transport window to begin playback.

4. When playback reaches the point where you want the selection to begin, press the Down Arrow key.

5. Press the Up Arrow key at the point where you want the selection to end. The selected range becomes highlighted.

6. To stop playback, click Stop in the Transport window.

To automatically scroll to the beginning of the selection (or to the location of the on-screen cursor), press the Left Arrow key. To scroll to the end of the selection, press the Right Arrow key.

While in Page Scroll or Continuous Scroll mode, making a selection in the Timeline or a playlist during playback as the playback cursor moves off-screen will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 270).

Object Selections

You can use the Object Grabber tool to select non-contiguous regions on one or more tracks. Non-contiguous selections must encompass entire regions. If you want a non-contiguous selection to include a portion of a region, first turn the portion into a new region with the Separate Region command (see “Separate Region Commands” on page 290).

⚠️ The Object Grabber is not available when the Edit mode is set to Shuffle or Spot.

To select non-contiguous regions:

1. Make sure the Edit mode is set to either Slip or Grid.

2. Click the Grabber tools pop-up menu and select “Object.”

3. Shift-click each region you want to include in the selection. The regions can even reside on different tracks.

Each clicked region becomes surrounded by a dark border, indicating it is selected.
The Object Grabber tool ignores Edit Groups when making selections. For instance, selecting a region on a grouped track does not cause regions in the other tracks in the group to become selected.

**Object to Time Selection**

You can convert between Time- and Object-based selections. Time selections are made with the Selector and Time Grabber tools. Object selections are made with the Object Grabber tool.

Converting to an Object selection is useful when you are working with large selections, especially across multiple tracks, and you want to remove certain regions from the selection.

Converting to a Time selection is useful if you want to select all regions between a non-contiguous Object selection.

**To change a Time selection to an Object selection:**

1. Drag with the Selector tool in any track to define a selection, or select in a Timebase ruler to select across all tracks.

2. With the Object Grabber tool selected, double-click the Grabber icon in the toolbar. The regions falling within the selection range become selected as objects. Regions that were partially selected become deselected.

Selected regions

To select regions that were partially selected, press the Control key while double-clicking the Grabber icon.

**To change an Object selection to a Time selection:**

1. Select any number of regions with the Object Grabber tool.

2. Double-click the Selector tool in the toolbar. The time range between the first and last region becomes selected.

When using the Object Grabber tool on tracks that belong to an Edit Group, regions in the other grouped tracks are selected if they fall within the range of the selected region.
Changing a Selection Length

The selection range can be shortened or lengthened; this does not affect the material within the selection.

To change the length of a selection, do one of the following:

■ With the Selector tool, position the cursor over one end of the current selection and Shift-click or Shift-drag left or right.

■ In the Main Timebase ruler, drag the Playback Marker for the selection’s start or end point.

■ If the Timeline and Edit selections are unlinked, drag the Edit Markers (see Figure 12 on page 273) to change the selection length.

To make a long-length selection:

1. With the Selector tool, click at where you want the selection to start.

2. Scroll to the end point and Shift-click at the point where you want the selection to end.

To verify the start and end points of a long selection, press the Left Arrow key to scroll to the beginning of the selection, or press the Right Arrow key to scroll to the end.

Nudging a Selection Range

The selection range (not the material within the selection) can be moved by the Nudge value.

To nudge a selection range:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 305.

2. Make the initial selection with the Selector tool.

3. While pressing Shift, press Plus (+) or Minus (−) on the numeric keypad to move the selection range by the Nudge value.

Nudging Selection Start/End Points

Start and end points for selections can be moved by nudging them.

To move a selection start or end point by the Nudge value:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 305.

2. Make the initial selection with the Selector tool.

3. While pressing Alt+Shift (Windows) or Option+Shift (Macintosh), press Plus (+) or Minus (−) on the numeric keypad to move the selection’s start point by the Nudge value.

– or –

While Control+Shift (Windows) or pressing Command+Shift (Macintosh), press Plus (+) or Minus (−) on the numeric keypad to move the selection’s end point by the Nudge value.
Extending Selections

You can extend selections to region start and end points, to include an adjacent region, or to Markers and Memory Locations.

To extend a selection to a region start or end point:

1. With the Selector tool, select a portion of a region, or click anywhere in the region.
2. Press Shift+Tab to extend the selection to the region’s end point.
   – or –
   Press Shift+Control+Tab (Windows) or Shift+Option+Tab (Macintosh) to extend the selection to the region’s start point.

To extend a selection to include an adjacent region:

1. Select the first region with the Time Grabber tool.
2. With Tab to Transients disabled, press Shift+Start+Tab (Windows) or Shift+Control+Tab (Macintosh) to extend the selection to the next region boundary.
   – or –
   Press Shift+Start+Control+Tab (Windows) or Shift+Control+Option+Tab (Macintosh) to extend the selection to include the previous region boundary.

To extend a selection to a Marker or Memory Location:

1. Click in a track with the Selector tool at the desired start or end point.
   – or –
   Make a selection with the Selector or Time Grabber tool.

2. Shift-click a Marker in the Markers ruler.
   – or –
   Shift-click a Memory Location in the Memory Locations window.

The selection is extended from the original Insertion point to the Marker or Memory Location.

Using the Edit Selection Indicators (Start, End, and Length)

The Edit Selection indicators at the top of the Edit window can define precise Edit selections. Time values for the Edit Selection indicators use the time format for the Main Time Scale.

To make a selection with the Edit Selection indicators:

1. Click with the Selector tool in the track you want to select.
2. Click in the Start field at the top of the Edit window.
3. Type in the start point for the selection and press the Forward Slash key (/) to enter the value and automatically move to the end field.
4. Type in the end point for the selection and press Enter to accept the value.
 Numeric Entry Shortcuts for Selection Indicators

You can use the following shortcuts for entering values in the Edit Selection indicators:

- Press the Forward Slash (/) key to cycle through the three Edit Selection indicators.
- Use Period (.) or the Left and Right Arrow keys to move through the different time fields in each Edit Selection indicator.
- Press the Up or Down Arrow keys to increase or decrease the numerical values.
- Control-drag (Windows) or Command-drag (Macintosh) in a field to scroll to a new value.
- Press Plus (+) or Minus (–), along with an accompanying number, to add or subtract from the current field value.

For example, to add 10 to a current field value, cycle to the field, press the Plus (+) key, type “10” and then press Enter.

- Press Escape to exit the Edit Selection indicators without entering any values.

These shortcuts can also be used to enter start and end values in the Transport window.

Calculator Entry Mode

You can perform calculator-style editing of values in the Edit Selection indicators.

To subtract time values:

1. In the Edit Selection indicator, highlight the time field you want to change.
2. Press Minus (–) on the numeric keypad.
3. Type the amount you want to subtract from the current time value, then press Enter.
4. Press Enter again to apply the change.

To add time values:

1. In the Edit Selection indicator, highlight the time field you want to change.
2. Press Plus (+) on the numeric keypad.
3. Type the amount you want to add to the current time value, then press Enter.
4. Press Enter again to apply the change.

Selecting Across Multiple Tracks

To perform edits across multiple tracks or all tracks, you must first select the tracks. Do this by including other tracks in the selection, or by selecting in a Timebase ruler (for all tracks).

To make a selection in multiple tracks:

With the Selector tool, click and drag vertically to include adjacent tracks in a selection (drag horizontally to define the time range).

To extend a selection to another track:

1. Using the Selector or Time Grabber tool, make a selection in the first track or tracks.
2. Shift-click in additional tracks with the Selector tool. An identical range is selected for each additional track.

To shorten or lengthen the selection across each of the tracks, press Shift while dragging to change the range of the selection.

To select across all tracks:

- Enable the All Edit Group and make a selection in any track.
- or –
- Drag with the Selector tool in any Timebase ruler (make sure the Timeline and Edit Selections are linked).
These selections include all tracks in the Edit window, but do not include the Conductor tracks (for Tempo, Meter, and Markers).

To select across all tracks, including the Conductor tracks (for Tempo, Meter, and Markers):
- Alt-drag (Windows) or Option-drag (Macintosh) with the Selector tool in any Timebase ruler.

Moving and Extending Selections Between Tracks

With Commands Keyboard Focus enabled, Edit selections can be moved or extended to adjacent tracks.

To move a selection to an adjacent track:
1. Enable the Commands Keyboard Focus by clicking its button in the upper left of the Edit window.
2. With the Selector or Time Grabber tool, make a selection.
3. Press P on your computer keyboard to move the selection to the previous track.
   – or –
   Press semicolon (;) to move the selection to the next track.
   In either instance, the original Edit selection becomes deselected.

With Commands Keyboard Focus disabled, press Start+P (Windows) or Control+P (Macintosh) to move the selection to the previous track, or Start+; (Windows) or Control+; (Macintosh) to move the selection to the next track.

To extend a selection to an adjacent track:
1. Enable the Commands Keyboard Focus.
2. With the Selector or Time Grabber tool, make a selection.
3. Press Shift+P to extend the selection to the previous track.
   – or –
   Press Shift+semicolon to extend the selection to the next track.
   In either instance, the original Edit selection remains selected.

To remove the bottom track from a selection:
- Press Start+Alt+semicolon (Windows) or Control+Option+semicolon (Macintosh) to remove the bottom track.
Other Useful Selection Techniques

Following are some additional selection techniques.

To position the edit cursor precisely at a region start, end, or sync point:
1. Make sure the Tab to Transients button is not enabled. (See “Tabbing to Transients” on page 283.)
2. Click with the Selector tool in the track.
3. Press Tab to move the cursor to the next region or region group start, end, or sync point.
   – or –
   Press Control+Tab (Windows) or Option+Tab (Macintosh) to move the cursor to the previous region or region group start, end, or sync point.

To make a selection with the Scrubber:
1. Choose Setup > Preferences and click the Operation tab.
2. Select the option for “Edit Insertion Follows Scrub/Shuttle,” then click Done.
3. Scrub with the Scrubber to find an appropriate start point for the selection, then release.
4. While pressing Shift, scrub to an appropriate end point for the selection, then release. The range between the initial and final scrub becomes selected.

To move a selection to an adjacent region on the same track:
1. Select a region with the Time Grabber.
2. Press Start+Tab (Windows) or Control+Tab (Macintosh) to move the selection to the next region.
   – or –
   Press Start+Control+Tab (Windows) or Control+Option+Tab (Macintosh) to move the selection to the previous region.

In either instance, the original region becomes deselected.

To slide an Edit selection in the Main Timebase ruler:
1. With the Selector or Time Grabber tool, make a selection.
2. While pressing Alt (Windows) or Option (Macintosh), move the cursor over either of the Playback Markers in the ruler (the Time Grabber appears).

3. Drag left or right to move the Edit selection back or forward in time, while preserving its length.

If the Timeline and Edit selections are unlinked, Alt-drag (Windows) or Option-drag (Macintosh) the Edit Markers instead.
Tabbing to Transients

With the Tab to Transients button, you can automatically navigate to transients in audio waveforms, placing the cursor just before the detected transient peak. This allows you to easily define selections and play ranges, as well as start and end points for new regions, without having to zoom in on the waveform.

When Tab to Transients is enabled, the Tabbing function also locates the cursor to region start and end points, but not to sync points.

To set the start and end points of a selection with Tab to Transients:

1. In the upper left of the Edit window, click the Tab to Transients button so it becomes selected.
2. If you will be setting the play range with this selection, enable Options > Link Timeline and Edit Selection.
3. Click in the audio track just before the beginning of the material you want to select.
4. Press Tab repeatedly until the cursor locates to the transient at the start of the selection.
5. Press Shift+Tab until the cursor locates to the end of the material you want to select.

If necessary, you can move to the previous transient by pressing Control+Tab (Windows) or Option+Tab (Macintosh).

Once selected, the material can be looped for recording or playback, or it can be turned into a new region with the Separate or Capture command.

PEAK TRANSIENTS ARE USUALLY VISIBLE IN THE WAVEFORM. HOWEVER, SOME LOW-FREQUENCY TRANSIENTS MAY NOT APPEAR AS VISIBLE PEAKS IN THE WAVEFORM.

Playing Selections

Once an Edit selection is made, you can audition it by clicking Play in the Transport window. If enabled, the pre- and post-roll amounts play as well.

To play a selection:

1. Make sure to select Options > Link Timeline and Edit Selection.
2. With the Selector or Time Grabber tool, make a track selection.
3. If you want to use pre- or post-roll, enable and set the pre- and post-roll amounts. For details, see “Setting Pre- and Post-Roll” on page 183.
4. Click Play in the Transport window, or press the Spacebar.

All tracks play for the range of the selection, including pre- and post-roll if enabled.

To play an Edit selection with Link Timeline and Edit Selection disabled:

- or -
- On Pro Tools LE or Pro Tools M-Powered, choose Edit > Play Edit Selection.
To play a Timeline selection with Link Timeline and Edit Selection disabled (Pro Tools HD only):

- Choose Edit > Selection > Play Timeline.

**Auditioning Pre- and Post-Roll**

You can audition and play just the pre-roll or post-roll material for a selection.

**To play from the pre-roll point to the start of a selection, or to the current Cursor location:**

- Press Alt+Left Arrow (Windows) or Option+Left Arrow (Macintosh).

**To play to the post-roll point from the end of a selection, or from the current Cursor location:**

- Press Control+Right Arrow (Windows) or Command+Right Arrow (Macintosh).

**Auditioning Start and End Points for Selections**

There may be times when you want to audition the start or end of an audio selection without hearing the entire selection. This allows you to check, for instance, whether the beginning or end of a selection includes any unwanted clicks or pops.

**To audition a selection start point:**

- Press Control+Left Arrow (Windows) or Command+Left Arrow (Macintosh).

When auditioning the beginning of a selection, the selection plays from the start point for a duration equal to the post-roll amount.

**To audition a selection start point with pre-roll:**

- Press Control+Alt+Left Arrow (Windows) or Command+Option+Left Arrow (Macintosh).

**To audition a selection end point:**

- Press Alt+Right Arrow (Windows) or Option+Right Arrow (Macintosh).

When auditioning the end of a selection, playback begins before the end point by the pre-roll amount.

**To audition a selection end point with post-roll:**

- Press Control+Alt+Right Arrow (Windows) or Command+Option+Right Arrow (Macintosh).

**Looping Playback**

When Loop Playback is enabled, the selected track range repeats on playback. If there is no selection, playback occurs normally from the current Cursor location.

💡 A selection must be at least 500 ms in length for it to loop on playback.

Looping playback is a useful way to check the rhythmic continuity of a selection when working with musical material. If you’re working with one-bar selections, you can loop playback to see if the material loops cleanly. If it seems to skip, you should then adjust the length of the selection until it works “musically” within the context of the playlist and the other tracks.
To loop playback of a selection:

1. Make sure to select Options > Link Timeline and Edit Selection.
2. With the Selector tool, select the track range you want to loop.
3. Select Options > Loop Playback. When enabled, a loop symbol appears in the Play button in the Transport window.

– or –

You can also enable Loop Playback by doing one of the following:
- Right-clicking (Windows) or Control-clicking (Macintosh) the Play button in the Transport window.
- With the Numeric Keypad mode set to Transport, press 4 on the numeric keypad.

4. Click Play in the Transport window.

Playback begins from the pre-roll point (if enabled) and continues to the selection’s end point, where it loops back to the start point.

5. Click Stop in the Transport window to stop playback.

**Timeline Selections**

With the Link Timeline and Edit Selection option disabled, selections can be made in the Timeline that are distinct and separate from Edit selections.

With the Timeline and Edit selections linked, any Edit selections that are made are mirrored in the Timeline.

Whether the Timeline and Edit selections are linked or not, the range indicated by the Playback Markers always determines the range for playback and recording.

With Pro Tools HD, when the Scrolling option is set to Center Playhead, it determines where playback begins. For details, see “Playing Timeline and Edit Selections with the Playhead” on page 288.

**To make a Timeline selection with the Selector tool:**

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in any Timebase ruler.

**Loop Playback and Audio Recording**

When Loop Playback is enabled, Pro Tools will not loop when attempting to record audio tracks with QuickPunch, Destructive Record, or Nondestructive Record mode.

To loop record audio tracks in Pro Tools, you must enable Loop Record mode. (See “Loop Recording Audio” on page 177.)
The Timeline selection is indicated in the Main Timebase ruler by the blue Playback Markers (red if a track is record-enabled). The start, end, and length for the Timeline selection is displayed in the corresponding fields in the Transport window.

![To select all tracks, including Conductor tracks, press Alt (Windows) or Option (Macintosh) while dragging in a Timebase ruler with the Selector tool.](image)

**To set the Timeline selection by dragging the Playback Markers:**

1. If you want to constrain movement to the current Grid value, set the Edit mode to Grid.
2. With the Time Grabber, drag the first Playback Marker (down arrow) to set the start point.
3. Drag the other Playback Marker (up arrow) to set the end point.

![Dragging a Playback Marker](image)

**To set the Timeline selection by typing into the Transport window:**

1. If necessary, resize the Transport window by clicking in the upper right so the start and end times are displayed.
2. In the Transport window, click in the start field.
   - or -
   Press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Macintosh) on the numeric keypad to select the start field in the Transport window.
3. Type in the new start location and press Forward Slash (/) to enter the value and automatically move to the end field.
4. Type in the new end location and press Enter to accept the value.

**Shortcuts for entering start and end values in the Transport window are listed in “Numeric Entry Shortcuts for Selection Indicators” on page 280.**

**Sliding a Timeline Selection**

Like Edit selections, Timeline selections can be slid in the Main Timebase ruler.

**To move a Timeline selection in the Main Timebase ruler:**

1. While pressing Alt (Windows) or Option (Macintosh), move the cursor over either of the Playback Markers (the Time Grabber appears).
2. Drag left or right to move the Timeline selection back or forward in time, while preserving its length.

**Timeline Selections to/from Edit Selections**

*(Pro Tools HD Only)*

When the Timeline and Edit selections are unlinked, you can copy selections between them.

**To copy the current Edit selection to the Timeline:**

- Choose Edit > Selection > Change Edit to Match Timeline.

**To copy the current Timeline selection to an Edit selection:**

- Choose Edit > Selection > Change Timeline to Match Edit.
TCE (Time Compression and Expansion) Edit To Timeline Selection

(Pro Tools HD Only)

When the Edit and Timeline selections are unlinked, you can compress or expand an audio selection to fit the Timeline selection. This feature works by using the Time Compression/Expansion plug-in to expand or compress the selected audio material.

To fit an Edit selection to the Timeline:
1. Deselect Options > Link Timeline and Edit Selections.
2. With the Selector tool, select the audio material to be compressed or expanded.
3. In any Timebase ruler, select the time range where you want to fit the audio material.
4. Choose Edit > TCE Edit to Timeline Selection. The Edit selection is compressed or expanded to the length of the Timeline selection.

TCE Edit to Timeline Selection on Multiple Tracks and Channels

The TCE Edit to Timeline command can be used on multichannel selections, and selections across multiple tracks.

However, all regions are compressed or expanded equally by the same percentage value, based on Edit selection range. This ensures that the rhythmic relationship between the different channels or tracks is retained.

Fitting an Audio Region to an Edit Selection

Regions can be dragged from the Region List to fit within an Edit selection. The dragged region is compressed or expanded to fit within the selection. This feature uses the Time Compression/Expansion plug-in to expand or compress the audio region.

To fit an audio region to an Edit selection:
1. With the Selector tool, select a time range in an audio track.
2. Control-Alt-drag (Windows) or Command-Option-drag (Macintosh) the region from the Region List to the track with the selection. The start of the region is positioned at the selection start, and the region is compressed or expanded to match the length of the selection.

Fit to Selection on Multiple Tracks and Channels

The Fit to Selection command supports dragging multiple regions from the Region List to multiple tracks, or multichannel tracks.

However, all dragged regions are compressed or expanded equally by the same percentage value, based on length of the region last clicked before dragging.
Playing Timeline and Edit Selections with the Playhead

(Pro Tools HD Only)

When the Scrolling option is set to Center Playhead, selections in the Timeline do not determine when playback begins. The Playhead, itself, denotes where playback begins when clicking Play in the Transport.

The Timeline and Edit selections, however, can still be played when the Playhead is enabled.

To play an Edit selection with the Playhead enabled:

1. Deselect Options > Linked Timeline and Edit Selections.
2. Select Options > Scrolling > Center Playhead.
3. With the Selector or Time Grabber tool, make a track selection.

The Playhead jumps to the Edit selection and plays it from beginning to end, and then stops.

To play a Timeline selection with the Playhead enabled:

1. Deselect Options > Linked Timeline and Edit Selections.
2. Select Options > Scrolling > Center Playhead.
3. Drag with the Selector tool in any Timebase ruler to set the play range.
4. Choose Edit > Selection > Play Timeline.

The Playhead jumps to the Timeline selection and plays it from beginning to end, and then stops.

Moving the Playhead

When the Scrolling option is set to Center Playhead, the Playhead can be moved forward or back to the next region boundary in the selected track.

To move the Playhead through a track’s region boundaries:

1. Make sure the Tab to Transients button is not enabled. (See “Tabbing to Transients” on page 283.)
2. Click in the track with the Selector tool.
3. Press Tab to move the Playhead forward to the next region boundary.
   – or –
   Press Control+Tab (Windows) or Option+Tab (Macintosh) to move the Playhead back to the previous region boundary.
Chapter 17: Working with Regions and Selections

Regions are the basic building blocks for arranging audio and MIDI in Pro Tools. Understanding how regions are created, edited, and arranged is essential to taking full advantage of the editing capabilities of Pro Tools.

This chapter covers basic editing functions as they apply to regions and region groups, and selections, which for the most part apply to both MIDI and audio data.

For editing procedures more specific to MIDI, see Chapter 22, “MIDI Editing.”

Creating New Regions

Pro Tools provides several commands for creating regions and region groups, each of them having a slightly different effect on the selection. When you create a new region or region group, it appears in the Region List and in the track’s playlist. For details on how these new regions are automatically named, see “Auto-Naming Options” on page 351.

When creating a new region from an existing region, the original region remains in the Region List.

Capture Region Command

The Capture Region command defines a selection as a new region and adds it to the Region List. From there, the new region can be dragged to any existing tracks.

To capture a new region:

1. With the Selector tool, click and drag within an existing region to select the material for the new region.

2. Choose Region > Capture.

3. Enter a name for the new region and click OK.

The new region appears in the Region List. The original region remains intact and unchanged.
Separate Region Commands

The Separate Region commands define a selection within an existing region, or a partially selected region, as a new region and separate it from adjacent material.

There are three different Separate Region commands:

- **At Selection** Creates new region boundaries at the selection start and end points.
- **On Grid** Creates new regions according to the current grid resolution.
- **At Transients** Automatically creates region boundaries on detected transients within a selection. This uses the same algorithm for transient detection as the Tab To Transients feature.

If there is no selection and the edit cursor is placed within the region, the region is split into two new regions at the insertion point.

To separate one or more regions:

1. With the Selector tool, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.
   - or -
   With the Selector tool, click at the point within a region, where you want to separate the region.
2. Choose Edit > Separate Region > At Selection.
   - or -
   Press Control+E (Windows) or Command+E (Macintosh).
3. If the Editing preference for Auto-Name Separated Regions is disabled, enter a name for the new region when prompted, then click OK.

New regions appear in the tracks in which they are created, separate from the data surrounding them. They also appear in the Region List.

To separate regions according to the current grid resolution:

1. Make the desired Edit selection.
2. Choose Edit > Separate Region > On Grid.

To separate regions at transients:

1. Make the desired Edit selection.
2. Choose Edit > Separate Region > At Transients.

Auto-Name Separated Regions Option

With the Auto-Name Separated Regions option in the Editing Preferences page selected, Pro Tools automatically names separated regions for you. The name is a numbered variation of the original region’s name.

By separating a region, additional regions are auto-created from data on either side of the separation, which have new numbers assigned to their names. The original region remains intact and unchanged on the Region List.

If the Editing preference for “Separate Region Operates On All Related Takes” is selected and you are editing a region that is one of a number of related takes with the same User Time Stamp (for example, as created with loop recording), the Separate Region command affects each take. For details see, “Editing Preferences for Takes” on page 179.

The Region List can quickly fill up with auto-created regions. From the Region List pop-up menu, deselect Show > Auto-Created to hide all auto-created regions in the Region List.
**Separating Multiple Tracks**

Figure 13 illustrates a separation across three mono audio tracks and one stereo track. For some tracks, the selection resides within a region, while others reside at the start or end of a region.

Once separated, this material can be easily moved or copied to another location.

**Separation Grabber Tool**

You can use the Separation Grabber tool to automatically separate an Edit selection and move it to another location or another track.

**To separate a selection with the Separation Grabber tool:**

1. With the Selector tool, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber tools pop-up menu, choose the Separation Grabber tool.

3. Drag the selection to the new location, or to another track.

A new region (or regions) containing the previous selection is created, separate from the original selection. New regions are also created from the material outside the original selection.
To separate a selection without affecting the original regions:

1. With the Selector tool, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber tools pop-up menu, choose the Separation Grabber tool.

3. While pressing Alt (Windows) or Option (Macintosh), drag the selection to the new location, or to another track.

New regions containing the previous selection are created and placed at the new location. The original selection and regions remain intact.

Region Overlap and Underlap

When a tick-based audio track has multiple regions, an increase in tempo can cause neighboring regions to overlap. Audio regions can be set to display a small “dog-ear” corner to indicate overlapping region boundaries.

To toggle the display of overlap and underlap region boundaries:

- Choose View > Region > Overlap.

Changing Region Overlap/Underlap

After tempo changes and other edits, regions may overlap in undesired ways. To correct this, a region can be brought to the front, or sent behind neighboring regions as needed.

To change the region overlap or underlap:

1. In the Edit window, choose the region or regions you want to re-order.

2. Choose Region > Bring to Front to make the region overlap the neighboring regions.

   - or -

Choose Region > Send to Back to make the region underlap the neighboring regions.

If multiple overlapping regions are selected, Pro Tools will apply the command to each region as that region relates to the neighboring region on the right.
Trimming Commands

Pro Tools provides several options for editing region and region group boundaries.

Trim Region to Selection Command

The Trim Region to Selection command removes data before and after a region or MIDI note selection, leaving only the selection. This command lets you quickly remove all data in a region (and in some instances the entire track) except for the current selection.

To trim unwanted data from a region or note:
1. With the Selector tool, select a portion of a region or note (or a range of notes).
2. Choose Edit > Trim Region > To Selection to remove material outside of the selection.

Trim Region to Insertion Commands

You can trim a region or MIDI note by automatically removing the material between the Edit insertion point and the start or end point of the region.

To trim from a start point to insertion:
1. With the Selector tool, click inside the region or note where you want the new start point to be.
2. Choose Edit > Trim Region > Start To Insertion. The region’s start point is automatically trimmed to the insertion point.

To trim from an end point to insertion:
1. With the Selector tool, click inside the region or note where you want the new end point to be.
2. Choose Edit > Trim Region > End To Insertion. The region’s end point is automatically trimmed to the insertion point.

Trim to Fill Selection Commands

The Trim to Fill Selection commands let you automatically reveal underlying material in the gaps between regions, as follow:

To trim from a start point to fill gaps:
1. With the Selector tool, select across at least one gap between regions.
2. Choose Edit > Trim Region > Start to Fill Selection.
The start point of the region behind the gap is automatically trimmed (expanded) to the previous region, or as far as possible if there is not enough underlying material to cover the gap.

To trim from a region’s start and end points to fill gaps:
1. With the Selector tool, select across at least one gap between regions.
2. Choose Edit > Trim Region > To Fill Selection.

The start point of the region behind the gap is automatically trimmed (expanded) to the previous region, or as far as possible if there is not enough underlying material to cover the gap; and the end point of the region in front of the gap is automatically trimmed (expanded) to the next region, or as far as possible if there is not enough underlying material to cover the gap.

Trimming with Nudge

You can trim the start and end points of a region by nudging them.

To trim a region’s start or end point by the Nudge value:
1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 305.
2. With the Time Grabber tool, select the region you want to trim.
3. While pressing Alt (Windows) or Option (Macintosh), press Plus (+) or Minus (–) on the numeric keypad to trim the region’s start point by the Nudge value.
   – or –

While pressing Control (Windows) or Command (Macintosh), press Plus (+) or Minus (–) on the numeric keypad to trim the region’s end point by the Nudge value.
Healing Separated Regions

The Heal Separation command returns separated regions to their original state—provided the regions are still next to each other and their relative start/end points haven’t changed since the separation.

If you have trimmed or otherwise changed the start or end points of the two regions, or moved them further away from each other, you won’t be able to repair them with the Heal Separation command. It is not possible to heal two regions created from different audio files.

To heal a separation between two regions:

1. With the Selector tool, make a selection that includes part of the first region, the entire separation between the regions, and part of the second region.
2. Choose Edit > Heal Separation.

If the regions do not heal with Heal Separation, do one of the following to return the separated regions to a single region:

- Delete one of the two separated regions (make sure you’re in Slip mode so the gap doesn’t close) and use the Trim tool to expand the remaining region to its original length. For information on using the Trim tool, see “Trimming” on page 254.
- or –
- Delete both of the separated regions and drag the original region from the Region List to the original location. For information on placing regions, see “Placing Regions in Tracks” on page 295.

Placing Regions in Tracks

Once you have created a region, it appears in the Region List. From the Region List you can drag it to a track to add to an existing arrangement of regions, or you can create a new track and start adding regions from scratch. The exact placement of regions in a track depends on whether the Edit mode is set to Shuffle, Slip, Spot, or Grid (see “Edit Modes” on page 246 for details).

For information on locating regions in the Region List by typing the first few letters of their name, see “Keyboard Selection of Regions” on page 244.

To place a region in a track:

1. In the Region List, select the region or regions you want to place.
2. Drag the selected regions from the Region List to a location in a track.

If dragging multiple regions, the regions are placed on adjacent tracks left to right or on multiple tracks from top to bottom depending on the selected Region List Timeline Drop Order (see “Timeline Drop Order” on page 296). If dragging a stereo region, it must be placed in a stereo track or in two mono tracks.
Regions are placed according to the current Edit mode:

- In Shuffle mode, existing track regions are slid as necessary to make room for the new region.
- In Spot mode, you are prompted by the Spot dialog to enter a location for the dragged region (see “Spotting Regions” on page 301).
- In Grid mode, the dragged region snaps to the nearest Grid boundary.
- In Slip mode, the regions are placed exactly where they are dropped in the destination track.

**Timeline Drop Order**

The Timeline Drop Order command in the Region List pop-up menu sets whether tracks dragged from the Region List are dropped sequentially in a single track or spread across multiple tracks, as follows:

**Top to Bottom** When enabled, regions spread across multiple destination (drop) tracks or on new tracks (when dragging to the area below the last track or to the Track List).

**Left to Right** When enabled, regions are placed sequentially in a single destination (drop) track or on a new track (when dragging to the area below the last track or on to the Track List).

**To set the Region List Drop Order:**

- Choose Region List > Timeline Drop Order, and then Top to Bottom or Left to Right.

**To drag and drop multiple items from the Region List to multiple new tracks:**

1. From the Region List pop-up menu, choose Timeline Drop Order > Top to Bottom.
2. Search and sort the Region List if desired to configure the order in which items will be placed.
3. Select multiple items in the Region List and do one of the following:
   - To create new tracks and place items to a specific location, drop items at the desired location along the area below the last track.
   - To create new tracks and have items placed at the start of the session, drop the items on the Track list.

**To place multiple items across multiple existing tracks:**

1. From the Region List pop-up menu, choose Timeline Drop Order > Top to Bottom.
2. Select multiple items in the Region List and drop them in the playlist of a compatible track at the desired location. When the cursor is over a compatible destination, the region outlines appear at the location.
To drag and drop multiple items from the Region List to a single track:

1. From the Region List pop-up menu, choose Timeline Drop Order > Left to Right.
2. Search and sort the Region List if desired to configure the order in which items will be placed.
3. Select multiple items in the Region List and do one of the following:
   - To create a new track and spot the first item to a specific location, drop at the desired location in the area below the last track shown in the Edit window.
   - To create a new track and have the first item placed at the start of the session, drop the items on the Track list.
   - To place items in an existing track, drop the items in the Edit playlist for the desired track.

If the selected items include mixed types of regions (such as audio and MIDI, or region groups and MIDI) the appropriate track types will be created and each corresponding item will be placed in them. Similarly, if the selected items include multiple formats (mono, stereo, or other) new tracks of each format will be created and those regions placed in them.

Placing Regions at the Edit Insertion Point

You can drag a region from the same track, from another track, or from the Region List, and align its start, end, or sync point to the Edit insertion point. This technique is very useful in post production since it lets you set an Edit selection point during playback or while stopped and then quickly place sound effects at the edit insertion point.

*With Pro Tools HD, when the Scrolling option is set to Center Playhead, regions snap to the playhead, instead of the Edit insertion point.*

To place the start of a region at the Edit insertion point:

1. With the Selector tool, click in the track at the time location where you want to place the start of the region.
2. While pressing the Start key (Windows) or Control (Macintosh), drag the region from the Region List, or from another track, to the destination track.
   - or –
   - If the region is already in the track, Start-click (Windows) or Control-click (Macintosh) the region with the Time Grabber tool.
To place the end of a region at the Edit insertion point:

1. With the Selector tool, click in the track at the time location where you want to place the end of the region.

2. While pressing Control+Start (Windows) or Command-Control (Macintosh), drag the region from the Region List, or from another track, to the destination track.
   – or –

If the region is already in the track, Control-Start-click (Windows) or Command-Control-click (Macintosh) the region with the Time Grabber tool.

To place the sync point of a region at the Edit insertion point:

1. With the Selector tool, click in the track at the time location where you want to place the sync point of the region.

2. While pressing Shift+Start (Windows) or Shift+Control (Macintosh), drag the region from the Region List, or from another track, to the destination track.
   – or –

If the region is already in the track, Shift-Start-click (Windows) or Shift-Control-click (Macintosh) the region with the Time Grabber tool.

Aligning to Region Start Points

The start, end, and sync point of one region can be aligned to the start of a different region on another track.

With Pro Tools HD, when the Scrolling option is set to Center Playhead, region start, end, and sync points align to the playhead.

To align the start points of regions on different tracks:

1. With the Time Grabber tool, select the region you want to align to by clicking it.

2. If the Scrolling option is set to Center Playhead (Pro Tools HD only), move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 288.

3. Start-drag (Windows) or Control-drag (Macintosh) a region from the Region List to another track.
   – or –

If the region is already in the track, Start-click (Windows) or Control-click (Macintosh) the region you want to move with the Time Grabber tool.

The start point of the second region is aligned to the start of the first region.

To align the end point of a region to the start of another region (on a different track):

1. With the Time Grabber tool, select the region you want to align to by clicking it.

2. If the Scrolling option is set to Center Playhead (Pro Tools HD only), move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 288.

3. Control-Start-drag (Windows) or Command-Control-drag (Macintosh) a region from the Region List to another track.
   – or –

If the region is already in the track, Control-Start-click (Windows) or Command-Control-click (Macintosh) the region you want to move with the Time Grabber tool.

The end point of the second region is aligned to the start of the first region.
To align the sync point of a region to the start of another region (on a different track):

1. With the Time Grabber tool, select the region you want to align to by clicking it.
2. If the Scrolling option is set to Center Playhead (Pro Tools HD only), move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 288.
3. Shift-Start-drag (Windows) or Shift-Control-drag (Macintosh) a region from the Region List to another track.

   – or –

   If the region is already in the track, Shift-Start-click (Windows) or Shift-Control-click (Macintosh) the region you want to move with the Time Grabber tool.

The sync point of the second region is aligned to the start of the first region.

### Sliding Regions

A region or group of selected regions (on the same track or on multiple tracks) can be slid with the Time Grabber tool to new locations or to other tracks. This feature is useful in post production applications where the timing of audio events such as sound effects and dialog need to be spotted to music, film, or video.

Sliding regions is affected by whether the current Edit mode is set to Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 246 for details.

💡 You can slide a copy of a region to another location or track by pressing Alt (Windows) or Option (Macintosh) while dragging.

#### Shuffling Regions

In Shuffle mode, you can move regions freely within a track or onto another track, but their movement is constrained by other regions. That is, if you place several regions in a track, their start and end points automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode.

In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.

To shuffle regions:

1. Set the Edit mode to Shuffle by clicking its button in the upper left of the Edit window.
2. Drag a mono region from the Region List to an empty track. The region snaps to the beginning of the track.
3. Drag a second region from the Region List to the same track, somewhere in the middle. The start point for the second region snaps to the end of the first region.
4. With the Time Grabber tool, drag the second region to the beginning of the track.

Pro Tools “shuffles” the position of the two regions. The second region now occurs first, yet the two still cling together.
Experiment more with Shuffle mode by dragging additional regions to the track and rearranging them.

Locked regions (see “Locking Regions” on page 308), and all regions occurring after the locked region, are not displaced when other neighboring regions are moved in Shuffle mode. If there is not enough room to place or duplicate a region in front of a locked region, the insertion area is disabled.

If you place a region while in Slip mode and switch to Shuffle mode, Pro Tools preserves the relative timing and position of the slipped region, and any blank space between it and other regions.

Shuffling Multiple Tracks and Multichannel Regions

Selections across multiple tracks or on multichannel tracks can be shuffled. Unlike shuffling regions on a single track, any partially selected regions will be cut and moved along with the dragged region. This lets you retain only the material that corresponds to the dragged region.

Slipping Regions

In Slip mode, regions can be moved with the Time Grabber tool freely within a track, or onto other tracks. In this mode, it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

To slip regions:
1. Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.
2. Drag a region from the Region List to an empty track.
3. Drag a second region from the Region List to the same track, somewhere in the middle. The second region is placed wherever you release it. It doesn’t snap to the first region as in Shuffle mode.
4. Drag the regions to different locations within the track to get a feel for moving them in Slip mode. Try placing the second region so that it slightly overlaps the first region. Play back the results.
Spotting Regions

Spot mode is useful for sessions in which you want to spot regions to precise locations based on any of the Time Scales. This can be particularly useful when performing post production tasks. In Spot mode you can spot a region by specifying a SMPTE frame (Pro Tools HD and Pro Tools LE with DV Toolkit only) or bar and beat location, by capturing an incoming time code address, or by using the region’s time stamps.

For even quicker spotting, if you are using VITC, use the Auto-Spot Regions command to spot a region to the current SMPTE frame location with the Time Grabber tool. For more information, see “Auto-Spotting Regions” on page 663.

To spot a region:

1. Set the Edit mode to Spot by clicking its button in the upper left of the Edit window.

2. Drag a region from the Region List, or drag audio files or sessions from a DigiBase browser, to an existing track.
   – or –
   Click a region already in a track with the Time Grabber tool.

3. In the Spot dialog, select a time format from the Time Scale pop-up menu.

   Each of the fields in the Spot dialog are displayed in the chosen Time Scale.

4. With Pro Tools HD or Pro Tools LE with DV Toolkit, if the Time Scale is set to Time Code, select the Use Subframes option to display subframes in the fields for improved accuracy.

5. Click in the field for Start, Sync Point, or End and type in a new location. Changing one of these locate points automatically updates the other locate points.
   – or –
   Click one of the up arrows next to Original Time Stamp or User Time Stamp to enter the associated values into the currently selected field.
   – or –
   If you are using an external SMPTE time code source, click the down arrow next to the Current Time Code display—or press Equal (=) on the numeric keypad—to capture an incoming time code address.

6. Click OK. The region is moved to the new location specified for its start, end, or sync point.

   If a region does not have a sync point defined, the Sync Point field in the Spot dialog functions the same as the Start field.

   To learn more about using SMPTE with Pro Tools, refer to Chapter 34, “Working with Synchronization.”
Region Time Stamps

When a region is created, it is time stamped relative to the SMPTE start time specified for the session. This Original Time Stamp is permanently stored with the region and cannot be changed. If a region is ever moved, it can easily be placed at its original position from the Spot dialog.

When the Original Time Stamp for a region is initially set, this same location is also used to define the region’s User Time Stamp.

Unlike the Original Time Stamp, the User Time Stamp can be redefined with the Time Stamp command in the Region List pop-up menu. For more information, see “Time Stamping” on page 664.

Time Stamps in DigiBase

Columns are provided in DigiBase browsers for both the Original and User Time Stamps.

Time Stamps and the Takes List

Regions with identical User Time Stamps appear together in the Takes List pop-up menu when auditioning takes. For more information, see “Selecting a Different Take from the Takes List Pop-Up Menu” on page 178.

Sliding Regions in Grid Mode

Grid mode provides several useful capabilities for sliding and moving regions in track playlists. This mode is especially useful for lining up regions at precise intervals, as when working with a session that is bar- and beat-based. Grid boundaries, depending on the Main Time Scale, can be based on frames, bar and beat values, minutes or seconds, or a number of samples.

Grid mode also provides two operational modes, Absolute and Relative. These modes control how the Grid is applied. (See “Absolute and Relative Grid Mode” on page 303 for more information.)

To temporarily suspend Grid mode and switch to Slip mode while dragging a region, hold down the Control key (Windows) or Command key (Macintosh).

Setting Up the Grid

When the Display preference for “Draw Grid in Edit Window” is enabled, vertical Grid lines appear in the Edit window.

Grid lines in the Edit window can also be enabled and disabled by clicking the Timebase ruler name after it becomes highlighted.

Defining the Grid Value

In addition to affecting the placement of regions, the Grid value also constrains Timeline and Edit selections, and determines how the Region > Quantize to Grid command works.

To set the Grid value:

1. From the View > Main Counter menu, select the Time Scale you will use for the Grid value.

   – or –

To keep the Main Time Scale and use a different time format for the Grid, deselect Follow Main Timebase in the Grid value pop-up menu in the Edit window.
From the Grid value pop-up menu in the Edit window, select the time value that will define the Grid boundaries.

To define a Grid based on the session’s Markers, selections, and region boundaries, select Regions/Markers from the Grid value pop-up menu.

Absolute and Relative Grid Mode

Grid mode can be applied in Absolute or Relative mode.

- In Absolute Grid mode, moving any region snaps the region start to Grid boundaries. If a region’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the region will snap its start time to the nearest 1/4 note (the current absolute Grid value).
- In Relative Grid mode, regions can be moved by Grid (or Nudge) units. If a region’s start point falls between beats and the Grid is set to 1/4 notes, dragging the region will be constrained to 1/4 notes, preserving the region’s relative position to the nearest beat.

To select Absolute or Relative Grid mode:

- Click the Grid mode selector and choose Absolute or Relative.

To temporarily suspend Grid mode and switch to Slip mode while dragging a region, hold down the Control key (Windows) or Command key (Macintosh).

To place or move a region while in Grid mode:

1. Configure the Grid value. For details, see “Defining the Grid Value” on page 302.
2. Drag a region from the Region List to an existing track.

- or –

With the Time Grabber tool, drag a region already in a track to a new location.

The region’s start point snaps to the closest Grid boundary. If the region has a sync point defined, the sync point snaps to the Grid boundary.

Sync Points

The placement of regions in Grid and Spot mode can be based on the definition of a region sync point. Sync points are used when a specific point within a region must be aligned to the Grid or to a particular SMPTE or bar/beat location. This capability is important in placing music and sound effects for film and video work.

For example, suppose you had an audio region for a door slam that included the creak of the door closing, the actual slam, and the reverb of the slam. Using a sync point for the slam lets you spot the slam to a specific time in the session.
To define a region sync point:

1. Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.

2. With the Selector tool, click at the point in the region where you want to define the sync point.

   – or –

   Press the Down Arrow key while playing back.

3. Choose Region > Identify Sync Point. A small down arrow appears at the bottom of the region, with a vertical, light grey line indicating the location of the sync point.

Removing Sync Points

To remove a sync point:

■ Select the entire region and choose Region > Remove Sync Point.

   – or –

■ Choose the Time Grabber or Scrubber tool, then Alt-click (Windows) or Option-click (Macintosh) the sync point to delete it.

Displaying Sync Points

Sync points in audio regions may be displayed or hidden.

To disable the display of sync points in audio regions:

■ Deselect View > Region > Sync Point.

To enable the display of sync points in audio regions:

■ Choose View > Region > Sync Point.

Dragging Sync Points

You can drag a sync point to another position in the audio region.

To set the sync point by dragging:

1. If you want the sync point to snap to the current Grid value, set the Edit mode to Grid.

2. Select the Time Grabber tool.

3. Click and drag the sync point to a new location.
Scrubbing Sync Points

While viewing an audio waveform can be a good way to set a sync point, a waveform display may not always reveal the desired spot in the audio material. By scrubbing while moving the sync point over an audio waveform, you can listen for the exact location to place the sync point.

To scrub while dragging the sync point:

1. If you want the sync point to snap to the current Grid value when you finish scrubbing, set the Edit mode to Grid.
2. Select the Scrubber tool.
3. Drag the sync point to a new location. The sync point will scrub the audio as you move it.

Nudging

Pro Tools can nudge regions (or MIDI notes) by precise increments with the Plus (+) and Minus (–) keys on the numeric keypad. The amount of the nudge is determined by the value specified in the Nudge Value pop-up menu. The Nudge function can be used in any of the Edit modes.

Nudging can be invaluable for adjusting the “groove” of a musical phrase or a sound effect relative to other elements in the session. Since Pro Tools can nudge material during playback, you can nudge continuously in real time to adjust the timing relationship between tracks.

Nudge can also be used to adjust the placement of automation breakpoints. For more information, see “Editing Automation” on page 552.

Defining the Nudge Value

The Nudge value determines how far regions and selections are moved when nudging.

Start and end points for selections can also be moved by the Nudge value (see “Nudging Selection Start/End Points” on page 278). In addition, regions can be trimmed by the Nudge value (see “Trimming with Nudge” on page 294).

To set the Nudge value:

1. From the View > Main Counter menu, select the Time Scale you will use for the Nudge value.
2. From the Nudge value pop-up menu in the Edit window, select the Nudge value.

To specify a Nudge value not listed in the Nudge Value pop-up menu, click the Nudge Value indicator and type in the value.
Nudging Regions

To nudge one or more region:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 305.

2. With the Time Grabber or Selector tool, select the region, regions, or region groups you want to nudge. The regions can reside on multiple tracks. Only regions that are entirely selected will be nudged.

3. On the numeric keypad, press Plus (+) to move the selection forward by the Nudge value.
   – or –
   Press Minus (–) to move the selection back by the Nudge value.

The Nudge command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

Nudging Regions on Multiple Tracks and in Multichannel Tracks

When nudging a selection of multiple regions within a single track or across multiple tracks, that also contains silence, any automation data residing within the silence is also nudged.

Nudging by Next Nudge Value

In addition to nudging by the current Nudge value, you can also nudge by the next, larger value in the Nudge pop-up menu.

For example, if the Nudge value is set to 1 frame and you want to nudge by a larger value, you can nudge by the next, larger Nudge value of 10 frames.

To nudge forward or back by the next, larger Nudge value:

1. Enable the Commands Keyboard Focus by clicking the Keyboard Focus button in the upper left of the Edit window.

2. With the Selector or Time Grabber tool, select the regions or notes you want to nudge.

3. Press Forward Slash (/) to nudge the selected material forward by the next Nudge value. Press M to nudge the selection back.

   You can also nudge by the next Nudge value without enabling the Commands Keyboard Focus. While pressing the Start key (Windows) or Control (Macintosh), press Forward Slash (/) or M.
Nudging a Region’s Contents

Often a region’s start point will reside at the correct location, perhaps at a SMPTE frame or bar, but the material within the region starts too late or early. You can, in effect, nudge a region’s audio waveform or MIDI notes without displacing the region’s start and end points.

This “sliding” of region contents is only possible if there is material residing outside the region’s start and end points—from the region having been trimmed, or perhaps captured from a larger region.

To nudge the contents of a region without changing the region start and end points:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 305.
2. With the Time Grabber tool, select the region whose contents you want to nudge.
3. While pressing the Start key (Windows) or Control (Macintosh), press Plus (+) or Minus (–) on the numeric keypad to move the material by the Nudge value.

Shift Command

Use the Shift command to move track material forward or back in time by a specified amount. The Shift command can operate on selections, regions, MIDI notes, MIDI controller data, and automation breakpoints.

To shift a selection or region:

1. With the Selector or Time Grabber tool, select the track material you want to shift. The selected material can reside on multiple tracks.
2. Choose Edit > Shift. In the Shift dialog, select whether the data will be moved Earlier or Later.
3. Click in one of the Timebase fields to specify the amount the material will be shifted. Entering a value in one Timebase field automatically updates the others.
4. If you want to shift material with greater precision, select the Use Subframes option.
5. Click OK. The material is shifted back or forward by the specified amount.

If a portion of a region was selected, new regions are created from the selection and from any material outside of the selection.
The Shift command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

### Quantizing Regions to Grid

The Quantize to Grid command adjusts the placement of selected audio and MIDI regions so that their start points (or sync points, if they contain one) precisely align to the nearest Grid boundary.

**To quantize one or more regions:**

1. Configure the Grid value. For details, see “Defining the Grid Value” on page 302.
2. With the Selector or Time Grabber tool, select the region or regions you want to quantize. The regions can be on multiple tracks. Only regions that are entirely selected will be quantized.
3. Choose Region > Quantize to Grid. Region start times (or sync points) are aligned to the nearest boundaries for the defined Grid.

For MIDI regions, all data contained within the regions (such as notes) are moved equally, thereby retaining their rhythmic relationships. To quantize individual MIDI notes, use the Quantize command in the Event > MIDI submenu (see “Input Quantize” on page 456).

---

**Locking Regions**

If you have a region or group of regions that you want to permanently associate with a particular location in a track (a beat, SMPTE frame, or sample location), you can lock it in place so it will not be accidentally moved. Locked regions cannot be moved or deleted.

**To lock a region:**

1. With the Time Grabber, select the region or regions to lock. The regions can even reside on multiple tracks.
2. Choose Region > Lock/Unlock.

A small lock appears in the region, indicating it has been locked and cannot be moved. If you attempt to perform edits that would move a locked region, Pro Tools alerts you.

In Shuffle mode, locked regions, and all regions occurring after the locked region, are not displaced when other neighboring regions are moved.
Muting/Unmuting Regions

Choosing the Mute/Unmute Region command mutes playback of a selected region. Choosing the command a second time unmutes the region. Regions that are muted become dimmed to indicate their status.

To mute a region or regions:

1. With the Time Grabber, select the region or regions you want to mute. The regions can even reside on multiple tracks.

2. Choose Region > Mute/Unmute. The selected regions become dimmed, indicating they are muted.

To unmute a region, select it and choose Region > Mute/Unmute.

Replacing Audio Regions

(Pro Tools HD Only)

You can use the Replace Region function to replace multiple instances of an audio region in a playlist with another region that you Control-Shift-drag (Windows) or Command-Shift-drag (Macintosh) from the Region List.

This is useful in post production if you use a sound effect, room noise, or atmosphere region many times in a session, and later decide to replace one or all of the original regions with a different region.

This is also useful in music production if you want to replace a certain loop or sample (for example, a drum beat) with a new one. You can use this compositionally, if you know the tempo of a section or session, to create a scratch piece with “rough” regions of the correct length, and later replace them with “final” regions of the same length.
The following options are available in the Replace Region dialog:

**Replace: Original Region Only** Replaces only the selected region with the replacement region dragged from the Region List.

**Replace: All Instances of the Original Region** Replaces all regions in the session that match the original region.

**Replace: All Regions That Match Original Region’s** Replaces all regions that fit the Match criteria and the On criteria with the replacement region from the Region List.

- Start Position: replaces all regions that have the same original start time as the selected region. This includes regions that may have been auto-created when trimming end points.
- End Position: replaces all regions that have the same original end time as the selected region. This includes regions that may have been auto-created when trimming start points.
- Name: replaces all regions that come from the same audio file and have been renamed to the same name.
- On This Track: replaces regions that fit the Match criteria and are on the same track as the original region.
- On All Tracks: replaces regions that fit the Match criteria for all tracks in the session.
- On Within the Selection: replaces regions that fit the Match criteria within the current selection.

Region matching uses all specified Match criteria. For example, if you select Start Position and End Position, all regions from the same original audio file as your selection with the same original start and end times will be replaced.

**Fit Region Using The: Original Region Length** If the replacement region is smaller than the original region, the region is placed in the playlist and any remaining audio from the original region is removed.

If the replacement region is larger than the selection, it is placed in the playlist and trimmed to fit within the length of the original region.

**Fit Region Using The: Original Selection Length** When the playlist selection extends beyond the original region, the replacement region (if larger than the original region) is trimmed to fit within the selection.

**Fit Region Using The: Replacement Region Length** The replacement region is placed in its entirety, regardless of the length of the original region or selection.

The Replace Region function only works on a selection that includes a single region on one track. The function is not available when the playlist selection includes the start points for two or more regions. Also, if the selection is across several tracks, only the selection in the first (top) track is used.
To replace regions:

1. Select a region in a track's playlist that you want to replace. The selection can extend beyond the region's end point, to include material from the replacement region that is longer than the original region.

2. Control-Shift-drag (Windows) or Command-Shift-drag (Macintosh) the replacement region from the Region List to the selected region. The Replace Region dialog opens.

3. If you want to replace only the original region, select Replace Original Region.

   – or –

   If you want to replace multiple regions, select Replace All Regions That Match Original, and set the Match criteria.

4. Select whether to apply the replacement to all tracks, or only to the track with the current selection.

5. Select whether to fit the replacement regions to the current selection, the entire region, or the entire replacement region regardless of the destination length.

6. When you have set all the options, click OK.

Replace Regions with Drag and Drop

Use the key modifiers Control+Shift on Windows, or Command+Shift on Macintosh, while dragging any region from the Region List to any unselected region on a track to open the Replace Region dialog without having to make a selection first.

Selecting Regions

The Replace Regions command is also available in the Region List pop-up menu. To use this command, make sure there is a region selected in a track and a different (replacement) region selected in the Region List, as explained in the following instructions.

By default, selecting a region in a track selects the same region in the Region List. If this preference is turned off on your system, the following instructions are not necessary.

To access the Replace Regions dialog:

1. Select a region in a track. This is the region that will be replaced.

2. Control-click (Windows) or Command-click (Macintosh) the desired replacement region in the Region List to select it. (The Control key is required if the preference setting Region List Selection Follows Track Selection is at its default, enabled setting).

3. Choose Replace Regions from the Region List pop-up menu.

Replace Region and Multichannel Tracks

The Replace Region command supports dragging multichannel regions from the Region List to multichannel tracks, provided they are the same format.

For example, you can replace a stereo region, selected in a stereo audio track, with another stereo region from the Region List. But you cannot replace it with two mono audio regions.

In addition, replacing regions in multiple mono tracks with multichannel regions is not supported.
Edit Commands

Pro Tools provides many standard edit commands—such as cut, copy, and paste—and also many specialized edit commands that are optimized for audio production—such as Repeat Paste to Fill.

Cut, Copy, Paste, and Clear

Use the Cut, Copy, Paste, and Clear commands to rearrange and edit track material. Edits can operate on entire regions selected with the Time Grabber tool, or on track ranges selected with the Selector tool. Edits can also work across multiple tracks (see “Editing Across Multiple Tracks” on page 316).

You can cut, copy, and paste discontiguous regions by selecting them with the Object Grabber tool.

Track View and Edit Content

When cutting or copying track material, the Track View determines the type of data placed on the Clipboard. When displaying waveforms for audio tracks, or when viewing MIDI or Instrument tracks in Notes or Regions Views, selections include all underlying automation and controller data. Thus, cutting an audio region also cuts any volume, pan, mute, send, or plug-in automation that is also on the track. This saves you from having to individually cut from each automation playlist on the track.

Audio waveform data

Automation data (breakpoint-type data)

However, when selecting groups of MIDI notes with any of the Grabber tools (by drawing a rectangle around them), only the note data is placed on the Clipboard. When selecting a time range of MIDI notes with the Selector tool, all controller data in the track is selected (similar to selecting with the Selector tool for audio tracks in Waveform view).

When a track is displaying automation data or controller data, only that data is placed on the Clipboard. Also, whenever you cut or copy automation data, bounding breakpoints are created at each end of the selected area, in order to preserve the slope of the automation both inside and outside the selection.

If tracks are grouped, copying and pasting on any of the tracks affects each of the other tracks in the group. Tracks that are hidden—even if they are part of a group being edited—are not affected by edits.

The current Edit mode affects how material is selected, copied, and pasted:

• In Slip mode, the Cut command leaves an empty space corresponding to the data removed from the track.
• In Slip mode, pasted data can overlap an adjacent region.
• In Shuffle mode, the Cut command leaves no empty space, since the regions to the right of the cut slide over, closing the gap.
• In Shuffle mode, pasted data causes all regions to slide over to make room for the pasted material.
New regions are often auto-created when performing edits. For instance, when clearing a selection from a region, new regions are auto-created from the material residing outside of the selection.

**Cut and Copy Commands**

Use the Cut command to place the selection on the Clipboard while also removing it from the track.

Use the Copy command to place a copy of the selection on the Clipboard so it can be pasted to another track, or to the same track at a different location, while leaving the original intact and in place.

**To cut or copy a selection or region:**

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Set the Track View for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3. Drag with the Selector tool in the track to select the material you want to cut or copy.
   - or –

Use the Time Grabber tool to select one or more regions (or a group of MIDI notes).

4. Choose Edit > Cut to remove the selection and place it on the Clipboard.
   - or –

Choose Edit > Copy to place the selection on the Clipboard, without removing it.

If a portion of a region was cut or copied, the material on the Clipboard appears as a new region in the Region List. If a portion of a region was cut, new regions are auto-created from the material residing outside of the selection.

When working in Shuffle mode, adjacent regions are slid over, as necessary, to fill blank spaces.

**Deleting Underlying Region Data**

When removing a region or selection, you can choose to remove or keep the underlying region data.

**To delete a region or selection along with the underlying region data:**

- Choose Edit > Cut.

**To delete a region or selection without removing the underlying region data:**

- Choose Edit > Clear.

**Paste Command**

Use the Paste command to place the Clipboard’s contents at the Edit insertion point, overwriting any material already there.

**To paste a selection or region:**

1. If you want to constrain the insertion point or the selection to the current Grid value, set the Edit mode to Grid.
With the Selector tool, click in a track at the point where you want to paste the material. Press Tab to move the insertion point forward to region start and end times; to move back, press Control+Tab (Windows) or Option+Tab (Macintosh).

– or –

Use the Selector or Time Grabber tool to make a selection where the material will be placed.

3 Choose Edit > Paste.

If pasting at an insertion point in Shuffle mode, material to the right of the paste point is shifted to the right. In Slip mode, the material is over-written with the paste.

If pasting into a selection in Shuffle mode, the selection is replaced by the Clipboard’s contents with the adjacent material slid left or right as necessary. In Slip mode, the selection is also replaced but with the surrounding material remaining unchanged.

Clear Command

Use the Clear command to remove a selection from a track without placing it on the Clipboard.

To clear a selection or region:

1 If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

2 Set the Track View for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3 Drag with the Selector tool in the track to select the material you want to clear.

– or –

Use the Time Grabber tool to select one or more regions (or a group of MIDI notes).

4 Choose Edit > Clear to remove the selection.

If a portion of a region was cleared, new regions are auto-created from the material residing outside of the selection. If working in Shuffle mode, adjacent regions are slid over, as necessary, to fill the blank space.
Special Cut, Copy, Paste, and Clear Commands

Use the four “special” Edit menu commands (Cut Special, Copy Special, Paste Special, and Clear Special) for editing automation playlists (volume, pan, mute, and plug-in automation) on audio, Auxiliary Input, Master Fader, and Instrument tracks. These commands can also be used for MIDI controller data.

⚠️ You cannot paste MIDI controller data to automation data nor automation to MIDI.

Cut Special

All Automation Cuts all automation or MIDI controller data whether it is shown or not.

Pan Automation Cuts only pan automation or MIDI pan data whether it is shown or not.

Plug-In Automation Cuts only the plug-in automation that it is shown.

Copy Special

All Automation Copies all automation or MIDI controller data whether it is shown or not.

Pan Automation Copies only pan automation or MIDI pan data whether it is shown or not.

Plug-In Automation Copies only the plug-in automation that it is shown.

Paste Special

Merge Pastes the MIDI controller data from the Clipboard to the selection and merges it with any current MIDI controller data in the selection.

Repeat to Fill Selection Pastes multiple iterations of audio or MIDI regions, or automation data or MIDI controller data from the Clipboard to fill the selection. For more information, see “Repeat To Fill Selection” on page 316.

To Current Automation Type Pastes the automation data or MIDI controller data from the Clipboard to the selection as current automation type or MIDI controller. This lets you copy automation from any type to any other type. For example, you can copy Pan automation to Plug-In automation. Or, you can copy MIDI volume data and paste it to MIDI pan.

Clear Special

All Automation Clears all automation or MIDI controller data whether it is shown or not.

Pan Automation Clears only pan automation or MIDI pan whether it is shown or not.

Plug-In Automation Clears only the plug-in automation that it is shown.

For more information on working with automation data, see Chapter 27, “Automation.”
Repeat To Fill Selection

The Repeat to Fill Selection command lets you automatically fill a selection with audio or MIDI regions or data without requiring that you manually duplicate the regions. To use Repeat to Fill Selection, cut or copy an audio or MIDI region, then make a selection and use the command to fill the selection. When pasting audio regions, you are prompted to specify a crossfade to be used for the pasted regions.

If you fill an area that is an exact multiple of the copied region size (for example, filling 16 bars with a 4-bar loop), the copied selection is pasted as many times as it takes to fill the selection. If you fill an area that is not an exact multiple of the copied region size (for example, filling 15 seconds of a track with a 2-second atmosphere or room noise region), the remaining selection area is filled with an automatically trimmed version of the original selection.

To fill a selection with Repeat to Fill Selection:

1. Select the audio or MIDI region you want to copy and choose Edit > Copy.
2. Select the area you want to fill using the Selector tool and choose Edit > Paste Special > Repeat to Fill Selection.
3. If pasting audio regions to larger areas, the Batch Fades dialog opens. Configure the dialog to insert crossfades between each pasted region, then click OK.

   – or –

If you do not want crossfades for the pasted audio, click Cancel in the Batch Fades dialog.

Editing Across Multiple Tracks

When working with data from multiple tracks, there are some important points to remember. For instance, if any of the selected tracks are set to their master view (see “Master Views for Tracks” on page 223), edits affect not only audio and MIDI for the selected tracks, but all automation and controller data as well.

If all selected tracks are displayed as automation data, edits only affect the type of automation data displayed in each track. Furthermore, if track 1 displays Pan automation, track 2 displays Volume automation, and track 3 displays Mute automation, the Cut command cuts only pan data from track 1, volume data from track 2, and mute data from track 3.

For details on selecting data on multiple tracks, see “Selecting Across Multiple Tracks” on page 280.

When copying only automation or controller data for selected tracks, press the Start key (Windows) or Control (Macintosh) to copy all types of automation on all selected tracks.

To paste to multiple tracks, place the insertion point in each of the destination tracks by Shift-clicking in them—or to select all tracks, Alt-Shift-click (Windows) or Option-Shift-click (Macintosh) in a track, or make a selection in one of the Timebase rulers.

When you paste multiple types of data, whatever data has been copied is pasted into the correct type of playlist. Automation data is pasted into the corresponding automation playlist. Audio or MIDI data is pasted into the audio or MIDI playlist. You do not need to set target tracks to the specific type of data being pasted for the paste to work correctly.
If all destination tracks in a multitrack paste are displayed as automation, the paste replaces any previous data on the target track without shuffling—regardless of whether you are in Slip or Shuffle mode.

**Duplicate Command**

The Duplicate command copies a selection and places it immediately after the end of the selection. Though this is similar to using Copy and Paste, Duplicate is more convenient and faster, particularly when working with data on multiple tracks.

To make more than one copy of a selection, use the Repeat command (see “Repeat Command” on page 318).

As with the Copy and Paste commands, certain rules apply when duplicating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 316.

**To duplicate a selection or region:**

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.

2. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

3. Drag with the Selector tool in the track to select the material you want to duplicate.

   – or –

   Click in the track and enter the start and end points for the selection in the Event Edit area.

4. Choose Edit > Duplicate. The material is placed immediately after the selection’s end point.

   In Shuffle mode, the duplicated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the duplicated material. In Slip mode, the duplicated material overlaps any adjacent data.

   When using Duplicate or Repeat with MIDI notes that were selected with the Time Grabber tool, material is always duplicated one measure later, and is merged with existing track material (instead of replacing).

**Duplicating Audio**

When using Duplicate (or Repeat) for audio that must fall cleanly on the beat (such as rhythmic loops), it is important that you select the audio material with the Selector tool, or by typing in the start and end points in the Event Edit area. If you select an audio region with the Time Grabber tool (or by double-clicking it with the Selector tool), the material may drift by several ticks because of sample-rounding.

If, on the other hand, you want to Duplicate (or Repeat) audio that is not bar- and beat-based, set the Time Scale to any format except Bars:Beats. This ensures that the duplicated audio material will have the correct number of samples and will be placed accordingly.
Repeat Command

The Repeat command is similar to Duplicate, but allows you to specify the number of times the selected material is duplicated.

As with the Copy and Paste commands, certain rules apply when repeating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 316.

To repeatedly paste copied data until it completely fills a selection, see “Repeat To Fill Selection” on page 316.

To repeat a selection or region:

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.
2. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
3. Drag with the Selector tool in the track to select the material you want to repeat.
   - or -
   Click in the track and enter the start and end points for the selection in the Event Edit area.
4. Choose Edit > Repeat. In the Repeat dialog, enter the number of times you want the material to repeat, then click OK.

In Shuffle mode, the repeated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the repeated material. In Slip mode, the repeated material overlaps any adjacent data.

Editing Stereo and Multichannel Tracks

Regions on individual channels within stereo and multichannel tracks cannot be independently selected. All selections for these tracks are time-based, which means that selections made with the Selector or Time Grabber tool extend to each channel in the track.

When regions in multichannel tracks are edited with any of the Trim tools or dragged with the Time Grabber tool, material on all channels is affected equally as a group.

Split Selected Tracks

To edit a specific channel within a stereo or multichannel track without affecting the other channels, you can split the track into separate mono tracks. Once the edits have been made to the separated material, you can then drag or copy it back to the original multichannel track.

To split a stereo or multichannel track:

1. Select the track you want to split by clicking its name in the Mix or Edit window. To split multiple tracks, Shift-click additional tracks.
2. Choose Track > Split Into Mono. Regions from the channels on the selected tracks are placed on new, mono audio tracks.
Names for the new tracks are based on the source track name and channel suffix. For example, if a stereo track called “Funkit” is split, two new tracks called “Funkit.L” and “Funkit.R” are created.

Output and send assignments and volume and pan settings are retained in the new tracks. Mono equivalents of stereo and multi-mono plug-in assignments are assigned in the new tracks; multichannel plug-in assignments are not assigned in the new tracks.

**Dragging Regions to and from Stereo and Multichannel Tracks**

When dragging regions to or from stereo or multichannel tracks, the following rules apply:

- Provided the number of tracks and channels are the same for the source and destination, you can drag regions between multichannel tracks and mono tracks.
- The source and destination for dragged regions can be mixed. For example, you can drag regions from a 5.0 track (containing five channels) to a stereo track and three mono audio tracks.
- When dragging multichannel regions to mono tracks, the destination tracks must be adjacent.
- When dragging regions from mono tracks to a multichannel track, the source tracks need not be adjacent.

Multichannel regions can also be dragged from the Region List, to multichannel tracks of the same format, groups of mono audio tracks, or a combination of both.

Conversely, a collection of single, mono regions can be dragged from the Region List to multichannel tracks—provided the dragged number of regions matches the number of channels in the destination track.

**Processing Audio with AudioSuite Plug-Ins**

The AudioSuite plug-ins included with your Pro Tools system can be used to process and modify an audio region or entire audio file. You may do this in order to apply a specific AudioSuite process, such as Normalization or DC Offset Removal, that you know you will always want applied to the audio.

Refer to the DigiRack Plug-Ins Guide for more information about AudioSuite plug-ins.
Waveform Repair with the Pencil Tool

The Pencil tool allows you to destructively “redraw” waveform data. This tool is most commonly used to repair a pop or click in an audio file. A pop or click appears as a sudden sharp spike in a waveform. This tool only becomes active when the Edit window is zoomed in to the sample level.

⚠️ The Pencil tool is a destructive editing tool that permanently modifies the audio file on disk and should be used with caution.

Although you can Undo a Pencil tool edit, it is recommended that you create a backup copy of the target audio, before using the Pencil tool. You can do this by using the AudioSuite Duplicate plug-in.

To make a copy of an audio region:
1. Select the source region in the track’s playlist.
2. Choose AudioSuite > Duplicate.
3. In the AudioSuite dialog, make sure that Playlist is enabled as the processing preference, and that Use In Playlist is enabled.
4. Click the Process button.

The AudioSuite Duplicate plug-in creates a new audio file that is a duplicate of the original. The duplicate replaces the original on the track, and it is automatically named with the region name and the suffix DUPL.

To destructively edit an audio waveform with the Pencil tool:
1. Locate the area you want to edit.
2. Using the Zoomer tool or the Zoom buttons, zoom down to the sample level so the waveform appears as a continuous thin line. Adjust the Track Height, as necessary, to edit the waveform with greater precision.

💡 You can recall zoom levels with the Zoom Preset buttons (see “Zooming” on page 249), or with Memory Locations (see “Memory Locations and Markers” on page 382).

3. Select the Pencil tool.
4. Carefully draw with the Pencil tool by dragging over the area of the waveform.

Do not over-edit or the results may be undesirable. You can use the Undo command to undo your previous edit.

Try to limit editing to smoothing over a very small problem area, and keep the “fixes” in character with the shape of the surrounding waveform.

💡 If you have trouble zooming in far enough to perform Pencil tool editing, check the Edit window (session) length. Shorten the overall Edit window (session) length, if possible, until the Pencil tool becomes usable.
Region Groups

A region group is a collection of any combination of audio and MIDI regions that looks and acts like a single region. Region groups can be created on a single or on multiple adjacent audio, MIDI, and Instrument tracks. Region groups let you “nest” multiple regions into “macro” regions for groove and tempo manipulation, editing, and arranging.

Region groups are essentially containers holding one or more regions. Region groups can be placed on tracks alongside standard regions, and edited using many of the same Pro Tools editing techniques. Certain edits to a region group will apply to all regions contained by the region group, such as Cut or Delete. Other edits only apply to the boundaries of the region group and do not affect the underlying regions, such as Trim.

Region groups are particularly useful for:

• Grouping tick-based audio regions that have been separated into many small regions, such as with individual hits of a drum pattern. Many such small regions can easily be created with Beat Detective or the Separate Region At Transients command, or imported as REX and ACID files.

• Grouping parts and sections to facilitate composition and arranging. For example, grouping the regions of a brass section during the chorus to copy it to the next chorus.

⚠️ Region groups are completely independent of Mix and Edit Groups.

Creating Region Groups

To create a region group:

1. Select one or more regions on one or more tracks. (For more information on multitrack region groups, see “Multitrack Region Groups” on page 323).

The size of the selection determines the size of the region group. The selection can start and end on any region boundary, empty space, or even in the middle of a region. Selections starting or ending within a region will separate the region at the selection boundary when you create a region group. Region groups created from object-based selections include all regions between the first and last selected region on the track whether they are selected or not.

2. Choose Region > Group.

The region group will appear as one region with the region groups icon in the lower left corner. Region groups also appear in the Region List.
**Region Group Timebase Format**

Region groups are created in the same timebase format (samples or ticks) as the tracks they are on. Multitrack region groups can include both sample-based and tick-based tracks.

The region group disappears, revealing all underlying regions and any nested region groups. When there are multiple nested region groups, the Ungroup command will ungroup the frontmost top-layer region group only, preserving any underlying region groups.

To ungroup a region group (and include all of its nested region groups):
1. Select a region group.
2. Choose Region > Ungroup All.

**Regrouping Regions**

The Regroup menu command undoes the last Ungroup command and regroups the individual regions back to their former region group state. This lets you ungroup a grouped region, edit its underlying regions in any way desired, and regroup it to continue working on higher-level composition and arranging.

To regroup a region group:
1. Select any region from the ungrouped region group.
2. Choose Region > Regroup.

If you used the Ungroup All command, the Regroup command recreates all previous nested region groups.

3. If you regrouped an ungrouped region group that was used more than once in the session, do one of the following when the Change All dialog opens.
   - Choose Modify to apply your changes to all other instances of the same region group.
   - or –
   - Choose Copy to create a copy and apply your changes only to the copied region group.
Multitrack Region Groups

Multitrack region groups (region groups created across multiple tracks) are useful for grouping parts, such as multi-miked drum tracks, and for composing and arranging. Multitrack region groups can be created across any combination of audio, MIDI, and Instrument tracks, and can include either or both tick-based or sample-based tracks.

Multitrack region groups work much like single-track region groups. Multitrack region groups appear as a single object across adjacent tracks.

To create a multitrack region group:

1. Select regions across multiple adjacent tracks.

2. Choose Region > Group.

Multitrack region group

Mixed multitrack region group (sample- and tick-based audio, and tick-based MIDI)

⚠️ Multitrack region groups create nested region groups of multiple regions by track before grouping them across tracks.

 وإذا The Regroup command supports multitrack region groups.
Separated Multitrack Region Groups

You can insert, move, hide, or delete tracks in multitrack region groups, but it may break the region group. A separated region group displays a break in the Region Group icon. Separated region groups will continue to function as a single region group, but the separated icon indicates that the region group displayed is somehow incomplete or separated across nonadjacent tracks.

There may be situations where you want separated region groups. For example, if you use the same accompaniment on verses one and two of a song, you can group the parts of verse one and copy them as a region group for verse two, but still have a continuous vocal track in the middle of those region groups.

If you want to delete a track and keep the region group intact, first ungroup the region group, then delete the desired track, and then Regroup the region group. The region group will be recreated intact, but without the deleted track.

Region Groups on Tick-Based Tracks

When changing tempos, region groups on tick-based tracks adjust their length by adjusting the position of all enclosed regions accordingly. This is useful for arranging rhythmic material and for playing back REX and ACID files.

Changing Region Group Timebase

The timebase format of a region group can be changed by:

- Changing the track's timebase.
- Dragging the region group to a track with a different timebase.
Changing the timebase creates a copy of the original region group. Both region groups (the original and the copy) appear in the Region List, but they have different timebases.

**Converting Samples to Ticks**

When dragging a region group from a sample-based track to a tick-based track, the length of the region group will not change. This is because region groups are converted from samples to ticks after they are moved into tick-based tracks. The length of the region group will only change with subsequent tempo changes. If possible, change the local tempo on the tick-based track to match the tempo of the sample-based region group before moving a sample-based region group to a tick-based track.

**Converting Ticks to Samples**

When dragging a region group from a tick-based track to a sample-based track, the length of the region group will not change unless it is moved to another time location with a different tempo. This is because region groups are converted from ticks to samples after they are moved into the sample-based tracks.

**Multitrack Region Groups with Sample- and Tick-based Tracks**

Multitrack region groups can include both sample-based and tick-based tracks. Changing the tempo will separate the region group between sample-based tracks and tick-based tracks.

**Editing Region Groups**

Region groups are edited in much the same way as regular regions: They can be named, moved, cut, copied, pasted, trimmed, muted, locked, and so on. However, there are a few significant differences between editing regular regions and region groups.

**Editing MIDI Region Groups**

If a MIDI region within a region group is modified in any way, a new region copy is created and placed over the region group. For example, if you record, draw in a new note, edit MIDI controller data, or Quantize a Timeline selection, a new region is created over the region group.
**Editing Audio Region Groups**

Certain audio editing commands create new regions over region groups. To use these commands and maintain the region group, ungroup the region group, perform the edit, and then regroup the region group.

The following edit commands create new regions over region groups:
- AudioSuite processing of a grouped region results in a new region over the region group.
- Consolidating a selection of a grouped region creates a new audio file and region over the region group.
- Recording into a region group creates a new audio file and region over the region group.
- Pencil tool waveform redraw results in a new region over the region group.

**Tabbing to Transients and Region Boundaries**

With Tab to Transients enabled, the Tab key moves the Location Cursor to transients and region boundaries within a region group.

With Tab to Transients disabled, the Tab key moves the Location Cursor to region group boundaries only (and the sync point, if present).

For more information on Tab to Transients, see “Tabbing to Transients” on page 283.

**Trimming Region Groups**

Trimming region groups works the same way as trimming regular regions, regardless of whether the you are trimming a single-track region group or a multitrack region group. The exception is the TCE Trim tool.

Trimming a region group does not trim the underlying regions. All underlying regions retain their length and location. This is true for all underlying audio and MIDI regions, and nested region groups. Consequently, if you trim the region group shorter, underlying regions may not be heard on playback because they are outside the region boundaries of the trimmed region group.

The TCE Trim tool applies only to audio regions, and creates a new region over any region group.

If you Ungroup after trimming a region group in (shorter), audio regions falling outside of the bounds of the current region group are trimmed to fit and removed.

**Recording**

When recording audio or MIDI, new regions are created over (in front) of region groups instead of being included in the region group. To record into a region group, first ungroup the region group, then record, and then regroup the region group. The region group will be recreated intact with the newly recorded material.
Fades and Crossfades on Region Groups

Region groups can have fades and crossfades just like regular regions. Fades only apply to audio regions. In addition to crossfading between region groups, you can also crossfade between region groups and regular audio regions.

Importing and Exporting Region Group Files

Pro Tools can export and import the new region group file format (.rgrp). You can import and export region group files to do any of the following:
- Separate region group metadata from audio files to avoid unnecessary file copy operations when exporting audio region groups composed from multiple source files
- Export MIDI data as part of a region group
- Create multitrack loops

Region group files store the following metadata:
- References to all audio files within the region group
- Region names and relative location in tracks
- Fades and crossfades
- Region group names and format (single or multitrack)
- All MIDI data present in the region group (such as notes, controllers, Sysex, and so on)
- Track names

Region group files do not store the following:
- Automation
- Plug-ins
- Track routing
- Tempo and Meter map
- Region List information

To export a region group, excluding its audio files:
1. Select one or more region groups in the Region List.
2. From the Region List pop-up menu, choose Export Region Groups. The Export Region Groups dialog opens.

Ungrouping a region group removes any region group level fades or crossfades. Fades and crossfades are restored by the Regroup command.
The Destination Directory defaults to the auto-created Region Groups folder in the session folder. You can change the Destination Directory by clicking the Choose button, navigating to the desired location, and clicking Choose. Click Reset to reset the Destination Directory to the default location.

Enable one of the following options for resolving duplicate region group file names:
- Prompting for Each Duplicate (default)
- Auto Renaming
- Replacing with New Files

Click OK.

Exporting Region Groups with Audio Files

Generally, if you are exporting region groups to another hard drive, you should copy any referenced audio files. This way you can move region groups not only from one session to another, but from one system to another.

To export a region group and include its audio files:

1. Export one or more region groups to the desired drive.
2. Create a new session on the new drive and enable the Automatically Copy Files on Import preference.
3. Import all previously exported region groups.

The audio files folder of the new session now contains all files referenced by the region groups.

Importing a Region Group

To import a region group:

- Drag and drop the region group file from a DigiBase browser or from Windows Explorer or Macintosh Finder to the Timeline, a track, the Track List, or the Region List.

Dropping a region group has the following different results depending on where you drop it:
- When dropping a region group in a track, Pro Tools checks for the matching track format, number of channels, and (in the case of multitrack region groups) if there are enough matching adjacent tracks to import the region group file. If these criteria match, the region group is imported and spotted to the drop location in the track or tracks.
- Dropping a region group on the Timeline or on the Track List creates new tracks for the imported region group.
- Dropping a region group in the Region List adds a new region group in the Region List. All audio and MIDI regions, and even other region groups, contained within the dropped region group also appear in the Region List.

Region Looping

Audio regions, MIDI regions, and region groups can all be looped using the Region > Loop and Unloop menu commands. Looping regions is an easy and powerful way to repeat a single region on a track or regions across tracks for composing and arranging. Looping regions provides more flexibility than the traditional Pro Tools Repeat and Duplicate menu commands.

Looped regions repeat the source region as many times as specified in the Region Looping dialog, or enough to fill the specified Loop Length (such as 30 seconds or until the next re-
region on the track). The source region is the original region selected for looping. Loop iterations are all looped regions following the source region. In cases where a specific number of repetitions has not been indicated, the last loop iteration will be truncated to fill to the end of the selection or specified Loop Length.

Once looped, the looped region can be edited much like a region group. For example, selecting and moving a looped region selects and moves the source region and all its loop iterations together.

Looped regions (all iterations) display a Loop icon in the lower, right corner.

Creating Looped Regions

To loop a region:
1. Select an audio or MIDI region, or region group.
   
   You can also select regions across tracks for looping.

   Selecting and looping more than one region on a track will loop only the first region in the selection.

2. Choose Region > Loop. The Region Looping dialog opens.

3. Do one of the following:
   - Select the Number of Loops option and enter the number of times to loop the region.
   - Select the Loop Length option and enter the duration according to the main time-base. If the duration is not an exact multiple of the source loop's duration, the last loop iteration will be truncated.
   - Select the Loop Until End of Session or Next Region option. The looped region will be repeated until the end of the session, or until the next region on the track. The last loop iteration will be truncated to fit.

   Looping a region does not loop any automation associated with the source region.

   Use the Copy Special and Paste Special Repeat To Fill Selection commands to copy automation for the source loop to all loop iterations (see “Automation and Looped Regions” on page 332).
4 If desired, select the Enable Crossfade option. This will create a crossfade at the loop point. To edit the loop crossfade:
   - Click the Settings button.
   - Configure the Loop Crossfades.
   - Click OK.

2 Choose Region > Unloop. The Unloop Regions dialog opens.

3 Do one of the following:
   - Click Remove to unloop and remove all loop iterations except the first full loop iteration.
   - Click Flatten to unloop and create individual regions from each loop iteration.

Region Ungroup functions on loops the same as using the Unloop command and choosing Flatten.

To unloop and ungroup a selection down to its individual regions:
1 Select a looped region that contains one or more region groups.
2 Choose Region > Ungroup All.

Unlooping and Flattening Loop Regions with Separate Regions Menu Commands
The Separate Regions commands (At Selection, On Grid, and At Transients) will automatically unloop and flatten looped regions before separating.
**Editing Looped Regions**

Looped regions can be edited as a group or as individual regions. For example, selecting a looped region with the Grabber tool will select the entire loop (the source region and all its loop iterations), but clicking the Loop icon of one of the loop iterations will select only that one iteration.

Moving a looped region moves the source region and all its looped aliases together as a group. Loop iterations cannot be moved independent of their source region. If you move or paste another shorter region over of a looped region the loop is continued after the new region. The parts of a separated looped region can be adjusted independently.

**To select a looped region as a group, do one of the following:**

- With the Grabber tool or Smart Tool, single-click the looped region.
  - or –
- With the Selector tool, double-click the looped region.

The source region and all its loop iteration will be selected.

**To select an individual source region or loop iteration, do one of the following:**

- With the Grabber tool or Smart Tool, single-click the Loop icon of the source region or loop iteration.
  - or –
- With the Selector tool, single click the Looped Region icon and drag to the left until the region is selected.

**Tabbing to Transients and Region Boundaries**

Tab to Transients tabs to transients and region boundaries in a looped region. Normal Tab (Tab to Transients disabled) tabs to the start and end boundaries of the entire looped region.

**Trimming Looped Regions**

Trimming looped regions can be done using the Trim tool, the Loop Trimmer, or one of the Trim Region commands. The Trim tool trims the entire looped region. The Loop Trimmer provides the most unique feature of loop editing and trims the duration of the individual loop iteration while filling the total length of the looped region.

**To trim a looped region as a group:**

1. Select the Standard or Scrub Trim tool.
2. Trim the start or end of the looped region as desired.

**Trimming a looped region with the Standard Trim tool**

- Hold down the Start key on Windows, or the Control key on Macintosh, while trimming to trim in loop iteration increments.

- **Trimming a loop does not trim any underlying Fades.**

- **The TCE Trimmer unloops and consolidates the looped region.**
To trim a looped region using the Loop Trimmer:

1. Select the Standard or Scrub Trim tool.
2. Move the cursor over a Loop icon in the looped region. The cursor changes to the Loop Trimmer icon.
3. Trim the start or end of the loop iteration as desired.

The number of repetitions of the trimmed loop increases or decreases to fill the length of the entire looped region.

To trim a looped region to selection:

1. Use the Selector tool to make an Edit selection including some or all of the looped region.
2. Choose Edit > Trim Region and one of the Trim Region commands (To Selection, To Fill Selection, Start to Fill Selection, End to Fill Selection).

If the source region is extended to the left using the Trimmer tool for the total length of the loop, the source region is moved earlier in the Timeline and loop iterations fill in up to the point where the last original loop iteration ended. If the trim to the left is part of the source region’s length, the source region is not moved and a partial loop iteration is created to the left of the source region. This is a powerful feature that lets you make quick changes to your arrangement by using partial loops as upbeats, or by extending looped sound effects or ambience earlier in a film score.

Automation and Looped Regions

Looping an audio region does not loop any automation associated with the source region. This is useful in that automation can be applied across an entire looped region. For example, you may want to have a long fade across part or all of looped region.

You can also repeat automation on individual loops. For looped audio regions, use the Copy Special and Paste Special Repeat to Fill Selection commands to copy and paste any or all automation data from the source region to some or all of its loop iterations.

To copy and paste automation from the source region to loop iterations:

1. Select the source region.
2. Choose Edit > Copy Special and one of the Copy Special commands (All Automation, Pan Automation, Plug-In Automation), depending on what automation you want to copy.
3. Select the looped region.
4. Choose Edit > Paste Special > Repeat to Fill Selection.
Chapter 18: Fades and Crossfades

Using Crossfades

You can quickly and easily crossfade between two adjacent audio regions. Crossfading is the process of fading two regions of audio to prevent pops, clicks, or sudden changes in sound. Crossfades have many applications, from smoothing transitions between regions to creating special audio effects. The crossfade duration, position, and shape are all user-definable.

Crossfades are computed and written to disk. Crossfades that are written to disk are stored in a folder named “Fade Files” within the session folder. When you play back your track, Pro Tools reads and plays back the crossfade file from disk.

Pro Tools does not allow you to replace fade-ins and fade-outs with crossfades. To add a crossfade between regions, any existing fade-ins and fade-outs between the regions must first be deleted.

About Crossfades and Curves

To create a crossfade between two regions, use the Selector tool to select across the end point of the first region and the start point of the second. The length of the selection determines the length of the crossfade. Though fades may appear to be discrete regions, they cannot actually be separated from the regions in which they were created. You can, however, create fade-ins and fade-outs for individual regions (see “Creating Fades at the Beginnings and Ends of Regions” on page 341).

You can use the Fades dialog to select, view, and manipulate the curves used to perform the crossfade. Different volume curves can be assigned to the fade-out and fade-in portions of crossfades. The Fades dialog can also render a preview of the fade.

The following examples illustrate common crossfade types, and explain how the type of selection you make determines the character of the crossfade.

Pro Tools HD includes an AutoFade feature that provides real-time fades without processing them to disk. See “Using AutoFades” on page 343.

Since crossfades are created by fading between overlapping audio material, a crossfade cannot be performed on regions that do not contain audio material beyond their region boundaries.
Standard Crossfade (Centered)

This type of selection creates a crossfade on both sides of the splice point, which affects the volume of region 1 and region 2. It is the most common type of crossfade.

This crossfade type requires that region 1 contain audio material beyond its end point, and region 2 contain audio material before its start point.

Pre Crossfade

This type of selection creates a crossfade before the splice point. This lets you maintain the volume of the very beginning of region 2 instead of fading across it, which is useful if there is a strong attack at the beginning of region 2 that you want to preserve. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

Post Crossfade

This type of selection creates a crossfade after the splice point. It is useful if you want to maintain the amplitude of region 1 until its very end. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 1 contain audio material beyond its end point.
The Fades Dialog

When choosing the Edit > Fades command you can use the Fades dialog to select, view, and preview the crossfade, and to edit the curves used to perform the crossfade.

Fades dialog

The controls in the Fades dialog include:

**Audition**

Click this button to audition your crossfade. Pro Tools supports crossfade auditioning directly from your audio interface outputs.

**View First Track**

If you are fading between more than one track, this button allows you to view and preview the audio of the first pair of adjacent tracks.

**View Second Track**

If you are fading between more than one track this button allows you to view and preview the audio of the second pair of adjacent tracks.

**View Both Tracks**

Click this button to display the waveforms of the first two adjacent tracks in a multitrack fade.

**Fade Curves Only**

Click this button to display the specified fade curves without showing the actual audio waveforms. This is the default view when you open the Fades dialog.

**Fade Curves and Separate Waveforms**

Click this button to display the specified fade curves along with separate views of the fade-in and fade-out waveforms.

**Fade Curves and Superimposed Waveforms**

Click this button to display the specified fade curves along with superimposed views of the fade-in and fade-out waveforms.

**Fade Curves and Summed Waveform**

Click this button to display the specified fade curves along with a single waveform representing the summation of the crossfaded audio.
Zoom In

Click this button to scale the view of the waveform’s amplitude upwards. Control-click (Windows) or Command-click (Macintosh) for the default view scale.

Zoom Out

Click this button to scale the view of the waveform’s amplitude downwards. Control-click (Windows) or Command-click (Macintosh) for the default view scale.

Fade Out Shape Setting

The Out Shape setting allows you to choose the shape of the fade-out from region 1.

Standard Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

S-Curve Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade out faster at the curve’s start and slower at its end, for example. S-shaped curves can be useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

Preset Curves Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- Preset Curve 1 keeps region 1 at full volume throughout the crossfade, then immediately drops the volume at the end of the crossfade.

- Preset Curve 2 fades out region 1 relatively slowly, keeping the volume fairly high throughout the duration of the fade.

- Preset Curve 3 fades out region 1 slightly faster, keeping the volume slightly lower during the fade.

- Preset Curve 4 fades out region 1 with a linear fade. This is the default curve.

- Preset Curve 5 fades out region 1 quickly at the beginning of the crossfade.
Preset Curve 6 drops the volume of region 1 even more quickly at the beginning of the cross-fade.

Preset Curve 7 silences region 1 at the beginning of the crossfade.

### Link Settings

The Link setting links the selected fade-out and fade-in curves. If you adjust one curve, the corresponding curve also adjusts. This ensures that the resulting crossfade is an equal power or equal gain crossfade, depending on which you select.

- **Equal Power** Recommended for material that is not phase coherent, as in the case of a crossfade between two completely different types of material. Use this option to avoid the volume drop that can occur with an Equal Gain crossfade. With this fade, you can Alt-click (Windows) or Option-click (Macintosh) the fade curve to reset it to its default shape.

- **Equal Gain** Recommended for material that is phase-coherent or nearly phase-coherent, as in the case of a crossfade between identical regions/instruments (for example, a repeated drum loop). Use this option to avoid clipping that can occur when using an Equal Power crossfade. With this fade, you can Alt-click (Windows) or Option-click (Macintosh) the fade curve to reset it to its default shape.

- **None** Disables linking between the fade-out and fade-in curves, and lets you freely adjust them separately, including start and end points. This option also allows you to create custom crossfade shapes. To edit only the fade-in portion of the curve, press Alt (Windows) or Option (Macintosh) while dragging. To edit only the fade-out portion of the curve, press Control (Windows) or Command (Macintosh) while dragging.

### Use Dither

The Use Dither option turns on a preset, noise-shaped dither function that improves audio performance when fading in or fading out of silence, and crossfading between low amplitude regions. Dithering is usually not necessary when fading between two regions of high amplitude. You can disable Dither while editing your crossfades in the Fades dialog to speed up previews and fade recalculation, then re-enable Dither to create the final crossfade.
**Fade In Shape Settings**

The In Shape setting allows you to choose the shape of the fade-in to region 2.

**Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

**S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade in faster at the start of the curve, and slower at the end. S-shaped curves are useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

**Preset Curves** Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- Preset Curve 1 fades in region 2 at full volume immediately at the beginning of the crossfade and keeps it there throughout the crossfade.

- Preset Curve 2 fades in region 2 quickly in the beginning, reaching full amplitude fairly early in the crossfade.

- Preset Curve 3 fades in region 2 moderately fast.

- Preset Curve 4 fades in region 2 with a linear fade curve. This is the default curve.

- Preset Curve 5 fades in region 2 slowly at the beginning of the crossfade.

- Preset Curve 6 fades in region 2 even more slowly than the previous curve.

- Preset Curve 7 silences region 2 until the end of the crossfade.
Typical Curve Combinations

Following are the available combinations of fade-out and fade-in curves.

**Linear Crossfade** This is a good general purpose crossfade with a smooth, even transition between region 1 and region 2.

**Equal Power Crossfade** This is a good general purpose crossfade useful in cases where a linear crossfade seems to create a noticeable drop in volume across the splice point.

**Overlap Fade** This combination of curves keeps both regions at full amplitude throughout the crossfade: region 2 “jumps in” at the beginning and region 1 “jumps out” at the end.

Fade and Crossfade Preferences

*(Pro Tools HD Only)*

You can set default fade and crossfade settings. These settings load as your “base” settings when you use the Create Fades command, and the Fade to Start and Fade to End commands.

**To set the crossfade preferences:**

1. Choose Setup > Preferences and click the Editing tab.
2. Set the Pre-Roll and Post-Roll times for Fade previews.
3. Click Fade In and set the default shape for fade-ins, then click OK.
4. Click Fade Out and set the default shape for fade-outs, then click OK.
5. Click Crossfade and set the default shape for crossfades, then click OK.
6. Click Done.
Creating a Crossfade

To create a crossfade between two regions:

1. With the Selector tool, click at the point where you want the crossfade to begin in the first region and drag to where you want it to end in the second region. Crossfade selections can begin and end anywhere in their respective regions.

2. Choose Edit > Fades > Create.
   – or –
   Press Control+F (Windows) or Command+F (Macintosh).

3. Use the view buttons to adjust the view of the crossfade. It may take a few moments to calculate the waveform display for long selections.

4. Select an Out Shape and an In Shape.

5. Choose a Linking option.

6. Click the Audition button, or play the session, to hear the crossfade. For long crossfades, it may take Pro Tools a few moments to calculate and load the audio into playback RAM.

7. Adjust the curves by choosing different preset shapes with the Out Shape and In Shape pop-up menus.
   – or –
   Drag the Fade In/Out curves to a custom shape. By choosing None as the Linking option, you can drag the beginning or end points of a fade curve to adjust its beginning or end point.

8. Click the Audition button, or play the session, to hear the crossfade again.

9. When the crossfade is right, click OK. The fade is calculated and written to disk, but the audio files and regions remain unchanged. Crossfades are stored in the Fades Folder within the session folder.

Crossfade lengths can later be resized with any of the Trim tools.

To remove a crossfade:

- Select the area of the track containing the crossfades you want to delete and choose Edit > Fades > Delete.
   – or –
- Select the crossfade with the Time Grabber tool and press Backspace (Windows) or Delete (Macintosh).

To trim a crossfade:

1. Select the crossfade with the Time Grabber tool, or double-click it with the Selector tool.

2. With any of the Trim tools, trim either side of the crossfade. The crossfade is recalculated to reflect the newly trimmed length.

Crossfades On Tick-Based Audio Tracks

Crossfades are re-rendered after changing tempo in a tick-based audio track. The new crossfade is the same length as the crossfade prior to the tempo change.

If there is not enough audio material to complete the crossfade, or if the new crossfade area falls outside of valid region boundaries, the crossfade is removed.
Pre and Post Crossfade Selections

By making a selection that begins or ends precisely on the border of two regions, you can create “pre” or “post” crossfades. Use the Tab key to place the insertion point at the exact beginning or end of a region.

To create a pre- or post-crossfade:

1. With the Selector tool, click in the track that contains the regions you want to crossfade.
2. Press Tab to move forward to the next region boundary.
   – or –
   Press Control+Tab (Windows) or Option+Tab (Macintosh) to move back to the previous region boundary.
3. Shift-drag to adjust your selection, or press Shift+Tab to extend the selection forward to the next region boundary.
   – or –
   Press Control+Shift+Tab (Windows) or Option+Shift+Tab (Macintosh) to extend the selection back to the previous region boundary.
4. Choose Edit > Fades > Create.
   – or –
   Press Control+F (Windows) or Command+F (Macintosh).
5. Choose a fade type and click OK.

Creating Fades at the Beginnings and Ends of Regions

In addition to crossfades between regions, Pro Tools lets you create fade-ins and fade-outs at the beginnings and ends of regions.

With Pro Tools HD, you can also use an automatic fade-in/out option, which applies real time fade-ins/outs to all regions during playback. These fades are not written to disk, but automatically applied during playback. See “Using AutoFades” on page 343.

Creating Fade-Ins and Fade-Outs

Depending on how you make the selection, you can position a fade-in/out at the exact beginning or end of a region, or position it so it extends into a blank area of the track. The length of the selection in the region determines the length of the fade-in/out.

You can also fade to the beginning or end of a region from an insertion point.

Although fades appear to be discrete regions, fades cannot be separated from the regions in which they were created.

When changing tempo in a tick-based audio track, fade-ins and fade-outs remain with their parent regions, and are unaffected by changes in tempo.
To create a fade-in:

1. Select the beginning of the region that you want to fade in. The selection must extend to the exact beginning of the region or a blank area prior to the region in the track.

2. Choose Edit > Fades > Create.
   
   – or –

   Press Control+F (Windows) or Command+F (Macintosh).

3. Choose the fade-in curve and other settings.

4. Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).

5. You can adjust the curve by dragging it or by choosing a different shape with the In Shape pop-up menu.

6. When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

To create a fade-out:

1. Select the end of the region that you want to fade out. The selection must extend to the exact end of the region or a blank area after the region in the track.

2. Choose Edit > Fades > Create.
   
   – or –

   Press Control+F (Windows) or Command+F (Macintosh).

3. Choose the fade-out curve and other settings.

4. Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).

5. You can adjust the curve by dragging it or by choosing a different shape with the Out Shape pop-up menu.

6. When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

Fade lengths can later be resized with any of the Trim tools.

To fade from the insertion point to a region start point:

1. Place the cursor at a location in the region.

2. Choose Edit > Fades > Fade To Start.

   – or –

   Press Alt+D (Windows) or Control+D (Macintosh).

The fade is applied based on the Fade In preferences.

To fade from the insertion point to a region end point:

1. Place the cursor at a location in the region.

2. Choose Edit > Fades > Fade To End.

   – or –

   Press Alt+G (Windows) or Control+G (Macintosh).

The fade is applied based on the Fade Out preferences.
Using AutoFades
(Pro Tools HD Only)

With Pro Tools HD, you can choose to have Pro Tools automatically apply real-time fade-ins and fade-outs to all region boundaries in the session. These fade-ins and fade-outs are performed during playback and do not appear in the Edit window, and are not written to disk.

This automatic fade-in/out option also has an effect on Voice borrowing in a session. Whenever a lower-priority virtual track “pops thru” a silence in a higher-priority track on the same voice, a fade-in and fade-out is applied to the transition.

This feature is especially useful in post production situations such as dialogue tracking. For example, you could assign both a dialogue track and a “room tone” track with matching background to the same voice. You could then set the AutoFade option to a moderate length (4 ms or so) so that whenever a silence occurred in the dialog, playback would switch smoothly to and from the background track without clicks or pops.

Using automatic fade-ins/outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. However, since these autofades are not written to disk, those clicks or pops still exist in the underlying sound file. Consequently, those anomalies still appear if the Duplicate AudioSuite plug-in or the Export Selected as Sound Files command (from the Region List) are used to duplicate multiple regions as a continuous file. To render these real-time auto fades to disk, choose File > Bounce to > Disk.

To set the length of automatic fade-ins/outs:

1. Choose Setup > Preferences and click the Operation tab.
2. Enter a value between 0 and 10 ms for the Auto Region Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur.
3. Click Done. The AutoFade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

Creating Fades and Crossfades in Batches

In “Batch mode” you can create many fades at once. You select across several regions and use the Create Fades command to create crossfades for each region transition. If your selection includes regions that already have crossfades, this feature allows you to modify them.

To create crossfades between multiple regions at once:

1. With the Selector tool, click in the first region in which you want to create a crossfade.
2. Drag to extend the selection to the last region you want to crossfade. Make sure that the selection includes the entire region.
3. Choose Edit > Fades > Create.

Selected regions for Batch Fades

Press Control+F (Windows) or Command+F (Macintosh).
4 Select whether you want to Create New Fades, Create New Fade-Ins & Outs, Adjust Existing Fades, or a combination of these options.

If you select to create new fades and new fade-ins and outs, new crossfades are created at each region boundary that is bordered by another selected region, a fade-in is created at the start of the first region, and a fade-out is created at the end of the last region.

5 Choose the placement of your Fades. You can choose Pre-Splice, Centered, or Post-Splice.

6 Enter a crossfade length in milliseconds.

7 Click OK. Pro Tools creates the fades for the selected regions.

* Fade lengths can later be resized with any of the Trim tools.*
Managing the regions in a session lets you keep system and storage requirements to a minimum, and simplify archiving requirements. This chapter describe several tools available to manage files and regions in Pro Tools sessions.

For more information on file management see the DigiBase Guide.

### Stripping Silence from Regions

The Strip Silence command analyzes audio selections—across multiple regions or multiple tracks—and removes (or extracts) any areas of silence, dividing the selection into smaller regions and removing the silent areas.

You can use Strip Silence to automatically divide a track into regions, which is useful if you want to quantize audio to musical values, or locate sound effects to SMPTE locations. It is also useful if you want to get rid of silent areas to prepare for compacting audio (see “Compacting an Audio File” on page 349).

### The Strip Silence Window

The Strip Silence window contains the following controls that let you set the parameters by which silence will be defined when using the Strip Silence command. Adjusting these controls will cause rectangles to appear in the selection (see Figure 14 on page 346), indicating areas of silence that will be removed.

- **Strip Threshold** Sets the amplitude threshold (from –48 dB to 0 dB) for Strip Silence. Audio falling below this threshold is considered silence and removed. Audio above the threshold is retained and defined as new regions.

- **Minimum Strip Duration** Sets the minimum duration (from 0 to 10,000 ms) that the material below the threshold must last to be considered silence. Use this control to avoid countless small regions that may occur within a selection.

- **Region Start Pad** Specifies a time value to be added to the beginning of each new region created with Strip Silence. This is useful for preserving musical material that falls below the threshold, such as the breath before a vocal phrase, or the finger slide before a guitar chord.

- **Region End Pad** Specifies a time value to be appended to the end of each new region created with Strip Silence, thereby preserving the nuances in the decay of the material.
**Extract** Extracts audio and leaves the silent portions of the track (in other words, an “inverse” strip silence feature that is ideal for generating room tone or ambience to use elsewhere).

**Separate** Separates regions based on the boundaries detected by Strip Silence.

### Auto-Naming for Strip Silence

The Rename button in the Strip Silence window opens the Rename Selected Regions dialog, which determines how regions are named with the Strip Silence command. The dialog remembers your previous settings, which can be cleared by clicking the Clear button.

The names generated for regions created by Strip Silence would be:
- SFX023.Reel1
- SFX024.Reel1
- SFX025.Reel1
- SFX026.Reel1
- SFX027.Reel1
- SFX028.Reel1

### Using Strip Silence

#### To strip silence from an audio selection:

1. Select one or more audio regions.
2. Choose Edit > Strip Silence.
3. To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 346.
4. In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.

For finer resolution on these sliders, press Control (Windows) or Command (Macintosh) while adjusting them.

![Rename Selected Regions dialog](image)

**Rename Selected Regions**

**Name** Specifies the base name for regions created with Strip Silence.

**Number** Specifies the number at which sequential auto-numbering starts.

**Zeros** Specifies the number of zeroes that occur before the appended auto numbers.

**Suffix** Specifies text appended to the end of the name, after the auto numbering.

For example, if you set these naming options to:
- Name = SFX
- Auto Number Start = 23
- Leading Zeros = 1
- Suffix = .Reel1

![Strip Silence rectangles](image)

**Figure 14. Strip Silence rectangles**
To retain material before and after the new regions, adjust the sliders for Region Start Pad and Region End Pad.

Once the Strip Silence rectangles encompass the audio that you want to keep, press the Strip button.

The material defined as silence is removed from the selection and new regions are created, which also appear in the Region List.

The Strip Silence command is nondestructive and does not remove audio data from parent audio files. In addition to the Undo command, you can use the Heal Separation command to restore stripped material.

Strip Silence works with stereo and multi-channel tracks, and keeps their audio regions phase-coherent.

To separate regions using Strip Silence:

1. Make an Edit or Time selection.
2. Choose Edit > Strip Silence.
3. To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 346.
4. In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.
5. Click the Separate button.

New regions are created based on the boundaries detected by Strip Silence.

**Inserting Silence**

The Insert Silence command is a simple and convenient way to insert silence in sessions. This command allows you to make a selection on a track (or tracks) and insert precisely that amount of silence. In Shuffle mode, all data on the track is shuffled later in the track by an amount equal to the selection.

To extract audio from an audio selection using Strip Silence:

1. Make and Edit or Time selection.
2. Choose Edit > Strip Silence.
3. To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 346.
In Grid mode, the Insert Silence command works just like the Edit > Clear command.

**Shuffle Mode** When inserting silence on multiple tracks in Shuffle mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected duration of silence is inserted into the audio or MIDI data and all underlying automation data on all selected tracks. All subsequent regions are shuffled by the amount of silence inserted. On MIDI tracks, only notes that are selected from the beginning are affected, so if you have selected the tail of a note and you Insert Silence, the note will remain unchanged.
- If all selected tracks are displayed as automation data, the selected range is cleared of automation data only of the type visible on each track. Regions are not shuffled. Instead, a blank gap appears equal to the length of the selection.
- If all selected tracks are displayed as automation data, press the Start key (Windows) or Control (Macintosh) while choosing the Insert Silence command to inserts silence on all automation playlists for all selected tracks. Regions are not shuffled.

**Slip Mode** When inserting silence on multiple tracks in Slip mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected range is cleared of audio or MIDI data and all underlying automation data on all selected tracks.
- If all selected tracks are displayed as automation data, press the Start key (Windows) or Control (Macintosh) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.
- If all selected tracks are displayed as automation data, press the Start key (Windows) or Control (Macintosh) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

**To insert silence into a track:**

1. Make a selection in a track or tracks. The length of the selection determines the duration of the silence inserted.
2. Choose Edit > Insert Silence.

For Shuffle mode, Pro Tools inserts the selected amount of silence. In the process, it splits the regions at the beginning of the insertion point, and moves the new regions later in the track by an amount equal to the length of the selection.

**Consolidate Command**

During the course of normal edit operations, a track may eventually contain many regions. However, once a track or track range (such as a verse or chorus) reaches a satisfactory state, you may want to consolidate its regions into a single region—thus making the material much more easy to work with.

When consolidating an audio track, a new audio file is written that encompasses the selection range, including any blank space.

**Consolidating an audio track does not consolidate underlying automation data. To create a single file with automation data applied to the audio, use Bounce to Disk (see “Bounce to Disk” on page 574).**

**To consolidate regions within a track:**

1. Using the Time Grabber or Selector tool, select the regions you want to consolidate.
2. Choose Edit > Consolidate.

To select all regions in a track, triple-click in its playlist with the Selector tool.
A new, single region is created that replaces the previously selected regions, including any blank space. If working with an audio track, a new audio file is written (with the Audio Suite Duplicate plug-in).

When consolidating audio regions with the Consolidate command, if the selection contains muted regions, the muted regions are treated as silence. Whether or not a track is muted, or contains Mute automation, does not affect the Consolidate command.

---

**Compacting an Audio File**

The Compact Selected command deletes unused portions of audio files to conserve disk space, and to prepare for cleaner hard drive back-ups. The Compact Selected command also deletes audio if there are no regions referencing the data.

Because it permanently deletes audio data, the Compact Selected command should be used only after you have completely finished your editing and are sure that you have no further use for the unused audio data.

The Compact Selected command can pad the regions of the compacted file by a user-selectable amount. You may want to do this because Pro Tools requires extra audio data before and after audio regions to create crossfades. So, if your regions have crossfades, or if you want to pad the regions for the sake of any future trimming, you should enter an appropriate amount of padding (in milliseconds) to allow for this.

⚠️ *The Compact Selected command is destructive and cannot be undone. It permanently alters the original audio files. There is no way to recover data deleted with this command.*

---

**To compact an audio file:**

1. From the Region List pop-up menu, choose Select > Unused. All regions that have not been placed in a track in the current session are highlighted in the Region List.

2. To remove all of these unused audio regions, choose Clear Selected from the Region List pop-up menu. When the dialog appears, choose Remove.

3. In the Region List, select the region or regions you want to compact.

4. From the Region List pop-up menu, choose Compact Selected.

5. Enter the amount of padding in milliseconds that you want to leave around each region in the file.

6. Click Compact to compact the file or Cancel to cancel the command.

Once the Compact operation has been completed, the session is automatically saved.
Naming and Displaying Regions

A typical session can become quite busy with many tracks and dozens of regions. There are a number of things you can do, however, to keep track of and manage a session’s regions, which include:

- Renaming existing regions
- Specifying how auto-created regions are named
- Hiding auto-created regions
- Removing unused regions

Renaming Regions

In the course of a session you can rename regions to give them more descriptive names, or merely to shorten or simplify an existing name. When renaming a region that was auto-created from an edit, the region becomes a user-defined region and is displayed in the Region List when auto-created regions are hidden.

Perhaps the easiest way to rename a region, if it resides in a track, is to double-click it with one of the Grabber tools. However, if the region does not yet reside in a track, or if you want to rename several regions, use the Rename command in the Region List.

You can also rename a region in a track using the Rename command in the Region List pop-up menu.

To rename one or more regions:

1. If you will be renaming an auto-created region, be sure to choose Show > Auto-Created in the Region List.
2. Select one or more regions to be renamed in the Region List.

   *If the Editing preference for “Region List Selection Follows Edit Selection” is enabled, you can highlight a region in the Region List by selecting it in a track.*

3. Choose Rename from the Region List pop-up menu.
4. When prompted, enter a new name for the region. If a whole-file audio region was selected, specify whether to rename just the region, or both the region and the disk file.

5. Click OK to rename the region. If renaming multiple regions, you are prompted, successively, to rename each region.
Auto-Naming Options

You can specify the auto-naming options for a region when new regions are created from it in the course of editing.

Auto-naming of regions does not affect the names of parent audio files. Instead, it stores pointers to the regions within the parent source file.

To set auto-naming options for a region:

1. Select a region in the Region List.
2. Choose Auto Rename from the Region List pop-up menu.
3. In the Rename Regions dialog, enter the text to be used when naming regions created from the selected region.

   Rename Regions Selected dialog

   Name Determines the root name for the auto-created regions.
   Number Sets the start number for the sequentially numbered new regions.
   Zeros Determines the number of zeros that occur before the auto numbers.
   Suffix Specifies text to be appended to the end of the name, following the auto numbering.
4. When you are finished, click OK to accept the new naming options.

Hiding and Removing Unwanted Regions

In the course of editing a session, the Region List can fill up quickly with regions—one you have created purposely and those that are automatically created by cutting, pasting, and separating other regions, or importing REX, ACID, or Region Group files. Pro Tools allows you to hide or remove regions in your session so you do not have to scroll through an unnecessarily long Region List.

Hiding Auto-Created Regions

You can hide regions that were automatically created during the course of editing.

To hide auto-created regions:

- In the Region List, deselect Show > Auto-Created. With this option deselected, only user-defined regions appear in the Region List.

User-defined regions include:
- Whole-file regions
- Regions created during recording
- Imported regions
- Renamed regions
- Regions created as a result of AudioSuite processing
- New regions created with the Region > Capture command or the Edit > Separate Region commands
- Regions created by trimming whole-file audio regions
When auto-created regions are hidden, Pro Tools warns you if the number of auto-created regions exceeds a certain threshold, and gives you the option of deleting them. If you choose to delete them, all auto-created regions are deleted at the same time.

To ensure that you keep a particular auto-created region, turn it into a user-created region by renaming it. For details, see “Renaming Regions” on page 350.

**Removing Unwanted Regions**

In the Region List, you can select unwanted regions and then use the Clear command to remove them from the session, whole-file regions can also be removed permanently from your hard drive.

> The Clear command cannot be undone.

**To find and remove unused regions in a session:**

1. Do one of the following:
   - For MIDI regions, from the Region List pop-up menu, choose Select > Unused.
   - or –
   - For audio regions, from the Region List, choose Select, then choose one of the following:
     - Unused
     - Unused Except Whole Files
     - Offline

2. After all unused regions are selected, choose Clear from the Region List pop-up menu.

3. Click Remove to remove the unused regions from the session.

   or –

If clearing a whole-file audio region and you want to permanently remove the audio file from your hard drive, click Delete.

**Clear Selected dialog (audio regions)**

When deleting audio files for multiple regions, Pro Tools presents a warning dialog for each audio file.

**To bypass repeated warning dialogs:**

- Alt-click (Windows) or Option-click (Macintosh) the Delete button in the Clear dialog. This permanently deletes each successive audio file from your hard drive (for each of the unused regions) without any further warnings.

Use this “power delete mode” with caution, since deletion of these files cannot be undone.
Chapter 20: Conductor Tracks and Memory Locations

In Pro Tools, tempo and meter changes reside in Conductor tracks. Tempo and meter events affect the timing of tick-based tracks, and also provide the tempo and meter map for the Bar|Beat grid. You can edit tempo events in the Tempo ruler or Tempo Editor, and meter events in the Meter ruler. Memory locations provide a powerful way to navigate your session while editing and arranging.

Song Start Marker

The Song Start Marker defines the initial tempo for Bar|Beat-based material. New sessions open with a default tempo of 120 BPM.

To move the Song Start Marker by dragging:

- In the Tempo ruler, drag the Song Start Marker left or right.

Dragging the Song Start Marker

If the Edit mode is set to Grid, the Song Start Marker moves in increments of the current Grid value.

To edit the initial tempo in the Song Start Marker:

1. In the Tempo ruler, double-click the Song Start Marker.
2. In the Change Tempo dialog, enter a new BPM value.
3. Click OK.
When a new session is created, the Song Start Marker has no associated meter event. A meter event is added automatically at the Song Start if you add another meter event anywhere else on the Meter ruler.

### Tempo

The Tempo ruler lets you edit tempo events one at a time. You can edit tempo visually in the Tempo Editor, or make precise changes in tempo in the Tempo Operations window.

- To set the default session tempo, see “Setting the Default Meter and Tempo” on page 166.

- You can use Beat Detective to generate Bar|Beat markers (tempo map). For more information, see “Generating Bar|Beat Markers with Beat Detective” on page 401.

### Tempo Events

Tempo events can be assigned to the Song Start Marker to replace the default tempo (of 120 BPM), and they can be inserted anywhere else within the session.

- Tempo cannot be modified when you are in Manual Tempo mode.

#### To display the Tempo ruler:

- Select View > Rulers > Tempo.

When in Manual Tempo mode, the Tempo track is ignored and the session plays at the tempo defined in the Transport window. For details, see “Using Manual Tempo Mode” on page 168.

### Current Tempo

As tempo events are encountered during playback, the session’s current tempo is displayed in the Transport window.

### Inserting Tempo Events

#### To insert a tempo event:

1. Click in the Tempo ruler where you want to insert the tempo event.

2. Click the Add Tempo Change button at the left of the Tempo ruler.

3. In the Tempo Change window, enter the Location and BPM value for the tempo change.

- Select the Snap To Bar option to place the inserted tempo event cleanly on the first beat of the nearest measure.
4 To base the BPM value on something other than the default quarter note, select a different note value.

5 Click Ok. The new tempo event is inserted and appears in the Tempo ruler.

Each tempo event has a small green triangle next to it that indicates its location. These triangles can be dragged to move the tempo event, and they can be double-clicked to edit the tempo event.

Editing and Moving Tempo Events

Existing tempo events can be moved, edited, deleted, and copied and pasted.

To move a tempo event by dragging:
- In the Tempo ruler, drag the triangle for the tempo event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the current Grid value.

To edit a tempo event:
1 In the Tempo ruler, double-click the tempo event.

2 In the Tempo Change window, enter a new Location or BPM value for the tempo event.

3 Click OK.

To delete a tempo event:
- While pressing Alt (Windows) or Option (Macintosh), move the cursor over the tempo event (where the cursor changes to a Grabber with a “–”) and click to remove it.

To copy and paste several tempo events:
1 With the Selector tool, click and drag in the Tempo ruler to select the range of measures that includes the tempo events.

2 Choose Edit > Copy.

3 Click in the Tempo ruler at the point where you want to paste the tempo events.

4 Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing tempo events.

To extend an Edit selection in a track to the Tempo ruler:
1 With the Selector or Time Grabber tool, select a time range.

2 Shift-click in the Tempo ruler.

To select all tempo events:
- Double-click with the Selector tool in the Tempo ruler.
To clear a range of selected tempo events:
1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in the Tempo ruler to select the tempo events you want to remove.
3. Choose Edit > Clear to delete the selected tempo events.

Tap Tempo
You can manually set the tempo for a Pro Tools session by tapping on your computer keyboard. You can also use a connected MIDI keyboard to tap tempo.

To set the Manual Tempo by tapping on a computer keyboard:
1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.
3. Click in the Tempo field so it becomes highlighted and tap the “T” key on your computer keyboard repeatedly at the new tempo.

You can apply the new tempo to the entire session by changing the default tempo of the Song Start Marker. See “Song Start Marker” on page 353.

To set the Manual Tempo by tapping on an external MIDI keyboard:
1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. Choose Setup > Preferences and click the MIDI tab.
3. Select Use MIDI To Tap Tempo
4. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.
5. Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the new tempo on your MIDI keyboard controller.

To compute the new tempo, Pro Tools averages the last eight (or fewer) taps to determine the correct tempo. The computed BPM value appears in the Transport’s Tempo field.
**Tempo Changes and Automation Drift**

When an audio track is sample-based, the track's automation playlist is unaffected by changes in tempo.

When an audio track is tick-based, however, the automation breakpoints change to match the changes in tempo.

Since the length of each audio region in a track is unaffected by changes in tempo, existing automation data is out of sync with the audio after a tempo change is made to a tick-based audio track.

**Minimizing Automation Drift**

In general, automation drift is more pronounced with larger audio regions. By creating many small audio regions, the effects of automation drift can be minimized, because the start points of each subsequent region change as the tempo changes. When tempo is decreased, automation expands. When tempo is increased, automation contracts.

Using many smaller regions...

...keeps audio aligned with automation changes.

**Tempo changes applied to small regions**

To break an audio region into smaller regions, use Beat Detective. For more information, see Chapter 21, “Beat Detective.”

You can also separate regions at transients or based on the current grid resolution. For more information, see “Separate Region Commands” on page 290
Graphic Tempo Editor

The Tempo Editor, a resizeable window beneath the Tempo ruler in the Edit Window, lets you view and edit tempo information graphically.

Tempo Editor

The Tempo Editor is an expansion of the Tempo ruler, opening in the rulers section of the Edit Window.

To display the Tempo Editor, do one of the following:
- Select View > Rulers > Tempo, then View > Rulers > Tempo > Tempo Editor.
- Click the Tempo Editor expand/collapse triangle.

Editing Tempo Events in the Tempo Editor

Tempo events in the Tempo Editor can be edited with any of the following methods:
- Individual tempo events can be dragged with any of the Grabber tools to adjust their location or value.
- A group of selected tempos can be scaled up or down with the Trim tool.
- New tempo events can be drawn in with the Pencil tool to replace existing ones.
- Tempo events can be copied and pasted, nudged, and shifted.

Drawing Tempo Events

Tempo events can be drawn in the Tempo Editor using the Pencil tool.
Freehand The Freehand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Tempo Edit Density setting. (For more information, see “Selecting Tempo Edit Density” on page 360.)

Line The Line shape draws in a straight line from click to release. Tempo values change in steps according to the Tempo Edit Density and Resolution. (For more information, see “Selecting Tempo Edit Density” on page 360.)

Parabolic The Parabolic shape draws the best possible curve to fit your freehand drawing. The shape is reproduced as a series of steps according to the Tempo Edit Density setting.

S-Curve The S-Curve shape draws a best possible fit of an S-Curve to your freehand drawing. The shape is reproduced as a series of steps according to the Tempo Edit Density setting.

⚠️ The Triangle, Square, and Random Pencil tool shapes do not apply to tempo events.

Selecting Tempo Resolution (BPM Rate)
The Tempo Editor lets you specify the note value that the BPM rate is based on for all tempo events created when you draw a tempo curve with the Pencil tool. This note value is the Tempo Resolution.

To select the Tempo Resolution (BPM rate) for Pencil tool edits, do one of the following:

- Click the Tempo Resolution selector and select a note value from the pop-up menu. Tempo events created by drawing with the Pencil tool will have their BPM set to the note value you choose.

- Choose Follow Metronome Click. Tempo events created by drawing with the Pencil tool will have their BPM set to mirror the click values set by meter events in the Meter ruler.

A tempo curve can have different BPM values if there are meter click changes within the selected range.

💡 Because it can be unnecessarily complicated to set meter events separately for each Tempo event, Digidesign recommends choosing Follow Metronome Click in most cases.
Selecting Tempo Edit Density

The Tempo Editor lets you specify the density of tempo events created in the Tempo ruler when you draw a tempo curve with the Pencil tool.

To select the Tempo Edit Density for Pencil tool edits:

- Click the Tempo Edit Density selector and select a time value from the pop-up menu. Tempo events created by drawing with the Pencil tool will be placed in the Tempo ruler at the density that you choose.

Pressing Start (Windows) or Control (Macintosh) before drawing a pencil line conforms already created tempo events to the drawn line rather than creating new tempo events.

Curve Adjustment Mode

Immediately after you draw new tempos using the Pencil tool, a tempo curve appears in blue, outlining the newly created tempo graph. Blue adjustment handles on the curve let you adjust the shape and size of the new tempo graph.

All the new tempo events under the curve will change as you move the Tempo Curve Adjustment Handles. To adjust the curve shape without the track data adjusting immediately, press Start (Windows) or Control (Macintosh) while adjusting the curve. Tempo events will change to fit the new curve when you release the mouse button.

The blue adjustment handles are only active until a new tool is selected or a new command is executed.
Grabbing Tempo Events

The Grabber tools let you create new tempo settings by dragging tempo events in the Tempo Editor. To remove a tempo event, Alt-click (Windows) or Option-click (Macintosh) the tempo event with any of the Grabber tools.

Drag a tempo event to the left or right to adjust the location of the tempo change.

Selecting Tempo Events

You can easily select a single tempo event, or an entire tempo curve within the Tempo Editor.

To Select a tempo event in the Tempo Editor:

Using the Selector tool or any Grabber tool, double-click on the horizontal tempo line.

To Select a tempo curve in the Tempo Editor:

Using the Selector tool or any Grabber tool, triple-click on a horizontal tempo line in the curve that you wish to select.

Extending Tempo Selections

You can extend Tempo selections to the next or the previous tempo event.

To extend a tempo selection:

1. Select a portion of a region, or click anywhere in the region.
2. Press Shift+Tab to extend the selection to the next tempo event.
   – or –
3. Press Shift+Control+Tab (Windows) or Shift+Option+Tab (Macintosh) to extend the selection to the previous tempo event.
Using the Trim Tool

The Trim tool lets you scale all the tempo events of the session, or within a time selection. The Trim tool also lets you stretch a region of tempo events to cover a longer or shorter area in the timeline.

To scale all the session’s tempo events with the Trim tool:
1. Open the Tempo Editor.
2. Select the Trim tool.
3. Click above the tempo events and drag up or down. Dragging up increases the tempo values; dragging down decreases them.

To change the rate of tempo change with the Trim tool:
1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to edit.
3. Select the Trim tool.
4. Click either the start or end handle for the selected range, and drag up or down.

To scale selected tempo events with the Trim tool:
1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to edit.
3. Select the Trim tool.
4. Click within the selected area, and drag up or down. Dragging up increases the tempo values of the selection; dragging down decreases them.

To stretch or shrink the tempo change range with the Trim tool:
1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to edit.
3. Select the Trim tool.
4. Click at the start or end of the selection, and drag horizontally. Tempo events will maintain their relative spacing to each other but will be spaced over a larger or smaller area.
Moving, Cutting, Pasting and Nudging in the Tempo Editor

To move a selected group of tempo events in the Tempo Editor:

1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to move.
3. Click on any selected tempo event with any Grabber tool, and drag horizontally to move the tempo events to a new location.

   Press Alt (Windows) or Option (Macintosh) while dragging to move a copy of the tempo events.

To copy and Paste tempo events in the Tempo Editor:

1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to copy.
3. Choose Edit > Copy.
4. Click in the Tempo Editor at the point where you want to paste the tempo events.
5. Choose Edit > Paste. Your copied selection is pasted from the insertion point, replacing any existing tempo events.

To nudge a selection in the Tempo Editor:

1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to nudge.
3. On the numeric keypad, press Plus (+) to move the selected tempo events forward by the Nudge value.
   – or –
   Press Minus (–) to move the selection back by the Nudge value.

Changing the Linearity Display Mode

You can choose to view the Edit Window in either a Linear Tick (Bars|Beats) scale or a Linear Sample (absolute) Time Scale. MIDI and Instrument tracks, audio tracks, and Tempo curves can appear and function very differently depending on the timebase display settings.

To change the timebase display:

■ Click the Linearity Display Mode selector and select a timebase from pop-up menu.

Drawing tempo events using the Linear Sample Display can cause Bar|Beat based material to move in non-intuitive ways. Digidesign recommends that you use Linear Tick Display when you draw tempo changes.

To change the timebase display:

■ Click the Linearity Display Mode selector and select a timebase from pop-up menu.
Tempo Edit Density and Linearity Display Mode

When both the Tempo Edit Density setting (in the Tempo Editor) and the Linearity Display Mode setting are set to either a Bars|Beats Time Scale or to an absolute Time Scale, Tempo edits will appear evenly spaced. When the Tempo Edit Density setting and the Linearity Display Mode setting are set so that one is set to an absolute Time Scale and the other is set to a Bars|Beats Time Scale, the number of Tempo edits will appear to increase or decrease over time.

Tempo Operations Window

The Tempo Operations window lets you define tempo events over a range of time (or measures). The time range is specified in the time format chosen for your Main Time Scale. In addition, the Tempo Operations window lets you:

- Fit a specific number of Bars|Beats into a precise time range.
- Create tempos that speed up or slow down, both linearly and over various curves.
- Scale and stretch existing tempos.

! The Tempo Operations window is not available in Manual Tempo mode.

The Tempo Operations window has six pages, one for each type of tempo operation.

Constant Lets you create a constant tempo over a selected range of time.

Linear Lets you create tempos that change evenly over a selected range of time.

Parabolic Lets you create tempos that accelerate or decelerate following a tempo curve that changes the tempo more rapidly or less rapidly over the selection time.

S-Curve Lets you create tempos that accelerate or decelerate following a tempo curve with a definable breakpoint that determines mid-curve times and tempo values.

Scale Lets you scale tempos within the selection by a percentage amount.

Stretch Lets you select a region of tempo events and apply them to a larger or smaller selection area.

To open a specific Tempo Operations window page:

- Choose Event > Tempo, followed by one of the Tempo Operations page commands (such as Constant).

💡 If the Tempo Operations window is already open, you can select any of the pages from the pop-up menu at the top of the window.

To open the last active Tempo Operations window page:

- Choose Event > Tempo > Operations Window.

➡️ Press Alt+2 (Windows) or Option+2 (Macintosh) to open the Tempo Operations window and display the last active Tempo Operations page.

To define tempo events over a range of time:

1. Make a selection in the Timebase or in a track.
2. Choose Event > Tempo > Operations Window.
3. Choose a Tempo Operation page from the pop-up menu at the top of the Tempo Operation window.
4. Change the settings for the page you have chosen, as necessary.
5 Click Apply.

– or –

Press Enter (Windows) or Return (Macintosh) to automatically apply the values and close the window.

**Constant**

The Constant page lets you create a constant tempo over a selected range of time.

![Constant page (Advanced Option)](image)

**Advanced** When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** Lets you choose to calculate either the tempo, or the selection end time.

**Selection Start and End** Specifies the start and end point for the tempo change in Bars|Beats. When an Edit selection is made, the Start and End fields will display the selection boundaries.

**End Time (Advanced Option)** Displays the selection end time. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

**Tempo** Specifies the tempo, in beats per minute (BPM), to apply to the selected range.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

💡 Selecting “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.
Linear

The Linear page lets you create tempos that change evenly over a selected range of time.

### Advanced

When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

#### Calculate (Advanced Option)

Lets you choose to calculate either the selection end time, the start tempo, or the end tempo.

#### Selection Start and End

Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

#### End Time (Advanced Option)

Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

#### Tempo Start and End

Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

#### Resolution (Advanced Option)

Lets you select the BPM note value for your tempo setting.

#### Density (Advanced Option)

Lets you specify the density of the tempo change events written to the Tempo ruler.

#### Preserve Tempo after Selection

If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Selecting “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.
Parabolic

The Parabolic page lets you create tempos that accelerate or decelerate by following a tempo curve, which changes the tempo more rapidly or less rapidly over the selection time.

Parabolic page (Advanced Option)

Advanced When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

Calculate (Advanced Option) Lets you choose to calculate the selection end time, the start tempo, the end tempo, or the curvature of the tempo change.

Selection Start and End Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

End Time (Advanced Option) Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

Tempo Start and End Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

Curvature Specifies and displays a numerical and graphic representation of the tempo curve. Negative numbers indicate a more rapid tempo change at the beginning of the time range, and positive numbers indicate a more rapid tempo change at the end of the time range. This value can be set with the Curvature slider.

Resolution (Advanced Option) Lets you select the BPM note value for your tempo setting.

Selecting “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.

Density (Advanced Option) Lets you specify the density of the tempo change events written to the Tempo ruler.

Preserve Tempo after Selection if selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.
**S-Curve**

The S-Curve page lets you create tempos that accelerate or decelerate by following a tempo curve with a definable breakpoint that determines mid-curve times and tempo values.

---

**S-Curve page (Advanced Option)**

**Advanced** When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** Lets you choose to calculate either the selection end time, the start tempo, the end tempo or the curvature of the tempo change.

**Selection Start and End** Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

**Start and End Time (Advanced Option)** Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats.

**Tempo Start and End** Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

**Curvature** Specifies and displays a numerical and graphic representation of the tempo curve. Negative numbers indicate a more rapid tempo change at the start and end of the time range, with a low rate of change around the midpoint. Positive numbers indicate a low rate of change near the start and end of the selected range, with rapid tempo change around the midpoint. This value can be set with the Curvature slider.

**Mid Point** Specifies the Main Time Scale location for the curve mid point. This value can be set with the Mid Point slider.

**Mid Tempo** Specifies the tempo at the mid point. This value can be set with the Mid Tempo slider.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

*Select “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.*

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.
Preserve Tempo after Selection  If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Scale  
The Scale page lets you scale tempos within the selection by a percentage amount.

Advanced  When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

Calculate (Advanced Option)  In combination with settings chosen in the Scale pop-up menu, the Calculate pop-up menu lets you choose to calculate the selection end time, the average tempo, the start tempo, or the end tempo.

Scale (Advanced Option)  In combination with settings chosen in the Calculate pop-up menu, the Scale pop-up menu lets you choose to scale all tempos, the start tempo, or the end tempo.

Scaling all tempos scales each tempo in the selected range equally. Scaling the start tempo scales the tempos unevenly, scaling the first tempo event the most, scaling each consecutive tempo event less until the end tempo which is not scaled. Scaling the end tempo scales the tempos unevenly, scaling the last tempo the most, scaling each previous tempo event less until the start tempo which is not scaled.

Selection Start and End  Displays the start and end points for the tempo operation in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

Start and End Time  Displays the absolute time for the selection start and end points. When the Main Time Scale is set to Bars|Beats, times are displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, times are calculated and displayed in Bars|Beats.

Average Tempo  Displays the Average Tempo, in beats per minute (BPM), across the selected range. Changing the Average Tempo changes the Scale percentage.

Chapter 20: Conductor Tracks and Memory Locations  369
**Scale** Displays the percentage by which the tempo is scaled, in beats per minute (BPM), across the selected range. Changing Scale changes Average Tempo.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

**Stretch**

The Stretch page lets you select a region of tempo events and apply them to a larger or smaller selection area.

**Stretch To End** Specifies a new end point for the region to which you want to apply the selected tempo events. Changing the end point causes the Stretch percentage to change.

**Stretch To Start (Advanced Option)** Specifies a new start point for the region to which you want to apply the selected tempo events. Changing the end point causes the Stretch percentage to change.

**Stretch** Specifies the percentage of time for the selected tempo events to cover.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

**Identify Beat Command**

The Identify Beat command lets you establish a tempo/meter map for audio that was recorded without a click, or for imported audio with unknown tempos.

The Identify Beat command analyzes a selection range (usually with a distinct number of beats or measures) and calculates its tempo based on the specified meter. In doing this, Bar|Beat Markers for the calculated tempo are inserted and appear in the Tempo ruler at the beginning and end of the selection; in addition, meter events are inserted into the Meter ruler.

Use Beat Detective to generate Bar|Beat Markers within a selection that includes rhythmic changes on beats or sub-beats. For more information, see Chapter 21, “Beat Detective.”
### Bar|Beat Markers

Bar|Beat Markers look similar to tempo events, but instead have small blue triangles to indicate their location.

#### Choosing Bar|Beat Markers or Tempo Events

Because tempo events are tick-based, and Bar|Beat Markers are sample-based, they cannot be mixed. If a session contains tempo events and you attempt to insert Bar|Beat Markers, existing tempo events are converted to Bar|Beat Markers (and vice versa).

Tempo events can also be manually converted to Bar|Beat Markers and vice versa.

#### To choose to use either tempo events or Bar|Beat Markers:

1. Press Control (Windows) or Command (Macintosh) and click the Add Tempo Change button.
2. Choose either Tempo Events or Bar|Beat Markers from the pop-up menu.

#### Identifying Beats

To add Bar|Beat Markers for a one-bar drum loop:

1. Place a one-bar drum loop at the beginning of an audio track.
2. Select View > Rulers > Samples. This ensures that the selected audio material will be sample-accurate.
3. Select the audio region with the Time Grabber tool and choose Event > Identify Beat.
4. In the Bar|Beat Markers dialog, specify the start and end locations for the inserted Bar|Beat Markers. Since this example deals with a one-bar loop, enter 1|1|000 and 2|1|000.

#### When converting between Tempo events and Bar|Beat Markers, some amount of sample rounding may occur.
Click OK to automatically calculate the new tempo and insert the necessary Bar|Beat Markers and meter events. Any existing tempo and meter events residing within the selection are deleted.

Once the tempo has been determined for the audio, you can duplicate the original audio region with the Repeat command.

When working with a selection, the Identify Beat command only calculates a single tempo for the selected range. If the tempo varies from measure to measure, or beat to beat, you'll need to use the Identify Beat command for each tempo variance (making sure to accurately define a precise selection range or beat location for the tempo change).

To accurately define tempos for a range of audio with the Identify Beat command, make certain that the initial selection represents an accurate length of beats or measures. You may want to first loop the selection on playback (see “Looping Playback” on page 284) to see if it plays cleanly without skipping. To avoid drift, and remain sample-accurate, select the audio material with the Time Scale set to Samples rather than Bars|Beats.

When identifying beats, select as large an area as possible. For example, if you have a four bar long audio file you want to identify, select the entire four bars instead of just one bar, in order to minimize rounding errors.

Dragging Bar|Beat Markers

Bar|Beat Markers can be dragged to new locations so they can align with audio regions that have been moved, or so that they can align to a slightly different point within an audio region. This results in neighboring MIDI data being adjusted to align with the new tempo map.

When dragging a tempo event:
- The tempo event is placed at a new bar and beat location. The sample and SMPTE locations for the event are updated as well.
- The BPM value for the dragged tempo event remains constant, as do any other tempo events in the session.
- Neighboring MIDI events, along with the ruler, shrink or expand as necessary to adjust for the new tempo location.

When dragging a Bar|Beat Marker:
- Its BPM value is recalculated along with the Bar|Beat Marker to its immediate left. Bar|Beat Markers to the right of the dragged marker remain unchanged.
- Its bar and beat location is dragged with the Bar|Beat Marker. If the Bar|Beat Marker was originally placed at 3|1|000, it remains there (unless it is edited).
• Its sample and SMPTE locations change, as calculated for by the new tempo for the Bar|Beat Marker.
• Neighboring MIDI events, along with the Bars:Beats ruler, shrink or expand as necessary to adjust for the new tempo.

Editing Bar|Beat Markers

A Bar|Beat Marker can be edited to redefine its bar and beat location, which also redefines the start or end point of the range being analyzed for tempo. This is different from dragging a Bar|Beat Marker.

To edit a Bar|Beat Marker:

1 In the Tempo ruler, double-click the Bar|Beat Marker.
2 In the Edit Bar|Beat dialog, enter a new Location for the Bar|Beat Marker.
3 Enter a new Time Signature if desired.
4 Click OK.

To delete a Bar|Beat Marker:

While pressing Alt (Windows) or Option (Macintosh), move the cursor over the Bar|Beat Marker (where the cursor changes to the Grabber with a “–”) and click to remove it.

Inserting Bar|Beat Markers One at a Time

Sample-Based Material with Varying Tempos

You can insert Bar|Beat Markers one at a time by setting an Edit insertion point (instead of making a selection) before using the Identify Beat command. The ability to identify each beat, one at a time, is especially useful when working with sample-based material with varying tempos.

For instance, if you have a measure that accelerates slightly, you could insert a Bar|Beat Marker on each beat (see Figure 15) so the tempo is accurately reflected.

After the Bar|Beat Markers are inserted, further adjustments in the tempo map are possible by dragging each of the Markers, as necessary, to align with the associated beat within the audio.

Figure 15. Bar|Beat Markers on each beat
**Meter Events**

You can change meter in the Meter ruler, or make precise meter changes in the Time Operations window.

Meter events can be inserted at the beginning of a session to replace the default meter (of 4/4), and they can be inserted anywhere within the session for additional meter changes.

To display the Meter ruler:
- Select View > Rulers > Meter.

**Current Meter**

As meter events are encountered during playback, the session’s current meter is displayed in the Transport window.

![Current meter displayed in Transport window](image)

**Inserting Meter Events**

**To insert a meter event:**

1. Do one of the following:
   - Choose Event > Time > Change Meter.
   - Click the Add Meter Change button at the left of the Meter ruler.

![Add Meter Change button](image)

2. In the Meter Change window, enter the Location and Meter for the meter change.

   - While pressing the Start key (Windows) or Control (Macintosh), move the cursor into the Meter ruler (where the cursor changes to the Grabber with a “+”) and click at the location where you want to insert the event.

![Manually inserting a meter event](image)

3. Select the Snap To Bar option if you want the inserted meter event to fall cleanly on the first beat of the nearest measure.

   - Double click the meter display in the Transport window.

4. Select a note value for the number of clicks to sound in each measure. For a dotted-note click value, select the dot (.) option.

   - In the Meter Change window, enter the Location and Meter for the meter change.
4 Click Apply to insert the new meter event. The new meter event is inserted and appears in the Meter ruler.

![Inserted meter event](image)

Each meter event has a small yellow triangle next to it that indicates its location. These triangles can be selected for copying and pasting, and they can be double-clicked to edit the meter event.

**Editing Meter Events**

Existing meter events can be edited, deleted, and copied and pasted.

**To edit a meter event:**

1. In the Meter ruler, double-click the meter event.
2. In the Meter Change dialog, enter a new Location or Meter for the event.
3. Click OK.

**To delete a meter event:**

- While pressing Alt (Windows) or Option (Macintosh), move the cursor over the meter event (where the cursor changes to the Grabber with a “—”) and click to remove it.

**To copy and paste several meter events:**

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag in the Meter ruler to select the range that includes the meter events.

![Meter events selected](image)

If the beginning of the selection includes a meter event, press Control (Windows) or Command (Macintosh) so the Selector tool appears.

- Press Alt (Windows) or Option (Macintosh) while dragging to select across all Conductor tracks.
3. Choose Edit > Copy.
4. Click in the Meter ruler at the point where you want to paste the meter events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing meter events.

**To extend an Edit selection in a track to the Meter ruler:**

1. Using the Selector tool or any Time Grabber tool, select a track range.
2. Shift-click in the Meter ruler.
3. Shift-click again in the Meter ruler to remove it from the selection.

**To select all meter events:**

- Double-click with the Selector tool in the Meter ruler.

> For some meters, it may be desirable to use a dotted value for the click. For instance, if using a meter of 6/8, a dotted quarter note click (yielding two clicks per measure) is generally more suitable than a straight eighth note click (six clicks per measure).
To clear a range of selected meter events:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag in the Meter ruler to select the meter events you want to remove.
3. Choose Edit > Clear to delete the selected meter events.

Partial Measures

As necessary, Pro Tools will create a partial measure to accommodate the inserted meter event. When a meter event is preceded by a partial measure, the meter event is displayed in italics in the Meter ruler.

To insert meter events while avoiding partial bars, use the Change Meter command in the Time Operations window. See “Change Meter” on page 377.

Time Operations

The Time Operations window lets you:

- Change Meter
- Insert Time
- Cut Time
- Move Song Start

To open a specific Time Operations window:

- Choose Event > Time, followed by one of the Time Operations commands (such as Change Meter).

If the Time Operations window is already open, you can select any Time Operation from the pop-up menu at the top of the window.

To open the last active Time Operations window:

- Choose Event > Time > Operations Window.

Press Alt+1 (Windows) or Option+1 (Macintosh) to open the Time Operations window and display the last active Time Operations window.
Change Meter

Change Meter lets you specify complex meter changes for Bar|Beat-based material. You can enter meter changes at a particular bar, make a meter change over a selected area of time, or add meter changes sequentially one bar at a time.

Options for the Change Meter command include:

New Meter Lets you specify a new time signature. The first field lets you enter the number of beats (up to 99) in a measure, and the second field lets you enter the note length that counts as one beat.

Click Lets you specify the note value that will trigger the metronome click. For example, if an eighth note is chosen, a click is played for every eighth note, regardless of tempo.

Starting at Bar Sets the bar where the meter change is added. Meter changes made in the Change Meter page can only be made at the beginning of a bar.

Apply Change To Lets you apply the meter change to the selected range, to the end of the session, or until the next bar.

Change The Change fields let you specify the number of bars of the new meter that you wish to have replace the selected range.

Pro Tools automatically calculates the nearest whole bar number, or you can specify a number of bars to be affected. Time is inserted or deleted, in whole bar increments, at the end of the selection, as necessary on all affected tracks when you override the calculated range.

Realign

The Realign controls let you choose which items to realign after meter changes have been made. You can choose to realign meter events, or choose to realign meter and tempo events, tick-based markers and tracks, and all or none of the sample-based tracks.

Meter Ruler Only Applies meter changes to the Meter ruler only. All other rulers and tracks are unaffected.

Meter and Tempo Rulers, Tick-Based Markers and Tracks, and Sample-based Markers and Tracks Applies meter changes to all rulers, tick-based tracks, and your choice of sample-based tracks. Time is inserted or deleted as needed at the end of the selection to preserve the alignment of material following the selection.

Change Meter Examples

To change the meter over a range of bars:

1. Drag with the Selector tool to select a range of bars to change.

   – or –

To have the meter change apply until the next meter event, click where you want the meter change to begin with the Selector tool. The meter change will be made at the beginning of the nearest bar.

Chapter 20: Conductor Tracks and Memory Locations
2 Choose Event > Time > Change Meter.

3 Specify a new meter and click setting. Pro Tools will automatically set the selection options to fit the new meter to the selected range as closely as possible, adding or subtracting beats a necessary.

4 Select To Selected Range in the Apply Change pop-up menu.

5 Choose which rulers and tracks you wish to realign after meter changes have been made.

6 Click Apply.

**To add a series of meter changes, one measure at a time:**

1 With the Selector tool, click where you want the meter change to begin. The meter change will be made at the beginning the nearest bar.  
   – or –

   Enter the first measure number in the Starting At Bar field.

2 Choose Event > Time > Change Meter.

3 Specify a new meter and click setting.

4 Choose “Until the Next Bar” from the Apply Change To pop-up menu.

5 Click Apply to enter the new meter and to move the insertion point to the end of the new measure.

6 Specify a new meter and click setting for the next measure.

7 Repeat steps 5–6 for every additional meter change you wish to insert.

---

**Insert Time**

Insert Time lets you insert an amount of blank time (silence) into Conductor rulers, MIDI tracks, and audio tracks.

**Insert Time window**

Options for the Insert Time command include:

**Start, End and Length** Sets the start and end points for the selection, and the selection length.

**Set Meter** If your Main Time Scale is Bars|Beats, Set Meter lets you specify a new meter for the inserted time. The selection is quantized to the nearest bars, and the previous meter is inserted after the selection.

If your Main Time Scale is sample-based, Set Meter is not available.
Realign

The Realign controls let you choose which items shift (occur later) when time is inserted, as follows:

- If your Main Time Scale is set to Bars|Beats, you can choose to realign meter events only, or choose to realign a combination of Meter and Tempo rulers, all tick-based markers and tracks, and your choice of sample-based tracks.
- If your Main Time Scale is set to an absolute timebase (such as Min:Secs), you can choose to independently realign conductor events, tick-based markers and tracks, and your choice of sample-based tracks.

Meter Ruler Only If your Main Time Scale is Bars|Beats, you have the option to insert time into the Meter ruler only. Meter events after the start point of the selection are shifted past the end point by the length of time selection.

If your Main Time Scale is sample-based, Realign Meter Ruler Only is not available.

Meter and Tempo Rulers Lets you insert time into the Meter and Tempo rulers. Meter and Tempo events after the start point of the selection are shifted past the end point by the length of time inserted.

Tick-Based Markers and Tracks Lets you shift Bar|Beat-based markers, and insert time into tick-based tracks. Marker events and tick-based tracks after the start point of the selection are shifted past the end point by the length of time inserted.

If the time selection includes any audio regions on tick-based tracks, the audio regions are separated at the Start point, and the new region containing the previous selection is shifted to the end point.

Sample-Based Markers and Tracks Lets you shift absolute time-based markers, and insert time into sample-based tracks. Marker events and sample-based tracks after the start point of the selection are shifted past the end point by the length of time inserted.

If the selection includes any audio regions on sample-based tracks, the selected portions of the audio regions are separated at the Start point, and the new region containing the previous selection is shifted to the end point.

Insert Time Example

To insert four empty measures of 4/4 time into a session:

1. Set the Main Time Scale to Bars|Beats.
2. Choose Event > Time > Insert Time.
3. Enter the measure where you want to insert the measures in the Start field.
4. Enter four measures in the Length field.
5. Select the Realign option to Meter and Tempo Rulers, All Tick-Based Markers & Tracks, and All Sample-Based Markers and Tracks.
6. Click Apply.
**Cut Time**

Cut Time lets you cut a specified amount of time (both Timebase and track data) from Conductor rulers, MIDI tracks, and audio tracks.

**Cut Time window**

Options for the Cut Time command include:

- **Start, End and Length** Sets the start and end points for the selection, and the selection length.

**Realign**

The Realign controls let you choose which items shift when time is cut, as follows:

- If your Main Time Scale is set to Bars|Beats, you have the option to remove time from the Meter ruler only. Meter events within the selection are removed, and meter events that occur after the end point of the selection are shifted to the selection start point.

- If your Main Time Scale is sample-based, Realign Meter Ruler Only is not available.

- **Meter and Tempo Rulers** Lets you cut time from the Meter and Tempo rulers. Meter and tempo events within the selection are removed, and the meter and tempo events that occur after the end point of the selection are shifted to the selection start point.

- **Tick-Based Markers and Tracks** Lets you shift Bar|Beat-based markers, and delete time from tick-based tracks. Marker events and tick-based tracks within the selection are removed, and the marker events and tick-based tracks that occur after the end point of the selection are shifted forward.

- **Sample-Based Markers and Tracks** Lets you shift absolute time-based markers, and cut time from sample-based tracks. Marker events and sample-based tracks within the selection are removed, and the marker events and sample-based tracks that occur after the end point of the selection are shifted forward.

If the time selection includes any tick-based audio regions, the selected area of the audio region is deleted, and the region following the selection is shifted forward.

If the time selection includes any sample-based audio regions, the selected area of the audio region is deleted, and the region following the selection is shifted forward.
Cut Time Example

To cut thirty seconds of time from a session:
1 Set the Main Time Scale to Minutes:Seconds.
2 Choose Event > Time > Cut Time.
3 With the Selector tool, click at the beginning of the area that you want to cut.
4 Enter thirty seconds (0:30.000) in the Length field.
5 Select the options to Realign both Meter and Tempo rulers, all tick-based tracks, and all sample-based markers and tracks.
6 Click Apply.

Move Song Start

Move Song Start lets you redefine the location of the Song Start Marker.

Move Start To

Sets the location for the Song Start Marker in the chosen timebase.

Renumber Song Start To

When enabled, this lets you set the Song Start Marker to any bar number.

Move

The Move controls let you choose which items shift when the Song Start is moved, as follows:

Song Start Only

Moves the Song Start Marker only.

Meter and Tempo Rulers, Tick-Based Markers and Tracks, and Sample-based Markers and Tracks

Moves the Song Start Marker, Meter and Tempo rulers, tick-based tracks, and your choice of sample-based tracks.

Move Song Start Example

To move the Song Start Marker to 15 seconds on the timeline:
1 Choose Event > Time > Move Song Start.
2 Select Minutes:Seconds from the Timebase pop-up menu.
3 In the Move Song Start To field, enter “0:15:000” to move the song start forward by 15 seconds.
4 If you wish to renumber the bars so that the Song Start Marker sits at a different bar, select the Renumber Song Start option, and enter the bar number in the Renumber 1st Bar to field.
5 Select whether you want to move all sample-based markers and tracks or none of them.
6 Click Apply.
Renumbering Bars

You can use the Renumber Bars command to renumber all bars in the session, effectively changing the bar locations for all regions, meter and tempo events while leaving their position intact. In doing so, however, the SMPTE and sample locations of the session data are not changed.

To renumber bars:

1. Choose Event > Renumber Bars.
2. Specify the bar you want to renumber, along with the new bar number, then click Renumber.

Memory Locations and Markers

Each session can save up to 999 Memory Locations that can be used to recall:

- Markers to important locations in the session
- Edit selections across one or more tracks
- Record and play ranges, along with pre- and post-roll times
- Track settings that include Show/Hide status, Track Heights, and zoom values
- Edit and Mix Groups enables

Memory Locations are viewed and sorted in the Memory Locations window, where they can be recalled by clicking the Memory Location.

Properties of Memory Locations

When creating a new Memory Location (see “Creating Memory Locations” on page 384) you are prompted to define its Time Properties and General Properties.

Time Properties

Under Time Properties, a Memory Location can be set to Marker, Selection, or None. This determines the type of Memory Location that is created. Each of these three Memory Location types can also save any combination of General Properties.

Marker Recalls a Timeline location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). When recalling a Marker Memory Location, the playback cursor moves to the Marker’s location and the start and end times in the Transport window are also updated. If the Timeline and Edit Selections are linked, the edit cursor also moves to the Marker location.
Markers appear in the Markers ruler with a thin yellow line extending down through all tracks in the Edit window (to assist in arranging and aligning track material). You can click a Marker in the Markers ruler to recall its location along with its stored General Properties.

**Selection** Recalls an Edit selection or edit cursor location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). A Selection Memory Location lets you store Edit selections, for one or more tracks, that you return to often within a session. If the Timeline and Edit Selections are linked, a Selection Memory Location can recall record and play ranges.

- **None** Recalls no Time Properties and is therefore referred to as a General Properties Memory Location.

**Bar|Beat and Absolute Reference**

The Reference pop-up determines whether the Marker or Selection Memory Location is Bar|Beat or Absolute. When set to Bar|Beat, the Memory Location is tick-based and its bar and beat location remains constant if the tempo is changed—though its relation to audio is scaled, resulting in a new sample location.

When set to Absolute, the Memory Location is sample-based and its bar and beat location shifts if the tempo is changed—though its sample location remains constant, along with its relation to audio material.

**General Properties**

All three types of Memory Locations (Marker, Selection, and None) can store and recall any combination of the following General Properties:

- **Zoom Settings** Recalls the horizontal, audio, and MIDI zoom values for audio, MIDI, and Instrument tracks.
- **Pre- and Post-Roll Times** Recalls pre- and post-roll times (but not whether they are enabled). This property can be stored with a Selection Memory Location to recall record and play ranges along with pre- and post-roll.
- **Track Show/Hide** Recalls which tracks are hidden. Use this property to display groups of tracks for editing and mixing.
- **Track Heights** Recalls all Track Heights. Use this option along with Zoom Settings to recall edit environments that are suited for particular tasks, such as editing down to the sample level or trimming MIDI notes.
- **Group Enables** Recalls which Edit and Mix Groups are enabled. This option is helpful in recalling groups for particular edit and mixing operations, such as muting all drum tracks or fading a stereo pair.

In the Markers ruler, Markers that are Bar|Beat appear as yellow chevrons, and Markers that are Absolute appear as yellow diamonds.

Only contiguous selections can be saved with Memory Locations. Discontiguous selections, made with the Object Grabber tool, will be recalled as if the selections were made with the Time Grabber tool.
Comments

All three types of Memory Locations (Marker, Selection, and None) can store and recall comments. You can enter a maximum of 255 characters to describe the Memory Location. You can also edit comments previously entered.

See “Creating Memory Locations” on page 384 and “Editing Memory Locations” on page 386 for more information.

Creating Memory Locations

Memory Locations can be created in different ways, based on the type of Memory Location.

When creating Memory Locations, the next available number is assigned to it (1–999). This number is used in recalling the Memory Location from the numeric keypad.

To create a Marker Memory Location:

1. Configure any session settings you will save with the Marker Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.

2. Make sure to select Options > Link Timeline and Edit Selection.

3. If the Markers ruler is not displayed, select View > Rulers > Markers.

4. Click with the Selector tool in any track or ruler at the location where you want to place the Marker. To place a Marker at the beginning of a region, select the region with the Time Grabber tool. Click the Add Marker/Memory Location button (or press Enter on the numeric keypad).

5. In the New Memory Location dialog, select the Marker option and specify the Reference as either Bar|Beat or Absolute.

6. Enter a name for the new Marker and select any General Properties you want to save with the Marker.

7. Click OK. The Marker is created and appears in the Markers ruler, and in the Memory Locations window.

Manually inserting a Marker

While pressing the Start key (Windows) or Control (Macintosh), move the cursor into the Markers ruler (where the cursor changes to the Grabber with a “+”) and click at the location where you want to place the Marker.
To create a Selection Memory Location:

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Select a range of material in one or more tracks.
3. Press Enter on the numeric keypad.
   – or –
From the pop-up menu in the Memory Locations window (click the Name button), choose Add Memory Location.
4. In the New Memory Location dialog, select the Selection option and specify the Reference as either Bar|Beat or Absolute.
5. Enter a name for the new Memory Location and select any General Properties you want to save with it.
6. Click OK. The Selection Memory Location is created and appears in the Memory Locations window.

To create a General Properties Memory Location:

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Press Enter on the numeric keypad.
3. In the Memory Location dialog, select the None option.
4. Enter a name for the new Memory Location and select any General Properties you want to save with it.
5. Click OK. The General Properties Memory Location is created and appears in the Memory Locations window.

In the New Memory Location dialog, you can Alt-click (Windows) or Option-click (Macintosh) any General Property to enable or disable all properties. You can also Control-click (Windows) or Command-click (Macintosh) any property to toggle its state and the state of all other General Properties.

Creating Memory Locations On-the-Fly

When the Editing preference for “Auto-Name Memory Locations When Playing” is enabled, Memory Locations can be created during playback, without raising the New Memory Location dialog. This option can also be selected from the pop-up menu in the Memory Locations window.

This capability is useful if you want to mark certain locations while listening during a record pass, or if you want to mark frame locations while viewing a video scene.

To create a Marker during playback:

1. From the pop-up menu in the Memory Locations window, select Default To Marker. This ensures that new Memory Locations default to being Markers.
2. From the pop-up menu in the Memory Locations window, select Auto-Name Memory Locations.
3. For inserted Markers to have a Bar|Beat reference, make sure to set the Main Time Scale to Bars:Beats.
4. Click Play in the Transport window.
5 When the location is reached, press Enter on the numeric keypad. A Marker is automatically created and appears in the Markers ruler.

Auto-created Markers are named with increasing numbers, as in “Marker 1,” “Marker 2,” and “Marker 3.”

When the option for Default To Marker is deselected, new Memory Locations default to whatever type was last created. Therefore, if a Selection Memory Location was created last, it will be the type that is created on-the-fly. In this case, the name for the created Memory Location is based on the start of the Edit selection using the time format for the Main Time Scale (such as “2:2:305” or “0:02.658”).

Recalling Memory Locations

Memory Locations can be recalled from the Memory Locations window and from the numeric keypad. In addition, Marker Memory Selections can be recalled by clicking them in the Markers ruler.

To recall a Memory Location:

1. If the Memory Locations window is not already open, choose Window > Memory Locations to display it.

2. If recalling a Selection Memory Location that will define a record or play range, make sure to select Options > Link Timeline and Edit Selection.

3. Do one of the following:
   - In the Memory Locations window, click the Memory Location to recall it.
   - With the Numeric Keypad mode set to Classic, press the Memory Location number followed by Period (.) again.

When recalling a Memory Location from the numeric keypad, the Memory Locations window does not need to be open.

To recall a Marker from the Markers ruler:

1. If the Markers ruler is not displayed, select View > Rulers > Markers.

2. Click the Marker. The playback cursor locates to the Marker and any General Properties stored with the Marker are recalled.

Even if the Markers ruler is not displayed, Markers can be recalled from the Memory Locations window, or from the numeric keypad.

Editing Memory Locations

Memory Locations can be renamed, edited, deleted, and copied and pasted.

To rename a Memory Location:

1. In the Memory Locations window, double-click the Memory Location you want to rename.

   – or –

   If renaming a Marker Memory Location, double-click the Marker in the Markers ruler.

2. Enter the new name for the Memory Location, and click OK.
To redefine the General Properties stored with a Memory Location:

1. Make changes to the session’s zoom settings, pre- and post-roll times, Show/Hide status of tracks, Track Heights, or Group Enables.

2. In the Memory Locations window, Right-click (Windows) or Control-click (Macintosh) the Memory Location you want to redefine.
   – or –
   If changing a Marker Memory Location, Right-click (Windows) or Control-click (Macintosh) the Marker in the Markers ruler.

3. In the Memory Location dialog, select the General Properties you want to save with the Memory Location.

4. Enter a new name for the Memory Location, if desired, and click OK.

To change a Memory Location from one type to another:

1. In the Memory Locations window, double-click the Memory Location you want to change.
   – or –
   If changing a Marker Memory Location, double-click the Marker in the Markers ruler.

2. In the Memory Location dialog, select either Marker, Selection, or None as the Memory Location type.

3. Enter a new name for the Memory Location, if desired, and click OK.

To change the Selection stored with a Memory Location:

1. If the Memory Locations window is not already open, choose Window > Memory Locations to display it.

2. Select a range of material in one or more tracks.

3. In the Memory Locations window, Right-click (Windows) or Control-click (Macintosh) the Memory Location that you want to redefine.

4. Enter a new name for the Memory Location, if desired, and click OK.

To move a Marker by dragging:

1. In the Markers ruler, drag the Marker left or right.

   Dragging a Marker

   If the Edit mode is set to Grid, the dragged event snaps to the current Grid value. If using Spot mode, the Spot dialog opens.

To align a Marker to a different location:

1. Make sure to select Options > Link Timeline and Edit Selection.

2. In any of the Timebase rulers, click with the Selector tool at the new location.
   – or –
   Click in the playlist for any track. To align the Marker to the start of a region, select the region with the Time Grabber tool.
3 In the Memory Locations window or the Markers ruler, Right-click (Windows) or Control-click (Macintosh) the Marker Memory Location that you want to redefine.

4 Enter a new name for the Marker, if desired, and click OK.

**Deleting Memory Locations**

**To delete a Memory Location:**
- In the Memory Locations window, select the Memory Location and choose Delete Memory Location from the pop-up menu.
  - or -
- In the Memory Locations window, Alt-click (Windows) or Option-click (Macintosh) the Memory Location.

**To delete all Memory Locations:**
- In the Memory Locations Window, choose Delete All from the pop-up menu.
  - or -
- Alt-Shift-click (Windows) or Option-Shift-click (Macintosh) any Memory Location in the Memory Locations window.

**To delete a Marker from the Markers ruler:**
- While pressing Alt (Windows) or Option (Macintosh), move the cursor over the Marker (where the cursor changes to the Grabber with a “–”) and click to remove it.

**Copying Marker Memory Locations**

**To copy and paste a range of Markers:**
1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag in the Tempo ruler to select the range of measures that includes the Markers.

If the beginning of the selection includes a Marker, press Control (Windows) or Command (Macintosh) so the Selector tool appears.

* Press Alt (Windows) or Option (Macintosh) while dragging to select across all Conductor tracks.

3. Choose Edit > Copy.

4. Click in the Markers ruler at the point where you want to paste the tempo events.

5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing Markers.

**To extend an Edit selection in a track to the Markers ruler:**
1. Using the Selector or Time Grabber tool, select a track range.

2. Shift-click in the Markers ruler.

Shift-click again in the Tempo ruler to remove it from the selection.

**To select all Markers in the Markers ruler:**
- Double-click with the Selector tool in the Tempo ruler.
Memory Locations Window

Memory Locations are listed, with their name and assigned number, in the Memory Locations window. To recall a Memory Location from this window, simply click it.

You can select viewing and sorting options, along with commands for creating and removing Memory Locations, from the pop-up menu in the Memory Locations window (obtained by clicking the Name button in the upper left).

Memory Locations Commands and Options

- **Show Markers Only** When selected, only Marker Memory Locations are displayed in the Memory Locations window. However, even when Selection Memory Locations and General Property Memory Locations are hidden, they can still be recalled from the numeric keypad.

- **Show View Filter Icons** When selected, the Memory Locations window provides an icon-based “View Filter” that allows you to show or hide Memory Locations based on the properties they contain. To show or hide Memory Locations containing a specific property, click the appropriate icon.

If an icon is disabled, all Memory Locations associated with that property are hidden. However, if a Memory Location contains other properties for an icon that is enabled, it is still displayed. When a view icon is enabled, it appears in color. When it is disabled, it appears gray.

In addition, the View Filter provides a handy reference for which properties are stored in each Memory Location (indicated by a row of icons for each Memory Location).
Show Main/Sub Counter When selected, a column appears in the Memory Locations window that displays the locations for Markers, and the start times for Selection Memory Locations. General Property Memory Locations display nothing in this column.

You can click at the top of these columns for a pop-up menu that will let you change the Main and Sub Time Scale.

Show Comments When selected, a column appears in the Memory Locations window that displays the comments for each of the Markers.

Main/Sub Counters in the Memory Locations window

Sort by Time When selected, Markers are sorted by their order in the Timeline, followed by Selection and General Properties Memory Locations, which are listed in the order in which they were created.

When Sort by Time is deselected, all Memory Locations are listed in the order of their assigned numbers.

Add Memory Location Choose this command to create a new Memory Location.

Remove Memory Location Deletes the currently selected Memory Location in the Memory Locations window.

Delete All Deletes all Memory Locations (Marker, Selection, and General Property) in the session.

Default To Marker When selected, new Memory Locations default to Markers, though in the New Memory Location dialog you can still define the new Memory Location as one of the other types.

Auto-Name Memory Location When selected, Memory Locations are created automatically without encountering the New Memory Location dialog. If the Default To Marker option is selected, a Marker Memory Location is auto-created. Otherwise, the Memory Location type is determined by whatever type (Marker, Selection, or None) was created last.

Comments in the Memory Locations window
Chapter 21: Beat Detective

Beat Detective is a powerful tool for analyzing, editing, and manipulating audio or MIDI tracks that have an inherent rhythmic character.

Beat Detective analyzes an audio or MIDI selection, identifies its peak transients or accented notes, and generates beat triggers based on the detected peak transients or MIDI notes. From these beat triggers, Beat Detective can:

- Extract tempo and beat information to create Bar|Beat Markers that can be used to define the session’s tempo map. See “Generating Bar|Beat Markers with Beat Detective” on page 401.
- Extract tempo and groove information as groove templates, called DigiGrooves. These templates can be applied to audio or MIDI using Beat Detective or Groove Quantize (see “DigiGroove Templates” on page 402.
- Separate an audio selection into discrete regions, and then conform (or “quantize”) separated regions to the session’s tempo map, or to groove templates. See “Separating Regions with Beat Detective (Audio Only)” on page 404 and “Conforming Regions with Beat Detective (Audio Only)” on page 406.

Beat Detective and Source Material

Beat Detective is most effective with audio or MIDI that has clear attack transients or accent patterns (including most instruments used in popular music, such as drums, guitar, or bass). Beat Detective will be less successful with audio material with soft attacks, or legato phrasing (such as strings and vocals).

Uses for Beat Detective

Beat Detective can be useful in many situations, including:

Extracting Tempo from Audio Beat Detective can generate Bar|Beat Markers, from which it can extract the tempo—even if the audio contains varying tempos, or material with a swing feel. Additionally, once Bar|Beat Markers have been generated, other audio and MIDI regions can be quantized to them.

Creating DigiGrooves Beat Detective can extract groove templates, called DigiGrooves, from an audio selection. DigiGrooves can be used to apply the groove, or feel of the captured passage to other audio selections (using Groove Conform) or MIDI data (using Groove Quantize).

Conforming Audio Regions Beat Detective can conform (“quantize”) audio with a different tempo, or with varying tempos, to the session’s current tempo map, or to a groove template.
“Tighten Up” Performances Beat Detective can be used to improve the timing of some audio material by calculating and extracting its average tempo, and then conforming its rhythmic components—regions separated with Beat Detective—to the session’s tempo map.

Loop Matching Since Beat Detective can extract tempo and beat information from audio, and conform audio to an existing tempo map or groove template, this makes it very useful for aligning loops with different tempos or grooves. If a loop is at a different tempo than the current session, Beat Detective lets you quickly separate each beat in the loop and conform them to the tempo map (as an alternative to time compressing or expanding the loop, which can alter the pitch and tone of the audio).

Remixes Beat Detective can be used for remixes or creating new rhythms. It can extract tempo from the original drum tracks, or in some instances the original stereo mix. New audio or MIDI tracks can then be conformed to the original material, or the original material can be conformed to new drum tracks, achieving an entirely new feel.

Smoothing Post Production Edits (Audio Only) Beat Detective’s Edit Smoothing can be used to automatically clean up foley tracks that contain many regions requiring trimming and crossfading, effectively removing the gaps of silence between the regions (thus retaining the room tone throughout the track).

---

**Beat Detective Requirements**

Beat Detective is available with Pro Tools HD, LE, and M-Powered.

⚠️ *Pro Tools LE and M-Powered do not support using Beat Detective across multiple tracks. When Beat Detective is applied to multiple tracks, only the top track is edited.*

**RAM Requirements for Beat Detective**

Beat Detective operations can require a large amount of RAM, especially when working with multiple tracks and lengthy selections.

To avoid low memory situations with Beat Detective, do the following:

- If you begin to experience slower Beat Detective response, add more RAM to your computer.
- If your computer does not have the extra RAM, work with shorter selections, or individual tracks.
- Set the Editing preference for Levels of Undo to a smaller value (see “Levels of Undo and Memory” on page 240). Memory-intensive editing operations, such as Edit Smoothing (audio only) with Beat Detective, can use up a large amount of memory when in the Undo queue.

When working with tick-based audio, use Beat Detective’s Region Separation command to quickly separate audio regions into individual “hits” (or slices). You can also create a region group of the separate regions to facilitate editing and arranging.

Pro Tools LE and M-Powered do not support using Beat Detective across multiple tracks. When Beat Detective is applied to multiple tracks, only the top track is edited.
The Beat Detective Window

The Beat Detective window appears as shown in Figure 16, below.

![Figure 16. Beat Detective (Pro Tools HD shown)](image)

**To open the Beat Detective window:**

- Choose Event > Beat Detective.
- or –
- Press Control+8 (Windows) or Command+8 (Macintosh) on the numeric keypad.

Beat Detective is a floating window that can be left open while working. This lets you adjust the controls in real time during playback, while viewing the beat triggers that appear in your selection in the Edit window.

**Beat Detective Modes**

The Beat Detective window is divided into three sections: Operation, Selection, and Detection. Depending on the Operation mode, the controls in the Action section change. The Selection options for Beat Detective are available in each of the Operation modes.

The Beat Detective modes include the following:

- **Operation** Lets you choose to analyze either MIDI or audio material.
- **Bar Beat Marker Generation** Generates Bar Beat Markers corresponding to transients detected in the audio selection.
- **Groove Template Extraction** Extracts the rhythmic and dynamic information from audio, and saves this information to the Groove Clipboard, or as a DigiGroove template.
- **Region Separation (Audio Only)** Separates and creates new regions based on transients detected in the audio selection.
- **Region Conform (Audio Only)** Conforms all separated regions within the selection to the current tempo map. Beat Detective can conform audio regions to groove templates (such as DigiGroove templates) in addition to standard quantization.
- **Edit Smoothing (Audio Only)** Fills the gaps between conformed regions by automatically trimming them, and if you choose, inserts cross-fades.
Defining a Beat Detective Selection

Whether you will be generating Bar|Beat Markers, extracting a DigiGroove template, or separating regions to be conformed, you must always define the audio or MIDI selection to be analyzed. The Beat Detective window provides tools to define and capture the selection range, time signature, and swing (sub-division) content for the selected audio.

To ensure the best possible results with Beat Detective, make sure the selected passage starts exactly on the attack of the first beat.

For Beat Detective to generate beat triggers that are metrically accurate, the length and meter of the selection must be correctly defined. In addition, the selection should not contain any meter or tempo changes.

Use Loop playback to check the accuracy of your selection.

To define a selection for Beat Detective:

1. In the Edit window, select a range of audio or MIDI material in a single track or in multiple tracks.

Pro Tools LE does not support using Beat Detective across multiple tracks. When Beat Detective is applied to multiple tracks, only the top track is edited.

To keep the Edit selection intact while playing or looping from any location, deselect Options > Link Timeline and Edit Selection.

Make sure the selection’s start and end points fall cleanly on the beat. To zero in on an audio region’s start and end points, zoom to the sample level and use the Tab to Transients option (see “Tabbing to Transients” on page 283).

To avoid losing an existing selection, save and recall an Edit selection by saving it as a Memory Location. See “Memory Locations and Markers” on page 382.

2. Choose Event > Beat Detective.

3. You must define or capture the selection every time you make a new selection or change the tempo map. To define the selection range, do one of the following:
   - If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.
   - If the tempo and meter of the audio selection do not match the session’s default tempo and meter, and you are unsure of the length of the material, enter the Time Signature and the Start Bar|Beat location; then start playback, and click the Tap button repeatedly to automatically calculate the End Bar|Beat. When using Tap with long selections, continue to tap until the End Bar|Beat stabilizes. Once stabilized, you may need to manually adjust the number to the nearest bar boundary.
• If the selection’s tempo and meter match the session tempo and meter (see “Calculating Tempo with Beat Detective” on page 395), and it aligns correctly with the session’s bars and beats, click the Capture Selection button. The correct Time Signature, and Start Bar|Beat and End Bar|Beat values will be filled in automatically.

Calculating Tempo with Beat Detective

If you know the meter, and start and end points of the audio selection, use Beat Detective to calculate its tempo.

To calculate a selection’s tempo with Beat Detective:

1. Make an audio selection in the Edit window and define the selection in the Beat Detective window as described in “Defining a Beat Detective Selection” on page 394.

2. Select Bar|Beat Marker Generation mode.

3. In the Detection section (Normal mode), click Analyze.

4. Set the Sensitivity slider set to 0%

5. Click Generate.

Bar|Beat Markers are automatically generated at the beginning and end of the selection, indicating the material’s tempo and meter.

Beat Detective, Selection options

As long as the audio material is correctly aligned with the session’s tempo map, use Capture Selection each time you make a new selection or make any changes to the tempo map (such as changing tempo or meter).

⚠️ The Selection definition is not retained when a session is closed and re-opened

4. To improve Beat Detective’s accuracy in analyzing swung notes, select the Contains option that indicates the smallest sub-division of the beat contained in the selection. The Contains option includes quarter-notes, eighth-notes, sixteenth-notes (the default setting), thirty-second-notes, and a triplet modifier. The selected Contains option determines the groove template grid locations for DigiGroove templates.
Generating Beat Triggers

Once you have accurately defined the selection range, Beat Detective can generate beat triggers based on detected MIDI notes or audio peak transients. The range and type of transients found can be adjusted with the Detection settings, allowing you to zero in on the bars, beats, and sub-beats in the material, while avoiding the non-rhythmic content.

To generate beat triggers from an audio selection:

1. In the Edit window, make an audio selection.
2. Select Audio from the operation pop-up menu.
3. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
   - Region Separation (audio only)
4. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 394.
5. From the Analysis pop-up menu, choose one of the following detection algorithms:
   - High Emphasis, works well with high frequency, inharmonic material, such as cymbals and hi-hats, while avoiding low frequency material.
   - Low Emphasis, works well with low frequency material, such as bass guitar and kick drum, as well as with most harmonic material, such as piano or rhythm guitar.
6. Click the Analyze button.
7. Depending on the rhythmic content of the selection, set the Resolution to Bars, Beats, or Sub-Beats.
8. Adjust the Sensitivity slider until beat triggers appear on the beats and sub-beats in the selection.

   Bar triggers are indicated with thick lines, beat triggers with medium lines, and sub-beat triggers with thin lines.

9. You can zoom to the sample level and click the Scroll Next button to scroll to the next trigger within the selection. To scroll to the previous trigger, Alt-click (Windows) or Option-click (Macintosh) the Scroll Next button (see “Navigating Consecutive Beat Triggers” on page 401). This is useful to confirm that the beat triggers are appearing in the appropriate locations. If false triggers appear between the beats or sub-beats (representing non-rhythmic material) delete them (see “Deleting Beat Triggers” on page 399), or reduce the Sensitivity value.
10. To display the metric locations for the triggers, select the Show Trigger Time option.
11. If you cannot get the beat triggers to appear at the right locations, repeat steps 5–10 trying the other Analysis algorithm (High or Low Emphasis).
To generate beat triggers from a MIDI selection:

1. In the Edit window, set the MIDI track you wish to use to Notes View.
2. Make a selection across a range of MIDI data. Make certain that the selection start and end points are at musically relevant locations, such as barlines.
3. Choose Event > Beat Detective.
4. Select MIDI from the operation pop-up menu.
5. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
6. Define the selection range. If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.
7. If your MIDI track contains chords, choose one of the following MIDI chord recognition algorithms from the Analysis pop-up menu:
   - Last Note
   - First Note
   - Loudest Note
   - Average Location
   - Highest Note
   - Lowest Note
8. Click the Analyze button.

MIDI Chord Recognition

Since MIDI notes in a chord may be played at slightly different moments, Beat Detective interprets notes that are close together (closer than half the time value that is set in the Selection Contains field) as a chord.

MIDI chord analysis

Beat Detective will use the criteria you set in the Analysis pop-up menu to interpret the location of the beat in relation to the chord.

- **Last Note** Sets the beat trigger to the start of the last note played in the chord.
- **First Note** Sets the beat trigger to the start of the first note played in the chord.
- **Loudest Note** Sets the beat trigger to the start of the note in the chord played with the highest velocity.
- **Average Location** Sets the beat trigger to a point that represents the average between the start of the first note played in the chord, and the last note played in the chord.
- **Highest Note** Sets the beat trigger to the start of the highest note played in the chord.
- **Lowest Note** Sets the beat trigger to the start of the lowest note played in the chord.
Realign Session

Beat Detective’s Realign Session function lets you generate Bar|Beat markers without tick-based material shifting. This is useful if you want to extrapolate Bar|Beat markers from tick-based material to align the tempo map and Bar|Beat grid to the tick-based material.

You can also switch tick-based material, such as a MIDI performance, to be sample-based and then manually insert Bar|Beat markers.

Generating Bar|Beat markers in sessions with tick-based material, such as MIDI tracks and tick-based audio tracks, can cause the tick-based material to shift in absolute time. This can be useful if you want to align the tick-based material to Bar|Beat markers generated from sample-based material.

When you generate Bar|Beat Markers in a session that contains tick-based audio or MIDI, Beat Detective gives you the option to preserve the position of the session’s tick-based material, or to allow the material to shift.

To generate Bar|Beat Markers with Beat Detective in a session with tick-based tracks:

1. In the Edit window, make an audio or MIDI selection.
2. In the Beat Detective window, select Bar|Beat Marker Generation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 394.
4. Set the Detection resolution to Bars or Beats.
5. Click the Generate button.
6. In the Realign Session dialog, choose Preserve Tick Position if you wish to let the tick-based material shift in absolute time. This option maintains prior Beat Detective functionality.
   – or –
   Choose Preserve Sample Position if you wish to have the tick-based material maintain its absolute position. This option can be useful when adding a meter and tempo map to a freely played performance.
7. Click OK.

Tips for Getting Useful Beat Triggers

Use the following tips to verify beat triggers:

- To focus on a particular area in the selection, unlink the Timeline and Edit Selections and set the playback range by clicking or dragging in any Timebase ruler.
- Check the thickness of the beat triggers to see if they align properly with the audio material. Thick triggers fall on barlines, medium triggers fall on beats, and thin triggers fall on sub-beats.
- Select the option for Show Trigger Time and see if the (assumed) metric locations of the triggers align with the material. A false trigger should be moved or deleted because it can cause subsequent triggers to appear in the wrong locations (see “Editing Beat Triggers” on page 399).
- Consider whether lengthy selections should first be broken down into smaller selections, which could be more easily managed. For example, working in 8- or 4-bar sections might yield better results more quickly.
Beat triggers are preserved when switching between audio and MIDI modes. This allows using MIDI triggers for editing audio, or collecting triggers from combinations of MIDI and audio tracks (Pro Tools HD only).

For selections across multiple tracks, consider whether it may be easier to work with them individually, or in Collection mode (Pro Tools HD only). See “Detection (Normal) and Collection Mode” on page 410.

**Beat Detective LE does not support multiple tracks. When Beat Detective LE is applied to multiple tracks, only the top track is edited.**

### Editing Beat Triggers

Even though Beat Detective offers a great deal of flexibility in how transients are detected, there may be times when beat triggers must be deleted, moved, or manually inserted. Additionally, triggers can be promoted so they are retained at lower sensitivity settings.

### Deleting Beat Triggers

False triggers, which do not represent an actual beat or sub-beat in the source material, may appear when raising the Sensitivity slider to detect quiet material. In these instances you can locate and manually delete any false triggers.

**To delete a beat trigger:**

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Locate the false trigger you want to delete. Transients for false triggers usually have smaller peaks than the other trigger points, and typically fall between the sub-beats.

3. Alt-click (Windows) or Option-click (Macintosh) the trigger to delete it.

**Moving Beat Triggers**

You can adjust the placement of triggers to allow for the attack of their transients, or to compensate for an individual transient that is slightly ahead of or behind the beat.

**To move a beat trigger:**

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Locate the beat trigger you want to move and drag it left or right.

---

**Chapter 21: Beat Detective 399**
Inserting Beat Triggers

If an important beat or sub-beat is not detected, because it is too quiet, you can manually insert a beat trigger.

To insert a beat trigger:

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Click in the selection where you want to insert the new trigger. After inserting a beat trigger, you can drag it left or right to adjust its placement (see “Moving Beat Triggers” on page 399).

If you click too close to an existing trigger, the existing trigger will be moved to the new location.

Promoting Beat Triggers

To ensure that important beat triggers do not disappear when lowering the Sensitivity value, you can promote them. This is useful if a selection has numerous false triggers (too many to bother deleting) at a Sensitivity level where crucial, necessary beat triggers are also displayed. If lowering the Sensitivity slider causes the needed triggers to disappear, simply promote them first.

To promote a beat trigger:

1. Raise the Sensitivity slider until the desired transient is detected and a beat trigger appears.
2. Control-click (Windows) or Command-click (Macintosh) the beat trigger to promote it.
3. If necessary, repeat steps 1–2 to promote additional beat triggers.
4. Lower the Sensitivity slider to a value where the false triggers disappear.

Once beat triggers are promoted, they will only disappear if the Sensitivity value is set to 0%. To demote all beat triggers in the selection—returning them to their original state—click the Analyze button.

Redefining a Beat Trigger’s Metric Location

It is vital that beat triggers are accurately placed at the correct metric location. If a detected transient is slightly off the beat, Beat Detective may assign it, as well as other transients in the selection, to the wrong metric location.

For example, if you have a bass track where a note was intended to be a downbeat, but was played too early, Beat Detective may define its location as occurring a little before the downbeat. If you then separate and conform the region containing this note, it will be moved to the wrong location. Subsequent regions may be moved to the wrong locations as well.

If a beat trigger is not assigned the correct metric location, relocate it using Identify Trigger.

To change the metric location of a beat trigger:

1. Double-click the beat trigger you want to relocate. The Identify Trigger dialog opens.
2. In the Identify Trigger dialog, enter the correct location for the trigger, then click OK.
Navigating Consecutive Beat Triggers

Use the Scroll Next button to move from the currently selected beat trigger to the next beat trigger. To move to the previous beat trigger, Alt-click (Windows) or Option-click (Macintosh) the Scroll Next button. This is particularly useful for editing consecutive beat triggers when zoomed in at the sample level.

Generating Bar|Beat Markers with Beat Detective

Once Beat Detective has accurately detected the peak transients in the audio selection and accurately generated beat triggers, the triggers can be converted to Bar|Beat Markers. Bar|Beat Markers generated by Beat Detective create a tempo map that can be used throughout the session.

Once a tempo map has been generated, other audio regions and MIDI notes can be conformed to the Bar|Beat Markers generated by Beat Detective.

If you want to match the audio material to the session’s existing tempo map or a groove template, do not generate Bar|Beat Markers from the material. Instead, use Beat Detective to separate and conform the material (see “Separating Regions with Beat Detective (Audio Only)” on page 404).

If you are simply aligning a sloppy part to the other tracks, you probably do not need to generate Bar|Beat markers.

To generate Bar|Beat Markers with Beat Detective:

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Bar|Beat Marker Generation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 394.
4. Set the Detection resolution to Bars or Beats, and configure the Detection settings so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 396).
5. Click the Generate button.

Bar|Beat Markers are generated, based on the beat triggers, and appear in the Tempo ruler.

Working with Sub-Beats

Tempo is derived from Bar|Beat Markers. Groove, or feel, is derived from Sub-Beats—the deviation of subdivisions of the beat from the strict tempo grid determines the groove or feel.

To extract the groove from a selection, set the Detection Resolution to Sub-Beats. This ensures that the inner rhythms within each bar (if they indeed exist) are represented when generating
Bar|Beat Markers. These Bar|Beat Markers can then be used to quantize other audio regions or MIDI tracks, thereby conforming to the Bar|Beat Markers generated by Beat Detective.

⚠️ When quantizing regions or MIDI notes to Bar|Beat Markers on sub-beats that represent a swing feel, make sure to use a straight quantize value (with the Swing option for Quantize disabled).

DigiGroove Templates

Beat Detective allows the fine timing nuances of a rhythmic performance to be extracted and saved as a groove template, called a DigiGroove template. DigiGrooves can be saved locally to the Groove Clipboard, or saved to disk as DigiGrooves.

Groove templates can be used to transfer the feel of a particular performance to:
- Selected audio regions using Groove Conform (see “Groove Conform” on page 407).
- Selected MIDI data using Groove Quantize (see “Groove Quantize” on page 443).

Groove templates are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Beat Detective analyzes an audio selection for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template.

When creating DigiGroove templates, Beat Detective also analyzes the dynamics of a performance. MIDI velocity data is saved from MIDI tracks, and accents and peak levels in audio data are incorporated into the groove template as velocity data, which can be applied to change the dynamics of MIDI tracks.

Beat Detective translates the amplitude of signals in audio tracks to MIDI velocity according to a linear scale. For example, a 0 dBFS signal equals a MIDI velocity of 127, a signal at –6 dBFS equals a MIDI velocity of 64, a signal at –12 dBFS equals a MIDI velocity of 32, and –48 dBFS equals a MIDI velocity of 1.

Capturing this information is very important to preserving the feel of a performance, and can add life to MIDI tracks that lack dynamics.

⚠️ Beat Detective only captures duration data from MIDI tracks, not from audio tracks.

To extract a Groove Template:

1. In the Edit window, make an audio or MIDI selection. The selection should consist of one or more complete bars, starting and ending on downbeats.

2. In the Beat Detective window, select Groove Template Extraction mode.

3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 394.

4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 396).

5. Click the Extract button.
In the Extract Groove Template dialog, enter comments about the groove. You can enter a maximum of 255 characters to describe the groove. Comments can be viewed using the Show Info button in the Beat Detective window.

Do one of the following:

- To save the extracted template for use in the current session, without writing the template file to disk, click Save To Groove Clipboard. (This template will be lost when you close the current session.)
- To save the extracted template to disk in order to use it in other sessions or share it with other Pro Tools users, click Save To Disk. Enter a name for the template and click Save. (Do not change the location of DigiGroove template files and folders or they will not be available in your sessions.)
- Click Cancel to cancel without saving the template.

Swing Content for Generating Groove Templates

When defining swing content of the selection, select the Contains eighth-note option if the audio selection has a heavily swung eighth-note groove. If the audio selection has relatively straight eighth-notes, use the Contains sixteenth-note option. This lets the resultant DigiGroove template be applied more easily elsewhere. Although a groove might be based upon non-swung eighth-note material, you might want to apply the template to material that contains sixteenth-notes. If a template only has eighth-note resolution, but the material being conformed contains sixteenth-notes, adjacent sixteenth-notes will be mapped to the same eighth-note location.

Groove Extrapolation

Beat Detective’s ability to extract tempo data from a wide range of material is enhanced by its powerful “groove extrapolation” logic. Groove extrapolation automatically generates beat triggers for inclusion in groove templates even if a peak transient is not detected. For example, a drum loop might not have a hit on beat 3, consequently no peak transient is detected and no beat trigger is generated. Beat Detective will extrapolate from other beat triggers in the selection and create a trigger for beat 3 in the groove template.

In addition, extrapolated triggers preserve the feel of triggers generated from detected peak transients. For example, if a bar of kick drum detected three beat triggers, all of which were 20 ticks ahead of the beat, any extrapolated beat triggers will also be mapped 20 ticks ahead of the beat.

Use folders and subdirectories to organize DigiGroove templates. However, be sure they are always located in C:\Program Files\Digidesign\Pro Tools\Grooves (Windows) or Applications/ Digidesign/Pro Tools/Grooves (Macintosh). Groove template files located elsewhere will not be available in either Groove Quantize or Beat Detective.
Separating Regions with Beat Detective (Audio Only)

Once beat triggers appear in your selection, they can be used to define start and end points for new regions that can be separated automatically. The new regions can then be conformed to the session's existing tempo map, or to a groove template.

If you want to clean up the timing for the selection, without affecting the tempo, make sure to first calculate the tempo by generating Bar|Beat Markers (see “Calculating Tempo with Beat Detective” on page 395).

To separate regions with Beat Detective:

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Region Separation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 394.
4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 396).
5. Click the Separate button.

Regions are separated based on the detected beat triggers.

Trigger Pad

When separating regions, the Beat Detective window displays an option called Trigger Pad.

Detection settings, Region Separation mode

Enter a value (0–50 ms) in this field to pad region start points—where the point of separation is located in relation to the beat trigger (transient). This creates a space between the region start point and the region sync point, thereby ensuring that the attack portion of the material remains intact.

Separated region with 20 ms Trigger Pad

When conforming separated regions, the region sync point, not the region start point, determines where the region is placed.

For more information on region sync points, see “Sync Points” on page 303.
Separating Multiple Tracks

You can use beat triggers from a single track, or subset of tracks, to separate a group of tracks.

⚠️ *Beat Detective LE does cannot be used across multiple tracks. When Beat Detective LE is applied to multiple tracks, only the top track is edited.*

In the following example, the defined selection is a drum loop consisting of two bars of 5/4. The kick, snare, hi-hat, and overhead microphones are recorded to separate tracks.

Analyzing the loop’s kick drum track, with Detection Resolution set to Beats, Beat Detective places beat triggers at the transients on beats 1 and 4 (see Figure 17).

Extending the selection to the snare, hi-hat, and overhead microphones tracks, and then performing the separation, results in separated regions in each of the drum tracks at the same location, based on the beat triggers from the kick drum track (see Figure 18).

The separated regions can then be conformed as a group.

You can also utilize Collection mode (Pro Tools HD only) when working with multiple tracks. Collection mode lets you analyze and detect triggers on tracks individually, and if you choose, add only the unique triggers from the current track to the overall collection. For more information, see “Detection (Normal) and Collection Mode” on page 410.
Conforming Regions with Beat Detective (Audio Only)

After regions have been separated with Beat Detective, the regions can then be conformed using one of two modes:

**Standard Conform** Uses the session’s current tempo map (Grid)

**Groove Conform** Uses groove templates.

Beat Detective will conform any selected region, whether or not it was separated with Beat Detective. However, in order to successfully conform regions with Beat Detective, the region start points must correspond to the start of the material that will align with the session’s bars and beats. This should generally not be a problem if the regions were separated with Beat Detective (rather than manually separated or trimmed).

**Standard Conform**

This is similar to using the Region > Quantize to Grid command, but with one important difference: With a single operation, Beat Detective can adjust the position of all regions, whether they have a straight or swing feel.

To conform regions using Standard Conform:

1. In the Beat Detective window, select Region Conform mode.
2. Make sure Standard is selected.
3. In the Edit window, if not already selected, select the separated regions you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.
4. In the Beat Detective window, define or recapture the selection as described in “Defining a Beat Detective Selection” on page 394.
5. To affect how strongly the regions are conformed to the Grid (tempo map), select the Strength option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the regions.
   - Higher percentage values align the regions more tightly to the tempo map, with 100% aligning precisely to the tempo map.

   ![Beat Detective, Standard Conform options](image)

To “tighten up” the original feel, while retaining it, set the Strength option to 85–88%.

6. To affect which regions are conformed, select the Exclude Within option and specify a percentage value with the slider or by typing in a value:
   - Lower percentage values ensure that regions further away from the Grid are conformed, while those closer to the Grid are not.
   - Higher percentage values ensure that regions closer to the Grid, as well as those further away, are conformed.

   To “tighten up” the original feel, while retaining it, set the Exclude Within option to 10–15%.
7 To achieve a swing feel for the conformed regions, select the Swing option and whether the swing is based on eighth-notes or sixteenth-notes, then specify a percentage value with the slider or by typing in a value:
  • Smaller percentage values yield less swing, with 0% yielding none.
  • Larger percentage values yield more swing, with 100% yielding a triplet, swing feel.
  • Percentage values between 100–150 move the regions beyond a triplet, swing feel, toward the next sixteenth-note boundary (provided the Swing note value is set to eighth-notes).

8 Click the Conform button to automatically conform all regions in the selection.

9 Audition the new conformed regions by clicking Play in the Transport window.

10 If necessary, select Edit > Undo, and repeat steps 4–8 trying a different set of Conform settings.

   – or –

If necessary, apply Edit Smoothing (see “Edit Smoothing (Audio Only)” on page 408).

**Groove Conform**

Instead of using a grid based on the session’s tempo map, Groove Conform uses a grid based on a groove template, or DigiGroove. DigiGrooves can be used to apply the feel of a captured passage to the selected audio regions. For information about creating DigiGroove templates, see “DigiGroove Templates” on page 402.

To conform regions using Groove Conform:

1 In the Beat Detective window, select Region Conform mode.

2 Select Groove.

   ![Groove Conform](image)

   **Regions conformed with Beat Detective**

3 In the Edit window, if not already selected, select the separated regions you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.

4 In the Beat Detective window, define or recapture the selection as described in “Defining a Beat Detective Selection” on page 394.

   ![Groove Conform options](image)

   **Beat Detective, Groove Conform options**

   - When using Groove Conform, the captured selection must not include Bar|Beat Markers. Otherwise, the accuracy of the Groove Template will be compromised.

5 From the Groove Template pop-up menu, select the Groove Clipboard or a saved groove template (for information on creating groove templates, see “DigiGroove Templates” on page 402).
6 To see comments about the selected template, click Show Info.

7 To affect how strongly the regions are conformed to the groove template, select the Timing option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the regions.
   - Higher percentage values align the regions more tightly to the groove templates grid, with 100% aligning precisely to the template grid.
   - If the slider is set to 200%, regions move to a location that is twice the difference between the original region location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073; a slider value of 200% shifts the note to 1|1|086.

8 If desired, enable the Pre-Process using Standard Conform option. With this option enabled, Beat Detective conforms regions to the current Standard Conform settings before applying the groove template. With material in which the performance was not accurate, Pre-Process using Standard Conform can lead to better results by ensuring that the performance is accurately mapped to the correct bars, beats, and sub-beats before the groove template is applied. Experimentation is the best way to determine when it is appropriate to use this option.

9 Click the Conform button to automatically conform all regions in the selection.

10 Audition the new conformed regions by clicking Play in the Transport window.

11 If necessary, select Edit > Undo, and repeat steps 4–9 trying a different groove template or Groove Conform settings.

   – or –

If necessary, apply Edit Smoothing (see “Edit Smoothing (Audio Only)” on page 408).

---

**Edit Smoothing (Audio Only)**

After regions are conformed, there may be gaps between the regions. These gaps can cause the material to sound unnatural on playback.

![Smoothing](image)

**Beat Detective, Smoothing options**

Beat Detective can automatically fill the gaps between regions, and even add crossfades if you choose. This Edit Smoothing option can be used with regions that have been conformed, or with a track that contains many regions that need to be trimmed and crossfaded (such as in a sound effects track). This automated process of smoothing region edits can save many hours of tedious editing.
To use Edit Smoothing on conformed regions:

1. In the Beat Detective window, select Edit Smoothing mode.

2. Select one of the following Smoothing options:
   - Select Fill Gaps to trim region end points so that the gaps between regions are filled.
   - Select Fill And Crossfade to trim region end points and automatically add a pre-fade (in ms) directly before each region start point.

3. In the Edit window, if not already selected, select the range of conformed audio regions you want to smooth. Make sure the selection’s start and end points fall cleanly on the beat.

4. Click the Smooth button to smooth the edits for the selected regions.

5. Audition the results by clicking Play in the Transport window.

6. If necessary, select Edit > Undo, and repeat steps 2–5 trying a different Crossfade Length.

Edit Smoothing Creates Sync Points

After smoothing edits with Beat Detective, sync points (corresponding to the material’s start point) are automatically created for the conformed regions. This allows you to later conform the regions to a different tempo map or groove template, or use different Conform settings. However, sync points are only created as they are needed: If gaps between regions are created during Region Conform, Fill Gaps in Edit Smoothing mode will trim regions to fill the gap and a sync point will be created at each region’s original start point. If there is no gap between regions, no sync point will be created by Edit Smoothing.

Consolidating Regions after Edit Smoothing

The process of separating, conforming, and smoothing with Beat Detective can leave tracks with many regions and many crossfades. If you are working with multiple tracks, the density of these edits may lead to system performance problems.

If performance is not an issue, use the Region Group command for easier editing and manipulation of regions. This can be useful for arranging beats that were sliced with Beat Detective, especially if you plan on changing tempos with tick-based audio tracks. For more information on region groups, see “Region Groups” on page 321.
Once you are satisfied with the results from Beat Detective, it is recommended that you flatten the tracks with the Consolidate command. For all regions selected, Consolidate creates a single, contiguous audio file to reduce the session’s edit density. See “Consolidate Command” on page 348.

⚠️ Before consolidating a large selection across multiple tracks, make sure there is enough RAM available. See “RAM Requirements for Beat Detective” on page 392.

**Detection (Normal) and Collection Mode**

(Pro Tools HD Only)

In some instances, it may be difficult for Beat Detective to successfully analyze multiple tracks with the same Detection settings. With Beat Detective’s Collection mode, you can collect a set of beat triggers from different tracks, each with different Detection settings, and use the collection of triggers to generate Bar|Beat Markers or DigiGroove templates, or separate new regions. Collection mode is the only way to analyze and create beat triggers on one track, and apply them to another track.

This method of selectively adding beat triggers from separate analysis passes on different tracks, until you get only the triggers you want, is potentially much more effective than manually deleting, inserting, or adjusting incorrect or false triggers.

⚠️ Beat Detective LE does not support Collection Mode.

**Drum Tracks and Collection Mode**

Suppose you have drum tracks for kick, snare, hi-hat, and overhead mics. If you analyze a selection across all of the tracks, you may get many false triggers when you raise the Sensitivity slider high enough to capture the hi-hat material (coming mainly from the tracks for the overhead mics).

However, if you analyze only the track for the overhead mics, the resulting beat triggers are slightly later than the material on the other tracks (since it will take more time for the sound to reach the overhead mics). If you then extend the selection to the other drum tracks and separate them, the regions from the kick, snare, and tom tracks will be cut slightly late (see Figure 19 below).

Using Collection mode, you can analyze each drum track separately, one at a time, optimizing the Detection settings for each track until you get the triggers you want. The triggers for each track can be added successively to the collection, or you can choose to collect only the unique triggers from a track. The collection of triggers that results can then be used to generate Bar|Beat Markers or a DigiGroove template, or separate new regions.

![Figure 19. Overhead mics generate late beat triggers](image-url)
Using Collection Mode

Collection mode is available in Bar|Beat Marker Generation, Groove Template Extraction, or Region Separation mode (audio only), and is accessed by clicking the Collection Mode button in the Detection section.

To use Collection mode:

1. In the Edit window, make an audio selection on a single track. Make sure the selection’s start and end points fall cleanly on the beat.

2. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
   - Region Separation (audio only)

3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 394.

4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 396).

5. Click the Collection Mode button.

6. In the Detection (Collection Mode) section, click Add to add all the current beat triggers to the collection.

7. Click the Normal Mode button and move the selection to the next track you want to analyze. Make sure to keep the selection range constant for each track.

8. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 396).

9. Click the Collection Mode button again.
Do one of the following:

■ In the Detection (Collection Mode) section, click Add Unique Triggers to add only the unique triggers from the track to the collection.

■ Click Add All to add all triggers to the collection.

■ Click Clear All to clear all triggers from the collection.

Each new set of triggers added to the collection appears in a different color. If successive triggers in the collection are located closely together (for example, because of microphone leakage), Beat Detective keeps only the earlier triggers (see Figure 20 on page 412).

1. Repeat steps 7–n for each additional track you are analyzing.

The beat triggers stored in the Collection mode are saved with sessions. Therefore, when a session is opened later, the previous collection material is still there (until it is cleared).

2. Once the desired beat triggers have been added to the collection, you can use them to generate Bar|Beat Markers or groove template, or separate regions. However, this must be done from the Collection Mode sub-pane (when the triggers are displayed in multiple colors).

To separate regions across multiple tracks, make sure to extend the selection to any additional tracks before separating.

Figure 20. Overhead mic track displaying a collection of beat triggers containing unique triggers generated from the kick, snare, and hi-hat tracks
Part V: MIDI Editing
Chapter 22: MIDI Editing

Pro Tools provides powerful MIDI editing tools. You can create and edit individual MIDI notes and controller events with the Pencil, Trim, and Grabber tools in the Edit window. You can use the various MIDI operations (such as Quantize, Transpose, Change Velocity, and Change Duration) to destructively transform groups of MIDI notes to affect pitch, timing, and phrasing. You can also use Real-Time Properties to non-destructively affect MIDI on playback or playthrough. Pro Tools also provides numerous zoom and view tools that are optimized for MIDI editing.

For information on region-specific editing for both MIDI and audio, see Chapter 17, “Working with Regions and Selections.”

Mirrored MIDI Editing

Mirrored MIDI Editing lets you edit MIDI regions and have your edits apply to every MIDI region of the same name. This can be particularly useful when editing looped MIDI regions.

To enable Mirrored MIDI Editing:
- Select Options > Mirror MIDI Editing.
- or -
- Enable the Mirrored MIDI Editing button in the Edit window.

In Mirrored MIDI Editing mode, the Mirrored MIDI Editing button will blink Red once as an edit is made to alert you that your edit is being applied to more than one region.

To disable Mirrored MIDI Editing:
- Deselect Options > Mirror MIDI Editing.
- or -
- Disable the Mirrored MIDI Editing button in the Edit window.

⚠️ If Mirrored MIDI Editing mode is disabled, and you edit notes of looped regions in notes view, the edit flattens the loop. Similarly editing region groups separates the region groups.
The Pencil Tool

The Pencil tool is useful for creating and editing MIDI data. The first five Pencil tool shapes (Freehand, Line, Triangle, Square, and Random) can be used to enter pitches with varying durations and velocities (note velocities are determined by the Pencil tool shape). The various Pencil tool shapes can be particularly useful for drawing and editing different types of MIDI control data—for example, try using Line for volume, Triangle for pan, Freehand for pitch bend, and Square or Random for velocity.

Freehand
When in Notes View, the Freehand shape inserts a single MIDI note whose velocity is defined by the Default Note On Velocity MIDI preference. The pitch, location, and duration of the note are determined by where on the MIDI track you click and release with the mouse.

When editing MIDI velocities or continuous controller data, the Freehand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

Line
When in Notes View, the Line shape inserts a series of MIDI notes on a single pitch whose velocities are defined by the Default Note On Velocity MIDI preference. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Line shape draws in a straight line from click to release. MIDI continuous controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

Triangle
When in Notes View, the Triangle shape inserts a series of MIDI notes on a single pitch whose velocities oscillate between the defined Default Note On Velocity MIDI preference and 127 according to a triangle pattern. The duration of each note is determined by the current Grid value.
When editing MIDI velocities or continuous controller data, the Triangle shape draws a triangular pattern that changes direction according to the current Grid value. MIDI controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

**Square**

When in Notes View, the Square shape inserts a series of MIDI notes on a single pitch whose velocities alternate between the defined Default Note On Velocity MIDI preference and 127. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Square shape draws a square pattern that repeats at a rate based on the current Grid value.

**Random**

When in Notes View, the Random shape inserts a series of MIDI notes on a single pitch whose velocities change randomly within the range between the defined Default Note On Velocity MIDI preference and 127. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Random shape draws a series of random values that change at a rate based on the current Grid value.

---

### Custom Note Duration

The Custom Note Duration command lets you define the default note duration for inserting notes manually.

**To select a Custom Note Duration:**

1. Click the Pencil tool icon in the Tool Bar for the Pencil tool shape pop-up menu.

2. Select Custom Note Duration. A note icon (the Custom Note Duration button) will appear below the Pencil tool icon in the Tool Bar.

3. Click the note icon for the Custom Note Duration pop-up menu, and select a note duration. The note icon changes to show the selected note value.
Setting the Grid Value

When inserting MIDI notes with the Pencil tool, the Grid value determines the duration of each note, or other characteristics, based on the Pencil tool shape (see “The Pencil Tool” on page 416).

To set the Grid value for MIDI editing:

1. Set the Main Time Scale to Bars:Beats (see “Setting the Main Time Scale” on page 233).

2. From the Grid Value pop-up menu, select a note value (such as 1/4, 1/8, or 1/16).

3. Verify the default session meter and tempo (see “Setting the Default Meter” on page 166 and “Setting the Default Tempo” on page 167).

For more information on Grid mode, see “Grid” on page 247.

Inserting MIDI Notes

In addition to recording, step recording, and importing MIDI into Pro Tools, you can manually insert MIDI notes using the Pencil tool.

To insert a MIDI note:

1. Set the MIDI or Instrument track to Notes View.

2. Select the Pencil tool and make sure it is set to Freehand. The cursor will change to the Pencil tool when located over the playlist area of a MIDI or Instrument track in Notes View.

3. To insert quarter notes on the beat, set the Main Time Scale to Bars:Beats, and set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).

4. Move the Pencil tool into the playlist area for the MIDI or Instrument track. Use the Edit window’s ruler and the track’s mini-keyboard to locate the pitch and time location you want.

When using the Pencil tool, the Cursor location and value are displayed in the Options Bar.

With the Smart Tool active (see “Using the Smart Tool” on page 259), Start-click (Windows) or Control-click (Macintosh) to change the cursor to the Pencil tool and insert MIDI notes; Option-Control-click (Macintosh) or Alt-Start-click (Macintosh) to delete notes.

With the Grid mode enabled, the start point of the MIDI note snaps to the nearest Grid boundary by default. Control-click (Windows) or Command-click (Macintosh) with the Pencil tool to temporarily disable snap to grid.
The velocity for inserted notes is determined by the Default Note On Velocity MIDI preference. When in Grid mode, the duration of the note is determined by the Edit window’s Grid value. The duration of the note can also be determined by the Custom Note Duration value (see “Custom Note Duration” on page 417).

If the Play MIDI Notes when Editing preference is enabled, each inserted note will sound.

The Pencil tool can be dragged after clicking (and before releasing) to adjust the note’s pitch or duration. Click and drag right to lengthen the note without changing its start point. Click and drag left to shorten the note without changing its end point.

The Line, Triangle, Square, and Random Pencil tool shapes can be used to enter a series of identical pitches with varying velocities. The length and spacing for the inserted notes are determined by the current Grid value, or by the Custom Note Duration value. The note velocities are determined by the Pencil tool shape.

Use the Square shape for alternating velocities of loud and soft. Use the Triangle shape for a ramp up and down of velocities. The Line shape enters notes with identical velocities.

**To insert a series of notes with random velocities:**

1. Set the MIDI or Instrument track to Notes View.
2. Select the Pencil tool and make sure it is set to Random.

**Pencil tool set to Random**

3. Set the Main Time Scale to Bars:Beats. In addition, set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).

With these settings, the inserted notes will be spaced one quarter note apart.

4. Click at the point where the first note will be inserted and drag to the right until you have the number of notes you want.

**Inserting a series of notes with the Pencil tool**

---

**Manually Editing MIDI Notes**

All aspects of a MIDI note can be edited from the Edit window, including start and end points, duration, pitch, and velocity. The Selector, Grabber, and Pencil tools can operate on individual notes or groups of notes.

**Selecting MIDI Notes**

MIDI notes must be selected, before they can be edited.
To select MIDI notes, do one of the following:

- With the Pencil tool or any Grabber tool, Shift-click each note.
- With any Grabber tool, move the cursor to where there are no notes (the Marquee appears) and click and draw a rectangle around the group of notes.

Selecting notes with a Grabber tool

When using a Grabber tool, if any portion of the rectangle touches a note (either its start or end point), the note is included in the selection. Selections made with a Grabber tool do not include underlying controller and automation data for the MIDI track.

- With the Selector tool, drag across a range of notes.

Selecting notes with the Selector tool

When using the Selector tool, a note’s start point must be included in order for it to be selected. When a MIDI or Instrument track is in Notes or Regions View, selections made with the Selector tool include underlying controller and automation data.

To select a single pitch for the entire length of a track:

- Start-click (Windows) or Command-click (Macintosh) a key on a MIDI or Instrument track’s mini-keyboard. The selected note will playback through the MIDI or Instrument track’s assigned output.

Selecting all instances of a note with the mini-keyboard

To select a range of notes on a MIDI or Instrument track:

- Start-Shift-click (Windows) or Command-Shift-click (Macintosh) a bottom key and a top key on a MIDI or Instrument track’s mini-keyboard.
  – or –
- Start-click (Windows) or Control-click (Macintosh) and drag across a range of keys on a MIDI or Instrument track’s mini-keyboard.

Selecting a range of notes with the mini-keyboard

On Windows, Control-Shift-click to play the notes when making a selection on a track’s mini-keyboard.
**To deselect one or more notes from a selection:**

- With the Pencil tool or any Grabber tool, Shift-click the notes so they become deselected.

You can also select notes in the Select/Split Notes window. See “Select/Split Notes” on page 454.

**Transposing Notes**

MIDI notes can be transposed by dragging up or down with the Pencil tool or any Grabber tool. If several notes are selected before dragging, each is transposed.

**To transpose a MIDI note:**

1. Set the MIDI or Instrument track to Notes View.
2. Select the Pencil tool or any Grabber tool.
3. While pressing Shift, drag the note up or down.

Transposing with a Grabber tool

The Shift key ensures that the transposed note retains its start point. While dragging, each new note sounds and the Cursor Location Value indicator (in the Edit window) indicates the number of semitones and direction (+/-) for the transpose.

To transpose a copy of the note, leaving the original unchanged, press Alt (Windows) or Option (Macintosh) while dragging.

**Moving Notes**

Like regions, MIDI notes can be dragged left or right with the Pencil tool or any Grabber tool to change their start point. If several notes are selected before dragging, each is moved.

**To move a MIDI note:**

1. Set the MIDI or Instrument track to Notes View.
2. With the Pencil tool or any Grabber tool, drag the note left or right (press Shift while dragging to preserve the note’s pitch).

As the note is dragged, the Cursor Location Value indicator (in the Edit window) displays the new start point.

If the Edit mode is set to Grid, the dragged note snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

To copy the selected notes, leaving the originals intact, press Alt (Windows) or Option (Macintosh) while dragging.

The placement of MIDI notes can also be adjusted with Shift (see “Shift Command” on page 307) or Nudge (see “Nudging” on page 305).

**Trimming Note Start and End Times**

Like regions, start and end points for MIDI notes can be adjusted with the Trim tool. If several notes are selected when performing the trim, each note is changed.

The Trim tool can also be used on MIDI regions. For more informations, see “Time Compression/Expansion Trim Tool Functionality on MIDI Regions” on page 425.
To change the start or end points for a group of MIDI notes:

1. Set the MIDI or Instrument track to Notes View.
2. Using the Pencil tool or any Grabber tool, Shift-click each note you want to trim.
3. Select the Trim tool. Click the Trim tool popup menu and, if necessary, select “Standard.”

   - or –

   Use the Pencil tool.

4. Move the cursor near the beginning of any of the highlighted notes, so the Trim tool appears. Drag right to shorten the notes, or drag left to lengthen them.

   - or –

   Move the cursor near the end of any of the highlighted notes, so the Trim tool appears. Drag left to shorten the notes, drag right to lengthen them.

If using Grid mode, the dragged start or end point snaps to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the note’s start or end point.

💡 When in Grid mode, you can use the Control key (Windows) or the Command key (Macintosh) to temporarily disable Grid mode.

Notes can also be trimmed with the Trim Region to Selection command (see “Trim Region to Selection Command” on page 293) and the Trim To Insertion command (see “Trimming with Nudge” on page 294).

Manually Editing Note Velocities

When a MIDI or Instrument track is set to Velocity View, each note’s attack velocity is represented with a velocity stalk. The taller the velocity stalk, the higher the velocity value (0–127).

To edit MIDI velocity:

1. Set the MIDI or Instrument track to Velocity View.
2. Select any Grabber tool.
Do one of the following:

- Drag the top (diamond) of the velocity stalk up or down.
- If two notes have the same start time (with velocity stalks on top of each other), Control-drag (Windows) or Command-drag (Macintosh) the actual note up or down.

Drag up to increase the velocity value, or down to decrease it. While dragging, the diamond turns blue and the associated note becomes selected. The dragged velocity values are reflected in the Cursor Location Value indicator (in the Edit windows).

The velocities for a range of notes can be edited with the Pencil tool, either by Freehand or with any of the Pencil tool shapes.

**To draw velocity values that fade in:**

1. Set the MIDI or Instrument track to Velocity View.
2. Select the Pencil tool with the shape set to Line.

3. Click at the beginning of the note range, near the bottom of the velocity range, and drag to the right and up until the line encompasses the range of notes you want to include in the fade.

You can also use the Trim tool to scale the velocities for all selected notes. This is useful if you like the velocity relationship between the notes, but want them to be louder or softer.

_Tip:_ When in Velocity View, the Trim tool can be used to trim note durations in addition to changing velocities.

**To scale velocities with the Trim tool:**

1. Set the MIDI or Instrument track to Velocity View.
2. Using the Selector tool or any Grabber tool, select the range of notes to be edited.
3. With the Trim tool, click near the range of selected notes and drag up or down. Dragging up increases the velocities for each note; dragging down decreases them.
Typing in Note Attributes

When an individual note is selected with the Pencil tool or any Grabber tool, its attributes are displayed in the Event Edit area.

Pitch is listed by note name and octave number. Attack and release velocities are listed with their MIDI values (0–127). Edit Selection Start, End, and Length times are displayed in the Main Time Scale.

To change an attribute for a MIDI note:

1. In the MIDI or Instrument track’s playlist area, select the note with the Pencil tool or any Grabber tool.

2. Click in the Attributes text box and do one of the following:
   - Enter the new value on the numeric keypad.
   - Press the Up or Down Arrow to scroll to the new value.
   - Drag up or down to scroll to the new value.
   - Play the new note value on your MIDI controller keyboard.

Press Forward Slash (/) to move between the fields in the Event Edit area.

Multiple Notes and Event Edit Area

When multiple notes are selected, you can enter values in the Event Edit area fields to affect all selected notes. A triangle (delta symbol) to the left of the displayed note indicates that multiple notes are selected.

A new value in the Start field moves the first note in the selection to that location, with all other notes moving with it.

Values entered in the pitch and velocity fields add to or subtract from the values for all selected notes. For example, to transpose all selected notes down an octave, enter a value of –12 for pitch.

Deleting MIDI Notes

In addition to deleting selected notes with the Clear command in the Edit menu, individual notes can also be deleted with the Pencil tool.

To delete a group of MIDI notes with the Clear command:

1. Using the Grabber or Selector tool, select the notes to be deleted. For details, see “Selecting MIDI Notes” on page 419.

2. Choose Edit > Clear to delete the selected notes. The track’s underlying controller data remains intact.

   – or –

Press the Backspace (Windows) or Delete (Macintosh) key.
To delete a single MIDI note with the Pencil tool:

- With the Pencil tool selected, press Alt (Windows) or Option (Macintosh) so the tool changes to an Eraser, then click the note to delete.

![Deleting a note with Pencil tool](image)

Program change events and Sysex events can also be deleted by Alt-clicking (Windows) or Option-clicking (Macintosh) them with the Pencil tool.

With the Time Compression/Expansion Trim tool, you can move the MIDI region’s start or end point to expand or compress the region, scaling the MIDI data accordingly regardless of the track’s timebase (ticks or samples).

![Scaling a MIDI region with the Time Compression/Expansion Trim tool](image)

**Time Compression/Expansion Trim Tool Functionality on MIDI Regions**

The Time Compression/Expansion Trim tool is useful for matching a MIDI region to the length of another region, a tempo grid, or any other reference point.

![Time Compression/Expansion Trim tool](image)

**Using the Time Compression/Expansion Trim Tool in Grid Mode**

The Time Compression/Expansion Trim tool can be used in Grid mode to match a region to the tempo of a session or a section of a session, or to create “double time” or “half time” performances.

**To use the Time Compression/Expansion Trim tool in Grid mode:**

1. Set the Edit mode to Grid.
2. Set the MIDI or Instrument track to Regions View.
3 Click the Trim tool pop-up menu and select “TCE.”

4 With the Time Compression/Expansion Trim tool, drag the MIDI region’s start or end point to compress or expand the region to the Grid (for example, by quarter notes). A new region is automatically created, and appears both in the playlist and in the Region List.

Using the Time Compression/Expansion Trim Tool in Slip Mode

To use the Time Compression/Expansion Trim tool in Slip mode:
1 Set the Edit mode to Slip.
2 Set the MIDI or Instrument track to Regions View.
3 Click the Trim tool pop-up menu and select “TCE.”
4 With the Time Compression/Expansion Trim tool, drag the MIDI region’s start or end point to compress or expand the region freely. A new region is automatically created, which appears in the playlist and in the Region List.

Using the Time Compression/Expansion Trim Tool in Spot Mode

In Spot mode, clicking with the Time Compression/Expansion Trim tool in a region opens the Spot Dialog. You can specify the location where you want the region to start or end, or the duration of the region, and the region is automatically compressed or expanded as specified.

Continuous Controller Events

Continuous controller events for MIDI and Instrument tracks are displayed in the form of a line graph with a series of editable breakpoints. Controller events for MIDI and Instrument tracks differ from automation data for audio tracks in that the breakpoints are stepped (instead of vector-based), where each breakpoint represents a single controller event.
Continuous controller events that can be inserted and edited in Pro Tools include:

- volume
- pan
- pitch bend
- aftertouch (mono)
- MIDI controllers, 0–127

MIDI controller #7 (volume) and #10 (pan) are treated by Pro Tools as automation data. This means that these controller events (along with Mutes) can be recorded and automated from the Mix window; in addition, each MIDI or Instrument track’s automation mode affects how these events are played back and recorded. While a MIDI track’s volume and pan (and mute) events can be suspended, all other controller events in the track always play. Instrument tracks support both MIDI volume, pan, and mute, and audio volume, pan, and mute.

To avoid overwriting existing MIDI volume and pan automation data, record in MIDI Merge mode. When recording in MIDI Merge mode, existing volume and pan data will play back while recording new MIDI data.

Continuous controller events (including volume and pan) can be recorded from an external MIDI controller (such as a keyboard or control surface), and they can be inserted in a MIDI track’s playlist using the Pencil tool or any Grabber tool.

Inserting and Editing Controller Events

Continuous controller events can be edited with any of the following methods:

- Individual breakpoints can be dragged with any Grabber tool to adjust their location or value.
- A group of selected breakpoints can be scaled up or down with any of the Trim tools.
- New controller events can be drawn in with the Pencil tool to replace existing events. Events can be drawn with the Pencil tool set to Freehand, or using any of the shapes (Line, Triangle, Square, or Random).
- Controller events can be copied and pasted, nudged, and shifted.

To copy continuous MIDI controller events and paste to a different MIDI controller, use Special Paste (Edit > Paste Special > To Current Automation Type). For example, you might want to use the same control data for volume and a cut-off filter, or for pan and pitch bend. For more information, see “Special Paste Function for Automation Data” on page 559.

Edits to volume data affect all tracks within an enabled Edit Group. This is not the case, however, for other controller playlists (such as pan). To insert and edit other controller types across all tracks in an Edit Group, press the Start key (Windows) or Control (Macintosh) while performing the edits.
Resolution for Inserted Controller Events

When inserting controller events with the Pencil tool, the density of the events is determined by the MIDI preference for “Pencil Tool Resolution When Drawing Controller Data.”

To set the Pencil tool resolution:

1. Choose Setup > Preferences, then click the MIDI tab.
2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value range is from 1 to 100 milliseconds.
3. Click OK.

To edit a continuous controller event with the Pencil tool, the controller first has to be added to the Automated MIDI Controllers list.

The controller is automatically added to the Automated MIDI Controllers list when you record controller information from an external device.

To manually enable a continuous controller for automation:

1. Click the Track View selector for the MIDI or Instrument track you wish to edit, and select Add/Remove Controller from the controllers pop-up.
2. Choose the MIDI controller range for the controller that you wish to automate.
3. Choose the continuous controllers that you wish to automate from the list on the left, and click Add.
4. Click OK to close the Automated MIDI Controllers dialog.

When you record continuous controller information from an external MIDI device, the controller is automatically added to the MIDI Controllers list.
Patch Select (Program and Bank Changes)

Each MIDI and Instrument track can have a default program change that is sent each time the track plays. Additional program changes can be inserted at any point within the track.

About Program and Bank Changes

The MIDI protocol lets you choose from a range of 128 programs (0–127). Most MIDI instruments have several banks of 128 programs. To specify a bank, a bank select message must be sent. Some instruments use Controller 0 to switch the bank while others use Controller 32; some use a combination of the two. The Patch Select dialog in Pro Tools lets you use either of these bank select messages when inserting a program change event. Check the manufacturer’s documentation for your MIDI device to see which Controller value it uses.

If you do not know what bank select command your instrument uses, you can record MIDI to Pro Tools while making a bank change from the instrument. Then review the bank select information your instrument has recorded into Pro Tools in the MIDI Event List.

Some older MIDI devices (such as the Kurzweil K1000) use a program change instead of a Bank Select message to switch banks. For these devices you may find it necessary to send two program change messages to access a particular program, where the first sets the bank and the second sets the program.

Default Program Change

The default program change for each MIDI track is specified by clicking on the Patch Select button, from either the Mix or Edit window. Once specified, the default program change message is sent to your instrument when playing the track.

To set the default program change for a MIDI or Instrument track:

1. From the Mix or Edit window, click the Patch Select button.

   ![Patch Select button](image)

   ![Patch Select button](image)

2. Do one of the following:
   - In the Patch Select dialog, select a program number.

   ![Patch Select dialog](image)

   - If you are using patch name files, choose a bank from the pop-up menu in the upper left of the Patch Select dialog and select a patch name. See “Patch Names” on page 430.
Once selected, the program number (or patch name) appears in the Patch Select button in the Edit window.

Unlike recorded and inserted program change events, the default program change does not appear in the track’s playlist.

To clear the default program change, select None in the Patch Select dialog.

**Patch Names**

Pro Tools supports XML (Extensible Markup Language) for storing and importing patch names for external MIDI devices (such as MIDI instruments). Pro Tools installs MIDI patch name files (.midnam) for the factory default patch names of many common MIDI devices. These files reside in directories, sorted by manufacturer, in Program Files\Common Files\Digidesign\MIDI Patch Names\Digidesign (Windows) and /Library/Audio/MIDI Patch Names/Digidesign (Macintosh).

To import MIDI patch names into Pro Tools:

1. Choose Setup > MIDI > MIDI Studio, and verify the MIDI Device definition in the MIDI Studio Setup window (Windows) or Audio MIDI Setup (Macintosh).

2. Verify the MIDI track’s output is correctly assigned to the MIDI device.

3. Click the MIDI track’s Patch Select button.

4. In the Patch Select dialog, click the Change button.

5. In the Open dialog, navigate to Program Files\Common Files\Digidesign\MIDI Patch Names\Digidesign\<name of manufacturer> (Windows) or /Library/Audio/MIDI Patch Names/Digidesign/<name of manufacturer> (Macintosh) and select the MIDI Patch Name file (.midnam) for the MIDI device.

6. Click Open.
7 The Patch Select dialog will be populated with patch names and the Patch Name Bank pop-up menu will appear in the upper left hand corner of the window.

Inserting and Editing Program Changes

Program changes can be inserted into a track’s playlist with the Pencil tool. Existing program changes can be edited, moved, and copied and pasted.

⚠️ On some instruments, changing programs during playback can interrupt playback. To avoid this, place program change events in the track where there are no notes sounding.

To insert a program change with the Pencil tool:

1. Set the MIDI or Instrument track to Program Change view.
2. If you want the inserted event to snap to a Grid value, set the Edit mode to Grid.
3. Click with the Pencil tool in the track’s playlist at the point where you want to insert the program change.
4. In the Patch Select dialog, select a program number (or name) and, if necessary, specify a bank change value.
5. Click Done to insert the program change event in the track’s playlist.

To edit a program change event:

1. With the Pencil tool or any Grabber tool, double-click the program change event you want to edit.
2. In the Patch Select dialog, select the new program number (or name) and, if necessary, specify a bank change value.
3. Click Done.
To move a program change event:

- With the Pencil tool or any Grabber tool, drag the program change event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

The placement of program changes can also be adjusted with Shift (see “Shift Command” on page 307) or Nudge (see “Nudging” on page 305).

To delete a program change event:

1. With the track set to Program Change View, click the program change event with any Grabber tool to select it.
   - or -

If the region contains other events you want to delete, select the entire region with any Grabber tool (when the track is displaying regions).

2. Choose Edit > Clear to remove the selected events from the track.
   - or -

Press the Backspace (Windows) or Delete (Macintosh) key.

Individual program change events can also be deleted by Alt-clicking (Windows) or Option-clicking (Macintosh) them with the Pencil tool.

Auditioning Programs

When the Patch Select dialog is open, Pro Tools can automatically scroll through the different patches for a track’s assigned MIDI device.

To audition patches:

1. If you want to audition patches for a MIDI track or Instrument during playback, click Play in the Transport window.

2. Open the Patch Select dialog by clicking the Patch Select button, or by inserting or editing a program change event in a MIDI or Instrument track.

3. Click a program number—the starting point from which you will scroll through the patches.

4. Enter a value for the number of seconds that will elapse between each program change.

5. Select the option for Increment Patch.

After the specified number of seconds, Pro Tools selects the next patch and transmits the program change to the track’s assigned MIDI device.

6. When you are finished auditioning settings, click Done to stop incrementing patches, and to close the Patch Select dialog.

System Exclusive Events

System Exclusive (Sysex) events can be recorded to MIDI or Instrument tracks in Pro Tools (see “MIDI Step Input” on page 200). Once the events are recorded, they appear in the track’s playlist as blocks when the Track View is set to Sysex.

While the contents of recorded System Exclusive events cannot be directly edited in Pro Tools, the events can be moved or nudged, copied and pasted, or deleted.
To move a Sysex event:

1. Set the MIDI or Instrument track to Sysex View.

2. With any Grabber tool, drag the Sysex event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

Note and Controller Chasing

Note Chasing

Note Chasing allows long, sustained MIDI notes to be heard when playing from a point after their start time. For example, if a note’s start time is at 1|1|000 and lasts for 8 measures (until 9|1|000), note chasing lets you begin playing from bar 5 and still hear the note that started at 1|1|000 as it continues to sustain until 9|1|000.

Note Chasing is something that can be turned on and off individually for each MIDI or Instrument track. By default, new MIDI and Instrument tracks have Note Chasing enabled.

To enable Note Chasing for a MIDI track:

- Click the track’s Playlist selector and select the option for Note Chasing.

Make sure to disable Note Chasing when working with samplers that are playing loops. If a MIDI track, for example, is triggering a 4-bar drum loop and you begin playing at bar 3, the loop will begin playing at the wrong time and be out of synchronization with the other tracks.
Controller and Program Chasing

Pro Tools always chases continuous controller events and program changes for MIDI tracks. This ensures that controller values and patches for MIDI devices are always appropriately set.

For example, suppose a MIDI track lasting 32 measures starts with a volume of 127 and in the last bar fades the volume down to 0. If after playing the track in its entirety you attempt to play from bar 8, the initial volume of 127 is chased and sent to the track’s assigned device—otherwise the track would not be heard since the most recent volume event sent would have been 0.

Chasing also occurs for a MIDI track’s default program change, along with any program change events residing within the track. Therefore, if you have chosen a default program change for a track, when playing from any point within the track, the program change event is sent to the track’s assigned device.

Default Controller Values and Chasing

Though new MIDI tracks appear to have default values for continuous controller playlists, this is actually not the case. For example, when viewing a MIDI track’s Mod Wheel playlist, you’ll see that the breakpoint line is set to a default of zero. However, since the modulation wheel on your synth may purposely be set to a different value, the default value in the track is not transmitted when playing.

This can cause some confusion, however, if you insert a fade (for example, from 0–90) in the Mod Wheel playlist towards the end of the track. If you then play from the beginning of the track, or from anywhere before the fade, the Mod Wheel value on your synth will be at 90 until the beginning of the fade data is reached—which is likely not what you want.

To ensure that the default controller value for a playlist is sent (and chased), click the initial breakpoint at the beginning of the track, move it slightly, and set it back to the default value.

Offsetting MIDI Tracks

Pro Tools can offset MIDI tracks globally or individually.

With Pro Tools HD, when Delay Compensation is active, MIDI and Instrument tracks are automatically delay-compensated to provide low latency monitoring. For more informations, see “Delay Compensation for MIDI” on page 508.

Global MIDI Playback Offset

Pro Tools offers a MIDI offset preference that allows MIDI and Instrument tracks to play back earlier or later (than audio tracks) by a specified number of samples. The offset affects playback only and does not alter in any way how MIDI data is displayed in the Edit window.

This capability is provided in large part to compensate for the audio monitoring latency in Pro Tools LE. If you are monitoring the output of external MIDI instruments with an external mixer or sound system (or headphones), there is no latency. If, however, you are monitoring the output of your MIDI devices through a Digi 002, Digi 002 Rack, Mbox 2, or Mbox, your MIDI tracks will appear to play slightly later than your audio tracks. The larger the setting for the H/W Buffer Size (128, 256, 512, or 1024 samples), the larger the latency.

By configuring the Global MIDI Playback Offset, you can get your MIDI tracks to play back slightly earlier (by a specified number of samples), thereby compensating for the latency in monitoring audio within Pro Tools LE.
To configure the Global MIDI Playback Offset:

1. Choose Setup > Preferences and click the MIDI tab.

2. For the Global MIDI Playback Offset option, enter the number of samples (−10,000 to 10,000) for the offset. A negative value causes the MIDI tracks to play back earlier than the audio tracks; a positive value causes the MIDI tracks to play back later.

To allow for monitoring latency in Pro Tools LE, set the offset to a value that is roughly equivalent to the H/W Buffer Size.

3. Click Done.

The Global MIDI Playback Offset can also be set from the MIDI Track Offsets window. You can also apply MIDI Real-Time Properties delay to offset MIDI (see “MIDI Real-Time Properties” on page 460).

Individual MIDI and Instrument Track Offsets

You can offset individual MIDI and Instrument track offsets in Pro Tools to compensate for delays in MIDI devices (the time it takes to trigger events on a sampler or synth).

For example, if you have some kick drums that are being played by an audio track in Pro Tools and want them to be exactly synchronized with kick drums that are being played by a MIDI device, you may need to use a MIDI offset. In this example, it will usually take at least 5 ms to trigger the MIDI notes, and it could take even longer, depending on the MIDI device.

You can measure the latency for a MIDI device assigned to a MIDI track by recording its audio output back into Pro Tools. Compare the sample locations for the recorded audio events against the original MIDI notes to calculate the latency.

To configure a MIDI or Instrument track offset for a track:

1. Choose Event > MIDI Track Offsets.

2. Click in the Sample Offset column for the MIDI track and enter the number of samples (−10,000 to 10,000) for the offset. A negative value causes the MIDI or Instrument tracks to play back earlier than the audio tracks; a positive value causes the MIDI or Instrument tracks to play back later.

The equivalent offset in milliseconds is displayed in the msec Offset column. This value cannot be edited, but updates when a new value is entered in the SMPTE Offset column.

3. Press Enter (Windows) or Return (Macintosh) to accept the entered offset value.

To reset all offsets for all MIDI and Instrument tracks, click the Reset button in the upper left of the window.
Stuck Notes

If you encounter stuck notes with any of your MIDI devices, you can silence them with the All MIDI Notes Off command.

To turn off all stuck notes:

- Choose Event > All MIDI Notes Off.

Press Control+Shift+Period (.) (Windows) or Command+Shift+Period (.) (Macintosh) for the All MIDI Notes Off command.

Remove Duplicate Notes

The Remove Duplicate Notes command is useful for removing duplicate notes from a MIDI performance. If a note starts within the first 25% of the duration of a note of the same pitch which is already sounding (or within an eighth-note, whichever is shorter), it is considered a duplicate and is combined with the previous note. If it starts later than that, the first note is shortened so that it ends at the same tick at which the new one starts.

To remove duplicate notes:

1. Make an Edit selection including the duplicate notes that you want to remove.

2. Choose Event > Remove Duplicate Notes.
Chapter 23: MIDI Operations

MIDI Operations Window

The MIDI Operations window provides commands to transform groups of MIDI notes to affect pitch, timing, and phrasing.

The MIDI Operations window has nine pages, one for each MIDI Operations command.

- Grid/Groove Quantize
- Restore Performance
- Flatten Performance
- Change Velocity
- Change Duration
- Transpose
- Select/Split Notes
- Input Quantize
- Step Input

The MIDI Operations window can be left open, revisiting it as necessary to apply a command, or to try out different options for a particular command.

You can also apply quantize, duration, delay, and transpose nondestructively using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 460.

See your system’s Getting Started Guide for complete steps on configuring MIDI on Windows and Macintosh systems.

To open a specific MIDI Operations window page:
■ Choose Event > MIDI, followed by one of the MIDI Operations (such as Grid/Groove Quantize).

If the MIDI Operations window is already open, you can select any of the pages from the pop-up menu at the top of the window.
To open the last active MIDI Operations window page:
- Choose Event > MIDI > Operations Window.

Press Alt+3 (Windows) or Option+3 (Macintosh) to open the MIDI Operations window and display the last active MIDI Operations page.

To apply the command in the MIDI Operations window:
- Click Apply or press Enter on the numeric keypad. This applies the command and leaves the window in the foreground.
- or –
- Press Enter on the QWERTY keyboard (Windows) or Return (Macintosh). This applies the command and closes the window.

When using the MIDI Operations window and MIDI Real-Time Properties at the same time, MIDI operations are applied to the actual MIDI data. MIDI Real-Time Properties will continue to be applied on top of any applied MIDI operations.

To undo the command in the MIDI Operations window:
- Choose Edit > Undo.

Grid/Groove Quantize

The Grid/Groove Quantize command adjusts MIDI note locations and durations so that timing is improved, or so that a particular rhythmic “feel” is achieved.

The default Grid/Groove page provides Grid Quantize options, so that you can Quantize works by aligning notes to a Quantize Grid, the size of which is defined in the Quantize Grid pop-up menu by a standard note duration, or you can apply a groove template. The Grid/Groove Quantize window provides slightly different options for Grid Quantize and Groove Quantize.

The Quantize command is not the same as the Quantize to Grid command (in the Region menu). The Quantize to Grid command adjusts the start point for a selected region, and its contents are moved along with the region (with internal rhythmic relationships remaining intact).
The Grid/Groove Quantize MIDI Operation, on the other hand, affects MIDI notes individually. Some notes may be moved back in time, others forward, some will be shortened and some will be lengthened; and, some notes will be more drastically affected than others.

To open the Grid/Groove Quantize window:
- Choose Event > MIDI > Grid/Groove Quantize.

To select Grid Quantize:
- From the Quantize Grid pop-up menu, select the desired note value.

To select Groove Quantize:
- From the Quantize Grid pop-up menu, select the desired groove template.

**Grid Quantize**

The Grid/Groove Quantize window can apply Grid Quantize when a specific rhythmic value is selected in the Quantize Grid pop-up menu. When a groove template is selected in the Quantize pop-up menu, Groove Quantize can be applied. For information on Groove Quantize, see “Groove Quantize” on page 443.

**What to Quantize**

The options under “What to Quantize” determine what aspects of the selected MIDI notes are quantized: attacks, releases, or both.

**Attacks** When selected, note start points are quantized.

**Releases** When selected, note end points are quantized.

**Preserve Note Duration** When selected, note durations are preserved.

When deselected with the Attacks option selected, note end points are not moved.

You can also quantize MIDI input, see “Input Quantize” on page 456.
When deselected with the Releases option selected, note start points are not moved.

If the options for both Attacks and Releases are selected, the Don’t Change Durations option is unavailable.

Figure 21 on page 440 shows how notes are adjusted by the different What To Quantize options.

Tuplet Select the Tuplet option to quantize irregular note groupings, such as quintuplets. The Quantize Grid for tuplets is calculated from the note size selection and the Tuplet value. For example, if an sixteenth note equals 240 ticks, quintuplet sixteenth notes with 5 in time of 4 would yield a Grid size of 192 ticks or (240 ticks/5)*4.

Offset Grid By Offsets the Quantize Grid forward or back in time by a specified number of ticks. Use this option to achieve a pushed feel (by using positive values) or a laid back feel (by using negative values).

Randomize When selected, notes are moved randomly forward or back in time (after the Quantize occurs). For example, with the Quantize Grid set to eighth notes and Randomize set to 50%, notes are placed up to a 32nd note before or after the beat boundary. The Randomize setting also affects note durations (if Releases is selected).

Options

Additional Quantize options include:

Swing When selected, every other Grid boundary is shifted by the specified percentage value (0–300) to achieve a “swing” feel. A Swing value of 0% yields no swing, while 100% yields a triplet feel. Settings above 100% progressively narrow the swing until the maximum of 300%, at which every other Grid boundary is moved to the next Grid point.
Include Within
When selected, attacks and releases are only quantized if located within the specified percentage of the Quantize Grid. Use this option to clean up downbeats without affecting notes that are “swung” or wildly off the beat.

Figure 22 shows the Quantize Grid set to quarter notes with the Include Within option set to 50%. Only attacks and releases falling within the shaded area (equivalent to an eighth note area around each beat) are quantized.

Exclude Within
When selected, attacks and releases are not quantized if located within the specified percentage of the Quantize Grid. Use this option to preserve the feel of notes close to the beat, while correcting others that are drastically away from the beat.

Figure 23 shows the Quantize Grid set to quarter notes with the Exclude Within option set to 25%. Attacks and releases falling within the shaded area (equivalent to a sixteenth note area around each beat) are not quantized.

100% Swing, eighth note Grid

Strength
When selected, notes are moved a percentage toward the Quantize Grid. Lower percentages preserve the original feel of the notes, higher percentages align the notes more tightly to the Grid.

Grid Quantize Examples

The following examples illustrate some of the more common uses for Grid Quantize.

If you intend to loop playback while quantizing, you may want to deselect Options > Link Timeline and Edit Selection. This ensures that the play range will not change when selected notes are moved in the course of quantizing and undoing.

⚠️ After quantizing, you can use Restore Performance to revert to the original version (see “Restore Performance” on page 448.)

Straight Quantize

To quantize to a straight sixteenth note feel:

1. Select the range of MIDI notes to be quantized.
2. Choose Event > MIDI > Grid/Groove Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4 From the Quantize Grid pop-up menu, select sixteenth notes (1/16). Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.

5 Leave the remaining Quantize options deselected and click Apply.

Quantizing While Preserving the Original “Feel”

You can quantize less strictly, to preserve the original feel of your recorded MIDI tracks.

To quantize while preserving the original feel:

1 Select the range of MIDI notes to be quantized.

2 Choose Event > MIDI > Grid/Groove Quantize.

3 Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.

4 From the Quantize Grid pop-up menu, select the note value you want to use. Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.

5 Select the Exclude Within option with a value of 10–15%.

6 Select the Strength option with a value of 70–80%.

7 Leave the remaining Quantize options deselected and click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with different values for Exclude Within and Strength.

Quantizing with Swing

If you’re working with MIDI hi-hats or bass lines, you may want to apply more of a swing feel to the track.

To quantize with an eighth note swing feel:

1 Select the range of MIDI notes to be quantized.

2 Choose Event > MIDI > Grid/Groove Quantize.

3 Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.

4 From the Quantize Grid pop-up menu, select eighth notes (1/8).

5 Select the Swing option with the Swing percentage you want:

- For a light swing, use 12%.
- For a tighter swing-like groove, use 24%.
- For a true “triplet-like” swing feel, use 50–75%.

6 Make sure the options for Tuplet, Offset Grid By, and Randomize are not selected. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Swing percentage.

Quantizing with Randomize

If quantized notes sound too mechanical or “on the beat,” use the Randomize option in the Quantize window to make them sound more natural.
To “humanize” the rhythmic feel of notes:

1. Select the range of MIDI notes to be quantized.
2. Choose Event > MIDI > Grid/Groove Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. From the Quantize Grid pop-up menu, select the note value you want to use.
5. Select the Randomize option with a value of 5%.
6. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Randomize percentage.

**Experimenting with Quantize**

When using the Quantize command, you’ll often have to experiment with many of the controls. You may have to try different values for Include and Exclude Within, and Strength; these controls determine which notes are affected and how drastically they are changed. In addition, the Randomize control, which adds a percentage of randomness to the quantize, can be used to make tracks feel less “mechanical.”

**Groove Quantize**

The Grid/Groove Quantize window can apply Groove Quantize when a groove template is selected in the Quantize Grid pop-up menu. Groove quantize adjusts MIDI note locations and durations according to a *groove template* rather than a strict quantization grid. Groove templates extract the particular rhythmic feel of a recorded performance so that is can be applied to a MIDI sequence. DigiGroove templates can be generated using Beat Detective.
DigiGroove templates can be created using Beat Detective. Beat Detective analyzes an audio file for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template. This template can then be used within Groove Quantize, as well as within Beat Detective.

For information on Beat Detective and creating Groove Templates, see Chapter 21, "Beat Detective."

Additionally, DigiGroove templates are available from Digidesign and third party manufacturers.

Numerical Sound’s Feel Injector Templates (960 ppq) are supported in Pro Tools, but DNA Groove Templates (192 ppq) are not.

Quantize Grid

Quantize Grid Pop-Up Menu Determines which groove template to use for quantization. All groove template files in the Grooves folder are available in the Quantize Grid pop-up menu. The directory path for the Grooves folder is: C:\Program Files\Digidesign\Pro Tools\Grooves (Windows), or Applications/Digidesign/Pro Tools/Grooves (Macintosh). If you organize your groove templates in sub-folders in the Groove folder, they will appear as sub-menus in the pop-up menu. Once you have selected a groove template, specific information about the template’s meter and duration (in bars) is displayed under the pop-up menu.

Show Comments The Comments field displays any comments saved with the Groove Template from Beat Detective. The Comments field cannot be edited in the Grid/Groove Quantize page, but can be edited when saving a groove template from the Groove Quantize page.

Pre-Quantize Enable to hard quantize the selected MIDI notes to a sixteenth-note grid before applying Groove Quantize.

Options

Timing Enable to apply Groove Quantize to the selected MIDI notes. Use the slider to change the amount of quantization applied to the selection. If the slider is set to 0%, there is no change in timing. A setting of 100% moves notes to the underlying template locations. If the slider is set to 200%, notes move to a tick location that is twice the difference between the original note location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073 (a slider value of 200% shifts the note to 1|1|086).

The default value for the Timing slider is 100%.

Duration Enable to influence the durations of the selected MIDI notes. At a setting of 100%, durations are changed to match the current groove template. Set to 200%, durations increase and decrease based on the ratio of the original duration of the selected notes and the durations in the template.

The default value for the Duration slider is 100%.

Beat Detective does not currently extract duration information from audio performances. DigiGroove templates created using Beat Detective contain a fixed duration value that is 50% of the selected template resolution (see “Defining a Beat Detective Selection” on page 394).
**Velocity** Enable to influence the velocities of the selected MIDI notes. If the slider is set to 0% there is no change to the selected velocities, a setting of 100% sets all velocities to match the current groove template. A velocity setting of 200% typically results in over-exaggerated velocities—loud notes increasing and soft notes decreasing in volume.

For example, if two adjacent notes have equal velocities of 80, and the two corresponding template velocities are 70 and 90, setting the slider to 200% changes both to velocities of 60 and 100.

The default value for the Velocity slider is 100%.

**Slider Settings**

**To Save the groove template with the current Options Slider Settings:**

1. In the Grid/Groove Quantize window, click the Save button.

2. Enter or edit any comments you want to save with the template.

3. Click the Save button to save the groove template with the current Options Slider Settings.

   - or -

Click the Save As button to make a copy of the groove template with the current Options Slider Settings. In the resulting Save dialog, enter a name for the copy and click Save.

Slider settings may be lost if any of the following operations are performed without saving the settings first:

- Another MIDI Operations window is selected.
- The MIDI Operations window is closed.
- You switch to another groove template.

**Recall With Template**

Restores all Groove Quantize Options to the settings that are saved with the current template.

**Applying Groove Templates**

Groove templates can be of any length and can be applied to any number of bars. Typically, you will apply groove templates to selections of the same length and meter. However, groove templates can be applied to different meters—for example, a groove template in 6/8 can be applied to a selection in 4/4. Also, it is not necessary to start on the downbeat when making a selection to apply a groove template.

**To apply Groove Quantize:**

1. With the Grabber or Selector tool, select the MIDI notes you want to Groove Quantize.

2. Choose Event > MIDI > Grid/Groove Quantize.

3. Select a groove template from the Grid Quantize pop-up menu.

4. Enable Timing, Duration, and Velocity as desired, and adjust their sliders to the percentages you want.

5. If desired, enable Pre-Process using Quantize.

6. Click the Apply button.
Mapping Groove Templates

Pro Tools applies groove templates relative to the song start. For example, a two-bar groove template repeats starting at every odd-numbered bar in the session (bar 1, 3, 5, 7…).

Template Mapping for Equal Meters And Odd Numbered Bars

If a two-bar groove template is applied to a selection of one bar of the same meter, only the first bar of the template is used. If the selection does not encompass bar boundaries, for example 1|2|000 to 2|1|000, the groove template will only modify the selected notes.

Template Mapping for Equal Meters And Even Bars

If a selection starts on an even bar, only the appropriate portion of the groove template will be used. For example, if the selection is two bars long and starts on an even bar, the template will apply bar 2 before bar 1.

Figure 24. A DigiGroove template (derived from the audio shown) applied to a series of sixteenth-notes with Timing and Velocity both set to 100%
Template Mapping for Unequal Meters

In cases where the Groove Templates and track selections are based on different meters, the template will be repeated or truncated to match the number of beats in the selection.

For example, if the Groove Template contains fewer beats than the selection, such as a one-bar template in 6/8 being applied to a one-bar selection in 4/4, the template will repeat to make up the difference.

If the Groove Template contains more beats than the selection on a track, such as a one-bar template in 6/4 being applied to a two-bar selection in 4/4, only the appropriate number of beats will be used.

Behavior for Mixed Meters

If the selection contains mixed meters, the groove template will always be mapped so that the downbeats are aligned. For example, if the Groove Template consists of one-bar of 4/4 and it is being applied to a selection of one-bar of 4/4 followed by a bar of 3/8 and one-bar of 3/4, the downbeat of the Groove Template will be aligned with the downbeats in the selection and only the appropriate number of beats from the Groove Template will be applied.

💡 You can reset the groove template grid by adding a new meter marker (it can be the same meter). The groove template will restart at the meter marker regardless of the measure number or whether or not the meter has actually changed.
The Restore Performance command reverts all selected MIDI notes to their original state (when first recorded or manually inserted), even after the session has been saved, or the Undo queue has been cleared. The following MIDI note attributes can be restored:

- **Timing (Quantization)**
- **Duration**
- **Velocity**
- **Pitch**

⚠️ The Restore Performance command can be undone.

To restore a note’s original time, duration, velocity, or pitch:

1. With the Grabber or Selector tool, select the MIDI notes you want to restore.
2. Choose Event > MIDI > Restore Performance to open the Restore Performance page.
3. Select the note attributes to restore.
4. Click Apply.

Any changes made through the standard Quantize, Groove Quantize, Change Duration, Change Velocity, or Change Pitch commands will be undone and the original “performance” will be restored. Also, any notes that were recorded with Input Quantize enabled will be restored (see “Input Quantize” on page 456).

⚠️ Restore Performance does not undo cut, copied, pasted, or otherwise manually moved MIDI notes.

Restore Performance also does not undo Duration changes made by trimming the start of a note. Trimming the start of a note is essentially changing the note’s timing, and therefore is treated by Pro Tools as manually moving it.

**Timing (Quantization)** Enable to restore the original start times of the selected notes. This will change the durations of the notes if the Duration option is not enabled.

**Duration** Enable to restore the original durations of the selected notes. If the Timing (Quantization) option is not enabled, the start time of the note will not be restored and the note end time will be affected.

**Velocity** Enable to restore the original velocities of the selected notes.

**Pitch** Enable to restore the original pitches of the selected notes.
Removing Input Quantize

Restore Performance can be used to remove quantization on input. For example, if you recorded a performance with Input Quantize on, you can still restore the performance as it was actually played.

For information on the Input Quantize command, see “Input Quantize” on page 456.

Flatten Performance

The Flatten Performance command “locks in” the current performance for selected notes, creating a new “restore to” state for the specified note attributes when using Restore Performance.

To flatten the performance:

1. With the Grabber or Selector tool, select the MIDI notes you want to flatten.
2. Choose Event > MIDI > Flatten Performance to open the Restore Performance page.
3. Select the note attributes to flatten.
4. Click Apply.

The Flatten Performance command can be undone.

Change Velocity

The Change Velocity command automatically adjusts attack and release velocities for selected MIDI notes. Use it to make notes louder or softer, or to create crescendos or decrescendos.

Velocities can also be edited manually with the Pencil and Grabber tools (see “Manually Editing MIDI Notes” on page 419).

Velocity values usually affect the loudness of MIDI notes. They may also affect other aspects of an instrument’s sound, such as filter cutoff, envelopes, and modulations.

The settings in the Change Velocity window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 53).

You can also change velocity non-destructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 460.
To open the Change Velocity page:

- Choose Event > MIDI > Change Velocity.

**MIDI Operations window, Change Velocity page**

💡 While there are options for adjusting both the attack and release velocities for notes, most MIDI devices ignore release velocity information. To see if your instrument supports release velocities, refer to the manufacturer’s documentation.

**Set All To** Sets all velocities to the specified value (1–127).

**Add** Adds to existing velocity values by the specified amount (1–127).

**Subtract** Subtracts from existing velocity values by the specified amount (1–127).

**Scale By** Scales all velocities by a percentage amount (1–400%).

**Change Smoothly** Allows velocities to change smoothly from one value to another over time.

**Change Smoothly by Percentage** Allows velocities to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/- 99) to affect how gradually the change occurs.

**Limit To** When selected, restricts the Change Velocity command to a minimum and maximum range.

**Randomize** When selected, the Change Velocity command is randomized by the specified percentage value. For example, using “Set all to” with a value of 64, along with a Randomize value of 50%, yields velocities anywhere between 48 and 80 (+/- 25% of the velocity value).

**Velocity Ranges**

The valid range for MIDI note velocities is 1–127. The Change Velocity command will never result in moving velocities outside this range; 1 will always be the lowest and 127 will always be the highest. This means that you may reach a state where the Change Velocity command has no effect on a particular note.

For example, if a note with a velocity 64 is scaled by 200%, the new velocity would be 127. Attempting to scale or increase the velocity any further would yield no change.
Fading Velocities

To change velocities smoothly over time:
1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Velocity.
3. Select the Change Smoothly option with the range set from 127 to 0.
4. Click Apply.

To preserve (somewhat) the existing velocity relationships and still achieve velocity fades, use the option for Change Smoothly by Percentage. Figure 25 illustrates the difference between the two Change Smoothly options.

Scaling Velocities

Many times existing note velocities will have the relationship you want, but will either be too soft or too loud overall. In these instances, use the Scale By option.

For example, to make velocities 20% louder:
1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Velocity.
3. Select the Scale By option with the percentage value set to 120.
4. Click Apply.

Change Duration

The Change Duration command adjusts durations for selected MIDI notes. Use it to make melodies and phrases more staccato or legato.

- The settings in the Change Duration page are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 53).

- You can also change note duration non-destructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 460.

To open the Change Duration page:
- Choose Event > MIDI > Change Duration.

Press Alt+P on Windows or Option+P on Macintosh to open the Change Duration window.
Set/Add/Subtract/Scale Option

Set All To Sets all durations to a length specified in quarter notes and ticks.

Add Adds to the durations by a specified number of quarter notes and ticks.

Subtract Subtracts from the durations by a specified number of quarter notes and ticks.

Scale by Shortens or lengthens durations based on a percentage value (1–400%).

Legato

Enable the legato option to add legato to the MIDI selection. Select Gap or Overlap from the Legato pop-up menu and enter the desired gap or overlap in beats and ticks.

Remove Overlap

The Remove Overlap option removes any note overlap for all notes of the same pitch. This command is different from Legato in that non-overlapping notes of the same or different pitches remain unchanged. To create a gap between previously overlapping notes, enter the desired gap in beats and ticks.

Transform Sustain Pedal To Duration

The Transform Sustain Pedal To Duration option extends the length of all notes which are sounding when the sustain pedal (controller 64) is down (0 to 63) to the point when the sustain pedal goes up (64 to 127). Enable the Delete Sustain Pedal Events option to convert sustain pedal events to note durations. Converting sustain pedal events to note duration can greatly simplify editing while maintaining the desired performance effect. For example, if a sustain pedal down event is deleted while editing, the subsequent MIDI performance looses its legato effect.

Change Continuously Option

The Change Continuously option lets you change the duration of notes continuously in ticks or by percentage. Adjust the Curve slider to modify the shape of the change.

Change Continuously in Ticks Allows note lengths to change smoothly from one duration to another over time. Duration values are specified in quarter notes and ticks.

Change Continuously by Percentage Allows note lengths to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/- 99) to affect how gradually the change occurs.
**Limit Range** When selected, restricts the Change Duration command to a minimum and maximum range (in quarter notes and ticks).

**Randomize** When selected, the Change Duration command is randomized by the specified percentage value. For example, using “Set all to” with a value of 480 ticks, along with a Randomize value of 50%, yields durations anywhere between 360 and 600 (+/− 25% of the duration value).

**Change Duration Examples**

**To make notes more staccato:**
1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Duration.
3. Select the option for Scale By with a percentage value of 50.
4. Click Apply. The durations for the selected notes are reduced by 50%.

With this option you may have to experiment with the percentage value to achieve the desired effect.

**To make notes more legato:**
1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Duration.
3. Select the Legato option.
4. From the Legato pop-up menu, select Overlap.
5. Enter 0|000 for the amount of overlap.
6. Click Apply.

The end points for the selected notes are extended to the start point of the next note, thereby eliminating the space between each note.

**Transpose**

While the Grabber tools can be used to manually transpose individual MIDI notes, or small groups of notes, the Transpose command can be used for entire MIDI tracks and regions. One of the more common uses for Transpose is to change the key for your MIDI tracks. You can define an Edit Group for MIDI tracks that you want to transpose, making sure to exclude any drum tracks from the group so they aren’t transposed.

You can also transpose MIDI notes non-destructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 460.

**To open the Transpose page:**
- Choose Event > MIDI > Transpose.

Press Alt+T on Windows or Option+T on Macintosh to open the Transpose window.

**Transpose By (Octaves)** Transposes transpose the selected MIDI notes by up to +/- 10 octaves.

**Transpose By (Semitones)** Transposes chromatically, up or down, by up to +/-127 semitones.
**Transpose (From and To)** Transposes by semitones, as expressed by the difference between the source and destination pitches. Transposing from C3 to F#3, for example, transposes the notes up by an augmented fourth (six semitones).

**Transpose All Notes To** Transposes all selected notes to the same pitch. Use the slider or the number entry box to enter the desired pitch to which to transpose all selected notes.

**To transpose MIDI notes to another key:**
1. If you will be transposing a group of tracks, make sure to enable the Edit Group.
2. With the Selector or any Grabber tool, select the range of MIDI notes to be transposed.
3. Choose Event > MIDI > Transpose.
4. Select the option for Transpose (From, To).
5. Set the “From” and “To” values, for example, to C4 and E4 to transpose from C to E.

With either of the pitch fields selected, you can play a note on your MIDI controller to automatically enter it as the pitch value.

6. Click Apply.

It is also common to transpose MIDI tracks up or down by an octave.

**To transpose a MIDI track down by an octave:**
1. With the Selector tool, double-click in the track to select all of its notes.
2. Choose Event > MIDI > Transpose.
3. Select the Transpose By option.
4. Enter a value of –1 octave.
5. Click Apply.

---

**Select/Split Notes**

The Select/Split Notes window provides a complete set of tools to select and split notes based on a wide variety of criteria. Additional tools are provided to specify whether selected data is copied to the clipboard or to new tracks, whether the data is split to multiple new tracks or a single destination, and more.

**To open the Select/Split Notes page:**
- Choose Event > MIDI > Select/Split Notes.

---

**Pitch Criteria**

- **All Notes** Selects all notes.
- **Notes Between** Selects a range of notes between the specified upper and lower note. Values for the notes can be entered in pitch (C1–G8) or MIDI note numbers (0–127).
Top Selects the highest note or notes in each chord.

Bottom Selects the lowest note or notes in each chord.

Other Criteria

Velocity Enable the Velocity option to specify a range of velocities for selecting or splitting notes. Enter the desired minimum and maximum velocities.

Duration Enable the Duration option to specify a range of durations (in beats and ticks) for selecting or splitting notes. Enter the desired minimum and maximum durations.

Position Enable the Position option to select or split all notes that fall into a range of relative beat and tick locations within each bar. The minimum value determines the start of the range, the maximum value sets the end of the range.

Action

Select Notes Selects MIDI notes based on the specified criteria.

Split Notes: The Clipboard Copies the selected data to the clipboard only.

Split Notes: A New Track Copies all selected data to a single, new track. If the selection includes multiple tracks, that same number of tracks will be created. The new tracks will duplicate the original track type (Instrument or MIDI).

Split Notes: A New Track per Pitch Copies all selected data to multiple new tracks (one new track for each pitch). New tracks zoom to single-note display. If the selection includes multiple tracks, each track will have its data split separately.

Include MIDI Controller Data Includes all continuous MIDI data, including pitchbend and aftertouch, on the entire track, without any restriction on time selection.

To select and split notes:

1. Choose Event > MIDI > Select/Split Notes.
2. Configure the Pitch Criteria as desired.
3. Configure the Other Criteria (Velocity, Duration, and Position) as desired.
4. Enable the Select or Split option as desired.
5. From the Split Notes pop-up menu, select Copy or Cut.
6. Select the desired Copy or Cut to destination:
7. If desired, enable the Include MIDI Controller Data option. Enabling this option will include all controller data associated with the split notes in newly created tracks. Leave this option unchecked to split only note data to new tracks.
8. Click Apply.

Any Real-Time Properties associated with the track or regions are copied to new tracks created by Select/Split Notes.

Selecting a Pitch Range of Notes

A common use for Select/Split Notes is to select a single note for the entire length of a region or track. This is especially useful if you want to select a note in a MIDI drum track (such as a hi-hat), and affect it over the selected time range with the Quantize, Groove Quantize, Transpose, or Change Duration command.
To select only the hi-hats in a General MIDI drum track:

1. With the Grabber or Selector tool, select the range of MIDI notes that contains the note.
2. Choose Event > MIDI > Select/Split Notes.
3. Select the Notes Between option with the note range set to F#1 and F#1 (if the MIDI Note Display preference is set to Standard Pitch).

For a General MIDI drum kit, the closed hi-hat is assigned to MIDI note number 42 (F#1 at Standard Pitch). If the hi-hat for your drum kit is assigned to a different note, make sure to specify it.
4. Click Apply.

Selecting Notes in a Chord

Another use for Select/Split Notes is to select only the upper or lower notes in a chord. Many times you’ll want to affect only the upper or lower notes in a chord—to boost their velocities, or transpose their pitch.

To select only the bass notes in a chord:

1. With the Grabber or Selector tool, select the range of MIDI notes that contains the notes.
   - or -
2. Choose Event > MIDI > Select/Split Notes.
3. Select the Bottom option and leave the number of notes set to 1.
4. Click Apply.

In order for notes to be considered a chord, their start times must be within thirty-two ppq ticks of each other.

Input Quantize

When Input Quantize is enabled, all recorded MIDI notes are quantized automatically. To preserve the original “feel” of your recorded MIDI tracks, make sure to disable this option.

To enable Input Quantize:

1. Choose Event > MIDI > Input Quantize.
2. In the Input Quantize page, select Enable Input Quantize.

MIDI Operations window, Input Quantize

Configure the other options in the Input Quantize page. For details on the various Quantize options, see “Grid/Groove Quantize” on page 438. When finished, close the MIDI Operations window.

For drum machine style loop recording, use Input Quantize while loop recording MIDI in Merge mode (see “Loop Recording with Merge Mode” on page 197).
Step Input

Step Input lets you use a MIDI controller to enter notes individually, one step at a time. This gives you precise control over note placement, duration, and velocity. With MIDI step input you can also create musical passages that might be difficult to play accurately, or at a fast tempo.

To enter MIDI notes with Step Input (using an external MIDI device):

1. Make certain your external MIDI device is properly connected and working with Pro Tools.
2. Choose Event > MIDI > Step Input.
3. Select the Enable option.
4. Choose the MIDI or Instrument track for step entry from the Destination pop-up menu.
5. Choose the note value you wish to enter from the Step Increment section.
6. Play a note or chord on your MIDI instrument. This enters the note and moves to the next step of the insertion point.

To increase a note’s length while using Step Input:

1. Play and hold a note on your MIDI instrument.
2. Choose the note value that you would like to add and press the Increment button.

Release the note on your MIDI keyboard to move to the next step insertion point.

Step Input Controls

The Step Input page has the following controls:

Enable When selected, MIDI events are added to the destination track when you play your external MIDI keyboard. Additionally, each previously record-enabled MIDI track is taken out of record enable.

If a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled when Step Input is enabled, and is re-enabled when Step Input is no longer disabled.

Destination Lets you select the destination track for the Step Input from a pop-up list of all the MIDI tracks in your session.
Step Increment

The options in the Step Increment section let you set the spacing and duration of MIDI events entered using the Step Input operation. You can select any size from whole notes to sixty-fourth notes (including dotted values).

Tuplet Lets you input irregular note groupings (such as triplets or quintuplets). The tuplet length is calculated from the note spacing selection and the Tuplet values. For example, an eighth note equals 480 ticks, so tuplet eighth notes with 3 in time of 2 would yield a note spacing of 320 ticks (480 ticks / 3 * 2).

Note Length Lets you select the note length as a percentage of the spacing value. For example, an eighth note equals 480 ticks, so an eighth note with an 80% duration would be 384 ticks long.

Options

Use Input Velocity When selected, MIDI notes are recorded using the velocity that you play on your MIDI keyboard.

Set Velocity To When selected, MIDI notes are recorded with the velocity that you specify in the Velocity field. This value can be set with the Velocity slider.

Enable Numeric Keypad Shortcuts When selected, Step Input options can be selected from the numeric keypad. See “Numeric Keypad Shortcuts” on page 459.

Undo Step, Next Step, and Redo Step

Use the Undo Step and Next Step buttons to do the following:

- Move the step insertion point, by either removing the previous note or by advancing the insertion point by the Step Increment value.
- Lengthen and shorten notes that are being held on the MIDI controller, by adding or removing Step Increment values. The Step Increment value can be changed mid-note to create a note with a hybrid note length.

Use the Redo Step button to sequentially redo any previously undone steps.

Undo Step When the previous note has been released from the MIDI keyboard, and the insertion point has moved forward to the next note, Undo Step will remove the entire last note.

When a note is being held on the MIDI keyboard, Undo Step changes to read “Decrement,” and removes the last Step Increment length that was added to the held note.

Next Step (or Increment) When no note is being held on the MIDI keyboard, Next Step moves the insertion point by the Step Increment value, essentially inserting a musical rest.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment” and adds the Step Increment value to the held note, increasing its length by the Step Increment value.

While the note is being held, the Step Increment value can be changed, allowing you to create notes of any musical length.

Redo Step Reinserts the last note that was removed by the Undo Step operation.
The Undo Step, Next Step and Redo Step buttons can be set to be triggered by an external MIDI synth, drum pad, or other controller.

**To set Undo Step, Next Step and Redo Step MIDI triggers:**

1. Choose Event > MIDI > Step Input.
2. Locate the button you want to assign a MIDI event to, and click in the field below the button.
3. Play the MIDI event you wish to use as a trigger.
4. Press Enter to confirm the MIDI trigger assignment.

**Numeric Keypad Shortcuts**

When Enable Numeric Keypad Shortcuts is selected, you can choose many of the controls in the Step Input page, as well as several selection controls.

<table>
<thead>
<tr>
<th>Step Input Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole note</td>
<td>1</td>
</tr>
<tr>
<td>1/2 note</td>
<td>2</td>
</tr>
<tr>
<td>1/4 note</td>
<td>4</td>
</tr>
<tr>
<td>1/8 note</td>
<td>5</td>
</tr>
<tr>
<td>1/16 note</td>
<td>6</td>
</tr>
<tr>
<td>1/32 note</td>
<td>7</td>
</tr>
<tr>
<td>1/64 note</td>
<td>8</td>
</tr>
<tr>
<td>Dotted note</td>
<td>. (decimal key)</td>
</tr>
<tr>
<td>Toggle Tuplet on/off</td>
<td>3</td>
</tr>
<tr>
<td>Next step</td>
<td>Enter</td>
</tr>
<tr>
<td>Undo step</td>
<td>0</td>
</tr>
<tr>
<td>Nudge forward</td>
<td>+</td>
</tr>
<tr>
<td>Nudge back</td>
<td>-</td>
</tr>
<tr>
<td>Select Main Counter</td>
<td>=</td>
</tr>
<tr>
<td>Edit Selection indicators</td>
<td>/</td>
</tr>
</tbody>
</table>
MIDI Real-Time Properties

MIDI Real-Time Properties let you change some MIDI properties in MIDI and Instrument tracks (or MIDI regions) during playback. There are five types of MIDI Real-Time Properties: Quantize, Duration, Delay, Velocity, and Transpose.

MIDI Real-Time Properties can be adjusted during playback, while you listen for the desired result. Once you have found the desired settings, you can write the settings to the selected tracks or regions. This overwrites the corresponding MIDI properties on selected tracks or regions and resets the Real-Time Properties display.

Real-Time Properties can be adjusted in the Real-Time Properties View in the Edit window, or in the Real-Time Properties window.

Real-Time Properties View

The Real-Time Properties View in the Edit window only applies to tracks. To apply Real-Time Properties to regions, use the Real-Time Properties window (see “Real-Time Properties Window” on page 460).

To enable Real-Time Properties View in the Edit window:
■ Select View > Edit Window > Real-Time Properties.

For Mini and Small track heights, the Real-Time Properties column only displays one or two properties, respectively. By default, the first one or two properties which are enabled are displayed automatically.

To select a different Real-Time Property in Mini or Small view:
■ Control-click on Windows or Command-click on Macintosh on a real-time property element to select a different element from the pop-up menu.

Real-Time Properties Window

Using the Real-Time Properties window, you can apply Real-Time Properties to selected tracks or regions.

To open the Real-Time Properties window:
■ Choose Event > MIDI Real-Time Properties.

The Real-Time Properties window can be used to apply either track-based or region-based Real-Time Properties by making an Edit or Time selection and selecting the desired tracks or regions from the Apply To pop-up menu.
Expanded Real-Time Properties Window

In the Real-Time Properties window, Quantize, Duration, and Velocity each provide an expand/collapse triangle to show or hide additional settings.

Enabling Real-Time Properties

To enable Real-Time Properties:

1. Select a track, or make a Edit or Time selection.

2. In Real-Time Properties View in the Edit window, or in the Real-Time Properties window, select the desired Real-Time Properties by clicking the property name (Quantize, Duration, Delay, Velocity, or Transpose). Enabled Real-Time Properties are highlighted and display their settings.

3. If you are using the Real-Time Properties window and Link Track and Edit Selection mode is enabled, select the track or region to affect from the Apply To pop-up menu.


Enabled Real-Time Properties will be heard on playback and play through for the selected tracks and regions.

Real-Time Properties Settings

Quantize

Quantize either can be based on a grid or a groove template. For grid quantize, additional tuplet and grid offset settings are available in addition to the standard MIDI quantize properties. For groove quantize, additional controls are provided to set the extent to which the groove’s duration and velocities are applied. Both grid and groove quantize also let you set a strength amount, an “include” range, and a randomize amount.
Quantize Pop-Up Menu Select the desired quantize value, including all standard note rhythm values between whole notes and 64th notes, including dotted and triplet options. This pop-up menu also provides access to all standard and custom grooves.

Swing Value Enter the desired amount of swing as a percentage between 0 and 300%.

Tuplet Value Enable Tuplet and enter the ratio for the tuplet (1–99), such as 3 to 2 or 5 to 4. Tuplet is only available in the expanded Real-Time Properties window.

Offset Value Enable Offset and enter the desired offset value in Ticks between –2000 and 2000. Offset is only available in the expanded Real-Time Properties window.

Strength Value Enable Strength and enter the amount as a percentage between 0 and 100%. Strength is only available in the expanded Real-Time Properties window.

Include Enable Include and enter the range between 0 and 100%. Include is only available in the expanded Real-Time Properties window.

Random Enable Random and enter a percentage between 0 and 100%. Random is only available in the expanded Real-Time Properties window.

Duration Duration can be used to increase or decrease the duration of MIDI notes by a fixed amount or by a percentage. This is useful for creating legato or staccato passages.

Duration Mode Pop-Up Menu Select one of the following options from the Duration Mode pop-up menu: Set, Add, Subtract, Scale, Legato/Gap, or Legato/Overlap.

Swing Value

Tuplet Value

Offset Value

Strength Value

Include

Random

Duration

Duration Mode Pop-Up Menu
**Legato/Overlap** Select to extend each note to the following note. The specified duration is then added to create a consistent amount of overlap.

**Duration Amount**

If the Ticks or Notes pop-up menu is set to ticks, enter a duration as a number of quarter-notes plus a number of ticks, such as 4|000. If the Ticks or Notes pop-up menu is set to a note size, enter a number to by which to multiply that note size, such as 7 16th-notes.

**Ticks or Notes Pop-Up Menus**

Selects either Ticks or a note size for Note Durations. There is also a Ticks or Notes pop-up menu for the Minimum and Maximum Durations options.

**Minimum and Maximum Durations**

Enable either or both minimum and maximum durations and enter a value in quarter notes plus ticks or as a multiple of a note size. The Minimum and Maximum Durations options are only available in the expanded Real-Time Properties window.

**Delay**

Delay lets you delay or advance all MIDI data in the selected region or track. Select “+” from the Delay pop-up menu to delay MIDI data, or select “–” to advance MIDI data. Select Ticks or Milliseconds from the Ticks or Milliseconds pop-up menu. Enter the Delay amount in Tick or Millisecond values. Delay is limited to a maximum of value of 2000 ms or 999 ticks.

**Velocity**

Velocity lets you change MIDI velocity by a percentage or by constant value. Enter a percentage value in the Dynamics field to scale velocity around the median velocity of 64. You can also enter an offset by adding (+) or subtracting (–) values between 1 and 127. You can also enter Minimum and Maximum Velocity value limits. The Minimum and Maximum Durations options are only available in the expanded Real-Time Properties window.

Velocity can be applied as a Real-Time Property to MIDI Input and Thru.

**Transpose**

Transpose lets you transpose MIDI notes up or down by a specified number of octaves and semitones. You can also transpose to a specified pitch. Select By or To from the Transpose pop-up menu to transpose by and interval or to a specific pitch. To transpose by an interval, enter the desired number of octaves and semitones as a positive or negative numbers. To transpose to a specific pitch, enter the desired MIDI note.

Transpose can be applied as a Real-Time Property to MIDI Input and Thru.
Real-Time Properties On Tracks and Regions

Real-Time Properties can be configured to apply to an entire track (all regions on that track), or on a region-by-region basis. Track-level properties also provide real-time MIDI input processing of velocity and transposition.

The presence of track-based Real-Time Properties are indicated by a “T” displayed in the upper right-hand corner of MIDI regions. Region-based Real-Time Properties are indicated by an “R” displayed in the upper right-hand corner of the region. Regions boundaries are indicated in notes view.

Region-Based Real-Time Properties

Region-based Real-Time Properties can only be applied using the Real-Time Properties window (Event > MIDI Real-Time Properties). Real-Time Properties can be applied to multiple regions. Once Real-Time Properties have been assigned to a region, the region can be moved or copied and pasted and retain its Real-Time Properties.

Track-Based Real-Time Properties

All track-based Real-Time Properties consistently apply to MIDI sequences throughout the entire track. However, regions with region-based Real-Time Properties will take precedence over any track-based Real-Time Properties. You can clear region-based Real-Time Properties by selecting the region and clicking the Clear Region Properties button in the Real-Time Properties window (see “Writing Real-Time Properties to Tracks or Regions” on page 464).

To allow greater flexibility when using Real-Time Properties, whenever Real-Time Properties are assigned on a track basis they are actually contained in a track playlist. This lets you create multiple playlists containing different Real-Time Property settings.

Writing Real-Time Properties to Tracks or Regions

Once you have found the desired settings, you can write Real-Time Properties to the selected tracks or regions using the Real-Time Properties window. Real-Time Properties are applied to the current MIDI data on the track or in a region.

To write Real-Time Properties to tracks:
1 Select one or more tracks to which you want to apply Real-Time Properties.
2 Open the Real-Time Properties window (Event > MIDI Real-Time Properties).
3 If Link Track and Edit Selection mode is enabled, select Tracks from the Real-Time Properties Apply To pop-up menu.
4 Configure the Real-Time Property settings as desired.
5 Do one of the following:
   - Click the Write to Track button in the Real-Time Properties window.
   - or –
   - Choose Track > Write MIDI Real-Time Properties.
To write Real-Time Properties to regions:

1. Select one or more regions to which you want to apply Real-Time Properties.
3. If Link Track and Edit Selection mode is enabled, select Regions from the Real-Time Properties Apply To pop-up menu.
4. Configure the Real-Time Property settings as desired.
5. Click the Write to Region button.

To clear Real-Time Properties from a region:

1. Select the region for which you want to clear Real-Time Properties.
3. Select Regions from the Real-Time Properties Apply To pop-up menu.
4. Click the Clear Region Properties button.

Real-Time Properties In the MIDI Event List

In the MIDI Event List, the presence of track-based Real-Time Properties are indicated by a “T” displayed to the right of each event. Region-based Real-Time Properties are indicated by an “R.”

For more information on the MIDI Event List, see Chapter 24, “MIDI Event List.”
Display of Real-Time Properties Effects

The Display Events as Modified by Real-Time Properties option determines if Pro Tools displays the effects of Real-Time Properties in both the Edit window and the MIDI Event List. The Edit window and the MIDI Event List display the effects of Real-Time Properties when the Display Events as Modified by Real-Time Properties option is enabled. With this option disabled, the effects of Real-Time Properties are heard but not seen—you see the notes and other MIDI events with their original location, pitch, duration, or velocity, but you hear them as they are effected by the Real-Time Properties settings.

To enable or disable the Display Events as Modified by Real-Time Properties option:
1. Choose Setup > Preferences.
2. Click the MIDI Tab.
3. Enable or disable the Display Events as Modified by Real-Time Properties option.
4. Click Done.

Real-Time Properties Effects Displayed in the MIDI Event List

The MIDI Event List takes into account the effect of Real-Time Properties whenever the Display Events as Modified by Real-Time Properties preference is enabled. When editing or inserting an event in a track or region with active Real-Time Properties, Pro Tools takes the properties into account and edits or inserts the event in a different place if necessary to match the effect of the Real-Time Properties.

Real-Time Properties Effects Displayed in the Edit Window

In the Edit window with the Display Events as Modified by Real-Time Properties preference enabled, MIDI events appear where they sound. However, MIDI events are not actually written to their modified locations until you write the Real-Time Properties to the track or region.

When moving MIDI events, the actual locations (pitch or time) move by the amount the events are dragged, but the effect of Real-Time Properties is displayed.

When inserting an event in a track or region with active properties, Pro Tools takes the properties into account and edits or inserts the event in a different place if necessary to match the effect of the Real-Time Properties.
Chapter 24: MIDI Event List

The MIDI Event List

The MIDI Event List displays a detailed list of all events in a single MIDI or Instrument track. The events are displayed with text and numbers, allowing you to precisely edit their location, length, and event values.

Events in the MIDI Event List can be copied and pasted, selected, or deleted. Any MIDI event (except Sysex) can be inserted and edited in the list. Certain MIDI event types can be hidden with the View Filter.

Unlike playlists in the Edit window, you can insert and display polyphonic aftertouch in the MIDI Event List.

Mute data for MIDI and Instrument tracks is not displayed in the MIDI Event List.

Opening the MIDI Event List

To open the MIDI Event List, do one of the following:

- Choose Event > MIDI Event List.
- Start-double-click (Windows) or Control-double-click (Macintosh) a MIDI or Instrument track name in the Mix or Edit window.
- Press Alt+Equal (Windows) or Option+Equal (Macintosh).

You can also use Alt+Equal (Windows) or Option+Equal (Macintosh) to toggle between the MIDI Event List and the Edit window.
**Menus in the MIDI Event List**

At the top of the MIDI Event List are three pop-up menus:

**Track Selector** Indicates the MIDI or Instrument track currently displayed, and can be used to choose a different MIDI or Instrument track to be displayed.

**Options Menu** Contains commands and options for the MIDI Event List (see “MIDI Event List Options” on page 474).

**Insert Menu** Contains a list of event types that can be inserted.

To the right of these pop-up menus, the number of displayed events is indicated.

**Columns in the MIDI Event List**

Information for the events in the MIDI Event List is displayed in the following three columns:

**Start Column** Displays the start location, using the Main Time Scale, for each event. Locations can also be displayed in the Sub Time Scale when the Show Sub Counter option is selected in the Options pop-up menu.

The playback cursor appears as a blue arrow (red, when tracks are record-enabled) in the Start column.

When several events reside at the same location, the location is only indicated for the top event, with the others dimmed. The dimmed locations can be edited by double-clicking them.

**Event Column** Displays the event type, indicated by an icon, and associated event values.

**Length/Info Column** Displays the end point or length for notes, depending on which option is selected in the Options pop-up menu. Also displayed are the names for continuous controller events and program changes.

**View Filter for MIDI Event List**

You can use the View Filter to specify which event types are displayed in the MIDI Event List. This can help you zero in on only the events you want to affect; it also protects MIDI events from being edited or deleted. Events not displayed in the MIDI Event List still play back.

The View Filter can be set to display “all” messages, “only” the specified messages, or “all except” the specified messages.

⚠️ When inserting an event type that has been filtered from the MIDI Event List, that event type will no longer be filtered.
For example, to filter the display of aftertouch and System Exclusive Messages in the MIDI Event List:

1. In the MIDI Event List, choose View Filter from the Options pop-up menu.
2. In the MIDI Event List View Filter dialog, select the All Except option.
3. Select the options for Mono Aftertouch, Polyphonic Aftertouch, and System Exclusive. Leave all other messages deselected.

When using the All Except option, the selected events are not displayed. Conversely, when using the Only option, only the selected events are displayed.
4. Click OK.

**Navigating in the MIDI Event List**

You can use the Tab and Arrow keys to move through the MIDI Event List. You can also locate to the Edit start point, or any other specified location.

To move through the MIDI Event List, do one of the following:

- Double-click to edit a value.
- Press Tab or the Down Arrow to move to the next event (with or without the edit field selected).
- Press Control+Tab (Windows) or Option+Tab (Macintosh) or the Up Arrow to move to the previous event (with or without the edit field selected).
- With an edit field selected, press the Right Arrow to move to the next edit field to the right.
- With an edit field selected, press the Left Arrow to move to the next edit field to the left.

To keep the last event selected, press Shift while moving to the next or previous event.

**To go to the Edit start point:**

- In the MIDI Event List, choose Scroll To Edit Selection from the Options pop-up menu.

**To go to a specific location in the MIDI Event List:**

1. In the MIDI Event List, choose Go To from the Options pop-up menu.
2. In the Go To dialog, choose a format from the Time Scale pop-up menu.
If using Time Code (Pro Tools HD and Pro Tools LE with DV Toolkit only), you can select the Use Subframes option.

3 Enter the location you want to go to, then click OK.

The following items from the Options menu affect navigating in the MIDI Event List:

- When the Page Scroll During Playback option is selected, the MIDI Event List scrolls during playback.
- When Scroll During Edit Selection is selected, the MIDI Event List is scrolled automatically when the Edit selection changes in the Edit window.

### Inserting Events in the MIDI Event List

You can insert events in the MIDI Event List by choosing an event type from the Insert menu. Following are several examples of inserting events in the MIDI Event List.

#### To insert a note in the MIDI Event List:

1. Click the Insert button and choose Note from the pop-up menu.
   - or –
   Press Control+N (Windows) or Command+N (Macintosh).

2. Enter the location, pitch, attack and release velocities, and length for the new note. To move between the Event Entry fields, use the Left and Right Arrow keys.

   - When a field is selected, enter a value with any of the following methods:
     - Enter the value on the numeric keypad.
     - Drag up or down to scroll to the value.
     - Play the note on your MIDI controller keyboard, then press Enter (Windows) or Return (Macintosh) on the QWERTY keyboard to confirm the value.

3. To insert the note and remain in Event Entry mode, press Enter on the numeric keypad.
   - or –
   To insert the note and exit Event Entry mode, press Enter (Windows) or Return (Macintosh) on the QWERTY keyboard.
To exit Event Entry mode, without inserting the note event, press Escape on the QWERTY keyboard.

To insert a controller event in the MIDI Event List:

1. Click the Insert button and choose Controller from the pop-up menu.
   - or -
   Press Control+L (Windows) or Command+L (Macintosh).

2. Enter the location, controller “type” number, and controller value for the new event. The controller name is displayed in the Length/Info column, to the right of the controller value. To move between the Event Entry fields, use the Left and Right Arrow keys.

When a field is selected, enter a value with any of the following methods:

- Enter the value on the numeric keypad.
- Press the Up or Down Arrow to scroll to the value.
- While pressing Control (Windows) or Command (Macintosh), drag up or down to scroll to the value.
- Play the controller event on your MIDI controller keyboard, then press Enter (Windows) or Return (Macintosh) on the QWERTY keyboard to confirm the value.

3. Do one of the following:
   - To insert the controller event and remain in Event Entry mode, press Enter on the numeric keypad.
   - To insert the controller event and exit Event Entry mode, press Return on the QWERTY keyboard.
   - To exit Event Entry mode, without inserting the controller event, press Escape on the QWERTY keyboard.

To insert a program change in the MIDI Event List:

1. Click the Insert button and choose Program Change from the pop-up menu.
   - or -
   Press Control+P (Windows) or Command+P (Macintosh).

2. Enter the location for the new event.

3. Enter a Program Change number and Bank Select value (if necessary). The program change name is displayed in the Info column.

   You can click in the Info column to open the Program Change window (for details, see “Patch Select (Program and Bank Changes)” on page 429).

   With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.
4 Do one of the following:
- To insert the program change and remain in Event Entry mode, press Enter on the numeric keypad.
- To insert the program change and exit Event Entry mode, press Return on the QWERTY keyboard.
- To exit Event Entry mode, without inserting the program change, press Escape on the QWERTY keyboard.

**Inserting Another Event**

After inserting an event, you can easily insert another event of the same type. The event type to be inserted is indicated at the bottom of the Insert menu.

For example, after inserting a note, to insert another:
- Click the Insert button and choose Another Note from the pop-up menu.
- or –
- Press Control+M (Windows) or Command+M (Macintosh).

💡 When the option for Insert At Playback Location is enabled (see “MIDI Event List Options” on page 474), you can use the keyboard shortcuts for inserting “another” event to insert events on-the-fly.

---

**Editing in the MIDI Event List**

Events in the MIDI Event List can be edited, selected, deleted, and copied and pasted.

**To edit an event in the MIDI Event List:**

1. Double-click the event field you want to edit.
   – or –
   To edit a selected event, press Control+Enter (Windows) or Command+Enter (Macintosh).

2. Enter a new value with any of the following methods:
   - Enter the new value on the numeric keypad.
   - While pressing Alt (Windows) or Option (Macintosh), press the Up or Down Arrow to scroll to a new value.
   - While pressing Control (Windows) or Command (Macintosh), drag up or down to scroll to a new value.
   - Play the new note or controller value on your MIDI controller keyboard, then press Enter (Windows) or Return (Macintosh) on the QWERTY keyboard to confirm.

3. To accept the new value, do one of the following:
   - To enter the new event value and move to another field or event, use the Arrow keys.
   - To enter the new value and remain in Edit Entry mode, press Enter on the numeric keypad.
   - To enter the new value and exit Edit Entry mode, press Enter (Windows) or Return (Macintosh) on the QWERTY keypad.
   – or –
   To exit Edit Entry mode without entering the new value, press Escape on the QWERTY keyboard.
Selecting in the MIDI Event List

To select a range of events in the MIDI Event List:
- Click the event at the beginning of the selection and drag to the ending event.
- or -
- Shift-click the event at the beginning of the selection, then Shift-click the ending event.

To select discontiguous events in the MIDI Event List:
- Control-click (Windows) or Command-click (Macintosh) each event.

To remove an event from the selection in the MIDI Event List:
- Control-click (Windows) or Command-click (Macintosh) the selected event.

Notes selected in the MIDI Event List can be modified by any of the commands in the MIDI Operations window. For details, see Chapter 23, “MIDI Operations.”

Deleting in the MIDI Event List

To delete an event in the MIDI Event List:
- Alt-click (Windows) or Option-click (Macintosh) the event you want to delete.

To delete a selection of events in the MIDI Event List:
1. Select the events you want to delete, by either dragging in the Start column, or by Shift-clicking each event.
2. To view only the events you want to delete, use the View Filter (see “View Filter for MIDI Event List” on page 468). Events not displayed cannot be deleted.
3. Choose Edit > Clear to delete all selected events.
- or -
Press Backspace (Windows) or Delete (Macintosh) on the QWERTY keyboard.

Copy and Paste in the MIDI Event List

To copy and paste in the MIDI Event List:
1. Select the range of events you want to copy by dragging in the MIDI Event List. To select discontiguous events, Control-click (Windows) or Command-click (Macintosh) each event you want to copy.
2. Choose Edit > Copy.
3 To paste the material at an existing event's location, click the event in the MIDI Event List.

– or –

To paste the material at any location, choose Go To from the Options menu in the MIDI Event List, enter the location you want to paste to, and click OK.

4 Choose Edit > Paste. The events from the Clipboard are pasted, replacing any existing events already there.

To paste events without overwriting other events, use the Merge Paste Special command.

### MIDI Event List Options

<table>
<thead>
<tr>
<th>MIDI Event List options</th>
</tr>
</thead>
<tbody>
<tr>
<td>The MIDI Event List provides the following options:</td>
</tr>
<tr>
<td><strong>Show Sub Counter</strong> Displays event times in the Sub Time Scale.</td>
</tr>
<tr>
<td><strong>Go To</strong> Opens the Go To dialog, where you can specify a location, based on any of the supported Time Scales, to which the Edit insertion point is moved.</td>
</tr>
<tr>
<td><strong>Scroll To Edit Selection</strong> Scrolls the MIDI Event List to the Edit start point or Edit insertion point.</td>
</tr>
<tr>
<td><strong>Page Scroll During Playback</strong> Scrolls the MIDI Event List during playback.</td>
</tr>
<tr>
<td><strong>Scroll During Edit Selection</strong> Scrolls the MIDI Event List automatically when the Edit selection changes in the Edit window.</td>
</tr>
<tr>
<td><strong>Show Note Length</strong> Displays note lengths, instead of note end times, in the Length/Info column of the MIDI Event List.</td>
</tr>
<tr>
<td><strong>Show Note End Time</strong> Displays note end times, instead of note lengths, in the Length/Info column of the MIDI Event List.</td>
</tr>
<tr>
<td><strong>Insert At Edit Location</strong> Defaults the location for inserted events defaults to the Edit start point or Edit insertion point.</td>
</tr>
<tr>
<td><strong>Insert At Playback Location</strong> Lets you insert events in the MIDI Event List in real time while listening to the session playback.</td>
</tr>
<tr>
<td><strong>Insert At Playback Location With Grid</strong> Snaps the location for events inserted in real time to the grid.</td>
</tr>
<tr>
<td><strong>View Filter</strong> Opens the View Filter dialog, where you can specify which events are displayed in the MIDI Event List. Events that are not displayed are not affected by Cut, Copy, and Paste operations in the MIDI Event List. Events that are not displayed still play back. For more information, see “View Filter for MIDI Event List” on page 468.</td>
</tr>
</tbody>
</table>
Part VI: Mixing
Chapter 25: Basic Mixing

In addition to the final mixdown, mixing tasks can occur any time during a recording session. This chapter covers Pro Tools mixing, including audio signal flow, output and bus paths, sends, and signal routing for submixing and mixdown.

During mixing, real-time plug-ins and hardware inserts provide effects and signal processing (see Chapter 26, “Plug-In and Hardware Inserts”).

Mixing Concepts

Mixing involves making decisions about elements such as volume levels, panning, and effects. These mixing decisions are initially based on what you hear in your studio. While you can control many variables in your studio (such as speakers and room acoustics), you cannot control the listening environment in which your final mix will be heard. The following tips include a few ways to make sure your mix will sound as good as possible to as many listeners as possible:

Alternate Speakers and Reference Monitoring Listen to your mixes on a variety of different speakers, to gauge how well the mix will translate. By listening to a mix through different playback systems, you are attempting to anticipate what the intended audience will hear.

Reference Mixes Tapes and discs of rough mixes let you audition mixes outside the studio in different listening environments.

Format Compatibility Monitoring Stereo mixes must often be mono-compatible. When you are mixing in multichannel surround, mixes may also need to be compatible with stereo or mono playback systems (see Chapter 29, “Surround Concepts (Pro Tools HD Only)”)

Metering and Calibration

Meters provide a visual display of signal levels. They tell whether signal is getting to a channel, and how loud or soft a signal is relative to (above or below) 0.

By calibrating all your equipment to standard reference levels, a consistent level can be achieved (and metered) among different recording devices in a studio, throughout a facility, or throughout an entire production chain of a feature-length film. For example, a level of, say, –18 dBFS coming out of a DAT deck should play and meter at –18 dBFS in Pro Tools.

Use the Calibration Reference Level option (in the Operations Preferences page) to set a default calibration reference level when Pro Tools is in Calibration mode.

For audio interfaces that have trims (such as the 192 I/O), see the interface’s guide for calibration instructions.
Signal Flow

Pro Tools provides four different types of audio tracks:
- Audio (disk tracks)
- Auxiliary Input
- Master Fader
- Instrument

Mono and stereo audio tracks are available on all Pro Tools systems.

Multichannel audio tracks and surround mixing formats are supported by Pro Tools HD only.

Pro Tools also provides two types of MIDI tracks:
- MIDI
- Instrument

Instruments tracks are listed under audio tracks and MIDI tracks because they are a combination of Auxiliary Input and MIDI tracks.

Tracks can be identified in the Mix window by their Track Type icon:

Audio, Auxiliary Input, Master Fader, MIDI, and Instrument tracks

For information on creating tracks, see “Creating Tracks” on page 93.

Audio Tracks

Audio tracks play audio from disk, record audio to disk, or monitor input signals when record-enabled, or in TrackInput monitoring mode. Inserts on audio tracks are pre-fader. Sends can be pre- or post-fader.
Auxiliary Input Tracks

Auxiliary Inputs provide the same signal routing options as audio tracks, except that their input must come from an internal bus or hardware input. Inserts on Auxiliary Inputs are pre-fader.

Common Uses for Auxiliary Inputs

By bussing tracks to the Auxiliary Input, you can:

- Apply real-time plug-ins or an external processor to a submix, using the Auxiliary Input as an effects return (such as reverb or bus line compression)
- Input audio from external MIDI instruments and other audio sources into the mix, to monitor or route to audio tracks for recording to disk (such as from the audio outputs of a MIDI synthesizer)
- Consolidate volume control of any submix under a single fader
- Play back audio from an instrument plug-in (although Instruments tracks are the recommended way to integrate instrument plug-ins, such as Digidesign Synchronic)

To route an Auxiliary Input:

1. Click the Input Path selector of the Auxiliary Input and choose an input or bus path.
2. Click the Output Path selector of the Auxiliary Input and choose an output or bus path.
3. Adjust the Auxiliary Input fader to set the return volume (it defaults to $-\infty$ dB).

Audio signal flow, Aux Input tracks

Auxiliary Inputs are used as inputs for audio from external MIDI instrument and other sources, as well as to submix internal bus and output paths. They can be fully automated. When using Auxiliary Inputs as inputs for external sources, adjust the source output levels to achieve proper recording levels.

Submix examples begin in “Submixing for Signal Routing and Effects Processing” on page 499.
**Master Fader Tracks**

Master Faders control the master output levels of output and bus paths. When assigned to an active output or bus path, they provide post-fader effects processing and master level control for a main mix, headphone and cue mixes, stems, effects sends, and other signal routing applications. Master Faders support all track formats supported on your Pro Tools system.

Master Faders provide up to five post-fader inserts and no sends. Also, Master Fader tracks do not have Pan sliders, or Mute and Solo buttons.

*If you absolutely must have a pre-fader insert on your Master Fader signal, set up an Auxiliary Input before the Master Fader.*

### Common Uses for Master Faders

Master Faders can be used to:

- Control and process output mixes
- Monitor and meter an output (such as a bus or hardware output) to guard against clipping
- Control submix levels
- Control effects sends levels
- Control submaster (bussed tracks) levels
- Apply dither or other inserts to an entire mix

Use Master Faders to control submix levels, send level masters, and other outputs. Master Faders can control either audio interface outputs or internal busses. A Stereo Master Fader controls the level of a pair of outputs. Master Faders do not consume any of your system’s audio processing power.

**To use a Master Fader as a stereo master volume control:**

1. Create a stereo Master Fader track.
2. Set the outputs of all audio tracks in the session to the main output path (for example, outputs 1–2 of your primary audio interface) and set the panning for each track.
3. Set the output of the Master Fader to the main output path.
**Master Fader Meters**

Meters on Master faders always show post-fader levels, regardless of the Pre-Fader Metering setting in the Options menu.

**Master Faders and Paths**

Master Faders can be assigned to main or sub-paths as defined in the I/O Setup. Multiple Master Faders cannot be assigned to the same path.

**Active and Inactive Master Faders**

When a Master Fader track is inactive, its associated plug-ins, I/O assignments, and their resources are made inactive.

When a Master Fader output assignment (path assignment) is made inactive, the Master Fader no longer controls the master gain of that path.

When you duplicate a Master Fader track, the duplicated track’s assignment will be inactive.

**Instrument Tracks**

Instrument tracks provide the same audio signal routing options as Auxiliary Input tracks, except that their input must come from an instrument plug-in inserted on that Instrument track, or from a bus or hardware input. Instrument tracks provide up to ten pre-fader inserts.

*Audio signal flow, Instrument tracks*

Instrument tracks are used as inputs for instrument plug-ins, and other sources (including internal busses). They can be fully automated. When using Instrument tracks as inputs for external sources, adjust the source output levels to achieve proper recording levels.
Common Uses for Instrument Tracks
By playing back MIDI from or through an Instrument track you can control and monitor the audio from:

- Instrument plug-ins, such as software synthesizers or samplers.
- External MIDI instruments, such as synthesizers and samplers.

To route audio from an external MIDI instrument to an Instrument track:
1. Click the Input Path selector of the Instrument track and choose the corresponding hardware input for your external MIDI instrument.
2. Click the Output Path selector of the Instrument track and choose an output or bus path.
3. In Instruments view, click the MIDI Input selector, and assign a device and channel from the pop-up menu to record and control the external MIDI instrument.
4. In Instruments view, click the MIDI Output selector, and assign the port and channel for the external MIDI instrument from the pop-up menu.
5. Adjust the Instrument fader to set the volume (it defaults to $-\infty$ dB).

For information on assigning MIDI input and output for Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 106

For information inserting Instrument plug-ins on Instrument tracks, see “Inserting Instrument Plug-Ins on Instrument Tracks” on page 107

Inserts
Pro Tools lets you insert up to five inserts on each audio, Auxiliary Input, Master Fader, or Instrument track. Each insert can be either a software plug-in insert or a hardware insert, or an instrument plug-in.

Inserts provide the following features:
- Plug-ins and hardware inserts route the signal from the track through the effect of your choice, and automatically return it to the same track.
- Hardware inserts send and return the signal to corresponding input and output channels of an audio interface, which can be connected to outboard effects.
- Some Instrument plug-ins (such as Virus Indigo) accept audio from the track input (letting you use them as processing plug-ins.
- Inserts on audio, Auxiliary Input, and Instrument tracks are pre-fader.
- Inserts on Master Faders are post-fader.
- Inserts can be bypassed or made inactive.
- Most plug-in controls are fully automatable.

See Chapter 26, “Plug-In and Hardware Inserts” for details about using plug-ins and inserts.

Track Output Format and Plug-Ins
Pro Tools supports mono, multi-mono, stereo, and multichannel plug-ins (Pro Tools HD with Surround Mixer only).

Because inserts process in series, changing the plug-in format can alter the channel format. For example, inserting a mono-to-stereo plug-in on a mono Auxiliary Input changes the signal path from that plug-in through the rest of the track.
This restricts all hardware inserts or plug-ins after the stereo plug-in to be stereo-in/stereo-out plug-ins (or the supported multichannel format).

**Plug-In Formats**

Pro Tools supports mono and stereo plug-ins, including the following three types of plug-in paths:

- mono-in/mono-out
- mono-in/stereo-out
- stereo-in/stereo-out

Pro Tools HD sessions running with the Surround mixer also support 3–8 channel, multimon and multichannel plug-ins.

**Views in the Mix and Edit Windows**

The Mix and Edit windows can be configured to show or hide various mixing controls, using menu commands or view selectors.

Most of these views are available in both windows, unless noted.

**Window View Selectors**

Both the Edit window and Mix window provide Window View selectors to configure their views.
Comments View Shows any text entered as comments in the Track Name/Comments dialog. For more information, see “Naming Tracks” on page 94.

Mic Preamps View Shows controls in each track for the Digidesign PRE. Deselect to hide. For detailed information, see the PRE Guide.

Instruments View Shows MIDI controls on Instrument tracks (MIDI Input selector, MIDI Output selector, MIDI volume, MIDI pan, and MIDI mute).

Inserts View Shows inserts (software plug-ins and hardware I/O inserts) in each track. Deselect to hide.

Sends View (Sends A–E and Sends F–J) Shows send assignments in each track. Deselect to hide. For more information, see “Configuring Sends View in the Mix and Edit Windows” on page 489.

I/O View (Edit Window Only) Shows Input and Output selectors, and Volume and Pan indicators in each track. Deselect to hide.
Shift-click (Windows) or Control-click (Macintosh) on the volume or pan fields in the Edit window I/O view to adjust the volume or pan controls with a pop-up fader.

**Delay Compensation View (Mix Window on Pro Tools HD Only)** The Delay Compensation View displays the total amount of plug-in delay on each track, lets you apply a user offset of track delay, and displays the total amount of delay that Pro Tools applies to each track. The Delay Compensation View can be shown in the Mix Window.

Delay values can be specified in either samples or milliseconds, as selected in the Display Preferences page. For more information on Delay Compensation, see “Delay Compensation” on page 505.

**Track Color View** Shows track color in each track. Deselect to hide. For detailed information, see “Color Coding for Tracks, Regions, Markers and Groups” on page 111.

**Transport View (Edit Window Only)** Displays functional transport controls in the top upper–right of the Edit window. These controls are the same as those in the Transport window. For more information, see “The Transport Window” on page 25.
Hiding Views in the Edit Window

You can quickly View columns in the Edit window using a simple keyboard shortcut.

To hide a View column in the Edit window:

- Alt-click (Windows) or Option-click (Macintosh) at the top of the column you want to hide (Mic Pre, Comments, Instrument, Inserts, Sends A–E, Sends F–J, I/O, Real-Time Properties, or Track Color).

Audio Input and Output Paths

Pro Tools lets you configure the physical input and outputs of your audio interfaces and also internal bus paths and subpaths in the I/O Setup dialog and the Hardware Setup dialog. These hardware inputs and outputs, and internal bus paths can be assigned as inputs and outputs on audio, Auxiliary Input, Instrument tracks, and Master Faders.

Input Audio Path

Input Path selectors determine the source input for audio, Auxiliary Input, and (optionally) Instrument tracks. Track inputs can be set from a hardware input or internal bus paths or subpaths. For detailed information on assigning track inputs, see “Assigning Audio Track Inputs” on page 101.

Hardware input and bus paths can be configured in the I/O Setup. For more information, see Chapter 7, “I/O Setup.”

You can also define what physical ports are routed to Pro Tools input ports in the “Main” page of the Hardware Setup dialog. For more information, see “Configuring Pro Tools System Settings (in the Playback Engine)” on page 37.

Output Audio Path

Track Output Path selectors route the post-fader signals to the assigned output or bus paths. The Output Path selector routes the main track output to the chosen main or sub-path. Tracks can be routed directly to hardware output or internal bus paths and subpaths for submixing (main or sub-paths).

The track format (mono, stereo, or multichannel) determines the available main and sub-path choices for track output. For detailed information on assigning track outputs, see “Assigning Audio Track Outputs” on page 101.

When audio, Auxiliary Input, Master Fader, and Instrument tracks are created, their mono, stereo, or greater-than-stereo multichannel format is defined:

- Mono tracks can be assigned to any available mono, stereo, multichannel main and sub-paths.
- Stereo tracks can be assigned to any available mono, stereo, or multichannel main and sub-paths.
- Multichannel tracks can be assigned to any mono path, or path of the same number of channels (for example, an LCRS track can be assigned to a mono or LCRS path).

Output Windows

Output windows provide the essential track mixing controls (such as track panning and volume), as an alternative to Mix and Edit window views. Multichannel Output and Send windows also provide expanded Panner views, and other surround-specific controls (see Chapter 32, “Surround Panning and Mixing (Pro Tools HD Only).”)
Output windows are useful in large sessions to leave important tracks in an anchored location, unaffected by Mix and Edit window (or control surface) banking. See “Output Windows for Tracks and Sends” on page 494.

**Multiple Output Assignments**

Pro Tools audio, Auxiliary Input, and Instrument tracks can be assigned to multiple output paths. Assigning to multiple paths is an efficient way to route an identical mix to other discrete outputs, for simultaneous monitor feeds, headphone mixes, or other situations where a parallel mix is needed.

**To assign a track to multiple outputs:**

1. Assign a main output path by selecting it from the track’s Output Path selector.

2. Start-click (Windows) or Control-click (Macintosh) an additional output path in the track’s Output Path selector. The newly selected output destination is added as an additional output.

- Alt-Start-click (Windows) or Option-Control-click (Macintosh) to add the assignment to all tracks, or Alt-Shift-Start-click (Windows) or Option-Shift-Control-click (Macintosh) to add to all selected tracks.

**Display of Multiple Output Assignments**

When a track is assigned to multiple output paths, the Output Path selector denotes multiple assignment status and active/inactive status with the following indicators:

- A plus sign (+) indicates that the track has multiple output assignments.
- In the Output Path selector menu, all currently assigned track outputs are checked to indicate they are active for the current track.
- An asterisk (*) indicates that one or more currently assigned outputs is Inactive.

**Inactive Outputs**

An output path can be made inactive, either globally in the I/O Setup dialog (affecting all tracks assigned to that path), or locally per assignment (only affecting that output on that audio track or Auxiliary Input).

When opening sessions, outputs will be made inactive automatically if the required hardware or other resources are not available.

Inactive outputs retain all associated automation playlists. Edits made in the session also affect the inactive track’s output automation playlists.

See “Making Tracks Inactive” on page 111.

**Inactive Outputs and DSP Resources**

Making a track output inactive silences the output, while retaining all automation and playlist data. Inactive outputs do not consume resources for TDM mixer connections, but any assigned plug-ins on the track continue to use their required DSP resources. RTAS plug-ins require CPU resources, and TDM plug-ins use the DSP available on Pro Tools|HD cards.

You can free up DSP of unused plug-ins by making a track inactive, or by just making the plug-in inactive.

See “Active and Inactive Items” on page 17, and “Making Inserts Inactive” on page 514 for more information.
About the “No Output” Option

Track outputs can be set to No Output. Assigning a track output to No Output loses any panning automation associated with the track.

Tracks assigned to No Output will not be audible, but they do not free their associated DSP resources.

Sends

Pro Tools lets you insert up to ten sends (A–E and F–J) on each audio track, Auxiliary Input, or Instrument track.

Sends provide the following features:

• Sends can be set as pre- or post-fader.
• Send level and mute can be configured to follow Groups.
• Send level, send mute, and send pan (for stereo and multichannel sends) are fully automatable. See “Automating Sends” on page 544.
• Send controls can be displayed and edited from the Mix or Edit windows, or in their own output windows.
• Sends can be assigned to available output and bus paths (main or sub-paths), in mono or stereo, or any of the supported multichannel formats for surround mixing.
• Each send can have multiple assignments (for example, to available output and bus paths).

Sends must be returned to the mix through an Auxiliary Input, audio track, or Instrument track, to be audible in Pro Tools. They can be monitored and processed through an Auxiliary Input (or Instrument track), recorded to audio tracks, and bounced to disk. (Bouncing and mixdown are explained in Chapter 28, “Mixdown.”)

Assigning Sends to Tracks

To add a send to a track:

1. Make sure Sends View is enabled in the Mix or Edit window (see “Views in the Mix and Edit Windows” on page 483 for information).
2. Click the Sends button on the track and choose a path from the pop-up menu.
3 Set the output level of the send in the Send window:
   • Adjust the Send Level fader.
   – or –
   • Set the send level to unity gain (0 dB) by
     Alt-clicking (Windows) or Option-clicking
     (Macintosh) the Send Level fader.

The first time you create a new send, its output
level is automatically set to off, displayed on-
screen as –INF (–∞).

To change the default setting for sends:
1 Choose Setup > Preferences and click the
Operation tab.
2 Select Sends Default to “–INF.”
   – or –

Deselect Sends Default to “–INF” and new sends
will default to unity gain (0 dB).

To remove a send from a track:
■ Click the Sends button on the track and
choose No Send from the pop-up menu.

Send Formats

Mono and Stereo Sends When you click the
Sends button on a track, you can choose from a
list of mono or stereo output or bus paths.

Multichannel Sends (Pro Tools HD Only) When
you click the Sends button on a track, you can
choose from a list of multichannel output or bus
paths.

Send Path Choices

The choices available in track Send selectors in-
clude bus and output paths.

The names, format, and channel mapping
of busses and output paths can be custom-
ized in the I/O Setup dialog. See “Creating
and Editing Paths” on page 74.

Internal Mix Busses Pro Tools HD provides 128
busses and Pro Tools LE provides 32 busses for
routing signals internally. Internal bus paths are
useful for submixing and processing with plug-
ins. Bus paths are defined in the I/O Setup dia-
log, and are available in all supported channel
formats (mono, stereo, or multichannel, as sup-
ported on your system).

Hardware Outputs Hardware sends are often
used for headphone cue mixes, or for sending
signals to external effects processors. Sends do
not automatically return audio as do hardware
inserts.

Configuring Sends View in the Mix
and Edit Windows

Audio tracks, Auxiliary Inputs, and Instrument
tracks include two sets of Sends Views: Sends
A–E (sends 1–5) and Sends F–J (sends 6–10). The
View menu provides separate options for view-
ing these sends in the Mix and Edit windows.

To display sends in the Mix or Edit window:
■ Select View > Mix Window (or Edit Window) >
Sends View Options

Sends are displayed in the Mix and Edit window according to the Sends A–E View and Sends F–J View options. Each Send View has six view choices: Assignments View and five individual Send Views (A–E or F–J).

Assignments View

This is the default Sends View, showing all five of the Sends A–E or Sends F–J sends on all tracks displayed in the Mix and Edit windows.

---

To show all send assignments:

1. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).
2. Do one of the following:
   - Select View > Sends A–E > Assignments or View > Sends F–J > Assignments.
   - or –
   - When displaying sends in an individual Send View (such as Send A View), Control-click (Windows) or Command-click (Macintosh) the Send selector and select Assignments.

Individual Send Views (A–J)

Individual Send Views (such as Send A) provide send level, pan, and mute controls for a single send across all tracks.

---

Assignments View, no sends (left) and with an assigned send (right)

In Assignment View, send controls are adjusted from Send windows. See “To view a different track Output or Send window:” on page 494.

Send A View, with different types of send assignments

Send controls can be adjusted directly from these Send Views. Sends can also be opened for control or metering in Send windows. See “Output Windows for Tracks and Sends” on page 494.
To display the controls for an individual send across all tracks:

1. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).

2. Do one of the following:
   - Select View > Sends A–E (or Sends F–J) and select one of the individual Send Views (such as Send A).
   - or –
   - In Assignment View, Control-click (Windows) or Command-click (Macintosh) the Send Assignment selector.

Editing Sends in the Mix and Edit Windows (Individual Send Views)

Individual Send Views (such as Send A) display all the controls of an individual send in the sends area of the Mix and Edit windows. These views provide full access to all controls for that send on all tracks.

Send level and mute can follow Mix groups, to adjust multiple send controls from a single set of controls. See “Sends and Groups” on page 499.

Individual Send Views and Meters

When you display the controls for an individual send, you also have the option of displaying send level meters.

Send level meters show peak values and indicate clipping that occurs while the meter is displayed (if a send clips any time before its meter is displayed, this is not shown). If you are using a slower computer, hiding send level meters can improve screen redraw times.

To display send level meters when viewing individual sends:

1. Choose Setup > Preferences and click the Display tab.
2. Select Show Meters in Sends View and click Done.

To clear a send meter’s Clip indicator:

- Click the Clip indicator.

To clear all meters, do one of the following:

- Option-click any Clip indicator.
- Choose Track > Clear All Clip Indicators.
- Press Alt-C (Windows) or Option-C (Macintosh).

In Assignment View, edit sends by opening their Output windows. See “Output Windows for Tracks and Sends” on page 494.
Send Status Display

When displaying all controls for an individual sends, the Send status is visible directly in the Mix or Edit windows.

In Assignment View, Send status is displayed as follows:

- By default, the Send button is grey, to indicate that it is unmuted.
- The Send button text is red when the send has clipped.
- The Send button is blue when the send is muted.
- The Send button is lit whenever a send’s window is open.

If you use a control surface (such as D-Control or Digi 002) with Pro Tools, colored outlines around sends, inserts, and outputs indicate the current controller focus.

Inactive Sends

Sends can be made inactive. Inactive sends free their DSP and mixer resources, while retaining their position in track Sends View. Inactive sends do not output audio. However, Inactive sends retain all related automation playlists. In addition, edits made to regions on tracks with inactive sends can still affect the sends automation playlists.

When opening sessions, sends will automatically be made inactive if the required hardware or other resources are not available.

To make a send inactive:

- Control-Start-click (Windows) or Command-Control-click (Macintosh) on the Send assignment.
  – or –
- Make the Track inactive. See “Making Tracks Inactive” on page 111.

To toggle sends in the same position (A–J) and assigned to the same path on all tracks active or inactive:

- Control-Start-Alt click (Windows) or Command-Control-Option click (Macintosh) a send button in the position you want to toggle.

To toggle sends in the same position (A–J) and assigned to the same path on all selected tracks active or inactive:

- Control-Start-Alt-Shift-click (Windows) or Command-Control-Option-Shift-click (Macintosh) a send button in the position you want to toggle.
Moving or Copying Sends

Sends can be moved or copied to other tracks, or to other positions on the same track using conventional drag and drop. Sends can be dropped to create new sends at the destination, or dropped onto existing send assignments to replace them.

Sends can be moved and copied to tracks with compatible send formats (mono, stereo, or other). Pro Tools alerts you when you try to move or copy a send to an incompatible destination. (For more information, see “Send Format and Track Compatibility” on page 493).

To move a send:

1. Make sure the Transport is stopped.
2. Click the send name and drag it at a new position in the original track or in a different track.

To copy a send:

1. Make sure the Transport is stopped.
2. Alt-drag (Windows) or Option-drag (Macintosh) the send and drop it at a new position.

Moving or copying a send maintains all routing assignments, automation (if any), level/pan/mute settings, and output format.

Send Format and Track Compatibility

Sends can only be copied to other tracks with a compatible send output format (mono, stereo, or other). In addition, the following conditions apply when moving or copying sends among tracks:

- When copying a stereo send from a mono track to a stereo track, Send pan automation (if any) will be dropped without warning.
- When copying a stereo send from a stereo track to a mono track, the left Send pan automation data is retained and the right side data is dropped. A warning dialog appears for you to confirm or cancel this destructive operation.
- When moving or copying a send and replacing an existing send, all automation on the existing send will be replaced. A warning dialog appears for you to confirm or cancel this destructive operation.

Copying Track Settings to Sends

(Pro Tools HD Only)

Sometimes you need send settings to match the settings in the track itself—for example, to provide a headphone mix based on the main mix.

For more information, see “Copying Track Automation to Sends” on page 545.
Output Windows for Tracks and Sends

Track outputs and sends can be opened for display and editing in dedicated windows.

- Track Output windows provide track fader, pan, automation, solo, and mute controls.
- Send windows provide send level, pan, automation, and mute controls.
- Standard Output and Send window controls provide additional routing, assignment, and display settings.

To open a track Output window:
- Click the Output Window button in the channel strip.

To open a Send window:
- Click the Send Assignment button in the Mix or Edit window.

To view a different track Output or Send window:
- Click an Output Window button, or Send Assignment button, in the Mix or Edit window.

If a similar Output window was already open with a highlighted Target icon (red, lit), the newly selected send will open in its place.

Opening Multiple Output Windows

Multiple track and Send windows can be displayed simultaneously using either of the following methods.

To open additional Output windows:
- Shift-click any Output Window button or Send Assignment button.
To set a window to remain open when opening additional Output windows:

- Make sure the Target is disabled.

Arrange multiple windows as desired. For additional information, see “Targeted Windows” on page 498.

**Panner Linking**

Stereo outputs provide two panning controls, one for each side of the left/right pair. Multi-channel outputs provide a multichannel panner.

The Output window provides controls to unlink (or link) channels for precise panning of stereo and multichannel tracks.

In the default Linked mode, all sides match changes to any other side’s Pan control. This is Absolute Link mode. To mirror panning changes, see “Inverse Linked Panning” on page 496.

When unlinked, Pan controls are completely independent of each other.

To enable linking:

- Enable the Link icon.

To unlink an output for independent panning:

- Deselect the Link icon.
Inverse Linked Panning

When linked and set to Inverse mode, panning moves are inverted or reversed in the other channels.

Inverse panning reflects one side’s location and direction in the other side. For example, when enabled for Front Inverse, if you pan one side of a stereo track output from right to left, the other side will exactly mirror that movement and pan left to right.

Front Inverse linking is available on all systems. Rear Inverse, and Front/Rear Inverse linking are available on Pro Tools|HD systems only, and only appear as options on multichannel plug-ins and panners/output windows.

To enable inverse linking:
1. Enable the Link icon.
2. Select an Inverse mode.

Standard Selector Controls in Output Windows

All Output windows provide standard selectors for path, automation, and other controls in the top area of the window (the Output Editor area).

Close Closes the window.

Track Selector Provides access to any audio track, Auxiliary Input, or Master Fader in the session.

Output View Selector Provides access to other outputs (track and send) in the track, if any, displaying the selected output in the current window.

Send View Selector (Send Window Only) Provides access to other sends on the track.

Output Path Selector Allows you to assign the Output path for the current track or send.

Pre/Post Fader button (Send Window Only) Determines whether the send is pre- or post-fader.
Automation Safe Protects track and send level, pan, and other controls from automation overwrites by placing them in Automation Safe mode. See Chapter 27, “Automation” for more information.

Inverse Pan Reflects one side’s panning location and direction in the other side (for example, left- and right-channel Pan controls).

Link and Unlink Lets you link and unlink left and right (or other) outputs in stereo (or multichannel). Unlinked mode provides discrete adjustment of individual sides, or channels. When linked, all changes affect all channels. See “Panner Linking” on page 495.

Target Identifies the target of plug-in settings commands. Also sets the current window for display of Output windows. See “Targeted Windows” on page 498.

Path Meter View Opens the path Meter View. These meters display levels of the selected path (not the levels of the track or send).

Track Fader, Pan Controls, and Solo, Mute, and Automation Controls

Output windows provide the associated track’s Volume fader, Pan controls, Solo and Mute switches, and Automation Mode selector. Use these to adjust or automate the controls of the Output window.
Targeted Windows

When lit (red), the Target indicates its window is “targeted,” and the next window opened of the same type replaces the current display (unless it is opened as an additional window with the Shift modifier). When unlit, the target is gray, and the current window anchors to its current contents and location on-screen. Opening additional windows does not affect anchored windows.

To set an open Send window as the target window:

- Click the Target, so that it is lit (red).

Plug-in windows have additional features related to the Target (such as Focus of Settings commands). See “The Plug-In Window” on page 520.

Using Output Windows

Output windows provide standard Pro Tools track, send, Target, and other controls.

To move to a different track:

- Click the Track selector and choose a track from the pop-up menu.

To reassign output:

- Click the Output Path selector and select a path from the pop-up menu.

To display the controls for a different send on the same track:

- Click the Send View selector and select the send.

To assign a different send to the same track:

- Click the Send selector and choose an output or bus path from the pop-up menu.

To add an additional output assignment to the current send:

- Press Start (Windows) or Control (Macintosh) while selecting an additional output path from the Send selector (or Output Path selector).
Sends and Groups

Send level, mute, and LFE level can follow Mix groups in each of the ten available sends (A–J). Use this option to adjust multiple send controls from a single set of controls.

To configure sends and Mix groups:

1. Choose Setup > Preferences and click the Automation tab.
2. Enable Send Level Follows Groups, Send Mute Follows Groups, or LFE Follows Groups.
3. Click Done to set the new preferences.

For more information on groups, see “Grouping Tracks” on page 114.

Submixing for Signal Routing and Effects Processing

The bussing and mixing features in Pro Tools support myriad possibilities for submixing and signal routing, including the ability to:

- Monitor and mix disk tracks with MIDI inputs
- Monitor and mix disk tracks with audio inputs
- Create submixes
  - Bus submixes for effects processing
  - Bus submixes for studio monitoring
  - Mix submixes with Master Faders

Monitoring Audio with Auxiliary Input Tracks

Use Auxiliary Input tracks to monitor and mix external audio sources—such as MIDI instruments, tape, microphone inputs, and other instruments—in a Pro Tools mix.

To use Auxiliary Inputs to monitor and mix external audio sources:

1. Connect the audio outputs of your audio source (such as a MIDI synthesizer or tape output) to available inputs on your Pro Tools audio interfaces.
2. If necessary, configure the I/O Setup dialog for the input paths you plan to use (see Chapter 7, “I/O Setup.”)
3. Use an existing or create a new Auxiliary Input track with the corresponding number of channels for your audio source (mono, stereo, or multichannel).
4. Set the input of the Auxiliary Input track to the corresponding input path.
5. Assign the track output to the appropriate path or paths for monitoring.
6. Adjust the Auxiliary Input fader to mix the audio input.
Monitoring Audio with Instrument Tracks

Use Instrument tracks to monitor and mix audio from instrument plug-ins or external MIDI instruments in a Pro Tools mix.

To use Instrument tracks to monitor and mix instrument plug-ins:

1. Use an existing or create a new Instrument track with the desired number of channels (mono, stereo, or multichannel).

2. Select the desired instrument plug-in from the first track Insert selector (such as Digidesign Synchronic).

3. The virtual MIDI node (port) for the instrument plug-in should be automatically selected for the Instrument track’s MIDI Output. If not, select the desired MIDI channel and corresponding port for the instrument plug-in.

4. Assign the track output to the appropriate path or paths for monitoring.

5. Adjust the Instrument track fader to mix the audio input.

6. If you are controlling the Instrument plug-in from the Instrument track, you can also mix using the MIDI Volume and Pan controls in the Instrument View.

To use Instrument tracks to monitor and mix audio from external MIDI instruments:

1. Connect the audio outputs of your external MIDI instrument (such as a MIDI synthesizer) to available inputs on your Pro Tools audio interfaces.

2. If necessary, configure the I/O Setup dialog for the input paths you plan to use (see Chapter 7, “I/O Setup.”)

3. Connect the MIDI input and output of your external MIDI instrument to available MIDI input and output ports on your MIDI interface.

4. If necessary, configure the MIDI Studio Setup (Setup > MIDI > MIDI Studio).

5. Use an existing or create a new Instrument track with the corresponding number of channels for your audio source (mono, stereo, or multichannel).

6. Set the audio input of the Instrument track to the corresponding input path.

7. In the Instrument track’s Instrument View, set the MIDI output to the corresponding MIDI port connected to the MIDI input of your external MIDI instrument.
8 Assign the track output to the appropriate path or paths for monitoring.

9 Adjust the Instrument track fader to mix the audio input.

10 If you are controlling the external MIDI instrument from the Instrument track, you can also mix using the MIDI Volume and Pan controls in the Instrument View.

Creating a Submix

A submix is created by routing multiple audio sources to a common bus or output path. This “submixes” the sources to a single path that can be returned to an Auxiliary Input, where the submix can be processed with plug-ins or external effects processors.

Audio is routed to a submix by assigning any combination of sends and track output to available bus or output paths.

Submixing with Track Outputs or Sends

You can use both track outputs and sends to route audio for submixing, depending on whether you want a **discrete** or **send and return** submix.

**Discrete Submix Output**

Pro Tools lets you discretely route source audio through a submix. This is preferred for dither or other mastering processing, where you do not want unprocessed audio heard in addition to the processed signals. Use track outputs (not sends) to assign tracks to a bus path for discrete submixing. In this arrangement, the balance of processed and unprocessed signal is controlled by plug-in wet/dry settings.

To create a discrete submix:

1 Set the output of the tracks you want to include in the submix to a stereo bus path.
2 Pan each track.
3 Choose Track > New.
4 Specify the track type (Aux Input) and format (stereo), then click Create.
5 Set the input of the Auxiliary Input to the same bus path to which you assigned all contributing tracks.
6 Set the output of the Auxiliary Input track to your main stereo mix outputs (typically, outputs 1–2).

7 Set the Auxiliary Input Track level.

8 To process the submix, assign a plug-in or hardware insert on the Auxiliary Input.

9 Set the controls of the plug-in. The plug-in Bypass and Wet/Dry controls (if available) determine the amount of effect heard.

The contributing track faders control the balance within the submix. The Auxiliary Input track controls the output levels of all tracks routed to it.

You can apply mix automation to the volume, pan, mute, and send level, send pan, and send mute controls of the Auxiliary Input.

You can also bounce a submix to disk to free up the voices for use by other tracks. See Chapter 28, “Mixdown” for information.

**Send and Return Submixing for Effects Processing**

When you are submixing for reverb, delay, and similar effects processing, use sends to achieve traditional send/return bussing. You can use a real-time plug-in or a hardware insert as a shared resource for all tracks included in a submix. The wet/dry balance in the mix can be controlled using the track faders (dry level) and Auxiliary Input fader (effect return, or wet, level).

See Chapter 26, “Plug-In and Hardware Inserts” for more information.

---

**Send and Return with a Plug-In or Hardware Insert**

To create an effects return submix with a plug-in or hardware insert:

1 Assign each track’s main output to your main mix outputs.

2 On the source tracks, assign a send (mono or stereo) and select a mono or stereo bus path from the Send selector. Configure the sends for pre- or post-fader, as needed.

3 Choose Track > New.

4 Specify the track type (Aux Input) and format (stereo), then click Create.

5 From the Auxiliary Input track's Input Path selector, select the send bus path.

6 Assign a plug-in or hardware insert on the Auxiliary Input.

7 Set the effect to “100% wet,” and set any other controls as desired.

8 From the Auxiliary Input track’s Output Path selector, select an output path (main outputs).
Adjust the individual track faders to balance the dry (unprocessed) tracks. With the send set to pre-fader, the amount of effect is controlled by the level of the Send Level fader or the Auxiliary Input Volume fader. If the send is post-fader, the Send Level fader follows volume level.

**Send and Return Submixes with External Devices**

**To create an effects return submix with an external device:**

1. Assign each track’s main output to your main mix outputs.
2. Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.
3. Choose Track > New.
4. Specify the track type (Aux Input) and format (stereo or mono), then click Create.
5. From the Auxiliary Input track’s Input Path selector, select the input path connected to the external device.
6. From the Auxiliary Input track’s Output Path selector, select an output path (main outputs).
Adjust the individual track faders to balance the dry (unprocessed) tracks. The amount of effect is controlled by the level of the Send Level fader or the Auxiliary Input Volume fader.

Creating Monitor Submixes

Route track sends to one or more Auxiliary Input tracks to monitor submixes in a studio environment. For example, you may want to provide the bassist with a drum submix for tracking a new bass part.

1 Assign each track’s main output to your main mix outputs.
2 Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.

3 Choose Track > New.
4 Specify the track type (Aux Input) and format (stereo or mono), then click Create.
5 From the Auxiliary Input track’s Output Path selector, select the output path (not the main outputs) for monitoring the mix.

Adjust the Auxiliary Input track fader to control the volume for the monitor mix.

Creating a Master Send Level Control

A Master Fader can control the overall level of bus and output paths.

To create a Master send level control:

1 Choose Track > New.
2 Specify the track type (Master Fader), and mono, stereo, or any of the supported multi-channel formats for surround mixing.
3 Click Create.
4 Do one of the following:
   • Set the output of the Master Fader to the same path that you are using to send to an Auxiliary Input track.
   • Set the output of the Master Fader to match the path that you have chosen for your effects send.

You can then adjust send levels to balance the source tracks, and use the Master Fader as a master level control for the entire submix.

**Soloing Tracks in a Submix**

Soloing any tracks implicitly mutes all other tracks, including Auxiliary Inputs. Solo-safering an Auxiliary Input prevents this implicit muting and lets the Auxiliary Input continue to pass audio when its source tracks are in Solo.

**To solo safe an Auxiliary Input:**
- Control-click (Windows) or Command-click (Macintosh) the Solo button on the Auxiliary Input track.

**To solo an individual track that is part of a group:**
- Start-click (Windows) or Control-click (Macintosh) the Solo button.

**Generating Stereo Output from a Mono Send/Return**

You can use an Auxiliary Input to generate a stereo output from a mono send. Set the send destination to a mono Auxiliary Input track and place a mono to stereo plug-in on the Auxiliary Input. The output of the Auxiliary Input becomes stereo.

To create a “stereo” effect from a mono source, you must use reverb, delay, or other time domain effects.

---

**Delay Compensation**

*(Pro Tools HD Only)*

Pro Tools provides Delay Compensation for managing DSP delays that occur on audio, Auxiliary Input, Master Fader, or Instrument tracks because of plug-in use and mixer routing. With Delay Compensation enabled, Pro Tools maintains time-alignment between tracks that have plug-ins with differing DSP delays, tracks with different mixing paths, tracks that are split off and recombined within the mixer, and tracks with hardware inserts.

To maintain time alignment, Pro Tools adds the exact amount of delay to each track necessary to make that particular track’s delay equal to the delay of the track that has the longest delay.

Delay Compensation should be enabled during mixing and playback for optimal delay-compensated sound. In some cases when recording, Delay Compensation should be turned off.

**To enable Delay Compensation:**
- Choose Options > Delay Compensation.

**Delay Compensation Settings**

There are three settings in the Playback Engine dialog for dedicating DSP resources for Delay Compensation:

- **None** Allocates no DSP resources for Delay Compensation.
- **Short** Allocates minimal DSP resources of Delay Compensation for each channel. This is the most efficient setting for Pro Tools|HD Accel systems.
**Long** Allocates maximum DSP resources of Delay Compensation for each mixer channel. Long Delay Compensation uses the same DSP resources used by high DSP overhead plug-ins.

**To configure the Delay Compensation Engine:**
2. From the Delay Compensation Engine pop-up menu, select a Delay Compensation setting.
3. Click OK.

The Delay Compensation status will be saved as a session and system preference.

**Delay Compensation View**

The Delay Compensation View displays the total amount of plug-in delay on each track, lets you apply a user offset of track delay, and displays the total amount of delay that Pro Tools applies to each track. The Delay Compensation View can be shown in the Mix Window.

**Plug-In Delay (dly) Indicator**

The Plug-In Delay (dly) indicator shows the total plug-in and hardware insert delay on the track. This delay total is used by Pro Tools to calculate the delay applied to other tracks to keep them time-aligned. The track with the highest plug-in and insert delay displays delay information in orange.

Bypassing the track’s reported delay to Pro Tools can be useful if your total plug-in delay on a track exceeds the amount allowed in the Delay Compensation Engine setting. After bypassing the track’s reported delay, you must manually nudge your track earlier by the reported amount to achieve the proper Delay Compensation for that track, while continuing to use Delay Compensation (see “User Offset (+/–) Field” on page 506.)

**To bypass reporting plug-in delay to Pro Tools:**
- Start-Control-click (Windows) or Command-Control-click (Macintosh) the Plug-in Delay indicator. The track delay will appear greyed out, and Pro Tools will not use that track’s plug-in delay to calculate Delay Compensation for the other tracks.

**User Offset (+/–) Field**

This field lets you adjust track delays manually. In addition to the automatic delay, positive or negative delay times can be entered in the user offset (+/–) field.

This is useful for changing the feel of a track or for time-aligning a track in case a plug-in is incorrectly reporting its delay.
To change track delay using the User Offset field:

1. In the Delay Compensation View, click in the User Offset edit field.

2. To set your delay value (in samples or milliseconds depending on your current preferences), do one of the following:
   - Enter a positive number (with or without the “+” modifier) or negative number (with the “–” modifier.)
   - Control-drag (Windows) or Command-drag (Macintosh) in the User Offset field to scroll to a new value.
   - Press the Up and Down Arrow keys to increase or decrease the numerical values.

3. Press Enter.

To bypass the user delay:

- Start-Control-click (Windows) or Command-Control-click (Macintosh) the User Offset field. The user defined delay will appear greyed out, and it will no longer be applied to the track.

Track Compensation (cmp) Indicator

This indicator shows the amount of compensation Pro Tools applies to each track.

Delay that Exceeds the Compensation Limit

When the total delay on a track exceeds the amount of compensation available, Pro Tools applies the maximum available compensation, and displays the delay information in red (in the Delay Compensation View) for any tracks that cannot be fully compensated. The Delay Compensation indicator in the Edit window also turns red to indicate that the track delay exceeds the Delay Compensation limit. In this case, you need to bypass the track’s reported delay (see “Plug-in Delay (dly) Indicator” on page 506), then manually nudge the track to maintain proper Delay Compensation (see “User Offset (+/–) Field” on page 506).

Low Latency Monitoring During Recording

For recording, Pro Tools automatically suspends Delay Compensation to provide a low latency monitor path through the main outputs of the record-enabled tracks. When an audio track is armed for recording (in stop), TrackInput-enabled, or punched in, the track’s Delay Compensation is automatically suspended (and the Track Compensation indicator displays 0).

You can suspend this automatic suppression of Delay Compensation as needed by doing the following:

To apply Delay Compensation to tracks where Delay Compensation was suspended:

- Start-Control-click (Windows) or Command-Control-click (Macintosh) the Track Compensation indicator. Track delay will be applied to the track and the Track Compensation indicator will display in blue.

Track Compensation on Auxiliary Inputs

Delay Compensation on Auxiliary Inputs can be bypassed to let you monitor outside sources (such as the audio tracks of a slaved video deck) with minimal latency, while still reporting the track’s delay.

To bypass an Auxiliary Input’s Delay Compensation:

Start-Control-click (Windows) or Command-Control-click (Macintosh) the Track Compensation indicator. The reported track delay will be zero, and will appear greyed out.
Delay Compensation for MIDI

When Delay Compensation is active, a MIDI event that is recorded to sound “in time” with delay-compensated material actually is recorded late by the length of total delay in effect.

To compensate, MIDI events are shifted back in time by the total session delay following each MIDI recording pass.

Low-Latency Recording with Virtual MIDI Instruments

When a MIDI or Instrument track that is routing MIDI data to an instrument plug-in is record-enabled, Pro Tools automatically suspends Delay Compensation through the main outputs of the audio track or Auxiliary Input that the instrument plug-in is inserted on. This allows for latency-free monitoring of the instrument plug-in during recording.

Delay Compensation for virtual MIDI instruments works only when all MIDI and audio connections take place inside of Pro Tools. For example, Pro Tools does not suspend Delay Compensation when you are using ReWire to connect software synthesizers and samplers in other ReWire client applications (such as Live and Reason).

MIDI and Audio Processing Plug-Ins

Some audio processing plug-ins (such as Bruno and Reso) and many instrument plug-ins let you process audio while allowing MIDI data to control processing parameters. When you record enable a MIDI or Instrument track that is controlling an audio processing plug-in, the track the plug-in is inserted on will go into low-latency mode, effectively making the processed audio play early.

To keep audio time-aligned when recording using a MIDI controlled plug-in on an audio track:

- Start-Control-click (Windows) or Command-Control-click (Macintosh) the Track Compensation indicator for the audio track to apply Delay Compensation.

To keep audio time-aligned when recording using a MIDI controlled plug-in on an Auxiliary Input:

1. Start-Control-click (Windows) or Command-Control-click (Macintosh) the Track Compensation indicator for the Auxiliary Input to bypass Delay Compensation.

2. Enter the total system delay into the User Offset field.
Dither

Dither is a special form of randomized noise used to mask quantization noise in digital audio systems. Digital audio’s poorest distortion performance exists at the lowest end of the dynamic range, where quantization distortion can occur. Dither reduces quantizing errors by introducing very low-level random noise, thereby minimizing distortion artifacts as audio reaches low level. With dither there is a trade-off between signal-to-noise performance and less-apparent distortion. Proper use of dither lets you squeeze better subjective performance out of a 16-bit data format (such as Red Book compact discs).

Pro Tools|HD systems process all audio internally at 24-bit, and Pro Tools LE processes internally at 32-bit, floating. Without dither to process the 24-bit data to 16-bit, the extra 8 bits are truncated (dropped entirely) when written to media or a device with a 16-bit maximum (such as CD recorders, and many DAT machines). Dithering, on the other hand, preserves low-level (quiet) fidelity in a surprising way—by adding a small amount of noise to a signal.

Dither in Pro Tools

There are several dither options provided in Pro Tools. Each has a specific application within the various operations that could benefit from dithering.

In addition to the TDM, RTAS and AudioSuite dither plug-ins, Pro Tools has a built-in dither capability.

Dither Mixer Plug-Ins (Pro Tools HD Only) There are two Mixer plug-ins that feature dither with noise shaping: Stereo Dithered and Surround Dithered. For more information, see the Pro Tools|HD Getting Started Guide. Standard Stereo and Surround Mixers do not have dither and require use of dither plug-ins.

Dither on Final Output for Mixdown You can insert a real-time dither plug-in on a Master Fader that controls your output mix, to dither your final mix for CD or other 16-bit media. Inserts on Master Fader process post-fader. This form of dithering lets you use dither plug-ins from Digidesign or third-party manufacturers. When using the Bounce to Disk, see “Dither and Bounce to Disk” on page 572.

AudioSuite Dither For AudioSuite plug-in processing, dither is based on the Dither plug-in.

For most AudioSuite plug-ins, dither can be automatically applied in the Processing Preferences page. The Use AudioSuite Dither checkbox enables a preset, N-shaped dither.

Operation preferences, for AudioSuite dither
The following AudioSuite plug-ins can automatically apply dither when processing:

- EQ III
- Compressor II
- Limiter II
- Gate II
- Expander/Gate II
- Normalize
- Gain
- DC Offset Removal
- Time Compression/Expansion
- Pitch Shift

For information about AudioSuite Dither, see the Digi-Rack Plug-Ins Guide.

Fades and Crossfades In the Fades dialog (Edit > Fades > Create), the Use Dither option enables a preset, noise-shaped dither.

Noise Shaping

Noise is an integral part of the dithering process. Noise shaping can further improve audio performance and reduce perceived noise inherent in dithering. Noise shaping utilizes digital filtering to move noise from frequencies around 4 kHz to near the Nyquist frequency. Essentially, noise shaping lessens our perception of the noise inherent in dithering by shifting audible noise components to a range in which the human ear is less sensitive.

Noise Shaping is available in the Dither plug-in.

For more information about dither during mixdown, see Chapter 28, “Mixdown.”

Using a Control Surface with Pro Tools

Control surfaces add hands-on control to Pro Tools functions. You can use a control surface to adjust on-screen faders and knobs, activate transport controls, or scrub and shuttle in Pro Tools.

There are several optional Digidesign control surfaces for mixing in Pro Tools:

- Digidesign’s D-Control and D-Command (Pro Tools HD Only) Innovative tactile worksurfaces that employ a familiar, intuitive channel strip/center section console layout.

- Digidesign ProControl (Pro Tools HD Only) and Control|24 (Pro Tools HD and LE Only) Dedicated controllers which provide access to Pro Tools recording, mixing, editing, signal routing, plug-in control, and automation features.

- Digidesign’s Command|8 Low cost USB-based control surface for Pro Tools. Command|8 is a compact, convenient, and flexible control surface for Digidesign-qualified Pro Tools systems.
Chapter 26: Plug-In and Hardware Inserts

Pro Tools provides up to five unity-gain inserts on each audio, Auxiliary Input, Master Fader, and Instrument track. Audio, Auxiliary Input, and Instrument track inserts are pre-fader, and Master Faders inserts are post-fader.

An insert can be either a software DSP plug-in or a hardware insert. A Pro Tools insert routes the signal from the track to a plug-in or external hardware effect of your choice and automatically returns it to the same track. Inserts do not alter the original audio source files, but process audio in real time, during playback. You can permanently apply real-time effects to tracks by recording or bouncing the effect to disk (see Chapter 28, “Mixdown" for more information).

Plug-In Inserts Plug-in inserts are software inserts that process audio material on a track in real time. For example, the DigiRack EQ, compressor, and delay plug-ins supplied with your Pro Tools system can be used as real-time plug-in inserts.

Hardware I/O Inserts Hardware I/O inserts can route audio through an external device connected to parallel inputs and outputs of an audio interface. You can process the audio material on a track with a hardware insert in real time.

General Information

When more than one insert is used on a track, they are processed in series. Each effect is added to that of any previous plug-ins or inserts (f lowing from top to bottom in the Mix window Inserts View, and left to right in the Edit window Inserts View).
Inserts on audio tracks and Auxiliary Inputs and Instrument tracks are pre-fader. You can cause clipping if you boost their gain to extremes, especially on tracks recorded at high amplitude. Watch on-screen metering for indication of clipping. (Inserts on Master Faders are post-fader.)

How to Use Inserts for Effects Processing

Inserts can be used in two ways:

**On Single Tracks** An insert can be applied to an individual audio, Auxiliary Input, Master Fader, or Instrument track.

With in-line inserts, you control the amount of effect by adjusting the balance (or, wet/dry) controls of the plug-in or external device.

**As Shared Resources** An insert can be used as a shared resource in a send-and-return arrangement, by bussing signals from several tracks to an Auxiliary Input, and then applying the insert to the Auxiliary Input track. You can then control the send level for each track, and the overall level of the effect can be controlled from the Auxiliary Input track. Using sends and other signal routing features helps maximize your system’s processing power.

For examples of send and return busses and other submixing setups, see “Submixing for Signal Routing and Effects Processing” on page 499.

Insert Formats

**Mono Inserts** Used on mono tracks. Inserts that occur on a track after a stereo insert are automatically used in stereo as well.

**Stereo Inserts** Used on stereo tracks. A stereo hardware I/O insert sends the signal to an input/output path.

**Mono In/Stereo Out Plug-In Inserts** Used to return a stereo effect from a mono source. Certain plug-ins (such as D-Verb) let you generate stereo output from a mono channel. A track made into stereo in this way has panning controls for each channel of the stereo signal. Any inserts that occur on a track after a stereo insert are automatically used in stereo as well.

**Multi-Mono Plug-In Inserts** Used on stereo or greater-than-stereo multichannel tracks when a multichannel version of the plug-in is not available. Controls for all channels are linked by default so that you can adjust them in tandem. You can unlink controls for independent adjustment using the Master Link button. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 527.

**Multichannel Plug-In Inserts** Used on stereo and greater-than-stereo multichannel tracks. On greater-than-stereo multichannel tracks, the controls for all channels are generally linked together.

Relinking may cause automation to be lost. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 527.

TDM and RTAS Plug-Ins

There are three plug-in formats supported by Pro Tools (TDM, RTAS, and AudioSuite), two of which can be used as real-time inserts, as follows:

**TDM Plug-Ins** Used with Pro Tools HD systems, these plug-ins rely on the processing power of DSP on Pro Tools|HD system cards.

**RTAS Plug-Ins** Similar to their TDM counterparts, but unlike TDM plug-ins, they rely on and are limited by the host processing power of your computer.
AudioSuite Plug-Ins  Non-real-time, file-based processing plug-ins for Pro Tools (see the Digi-Rack Guide).

Depending on your Pro Tools software, plug-ins can be used as follows:

Pro Tools HD
• Both TDM and RTAS plug-ins can be used on audio, Auxiliary Input, Master Fader, and Instrument tracks.

⚠️ With Pro Tools HD, RTAS plug-ins placed on Auxiliary Input, Master Fader, and Instrument tracks will use additional voices and may introduce extra latency based on the HW Buffer Size. For more information, see “Voice Usage and Total Latency for RTAS Plug-Ins” on page 513.

Pro Tools LE and M-Powered
• RTAS plug-ins can be used on audio, Auxiliary Input, Master Fader, and Instrument tracks.

⚠️ For tips on maximizing RTAS performance, see the DigiRack Plug-Ins Guide.

Voice Usage and Total Latency for RTAS Plug-Ins  (Pro Tools HD Only)

With Pro Tools HD, the initial insert of an RTAS plug-in may cause additional latency, and will take up two additional voices per channel (one voice for input and one voice for output) in the following conditions:
• When inserted on an Auxiliary Input or Master Fader track
• When inserted on an Instrument track that does not contain an instrument plug-in
• When inserted after a TDM plug-in on any kind of track

For example, the initial insert of an RTAS plug-in on a mono Auxiliary Input track uses two voices (one channel with two voices), while the initial insert of that plug-in on a stereo Auxiliary Input track uses four voices (two channels with two voices each).

Subsequent RTAS plug-ins on the same track do not take up additional voices unless a TDM plug-in is inserted between other RTAS plug-ins.

⚠️ Avoid inserting TDM plug-ins between RTAS plug-ins on any kind of track—this causes unnecessary voice usage and may cause additional latency.

Furthermore, one additional voice is used for each occurrence of any of the following conditions when using voices for RTAS plug-ins on a track:
• When you use the external key side-chain of an RTAS plug-in on that track
• When you select multiple track outputs for that track (one voice used for each output)
• When you select an AFL/PFL Path output in the Output tab of the I/O Setup dialog (one voice used for each channel)

⚠️ When you use Pro Tools 6.9.x or lower to open a session originally created with Pro Tools 7.0, any RTAS plug-ins inserted on Auxiliary Input or Master Fader tracks—or after TDM plug-ins on any kind of track—will become inactive.
Viewing Inserts

Both the Mix and Edit windows can be configured to show or hide inserts. Plug-in windows provide complete access to plug-in controls.

To show (or hide) inserts:

- In the Mix window (or Edit window), select View > Mix Window (or Edit Window) > Inserts.
- Select Inserts View from the Edit Window or Mix Window View selector.

Display of Plug-In Window Status

In the Mix and Edit window, the plug-in button and selector display the currently inserted plug-in, its bypass state (see “Bypassing Plug-Ins” on page 527), target status, and window status.

Indicating the Controller Target

If you are using a control surface with Pro Tools, only one plug-in can be targeted at a time. The current controller target, if any, is indicated with a color outline around its name:

Making Inserts Inactive

Plug-in and hardware inserts can be made inactive to free up their resources for other uses. When a plug-in insert is inactive it retains its assignment, position, and related automation playlists. However, it will not pass audio and does not consume any DSP or TDM resources.

When opening sessions, inserts will automatically be made inactive in any of the following situations:

- The system has insufficient DSP resources.
- A plug-in is not installed.
- A plug-in type is not available (RTAS or TDM).
• Opening the session results in plug-in type substitutions. This can happen if the type is available but substituting would result in an unsupported condition, such as opening a session containing an HTDM plug-in for which an RTAS version is unavailable.

To make an insert inactive:

■ Control-Start-click (Windows) or Command-Control-click (Macintosh) the Insert button.
  – or –
■ Make the track inactive. See “Making Tracks Inactive” on page 111.

To toggle inserts in the same position on all tracks active or inactive:

■ Control-Start-Alt click (Windows) or Command-Control-Option click (Macintosh) an Insert button in the position you want to toggle.

To toggle inserts in the same position on all selected tracks active or inactive:

■ Control-Start-Alt-Shift click (Windows) or Command-Control-Option-Shift click (Macintosh) an Insert button in the position you want to toggle.

Inactive Plug-In Inserts

Inactive plug-in inserts retain all associated automation playlists. In addition, any edits made in the session affect the plug-in automation playlists. You cannot record automation or adjust the controls for an inactive plug-in.

Display of inactive plug-ins

Inactive Hardware Inserts

Inactive hardware inserts retain their assignments, but do not pass audio and do not consume any DSP resources.

Hardware inserts do not provide a bypass control. You can use the inactive feature whenever you need to mute or bypass a hardware insert.

Inserting Plug-Ins on Tracks

To use a real-time plug-in, insert it on a track.

To insert a plug-in on a track:

1 Make sure the Inserts View is shown in the Mix or Edit window.
2 Click the Insert selector on the track and select the plug-in that you want to use. (See “TDM and RTAS Plug-Ins” on page 512 for related information.)
To remove an insert from a track:

- Click the Insert selector and choose No Insert.

Removing a plug-in

Ordering RTAS and TDM Plug-Ins on Audio Tracks

(Pro Tools HD Only)

With Pro Tools HD, when RTAS and TDM plug-ins are combined on an audio track, Auxiliary Input, or Master Fader, the order in which they are inserted has different results:

RTAS Plug-Ins Grouped Before TDM Plug-Ins

No additional voices will be used, and no processing latency will occur. RTAS plug-ins will be bypassed when Record Enable or Track Input monitoring is enabled for that track.

TDM Plug-Ins Grouped Before RTAS Plug-Ins

Each initial insert of an RTAS plug-in after a TDM plug-in on a track will cause processing latency, and will use voices as described in “Voice Usage and Total Latency for RTAS Plug-Ins” on page 513. RTAS plug-ins will stay active while Record Enable or Track Input monitoring is enabled for that track.

⚠️ As a rule, always group plug-ins of the same type together, especially if inserting RTAS after TDM plug-ins. Otherwise, additional voices may be unnecessarily used.

Ordering Recommendations

When combining RTAS and TDM plug-ins on an audio track, use one of the following two strategies based on your recording needs:

- To ensure that RTAS plug-ins stay active when you record enable a track or use Track Input monitoring, order all TDM plug-ins before RTAS plug-ins.
  - or -
- To conserve voices and minimize processing latency, order all RTAS plug-ins before TDM plug-ins.

Configuring Plug-Ins During Playback and Recording

Playback must be stopped before performing any of the following operations:

- Dragging a plug-in to a different location
- Inserting or removing a plug-in while recording
- Inserting or removing a plug-in that changes a track's format
- Inserting an RTAS plug-in on or removing an RTAS plug-in from an Auxiliary Input or Master Fader track
- Inserting an RTAS plug-in after a TDM plug-in on an audio track
- Removing an RTAS plug-in from an audio track if it comes after a TDM plug-in
- Inserting TDM plug-ins before an RTAS plug-in on an audio track
- Removing a TDM plug-in from an audio track if it comes before an RTAS plug-in.
- Removing a plug-in that contains automation data
- Enabling plug-in controls for automation
- Configuring an external side-chain input
Plug-In Menu Organization

You can customize how plug-in lists (plug-in menus) are organized in the Insert selector and Plug-In selector.

Use the “Organize Plug-In Menus By” pop-up menu in the Pro Tools Display Preferences page to organize plug-in menus in a Flat List (with plug-ins in alphabetical order), or by Category, Manufacturer, or Category and Manufacturer.

Category Organizes plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. Plug-ins that do not fit into a standard category (such as the DigiRack Signal Generator), or third-party plug-ins that have not had a category designated by their developers, appear in the Other category. Plug-ins can appear in more than one category.

Plug-ins organized by category (using the Insert selector)

Plug-ins organized by Manufacturer (using the Plug-In selector)

Flat List Organizes plug-ins in a single list, in alphabetical order.

⚠️ If no plug-ins within a certain category are installed on your system, the subfolder named for that category will not appear in the menu.
**Manufacturer** Organizes plug-ins by their manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus. Plug-Ins that do not have a Manufacturer defined will appear in the “Other” manufacturer folder.

Most Digidesign-distributed third party plug-ins will be grouped under Digidesign when this option is enabled.

⚠️ **If no plug-ins by a certain manufacturer are installed on your system, the subfolder named for that manufacturer will not appear in the menu.**

**Category and Manufacturer** Organizes plug-ins in two levels of menus. The top menus display plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. The bottom menus display plug-ins by manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus.

**To select how plug-ins are organized:**

1. Open or create a session.
2. Choose Setup > Preferences, and click the Display tab.
3. Click the “Organize Plug-In Menus By” pop-up menu, and select one of the view options.
4. Click Done.

The current “Organize Plug-In Menus By” setting is saved with Pro Tools preferences (it is not saved with the Pro Tools session file).

**Control Surface Support**

Digidesign control surfaces with multi-color LCDs (such as D-Control) indicate plug-ins as follows:

- Plug-in categories (such as EQ) and plug-in manufacturers (such as Digidesign) are indicated in green text.
- Specific plug-ins located in the plug-in subfolders (such as EQ III in the EQ subfolder) are indicated in yellow (amber) text.

Control surfaces with single-color displays (such as ProControl and Command|8) do not indicate plug-in view choices. They display contents of a plug-in folder as a single list of plug-ins. (While control surfaces with single-color displays do not indicate plug-in choices, Pro Tools software continues to display plug-ins according to their “Organize Plug-Ins Menu By” setting.)
Plug-in Favorites

To find a plug-in faster, a plug-in can be designated as a favorite. Favorite plug-ins are shown at the top of the plug-in menu.

When a plug-in becomes a favorite, it is still shown in its plug-in category and its name appears in bold.

To designate a plug-in as a favorite:

■ Control-click (Windows) or Command-click (Macintosh) on a plug-in Insert button, and select a plug-in from a plug-in category to designate it as a favorite.

To change the status of a plug-in favorite:

■ Control-click (Windows) or Command-click (Macintosh) on a plug-in Insert button, and select a plug-in favorite that you no longer want to designate as a favorite.

When selecting the plug-in favorite to change, you can select the plug-in from the list of favorites at the top of the plug-in menu, or in its plug-in category (where the plug-in appears in bold).

Moving and Duplicating Plug-In and Hardware Inserts

You can move or duplicate an insert by dragging it to a different position on the same track or a different track. Inserts that are moved or duplicated retain their original settings and automation.

⚠️ Plug-ins cannot be moved or duplicated during playback or recording.

To move an insert:

■ Drag the insert to a new insert location.

![Moving a plug-in]

To duplicate an insert:

■ Alt-drag (Windows) or Option-drag (Macintosh) the insert to a new insert location. Duplicated plug-in inserts retain their original settings and automation.

💡 You can also duplicate Sends. See “Moving or Copying Sends” on page 493
The Plug-In Window

The Plug-In window appears whenever you click a plug-in’s Insert button on a track. This floating window lets you edit the adjust the controls of any real-time plug-in insert in use on a track.

**Track Selector**
Accesses any non-MIDI track in a session.

**Insert Position Selector**
Accesses any insert on the current track.

**Plug-In Selector**
Lets you select any real-time plug-in installed in the Plug-Ins folder (that is created when you install Pro Tools).

**Effect Bypass Button**
Disables the currently displayed plug-in. This lets you compare the track with and without the effect.

**Convert Plug-In Selector**
Lets you convert the insert from a TDM plug-in to an RTAS plug-in of the same type (or vice-versa). This feature can only be used on plug-ins that are available in both TDM and RTAS formats.

**Clip LED**
Lights red to indicate if any meter in a plug-in has clipped (not available on all plug-ins). The Plug-In Clip LED follows Pro Tools settings for clip indication.

**Settings Menu**
Lets you copy, paste, save, and import plug-in settings.

**Librarian Menu**
Recalls settings files saved in the plug-in’s root settings folder or in the current session’s Settings folder. See “Using the Librarian” on page 523.

**Next (+) and Previous (–) Setting Buttons**
Let you select the next or previous plug-in setting from the Librarian menu.

⚠️ **You will lose the current settings if they are not saved before you use the Next and Previous Setting buttons. Always save your settings to the Librarian menu.**

**Plug-Ins Settings Select Button**
Accesses the Plug-In Settings dialog, which lists the settings files for the current plug-in. From this list, you can select a new setting, or audition a series of settings.

**Compare**
Toggles between the original saved plug-in setting and any changes you have made to it so you can compare them.

**Auto Button**
Lets you enable individual plug-in controls for automation recording. See “Automating Plug-Ins” on page 546.

**Automation Safe**
When enabled, prevents existing plug-in automation from being overwritten.
**Target Button** When multiple Plug-In windows are open, clicking this button selects that plug-in as the target for any computer keyboard commands. For more information, see “Targeted Windows” on page 498.

**Key Input Selector** Lets you select audio on a particular input or bus and route it to trigger the plug-in. This menu only appears on plug-ins that feature side-chain processing. Key inputs are monophonic.

**MIDI Node Display** Shows MIDI node information for MIDI-enabled plug-ins. MIDI nodes are virtual connections from Pro Tools to software instruments and other MIDI-enabled plug-ins. MIDI nodes are useful for routing multiple MIDI tracks to different channels of a single virtual MIDI device. MIDI node numbers are also displayed in a track’s MIDI Output selector.

**Master Link Button** When enabled, links the controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

**Link Enable Buttons** Let you selectively link or unlink the controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 527.

**Channel Selector** Accesses a specific channel within a multichannel track for plug-in control editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than one channel. Shift-clicking this selector opens a separate Plug-In window for each channel of the multichannel track on which the plug-in is inserted.

**Phase Invert Button** Inverts the phase polarity of the input signal on some plug-ins.

**LFE Enable** Enables plug-in processing of the LFE (low frequency effects) channel on a multichannel track formatted for 5.1, 6.1, or 7.1 surround formats on some plug-ins. To disable LFE processing, deselect this button.

**Tempo Sync** Enables compatible plug-ins to automatically synchronize to the session tempo, for rhythmic delay, echo, and similar effects.
Opening Plug-In Windows

To open a Plug-In window:
- Click the plug-in button in the Mix or Edit window channel strip.

By default, each plug-in you open will appear in the same location as a currently open plug-in, replacing it in the same window location.

Opening Multiple Plug-In Windows

Pro Tools normally displays a single Plug-In window from which you can adjust the controls of any session plug-in. You can also open additional Plug-In windows for specific plug-ins. Once you begin working with multiple Plug-In windows, you will need to click the Target button on the plug-in whose controls you want to adjust using keyboard commands.

To open an additional Plug-In window:
- In the Mix window, Shift-click the Insert button of a plug-in.

To open Plug-In windows for each channel of a multi-mono plug-in:
- Alt-click (Windows) or Option-click (Macintosh) the Channel selector in the Plug-In window of a plug-in insert.

To close all currently open Plug-In windows:
- Alt-click (Windows) or Option-click (Macintosh) the close box of any currently open Plug-In window.

Plug-In Window Controls

All plug-ins provide standard Pro Tools controls for track and insert selection, bypass, and other controls, in addition to the EQ, dynamics, and other processor-specific controls.

To select a different plug-in on the same track:
- Click the Insert selector and select a plug-in from the pop-up menu.

Choosing a plug-in from the Plug-In window

Choosing a track from the Plug-In window

Target Window and Settings Shortcuts

When multiple Plug-In windows are open, a highlighted target indicates the target window. Pro Tools keeps a single plug-in target window. Opening a new plug-in opens it as the new target window, in the same location. In addition, the plug-in target window is also the focus of keyboard shortcuts for plug-in settings.
Using the Librarian

The Settings Librarian makes it easy to create your own library of plug-in settings. Using the Librarian and Settings pop-up menus, you can copy, paste, save, and import these settings from plug-in to plug-in, or from session to session.

Once you create and save settings files to disk (and tell Pro Tools where to find them by assigning their root folder) they will appear in the Librarian menu (and in the Plug-In Settings dialog).

💡 You can also use the Plug-In Settings dialog to select settings or audition them. See “Plug-In Settings Dialog” on page 526.

The Settings Menu

Use the Settings menu commands to save, copy, paste, and manage plug-in settings files.

Settings menu commands include:

- **Save Settings** Saves the current settings. This command overwrites any previous version of the settings. The setting then appears in the Librarian menu.
- **Save Settings As** Saves the current settings under a different name.
- **Copy Settings** Copies the current settings. You can then apply these settings to the same type of plug-in on a different track by choosing the track in the Plug-In window and pasting the settings with the Paste Settings command.
- **Paste Settings** Pastes settings copied with the Copy Settings command.
- **Import Settings** Imports a settings file from a location other than the Root Settings folder or Session folder.
- **Delete Current Settings File** Permanently deletes the current settings file from disk.
- **Lock Settings File** Prevents the current settings from being overwritten by the Save command. If you attempt to save control settings, you will be required to save them using a different name or disk location.
- **Set As User Default** Defines the current settings as the User Default for a specific plug-in.

Settings Preferences

The Settings Preferences sub-menus are for choosing preferences for saving and importing plug-in settings. They include:

- **Set Plug-In Default To** Sets the default setting to either Factory Default (the standard default setting for that plug-in) or User Default (your custom setting).
Save Plug-In Settings To Selects the folder where plug-in settings are saved. If you choose Session Folder, the settings are saved in a folder named “Plug-In Settings” within the current Session folder. If you choose Root Settings Folder, the settings are saved in the folder you specified with the Set Root Settings Folder command.

Set Root Settings Folder Selects a location or root folder for saving and importing settings. This root settings folder must be named “Plug-In Settings.” Use this command only if you want to choose a location other than the default Plug-In Settings folder.

The default location for the Root Plug-In Settings folder is as follows:

Windows Program Files\Common Files\Digidesign\DAE\Plug-In Settings

Macintosh Library/Application Support/Digidesign/Plug-In Settings

⚠️ To save plug-in settings to any location other than the default Plug-In Settings folder, you must first create a folder named “Plug-In Settings” in the new location and then save to that folder.

Choosing a Destination for Settings

Before you save plug-in settings, select their destination folder.

To select a destination folder:

§ From the Settings pop-up menu, choose Settings Preferences > Save Plug-In Settings To, and choose Session Folder or Root Settings Folder.

If you choose Root Settings folder, Pro Tools saves to the default Root Plug-In Settings folder unless you have specified a different location for the Root Settings folder.

To select a different Root Settings folder:

1. From the Settings pop-up menu, choose Settings Preferences > Set Root Settings Folder.
2. Select the folder you want to use as your Root folder and click Select.

Creating Subfolders for Settings

To make it easier to find specific types of settings, you can subdivide settings files by creating subfolders for them.

Creating a settings subfolder:

1. From the Settings pop-up menu, choose Save Settings.
2. Click the New Folder button and type a name for the subfolder.
3. Name the setting and click Save. The setting is saved within the subfolder.

Managing Settings

Use the Settings pop-up menu to manage settings.

⚠️ Unlinked multi-mono plug-ins have specific rules for settings. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 527.

To save a setting:

1. Choose Save Settings from the Settings pop-up menu.
Type a name and click OK. The setting appears in the Librarian menu.

Press Control+Shift+S (Windows) or Command+Shift+S (Macintosh) to save plug-in settings.

To load a previously saved setting:
- Choose the setting from the Librarian pop-up menu.

To import a setting:
1. Choose Import Settings from the Settings pop-up menu.
2. Locate the settings file you want to import and click Open. Pro Tools loads the setting and copies it to the root destination folder.

To copy a setting:
- Choose Copy Settings from the Settings pop-up menu.

Press Control+Shift+C (Windows) or Command+Shift+C (Macintosh) to copy plug-in settings.

To paste a setting:
1. Open the destination plug-in.
2. Choose Paste Settings from the Settings pop-up menu.

Press Control+Shift+V (Windows) or Command+Shift+V (Macintosh) to paste plug-in settings.

To create a custom User Default setting:
1. Create and save a setting.
2. Choose Set As User Default from the Settings pop-up menu.

To make a plug-in default to your custom setting:
- From the Settings pop-up menu, choose Settings Preferences > Set Plug-In Default To > User Setting.

Changing Settings with the Next (+) and Previous (−) Setting Buttons

These buttons let you select the next or previous setting of the Librarian menu.

To change plug-in settings using the +/− buttons:
- Click the Plus (+) or Minus (−) buttons to select the next or previous plug-in settings file. The next (or previous) settings file are enabled, and the Librarian menu changes to reflect the new setting.

You will lose the current settings if they are not saved before you use the Next and Previous Setting buttons. Always save your settings to the Librarian menu.

Editing Settings on Unlinked Multi-Mono Plug-ins

When a multi-mono plug-in is unlinked, importing, copying, pasting, or bypassing settings affects only the currently selected channel.

To apply an operation to all channels of an unlinked plug-in:
- Hold down the Alt key (Windows) or Option key (Macintosh) while performing the command.
Plug-In Settings Dialog

The Plug-In Settings dialog lists the settings files for the current plug-in type. From this list, you can select a new setting, or audition a series of settings. Auditioning plug-in settings is especially useful for selecting patch names for virtual MIDI instrument plug-ins or trying out different effects types applied to your audio.

Use the Folder pop-up menu at the top of the Settings dialog to switch between plug-in settings subfolders, or root and session settings folders.

The Plug-In Settings dialog includes the following:

Folder This pop-up menu lets you switch between settings located in root or session folders (and any available subfolders).

Patch Field This field displays the name of the active (highlighted) setting.

Increment Patch Every X Sec This option lets you audition contiguous plug-in settings on-the-fly by automatically scrolling through them for a specified number of seconds.

To change plug-in settings using the Plug-In Settings dialog:

1. Click the Settings Select button.

2. From the dialog list, select the desired plug-in setting.

   – or –

Use the Arrow keys to scroll through the available settings.

![To switch between settings subfolders, press Control (Windows) or Command (Macintosh) and use the Up/Down Arrow keys.

3. Click Done.

Auditioning Plug-in Settings

When the Plug-In Settings dialog is open, you can have Pro Tools automatically scroll through and audition the settings files saved in the plug-in’s root settings folder or in the current session’s settings folder.

To audition plug-in settings:

1. Click the Settings Select button.

2. From the dialog list, click a setting—the starting point from which you will scroll through the settings files.

3. Enter a value for the number of seconds that will elapse between each program change.

4. Select the option for Increment Patch.

After the specified number of seconds, Pro Tools selects the next setting.
When you are finished auditioning settings, do one of the following:

- Click Done to stop incrementing patches, and to close the Plug-in Settings dialog.
- or –
- Select the Increment Patch option to stop incrementing patches and keep the Plug-In Settings dialog open.

**Bypassing Plug-Ins**

Plug-ins can be bypassed from their Plug-In window, or from the Mix and Edit window Inserts View.

*When a plug-in insert is bypassed, the Insert selector in the Mix window changes its color to blue for easy visual reference. If some, but not all channels of an unlinked multi-mono plug-in are bypassed, the Insert selector appears purple.*

**To bypass a plug-in:**

- Click the Plug-In window’s Effect Bypass button.
  - or –
- Control-click (Windows) or Command-click (Macintosh) the plug-in’s Insert button in the Mix or Edit window.

**Linking and Unlinking Controls on Multi-Mono Plug-Ins**

When a multi-mono plug-in is used on a stereo track or greater-than-stereo multichannel track (Pro Tools HD only), the controls are linked by default. Adjusting the Gain control on one channel, for example, will adjust it for all channels.

You can unlink multi-mono plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

**To unlink controls on a multi-mono plug-in:**

- Deselect the Master Link button.

**To access controls for a specific channel:**

- Select the channel from the Channel selector.

**To link the controls of specific channels:**

1. Deselect the Master Link button if it is not already deselected.
2. Click the Link Enable buttons for the channels whose controls you want to link. For example, on plug-ins that do provide discrete LFE controls from the LFE Enable button, you can link all channels except the LFE by highlighting the icons representing the five full-range speakers in a multi-mono plug-in.

*All channels linked except the LFE*
Editing Plug-In Controls

You can adjust plug-in controls by dragging the control’s slider or knob, or by typing a value into the control’s text box. For instructions on editing specific plug-ins, see the plug-in’s documentation (such as the DigiRack Plug-Ins Guide and Digidesign Plug-Ins Guide).

To adjust a plug-in control:

1. Begin audio playback so that you can hear the control changes in real time.
2. Adjust the controls of the plug-in for the effect you want.
3. Close the Plug-In window to save the most recent changes.

Keyboard Shortcuts

- For finer adjustments, Control-drag (Windows) or Command-drag (Macintosh) the control.
- To return a control to its default value, Alt-click (Windows) or Option-click (Macintosh) the control.

Keyboard Shortcuts for Plug-In Controls

You can use your computer keyboard to edit plug-in controls.

If multiple Plug-In windows are open, Tab and keyboard entry remain focused on the plug-in that is the target window.

To adjust controls from a computer keyboard:

- Click or Tab to the control text field that you want to edit to activate the field. Type an appropriate value.
- In fields that support values in kilohertz, typing “k” after a number value will multiply the value by 1,000. For example, type “8k” to enter a value of 8,000.
- To increase a value, press the Up Arrow on your keyboard. To decrease a value, press the Down Arrow on your keyboard.
- Press Enter on the numeric keyboard after typing a value to input the value (without leaving the selected control field).
- Press Enter on the QWERTY keyboard (Windows) or Return (Macintosh) to enter the value and leave keyboard editing mode.
- To move forward through the different control fields, press the Tab key. To move backward, press Shift+Tab.
- Press Alt-C (Windows) or Option-C (Macintosh) to clear plug-in clipping.

The plug-in target window is the focus of keyboard shortcuts for plug-in settings. To make a plug-in the target for any computer keyboard commands (including key shortcuts), click the plug-in’s Target button in its Plug-In window.

Plug-In Automation and Safe

All real-time plug-ins can be fully automated, and support all Pro Tools Automation modes (Write, Touch, and Latch, plus Trim).

The Auto button opens the Plug-In Automation dialog, where you can enable individual plug-in controls for automation recording. (See “Automating Plug-Ins” on page 546 for more information.)
The Safe button engages Automation Safe mode. When enabled, existing plug-in automation is protected from being overwritten. (See “Record Safing Plug-In Automation” on page 547.)

**Using a Side-Chain Input**

The *side-chain* input is the split-off signal used by a plug-in’s detector to trigger dynamics processing, and is generally drawn internally from the input signal. However, some plug-ins let you switch between internal and external side-chain processing.

With external side-chain processing, a plug-in’s detector is triggered by an external signal (such as a separate reference track or audio source) known as the *key input*.

A typical use for external side-chain processing is to control the dynamics of one audio signal using the dynamics of another signal (the key input). For example, a kick drum track could be used to trigger gating of a bass track to tighten it up, or a rhythm guitar track could be used to gate a keyboard pad.

**Side-Chain Filters**

Some plug-ins feature key high-pass and low-pass filters. These controls let you define a specific frequency range in the side-chain signal with which to trigger the plug-in effect. A common production technique is to use these controls to filter a drum track so that only specific high frequency sounds (such as a hi-hat) or low frequency ones (such as a tom or a kick) trigger the effect.

---

### Using a Key Input for External Side-Chain Processing

**To use a key input for external side-chain processing:**

1. Click the plug-in’s Key Input selector and select the input or bus carrying the audio you want to use to trigger the plug-in.

2. Click the External Key to activate external side-chain processing.

3. Press the Spacebar to begin playback. The plug-in uses the input or bus that you chose as a key input to trigger its effect.

4. During playback, do any of the following to fine-tune key input triggering:
   - To hear the audio source you have selected to control the key input, enable Side-Chain Listen or Key Listen (depending on the plug-in). When finished, disable Side-Chain Listen/Key Listen to resume normal plug-in monitoring.
   - To filter the key input so that only specific frequencies trigger the plug-in, use the filtering controls (if available) to select the desired frequency range.

5. Adjust the plug-in’s Threshold control (if available) and other controls as needed.
Using Hardware Inserts

You can connect external devices, such as reverb or effects processors, to your Pro Tools system and use them as hardware inserts on individual tracks or on submixes.

Pro Tools inserts utilize corresponding hardware input and output channels to send and return the audio. Inserts can be defined, and their channels mapped to audio interface channels, in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a hardware insert being supplied by outputs 7–8 needs to be returned to hardware inputs 7–8.

To define a hardware insert:

1. Choose Setup > I/O, then click the Inserts tab.
2. Select an insert path, or click New Path to create a new Insert path.
3. Double-click the Path Name to enter a custom path name for the insert.
4. Make sure the insert path is set to the correct format (mono, stereo, or other).
5. Map inserts in the Channel Grid as needed. Insert and Output paths have special rules regarding channel mapping (see “Overlapping Channels and Valid Paths” on page 79).

Assigning Hardware Inserts

To assign an external hardware insert to a track:

- Select an insert from the track Insert selector.

Bypassing Hardware Inserts

Hardware inserts do not provide a bypass control. To monitor playback without a hardware insert, either set it to Inactive, remove it by reassigning it to No Insert, or use a bypass switch on the hardware device itself. (See “Making Inserts Inactive” on page 514 for more information.)

Connecting and Integrating External Devices

Pro Tools can create dedicated connections to external analog or digital devices. The number and type of connections depends on what kind of system you have.

To connect an external device to a Pro Tools system:

1. Connect an unused output (or pair of outputs for a stereo device) of your Pro Tools system to an input of the external signal processor.
2. Connect the output of the external signal processor to an unused input (or pair of inputs for a stereo device) of your Pro Tools system.
3 Define what physical ports are routed to Pro Tools input and output ports, as appropriate, in either the Hardware Setup dialog or I/O Setup dialog.

4 Define output, input, or insert paths as appropriate in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, to use outputs 7–8, the insert has to use inputs 7–8 also.

For additional information on connecting external devices, refer to your Pro Tools Getting Started Guide.

Connecting Effects Units Digitally

If you want to use the digital inputs and outputs on your Pro Tools system as effects sends and returns to a digital effects device, Pro Tools should be the clock master in most cases. Set your digital effects device to accept an external digital clock so that it synchronizes to Pro Tools.

To set up a digital send to an external device from a Pro Tools|HD system:

1 Do one of the following:
   • On a 192 I/O, 192 Digital I/O, 96 I/O, 96i I/O, or 888|24 I/O, choose Setup > Hardware, choose the peripheral, format, and clock format, and set the channel pair to Digital.
   • On an 882|20 I/O or 1622 I/O, choose Setup > Hardware, choose the peripheral, and set Channel 1–2 input to Digital.

2 Choose Internal from the Clock Source popup menu.

3 Click OK.

To set up a digital send to an external device from a Digi 002 or Digi 002 Rack system:

1 Choose Setup > Playback Engine and choose the peripheral.

2 Do one of the following:
   • If the external device is connected to the S/PDIF RCA jacks, deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)
   • If the external device is connected to the Optical ports, choose a format (most likely S/PDIF for an effects device) from the Optical Format pop-up menu.

3 Choose Internal from the Clock Source popup menu.

4 Click OK.

5 Optionally, configure the I/O Setup dialog with new path names for effects routing.

If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for any audio input, and ignore any audio input on the S/PDIF RCA jacks.

Using External Clock Sources (for Recording and Monitoring)

When recording or monitoring, Pro Tools can synchronize to an external clock source. Options for external clock vary according to the type of Pro Tools system you are using.

Pro Tools|HD Systems

Pro Tools|HD systems can receive external clock through any of the digital inputs on any Pro Tools|HD I/O (including AES/EBU, S/PDIF, and Optical).
With an expanded Pro Tools|HD system that includes Legacy interfaces (such as the 888|24 I/O), connect to the digital input on Channels 1–2 of the Legacy audio interface in order to clock from them. Legacy I/Os only support 44.1 kHz and 48 kHz sample rates.

To determine correct card order and audio interface connections, refer to the Pro Tools|HD Getting Started Guide.

To select an external clock source for a Pro Tools|HD system:

1. Choose Setup > Hardware.
2. Select the appropriate Pro Tools|HD I/O in order to display its settings in the Main page.
3. If necessary, enable the appropriate Digital Format (if you have not already done so, according to the instructions in your Getting Started Guide or I/O Guide).
4. Set the Clock Source to match the type of input.
5. Configure input routing of the digital source, using the Input and Output pop-up menus, if necessary.
6. Click OK to close the Hardware Setup dialog.

Digi 002 or Digi 002 Rack Systems

Pro Tools can receive external clock from the Optical input or S/PDIF input.

To select an external clock source for a Digi 002 or Digi 002 Rack system:

1. Choose Setup > Hardware.
2. Set the Clock Source to match the type of input.
3. If you choose Optical, make sure the Optical Format matches the type of optical input you are sending to your Pro Tools system.

⚠️ If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for external clock, and ignore any clock input on the S/PDIF RCA jacks.

Mbox 2 and Mbox Systems

Pro Tools can receive external clock from the S/PDIF input on these interfaces.

To select an external clock source for an Mbox 2 or Mbox system:

1. Choose Setup > Hardware.
2. Choose the SPDIF (Windows) or SPDIF/RCA (Macintosh) from the Clock Source pop-up menu.
3. Click OK.

⚠️ Your digital input device must be connected and powered on for Pro Tools to synchronize to it. If your input device is not powered on, leave the Clock Source set to Internal.
Chapter 27: Automation

Pro Tools features dynamic automation of volume, pan, and mute controls for audio, Auxiliary Input, and Instrument, tracks, and sends and real-time plug-in controls. Master Fader tracks support volume automation. MIDI and Instrument tracks support MIDI volume, pan, and mute automation (MIDI data is unique from automation data).

In Pro Tools, you can write automation moves in real time during playback of your session. You can also edit automation data with the same techniques you use to edit audio and MIDI data.

Automation Accuracy with Control Surfaces

Digidesign Control Surfaces Digidesign’s D-Control, D-Command, ProControl, Control|24, and Command|8 control surfaces support all automation features in Pro Tools. Digidesign control surfaces provide 10-bit resolution, or 1,024 steps of fader resolution. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in extremely accurate and smooth fader automation.

MIDI Control Surfaces Most MIDI control surfaces have 7-bit resolution, or 128 steps. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in accurate and smooth fader automation.

Automation Quick Start

Pro Tools provides many options for recording, replacing, and editing automation data.

The basic steps for automation recording are:

- Enable the automation type that you want to record (volume, pan, mute, send level, send pan, send mute, or plug-in automation).
- Put the appropriate tracks in an automation writing mode (Write, Touch, or Latch, or a Trim mode).
- If you are automating a plug-in, enable the individual plug-in controls to be automated.
- Automation Safe any plug-ins, outputs, or sends that have existing automation data that you want to protect from being overwritten.
- Begin playback to begin automation recording, and adjust controls as needed. Pro Tools remembers all moves performed on enabled controls.

For details on using Digidesign control surfaces to create mix automation, refer to your Digidesign control surface guide.
To edit automation once it has been recorded, you can:

- Repeat the above steps to write new automation over the previous data.
- Graphically edit the automation data in the Edit window.
- Cut, copy, paste, or delete automation data (certain restrictions apply).

## Automation Playlists

Each Pro Tools track contains a single automation playlist for each automatable parameter.

On audio tracks, these parameters include:
- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-in controls

On Auxiliary Input tracks, these parameters include:
- Volume
- Mute
- Pan

On Master Faders, these parameters include:
- Volume

On MIDI tracks, these parameters include:
- Volume (MIDI)
- Pan (MIDI)
- Mute

On Instrument tracks, these parameters include:
- Volume (audio)
- Mute (audio)
- Pan (audio)

You can display and edit each of these automatable playlists individually from Pro Tools, even during playback.

In addition, on MIDI and Instrument tracks you can display and edit other continuous MIDI controller data (such as mod wheel, breath controller, foot controller, or sustain) in a similar manner. For more information on editing MIDI data, see “Continuous Controller Events” on page 426.

## Automation Playlists with Audio and MIDI Regions

Pro Tools handles audio regions and their automation playlists differently from MIDI regions and their automation playlists.

### Audio Tracks

On audio tracks, automation data resides on a separate playlist from audio data and regions. Each edit playlist on an audio track shares the same automation data.

### MIDI and Instrument Tracks

On MIDI tracks and Instrument tracks, all controller automation data except for MIDI Mute data, or audio mute (Instrument tracks only), is stored in the MIDI region that contains it. Each edit playlist on the track is separate, and represents a distinct performance, complete with controller automation.

> **MIDI Mute data is independent of the MIDI data in a MIDI region. This lets you mute playback of individual MIDI or Instrument tracks in Pro Tools without altering the controller data.**
Multiple Edit Playlists and Audio Track Automation

All edit playlists on a single audio track share the same automation data. When you record or edit automation data in an audio track, the automation data is stored in the track automation playlist so it can be edited with, or independently from, its associated audio regions.

◆ When you copy or cut audio data from a track while it is in Waveform View, the underlying automation data is cut or copied with it.
◆ If you paste audio data from other locations or tracks into an edit playlist, you may change the underlying automation data on the track.
◆ When you trim regions using Edit > Trim, the underlying automation data remains unchanged.

MIDI continuous controller data always follows region editing, with the exception of mute. See “MIDI and Instrument Tracks” on page 534 for more information.

Duplicating Tracks for Playlist Editing

The Duplicate Track command provides a convenient way to make a working copy of a track to experiment with routing, plug-ins, and automation. This protects the original track and its automation data from being edited or overwritten.

To copy a track for automation:

1 Select the track and choose Track > Duplicate.
2 In the Duplicate Tracks dialog, configure the following options as needed:
   • Enter how many copies you want to create by typing into the Number of Duplicates field.
   • To copy the currently active (visible) Edit playlist from the source track, enable Active Playlist.
   • To copy all Edit playlists on the source track, enable Alternate Playlists.
   • To copy all automation from the source track, enable Automation.
   • To copy all plug-in and insert assignments, enable Inserts.
   • To copy all sends and send assignments, enable Sends.
   • To maintain all Mix and Edit Group assignments, enable Group Assignments.
3 Click OK to duplicate the track according to the settings in the Duplicate Tracks dialog.
4 To temporarily disable the original track, make it inactive by doing one of the following:
   • Control-click (Windows) or Command-click (Macintosh) the Track Type icon.
   – or –
   • Select that track and choose Track > Make Inactive.
5 Edit automation on the duplicated track.
Automation Modes

Automation modes control how a track’s automation data is written and played back. Each track provides an Automation Mode selector for selecting the track’s Automation mode.

Off Mode

Off mode turns off automation for all automatable parameters:

- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-in controls
- MIDI volume, pan, and mute

In Off mode, automation data for these parameters is ignored during playback. All other MIDI controller data is sent.

Automation can be switched from Off to another Automation mode during playback or record.

Read Mode

Read mode plays the automation that was previously written for a track.

Write Mode

Write mode writes automation from the time playback starts to the time it stops, erasing any previously written automation for the duration of the automation pass. When a Write automation pass stops, it behaves as follows:

Pro Tools LE After an automation pass, Pro Tools automatically switches from Write mode to Touch mode. This prevents you from accidentally overwriting automation data on later playback.

Pro Tools HD You can set Write mode to automatically change to Touch mode or Latch mode, or remain in Write mode. See "‘After Write Pass, Switch To’ Preference" on page 536 for details.

On Pro Tools|HD systems with supported Digidesign control surfaces, an AutoMatch can be applied to a Write automation pass. See “AutoMatch Time” on page 541.

‘After Write Pass, Switch To’ Preference

The “After Write Pass, Switch To” preference selects the Automation mode that Pro Tools tracks automatically switch to after an automation pass in Write mode. You can choose to switch to Touch or Latch mode, or stay in Write mode by selecting No Change.

To configure “After Write Pass, Switch To”:

1. Choose Setup > Preferences and click the Automation tab.
2. Select an “After Write Pass, Switch To” option (Touch, Latch, or No Change).
3. Click Done.
**Touch Mode**

Touch mode writes automation only while a fader or switch is touched or clicked with the mouse. When the fader is released, the writing of automation stops and the fader returns to any previously automated position, at a rate determined by the AutoMatch and Touch Timeout settings. See “Automation Preferences” on page 540.

In Touch mode, certain control surfaces start writing automation as soon as you touch them. These include touch-sensitive fader controllers, such as Digidesign’s D-Control, D-Command, ProControl, Control|24, Digi 002, Command|8, or the Mackie HUI.

With other control surfaces in Touch mode, writing of automation does not begin until the fader hits the pass-through point, or the previously automated position. Once you reach the pass-through point with the fader, or a non-touch sensitive rotary control, writing of automation begins and continues until you stop moving the fader.

**Latch Mode**

Latch mode works in the same way as Touch mode, writing automation only if you touch or move a control. However, unlike Touch, writing of automation continues until you stop playback or “punch out” of the automation pass by changing the Automation mode to Read or Touch.

On Pro Tools|HD systems with supported Digidesign control surfaces, an AutoMatch Time can be applied to a Latch automation pass. See “AutoMatch Time” on page 541.

Latch mode is particularly useful for automating Pan controls and plug-ins on non-touch sensitive rotary controls, since it does not time out and revert to its previous position when you release a control.

*See also “Writing Automation to the Selection, Selection Start, or Selection End” on page 561.*

**AutoJoin with Latch Mode**

(Latch Mode with Supported Digidesign Control Surfaces Only)

Pro Tools provides two different methods to resume writing automation on controls that were active at the point where the transport stopped:

**AutoJoin** lets you automatically resume writing automation in Latch mode. AutoJoin can be enabled from a supported Ethernet-based control surface, or from Pro Tools if a supported control surface has been declared.

**Join** lets you manually resume writing automation in Latch mode. Join is available only with Digidesign-supported control surfaces.

To enable AutoJoin from a control surface or manually resume writing with Join, see your control surface guide.
To enable AutoJoin from Pro Tools:

1. Open the Automation Enable window (Window > Automation Enable).
2. Click AutoJoin in the Automation Enable window.

AutoJoin Indicator

After a Latch automation pass with AutoJoin enabled, the AutoJoin indicator appears in the Pro Tools Edit window.

Trim Mode

(Pro Tools HD Only)

Pro Tools HD can adjust (or trim) existing track volume and send level automation data in real time. Pan and plug-in automation cannot be trimmed in this manner. Trim mode works in combination with the other Automation modes (Read, Touch, Latch, and Write) and is useful when you want to preserve all of your volume automation moves, but need to make levels a bit louder or softer to balance a mix. For example, use Trim mode to create alternate mixes with “vocals up 1 dB” or “bass down 1 dB” (as often requested by labels and studios).

When editing automation in Trim mode, fader moves write relative rather than absolute values. The existing automation data is changed by the amount of increase or decrease (or the delta value) indicated by the faders. When trimming, a track’s Volume indicator or Send Level indicator shows the delta values being written rather than the absolute value.

When Trim mode is enabled, non-trimmable controls behave in the same manner as in the standard Automation modes, with the exception of Write/Trim mode, where non-trimmable controls operate as in Touch mode.
Trim/Off

Trim/Off mode turns off automation and trimming for a track. All automation moves are suspended during playback.

Automation can be switched from Trim/Off to another Automation mode during playback or record.

Read/Trim

In Read/Trim mode, the Volume and Send Level faders are disengaged from displaying and following existing automation data, so you do not have to chase them during playback. Faders are automatically positioned at 0 dB, where no trimming occurs (they start with a delta value of zero).

In Read/Trim mode, as soon as playback begins, trim moves (delta values) are played back, but are not written to automation data. This lets you audition trim moves without affecting existing automation.Trimming continues until playback stops.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Read mode—no automation data is written.

Touch/Trim

In Touch/Trim mode, when playback begins, the Volume and Send Level faders are disengaged from displaying and following existing automation data, so you do not have to chase them during playback. Faders are automatically positioned at 0 dB, where no trimming occurs (they start with a delta value of zero).

When one of the faders is touched, real-time trimming begins. Fader moves write delta values (an increase or decrease in the form of an offset to existing automation data).

When the fader is released, trimming stops and the fader returns to a zero delta or offset value and continues to follow the previously written automation. The rate of the fader’s return to a zero delta value is determined by the AutoMatch Time specified in the Automation Preferences page. See “AutoMatch Time” on page 541 for more information.

If you apply an AutoMatch Time, the fader will glide out, but the fader position represents the delta being applied to the underlying automation already on the track.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Touch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until the control is released or until playback stops.

Latch/Trim

In Latch/Trim mode, when playback begins, the Volume and Send Level faders are disengaged from displaying and following existing automation data, so you do not have to chase them during playback. Faders are automatically positioned at 0 dB, where no trimming occurs (they start with a delta value of zero).

When one of the faders is touched, real-time trimming begins. Any fader moves after trimming begins increase or decrease existing automation data accordingly. Trimming of the touched control continues until playback stops, or until you “punch out” of the record pass by changing the Automation mode to Read or Touch.

If you apply an AutoMatch Time, the fader will glide out, but the fader position represents the delta being applied to the underlying automation already on the track.
When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Latch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.

**Write/Trim**

In Write/Trim mode, the Volume and Send Level faders are disengaged from displaying and following existing automation data, so you do not have to chase them during playback or recording. Faders are automatically positioned at 0 dB, where no trimming occurs (they start with a delta value of zero).

In this mode, as soon as playback begins, delta values are applied to the existing automation data. Trimming continues until playback stops.

If you apply an AutoMatch Time, the fader will glide out, but the fader position represents the delta being applied to the underlying automation already on the track.

When Write/Trim mode is enabled, non-trimmable controls (all controls other than track volume and send level) are not in Write mode, but behave as if they are in regular Touch mode (no automation is written unless a control is touched). This is to prevent the controls from overwriting all of their automation data on every pass in Trim mode.

The “After Write Pass, Switch To” setting affects Write/Trim mode. After an automation pass in Write/Trim mode, Pro Tools tracks automatically switch to the Trim version of the “After Write Pass, Switch To” setting (Latch/Trim, Touch/Trim, or Write/Trim).

**Automation Preferences**

Pro Tools gives you several options for controlling the writing and playback of automation data.

**To display Automation preferences:**

- Choose Setup > Preferences and click the Automation tab.

**Smoothing**

When you perform automation moves with a continuous control, Pro Tools records the move as a series of very small steps, resulting in a staircase pattern with many breakpoints. Smoothing intelligently resolves this staircase pattern into a single, smooth ramp from one breakpoint to the next. (Smoothing does not apply to switched controls such as mutes or plug-in bypasses.) With smoothing enabled, the resulting automation is often a more accurate representation of actual automation moves.
**Thinning**

Thinning automatically reduces the overall number of breakpoints in the automation playlist in order to improve system performance. The amount of thinning applied is determined by the Degree of Thinning setting in the Automation Preferences page. When using high amounts of thinning, the resulting automation may differ noticeably from the original automation moves. Thinning only applies to audio tracks, and does not affect MIDI tracks. For instructions, see “Thinning Automation” on page 549.

**AutoMatch Time**

AutoMatch Time is the amount of time it takes for a fader to return (by ramping up to down) to the level of automation still on the track, as the automation pass ends. This time value is set in the Automation Preferences page (see “Automation Preferences” on page 540).

An AutoMatch Time is applied to all Touch mode passes.

The AutoMatch Time also determines the rate at which delta values written with the Trim will return to 0 dB (delta value of zero).

The AutoMatch feature works with continuous controls (such as Volume or Pan) by ramping their values back to previously automated levels. There are some stepped controls (for example, the EQ type in the 1-band EQ plug-in) that provide more than two discrete steps over their operational range. AutoMatch has no effect on these controls.

**AutoMatch Indicators**

There are triangular AutoMatch indicators at the bottom left of each channel strip in the Mix window. When lit, these indicate the direction the fader will automatically move.

**Setting the Automation Buffer Size**

Pro Tools lets you specify the size of the memory buffer used to write automation. If you are working on a large session or writing a very large number of automation moves, you may want to increase this value.

**To set the Automation Buffer size:**

1. Choose Setup > Preferences and click the Automation tab.

2. For the option “Amount of memory to reserve for automation recording,” enter a value between 200 and 20,000K. The default value for a new session is 200K.

3. Relaunch Pro Tools for this change to take effect.
To reduce processing load, try one of the following:

- Deselect the Faders Move During Playback option in the Automation Preferences page.
- Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 549.
- Turn off Sends View meters, if enabled, in the Display Preferences page. See “Individual Send Views and Meters” on page 491 for more information.

**Automation Safe**

Outputs, sends, and plug-ins can be placed in Automation Safe mode. In Automation Safe mode, any automation associated with an output window (such as track or send level, panning, or mute), or plug-in on that track, is protected from being overwritten while automating other items on that track.

Automation Safe enabled send

Automation Safe mode suspends automation recording for the selected track output, send, or plug-in that is enabled. You can also suspend automation recording and playback session-wide from the Automation Enable window. See “Enabling and Suspending Automation” on page 547.

**Viewing Automation**

Pro Tools creates a separate playlist for each type of automation you write. This data can be viewed and edited in the same way as audio and MIDI data.

To show automation data:

- Click the Track View selector and select from the pop-up menu the automation type you want to view.

    ![Displaying automation data](image)

    You can easily toggle between different Track Views. See “Changing Track Views” on page 222.
Writing Automation

You can write automation for all automatable controls by moving those controls during playback.

To write automation on a track:
1. Choose Window > Automation Enable.
2. Make sure the automation type is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector of the track you want to automate, and set the Automation mode. For the initial automation pass, choose Write mode.
4. Click Play to begin writing automation.
5. Move the controls you want to automate.
6. When you have finished, click Stop.

After the first automation pass, you can write additional automation to the track without completely erasing the previous pass by choosing Touch mode or Latch mode. These modes add new automation only when you actually move the control. (See “Automation Modes” on page 536.)

To write additional automation to a previous pass:
1. Enable Options > Link Timeline and Edit Selection.
2. In the Edit window, make a selection or place the cursor in the location where you want to start writing automation.
3. In the Mix or Edit window, click the Automation Mode selector of the track you want to automate, and set the Automation mode to Touch or Latch mode.
4. Click Play to begin writing automation.
5. Move the controls you want to automate.
6. When you have finished, click Stop.

You can write additional automation on more than one track at a time. To do so, set the Automation mode in each track you want to automate.

If you write automation in Touch mode with Loop Playback enabled, writing of automation will automatically stop at the end of the looped selection. At the beginning of each successive loop, you can then touch or move the control again to write new data.
Storing an Initial Controller Position

When you create a new audio, Auxiliary Input, MIDI, or Instrument track, it is automatically placed in Read mode. Even though the track is in Read mode, you can set the initial position of any automatable control, and it is saved with your session.

In this initial state, only a single automation breakpoint appears at the beginning of each automation playlist. If you move the control without writing automation, this breakpoint will move to the new value.

You can permanently store the initial position of an automatable control by doing one of the following:

- Place the track in Write mode and press Play to write a few seconds of automation data to the track
- Manually place a breakpoint on the automation playlist somewhere after the initial breakpoint. (See “Graphical Editing of Automation Data” on page 552 for more information.)

Automating Switched Controls

Pro Tools treats switched controls (such as mutes and plug-in bypasses) as touch sensitive controls. Automation data is written for as long as the switch or button for that control is pressed or touched.

For example, if you have just written a series of mute on/off states on a track in quick succession, the manual method for clearing this automation data would require you to move to the Edit window, choose automation playlist for Mute, select the mute automation data, and delete it. In Pro Tools, this can be done automatically.

To automate a switched control (such as the Mute button):

1. Perform another automation pass on the track.
2. When you reach the location of the mute state you want to remove, press and hold down the Mute button.
   
   When playback gets to the first muted section, the Mute button become highlighted.

3. As long as the button is held down, Pro Tools overwrites the underlying mute data on the track with the current state of the switch (on or off) until playback is stopped.

Automating Sends

Pro Tools provides automation of send level, send mute, and send pan (for stereo and multi-channel sends only). This makes it easy to control effects levels and placement during mixdown with great precision.

Send level and mute can also be configured to follow groups.

To automate a send level, mute or pan:

1. In the Automation Enable window, make sure the automation type is write-enabled (send level, send mute, send pan).
2. In the Mix or Edit window, set the Automation mode for each track containing sends you want to automate. For each track, click the Automation Mode selector and set the Automation mode. For the initial automation pass, choose Write mode.
3. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).
4 To display send controls, do one of the following:
   • Click the send to open the Output window for the send that you want to automate.
   • Choose View > Sends A–E (or Sends F–J) and select one of the individual views (such as Send A).
5 Click Play to begin writing automation.
6 Move the controls you want to automate.
7 When you have finished, click Stop.

Send mutes and levels can also be configured to follow Mix Groups. See “Automation Preferences” on page 540 for information.

Copying Track Automation to Sends
(Pro Tools HD Only)

There may be times where you want a track’s send automation to mirror automation in the track itself, for example, when an effect level needs to follow the levels in a main mix. To do this, you can copy the entire automation playlist for the selected control to the corresponding playlist for the send.

To copy a track’s automation to one of its sends:
1 Select the tracks you want to edit by clicking on the track names to highlight them.
2 Choose Edit > Automation > Copy to Send.
3 In the Copy to Send dialog, select Automation to copy the entire automation playlist for the corresponding controls.
4 Select the controls you want to copy.
5 Select the sends to which to copy the automation, and click OK.

When overwriting automation, Pro Tools presents a confirmation dialog. To suppress this dialog, press Alt (Windows) or Option (Macintosh) while clicking OK. You can undo the results of the Copy to Send command (Edit > Undo).
Automating Plug-Ins

You can automate changes to virtually all controls of the plug-ins included with your Pro Tools system. Automating a plug-in is slightly different from other automation procedures, because you must enable individual plug-in controls for automation.

To enable plug-in controls for automation:
1. Open the Plug-In window for the plug-in you want to automate.
2. Click the Automation Enable button in the Plug-In window.
– or –
   Control-Alt-Start-click (Windows) or Command-Option-Command-click the Track View selector in the Edit window.
3. Choose the controls to automate and click Add. If there are multiple plug-ins on the same track, you can select from among these by clicking their buttons in the Inserts section of this dialog.
4. Click OK to close the Plug-In Automation dialog.

To automate a plug-in:
1. In the Plug-In Automation Enable window, make sure plug-in automation is enabled.
2. In the Mix or Edit window, for each track containing plug-ins you want to automate, click the Automation Mode selector and set the Automation mode. For the initial automation pass, choose Write mode.
3. Click Play to begin writing automation, and move the controls you want to automate.
4. When you have finished, click Stop.
Enabling Automation for a Single Plug-In Parameter

As an alternative to using the Plug-In Automation window, you can enable individual plug-in controls directly from the Plug-In window by Control-Alt-Start-clicking (Windows) or Command-Option-Control-clicking (Macintosh) the control. Refer to the DigiRack Plug-Ins Guide or Digidesign Plug-Ins Guide for more information.

Enabling Automation for All Plug-In Parameters

To enable all plug-in parameters:

1. Make sure the plug-in window is open for the plug-in you want to automate.
2. Control+Alt+Start-click (Windows) or Command+Option+Control-click (Macintosh) on the Auto button at the top of the plug-in window.

Additional plug-in automation shortcuts are available from Digidesign D-Control or D-Command control surfaces. These shortcuts let you automate all parameters on a single plug-in, all parameters on all plug-ins in the same insert location on other tracks, or all parameters on all plug-ins in the session.

Record Safing Plug-In Automation

You can protect plug-in automation from being overwritten by using Automation Safe mode.

To enable plug-in safe mode:

1. Open a plug-in.
2. Click the Safe button so that it is highlighted.

Enabling and Suspending Automation

From the Automation Enable window, you can enable or suspend writing for the following types of automation across all tracks:

- Volume
- Pan
- Mute
- Plug-in
- Send level
- Send pan
- Send mute

Playback of automation can be suspended or unsuspended on-the-fly (without having to stop the transport).

To suspend writing of automation on all tracks:

1. Choose Window > Automation Enable.
2. Do one of the following:
   - To suspend writing of all automation on all tracks, click the Auto Suspend button.
• To suspend writing of a specific type of automation on all tracks, click the button for that automation type (volume, mute, pan, plug-in, send level, send mute, or send pan).

• To suspend writing and playback of automation for a specific control on all tracks, Control-Alt-click (Windows) or Command-Option-click (Macintosh) the name of the control in the Track View selector.

**Suspending Automation Playback**

You can suspend playback of automation for tracks by clicking on the track’s View selector. When a control is suspended, its control name is italicized.

**To suspend playback (and writing) of automation for specific controls:**

1. In the Edit window, set the Track View selector to show the automation playlist for the control you want to suspend.

2. Do one of the following:
   - To suspend writing and playback of automation for only the displayed control, Control-click (Windows) or Command-click (Macintosh) the control name in the Track View selector.
   - To suspend writing and playback of automation for all controls, Control-Shift-click (Windows) or Command-Shift-click (Macintosh) the name of any control in the Track View selector.
   - To suspend writing and playback of automation for a specific control on all tracks, Control-Alt-click (Windows) or Command-Option-click (Macintosh) the name of the control in the Track View selector.

**Automation Enable Guidelines**

The following rules determine whether automation is written or played back for a track:

- Although Pro Tools shows a single Automation mode for each track, all automatable controls associated with that track are not necessarily in the same Automation mode.

- If automation is globally suspended in the Automation Enable window, all automatable controls behave as if they were in Off mode, regardless of the track’s current Automation mode.

- If automation for a control is suspended by Command-clicking (Macintosh) or Control-clicking its name in the Track View selector, that control behaves as if it were in Off mode, regardless of the track’s current Automation mode.

- If automation for a control is suspended in the Automation Enable window, that control behaves as if it is in Read mode when the track is in a recordable Automation mode (Touch, Latch, or Write mode).
Deleting Automation

Automation data takes the form of a line graph with editable breakpoints. The easiest way to remove automation in a track or selection is to manually delete breakpoints from the automation playlist.

Removing data in this manner is different from using the Cut command, which creates anchor breakpoints at the boundaries of the remaining data. For details, see “Cutting, Copying, and Pasting Automation” on page 556.

To remove automation data, display the automation playlist you want to edit by selecting it from the Track View selector, and do one of the following:

To remove a single breakpoint:
- With the Pencil tool or any Grabber tool, Alt-click (Windows) or Option-click (Macintosh) the breakpoint.

To remove several breakpoints at once:
- Use the Selector tool to select a range that contains the breakpoints, and press Backspace (Windows) or Delete (Macintosh).

To remove all automation data of the displayed type:
- Click with the Selector tool in the track and choose Edit > Select All, then press Backspace (Windows) or Delete (Macintosh).

To remove all automation for all automation playlists on a track:
1. Use the Selector tool to select a range of data to be removed.
2. Press Start+Backspace (Windows) or Control+Delete (Macintosh).

All automation data within the selection is removed for all automation playlists on that track, regardless of whether automation is write-enabled for those controls.

Thinning Automation

Pro Tools writes a maximum density of automation data during an automation pass, in the form of breakpoints. Since Pro Tools creates ramps between breakpoints, it may not need all of the captured points to create a sonically accurate representation of the automation moves that you have made. Each breakpoint takes up space in memory allocated for automation, so thinning data can maximize efficiency and CPU performance.

Pro Tools provides two different ways to thin automation data and remove unneeded breakpoints: the Smooth and Thin Data After Pass option and the Thin Automation command.
Using Smooth and Thin Data After Pass

When this option is selected in the Automation Preferences page, Pro Tools automatically thins the automation breakpoint data after each automation pass.

The Smooth and Thin Data After Pass Option

In the default settings for new sessions, the Smooth and Thin Data After Pass option is selected, with the “Some” setting chosen. In most cases, this setting yields optimum performance while providing an accurate reproduction of your automation moves.

If you choose None, Pro Tools writes the maximum possible number of breakpoints. You can still perform thinning at any time with the Thin command. For more information on smoothing automation data, see “Smoothing” on page 540.

Using the Thin Automation Command

The Thin Automation command lets you selectively thin areas in a track where automation data is too dense. You can use the Undo command to audition the results of thinning (comparing thinning and not thinning) before you apply it permanently.

To use the Thin Automation command:
1. In the Edit window, click the Track View selector to display the automation type you want to thin.
2. With the Selector tool, highlight the automation data you want to thin. To thin all automation of the selected type in the track, click with the Selector tool in the track and choose the Select All command.
3. Choose Edit > Automation > Thin to thin the selected automation by the amount you have selected in the Automation Preferences page.

Drawing Automation

Use the Pencil tool to create automation events for audio and MIDI tracks by drawing in any automation or MIDI controller playlist.

The Pencil tool can be set to draw a series of automation events with the following shapes:

Choosing a Pencil tool shape

Free Hand Draws freely according to the movement of the mouse. In audio tracks, the shape has the number of breakpoints needed to smoothly interpolate and reproduce the automation shape. In MIDI tracks, the shape is reproduced as a series of steps, according to the resolution setting in the MIDI Preferences page.
**Line** Draws a straight line. In audio tracks, the line has a single breakpoint at either end. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI Preferences page.

**Triangle** Draws a sawtooth pattern that repeats at a rate based on the current Grid value. In audio tracks, the pattern has a single breakpoint at each extreme. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI Preferences page. Amplitude is controlled by vertical movement of the Pencil tool.

**Square** Draws a square pattern that repeats at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

**Random** Draws a random pattern of levels that change at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

**Using Pencil Tool Shapes**

You can draw automation for audio as well as MIDI tracks. For example, use the Triangle pattern to control continuous functions, or the Square pattern to control switched functions such as Mute or Bypass.

Since the Pencil tool draws these shapes using the current Grid value, you can use it to perform panning in tempo with a music track, or on frame scene changes when working in post production.

To set the resolution for the Pencil tool:

1. Choose Setup > Preferences and click the MIDI tab.

2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value can range from 1 to 100 milliseconds.

The illustrations below show the same MIDI controller automation drawn with different Pencil tool resolution settings.

For better performance, consider selecting a smaller value for MIDI controls that need higher resolution (such as MIDI volume), and a larger value for controls that may not require a high resolution (such as Pan).

**Resolution of MIDI Controller Data**

When using the Pencil tool to draw MIDI automation, the data is drawn as a series of discrete steps. You can control the resolution (or density) of these steps to help manage the amount of MIDI data sent for a given MIDI controller move.

- **For more information on MIDI continuous controller data, see “Continuous Controller Events” on page 426.**
Editing Automation

Pro Tools provides several ways to edit automation data for any track in your session. You can edit automation data graphically, by adjusting breakpoints on the automation playlist of a track. You can also cut, copy, and paste automation data in the same manner as audio and MIDI data.

Graphical Editing of Automation Data

Automation data takes the form of a line graph with editable breakpoints. By dragging these breakpoints, you can modify the automation data directly in the Edit window. When you drag an automation breakpoint up or down, the change in value is numerically or textually indicated. Dragging an automation breakpoint to the left or right adjusts the timing of the automation event.

Using the Grabber Tools

The Grabber tools lets you create new breakpoints by clicking on the graph line, or adjust existing breakpoints by dragging them. Alt-click (Windows) or Option-click (Macintosh) breakpoints with a Grabber tool to remove them.

Using the Pencil Tool

The Pencil tool lets you create new breakpoints by clicking once on the graph line. Alt-click (Windows) or Option-click (Macintosh) breakpoints with the Pencil tool to remove them.

Using the Trim Tools

The Trim tools let you adjust all selected breakpoints up or down by dragging anywhere within that selection.

Editing Automation Types

Each automatable control has its own automation playlist, that can be displayed by choosing it from the Track View selector. “Viewing Automation” on page 542.

Editing Volume Automation

Drag a breakpoint up or down to change the volume (dB value). Drag a breakpoint to the left or right to adjust the timing of the volume change.
Editing Pan Automation

Drag a breakpoint down to pan right, and up to pan left. Drag a breakpoint to the left or right to adjust the timing of the panning moves.

Editing Mute Automation

Drag the breakpoint down to mute a section. Drag a breakpoint up to unmute the section. Drag a breakpoint to the left or right to adjust the timing of the mute.

Editing Stepped Control Automation

Automation for certain controls (such as MIDI controller values or plug-in settings) appears as a stepped pattern on the breakpoint line. Drag a breakpoint up or down to a different step to change to a new control value. Drag a breakpoint to the left or right to adjust the timing of the stepped control change.

Editing Automation Breakpoints

To edit automation breakpoints, display the automation playlist for the control you want to edit by selecting it from the Track View selector, then do one of the following:

To create a new breakpoint:
- Click with the Pencil tool or any Grabber tool on the line graph.

To edit one breakpoint:
- Click an existing point on the line graph with any Grabber tool and drag it to a new position.

To clear one breakpoint:
- Alt-click (Windows) or Opt-click (Macintosh) with any Grabber tool.

To edit several breakpoints at once:
- Use the Selector tool to select a range in the automation playlist that contains the breakpoints, and do one of the following:
  - To move the breakpoints earlier or later in the track, press the Plus key (+) to nudge them later (to the right) or the Minus key (−) to move them earlier (to the left). The breakpoints move by the current Nudge value.
  - To adjust the breakpoint values, click with any of the Trim tools in the selection and drag the breakpoints up or down.

When you use a Trim tool to edit a selection containing breakpoints, new anchor breakpoints are created before and after the selected area. To suppress creation of anchor breakpoints, press Alt (Windows) or Option (Macintosh) while using a Trim tool.
To edit all breakpoint values in a region:
- Click in the region with any of the Trim tools and drag the breakpoints up or down.

**Constrain New Breakpoints to Next or Previous Automation Value**

New automation breakpoints can be constrained and written to the same value as the next or previous breakpoint.

![Diagram showing original automation, after write to previous breakpoint, and after write to next breakpoint.]

**Constraining and writing new breakpoints (at Marker 1)**

Writing a new breakpoint to the next or previous automation value is accomplished using any Grabber tool, but is not supported with the Smart Tool.

**To write a new breakpoint to the next automation value:**
- Press and hold Alt+Shift (Windows) or Option+Shift (Macintosh) while writing a breakpoint (by clicking with any Grabber tool in a track’s automation playlist).

**To write a new breakpoint to the previous automation value:**
- Press and hold Control+Alt (Windows) or Command+Option (Macintosh) while writing a breakpoint (by clicking with any Grabber tool in a track’s automation playlist).

**Editing Automation on Stereo and Multichannel Tracks**

Stereo and multichannel tracks display a single automation playlist per track. Only one playlist for volume and mute is available for the stereo or multichannel track.

For multi-mono plug-ins, automation playlists for each individual channel can be displayed and edited when the plug-in is unlinked, and the track is in Expanded Track Display.

**Expanded Track View**

By default, a single automation playlist is displayed on stereo and multichannel tracks. The playlist occupies the entire height of the track (similar to mono automation playlists).

Optionally, you can display an expanded view of the track whereby the same automation playlist is displayed across each channel.

**Plug-In Automation Playlists on Stereo and Multichannel Tracks**

Some multichannel plug-ins provide a single set of automatable controls for all channels in a track. Other multichannel plug-ins and all multi-mono plug-ins provide a single set of controls for all channels when linked, or discrete controls for each channel when unlinked. Refer to your plug-in guide for more information.
To view and edit the individual playlists of a multi-mono plug-in:

1. Unlink the plug-in.
2. Select the required playlist from the Track View selector.

Examples

- If you create new automation breakpoints on a grouped track (with the Pencil tool or any Grabber tool), other members of the group have breakpoints placed relative to that track.
- If you move volume or send automation on a grouped track (with any of the Trim tools), other members of the group have their volume or send breakpoints trimmed relative to that track. This lets you trim entire sections of a mix.

Editing Automation on Grouped Tracks

When you edit automation on an audio track that is a member of an active Edit Group, the same type of automation (with the exception of audio and MIDI Pan controls) is also edited on all tracks that are part of that group. This occurs even if the playlist for that type of automation is not currently displayed on the other grouped tracks.

However, when you edit automation on a MIDI track that is a member of an active Edit Group, grouping is ignored; the same type (with the exception of audio and MIDI Pan controls) are not edited on all tracks that are part of that group.

To individually edit a member of a group without affecting the other members:

- For audio, Auxiliary Input, and Instrument tracks, press the Start key (Windows) or Control (Macintosh) while you perform the edit.
- For MIDI tracks, do not press the Start key (Windows) or Control (Macintosh) while you perform the edit.

To edit all members of a group:

- For audio, Auxiliary Input, and Instrument tracks, do not press the Start key (Windows) or Control (Macintosh) while you perform the edit.
- For MIDI tracks, press the Start key (Windows) or Control (Macintosh) while you perform the edit.
When editing automation, audio and MIDI Pan controls work opposite from the way all other controls work.

For audio, Auxiliary Input, and Instrument tracks, when you edit or trim Pan breakpoints, Edit Groups are not obeyed. For grouped behavior, press the Start key (Windows) or Control (Macintosh) while trimming.

For MIDI pan on MIDI and Instrument tracks, when you edit or trim Pan breakpoints, Edit Groups are obeyed. For individual behavior, press the Start key (Windows) or Control (Macintosh) while trimming.

Cutting, Copying, and Pasting Automation

Cutting automation data is different from deleting it, and yields different results (although both change the existing automation data). Copying automation leaves the original automation data intact.

You delete automation data by selecting a range of breakpoints and pressing Backspace (Windows) or Delete (Macintosh). See “Deleting Automation” on page 549 for details.

You cut automation data by selecting a range of breakpoints from an automation playlist and selecting the Cut command.

When you cut automation data and when you paste it into a new location, anchor breakpoints are added to the beginning and end points of the data. This is done to preserve the true slope (of continuous controls, such as Volume faders or pans) or state (of switched or stepped controls, such as Mutes) of the automation data both inside and outside the selection.

The following illustrations show the difference between cutting and deleting automation data. In Figure 26, a track is set to display volume automation, and a range of automation data is selected.

![Figure 26. Selecting automation data](image)

If the Cut command is chosen, anchor breakpoints are created at each end of the selection, and the automation slope on either side of the cut data is preserved, as shown in Figure 27.

![Figure 27. After cutting the automation data](image)

If the data is deleted by pressing Backspace (Windows) or Delete (Macintosh), the automation data is removed, and automation values span the gap between pre-existing breakpoints, as in Figure 28.

![Figure 28. After deleting the automation data](image)
In addition, if cut or copied data is pasted elsewhere in a track, breakpoints are created at the end points of the pasted data to preserve its “neighboring” (incoming and outgoing) automation value and slope, as shown in Figure 29.

For additional flexibility, you can use playlists or the Duplicate Track command to work nondestructively on a copy of the edit data.

**Tips for Cutting, Copying and Pasting**

- On audio tracks, when you are in Waveform View and cut or copy a section of the waveform, any automation data associated with the waveform is also cut or copied.
- On audio tracks, when you are in Waveform View and cut audio data from a track also containing automation data, breakpoints are automatically created at the boundaries of the remaining automation data.
- On audio tracks, pasting waveform data also pastes any associated automation data.
- On Auxiliary Input, Master Fader, or Instrument tracks, only the displayed automation data is cut or copied. To cut or copy all automation data on these types of tracks, press Control while cutting or copying.
- In tracks where an automation playlist contains no data (when there is only a single breakpoint at the very beginning of the track), if you cut data, no new breakpoints are created.
- In cases where regions overlap (such as when moving regions in Slip mode) and an overlapping region is removed, any overlapped automation breakpoints are lost.
- If cut or copied data contains a type of automation not currently on the target track, Pro Tools prompts you before allowing you to paste the data.
- Cut or copied automation data for plug-ins or sends that do not exist on the target track is ignored when pasted.
Cut, Copy, Clear, and Paste Special Commands

The four “special” commands (Cut Special, Copy Special, Paste Special, and Clear Special) simplify the tasks involved with moving or clearing different types of automation data and MIDI controller data between tracks, sends, and plug-ins. These commands let you

- edit automation and MIDI controller data only (without associated audio or MIDI notes).
- edit automation and MIDI controller data without having to change Track Views

In addition, the Paste Special command lets you copy one data type to another (for example, Left Pan data into the Right Pan playlist).

⚠️ You cannot paste MIDI controller data to automation data nor automation to MIDI.

Cut Special

The Cut Special commands lets you cut just automation data from the current selection (without associated audio or MIDI notes) and place it in memory to paste elsewhere, as follows.

Choices include:

- **All Automation** Cuts all automation or MIDI controller data whether it is shown or not.
- **Pan Automation** Cuts only pan automation or MIDI pan data whether it is shown or not.
- **Plug-In Automation** Cuts only the plug-in automation that it is shown.

Copy Special

The Copy Special commands let you copy just automation data from the current selection (without associated audio or MIDI notes) and place a copy of it in memory to paste elsewhere, as follows:

- **All Automation** Copies all automation or MIDI controller data whether it is shown or not.
- **Pan Automation** Copies only pan automation or MIDI pan data whether it is shown or not.
- **Plug-In Automation** Copies only the plug-in automation that it is shown.

Paste Special

The Paste Special commands let you paste automation data into another region (without affecting associated audio or MIDI notes) in the following ways:

- **Merge** Lets you add the pasted data to any existing automation data of the same type in the destination selection. This can be useful for consolidating MIDI data from several tracks into a single MIDI track. For example, you like the pitch bend on the synth trombones and want to apply it to the synth guitar.
- **Repeat to Fill Selection** Pastes multiple iterations of the automation data to the entire selection range. If you select an area that is not an exact multiple of the copied region size, the remaining selection area is filled with a trimmed version of the original selection. This lets you easily create drum loops and other repetitive effects. Before the data is pasted, Pro Tools prompts you to specify a crossfade to smooth transitions between regions.
- **To Current Automation Type** Pastes the automation data or MIDI controller data from the clipboard to the selection as current automation type or MIDI controller. This lets you copy automation from any type to any other type. For example, you can copy a Left Pan automation to Plug-In automation. Or, you can copy MIDI volume data and paste it to MIDI pan.
Clear Special

The Clear Special commands let you clear just automation data from the current region, as follows:

**All Automation** Clears all automation or MIDI controller data whether it is shown or not.

**Pan Automation** Clears only pan automation or MIDI pan whether it is shown or not.

**Plug-In Automation** Clears only the plug-in automation that it is shown.

**Special Paste Function for Automation Data**

Normally, when you copy and paste automation data, it is pasted in an automation playlist of the exact same type (for example, Left Pan data is pasted into the Left Pan playlist).

However, there may be times when you want to paste from one data type to another (for example, Left Pan data into the Right Pan playlist).

The Special Paste function lets you copy one data type to another.

If you want to paste automation or MIDI controller data only (without its associated audio or MIDI notes), use the Paste Special command (see “Paste Special” on page 558).

For this special paste mode to function, the following must be true:

- Every track selected for pasting must be currently displayed as automation data.
- There must be only one automation playlist on the Clipboard for each target track. (The Special Paste function cannot copy multiple automation playlists for each track.)

You cannot interchange automation data between audio and MIDI tracks, or between continuous controls (such as faders or pans) and switched or stepped controls (such as mute or MIDI controllers).

**To paste data into a different automation playlist:**

- Press the Start key (Windows) or Control (Macintosh) when choosing Edit > Paste.

Glide Automation

The Glide Automation commands let you manually create an automation transition (or glide) from an existing automation value to a new one, over a selected area.

**When gliding multiple parameters at the same time, such as with the Surround Pan or plug-ins, use the Edit > Automation > Glide to All Enabled option.**

**To apply a Glide Automation to the current automation parameter type:**

1. In the Automation Enable window, make sure the automation type is write-enabled.
2. Click the Track View selector to choose the automation type you want to automate.
3. Drag with the Selector tool in the track to select the area you want to write the glide to.
4. Change the automation parameter to the value desired at the end of the selection. For example, to glide automation volume to –Infinity, move the Volume fader to –Infinity.
5. Choose Edit > Automation > Glide to Current.

You can also press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Macintosh).
To do a Glide Automation to all current enabled parameters:

1. In the Automation Enable window, make sure the automation types are write-enabled.
2. In each track you want to automate, click the Track View selector and select from the pop-up menu the automation type you want to automate.
3. With the Selector tool, click and drag horizontally to include all the tracks you want to automate in a selection (drag vertically to define the time range).
4. In each track you want to automate, change the automation parameter to the value desired at the end of the selection.
5. Choose Edit > Automation > Glide to All Enabled.

Glide Automation Considerations

When a Glide Automation is applied to automation data, it behaves as follows:

- When a selection is made, the automation value at the start of the selection is the start point of the Glide Automation and the end of the selection is the end point of the Glide Automation. The Glide Automation that is created between the two is based on the length of the selection and the end value that is selected.

- If a selection is made and automation data exists before the start of the selection, automation breakpoints are written at the start and end points of the Glide Automation.

- If automation breakpoints follow the selection, they are not changed, but the value selected for the end of the selection is written from the end point up until the next breakpoint.

- If no automation breakpoints follow the selection, the value selected for the end of the selection is written to the end of the track.

- If no selection is made, a breakpoint is written to the current location, and the value selected for the Glide Automation is written to the next breakpoint.

Trimming Automation

(Pro Tools HD Only)

If you have already written automation, you can modify automation data for track volume and send levels in real time by using Trim mode. When a track is trim-enabled, you are not recording absolute fader positions, but relative changes in the existing automation. See “Trim Mode” on page 538 for more information.

To enable Trim mode:

- In the Mix or Edit window, click the Automation Mode selector of the track you want to trim automation, and select Trim.
When Trim mode is enabled for a track, its Volume and Send Level faders turn yellow, and its Automation Mode selector is outlined in yellow. This outline flashes to indicate that the track is trim-enabled, and appears solid whenever trimming is occurring on the track’s volume or send levels.

**To trim track volume or send levels in real time:**

1. In the Automation Enable window, make sure the automation type (volume or send level) is write-enabled.

2. In the Mix or Edit window, click the Automation Mode selector of the track you want to trim automation and set the Automation mode:
   - Use Touch or Latch mode to have the faders follow existing automation, so you can “chase” them during the automation pass.
   - Use Write mode if you want to disengage the faders from existing automation.

3. In the Mix or Edit window, click the Automation Mode selector of the track you want to trim automation, and select Trim.

4. Click Play to begin trimming automation, and move the Volume or Send Level faders.

5. When you have finished, click Stop.

---

**Writing Automation to the Selection, Selection Start, or Selection End**

*(Pro Tools HD Only)*

Pro Tools lets you write current automation values from any insertion point forward (or backward) to the end (or beginning) of a selection or track, or to an entire selection or track, while performing an automation pass.

The standard Write Automation to Selection/Selection Start/Selection End commands do not operate when the Pro Tools transport is stopped. It only affects automation for those parameters that are currently write-enabled and currently writing automation data.

Optionally, Write Automation to Selection, Selection Start, and Selection End can be configured to always be applied automatically. See “Write Automation to Selection, Selection Start, and Selection End On Stop” on page 563.
Requirements for Standard Write Automation Commands

For automation data to be written for a specific parameter, the associated track must be in one of the following Automation modes and meet the following conditions:

- **Latch Mode** The control for the parameter must be changed (touched) during the automation pass.
- **Touch Mode** The control for the parameter must be changed (touched).
- **Write Mode** All controls on that track must be in Write mode.

This command can be undone (Edit > Undo).

**To write current automation values to the start, end, or all of a track or selection:**

1. Open the Automation Enable window (Window > Automation Enable).
2. Make sure that the automation type is write-enabled.
3. Click in a track at an insertion point.
   - or –
4. Drag with the Selector tool to select a portion of the track.
5. Click Play to begin playback.
6. When you reach a point in the track or selection that contains the automation data you want to apply, click Write Automation to Selection, Selection Start, or Selection End in the Automation Enable window.

The current values of all write-enabled automation at that point are written to the corresponding area of the track/selection.

**Trim Mode**

Using Trim mode, it is also possible to write trim delta values for track volume and send levels to the start (beginning), end or all of a track.

**To write current trim delta values to the start, end, or all of a track or selection:**

1. Open the Automation Enable window (Window > Automation Enable).
2. Make sure that the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector of the track you want to trim automation, and select Trim. The track Volume and Send Level faders turn yellow.
4. Click in a track at an insertion point.
   - or –
5. Drag with the Selector tool to select a portion of the track.
6. When you reach a point in the track or selection that contains the trim setting (delta value) you want to apply, click the Write Automation to Selection, Selection Start, or Selection End button in the Automation Enable window.

The relative changes to the track volume and send levels at that point are written to the corresponding area of the track/selection.
### Write Automation to Selection, Selection Start, and Selection End On Stop

The Automation Enable window provides options for writing automation after a valid automation pass has been performed.

Write Automation to Selection, Selection Start, and Selection End On Stop modes can be configured to disable or remain enabled after a valid automation pass.

See “Requirements for Standard Write Automation Commands” on page 562.

#### To configure Write on Stop modes to disable after an automation pass:

1. Open the Automation Enable window (Window > Automation Enable).
2. Click to enable one of the Write On Stop modes (Selection, Selection Start, Selection End).

The enabled Write on Stop arrow will appear in blue.

#### To configure Write on Stop modes to remain enabled after an automation pass:

1. Open the Automation Enable window (Window > Automation Enable).
2. Press Alt (Windows) or Option (Macintosh) and click one of the Write On Stop modes (Selection, Selection Start, Selection End) to enable the Write On Stop mode.

The enabled Write on Stop arrow will appear in red.

### Writing Automation to the Next Breakpoint

**(Pro Tools HD Only)**

While performing an automation pass, Pro Tools lets you write current automation values from the current insertion point to the next (similar) automation breakpoint.

This lets you update automation within a track without overwriting automation located earlier or later in the timeline, and without having to define a selection before editing automation.

Like the standard Write Automation to Selection commands, the standard Write Automation to Next Breakpoint command does not operate when the Pro Tools transport is stopped. It only affects automation for those parameters that are currently write-enabled and currently writing automation data.
Optionally, Write Automation to Next Breakpoint can be configured to be applied automatically after a valid automation pass has been performed. See “Write Automation to Next Breakpoint On Stop” on page 565.

Write Automation to Next Breakpoint remains enabled after a valid automation pass. Unlike standard Write Automation commands, it cannot be configured to disable after an automation pass.

To write current automation values to the next breakpoint:

1. Open the Automation Enable window (Window > Automation Enable).
2. Make sure that the automation type is write-enabled.
3. Click in a track at an insertion point.
4. Click Play to begin playback.
5. Make sure you are actively writing on the appropriate track if you are in Latch or Touch mode.
6. When you are satisfied with the controller data you are writing, and you want to apply it, click Write Automation to Next Breakpoint in the Automation Enable window.

Trim Mode for Write To Next Breakpoint

Using Trim mode, it is also possible to write trim delta values for track volume and send levels to the next written breakpoint.

To write current trim delta values to the next breakpoint:

1. Open the Automation Enable window (Window > Automation Enable).
2. Make sure that the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector and select Trim. The track Volume and Send Level faders turn yellow.
4. Do one of the following:
   - Click in a track at an insertion point.
   - or –
   - Drag with the Selector tool to select a portion of the track.

Write Automation to Next Breakpoint on Stop button in the Automation Enable window

The current values of all controls being written at that point are written up to the next breakpoint, and the transport will automatically stop.
5 Click Play to begin playback.

6 When you are satisfied with the controller data you are writing, and you want to apply it, click the Write Automation to Next Breakpoint button in the Automation Enable window.

The relative changes to the track volume and send levels at that point are written to the corresponding area of the track/selection.

**Write Automation to Next Breakpoint On Stop**

The Automation Enable window provides an option for automatic Write Automation to Next Breakpoint on Stop.

Write Automation to Next Breakpoint on Stop remains enabled after a valid automation pass. Unlike Write on Stop Modes (Write Automation to Selection, Selection Start, and Selection End), it cannot be configured to disable after an automation pass.

When this option is enabled, automation writing will be performed automatically to the next breakpoint after a valid automation pass has been performed.

---

**Mute Automation Overwrite/Extend Command**

(Pro Tools HD Only)

The Mute Overwrite/Extend command lets you overwrite or extend an existing mute event in real-time, without changing the current mute state.

A mute event can be overwritten when the automation pass begins before the first mute event and ends after the second event. In this case, the current on/off state of the mute is maintained.

A mute event can be extended when the automation pass begins before an on or off event and stops before the end of the second event.

---

**Mute on event overwritten**

Overwriting a mute automation event

---

**To configure Write Automation to Next Breakpoint on Stop:**

1 Open the Automation Enable window (Window > Automation Enable).

2 Click to enable Write Automation to Next Breakpoint on Stop.
Mute Overwrite/Extend is supported in Touch and Latch mode, as follows:

**Touch Mode** Writes the current state as long as the Mute button is held.

**Latch Mode** Writes the current state until you stop or AutoMatch out (with supported Digidesign control surfaces only).

**To overwrite a mute state on one or more tracks:**

1. Choose Window > Automation Enable.
2. Make sure Mute is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector of the track you want to overwrite the mute state, and set the Automation mode to Touch or Latch mode.

   ✏️ To overwrite mute states on multiple tracks, set all tracks to the same Automation mode.

4. In each track you want to automate, click the Track View selector and select mute.
5. Place the cursor before the start of the mute event you want to overwrite.
7. Press Control (Windows) or Command (Macintosh) and the track Mute button before the start of the mute event you want to overwrite.

   ✏️ To overwrite mute states on multiple tracks, press Alt+Control (Windows) or Option+Command (Macintosh) and the Mute button on one of the tracks to be automated.

8. After the end of the second mute event, release the key and the Mute button.

   ✏️ With Touch mode, you have to hold the Mute button for the duration of the write.
When you have finished the automation pass, click Stop.

To extend a mute state on a track:

1. Choose Window > Automation Enable.
2. Make sure mute is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector of the track you want to automate, and select Touch or Latch mode.
4. In each track you want to automate, click the Track View selector and select mute.
5. Place the cursor before the start of the mute event you want to extend.
7. Press Control (Windows) or Command (Macintosh) and the track Mute button before the start of the mute event you want to extend.

Tip: To extend mute states on multiple tracks, set all the tracks to the same Automation mode.

8. Before the end of the second mute event, release the key and the Mute button.

Tip: If you extend past the subsequent on or off event, the entire event will be changed.

9. When you have finished the automation pass, click Stop.

Example of mute state overwritten

Example: Stop automation pass here, after end of mute event

Stopping automation after the end of a mute event

Example: Stop automation pass here, before end of mute event

Stopping automation before the end of a mute event

Example of mute state extended

Place the cursor here, before start of mute event

Placing the cursor before the start of a mute event

Example: Place cursor here, before start of mute event

Example: Stop automation pass here, after end of mute event

Example: Place cursor here, before start of mute event

Example of mute state extended
Creating Snapshot Automation

(Pro Tools HD Only)

Pro Tools lets you write automation data values for multiple parameters in a single step. You can write snapshot automation in two ways:

To a Selection  Automation data is written to the Timeline selection (as well as the Edit selection if linked). Anchor breakpoints are placed just before and after the selection so that data outside the selection is not affected.

To a Cursor Location  Automation data is written at the insertion point. After the insertion point, the automation ramps to the next breakpoint value, or if no breakpoints exist, remains at the newly written value for the remainder of the session.

For more information on cutting, copying, and pasting automation data within a session, see “Writing Automation to the Selection, Selection Start, or Selection End” on page 561.

To write snapshot automation:

1. In the Edit window, click the Track View selector to show the automation you want to edit.

2. In the Automation Enable window, make sure that the parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

3. Select an area in the track’s playlist (or within multiple tracks) where you want to apply the automation.

   – or –

   Place the cursor at an Edit insertion point.

4. Adjust the controls you want to automate. You can also change a plug-in preset.

5. Choose Edit > Automation and do one of the following:

   • To write the current value to only the currently displayed automation parameter, choose Write to Current.

   – or –

   • To write the current settings for all automation parameters enabled in the Automation Enable window, choose Write to All Enabled.

Adding Snapshot Automation to Empty Automation Playlists

When you use a Write Automation command on an automation playlist with no previously written automation data, the selected value is written to the entire playlist and not just the selected area.

This is because a playlist with no automation data contains only a single automation breakpoint that corresponds to the current position of the control for the parameter. The position of the breakpoint is updated whenever the parameter value is changed.

If you do not want the Write Automation command to write the selected automation value to the entire playlist, you can:

   • Anchor the automation data by placing the cursor at the end of the session (or any other endpoint) and choosing Write to Current.

   – or –

   • Click with any Grabber tool on each side of the selection.

This lets the Write Automation command write only to the selected area.
**Writing Snapshot Automation over Existing Automation Data**

When you move the playback cursor, the automated controls in Pro Tools update on the screen to reflect the automation data that is already on the track. To keep the settings you have made for a snapshot, you can suspend automation parameters to prevent them from updating.

**To write snapshot automation over existing data:**

1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.
2. Adjust the controls for the parameters you want to automate.
3. Click the Automation Mode selector and select Off mode for the tracks you want to apply the automation.
4. With the selector, select the track range you want to apply the automation.
5. Choose Edit > Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose to Write to Current.
   - or –
   - To write the current settings for all automation parameters enabled in the Automation Enable window, choose to Write to All Enabled.
6. Click the Automation Mode selector and select Read mode for the tracks you want to play back with automation.

**Capturing Automation and Applying it Elsewhere**

The Write Automation commands can also be used to capture automation states at specific locations in a session and apply them to other locations.

**To capture and apply automation:**

1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.
2. Click with the Selector tool in the track with the automation you want to capture. All automated controls update to reflect the automation at that location. (If you make a selection, the controls update to reflect the automation at the beginning of the selection.)
3. In each track you want to apply automation, click the track’s Automation Mode selector and set the Automation mode to Off.
4. With the Selector tool, select the location where you want to apply the automation.
5. Enable the automation parameters previously suspended.
6. Choose Edit > Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose To Current Parameter.
   - or –
   - To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.
7. Click the Automation Mode selector and select Read mode for the tracks you want to play back with automation.
Snapshot Automation and Trimming of Automation Data

Pro Tools lets you use trim values as snapshots and apply the relative changes (delta values) to the selected automation by using the Trim Automation command. This works in much the same way as the Write Automation command, except that it writes delta values instead of absolute values to automation data.

You can use trim values in writing snapshot automation to any automatable parameter.

To create a snapshot of relative changes in automation data:

1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2. Select the area of the track you want to edit. All automated controls update to reflect the automation at the beginning of the selection.

3. Move the controls for the parameter up or down by the amount you want to change the data.

4. Choose Edit > Automation and do one of the following:
   - To write the current delta value to only the currently displayed automation parameter, choose Trim to Current.
   - Or –
   - To write the current delta value for all automation parameters enabled in the Automation Enable window, choose Trim to All Enabled.

Automation Follows Edit Option Command

When disabled, automation events are not affected by edits to audio or MIDI notes. When enabled, automation events are affected by edits to audio or MIDI notes.

To disable Automation Follows Edit:

- Choose Options > Automation Follows Edit.
Chapter 28: Mixdown

Pro Tools lets you record and bounce tracks to disk. The Bounce to Disk command lets you write a final mix to disk, create a new loop, print effects, or consolidate any submix. You can also submix, route, and record busses and inputs to new audio tracks.

**Bounce to Disk** This command writes the current session (if no selection), Edit, or Timeline selection as new audio files to disk. Any available output or bus path can be selected as the bounce source. Use Bounce to Disk to write or master any output or bus path directly to disk. Sample rate, bit depth, and other conversion processes can be applied during or after the bounce. The Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve. Though you can hear the bounce being created in real time, you cannot adjust mixer or other controls during a Bounce to Disk.

**Recording to Tracks** This is the process of submixing and recording to new audio tracks, as you would any input signals. This method requires available tracks, voices, and bus paths to accommodate the submix and the new tracks. While recording to tracks, you can adjust mixer or other controls.

**Selecting Audio for Loops, Submixes, and Effects**

Both Bounce to Disk and recording to tracks operate on the current Timeline or Edit selection, if any. This makes it easy to turn multitrack selections into mono, stereo, or multichannel loops. Submixes, stems, and other specialized types of mixes can also be printed to disk using either method, or recorded out to a DAT, MDM, or other recording, transfer, or archiving medium.

Printing effects to disk is the technique of permanently adding real-time effects, such as EQ or reverb, to an audio track by bussing and recording it to new tracks with the effects added. The original audio is preserved, so you can return to the source track at any time. This can be useful when you have a limited number of tracks or effects devices.

AudioSuite plug-ins provide another option for printing a plug-in effect to disk. See the DigiRack Plug-Ins Guide for details.

Use Bounce to Disk if you need to convert the bounce files, or if you do not want or need to interact with mixer controls during the bounce.

Record to new tracks if you want to adjust controls while the files are being written.
Dither and Bounce to Disk

Dithering can significantly improve audio quality. Generally, dithering is necessary when reducing the bit depth for digital audio.

If you use Bounce to Disk, it is important to understand that the Bounce to Disk process does not apply dither.

To dither a bounce file, you should insert one of the included Digidesign Dither plug-ins, or another dithering plug-in, on a Master Fader assigned to the bounce source path. Master Faders are often preferable to Auxiliary Inputs because Master Fader inserts are post-fader (better for dithering).

If you do not use a dithering plug-in on your bounce source path, and you choose to convert to a lower resolution during or after a Bounce to Disk, the resultant file will be converted by truncation.

When to Use a Dithering Plug-In

You should use a dithering plug-in in any situation where you are reducing bit depth, for example, when mastering to a 16-bit file with the Bounce to Disk command, or when mastering to an external device that records at 16-bit.

This is even necessary when using 16-bit sessions. Even though 16-bit sessions use 16-bit files, they are still being processed at a higher bit rate:

- 24-bit audio input and output signal paths with internal 48-bit mixing and processing for Pro Tools|HD systems
- 24-bit audio input and output signal paths with internal 32-bit floating point processing for Pro Tools LE systems

For this reason, whether you are using a 16-bit session or a 24-bit session, it is recommended that you use a Dither plug-in when mastering to 16-bits.

When mastering to 24-bits, it is not necessary to use a Dither plug-in.

Using Dither on an Output Mix

Pro Tools includes real-time dithering plug-ins that improve 16-, 18-, or 20-bit performance and reduce quantization noise when mixing or fading low-level signals.

The dithering plug-ins have no user-selectable controls other than Bit Resolution and Noise Shaping controls.

For more information about dither, see "Dither" on page 509.

To use a dithering plug-in on a submix:

1. Choose Track > New and select Master Fader (stereo) from the pop-up menu.
2. Set the output of the Master Fader to the output or bus path you want to bounce.
3. Assign the outputs of all audio tracks in the session to the same path you selected in step 2. The Master Fader now controls the output levels of all tracks routed to it.
4. On the Master Fader, click an Insert button and choose one of the Digidesign Dither plug-ins.
5. In the dithering plug-in window, choose an output Bit Resolution and Noise Shaping setting.
When you Bounce to Disk you can convert the file to the appropriate resolution. Before being converted by the Bounce to Disk command, the signal will have been dithered to the resolution and noise shaping settings in a dithering plug-in.

For more information about the Digidesign dithering plug-ins, refer to the DigiRack Plug-Ins Guide.

**Recording to Tracks**

You can create a submix in your Pro Tools session and record it to available tracks in the same session. This technique lets you add live input to the mix, as well as adjust volume, pan, mute, and other controls during the recording process. You can also use this technique instead of Bounce to Disk, to create mixed tracks directly in your Pro Tools session.

**Voice Requirements**

Recording a submix to new tracks requires an available voice for each track that you want to record. Make sure you have enough voices available to play back all tracks that you want to record and enough voices available to record the destination tracks.

In contrast, the Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve, but you cannot manually change any controls during the bounce. See “Bounce to Disk” on page 574 for more information.

For information about voice management, see “Track Priority and Voice Assignment” on page 102.

With Pro Tools HD, RTAS plug-ins placed on Auxiliary Input, Master Fader, and Instrument tracks will use additional voices and may introduce extra latency based on the HW Buffer Size. For more information, see “Voice Usage and Total Latency for RTAS Plug-Ins” on page 513.

**To record a submix to a track:**

1. Apply any plug-ins or external processors you want to add to your audio tracks or Auxiliary Inputs before you record.
2. Set the main channel output of the tracks you want to include in the submix to a bus path. If you are using stereo or multichannel tracks, set the panning of each track.
3. Choose Track > New and create one or more mono, stereo, or multichannel audio tracks.
4. If you are recording in stereo, pan the new stereo track (or two mono tracks) hard left and right.
5. Set the input of each destination track to match the bus path from which you are recording.
6. Set the output of your new tracks to your main output path.
7. Select Options > Link Timeline and Edit Selection.
8 Select audio to record. The start, end, and length of the recording can be based on the cursor location or Timeline and Edit selections.

- Selection-based recording automatically punches in and out of recording at the selection start and end. Be sure to include time at the end of a selection for reverb tails, delays, and other effects.
- If you do not make a selection, recording will begin from the location of the playback cursor. Recording will continue until you press Stop.

9 Record enable the new tracks and click Record in the Transport window.

10 Click Play in the Transport window to begin recording the submix.

11 If recording a selection of audio, recording will stop automatically. If performing an open-ended recording, click Stop, or punch out of recording. Make sure Loop Playback is not enabled.

Bounce to Disk

The Bounce to Disk command lets you mix down with all available voices on your system. Since it records to separate audio files, you do not have to reserve any tracks for a bounce.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process (though you can’t adjust it).

You can use the Bounce to Disk command to create and automatically import loops, submixes, or any audio into your session. You can use it to create a final mono, stereo, or multichannel master, in any of several audio file formats. Bounce to Disk provides conversion options for sample rate, bit resolution, and format.

When you bounce a track to disk, the bounced mix includes the following:

Audible Tracks All audible tracks that are routed to the output which is selected as the source of the bounce are included in the bounce. Any muted tracks are not included in the bounce. If you solo one or more tracks, only the soloed tracks are included in the bounced mix.

Automation All read-enabled automation is played back and incorporated in the bounced mix.

Inserts and Sends All active inserts, including real-time plug-ins and hardware inserts, are applied to the bounced mix.

Selection or Track Length If you make a selection in a track, the bounced mix will be the length of the selection. If there is no selection in any track, the bounce will be the length of the longest audible track in the session.

Time Stamp Information Bounced material is automatically time stamped so that you can drag it into a track and place it at the same location as the original material. For more information about time stamping, see “Time Stamping” on page 664.

Bounced Files Are “Delay-Compensated”

Pro Tools compensates for any bus and plug-in delays due to a bounce. This means that if a bounce file is imported back into a session, and placed directly in time against the source mix, it is time-aligned with the original source mix.

Record-Enabled Tracks and TrackInput-Enabled Tracks Cannot Be Bounced

Pro Tools does not allow you to bounce tracks that are either record-enabled or in Input Only monitoring mode.
To Bounce to Disk:

1. Choose File > Bounce to > Disk.

2. Configure bounce options as needed and perform the bounce (see “Bounce Options” on page 575).

**Bouncing with Mute Frees Assigned Voice (Pro Tools HD Only)**

When bouncing sessions that include muted tracks, enabling “Mute Frees Assigned Voice” can, in some instances, increase the number of tracks that can be successfully bounced. See “Mute Frees Assigned Voice” on page 111.

**Bounce Options**

When you use the Bounce to Disk command, you can configure several file options.

**Default Settings**

Available options and their default settings are listed in the following table.

<table>
<thead>
<tr>
<th>Options and Default Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bounce Option</td>
</tr>
<tr>
<td>Bounce Source</td>
</tr>
<tr>
<td>File Type</td>
</tr>
<tr>
<td>Format</td>
</tr>
<tr>
<td>Resolution</td>
</tr>
<tr>
<td>Sample Rate</td>
</tr>
<tr>
<td>Conversion Quality</td>
</tr>
<tr>
<td>Use Squeezer (8-bit only)</td>
</tr>
<tr>
<td>Convert During Bounce</td>
</tr>
<tr>
<td>Convert After Bounce</td>
</tr>
<tr>
<td>Import After Bounce</td>
</tr>
</tbody>
</table>

**Bounce Source**

Select any mono, stereo, or multichannel output or bus path as the source for the bounce. All currently active output or bus paths as defined in the I/O Setup dialog are available as the Bounce Source.
To set the bounce source:

- Select an output or bus path from the Bounce Source selector.

![Bounce Source Selector](image)

**File Type**

Selects the (creator) type for the bounced files.

![Selecting a File Type](image)

**Sound Designer II**

*(Macintosh Only)*

This was the native format for older Macintosh-based Pro Tools systems. Select this to use the bounced audio with any Digidesign application for Macintosh.

**BWF (Broadcast .WAV Format)**

This was the native format for older Windows-based Pro Tools systems, but is now supported on Windows and Macintosh. To use a BWF (.WAV) file in Pro Tools, you can drag and drop from the DigiBase Browser, Windows Explorer or Macintosh Finder, or a folder, or you can use the Import Audio to Track or Import Audio to Region List menu command. Files in this format do not have to be converted to be used in Pro Tools.

**AIFF (Audio Interchange File Format)**

To use an AIFF file in Pro Tools, you can drag and drop from the DigiBase Browser, the desktop, Windows Explorer or Macintosh Finder, or you can use the Import Audio to Track or Import Audio to Region List command. Files in this format do not have to be converted to be used in Pro Tools. AIFF waveform overview data is calculated and saved to a cache file, which is accessed each time the session is opened.

**QuickTime**

This is Apple’s audio file format for QuickTime-based multimedia. Pro Tools does not directly support this type of file in its sessions. To use a QuickTime audio file within Pro Tools, use the Import Audio from QuickTime Movie command (or Import Audio from Current Movie). The QuickTime format is popular for attaching to emails, to simplify long-distance project review and approval. Many popular multimedia applications also support QuickTime.

**Sound Resource**

*(Macintosh Only)*

This file type is supported by some Macintosh software applications and also by Macintosh System Software. Pro Tools does not directly support this type of file in its sessions. To use a SND file within Pro Tools, use the Import Audio to Track or Import to Region List menu command. The SND format is useful if you plan to use your audio with other Macintosh applica-
tions that do not support Sound Designer II or AIFF formats. To use a bounced file as a System alert sound, save it in this format and then drag it onto the Macintosh System File.

Windows Media
(Windows Only)

Windows Media formatted files can contain audio, video, or script data stored in Windows Media Format. A Windows Media Format file may have an .asf, .wma, or .wmv file name extension.

MXF (Material Exchange Format)
(Pro Tools with DigiTranslator Only)

MXF is a media file format that includes both video and audio files, and is designed for the interchange of audio-visual material with associated data and metadata. It was designed for improving file-based interoperability between servers, workstations, and other content creation devices.

AAF and OMF sequence format files can refer to MXF media files, or have MXF media files embedded within them. Pro Tools with DigiTranslator supports AAF embedded sequences.

See the DigiTranslator Guide for more information.

MPEG-1 Layer 3 (MP3)

The MPEG-1 Layer 3 compression format (MP3) is used for streaming and downloading audio over the Internet, and for playback on portable devices. The MP3 Option is required to use this file type.

The MP3 Option is available for purchase from the online DigiStore only at the Digidesign Web site (www.digidesign.com).

MP3 Output Options

The MP3 encoder provided as an install option with Pro Tools is a fully functional 30-day demo version. To purchase the full version of the MP3 encoder, visit Digidesign’s Web site (www.digidesign.com).

When you select this format, the Resolution pop-up menu in the Pro Tools Output Options dialog is unavailable. The resolution is set by the encoder.

The sample rate chosen is given to the codec as a “base” sample rate for operations. The actual sample rate of the resulting file is determined in the MP3 Encoder Options dialog. For example, if a base sample rate of 48000 Hz is chosen, the MP3 Encoder Options dialog will allow output streams in 48, 24, or 12 kHz, depending on encoding quality.

When you export or bounce to MP3 format, you can set the following options:

Encoder Settings

Encoding Quality Determines the audio quality of the bounced file. The higher the quality, the longer it will take to process the audio. The three options, in ascending order of quality, are Fastest Encoding, Medium Encoding, and Highest Quality.
The Highest Quality setting can take up to five times longer to process audio than the Fastest Encoding setting, so you should use it only when the highest fidelity is essential and you have a considerable amount of time to devote to the encoding process. You should experiment with the other encoding quality settings, since they can provide acceptable quality with a significantly shorter encoding time.

**Encoding Method**

Two encoding methods are available:

- **Constant Bit Rate (CBR)** encodes the file at a single bit rate that you choose from the CBR pop-up menu. Because the bit rate is fixed, the quality of the encoded audio will vary depending on the nature of the material being compressed. This option is best for streaming over the Internet, since it has predictable bandwidth requirements.

- **Variable Bit Rate (VBR)** encodes the file at a varying bit rate to maintain the level of encoding quality that you choose from the VBR pop-up menu. The bit rate varies automatically depending on the nature of the material being compressed. This option is best for personal jukebox applications.

**ID3 Tag Info Settings**

**ID3 Tag Type**

The ID3 tag stores data about the encoded audio file that is used by MP3 players to display information about the file. Pro Tools supports three versions of this tag, in order to provide backward compatibility with older MP3 players:

- **ID3 v1.0**: Appears at the end of a streaming MP3 file, so that tag information is only displayed after software streaming is finished.
- **ID3 v1.1**: Same as version 1.0, but adds track number information to the tag.
- **ID3 v2.3**: Appears at the front of a streaming MP3 file, so that tag information is displayed when streaming begins.

⚠️ *While ID3 v2.3 is becoming the standard MP3 format, not all MP3 players currently support ID3 v2.3. Contact the developer of your player software for compatibility information.*

**Title/Artist/Album/Comment**

Type the title, artist, and other information for the MP3 file. This information is displayed by many MP3 players.

**Genre**

Choose a genre for the file. This information is displayed by many MP3 players, and can appear in searchable catalogs and databases.

**Track Number**

If you select ID3 tag type v1.1 or v2.3, you can enter a CD track number for the file. This information is displayed by many MP3 players.

**Year**

Enter a year for the file. This information is displayed by many MP3 players.

**Advanced Settings**

The options listed under Advanced Settings, under normal situations, do not need to be changed from their default values.

**Pad To Match Bit Rate Exactly**

This option determines whether MP3 frames are padded to maintain bit rate very precisely. You should only select this option if you need a file with an exact bit rate, for specific applications (such as synchronous transmission over an ISDN line).

⚠️ *Padding of MP3 frames can cause problems with some versions of Internet streaming software. If your files are destined for desktop or Internet delivery, do not select this option.*
Allow Intensity Stereo Coding  This option determines whether the encoder takes into account the frequency of a signal when encoding its phase characteristics, allowing for more compression at low bit rates. In most cases, you should leave this option selected. However, if you are working with highly phase-dependent material, such as Dolby Surround, you may want to deselect this option.

Write CRC Checksums  This option adds error-detection data to the MP3 file. This data is not necessary for most computer and Internet applications, and also takes away from the space available for audio data. Select this option only if you are sure your delivery mode requires error correction.

Copyrighted  This option sets a bit in the MP3 data stream to indicate that the audio is copyrighted. Not all MP3 players use this information. Selecting this option does not guarantee that the audio file will not be copied.

Original  This option sets a bit in the MP3 data stream to indicate that the audio is the original media for the track, rather than a copy. This setting is not widely used.

Private  This option sets a bit in the MP3 data stream that is interpreted differently by various applications. It is not normally used.

Mac File Settings

Mac File Type and Creator  If you expect your file to be used on a Macintosh, you can enter the Macintosh file type and creator. This will allow users to double-click the file to open their MP3 player.

Default Button

To restore all settings in this dialog to their default values, click Defaults.

Format

This is the format for the bounced result. Choices are Mono (summed), Multiple mono, and Interleaved.

To set the bounce file format:

■ Select a file format from the Format selector.

Mono (Summed)  Creates a single disk file that is a summed mono mix of the current sources being monitored.

Before bouncing to disk, make sure your levels are below –3 dB to avoid clipping that occurs when left and right signals exceed –3 dB below maximum, or full code (0 dBFS).

Multiple Mono  Creates multiple mono files with the same number of channels as the source path.

• If the source output or bus path is stereo, two mono files will be created, and appended with “.L” and “.R” suffixes on bounce.

• If a multichannel format is used (for example, six-channel, 5.1), individual mono files will be created for each member of the path. Files will be appended with path suffixes according to the path definition in the I/O Setup dialog.

• If the source output or bus path is mono, the pop-up menu will switch from multiple mono to mono, and will create one mono file (no summing of multiple sources).
Stereo Interleaved Creates a single, interleaved file that contains all of the bounced streams from the chosen output path. In an interleaved stereo bounce, tracks assigned to odd-numbered outputs are sent to the left channel, and tracks assigned to even-numbered outputs are sent to the right channel.

Pro Tools also lets you bounce multichannel interleaved files of any supported file type. This can simplify file management of mixes and projects for backup and archiving.

Pro Tools does not support interleaved files natively. This means that they must be split into multi-mono files on import (requiring additional disk space).

Resolution

This option lets you select between three different bit resolutions for the bounce conversion.

Bounce to Disk does not apply dither when converting during or after a bounce to a lower resolution (including when bouncing to 16-bit). When you need to create a lower resolution bounce file, use a Dither plug-in, or similar, on a Master Fader assigned to the bounce source path. This dithers the bounce file, before the Bounce to Disk conversion truncates bits into the final file resolution. (See “Dither and Bounce to Disk” on page 572.)

Resolution choices include the following:

- **8-bit** This resolution is often used in multimedia applications. If the material you are working with is relatively simple, you can use the Pro Tools “Squeezer” feature for optimal results. See “Sample Rate Conversion Quality Option” on page 581 for details.

- **16-bit** This is the Compact Disc standard bit resolution.

- **24-bit** This setting provides the highest resolution. It is useful when you want to create a final mix without losing any resolution (for example, if you are delivering a final mix that will be ready to master).

If your session is 16-bit, you should still apply Dither, because all Pro Tools sessions process internally at 24-bit.

To set the bounce file resolution:

- Select a bit depth from the Resolution selector.

Sample Rate

This option lets you save to any of several sample rates. Choices are dependent on your Pro Tools system and Digidesign audio interfaces.

Sample Rate Conversion Quality

If you choose a sample rate that differs from the original sample rate of the session, the conversion options become available. You can configure the conversion quality, and schedule conversion to occur during, or after, the bounce. See “Sample Rate Conversion Quality Option” on page 581 for more information.

The following are the more common sample rates, and their applications. Higher sampling rates will provide better audio fidelity for recording and playback, and also for processing with dynamics, dither (with noise shaping), and analog emulation plug-ins.

- **192000** This is a supported sample rate for some audio DVDs, and provides the highest quality audio fidelity with compatible audio interfaces (such as the 192 I/O).
176400 You may want to work at a sample rate of 176.4 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 192 kHz.

96000 This is a supported sample rate for DVD audio and provides high-quality audio fidelity with compatible audio interfaces (such as the 192 I/O, 96 I/O, 96i I/O, and Digi 002).

88200 You may want to work at a sample rate of 88.2 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 96 kHz.

48000 This is a standard sample rate for Professional and DVD video, as well as some broadcast and recording label archiving, and is supported by DA-88/98, DAT, and ADAT decks.

44100 This is the standard sample rate for compact discs (CD), and is supported by DA-88/98, DAT, and ADAT decks.

Custom For a custom sample rate, click in the sample rate window and manually enter in a value.

Pull-Up and Pull-Down Rates All available sample rates support pull-up and pull-down rates, or other specialized rates.

Sample Rate Conversion Quality Option

When you specify a different sample rate for a bounced file (for example, when mixing a session recorded at 96 kHz to 44.1 kHz for release on an audio CD), Pro Tools uses the Conversion Quality option to determine the quality of sample rate conversion used.

There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality of sample rate conversion, the longer it takes to convert the bounced file.

Use Squeezer (8-Bit Resolution Only)

The Use Squeezer option uses a proprietary DSP algorithm specifically designed for performing 8-bit conversion of simple source files such as voice-overs. It optimizes the dynamics of the audio by preprocessing it using compression, limiting, and gating before conversion to 8-bit resolution. This results in greater apparent loudness in the signal, and improved intelligibility. If you are converting a more complex 16-bit audio file to 8-bit resolution, test this option before converting all of your material.

Convert During or After Bounce

The Bounce to Disk dialog can perform any conversion options, including sample rate and bit depth conversion, during a bounce or post-bounce.

The following options are only available when bouncing to a different file type, format, resolution, or sample rate.

Convert During Bounce This option may take less time than Convert After Bounce, but does so at the expense of plug-in automation playback accuracy.

Convert After Bounce The Convert After Bounce option, though it takes more time, offers the highest level of plug-in automation accuracy possible.
Import Into Session After Bounce

The Import After Bounce option automatically imports the newly bounced files into the Region List so you can place them in tracks. If your newly bounced files are split stereo files (Multiple Mono), they are listed together in the Region List.

⚠️ The Import After Bounce option is only available if the target file type and sample rate for the bounce is the same as the file type and sample rate of the current session, and the target resolution (bit rate) is the same or lower than the resolution of the session. In addition, tracks bounced to a Stereo Interleaved file cannot be automatically imported after a bounce.

Help

The Help button opens a display-only dialog that describes the Bounce to Disk features.

Recording a Submix (with Bounce to Disk)

You can create a submix with the Bounce to Disk command by muting tracks or bypassing inserts that are not part of the submix, and selecting the part of the session you want to bounce. Or, you could solo only the audio you want to bounce.

You can also create a submix by recording to new tracks. For details, see “Recording to Tracks” on page 573.

To bounce a submix to disk and bring it into the session:

1 Configure your submix using sends, Auxiliary Inputs, and Master Faders. (See “Submixing for Signal Routing and Effects Processing” on page 499.)

2 Do one of the following:
   • To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   – or –
   • To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.

3 Choose File > Bounce to > Disk.

4 Configure bounce options and settings.

5 Verify the bit resolution for the bounced file matches the bit resolution of the session.

6 Verify the sample rate for the bounced file is supported by the session and the audio interface.

7 If required, verify the file type and format for the bounced file matches the file type and format of the session.

8 Select the Import After Bounce option.

9 Click Bounce.

10 Select a destination for the new audio file, enter a name, and click Save.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process. You cannot adjust controls during a Bounce to Disk.
To bring bounced files back into tracks:

1. Do one of the following:
   - If the newly bounced audio was automatically imported into the session, drag the new files from the Region List to existing tracks in your session.
   - If the bounced files are not available in the Region List, import them into the session by choosing File > Import > Audio to Track, or drag and drop the bounced files from a DigiBase browser.
   - If you are placing multiple files, keep channels time-aligned with each other by Shift-selecting them in the Region List, and dragging them simultaneously into existing tracks of the right format.

2. When working with stereo tracks, set the Pan controls hard left and hard right.

3. Solo the track with the bounce on it.

4. Click Play in the Transport window to hear the results of the bounce.

To bounce a final mix to disk:

1. Adjust track output levels, and finalize any mix automation for each track in the session.

2. Adjust any real-time plug-in and effects settings and their automation for each track in the session.

3. Make sure that all of the tracks you want to include in the bounce are audible (not muted or inactive).

4. Assign the output of each of the tracks you want to include in your bounce to the same output or bus path.

5. Add dither. See “Dither and Bounce to Disk” on page 572.

6. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.

7. Choose File > Bounce to > Disk.

8. Choose the source path you want to bounce.

9. Configure other Bounce to Disk settings as appropriate. See “Bounce Options” on page 575.

10. Click Bounce.

11. Select a destination for the new audio file, enter a name, and click Save.

Final Mixdown

In final mixdown, you create a mix that includes all your edits, automation, and effects processing.
Mastering

In the final mastering process, you might record directly to disk, DAT, DVD, CD, stereo mastering recorder, or a multitrack recorder (for surround mixes).

Once you have created a master of your session, you can transfer it to a portable medium for duplication. You can transfer the master file to CD or DAT to be used as a master for pressing compact discs.

Mastering to a Digital Recorder

Although it is usually best to master sessions directly to hard disk, Pro Tools also lets you master digitally, direct to any AES/EBU-equipped or S/PDIF-equipped digital recorder such as a DAT deck.

24-Bit Input and Output

Pro Tools|HD systems support full 24-bit audio input and output signal paths, with 48-bit internal mixing and processing, providing an additional 16 bits of headroom at the top of a channel’s dynamic range, and 8 bits at the bottom. You can exchange files with other 24-bit recording systems without any bit-depth conversion (as long as they are in a compatible file format).

Pro Tools LE systems support 24-bit input and output, and uses 32-bit floating point mixing and processing internally. You can exchange files with other 24-bit recording systems without any bit-depth conversion (as long as they are in a compatible file format).

Mastering and Audio Compression

Although audio compression is often an indispensable tool in analog recording, it can present problems in the digital domain. If you compress an input signal at a very high ratio, you create a signal that contains a much higher overall power level compared to its transients. By recording a number of such signals at the highest possible level on multiple tracks, you create a scenario that is more likely to clip the mixed output signal.

High-power compressed signals, when mixed together, create an extremely high-level output. This output may rise above the full-code level, resulting in clipping.

To avoid this problem, watch the overall level of your program material—use a meter on a Master Fader, or use an external mastering deck’s meters to help identify clipping. If you are mastering to hard disk, avoid mixing full-code audio signals together at unity or “0” level, as this invariably causes clipping.

Mastering and Error-Correcting Media

Random access media (such as hard disks, optical cartridges, Bernoulli cartridges or WORM drives) can produce a true digital copy of your data, because every bit value is maintained. Sequential media (such as DAT tapes) use error correction schemes to fix the occasional bad data that is received in a digital transfer. These corrections are deviations from the actual data, and with successive reproductions, represent a subtle form of generation loss.

You can avoid this loss by creating and maintaining masters on random-access digital media (such as a hard drive) and transferring them to sequential digital media (such as DAT tapes) only as needed.
To configure Pro Tools for direct digital stereo mastering:

1. Connect your digital recorder to your system’s digital outputs. If your system has multiple digital outputs, use channel 1 and 2 of the audio interface.

2. In Pro Tools, set the appropriate digital format and output from the Hardware Setup dialog or I/O Setup dialog. (See “Configuring Pro Tools Hardware Settings” on page 42.)

3. Set the clock on the master device to slave to Pro Tools digital clock, or to provide master clock to Pro Tools. (See “Configuring Pro Tools Hardware Settings” on page 42.)

4. On your digital recorder, choose the appropriate digital format for the connections.

5. In Pro Tools, set all audio tracks you want to your master outputs 1–2 path.

6. Click Return to Zero in the Transport window to go to the beginning of the session.

7. Press Record on your digital recorder.

8. Start playback of your session.

9. When your session has finished playing, stop the digital recorder.
Part VII: Surround
Pro Tools|HD systems support multichannel mixing for surround sound.

**How to Use These Chapters**

This part of the guide describes multichannel mixing for surround sound with Pro Tools. These sections supplement the basic Pro Tools information provided elsewhere in the *Pro Tools Reference Guide*.

If you are new to surround mixing, read the remaining sections of this chapter for an introduction to surround terminology and concepts.

If you already have experience with surround mixing, mastering, and monitoring, this chapter can be skipped. Operational instructions for Pro Tools surround features begin in Chapter 30, “Pro Tools Setup for Surround (Pro Tools HD Only).”

---

**Mixing Formats and Surround Formats**

When running Pro Tools with the Surround Mixer plug-in, you can mix in 3- to 8-channel formats, in addition to standard mono and stereo.

Supported mixing formats include Mono, Stere, LCR, Quad, LCRS, 5.0, 5.1, 6.0, 6.1, 7.0, and 7.1.

Surround formats include Dolby Surround (Pro Logic), Dolby Digital, DTS, and SDDS. Pro Tools does not provide its own surround format processing, and requires appropriate plug-ins (such as Dolby Surround Tools™) or hardware to provide Dolby surround encoding and decoding.
Pro Tools Mixing Formats

See also “5.1 Track Layouts, Routing, and Metering” on page 604.

Table 30. Multichannel Mixing and Surround Formats

<table>
<thead>
<tr>
<th>Speaker Channels</th>
<th>Multichannel Mixing Format</th>
<th>Surround Format</th>
<th>Channels and Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mono</td>
<td></td>
<td>C</td>
</tr>
<tr>
<td>2</td>
<td>Stereo</td>
<td></td>
<td>L R</td>
</tr>
<tr>
<td>3</td>
<td>LCR</td>
<td>Cinema Stereo</td>
<td>L C R</td>
</tr>
<tr>
<td>4</td>
<td>Quad</td>
<td>Quadraphonic</td>
<td>L R Lr Rr</td>
</tr>
<tr>
<td>4</td>
<td>LCRS</td>
<td>Dolby Surround</td>
<td>L C R S</td>
</tr>
<tr>
<td>(Pro Logic)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>Film (Pro Tools</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td></td>
<td></td>
<td>default), for</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Dolby Digital</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>SMPTE/ITU</td>
<td>L R C LFE Ls Rs</td>
</tr>
<tr>
<td>(Control[24])</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>DTS (ProControl)</td>
<td>L R Ls Rs C LFE</td>
</tr>
<tr>
<td>7</td>
<td>6.1</td>
<td>Dolby Surround</td>
<td>L C R Ls Cs Rs LFE</td>
</tr>
<tr>
<td>EX</td>
<td></td>
<td>EX</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>7.1</td>
<td>SDDS</td>
<td>L Lc C Rc R Ls Rs LFE</td>
</tr>
</tbody>
</table>

Legend: L = Left; R = Right; C = Center; S = surround (mono); Ls = Left Surround; Rs = Right Surround;
Lc = Left Center; Rc = Right Center; Cs = Center Surround; Lr = Left Rear; Rr = Right Rear;
LFE = Low Frequency Effects (handled by a sub-woofer or bass management systems)

Speaker Layouts

Figure 30 on page 591 illustrates the speaker arrangements of each surround format. Speaker placement for each format is approximate. For proper placement, alignment, and calibration of surround monitoring systems, consult the documentation that came with your speakers and other monitoring equipment. Placement of speakers is crucial to accurate monitoring of any mix, but this is especially true with multichannel mixing for surround sound.
Chapter 29: Surround Concepts (Pro Tools HD Only)

Figure 30. Speaker arrangement of surround formats

- Mono
- Stereo
- LCR
- L
- R
- Lcr, Rcr
- Mono Stereo LCR
- 2+2 Quad
- Lcr, Rcr
- Quadrahonic
- Lcr, Rcr
- 3+1 LCRS
- S
- Often split to a pair of surround speakers
- Lcr, Rcr
- 5.1 for DTS, Dolby Digital
- Lcr, Rcr
- Sub
- 6.1 for Dolby Surround EX
- Lcr, Rcr
- Sub
- Lcr, Rcr
- 7.1 for SDDS
- Sub
- Lcr, Rcr

Ls, Rs
Surround Monitoring

In order to monitor your current multichannel mix in a given surround format (such as DTS or Dolby Digital), encoding and decoding equipment for that format is required. Pro Tools does not provide direct support for surround format processing, but encoding/decoding hardware or software is available from Digidesign and third-party manufacturers. Contact Digidesign or your dealer for information.

Proper speaker placement, studio calibration, additional surround processors, monitors, and a properly calibrated system can lessen the variables that your mix will be subjected to when the audience eventually hears it in the theater, in their home, or elsewhere.

The Importance of Speaker Placement

It is very important that your surround monitor system be installed and configured correctly. Proper speaker placement, angling, and level calibration are necessities for surround mixing, so consult the manufacturer of your monitor system. Several surround formats (especially all of those from Dolby as well as DTS) have very specific speaker and monitoring recommendations, so take the time to locate this information and adhere to the suggestions they provide.

For an example of a 5.1 monitor system, see Figure 31.

![Figure 31. Example of speaker arrangement for 5.1 mixing and monitoring (SMPTE specification). Sub placement is variable, while all other speakers should be as close to the suggested angles as possible.](image-url)
Calibrated Surround Monitoring

One of the most important things you can do is to calibrate not only Pro Tools, but also your monitoring system and other equipment.

For example, many post production facilities calibrate their Pro Tools audio interfaces for $-20\,\text{dB} = 0\,\text{VU}$. Once Pro Tools hardware has been calibrated to unity gain, the monitoring system can be adjusted to account for anomalies in the room acoustics, speaker placement, and other variables.

Calibrating your Pro Tools system involves attenuating the input and output stages of your system. Settings and reference level vary according to the applicable standards of the current project.

Instructions for calibrating a Pro Tools 192 I/O audio interface are included with the 192 I/O documentation.

Calibrating Your Studio The first task for surround mixing should be getting your monitor speakers in proper position, alignment and calibration for accurate listening and mixing.

Speaker position and alignment will vary according to each installation, and is very specific for different speakers, manufacturers, and for each surround format. Instructions for optimal speaker location should have been provided with the speaker and monitor system, so consult the documentation provided by its manufacturer.

Proper speaker calibration ensures that your system plays back at accurately balanced levels. This lets you compensate for any variances in speaker position, alignment, or performance.

Formats and Terminology

Some multichannel mixing formats are referred to numerically (such as 5.1 and 7.1). These numbers describe the number and type of output (speaker) channels required for that format. Other formats are referred to by their track layout (such as LCRS and LCR).

Surround formats are referred to by their developer and product name, such as Dolby Surround (or Pro Logic), Dolby Digital, DTS, Dolby Surround EX, and others. Each surround format requires you to mix in a compatible mixing format. For example, both Dolby Digital and DTS are “5.1 surround formats.”

The standards for each format include more than just the number of speakers. Formats also may require specific track layout and filtering for the various channels. For example, the surround channel in Dolby Surround is band limited from 100 Hz to 7 kHz.

Surround formats also increase the importance of phase, balance, and sound placement due to the various ways in which multichannel mixes can be encoded, decoded, compressed, matrixed, or downmixed. Many publications are available on these subjects. For a listing of several sources of surround format information, see “Where to Get More Information on Surround Technology” on page 596.
**LCRS for Dolby Surround**

Dolby Surround (Pro Logic) is a four-channel format that is one of the most widely installed consumer surround formats.

This format, which requires Dolby encoding and decoding technology, provides three full-range front speakers left, center, and right, plus a mono surround channel (often split and monitored through pairs of satellite speakers, but a single “rear” channel nonetheless).

**Surround Format Example**

The goal of Dolby Surround encoding is to make a four-channel mix (LCRS) more portable, by transforming it into an encoded two-channel mix referred to as Lt/Rt. Lt and Rt represent Left Total and Right Total, respectively. Whenever you see Lt/Rt, it refers specifically to material that has been processed by a Dolby Surround Encoder (such as the Dolby SEU4 or Dolby Surround Tools plug-in).

The Lt/Rt mix can then be transported, transmitted, or played as a stereo mix, making it compatible with most home and theater systems. Alternately, the Lt/Rt pair can be decoded back into an LCRS mix in home theater systems where the required decoding hardware is available.

⚠️ For professional results, always use professional-level products (such as the Dolby Model SDU4 Decoder, Model DP564 Decoder, or Dolby Surround Tools plug-in) when mix monitoring. Pro Logic-equipped consumer products have auto-balancing features which, if used for mix monitoring, may contribute to inappropriate mixing decisions.

**5.1 for Dolby Digital and DTS**

Both Dolby Digital and DTS formats are six-channel, 5.1 formats. Both provide five full-range speakers and a sub. These two surround formats use different track layouts, filtering, and compression as part of their specifications.

**.1 Formats**

The “.1” in any multichannel mix format indicates an LFE (Low Frequency Effects) track in the mix. Whenever a decimal is part of a surround format, it indicates a discrete Sub channel in the surround playback system that is intended for playback through a subwoofer speaker. For example, Dolby Digital is a 5.1 format intended for playback through systems with five full-range speakers and one subwoofer speaker. Dolby Surround EX is a 6.1 format, with six full-range speakers and one subwoofer speaker. SDDS is a 7.1 format, with seven full-range speakers and one subwoofer speaker.

Sub content will include the LFE channel of a “.1” format mix, as well as the effects of any bass management in the playback system. See “LFE” on page 595.

**.0 Formats**

The “.0” formats (5.0, 6.0, 7.0), while not associated with any specific surround formats, are useful in many mixes as sub-paths. For example, not all tracks will have content that needs to be routed to the LFE channel (the “.1” channel). Assigning such tracks to a 5.0 path provides a 360° panner without LFE controls.
LFE

When a decimal such as “.1” is present in the name of a surround format, it indicates the presence of an LFE channel. The LFE channel (for Low Frequency Effects, also known as Low Frequency Enhancement) refers most often to a specific track used in production (not during playback or decoding). LFE is the “.1” component in mix formats such as 5.1 and 7.1.

The reason the LFE component is referred to as “.1” is that unlike the other five or seven speakers, LFE is not full bandwidth (or full-range). The LFE signal provides a discrete path for low end to the subwoofer, unaffected by bass management (if any). Low frequency effects include such things as thunder, explosions, and other bass effects.

LFE is generally used to enhance sound effects in films. There are no set rules about whether or not you must employ an LFE channel.

⚠️ Pro Tools applies no filtering to LFE signals. Some delivery requirements may require filtering for the LFE track. See “Mixing Formats and Surround Formats” on page 589 for more information.

Sub Content

When surround mixes are played back on systems that include one or more subs, subwoofer content comes from either or both of the following sources:

- All bass from all channels that is below the threshold of the bass management filter cutoff (if any)
- Audio in the LFE channel (if any)

A surround sub will play back all the lowest-frequency sounds from all of the other speaker channels, below a fixed frequency threshold. The threshold varies among different surround formats. See “Where to Get More Information on Surround Technology” on page 596 for a list of surround specification resources.

In addition to the frequency cutoffs and other specifications of each surround format, playback system variables can affect sub content. See “Surround Playback System Variables” on page 597 for more information.

Divergence

Divergence is a surround mixing control that lets you set panning “width.” Full divergence results in discrete (or narrow) panning. Lower divergence settings result in progressively less discrete (or wider) panning.

With Full (100%) divergence, tracks can be panned exclusively, or discretely, to a single speaker. Sounds panned to a single speaker are only audible in that speaker.

When divergence is less than 100%, tracks will be audible in neighboring speakers even when panned directly to a single speaker in the grid. Lower divergence settings result in a progressively wider source signal.

Divergence Example

To understand divergence, it can be helpful to imagine the inside of a large movie theater. This is a good example because one of the most challenging playback variables one faces in multi-channel mixing is the size of the intended listening environment.
Unlike the typical living room, movie theaters are large spaces with speakers placed widely apart. Due to distance, sounds panned discretely to the front right speaker, for example, might be inaudible in the opposite corner. To avoid this problem, variable divergence lets you control the panning width, in order to widen the sound source. This results in signals spreading into adjacent speakers, even when panned 100% to an individual speaker.

Divergence options in Pro Tools are explained in “Divergence” on page 628.

**Where to Get More Information on Surround Technology**

The table below lists several sites that are good starting points for your research into the constantly evolving world of surround sound production.

**Resources for surround specifications and information**

<table>
<thead>
<tr>
<th>Surround Specifications</th>
<th>Web Site</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dolby Surround/Pro Logic</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>Dolby Digital</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>Dolby Surround EX</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>DTS</td>
<td><a href="http://www.dtsonline.com">www.dtsonline.com</a></td>
</tr>
<tr>
<td>SDDS</td>
<td><a href="http://www.sony.com">www.sony.com</a></td>
</tr>
<tr>
<td>THX</td>
<td><a href="http://www.thx.com">www.thx.com</a></td>
</tr>
</tbody>
</table>

**Surround Mixing Concepts**

As in stereo mixing and mastering, the goal in surround mixing is to provide the best sounding mix to the greatest number of potential listeners. Doing so for surround mixes requires many of the same techniques used for professional stereo production, plus several unique factors that are introduced in the following sections.

**Surround Format Compatibility**

Pro Tools lets you mix in surround and create multichannel masters, consisting of four, six, or more tracks that comprise an LCR, 5.1, or other format mix.

- Whenever necessary, multichannel mixes can be transferred as discrete, unencoded, multi-track masters. Track layout requirements vary by format (see “Importing Multichannel I/O Setups” on page 601 for more information).
- Consumer playback systems do not necessarily support every format. Downmixing occurs when a specific format mix has to be created from another. (A typical example of this is listening to a DVD’s 5.1 Dolby Digital soundtrack downmixed to stereo.)

To anticipate the effects of surround encode and decode, as well as potential downmixing, professional surround mixes are monitored through appropriate encoding and decoding processors. Monitor controller systems let engineers hear their mix through different speakers and configurations for reference, as well as compare factors such as different bass management settings and their effect.
Surround Formats and Delivery Mediums

Surround mixes are tailored for their specific delivery medium. Most often, this requires format-specific encode and decode processing.

Some delivery media on which surround formats are distributed may have additional audio constraints, which could influence your workflow in Pro Tools. Dolby Digital audio on a DVD-Video disc, for example, requires a 48 kHz sampling rate. If your Pro Tools session isn’t at 48 kHz, you must sample rate convert the audio before encoding it with Dolby Digital for DVD.

Encoding and Decoding

Many surround formats utilize some form of encoding and decoding to make it practical to deliver, broadcast, and transfer the multiple channels of full-bandwidth audio they require.

- **Encoding** is the process necessary to make multichannel mixes portable and playable. In many cases, this involves taking the four, five, six, or more discrete channels resulting from a multichannel mix and converting them into a two-channel stream for broadcast (still a predominantly 2-channel medium).

- **Decoding** is the process needed to reproduce (or unfold) the discrete surround channels from a 2-channel delivery medium.

Both encoding and decoding, no matter how refined, represent additional processing stages applied to your mix before it reaches its ultimate destination, the audience.

For example, because the Dolby Surround algorithm depends heavily on phase relationships, there is always a significant difference in a decoded LCRS output as compared to the original LCRS mix. To account for these anomalies, engineers mixing for Dolby Surround listen through hardware encode and decode processors for reference.

Professional mixing and mastering engineers use encoders and decoders to precisely audition the effect of the encoding and decoding process, and make any adjustments necessary.

Surround Processing and Pro Tools

Pro Tools requires additional software or hardware for surround encoding, decoding, and processing. For example, the Dolby Surround Tools™ plug-in lets you monitor and process completely within the Pro Tools environment.

Surround Tools and other surround processing solutions are available from Digidesign and third party manufacturers. Contact your Digidesign Dealer for more information.

Surround Playback System Variables

Different playback systems for surround sound introduce varying amounts and types of filtering, bass management, and other variables. These include the specifications for certain surround formats, as well as options to fine-tune a system for its particular installation.

In your own studio, you know what speakers you are listening to, what their qualities are, and what your control room sounds like. What is impossible to know, however, is what speakers are in the living room, theater, or concert hall where your mix will be heard by an audience.
**Bass Management**

Bass management is a function of the playback system. Bass management refers to a number of processes by which a playback system can control what will be heard through the Sub(woofer) and other channels. The purpose of bass management is to optimize low frequency reproduction and overall frequency response for your specific monitoring system. Bass management provides a way to tune bass response for variables, including room size and shape, the presence (or absence) of a subwoofer, and the frequency range of each speaker.

**Filtering**

In its simplest form, bass management applies high-pass filtering to the full-range speakers. Frequencies below the filter cutoff are summed with the LFE channel (if present) and then routed to the subwoofer. Different systems may offer additional bass management processes, including:

**Bass Redirection** Mutes or unmutes the low-frequency signals filtered out of the full-range channels (all signals that fall below the bass management filter cutoff frequency). This is useful when the full-range speakers are truly full-range, capable of accurately reproducing bass without distorting.

**Bass Extension** Allows the bass (however it is derived) to be routed back through the full-range speakers. Though this may seem like a contradiction, its main purpose is to let sub content emanate from all around, rather than only from the subwoofer.
Chapter 30: Pro Tools Setup for Surround (Pro Tools HD Only)

This chapter explains how to set up and configure Pro Tools sessions for multichannel mixing.

Multichannel mixing is supported on Pro Tools|HD systems only. In this chapter, all references to Pro Tools refer to Pro Tools|HD systems.

Pro Tools Audio Connections for 5.1 Mixing

While all 5.1 mixing formats provide the same speaker arrangement, there are three primary standards in use for the track layout of the individual channels that comprise the 5.1-format multichannel mix.

In the following table, it is assumed that surround channels are mapped to outputs 1–6 of a Pro Tools audio interface. Use channels 7–8 to monitor a stereo mix for a stereo version, or for cue mixes and monitoring.

<table>
<thead>
<tr>
<th>Formats</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>Film (Pro Tools default)</td>
<td>L</td>
</tr>
<tr>
<td>SMPTE/ITU for Dolby Digital (AC3) and Control</td>
<td>24</td>
</tr>
<tr>
<td>DTS with ProControl</td>
<td>L</td>
</tr>
</tbody>
</table>

To connect your audio interfaces for 5.1 format mixing and monitoring:

1. Determine the 5.1 format and track layout you want to use.
2. Connect the output channels of your audio interface to the corresponding input channels of your monitoring system according to the assignments listed in Table 31 on page 599.

If you use a Digidesign control surface, see its guide for more information.
Configuring Pro Tools for Multichannel Sessions

Configuring Pro Tools and sessions for multichannel mixing can be done in any, or all of the ways, as described in this section.

New Sessions

You can create a new session and choose a surround mix I/O Settings file as the default I/O Setup. (See “New Sessions and I/O Settings” on page 600.)

Remixing Sessions in Surround

By creating or importing a surround mix I/O Settings file in the I/O Setup dialog, multichannel paths can be made available in any stereo (or other format) session. You can then reassign track routing from the original stereo paths to multichannel paths. Inactive and active paths simplify reassignment. (See “Importing Multichannel I/O Setups” on page 601.)

Custom Paths

You can customize and redefine existing paths in the I/O Setup dialog. For more information, see “Custom Multichannel Paths” on page 602.

Importing Session Data

By using the Import Session Data command (File > Import > Session Data), you can import tracks and media from other sessions plus their associated paths and track assignments. After importing session data, you can use the I/O Setup dialog to configure main and sub-paths for the requirements of the session. For more information, see Chapter 7, “I/O Setup.”

New Sessions and I/O Settings

When you create a new session, you can specify a surround format that you want to use as your I/O Setup. Default path configurations are provided as I/O Settings files, for stereo and surround mixing.

Once you create the new session, you can create and import tracks, import audio, and assign signal routing to set up your mix.

To create a new session for multichannel mixing:

2. Select one of the available 5.1 settings from the I/O Settings menu.

Configuring a new session for a 5.1 mix

3. If needed, change other parameters in the Session Parameters section.
4. Name the session.
5. Click Save.
The surround presets preconfigure the I/O Setup dialog with default 5.1 format main and sub-paths for outputs and busses.

**Surround Mix Settings Files**

The surround mix I/O Settings files provide output and bus paths for three specific track layout standards. (For information on inputs and insert paths, see “Default Input and Insert Paths with 5.1 Settings” on page 601.)

**Settings Files and Track Layouts**

<table>
<thead>
<tr>
<th>Settings</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools Standard)</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>SMPTE/ITU (Control/24 Monitoring)</td>
<td>L R C LFE Ls Rs</td>
</tr>
<tr>
<td>DTS (ProControl Monitoring)</td>
<td>L R Ls Rs C LFE</td>
</tr>
</tbody>
</table>

All three 5.1 format settings files provide the following default output and bus paths:

**Default 5.1 Output Paths**

- One 5.1 main output path, with sub-paths for center, left/right, LCR, and 5.0 (no LFE).
- One stereo main path with two mono sub-paths.

**Default 5.1 Bus Paths**

- One 5.1 main bus path, with sub-paths for 5.0 (no LFE), left/right (stereo), LCR, and center (mono).
- One stereo main path with two mono sub-paths.

**Default Input and Insert Paths with 5.1 Settings**

The 5.1 Mix settings files provide default stereo main and sub-paths for inputs and inserts. If you need multichannel input paths or inserts, you can create them in the I/O Setup dialog (see “Custom Multichannel Paths” on page 602).

**Importing Multichannel I/O Setups**

The I/O Setup dialog can import and export settings files. Importing I/O Setup settings files is useful when you want to remix a stereo session in surround. You can also use this feature to prepare a session for transfer to a different Pro Tools system, or to simply save and exchange I/O Settings.

To import a multichannel I/O Setup settings file:

1. Choose Setup > I/O.
2. Click Import Settings.
3 Select the settings file to import and click Open.

If the current session has existing path definitions that do not match those in the imported settings file, Pro Tools asks whether you want to delete the existing paths or retain them and add the imported settings to your session.

• Click No to add new paths to your current I/O Setup configuration.

• Click Yes to replace your current I/O Setup configuration with the imported settings.

Exporting I/O Settings
Projects Exporting I/O Setup settings files lets you build a library of multichannel setups for different projects.

To export an I/O Setup settings file:
1 Choose Setup > I/O.
2 Click Export Settings.
3 Name and Save your current I/O Settings.

Custom Multichannel Paths
The I/O Setup dialog lets you create and customize signal paths for any supported multichannel mixing format.

Multichannel paths and sub-paths are mapped to inputs, outputs or internal busses in the Channel Grid. When you select a preset 5.1 I/O Settings file, default layout for the corresponding multichannel format paths you create will match the selected format’s track layout.

In addition, the I/O Setup dialog, like the Main page of the Hardware Setup dialog, provides controls for routing the physical inputs and outputs on your audio interface to available inputs and outputs in Pro Tools.

Example LCRS Setup
The following example shows one possible way to configure the I/O Setup dialog to mix in 4-channel LCRS format, with a 96 I/O.

When creating 5.1 format paths, you can specify the default track layout. See “Default Path Order for 5.1 Tracks” on page 604.

Remapping Channels
The I/O Setup dialog and its Channel Grid also let you remap channels. This is especially useful to route channels within a multichannel path, without having to repatch your audio interfaces.

You can remap paths to any required configuration, limited only by your systems resources, and the I/O Setup dialog requirements for channel overlapping and naming (see “Valid Paths and Requirements” on page 79 for more information).

See also “Example Paths and Signal Routing for a Surround Mix” on page 614.

Example LCRS output main and sub-paths
For additional I/O Setup information, see “Creating and Editing Paths” on page 74.

To define an LCRS path:
1 Choose Setup > I/O, and click the Output tab.
2 Click New Path.
3 Select LCRS from the Path Format selector.

4 Name the path LCR.

5 In the Channel Grid, click in the box below the first (left-most) audio interface channel for the path. Pro Tools automatically fills up the adjacent units to the right. If you click in the LCRS row under channel 1, the LCRS path will be mapped across channels 1–4.

6 Select the new LCRS path and click New Sub-Path.

7 Name the new sub-path LCR and select LCR as the Path format. Click in channel 1 in the LCR row to map the path.

8 Select the LCRS path, click New Sub-Path, and create a stereo sub-path for front Left and front Right.

9 Select the LCRS path, click New Sub-Path, and create a mono sub-path for the Center channel.

10 Select the LCRS path, click New Sub-Path, and create a mono sub-path for the Surround channel.

5.1 Tracks, Formats, Mapping, and Metering

Path definitions in I/O Setup determine how audio is routed through, and metered on, your audio interfaces.

Pro Tools internal (on-screen) metering of 5.1 format paths always follows the Film track layout:

```
L C R Ls Rs LFE
```

Pro Tools track layout of 5.1 format audio tracks in the Edit window also conforms to the Film layout (arranged top to bottom). See the illustration “5.1 Track Layouts, Routing, and Metering” on page 604.

In the I/O Setup dialog, you can route these signals out of your audio interfaces according to any track layout (such as DTS or SMPTE/ITU).

To re-map channels in a path:

- Click and drag a channel to a new valid location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

---

Default I/O Selectors in I/O Setup

The Output tab of the I/O Setup dialog provides the following default settings for multichannel sessions:

- **Default Path Order**
- **Controller Meter Path**

**Default in the I/O Setup dialog**

**Default Path Order** Selects the default track layout (or, path order) for new 5.1 format (six-channel) paths.

**Controller Meter Path** Selects the path that will be shown in Digidesign control surface output meters. See “5.1 Tracks, Formats, Mapping, and Metering” on page 603 for more information.
Audition Paths Selects the monitoring path for previewing audio in the Region List, Import Audio dialogs, and DigiBase. Only outputs on your primary interface can be used as your Audition path.

New Track Default Output Selects the default output path for all new tracks, for each supported track format.

The New Track Default Output can be set to bus paths, as well as output paths.

AFL/PFL Path (Pro Tools HD Only) Selects where tracks are routed to when they are soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode.

AFL/PFL Mutes (Output Path) (Pro Tools HD Only) Selects which output is muted when AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode is enabled, and a track is soloed.

Default Path Order for 5.1 Tracks

You can specify the default track layout for all new 5.1 format paths you create.

To choose a new default Pro Tools 5.1-format path order (track layout):

1. Choose Setup > I/O.
2. Use the Default Path Order menu and sub-menus to choose the track layout you want.

5.1 Track Layouts, Routing, and Metering

<table>
<thead>
<tr>
<th>5.1 Format</th>
<th>Tracks</th>
<th>Track Meters</th>
<th>Channel Map in I/O Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Film</strong> (Pro Tools Standard)</td>
<td>L C R Ls Rs LFE</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>SMPTE/ITU</strong> (ProControl Monitoring)</td>
<td>L R C LFE Ls Rs</td>
<td>same (top to bottom)</td>
<td>L C R Ls Rs LFE (top to bottom)</td>
</tr>
<tr>
<td><strong>DTS</strong> (ProControl Monitoring)</td>
<td>L R Ls Rs C LFE</td>
<td>same (left to right)</td>
<td>L R C LFE Ls Rs</td>
</tr>
</tbody>
</table>

*Figure 32. Track layout of different 5.1 formats*
Surround sessions typically include a combination of mono, stereo, and multichannel audio, Auxiliary Input, Master Fader, and Instrument tracks, and inserts and busses.

Once the appropriate I/O Setup has been imported or configured, audio, Auxiliary Input, Master Fader, and Instrument tracks can be mixed in multichannel for surround using Pro Tools mixing features.

Multichannel I/O and signal routing is determined by the paths defined in the I/O Setup dialog.

Multichannel mixing is supported on Pro Tools|HD systems only. In this chapter, all references to Pro Tools refer to Pro Tools|HD systems.

### Multichannel Quick Start

The following is an overview of how to get started mixing in multichannel for surround in Pro Tools.

**To mix in multichannel:**

1. Open any stereo Pro Tools session to remix it in surround. (You can also create new, empty surround sessions. See “New Sessions and I/O Settings” on page 600.)

2. Configure the I/O Setup dialog with multichannel inputs, outputs, busses, and inserts, as needed. (See “Configuring Pro Tools for Multichannel Sessions” on page 600.)
Do one of the following:

- Create new tracks, and assign track outputs and sends to your multichannel paths. Configure signal routing as needed for sub-mixing, bussing, processing, and monitoring. For tracks that do not need to be panned in 360°, place them in the mix using sub-paths and signal routing. (See “Multichannel Signal Routing” on page 609.)
- Use the Import Tracks command to import multichannel tracks.
- Use the Import Session Data command to import existing 5.1 tracks, busses, and other data. (See “Importing Tracks and Track Attributes” on page 124.)

Pan in surround using the multichannel Track Output and Send windows. (For information on mixing and panning for surround, see Chapter 32, “Surround Panning and Mixing (Pro Tools HD Only).”)

Multichannel audio tracks can be:

- Recorded directly into Pro Tools, using multiple microphones or microphone arrays, or routed to appropriate multichannel Pro Tools Input paths
- Imported from other Pro Tools sessions
- Edited, processed, and mixed in combination with mono and stereo tracks

Multichannel audio tracks contain an individual channel for each signal in the track (for example, a 5.1 track would have six channels for left, center, right, left surround, right surround, and LFE).

Multichannel audio tracks are not required to mix in multichannel formats. Mono, stereo, and all supported track formats can be mixed using Pro Tools track outputs and sends. See “Multichannel Signal Routing” on page 609.
Placing Audio in Multichannel Tracks

You can drag audio files and regions from DigiBase browsers, the Region List, Windows Explorer or Macintosh Finder, or from other tracks, to place them in multichannel audio tracks.

To do so, the number of channels being dragged must match the destination track format. For example, you can only drag a stereo pair or two mono regions onto a stereo audio track. Similarly, you can only place audio into an LCR track when you have selected three regions. With 5.1 tracks, you must select six mono files or regions.

⚠️ When dragged into a multichannel track, audio files are placed from top to bottom in the exact order that they appear in the Region List or playlist from which they came. For this reason, you may want to rename audio files before dragging them, so that they are in a preferred order. Rename them so that sorting them by Region Name in the Region List results in the preferred order. (For example, with a 5.1-format track, you can rename the audio tracks, so that the arrangement of the tracks corresponds to L, C, R, Ls, Rs, and LFE.)

Solo, Mute, and Gain in Multichannel Tracks and Paths

Stereo and multichannel tracks consist of multiple audio signals, linked together. By default, multichannel tracks are linked and are controlled by a single channel fader, and solo and mute switches.

For discrete control of signals, multichannel tracks can be converted into individual mono tracks. For discrete level and phase adjustment, you can insert and unlink a multi-mono Trim plug-in. Both of these techniques are explained below.

⚠️ Once converted to mono, multichannel tracks cannot be relinked into their original multichannel format. However, a multichannel track can be reassembled by dragging the corresponding number of mono files into a multichannel track, although some automation data may be lost. As an alternative, record the submix of the mono tracks to disk on a multichannel track.

To convert a multichannel track into discrete mono tracks:

1. Select the multichannel track.
2. Choose Track > Split into Mono.

To have discrete control of gain on individual channels of a multichannel track:

1. Insert a multi-mono Trim plug-in on the multichannel track.
2. Unlink the Trim plug-in by clicking the Link icon so that it is unlit.
3. Use the Channel selector to display the controls for a channel, and adjust the gain.

See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 611 for more information.
Track and Output Formats

When you create new tracks, you specify mono, stereo, or a supported multichannel format for the new tracks.

In the Mix and Edit windows, the track format of a track’s output is always visible by the number of track meters contained in its fader strip (for example, a single meter for mono tracks, a pair of meters for stereo tracks, and six meters for 5.1 tracks).

Assigning track output determines the format of that output. For example, a mono track always has a single track meter, even when assigned to a stereo output path. If that same mono track is assigned to a 5.1 output path, it’s output will be split among those six output channels, depending on the position of its panner.

Changing Format

Changing the output format for a given track has several effects:

- The panner that appears in the track will change to reflect the new output format.
- It may be necessary for one or more pan related automation playlists to be created or deleted.

Because changing the output format has these effects, a warning dialog appears whenever you change the output format of a track to a format of fewer channels. Specifically, this will occur whenever automation playlists will have to be deleted.

Multiple Output Assignments and Track Format

When a track is assigned to more than one path of differing formats, the main output for that track will match the format of the assigned path with the greatest number of channels.

Multiple Outputs and Automation Playlists

When a track has multiple output assignments, Pro Tools sorts panning data appropriately for each assigned path. For example, if you assign a mono track to a stereo path and a 5.1 path simultaneously, that track will have a 5.1 panner in the Mix or Edit window. When you pan the track, Pro Tools interprets the 5.1 panning moves into stereo panning moves.

This provides a type of parallel mixing. You can create a variety of mixes of differing formats all at the same time by routing your elements to multiple paths.

Control-Start-click (Windows) or Command-Control-click (Macintosh) any control in an Output window to show its automation playlist in the Edit window and view any pan automation.
**Multichannel Signal Routing**

To mix in a multichannel format, tracks are assigned to multichannel paths.

Tracks can be mixed in surround using the following two methods:

- By setting a track main output to a multichannel path.
- By assigning a multichannel send to route audio to a multichannel path.

See “Multichannel Sends” on page 609 for more information.

**Multichannel Track Outputs**

Tracks can be routed to multichannel output or bus paths using the track’s Output Path selector. This provides a multichannel panner and meter in the Mix and Edit window I/O View.

Additional output assignments can be added by Start-clicking (Windows) or Control-clicking (Macintosh) the Selector tool and assigning another path.

**Multichannel Sends**

All track formats, including mono and stereo, let you assign one or more multichannel sends. This provides a multichannel panner in the Sends View. Sends are also useful to bus tracks for multichannel plug-in processing.

Figure 33 shows a mono audio track with a 5.1 (6-channel) send (Sends View Shows > Send A View).
Pro Tools bussing and submixing features are available for all channel formats, from mono/stereo through 8-channel. For examples of multichannel monitoring, effects processing, and bussing, see “Mixing with Paths and Sub-Paths” on page 612. For mono and stereo mix examples, see Chapter 25, “Basic Mixing.”

Multichannel Auxiliary Inputs and Master Faders

A multichannel Auxiliary Input or Master Fader is used as a return for the multichannel bus. Sends are useful when you need to create an additional, independent mix simultaneously (perhaps of a distinct format), requiring dedicated fader, mute, solo, and automation controls.

You can assign Master Faders to main and sub-paths. Main paths must match the format of the Master Fader, and only one Master Fader can be active and assigned to any single (active) main or sub-path. A Master Fader cannot be assigned to a sub-path if its associated main path is already assigned on another Master Fader. See “Master Fader Tracks” on page 480.

Multichannel Instrument Tracks

Multichannel tracks can be used to monitor and route multichannel instrument plug-ins or multichannel external MIDI instruments.

Mono, Multi-Mono and Multichannel Plug-Ins

Plug-ins can be used in mono, multi-mono, or multichannel formats.

Plug-in formats

For information about mono, stereo, and mono-in/stereo-out plug-ins, see Chapter 26, “Plug-In and Hardware Inserts.”
Multi-Mono Plug-Ins are designed for use on stereo or greater-than-stereo multichannel tracks. Multi-mono plug-ins are useful, or required, in the following situations:

- When a plug-in does not involve multichannel correlated processing (for example, when applying EQ to select sides of a multichannel signal)
- When you need to adjust signals within the multichannel track independently
- When a plug-in does not support multichannel formats

When a multi-mono plug-in is first inserted on a multichannel track, the plug-in controls are linked. You can unlink them for independent adjustment. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 611 for more information.

Multi-mono plug-ins can also be inserted on stereo tracks, to apply unlinked plug-ins on the left and right channels.

Multichannel Plug-Ins are designed for use on stereo and multichannel tracks that require correlated processing, including stereo and multichannel limiting, compression, and similar effects.

Linking and Unlinking Controls on Multi-Mono Plug-Ins

When a multi-mono plug-in is used on a multichannel track of more than two channels, the controls are normally linked. Adjusting the Gain control on one channel, for example, will adjust it for all channels.

If necessary, you can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

For example, to apply equal filter cutoffs to the Ls and Rs (surround) channels in a 5.1 mix, you could link enable just those channels in an unlinked, multi-mono EQ plug-in. Adjusting the controls in the plug-in window for either channel (Ls or Rs) adjusts the other, linked channel as well.

Channel selector and Link controls

Channel Selector accesses a specific channel within a multichannel track for plug-in parameter editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than two channels.

Master Link Button When enabled, links the controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

Link Enable Buttons Let you selectively link the controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons.

To unlink controls on a multi-mono plug-in:
- Deselect the Master Link button. It is lit when linked, unlit when unlinked.

To access controls for a specific channel:
- Select the channel from the Channel selector.

To open a plug-in window for all channels of a multi-mono plug-in:
- Alt-click (Windows) or Option-click (Macintosh) the Channel selector.
To link the controls of specific channels:

1. Deselect the Master Link button if it is not already deselected.

2. Click the Link Enable buttons for the channels whose controls you want to link.

Paths in Surround Mixes

Because Pro Tools provides a flexible routing and submixing environment, you can maximize your system’s available resources by first identifying the elements that you want to pan dynamically and those that can be placed in certain channels only (see “Mixing with Paths and Sub-Paths” on page 612).

Once you have identified these elements in your session, you can use a combination of main and sub-path assignments, and multichannel panning.

Mixing with Paths and Sub-Paths

It is rare that every track needs to be “flown” (actively panned in between more than a pair of speakers). In most situations, certain elements are placed in certain speakers and remain there, providing the foundation for a mix.

Figure 34 on page 613 illustrates an example of how panning and signal routing can be combined in a multichannel mix. The following sections describe how to organize your session and signal routing to maximize the available resources.

When to Assign Multichannel Outputs

- Assign 5.1 paths only to those tracks that need to be panned to all six channels.

For example, a sound effects track with a jet flyover should be assigned a 5.1 path to be able to fly the sound from front-to-back. In a music mix, you can fly a solo instrument or make a synth pad swirl around the room as a special effect.

Elements that need to be heard in all speakers simultaneously can also be assigned to the multichannel output, whether or not they need active panning in the sound field.

When to Use Sub-Paths

- To help simplify large sessions, use sub-paths to route static (or, stationary) elements directly to the output channel or channels.

For example, film dialog is often mixed to the center channel to anchor this essential sound element to the picture. Instead of assigning a six-channel panner to dialog tracks and panning the tracks to the center speaker only, you can route the dialog track’s main output to a mono (Center) sub-path.

For information on the Trim plug-in, see the DigiRack Plug-Ins Guide.

See “Extending Stereo Mixing Conventions to Surround Mixing” on page 613 for related information.
Chapter 31: Multichannel Tracks and Signal Routing (Pro Tools HD Only)

Extending Stereo Mixing Conventions to Surround Mixing

Stereo mixing sets the precedent for active and static panning, and surround mixing can benefit from the same basic principles.

Panning a sound back-and-forth between the left and right speakers is best used as a special effect. In a typical music mix, the basic tracks are placed in the stereo sound field and remain there.

Surround mixes can become incoherent if too many elements are continuously moving. For special effects, some tracks can be panned dynamically, bouncing between speakers or sweeping from one side to the other.

Figure 34. Using signal routing and sub-paths to mix in surround
Example Paths and Signal Routing for a Surround Mix

The examples that follow show how Auxiliary Inputs, Master Faders, and other Pro Tools signal routing features can be used for stem mixes, submixes, and similar project needs.

In these examples, music and effects are being mixed for a trailer, in 5.1 surround. Separate stem mixes (for music and for effects) are to be mastered to 8-track MDM.

Example Multichannel Paths

Signal routing is the key element in any Pro Tools surround session. Signal routing is configured and defined in the I/O Setup dialog.

Example Output Paths

Figure 35 shows output paths defined in the I/O Setup dialog of an example session that was created on a Pro Tools|HD system with one 192 I/O audio interface.

Sub-paths have been defined for Mix, Music, and FX main output paths.

Additional stereo output paths, with mono sub-paths, have also been defined for the remaining channels.

Example Bus Paths

Figure 36 shows example bus paths.

Two 5.1 format main paths have been defined ("Music" and "FX"), each with several sub-paths.

Example Sub-Paths

Sub-paths let you route to selective channels within the multichannel surround output. In Figure 37, the Mix 5.1 bus has several sub-paths that show this.

5.0 Sub-Path

The 5.0 FX bus is a 5-channel sub-path. Use this type of sub-path routing to conserve mixing resources with tracks you want to keep out of the LFE channel.

LFE Path

A custom LFE sub-path has been added to provide a discrete mono path for the LFE channel.
**Signal Routing Examples**

The following examples show how main and sub-paths can be used, using an example session consisting of a 5.1 main mix, with music and effects stems (or submixes).

**Submix Stem Examples**

Figure 38 shows a routing configuration for an effects submix.

Some tracks are routed to stereo sub-paths, while others are assigned to mono, LCR, or other sub-paths. Two tracks (one stereo, one mono) are assigned to multichannel busses for surround panning. A 5.1 Auxiliary Input assigned to the FX main bus path serves as a submixer.
Figure 39 shows a routing configuration for music tracks.

Most of the music tracks in this example are routed to the front left/right channels, using a stereo sub-path. A 5.1 Auxiliary Input controls the bus and stem output.

**Main Stems Example**

Figure 40 shows two Auxiliary Input channels assigned to additional 5.1 format paths for a main mix.
Multiple output assignments make it possible to configure a number of multi-format mixes. For example, you can assign an additional stereo output to tracks and create a stereo mix at the same time as a 5.1 mix. For more information, see “Multiple Output Assignments” on page 487.

**LFE Examples**

LFE tracks and other audio can contribute to the LFE output in two ways:

- Using the LFE slider in Output windows. This LFE signal is post-fader.
  - or –
- Using a custom sub-path to route channels discretely.

Figure 41 shows a channel Output window, sending and metering to the LFE channel.

Using the LFE fader, you can add any amount of any multichannel path to the overall LFE output. In the above example, the track’s Center percentage has been turned off, and the LFE fader has been raised to route it to the LFE channel.

Figure 42 shows how a “traditional” LFE track can be routed to only the LFE channel. This example uses a custom-defined LFE sub-path to the FX main bus path.

LFE faders can follow Mix and Edit Groups. See “Automation Preferences” on page 540 for more information.

For instructions on how to create a sub-path, see “Custom Multichannel Paths” on page 602.

**LFE and Filtering**

Pro Tools applies no filtering to LFE signals. Some delivery requirements may require filtering for the LFE track. See “Mixing Formats and Surround Formats” on page 589 for more information.
This chapter explains how to pan and mix in surround with Pro Tools.

Multichannel mixing is supported on Pro Tools|HD systems only. In this chapter, all references to Pro Tools refer to Pro Tools|HD systems.

Before you can pan a track in surround, it must be assigned to an appropriate multichannel output or bus path.

The I/O Setup dialog defines the bussing and output architecture of the Pro Tools multichannel surround mixer. If you have not already done so, it is recommended that you become familiar with main and sub-paths and the I/O Setup dialog before starting multichannel Pro Tools projects.

See Chapter 30, “Pro Tools Setup for Surround (Pro Tools HD Only)” for more information on multichannel configurations and I/O Setup options. For multichannel signal routing, see Chapter 31, “Multichannel Tracks and Signal Routing (Pro Tools HD Only).”

Introduction to Pro Tools Surround Panning

There are four different track panning methods available:

- In the Edit window, using the reduced-height Panner Grid in the I/O View
- In the Mix window, using the reduced-height Panner Grid
- In the Output window, using the full-size Panner Grid
- Through pan automation editing

Control surfaces provide additional panning options. Refer to the documentation for your control surface for more information.
Mix and Edit Window Panner Grids

In the Mix and Edit window, multichannel Panner Grids are displayed on tracks that have multichannel track or send output assignments.

To pan from the Mix or Edit window:

1. To pan in the Edit window, make sure I/O View is being shown (View > Edit Window > I/O). Panner Grids are always displayed in Mix window tracks that support panning.

2. Begin playback.

3. Click and drag on the appropriate multichannel track’s Panner Grid in the Mix or Edit windows.

Pan Location Cursor Color while Automating

The Pan Location cursor is green when the track is in Automation Read mode, red in an Automation Write mode, and yellow in Automation Off (or Automation Suspend) mode.

In Trim mode, the Volume fader and LFE fader are yellow.

Output windows provide additional features and controls (and a much larger Grid). For details, see “Output Window” on page 620.

Output Window

Output windows provide panning controls (called panners), as well as standard Pro Tools controls, for tracks of all mix formats (from 3-channel LCR through 8-channel 7.1).

For information on Output window standard controls, see “Standard Controls” on page 621. For information on Output window panning controls, see “Surround Panner Controls” on page 622.

Some of the features of Output windows include:

- X/Y (joystick-style) panning
- 3-Knob panning
- Full Divergence and Center Percentage control
- LFE feed
- Multichannel meters
- Pro Tools target window support

Multiple panners can be opened simultaneously, or a single window can display the current panner.

The Pan Location cursor follows your movements as long as you hold down the mouse button. Movements are scaled so that, once you click to “grab” the Pan Location cursor, you do not need to limit your movements to the small Track Grid area.
To open an Output window:

- Click the Output Window button in the track in the Mix or Edit window (I/O View).

Opening a multichannel Output window

For instructions on managing multiple Output windows, see “Output Windows for Tracks and Sends” on page 494.

Standard Controls

All Output windows provide standard Pro Tools controls for routing, path assignment and other track features. These controls are located at the top of all Output, Send, Insert, and Plug-In windows. Some controls are specific to the type of window.

Opening a multichannel Output window

For details on these standard features, see “Standard Selector Controls in Output Windows” on page 496.

Track Fader, Solo, Mute, and Auto

All Output windows provide track volume and mute controls. You can adjust and automate track volume, or mute, directly using these controls. The larger fader and Mute button are equivalent to those in the Pro Tools Mix window.
Surround Panner Controls

When assigned to tracks or paths with four or more channels, the Output window provides an X/Y Grid for surround panning. The speakers associated with the panner’s multichannel format are displayed in their relative positions outside the Panner Grid. These speakers are also used as Snap Pan to Speaker controls.

This section identifies all the controls and features found in Pro Tools multichannel panners.

Figure 43. Output window with a 5.1-format multichannel panner
The X/Y Grid and Pan Location Cursor

The X/Y Grid is where multichannel panning information is input and displayed. You can input pan information using X/Y mode, 3-Knob mode, or by entering numeric values in the Position data fields. You can also edit pan automation graphically in the Edit window.

Multichannel panners default to X/Y mode. In X/Y mode, the track’s current pan position is represented by a green dot. This dot is the Pan Location cursor, and its color indicates track automation status using standard Pro Tools colors:

**Green** The track is in automation Read mode.

**Red** The track is in automation Write, Touch or Latch mode.

**Yellow** The track is in automation Off mode (or Automation Suspend) mode.

Panning Mode Button

This button, located below the X/Y Grid, provides access to Surround panning modes. See “Panning Modes” on page 624.

Position Controls

The Position controls let you set the positions of the panner.

**Front** Displays and controls the current front X-axis (left/right) position of the panner.

**Rear** Displays and controls the current rear X-axis (left/right) position of the panner. In default X/Y Panning mode, Rear is linked to Front position and cannot be controlled independently.

**F/R (Front/Rear)** Displays and controls the current Y-axis position of the panner.

Center % Control

Center % controls how much of the signal is routed to the center speaker. This lets you mix a track to the front with a phantom center (0% Center value) or to three-channel (LCR) when panning front.

Divergence Controls

Divergence determines the width of the panned signal with respect to neighboring speakers. (For more information, see “Divergence” on page 595.) There are three Divergence controls...
Front, Rear, and F/R Divergence  Provide separate, automatable divergence control over front speakers, rear speakers, and between front/rear, respectively.

For examples of how divergence settings affect output panning, see “Divergence and Center Percentage” on page 627.

Snap Pan to Speaker Icons
The Snap Pan to Speaker icons let you force the panner to the speaker’s location. For example, clicking on the upper left speaker moves the Pan Location cursor to the upper left corner of the X/Y Grid.

LFE Fader
The LFE fader is only available in “.1” surround formats (5.1, 6.1, and 7.1).

The LFE fader determines how much of the current track’s signal will be routed to the LFE channel. LFE faders in Track and Send windows can follow groups. The Pro Tools LFE channel is always full-bandwidth. For more information on how to use the LFE fader, see “LFE Faders in Multichannel Panners” on page 629.

Panning Modes

The Panning Mode button provides access to four panning modes: X/Y mode, Divergence Editing, 3-Knob mode, and AutoGlide mode.
To enable a Panning Mode:
■ Click on the Panning Mode button in the Surround Panner until the desired mode icon is displayed.

X/Y Panning

To pan in X/Y mode:
1. Click on the Panning Mode button until the X/Y mode icon is displayed.

2. Drag the Pan Location cursor, or click anywhere in the Grid and drag to pan the track. The location of the Pan Location cursor determines the pan position of the signal. For example, to pan something to the left rear speaker, move the Pan Location cursor to the lower-left corner of the Grid.

It is not necessary to click exactly on the Pan Location cursor. Clicking anywhere in the Grid will move the Pan Location cursor relative to where you click or take over with a hardware panner. Panning does not jump to the click position.

To snap the Pan Location cursor to a location in the Grid:
■ Hold down the Control key and click anywhere in the X/Y Grid.

Grid Options and Shortcuts

Fine-Adjust Mode Hold down the Control key (Windows) or Command key (Macintosh) for fine adjustment of all Panner controls.

Constraining to X or Y Movement Shift-drag the Pan Location cursor to constrain its movement to the X or Y direction.

Reset to Default Alt-click (Windows) or Option-click (Macintosh) in the Panner Grid to reset all controls to their default position.

Snap Pan to Speaker Click one of the Snap Pan to Speaker icons to force the panner to that speaker location.

Display Automation in Edit Window Control-Start-click (Windows) or Command-Control-click (Macintosh) a control to display that control’s playlist in the Edit window.

All Pan controls can be automated, including pan position and divergence. See Chapter 27, “Automation” for details.

3-Knob Panning

Pro Tools provides 3-Knob mode as an additional way to input pan moves.

3-Knob mode lets you:
• Pan in straight lines, moving the Pan Location cursor using the Position rotary knobs with full movement of front, rear, and front-rear position.
  – and –
• Pan discretely between pairs of speakers.
3-Knob mode lets you pan discretely between speakers. For example, when panning front-left to rear-right in 3-Knob mode, audio will be heard from just those two speakers (assuming full divergence is in effect).

By comparison, in X/Y mode a diagonal pan may result in audio being heard in some or all channels.

**To enable 3-Knob Panning mode:**
- Click on the Panning Mode button until the 3-Knob mode icon is displayed.

**Panner Mode button set to 3-Knob mode**

The panner trajectory line appears across the Grid, extending from the front (X-axis) to the rear (Y-axis).

**To pan in 3-Knob mode:**
1. Adjust the Front and Rear Position knobs to set the trajectory line.
2. Rotate the Front/Rear Position knob to pan along the trajectory. The Pan Location cursor is constrained to the white trajectory line.

**To change the 3-Knob trajectory angles:**
- Drag either endpoint (Front or Rear) of the trajectory line.
  - or –
- Adjust the Front or Rear Position controls.

**To change the current trajectory position (left-to-right) and retain its current angles:**
- Drag the trajectory line (not its endpoints) to a new position.

**AutoGlide Mode**

AutoGlide mode lets you quickly write Surround Panner automation by clicking new locations in the Surround Panner window, instead of manually moving the Surround Panner controls.

**When writing automation in AutoGlide mode, the Pan Location cursor cannot be dragged from its location.**
The time it takes to glide from point to point (from the Pan Location cursor to the new destination) is called the AutoGlide Time. This time is set in the Automation Preferences page and has a range of 1 msec to 10000 msec (10 seconds).

**To set the AutoGlide Time**

1. Choose Setup > Preferences and click the Automation tab.
2. Set the AutoGlide Time.

**To do an AutoGlide automation pass:**

1. Click the Panning Mode button until the AutoGlide mode icon is displayed.
2. In the Mix or Edit window, click the Automation Mode selector and select an Automation mode for the track you want to automate.
3. Press Play to begin playback.
4. Set a new destination for the cursor by doing one of the following:
   - Click a Snap Pan to Speaker icon to glide to its speaker location.
   - or —
   - Click in the pan window to glide to a specific location in the X/Y Grid.
5. Repeat the previous step if you want to write additional panning moves.
6. Stop the transport when finished.

---

**Divergence and Center Percentage**

The Divergence and Center Percentage controls range from 0 to 100, and can be automated. They are especially useful for ensuring audibility and coverage in large venues, and to increase clarity of voices.

- **Front Divergence** Controls divergence between front speakers (X-axis only).
- **Rear Divergence** Controls divergence between the rear speakers (X-axis only).
- **Front/Rear Divergence** Controls divergence between front and rear (the Y-axis).
**Center % (Percentage)** Determines whether there is a *discrete* center image, a completely *phantom* center image, or a variable amount in between.

**Divergence**

In the Panner Grid, the current divergence values are displayed using a purple outline.

Lower divergence settings result in a progressively wider source signal. When Divergence is less than 100%, tracks will be routed to neighboring speakers to some degree, even when the Pan Location cursor is positioned next to a single speaker.

By default, Pro Tools surround panners are 100% or fully divergent, meaning that a signal that is panned completely to one speaker will only be audible in that speaker.

---

**Center % (Percentage)**

Center Percentage controls whether there is a discrete center channel for the track or a phantom center channel.
Center Percentage Example

In film and video production, the center channel often contains dialog. To enhance the clarity of dialog, it is often beneficial to keep elements such as music out of the center speaker. By reducing the Center Percentage on music tracks, music panned to the front of the soundfield can be panned to only the left and right speakers, forcing them to have a variable phantom center image.

To adjust Center Percentage:
- Adjust the Center Percentage knob as appropriate.

As you reduce the Center Percentage value, the center speaker at the top of the Grid becomes less visible. At 0, the center speaker is completely invisible, reflecting the setting for fully phantom center.

LFE Faders in Multichannel Panners

The LFE fader controls how much of the track is sent to LFE. LFE faders are only available when a track is assigned to a path whose format supports LFE (5.1, 6.1, or 7.1).

To mix to the LFE channel:
- Adjust the LFE fader in any “.1” surround format Output window.

![LFE Faders in Multichannel Panners](image)

LFEs Follow Groups preference

LFE and Groups

Track and send LFE faders can follow Mix and Edit Groups by enabling this feature in the Automation Preferences page. See “Automation Preferences” on page 540 for more information.

![LFEs Follow Groups preference](image)
LFE Enable

Some multichannel plug-ins, including the DigiRack multichannel Compressor, provide LFE Enable. This lets you enable or bypass processing of the LFE channel if present.

To process the LFE channel in a multichannel plug-in:

- Click to enable LFE Enable in supporting multichannel plug-ins. LFE Enable is highlighted when LFE processing is enabled, and unhighlighted when LFE processing is bypassed.

⚠️ When LFE Enable is unavailable, try using the multi-mono version of the plug-in.

SurroundScope Metering Plug-In

The SurroundScope Metering plug-in provides a 360° meter for metering multichannel paths during mixing.

5.1 Format Track Layouts

All 5.1-format meters (including those displayed in the SurroundScope meter, on tracks, and in Output windows and their Path Meter Views) are always arranged in the following order:

L C R Ls Rs LFE

For more information on Pro Tools metering, see “5.1 Tracks, Formats, Mapping, and Metering” on page 603.

To use the SurroundScope Metering Plug-In:

- On a multichannel Master Fader, click an Insert button and select the SurroundScope multi-channel Meter plug-in.

SurroundScope has no adjustable controls, but displays output levels in both a 360° Grid, and in traditional LED meters.

Refer to the Digidesign Plug-Ins Guide, for details on SurroundScope.
Part VIII: Synchronization
Chapter 33: Synchronization Concepts

This section is designed to give you a basic understanding of synchronization as it relates to Pro Tools.

If you are using a device that sends or receives time code (such as a video tape recorder or MIDI interface), refer that device’s documentation for information on how it generates or receives time code and how to configure its options.

Synchronization Requirements

Synchronization requirements and support vary among different Pro Tools hardware systems. This guide notes whenever a feature requires a synchronization peripheral (such as a Digidesign SYNC I/O, or equivalent). See the guides for these peripherals for details on their installation and configuration.

We strongly recommend that you research your synchronization requirements thoroughly. For example, if you are using Pro Tools for audio post production work for video, consult your video engineer or editor to determine what time code format will be used. Also, there may be additional time code issues that affect how you use synchronization (such as pull-down). Your Digidesign dealer may be able to offer suggestions about working with synchronization in your studio.

Synchronization Peripherals

Synchronization peripherals include a wide variety of devices, ranging from simple MTC-capable MIDI interfaces, to high precision time code synchronizers capable of handling many professional time code and clock standards used in the music, television, and film industries.

Though many devices are capable of providing synchronization, only the Digidesign SYNC I/O and USD peripherals deliver frame-edge accuracy when synchronizing Pro Tools|HD systems to external time code sources.

Aspects of Synchronization

Synchronization in a digital audio workstation has two concepts that need to be independently considered:

- “Where are we?” This is called the Positional Reference.
- “How fast are we going?” This is called the Clock Reference.

To synchronize Pro Tools to another device (such as a tape machine or VTR) accurately over an extended period of time, Pro Tools needs to know where the device is and at what speed it is running. Some peripherals can provide only one
of these references; for example, a black burst generator provides only a clock reference. Some peripherals, such as the Digidesign SYNC I/O, can provide both.

**Synchronizing Pro Tools**

Pro Tools|HD systems require a clock reference, in addition to time code, to maintain correct synchronization once it has been achieved. In addition, transfers (recording) between digital devices must be performed to a resolved clock source.

You can resolve Pro Tools to an external clock reference without locking it to a positional reference. For example, you can use any Pro Tools|HD audio interface to resolve the Pro Tools sample clock to an incoming digital signal (S/PDIF, or Word Clock, for example) without synchronizing Pro Tools to external time code.

In the following example, Pro Tools uses time code for positional information, and a clock reference to maintain synchronization. Pro Tools is slaved, using the SYNC I/O or USD, to a video tape recorder, with Pro Tools and the VTR referenced to the same house video reference source (house sync).

**Example: Pro Tools slaved, through a SYNC I/O or USD, to a video tape recorder**

In this example, house sync is provided to the SYNC I/O, which provides the master Loop Sync signal to the Pro Tools|HD system through a Pro Tools|HD audio interface. House sync is also provided to the VTR.

1. When you start the video tape, time code (LTC or VITC) is read from the tape and routed to the SYNC I/O or USD. The SYNC I/O (or USD) reads the time code position and continuously forwards the positional reference information down the SYNC I/O serial connection to the Pro Tools card.

2. Pro Tools takes the first time code address it receives, and calculates the sample location in the session that corresponds to the address. Though you can work with Pro Tools using any standard time code format, it calculates internally in sample numbers.

3. Assuming that the time code address corresponds to a sample number that is within the Pro Tools session, Pro Tools converts the time code address to a sample number within the session, and begins playing from that point. The point from which playback starts is the trigger point. The clock reference is used by Pro Tools and the VTR to keep them running at the same speed.

4. At this point, if the video tape is stopped, rewound, and started again, the process repeats, based upon a newly calculated trigger point.

**About Positional References**

Time code is positional information in an analog signal or a digital streaming signal that can be recorded on magnetic video or audio tape. Time code can be used as a positional reference, to synchronize the playback and recording of your Pro Tools system with another machine’s time code signal, such as an analog multitrack tape machine or a video tape recorder (VTR).
SMPTE and ISO/EBU Time Code

The “Where are we?” question refers to relative position. To describe position, many professional audio, video, and multimedia devices and programs use SMPTE (Society of Motion Picture & Television Engineers) time code. In Europe, a standard called ISO (International Standards Organization) time code, formerly called EBU (European Broadcasters Union) time code, is generally used. These time code types are almost exactly the same in terms of how they are represented electronically. However, ISO/EBU time code works at a fixed rate of 25 fps (frames per second) and SMPTE includes provisions for several different frame rates. For the purposes of explanation, this chapter will generally refer to frame-measured timing information as “SMPTE time code.” This description should be understood to include SMPTE and ISO/EBU time code.

SMPTE Time Code Methods

There are two basic techniques used to record SMPTE time code onto magnetic tape: LTC (Linear Time Code) and VITC (Vertical Interval Time Code). LTC is recorded or generated on an audio channel or a dedicated time code track of the audio or video device. VITC is recorded within the video signal in the video “blanking area” of each video frame. VITC cannot be recorded on audio tracks, so it has no application when working with audio tape recorders, but it does offer features for post production (such as still frame and slow speed time code address reading).

There is also a non-SMPTE form of time code called MIDI Time Code (MTC) that some devices use to send timing information.

SMPTE Time Code Units

Time code describes locations in terms of hours, minutes, seconds, frames, and subframes (1/100th of a frame). The frame is used as a unit of time measurement due to SMPTE time code’s origin in film and video applications (see also “Frame Count and Frame Rate” on page 635.) Depending on the SMPTE frame rate, one frame is equal to 1/24th, 1/25th, 1/29.97th, or 1/30th of a second. For example, a video tape time code reading of “01:12:27:15” would tell us that we were at a position of one hour, twelve minutes, twenty-seven seconds, and fifteen frames. However, this time address alone does not tell us frame rate information.

Because SMPTE stores an absolute time reference on the tape in the form of time code, any location on that tape can be precisely located by devices that read time code. Once the time code has been recorded or striped on a tape, it provides a permanent positional reference that allows Pro Tools to link the playback of an event to an exact tape location. For example, with time code synchronization, a gun shot sound effect can be played at the precise instant that the gun’s flash appears on-screen.

Frame Count and Frame Rate

It is important to remember the difference between frame count and frame rate.

Frame count is the amount of frames that the time code counts before ascending to the next second count. Standard frame counts are:

<table>
<thead>
<tr>
<th>Frame Count</th>
<th>fps</th>
</tr>
</thead>
<tbody>
<tr>
<td>frames 0–23</td>
<td>24</td>
</tr>
<tr>
<td>frames 0–24</td>
<td>25</td>
</tr>
<tr>
<td>frames 0–29</td>
<td>30</td>
</tr>
</tbody>
</table>
“Frame rate” is the rate of speed that the time code is ascending through the frames. For example, when someone refers to a time code of 29.97, they usually are referring to “using a frame count of 30 frames, but counting each frame at the speed of 29.97 frames per second.”

**LTC (Longitudinal or Linear Time Code)**

LTC is time code that is recorded and played back, or generated, in the form of an analog audio signal. LTC is supported by many audio and video tape recorders.

**LTC Speed Usage**

LTC can be read at high tape shuttle speeds, allowing a machine’s time code reader to communicate with synchronizers at rewind or fast forward speeds exceeding 50 times playback speed (provided the tape recorder is able to reproduce the time code at this speed). However, LTC cannot be read at very slow shuttle speeds (such as when you are “crawling” the tape frame by frame) or when the machine is paused. With LTC, the VTR must be running (usually at a minimum speed of about 1/10th normal playback speed) in order to capture a SMPTE time address.

**VITC (Vertical Interval Time Code)**

VITC is a type of time code that is recorded and played as an invisible part of a video signal. VITC is commonly used in professional video editing and audio-for-picture applications. Because VITC is recorded as part of each video frame, it must be recorded at the same time as the video signal—it cannot be added later as LTC can. Since VITC cannot be recorded on audio tracks, it is never used to synchronize audio-only recorders. Instead, LTC is most often used in audio-only applications.

**VITC Speed Usage**

VITC’s ability to be read when moving a VTR transport at slow speeds or when the VTR is paused makes it more useful than LTC in these situations. When VITC is used, Pro Tools can capture the current SMPTE time from the VTR when it is paused or in “crawl” mode. However, if you are using additional external transport synchronizers in your setup, most synchronizers cannot read VITC at speeds exceeding approximately 10 times playback speed, preventing slaved machines from maintaining synchronization during rewind and fast forward.

**LTC/VITC Auto-Switching**

Many synchronizers and devices support automatic switching between LTC and VITC, depending on the speed, to get the best of both worlds (both the SYNC I/O and USD support auto-switching). For example, VITC might be used when a VTR is paused, or crawling frame-by-frame, while the synchronizer might automatically switch to LTC when fast-forwarding.

**Bi-Phase/Tach**

This electronic pulse stream is used by film mag recorders, film editing stations, and film projectors. You can use this format to synchronize Pro Tools if you have a SYNC I/O (or USD). Unlike time code, Bi-Phase/Tach doesn’t actually contain absolute location information. It simply supplies speed (based upon the frequency of the pulses) and direction, and therefore, relative position. Since the SYNC I/O can “count” both the speed and direction of the stream of pulses, it can use a Bi-Phase/Tach source to deduce positional information from a starting “address point.” The difference between Bi-Phase and Tach formats is that Bi-Phase encodes rate and direction on a pair of signals using a format...
called phase-quadrature, while Tach encodes rate on one signal and direction on the other. For more information on Bi-Phase/Tach, see the SYNC I/O Guide.

---

**SMPTE Frame Formats**

Several different formats of SMPTE time code exist, and Pro Tools can synchronize to all common formats with a compatible synchronization peripheral.

When you work with NTSC video (the standard in North America and Japan), you will generally work with the NTSC color video standard: either 29.97 fps Non-Drop or 29.97 fps Drop frame. If you are working with PAL, your frame rate is 25 fps.

Pro Tools supports the following SMPTE frame rates:

**30 fps Frame Format**

This is the original SMPTE format developed for monochrome (black & white) video, and is commonly used in audio-only applications. This format is often referred to as 30 Non-Drop frame format.

**30 fps Drop Frame Format**

Some field film recordings are done at 30df so when they get pulled down after the telecine transfer, they will end up as 29.97df.

**29.97 Non-Drop Frame Format**

This format is used with NTSC color video. It runs at a rate of 29.97 fps.

---

**29.97 Drop Frame Format**

NTSC color video has an actual frame rate of 29.97 fps, so an hour’s worth of frames (108,000) running at 29.97 fps Non-Drop will take slightly longer than one hour of real time to play. This makes calculating the actual length of a program difficult when using 29.97 Non-Drop time code. A program that spans one hour of 29.97 Non-Drop time code addresses (for example, from 1:00:00:00 to 2:00:00:00) is actually 60 minutes, 3 seconds and 18 frames long.

To make working with 29.97 time code easier for broadcasters, the SMPTE committee created 29.97 Drop Frame time code, which runs at exactly the same speed as 29.97 Non-Drop (non-drop frame) time code, but compensates for the slower speed by “dropping” (omitting) two frames at the top of each minute, with the exception of every 10th minute. For example, the time code address of 1:01:00:00 does not exist in drop frame code because it has been skipped.

Note that even though time code addresses are skipped in drop frame format, actual frames of video material are not dropped.

At the end of a program that spans precisely one hour of drop frame time code (for example, 1:00:00:00 to 2:00:00:00), exactly one hour of real time has elapsed.

Although it sounds complicated, drop frame time code allows broadcasters to rely on time code values when calculating the true length of programs, facilitating accurate program scheduling.
25 fps Frame Format

This format is used with the European PAL video standard, which runs at a 25 fps frame rate. This format is also called the EBU (European Broadcast Union) format because it’s used by broadcasters throughout most of Europe.

24 fps Frame Format

This format is used for high-definition video and film applications. Film is typically photographed and projected at a 24 fps frame rate, so this SMPTE format is useful when one time code frame should equal one film frame.

23.976 fps Frame Format

This format is used for high-definition digital video production using NTSC video equipment, and film applications.

Working with Film-Originated Material

When you do post production work in Pro Tools, you will usually work with video material. However, it is possible that the video you are working on was shot on film.

Film footage and production sound go through separate conversion processes before they reach video, and the audio post production stage. The film is transferred to video using a process called Telecine, using a method called 3:2 Pulldown. Audio can also be pulled down during the transfer, or you might end up working with audio that has not been adjusted (production sound).

Typically, during the Telecine process, a master digital video tape is created, along with a work copy on Betacam or 3/4-inch analog video tape for the picture editor to use. At the same time, a new audio master may be created by slowing down, or pulling down by 0.1%, the production sound to compensate for the change in speed from film to NTSC video. (See Figure 44 on page 640.)

Guide Tracks and Conforming

In the Video editing process, the audio track produced by the video editor (the “guide track”) is rough and needs to be enhanced and improved by the audio engineer. For this reason, the audio engineer will need to re-assemble the original sound elements in a process known as conforming.

3:2 Pulldown

A film clip that lasts 1000 seconds consists of 24,000 film frames (pictures). If you want to transfer that film to 1000 seconds worth of NTSC color video, you have to fit 24,000 film frames into 29,970.02997 video frames.
If we use the black and white NTSC video standard (30 fps) instead of 29.97 fps, the process of converting film frames to video frames is greatly simplified. Now instead of any fractional frames, we have 24,000 film frames going into 30,000 video frames (60,000 video fields). In the Telecine process (for NTSC color video), each odd film frame is copied to two video fields, and each even film frame is copied to three video fields, creating what is called a 3:2 Pulldown. The speed of the film is also “pulled down” to 23.976 fps in order to accommodate the slower speed of NTSC color video compared to NTSC black and white video (29.97 fps compared to 30 fps).

**Film Speed Differs from NTSC Video Speed**

When spotting audio to video that was transferred from film to NTSC video, there are two important terms to keep in mind: film speed and video speed.

**Film Speed** Film speed refers to audio that was recorded and plays back in synchronization with the original film material. This audio often comes from production reels recorded on a Nagra® recorder or a field DAT recorder, and is usually striped with 30 Non-Drop time code. Film must be pulled down 0.1% when being transferred to 29.97 NTSC. Film must be pulled up by 4.16667% when film is being transferred to PAL.

**Video Speed** Video speed refers to audio that is running at the NTSC color standard of 29.97 fps. Video speed is 0.1% slower than film speed, so audio that is still at film speed will be out of sync with the video.

In Figure 44, note the following:

- The vertical arrow at the left (“faster” “slower”) represents program speed or rate.
- Telecine is a frame count conversion (for example, 24 to 30).
- The speed you play the result back is a frame rate conversion (for example, 30 to 29.97).

The following table lists the applications for each of the frame rates and counts shown in Figure 44 on page 640.

### Frame Rates and their Applications

<table>
<thead>
<tr>
<th>Frame Rate</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>25 fps</td>
<td>PAL</td>
</tr>
<tr>
<td>24 fps</td>
<td>Film, and 24P HD</td>
</tr>
<tr>
<td>23.976 fps</td>
<td>24P pull down, for NTSC broadcast, and HD digital video</td>
</tr>
<tr>
<td>30 fps</td>
<td>30 frame music production, and 30 frame recording for film</td>
</tr>
<tr>
<td>29.97 fps</td>
<td>Broadcast NTSC video</td>
</tr>
</tbody>
</table>
Frame Rates and Relative Playback Speeds

The following diagram illustrates the relative playback speeds of SMPTE formats.

![Diagram showing frame rates and relative playback speeds]

Figure 44. Frame rates, telecine transfers, and relative playback speeds

Pull Up and Pull Down

*Pull Up* and *Pull Down* are terms used to refer to the deliberate recalibration of the audio sample rate clock (speed, or musical pitch) in order to compensate for a speed change. Pro Tools can be used to pull down or pull up audio or video playback rates. Pro Tools 5.3.1 and higher support pull rates known as “4% factors” (4.0% down, or 4.167% up to be exact), applicable to audio and video playback, to support PAL/film/NTSC conversion requirements.

Pull Down allows you to play back film-originated material at video speed (~0.1%). Pull Up allows you to play back video speed material at film speed (+0.1%).

Using Pro Tools in Pull Up or Pull Down modes requires a SYNC I/O, USD, or third party synchronizer.

When to Pull Up or Pull Down

There are many ways to get audio into Pro Tools for post production. Consider your source audio and your final destination format carefully. In some cases, audio will already be pulled down for you. In other cases, audio will have to be temporarily pulled down. In still other cases, you may choose to pull down your audio source, like a DAT deck, then use a a D-A-D (digital-to-analog-to-digital) process, or the Sample Rate Conversion option on the 192 I/O, to record the audio into Pro Tools at the proper sample rate. Or you may choose only to pull Pro Tools up or down on delivery of the audio.
Because mistakes in pull factors can be expensive, good communication with other participants in the project is critical. Find out as soon as possible how your task relates to the rest of the project.

**Final Audio Destination: Film**

If your final destination is film, your source audio is at film speed, and your goal is to edit and mix audio in Pro Tools and then lay back to a device that runs at film speed (such as mag or time code DAT), you can temporarily pull down the audio in Pro Tools for NTSC video work, then return the audio back to film speed when you’re finished (by disengaging pull down).

For example, film speed audio from a field audio recorder that is referenced to 30 fps time code is recorded into your Pro Tools system at a sample rate of 44.1 or 48 kHz. Keeping in mind that film speed is faster than video speed, select 30 fps in your Session Setup window in Pro Tools, and record in your audio online and referenced to the time code on the field audio recorder.

Once all the audio has been recorded, and you are locked to a video work print (at video speed), enable Pull Down. If you are using a Digidesign SYNC I/O, select Pull Down in the Session Setup window. If your synchronizer is not a Digidesign product, select Pull Down on the front of your synchronizer, then enable Pull Down in the Pro Tools Session Setup window. At this point, it is highly recommended that you verify whether the video you’re working with is striped with 29.97 Drop Frame or Non-Drop Frame time code. While in Pull Down mode, you can work with your reference video and everything will remain synchronized and run at the proper speed (assuming your system is completely resolved).

Once you are ready to lay back your completed project to an audio device running at film speed, deselect Pull Down in the Session Setup window, and from your synchronizer if it is not a SYNC I/O. Then change your time code frame rate in the Pro Tools session back to 30 fps. Once Pull Down has been deselected, the audio played back from Pro Tools will synchronize perfectly with the edited film.

Alternatively, you can pull down the source audio deck while recording audio into Pro Tools, work at 29.97 fps with no Pull-Down selected in Pro Tools, and then switch to 30 Non-Drop frame format, and select Pull Up during the delivery stage. You will have to perform a sample rate conversion on the audio either digitally or by using an analog stage (D-A-D).

Only the inputs on the Digital I/O card (on the 192 I/O) feature real-time sample rate conversion.

Most “simul-dats” or “simo-dats” already have their audio pulled down, and should not be pulled down further.

You will also need to select the Audio Rate Pull Up/Down option in the Session Setup window.

**Final Audio Destination: Video**

If you are working with video that was transferred from film, your audio source is at film speed, and the final layback destination is NTSC video (or television), and you would like to provide a digital transfer to your clients, you will need to alter the above recipe slightly. Keep in mind that when you are working in Pull Down mode, your active sample rate is 44.056 kHz (if the audio was recorded at 44.1 kHz) or 47.952 kHz (if the audio was recorded at 48 kHz).
Pull Down the Audio Source

Some professional DAT machines will let you pull down the sample rate to 44.056 kHz (and 47.952 kHz). You can record this audio into Pro Tools using a D-A-D (digital-to-analog-to-digital) process, or Digidesign's 192 I/O Sample Rate Conversion option. Then your audio will be at the correct speed for the remainder of the project, since the final destination is video, and no Pull Down or Pull Up is necessary.

Pull Up Pro Tools While Recording

If you cannot pull down your source, you can accomplish the same thing by Pulling Up Pro Tools, and setting your SMPTE frame format to 30 fps, before recording in the production sound. First select 30 fps as the frame format in the Session Setup window. Then select an Audio Rate Pull Up option in the Session Setup window (and on your synchronizer if it isn’t a SYNC I/O) before you record in the production audio. In this case, while the production audio is running at 44.1 or 48 kHz, Pro Tools is running (and recording) at a rate of 44.144 or 48.048 kHz. After all the production audio has been recorded into Pro Tools, reset the Audio Rate Pull to none in the Session Setup window, and on your hardware synchronizer if it is not a SYNC I/O. After you deselect Pull Up, the recorded audio will play back 0.1% slower, synchronized with the video, while achieving a true playback sample rate of 44.1 or 48 kHz. Note that this process is designed for a final destination of video; to bring this audio back up to film speed you would have to pull up Pro Tools and record to a destination that is not Pulled Up.

Note on Sample Rate Conversion

In many cases, you have to perform a sample rate conversion at some point, either digitally, or by recording in audio using an analog stage (D-A-D). The only situation where sample rate conversion never has to be performed is when you are working with film speed audio and your final destination format is film. Then you can simply pull down Pro Tools while you work with the video, then deselect Pull Down to set the audio back to film speed. (On the 192 I/O and 192 Digital I/O, the inputs on the Digital I/O card feature real-time sample rate conversion.)

Using Digital Input

If working with Pull Up or Pull Down, do not “resolve” to any digital inputs that are used as audio sources in Pro Tools. This would override the use of the SYNC I/O as the clock reference. Any equipment providing digital audio sources to Pro Tools should be synchronized externally.

💡 You will also need to select the Audio Rate Pull Up/Down option in the Session Setup window.
Chapter 34: Working with Synchronization

Synchronization allows one system to output time code and the other device to follow that time code. Pro Tools is synchronized to other devices using SMPTE/EBU time code or MIDI Time Code. For more information on different SMPTE/EBU formats, and other concepts related to time code, refer to Chapter 33, “Synchronization Concepts.”

**Pro Tools Synchronization Options**

There are several options for synchronizing Pro Tools to an external source or using Pro Tools as the master device. Not all options are available on all Pro Tools systems, as noted.

**SMPTE Trigger Only**

This solution is useful for short projects if both systems are extremely close in speed, but even the best systems will rarely stay perfectly synchronized for longer than a couple of minutes.

**SMPTE Trigger Resolved with SYNC I/O**

(Pro Tools HD Only)

You can use the optional SYNC I/O, or an equivalent third-party device to resolve Pro Tools recording and playback speed with any of the following clock reference sources while slaving Pro Tools to time code:

- LTC
- Video source
- House video reference
- VITC
- 1x Word Clock
- AES/EBU “null” clock
- Pilot Tone
- Bi-Phase

This enables long-term, high-fidelity synchronization when all transports within the system are resolved to this common synchronization source, or by resolving to any variations in incoming time code while slaving to time code.
**SMPTE Trigger while Locking to an Unresolved Source**  
*(Pro Tools HD Only)*

SMPTE Trigger can be used with the optional SYNC I/O or equivalent device to resolve Pro Tools recording and playback speed while slaving to LTC. This enables long-term, accurate synchronization by resolving to any variations in incoming time code. The SYNC I/O also supports VITC and Bi-phase/Tach positional reference.

**SYNC I/O Synchronization Options**

By adding the SYNC I/O to your Pro Tools|HD system, you can use Pro Tools as the master device in your synchronization setup. All other devices are then slaved to Pro Tools.

You can use Pro Tools in conjunction with SYNC I/O to generate LTC, MIDI Time Code, or MMC commands. When SYNC I/O is reading incoming SMPTE time code, it regenerates the time code through the LTC or MTC output connector. This signal can be passed along to other slave devices.

**MachineControl™**

The SYNC I/O also supports Digidesign MachineControl software, which provides many specialized features for post-production synchronization tasks including remote track arming, VTR emulation, serial time code, and other capabilities. (See the MachineControl Guide for more information, or contact your Digidesign dealer.)

**Ext. Clock Output**

Pro Tools can be used as the master device in your synchronization setup, where all other devices are then slaved to Pro Tools word clock output.

With Pro Tools|HD systems, clock output can be configured for 1x word clock, or 256x Slave Clock for Digidesign Legacy I/Os (such as 888|24 I/O). See the Pro Tools|HD Getting Started Guide for more information on clock output and Legacy I/Os.

**To set Ext. Clock Output:**

2. Click the Ext. Clock Output pop-up menu and select an available signal.
3. Click OK to close the Hardware Setup dialog when you have finished.

If the Legacy Port is enabled (as opposed to the Expansion Port) then the Ext. Clock Output automatically switches to Slave256x. To reset the Ext. Clock Output, the Port Settings button must be set back to Expansion and the Legacy I/O must be set to No Interface. (To set a Legacy I/O to No Interface, select its name in the Peripherals list, then choose No Interface from the Interface pop-up menu.)

---

*For instructions on connecting an external synchronization peripheral to your Pro Tools system, refer to your Getting Started Guide. If you are using SYNC I/O, refer to your SYNC I/O documentation.*
Session Setup Window

The Session Setup window lets you configure various time code-related settings on your system. The window also includes display-only areas for session sample rate, file format, and bit depth.

Pro Tools LE systems with DV Toolkit support various time code-related settings (such as Time Code and Feet+Frame Timebase rulers). For a complete list, refer to the DV Toolkit for Pro Tools LE Guide.

Session Setup Window

The Session Setup window is organized into three view sections. Session displays and settings are displayed at the top of the window. The SYNC Setup & Session Offsets section, and the Time Code Settings section, can be shown or hidden using their dedicated expand/collapse triangles.

To show the Session Setup window:
- From a Pro Tools session, choose Setup > Session.

To expand SYNC Setup & Session Offset section:
- Click the SYNC Setup & Session Offsets expand/collapse triangle.

The controls in this section configure settings of the Digidesign SYNC I/O. Settings are provided for Clock and Positional Reference, Video Format, and Variable Speed Override.

To show Time Code Settings section:
- Click the Time Code Settings expand/collapse triangle.

The controls in this section provide time code generation and freewheel options, and separate pull up and down selectors for audio and video rates.
Session Displays and Settings

Sample Rate
This display indicates the sample rate for the current session.

Bit Depth
This display indicates the bit depth for the current session.

Audio Format
This display indicates the file format for files recorded in the session.

Mac<>PC
This display indicates whether Pro Tools is set to create sessions and audio files that are usable on both Windows and Macintosh.

Clock Source (Sync Mode)
Use this menu to configure the system Clock Source. You can choose between a SYNC I/O, an internal clock source from a digidesign card or peripheral, or an external clock source connected to a Pro Tools|HD audio interface.

Internal Mode
In Internal mode, your system will reference your Digidesign card or peripheral's quartz crystal oscillator and play back at the session's sample rate.

External Clock Sources
Depending on your Pro Tools|HD audio interface, external Clock Source options can include AES/EBU [Encl.], S/PDIF, Optical [Encl.], AES/EBU 1-8, TDIF, ADAT, and Word Clock (optional word clock rates are available at higher frequencies). External sources can be 1x any sample rate or the “base” rate. Base rate equals 44.1 kHz for 88.2 and 176.4 kHz; 48 kHz for 96 and 192 kHz. If an external source is chosen, and no valid sync clock is detected at the External Clock In, the I/O will return to Internal mode.

If SYNC I/O is enabled in the Peripherals dialog, and is correctly connected in the Loop Sync chain, SYNC I/O can be the Loop Master, and Pro Tools|HD audio interfaces will clock as Loop Sync slaves.

System Delay
This display indicates the total amount of system delay (in samples) caused by plug-ins and mixer routing.

Fader Gain
This display indicates the maximum fader gain level for the session.

Session Start
Use this field to specify a SMPTE start frame location for your session. See “Setting a SMPTE Session Start Time (Start Frame)” on page 650.
Incoming Time (Current Time)
This display indicates incoming time code.

Time Code Rate
This pop-up menu lets you set the SMPTE time code rate for the current session.

Feet+Frame Rate
Feet+Frame rates for sessions can be set with the Feet+Frame Rate selector. Supported rates are 23.976, 24, and 25 fps.

Set this rate to match the rate of the film projector, or the video if the film projector speed is taken into account. For example, doing a Telecine transfer from a 24 fps film projector to NTSC video would necessitate the projector running at 23.976 fps. This is regardless of whether the session is using pull down audio or not.

SYNC Setup Settings
(Pro Tools HD Only)
The controls in the SYNC Setup section let you configure SYNC I/O settings, including clock reference, positional reference, video format, and VSO.

These controls are grouped in the Synchronization Settings section.

Clock Reference
This menu lets you set the Pro Tools clock reference.

When using a Digidesign SYNC I/O, the Clock Reference selector lists all supported clock types for the Digidesign synchronization interface.

When using Pro Tools|HD systems without a SYNC I/O, choices include any currently-enabled digital format or source available from your Pro Tools|HD I/O (such as AES, S/PDIF, or 1x Word arriving at the Pro Tools|HD interface’s Word Clock In port).

Positional Reference
Use this menu to set the time code source for Pro Tools to use for positional reference.

Video Format
Use this menu to set the session for NTSC or PAL format.

Variable Speed Override (VSO)
Variable Speed Override (VSO) requires a SYNC I/O.

When a SYNC I/O is connected to a Pro Tools|HD system, the VSO controls are located in the SYNC Settings section of the Session Setup window.

Refer to the SYNC I/O Guide for instructions on using VSO to varispeed Pro Tools playback.

Locked Indicator
The Locked indicator stays lit when the SYNC I/O is locked to the selected clock reference. The Locked indicator flashes if the selected clock reference source is missing or out of lockable frequency range.
**Speed Cal Indicator**

This indicator provides the accuracy of the incoming clock reference. The Speed Cal indicator is lit when the output frequency is within 200 ppm (0.02%) of the selected sample rate. The Speed Cal indicator turns off when the output sample rate is not at the expected (or target) rate.

**External Time Code Offsets**

In the External Time Code Offsets section, Pro Tools lets you compensate for devices that are consistently offset by a fixed number of frames (such as some color-corrected video masters), or for material that starts at a different time than the session.

Pro Tools provides three different types of Session Start Time Code Offset settings. These offsets include:

- MMC (MIDI Machine Control)
- 9-Pin (Serial machine control)
- Synchronization peripherals (such as the SYNC I/O, or a MIDI interface that provide MIDI Time Code).

Positive and negative offset values can be entered to offset Pro Tools time code display later or earlier, respectively.

Unique values can be defined for each of these three types offsets, or you can link all three to adjust in unison.

If you are using Digidesign’s MachineControl option, additional options for External Time Code Offsets are available. See the Machine-Control Guide for more information.

**Time Code Settings**

The Time Code Settings section provides generator, freewheel, and pull up/down options.

These controls are located in the Time Code Settings section of the Session Setup window. Click the Time Code Settings expand/collapse triangle to show or hide these controls.

**Generator**

The Generator lets you enable Pro Tools generation and output of LTC and MTC using the SYNC I/O. For more information, see “Generating Time Code” on page 656.

**Using Synch** This option outputs time code from the Device type selected in the Synchronization page of the Peripherals dialog.

**MTC to Port** When enabled, outputs MIDI Time Code to the MIDI destination selected in the pop-up menu. In Pro Tools on Windows, choices appear as they are in your MSS (MIDI Studio Setup) profile. In Pro Tools on Macintosh, choices are based on your AMS (Audio MIDI Setup) profile.

**Freewheel**

The choices in the Freewheel section let you configure how Pro Tools will freewheel, or continue playback if time code is interrupted or corrupted. Use these options to protect against errors that can occur if your SMPTE time code source has “drop outs” or temporary lost signals.

**None** No freewheel is applied.

**Frames** Sets a number of frames to freewheel, from 1 to 120 frames. This value defaults to 8 frames, which is the recommended setting for most applications.
Jam Sync  Lets Pro Tools trigger synchronization to incoming time code, and continue to play back even if time code input is completely interrupted. It can be useful if time code is damaged, or has been accidentally erased from your source tape.

Pull Up/Down  
When Pro Tools is used in conjunction with a SYNC I/O, or a third party peripheral or synchronizer that supports pulled sample rates, this option allows you to “pull up” or “pull down” the current sample rate.

For general information, see “Working with Film-Originated Material” on page 638. For more information on applying pull factors in Pro Tools, see “Pull Up and Pull Down” on page 652.

⚠️ Remember, pull up and pull down are applied differently in different workflows. Make sure you check each project’s specific workflow before you begin your work.

Time Code Reader Offset (Sync Offset)  
This field lets you set a trigger offset for incoming MIDI Time Code (anywhere from –100000 to +100000 samples). This allows you to create a permanent offset to fine-tune the point at which Pro Tools synchronizes relative to incoming time code. For example, a value of –50 makes an event in Pro Tools occur 50 samples before the same event in the incoming MIDI Time Code. Use this to compensate for timing differences between various SMPTE-to-MIDI Time Code converters or analog-to-digital/digital-to-analog converters.

Preparing to Work with SMPTE  
The first step when preparing to work with SMPTE is to choose an appropriate SMPTE frame rate. Pro Tools supports all standard SMPTE frame rates. For a full explanation of these SMPTE frame rates, see “SMPTE Frame Formats” on page 637.

Determining SMPTE Frame Rate  
Common methods to determine the SMPTE frame rate include labeling procedures or communication.

Configuring Pro Tools for SMPTE  
Synchronization and MachineControl™ system settings are enabled in the Pro Tools Peripherals dialog. These settings are system settings, and remain constant regardless of the particular session you are working on. Configure these settings before opening a session.

⚠️ MachineControl is supported on Pro Tools|HD systems only.

Other settings are configured in the Session Setup window, such as the session Time Code rate, the Feet+Frames rate, the session start frame, and time display format. These settings are session-specific settings. These settings can only be configured when a session is open.
Selecting a SMPTE Format

To choose a SMPTE format:
1. From a Pro Tools session, choose Setup > Session.
2. Choose a frame rate (SMPTE format) from the Time Code Rate selector.
3. Enter the Time Code Freewheel frames (if any) in the designated box. See “Freewheel” on page 648 for more information.

Setting a SMPTE Session Start Time (Start Frame)

The Session Setup window also allows you to set a SMPTE Start Frame for your session. Video work tapes are rarely striped beginning at a SMPTE frame address of 00:00:00:00. You can quickly enter a start time for your session based on an appropriate frame number from your project tape. The Pro Tools SMPTE-related functions (such as Spot mode) will then use this value as their reference for the session’s start point.

Start Time When Striping Tape

If you are generating time code, it is a good practice to stripe your time code beginning at 01:00:00:00 (subtracting time for initial black, bars and tone, or logos). This prevents problems that can occur with some synchronizers when the striped time code crosses from 23:59:59:29 to 00:00:00:00 (commonly referred to as the “midnight” boundary).

To set a SMPTE Start Time for your session:
1. Choose Setup > Session.
2. Enter a SMPTE frame number in the Session Start field.

To capture an incoming SMPTE address as the session start time:
1. Click in the Session Start field.
2. Begin playback of the time code source.
3. At the desired location, press Equal (=) in the numeric keypad.
4. Press Enter to accept the value. You can then edit the captured address. The session uses the frame number you enter as its SMPTE start frame when online.

If there are existing regions on the tracks and you are changing the original SMPTE start frame to a later time (from 00:00:00:00 to 01:00:00:00, for example), all existing regions on tracks will remain in their relative positions, but will start later by the time value added to the start frame.

5. If you are changing the session start time in an open session in which tracks already exist, a warning dialog appears after Session Setup window. Choose from one of two options:

Maintain Time Code  Places the additional session time at the start of the session, and keeps existing regions in their original time code locations.

Maintain Relative Position  Places the additional session time at the start of the session, and maintains the relative position of existing regions to the new start frame. For example, if you change the session start frame from 01:00:00:00 to 00:59:00:00, Pro Tools adds one minute of session time to accommodate the new start frame, and moves all existing regions earlier in time to maintain their relative position to the start frame.
Redefining a Time Code Position

Use this command to redefine the current time code position and session start time. By creating an insertion point (or selection), and then entering the desired new time code position for that location, the session start time will be recalculated based on the new, relative Time Code location.

To redefine a current Time Code code position:

1. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.

⚠️ If your insertion or selection is not on a grid boundary, it will round to the closest boundary.


3. Enter a new SMPTE frame number in the dialog to correspond to the time code shown in the dialog.

4. Click OK.

Redefining a Feet+Frame Position

(Pro Tools HD and Pro Tools LE with DV Toolkit Only)

Use this command to redefine the current Feet+Frames position. By creating an insertion point (or selection), and then entering the desired new Feet+Frames position for that location, the session start time is recalculated based on the new, relative Feet+Frames location.

Typically, this command is used for integrating test tones, pre-roll, Academy leader, and similar pre-program material into Pro Tools sessions.

To set a relative frame position for a session (Feet+Frames):

1. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.

⚠️ If your insertion or selection is not on a grid boundary, it will round to the closest boundary.


3. Enter a Feet+Frame position to correspond to the time code shown in the dialog.

4. Click OK.
Displaying Time in SMPTE Frames
(Pro Tools HD and Pro Tools LE with DV Toolkit Only)

In Pro Tools, you can set the Main Time Scale to Time Code (SMPTE) and this will be displayed in the Main Counter. Though Pro Tools will still synchronize to incoming SMPTE time code if the Time Scale is displayed in Bars:Beats, Minutes:Seconds, or Feet:Frames, it is usually more useful to use SMPTE time code as your reference.

To set the Main Time Scale to SMPTE Time Code:
- Choose View > Rulers > Time Code.
- or –
- Click the Main Counter selector in the Edit window and select Time Code.

Pro Tools will display time code values in the currently selected SMPTE frame rate.

Sub Counter and Sub Time Scale Display

You can display a Sub Time Scale in the Sub Counter. For example, if the Main Time Scale is set to Time Code, and you want to compare SMPTE time to “wall clock,” when you are using 29.97 Non-Drop frame rate, click the Sub Counter selector and select Min:Secs as the Sub Time Scale.

Pull Up and Pull Down

Pro Tools supports up to 4% pull up and pull down, with support for an additional 0.1% up or down. Separate rates can be set for session audio and video (when video has been imported or captured into the session).

When referring to 4% pull up and pull down, the precise percentages used in pull ups is 4.167%. See Table 35 on page 654.

While the SYNC I/O is not required in order to use the extended pull up and down options provided in Pro Tools, the SYNC I/O is the only device that can be controlled from within Pro Tools, and that recalls and restores pull factors automatically when a session opens. Other synchronization peripherals must be configured manually.

Pull up and down settings do not affect time code generated by the SYNC I/O.

Configuring Pull Up and Pull Down

To pull up or pull down audio or video:

1. Choose Setup > Session.
2. From the Time Code Settings section of the Session Setup window, select a Pull Up/Down Rate.

Audio Rate Pull Up/Down Controls audio sample rate. See “Audio Sample Rate Pull Up and Down” on page 654.
Video Rate Pull Up/Down Controls video rate. See “Video Rate Pull Up and Down” on page 655.

The choices available in these menus are determined by the session frame rate. Combinations can be applied by choosing from both menus.

4% pull factors are not available in 176.4 and 192 kHz sessions.

The choices available in these menus are also determined by the Preferences and Auto Match Pull Factors settings in the Time Code Rate menu. See “Extended Pull Up and Pull Down” on page 653 and “Auto Match Pull Factors” on page 653.

Extended Pull Up and Pull Down

Preference and Session Setup Controls The Audio Rate Pull Up and Down menu offers all possible combinations of pull ups and pull downs for the audio sample rate, regardless of the session frame rate.

In addition, if there is a QuickTime video clip in the timeline, the video rate can be pulled up or down by 0.1%, regardless of the session frame rate. Though not an approved workflow, earlier versions of Pro Tools also enabled pull down of QuickTime video clips when audio was pulled down, so this option is included in Pro Tools 5.3.1 and higher to maintain compatibility with earlier sessions.

Auto Match Pull Factors

Auto Match Pull Factors is available from the session Time Code Rate menu in the Session Setup window. When Auto Match Pull Factors is enabled, Pro Tools adjusts audio and video playback rates as needed to match any changes to the current session Time Code Rate.

Auto Match Pull is applied relative to the current pull up setting. While enabled, if the session frame rate is changed in such a way that the video would have to be pulled by an unsupported amount, the video remains unaffected.

This setting is latching, is not enabled by default, and its state is stored with the session.

Example of Auto Match Pull Factors

Auto Match Pull Factors links audio and video pull factors when changing session frame rate.

For example, assume a Pro Tools session is set to a frame rate of 25 fps, the audio and video are both playing with no pull ups, and Auto Match Pull Factors is enabled.

If you then change the session Frame Rate to 24 fps, both the Audio and Video Rate Pull settings would change by –4.0% (the appropriate pull setting required by the change in frame rate).

Auto Match-enabled pull factors are applied to any existing Audio Rate Pull Up/Down or Video Rate Pull Up/Down settings. For example, if audio was already being pulled –0.1% when you changed the session Frame Rate from 29.97 to 24 fps, then the Audio Rate Pull Up/Down menu would switch to None.
**Audio Sample Rate Pull Up and Down**

The Audio Rate Pull/Down menu applies pull up or down factors to session audio record and playback. All pull rates are available, regardless of session frame rate.

Table 35 lists actual sample rates of each pull up and pull down option and combination (rounded to the nearest whole Hz):

<table>
<thead>
<tr>
<th>Pull Up/Down</th>
<th>Sample Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>44100</td>
</tr>
<tr>
<td>+4.1667% and +0.1%</td>
<td>45983</td>
</tr>
<tr>
<td>+4.1667%</td>
<td>45938</td>
</tr>
<tr>
<td>+4.1667% and –0.1%</td>
<td>45892</td>
</tr>
<tr>
<td>+0.1%</td>
<td>44144</td>
</tr>
<tr>
<td>–0.1%</td>
<td>44056</td>
</tr>
<tr>
<td>–4.0% and +0.1%</td>
<td>42378</td>
</tr>
<tr>
<td>–4.0%</td>
<td>42336</td>
</tr>
<tr>
<td>–4.0% and –0.1%</td>
<td>42294</td>
</tr>
</tbody>
</table>

See also “Auto Match Pull Factors” on page 653.
**Video Rate Pull Up and Down**

The Video Pull Up/Down selector lets you change the frame rate of video playback independently from the audio pull-ups (if any). It is located below the Audio Rate Pull Up/Down menu in the Session Setup window.

*See also “Auto Match Pull Factors” on page 653.*

The choices available in the Video Rate Pull Up/Down menu depend on the file format of the video clip, as well as its frame rate. The following table shows the pull ups available for Avid video clips, both interlaced and Progressive Scan.

**Video Frame Rates and Pull Options**

<table>
<thead>
<tr>
<th>Format and Video Frame Rate</th>
<th>Available Video Pull Rate</th>
<th>To synchronize with</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avid Video</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24 fps</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td></td>
<td>–0.1%</td>
<td>29.97 NTSC videotape</td>
</tr>
<tr>
<td></td>
<td>+4.167%</td>
<td>25 fps PAL videotape</td>
</tr>
<tr>
<td>25 fps</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td></td>
<td>–4.0%</td>
<td>24 fps</td>
</tr>
<tr>
<td></td>
<td>+4.167%</td>
<td>29.97 NTSC videotape</td>
</tr>
<tr>
<td>29.97</td>
<td>None</td>
<td></td>
</tr>
</tbody>
</table>

Video pull rates are saved with the session.

**No Video Recording with Pull Ups**

(video|option|XL Required)

Video may not be recorded to the timeline if a video pull up is selected. If the video track is record-enabled while video pull ups are enabled, or if you attempt to set a video pull up rate while the video track is record-enabled, Pro Tools will post a dialog and disallow video recording. To proceed with digitization, reset the Video Rate Pull Up menu to None.

**What is Pulled Up or Down?**

The following sections describe how related Pro Tools features are affected by pull up and down rates.

**Time Code Ruler**

Video pull up and down does not affect the Time Code ruler. Be sure to set the session Frame Rate to the correct frame rate for your project. For example, if working with 24 fps video and you pull the video up by 4%, switch the session Frame Rate to 25 fps to keep the Time Code ruler aligned. Similarly, if working with 24 fps video that is pulled down by 0.1%, switch the frame rate of the session to 29.97.

When working with 25 fps Avid media and the video is set to pull down by 4%, set the session Frame Rate to 24 fps.

**Plug-Ins**

For proper operation at larger (4%) pull rates, plug-ins must utilize sample clock instead of an absolute time clock. All Digidesign plug-ins are based on sample clock.

**Higher Sample Rates and Pull Factors**

4% audio pull rates are not available in 176.4 and 192 kHz sample rates sessions.
Putting Pro Tools Online

To trigger playback or recording from an external source, the Pro Tools Transport must be placed online. This tells Pro Tools to listen for incoming time code.

To put the Pro Tools Transport online, do one of the following:

- Choose Options > Transport Online.
- Click the Online button at the far left of the Transport.
- Press Control+J (Windows) or Command+J (Macintosh).

The Online button flashes while Pro Tools waits for a SMPTE frame to trigger playback. When time code is received, playback begins and the Online button becomes highlighted. The Edit Selection indicators in the Edit window, and the Incoming Time field in the Session Setup window display the incoming time code.

To take Pro Tools offline:

- Deselect Options > Transport Online.
- Deselect the Online button in the Transport window.

Recording Online

The Operation Preferences page contains two options that affect how Pro Tools initiates recording when online.

- **Record Online At Insertion/Selection** Makes online recording begin wherever you have placed the insertion point in a track. Recording then continues until Pro Tools stops receiving time code. If you make a selection in a track, Pro Tools will record online only for the length of the selection.

- **Record Online at Time Code (or ADAT) Lock** Makes online recording begin as soon as Pro Tools receives and locks to time code or ADAT sync. In this case, you do not need to make an insertion or selection in a track to designate a start point.

Generating Time Code

Using SYNC I/O, Pro Tools can generate SMPTE and MIDI Time Code (MTC). You can then make Pro Tools a master synchronization source with other devices slaved to it.

**SYNC I/O cannot generate 30 fps, 24 fps, or 23.976 fps time code while locked to video input or video reference**

The SYNC I/O cannot generate 30 fps, 24 fps, or 23.976 fps time code while it is locked to a video clock signal. If you set Pro Tools to generate 30 fps time code while the SYNC I/O is locked to a video clock signal, the SYNC I/O will actually generate at the NTSC color standard 29.97 fps. Pro Tools can generate time code at non-NTSC frame rates if you use the internal clock or external word clock on the SYNC I/O as a synchronization source.
To generate time code using SYNC I/O:

1. Connect the SYNC I/O LTC Out to the SMPTE in connector on the devices you are slaving. If you are slaving a device that recognizes MTC, connect the MTC OUT connector of the SYNC I/O to the MIDI IN connector of the slaved device (MIDI Interface or other).

2. Make sure your SYNC I/O is powered on.

3. Launch Pro Tools, and make sure you have already enabled the SYNC I/O in the Synchronization page of the Peripherals dialog. See the SYNC I/O Guide for more information.

4. Choose Setup > Session, and choose the appropriate frame rate from the Time Code Rate selector.

5. Select SYNC I/O from the Generate selector in the Time Code Settings section of the Session Setup window.

6. Choose a clock reference from the Clock Reference selector. Not all clock choices are available at all sample rates. See “External Clock Sources” on page 646.

7. Click the Online button on the Transport, then click Play. Pro Tools generates and outputs time code from the SYNC I/O.

Using MIDI Machine Control

Pro Tools provides the capability to transmit location information to external devices, and to control their transports, using MIDI Machine Control (MMC).

Controlling External Devices Using MMC

Any device that supports MMC (such as an Alesis ADAT or Tascam DA-88) can be controlled directly from within Pro Tools, with either the device or Pro Tools acting as clock master.

The external devices supported by Pro Tools implement “open loop” communications only. Because of this, while Pro Tools is the Transport Master, any direct operation of the receiving device’s transport will not be communicated back to Pro Tools. Instead, you can use the Transport pop-up to select the external device (MMC in the pop-up) and use the Pro Tools on-screen transport controls to drive the device.

Pro Tools does not support remote track arming of MMC-controlled external devices. You need to manually arm tracks for recording on the external device.

Digidesign’s MachineControl option supports remote track arming for Sony 9-pin and V-LAN enabled devices. See “Remote Track Arming” on page 660.

Windows

Pro Tools on Windows uses your Multimedia Setup to determine which MIDI devices are available, and what their properties are. Refer to your device’s installation and usage documentation to properly configure the device.
Enabling MIDI Machine Control in Pro Tools

To enable MIDI Machine Control:

1. Choose Setup > Peripherals, then click the Synchronization tab.

2. Select your synchronization peripheral from the Synchronization/Device pop-up menu. If you are using a MIDI interface, select “Generic MTC Reader.” If using SYNC I/O, set the Port to DigiSerial.

3. Select the appropriate port for synchronization information. This is the port to which your synchronization peripheral is attached.

4. Click the Machine Control tab in the Peripherals dialog.

5. In the MIDI Machine Control section, enable MMC.

6. Select your external device from the Send To pop-up menu.

The port on which this information will be transmitted is set in the “ID” field. MMC commands contain an ID number to identify which machine should respond to the MMC command. There are 128 MMC ID numbers, from 0–127. The default of ID #127 is a special setting that broadcasts to all 128 MMC IDs. With this setting, any device on the specified port will respond to MMC commands.

7. Set a pre-roll time for your MMC device. Pre-roll is needed to provide Pro Tools with sufficient time to lock to the incoming time code. This value will vary depending on the external device. If the pre-roll time is insufficient, Pro Tools may not be ready to lock until after the current time code position has passed.

8. Click OK to close the Peripherals dialog. Pro Tools will now be able to control the selected device’s transport.

Operating the Pro Tools Transport with MMC

You use the Pro Tools Transport window as the remote controller for all your enabled devices (MMC units, ADAT, or a nonlinear video deck). To do so, set the enabled devices to listen to the address you enter for MMC. The Transport window will then “drive” Pro Tools transport and any slaved devices.

You can also configure a “Pro Tools master,” which can “drive” other devices (as needed), and to which Pro Tools will chase (slaving Pro Tools).
To control external devices from the Pro Tools Transport Master:

- Select either Pro Tools or MMC from the Transport pop-up in the Pro Tools Transport window. The selected item will act as Transport Master.

When the Transport Master is set to Pro Tools, the playback position is governed by the on-screen cursor in Pro Tools.

When the Transport Master is set to MMC, the playback position is governed by the external device's play position.

For more information, see “Recording from MIDI Devices” on page 187.

**MMC Transport Settings**

When using MMC, you can set the following options for machine transport behavior in the Operation Preferences page.

**Machine Chases Memory Location** With this option enabled, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** With this option enabled, navigating to a specific location in a session by moving the selection point or by scrubbing a track causes a connected transport to chase to that location.

**Taking a Device Offline**

Use the Online pop-up menu in the Transport Master selector to take a MIDI (or Machine) device offline.

**To take a device offline:**

1. Click the Transport Master selector.
2. Click on the Online pop-up menu and deselect the device (Machine or MIDI) by clicking on it. Device choices depend on the current Transport Master and which devices have been set up in Pro Tools.

**Desselecting a device to take it offline**

To bring a device back online, click and reselect it in the Online pop-up menu.

*The Online pop-up menu will only display devices that have been properly set up in Pro Tools.*

To set up MIDI devices, see “Enabling MIDI Machine Control in Pro Tools” on page 658.

To set up machine devices, see the Machine-Control Guide.
Setting Minimum Sync Delay

Lock-up time delay is the amount of time your system’s devices need to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization window of the Peripherals dialog. The lowest value available is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set this as the Minimum Sync Delay. On systems utilizing Digidesign MachineControl, enabling the Use Serial Time Code setting will make machines lock up much faster. (Serial time code requires both the SYNC I/O and external devices to be locked to house video reference.)

To set a Minimum Sync Delay:

1. Choose Setup > Peripherals, and click the Synchronization tab.
2. Enter a number of frames in the Minimum Sync Delay field.
3. Click OK to close the Peripherals dialog.

Configuring Minimum Sync Delay for External MMC Devices Locked to House Sync

When controlling a house-synced device from Pro Tools through MMC, the device will first lock to the MMC location and then align the color framing. Within house sync code are 4 frames for ensuring color frame lock. If the minimum synchronization setup time is less than the time required to achieve both location and color frame lock, playback will begin before the device has aligned the color frames. In this scenario, you should set the Minimum Sync Delay to be more than the time required for color frame lock. This is not a problem with the SYNC I/O, which will drop out of lock until the color frame is locked.

Remote Track Arming

Digidesign’s MachineControl™ option for Pro Tools allows you to remotely arm tracks on supported 9-pin (or V-LAN for transport only) decks. Without MachineControl, Pro Tools does not support remote track arming of external devices. MachineControl lets Pro Tools act as the master or slave to external Sony 9-pin (or V-LAN for transport only) machines, in addition to providing remote track arming from within Pro Tools.

For information on remote track arming with MachineControl and using Pro Tools menu commands dedicated for remote track arming, see the MachineControl Guide.
MIDI Beat Clock

Some MIDI devices such as drum machines, hardware sequencers, and arpeggiators can only synchronize to MIDI Beat Clock. To synchronize these devices to Pro Tools, you can transmit MIDI Beat Clock to them. Many plug-ins also support MIDI Beat Clock.

To transmit MIDI Beat Clock:
1. Choose Setup > MIDI > MIDI Beat Clock.
2. In the MIDI Beat Clock dialog, select the Enable MIDI Beat Clock option.
3. Select the devices you want to receive MIDI Beat Clock. If your MIDI interface does not support transmitting MIDI Beat Clock to separate ports, only the interface appears as a destination.
4. Click OK.

Spot Regions to SMPTE Frame Locations

(Pro Tools HD and Pro Tools LE with DV Toolkit Only)

Spotting is the process of assigning music and sound cues to specific SMPTE frame locations in a film or video. This function can be used to spot:
- Entire regions, selected with the Time Grabber tool. Multiple regions can also be selected, and Pro Tools will reference the first region in your selection.
- A specific location within a region, by clicking with the Selector tool at that location, and choosing Region > Identify Sync Point.
- Sessions or tracks, dragged from a browser to the session Timeline or Region List.

Spot Mode

In Spot mode, a region in a track can be quickly spotted by simply clicking it with the Time Grabber tool.

You can also drag a region from a DigiBase browser, or from the Region List, to a track while in Spot mode.

The Spot Dialog

The Spot Dialog appears when you drag a region to a track or click a region with the Time Grabber tool in Spot mode. The numeric fields function as both data displays and editing controls for the currently selected regions.
Information in these fields is displayed in SMPTE Time Code, Minutes:Seconds, Feet:Frames, Samples, or Bars & Beats, depending on which Time Scale format is selected.

A highlighted numeric field indicates the current active field for numeric entry editing. Entering a value in a field allows you to move a selected element to the time location that you enter. The Start, Sync Point and End fields are accessible when the Time Grabber tool is active. Only the Start or End (depending on where you click the mouse) and Duration fields are active when one of the Trim tools is active (see “Using the Trim Tools in Spot Mode” on page 664).

To increase or decrease SMPTE values in the Spot dialog by a specific number of frames, press Plus (+) or Minus (–) on the numeric keypad, enter a number, and press the Enter key.

**Use Subframes Option**

A subframe is 1/100th of a frame. The Use Subframes option enables you to use these smaller units for greater accuracy. This command adds an additional time field in the SMPTE hours:minutes:seconds:frames box, which appears as the far right time field when enabled. Use a Period (.) to separate subframe values from whole frames.

![Additional time field with "Use Subframes" enabled](image)

Subframe measurements are not available in the Current Time field.

**Capturing Time Code**

Pro Tools also allows you to easily capture frame locations on-the-fly in this dialog by pressing the Equal key, or by clicking the Current Time button while valid time code is being received by Pro Tools. With VITC, you can accurately capture a paused or “crawling” VTR’s SMPTE location.

When Time Code is selected for the Time Scale, pressing the Equal key captures the incoming time code. When Bars:Beats is selected for the Time Scale, pressing the Equal key will capture to the nearest measure.

Although the Capture Time Code button works with free-running Linear Time Code (LTC) or VITC, frame numbers of a paused frame can only be captured with VITC.

The SYNC I/O can read VITC. With Machine-Control and SYNC I/O, you can also read serial time code.

To use Remote mode with MachineControl, you will need an approved serial port. For a complete list of currently approved ports, see www.Digidesign.com.
To spot a region to a specific SMPTE frame:

1. Choose Window > Edit.
2. Set the Main Time Scale to Time Code. (See “Setting a SMPTE Session Start Time (Start Frame)” on page 650.)
3. Click the Spot button at the top left of the Edit window to put Pro Tools into Spot mode.
4. Identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
5. With the Time Grabber tool, click a region in a track, or in the Region List, and drag it into a track. The Spot dialog appears.
6. Enter the SMPTE frame location.
   - If you are using VITC, you can press the Equal (=) key on the numeric keypad, or click Current Time Code to enter a paused VTR’s current SMPTE location.
   - If you are using LTC, when Time Code is selected for the Time Scale, press the Equal (=) key on the numeric keypad to capture the incoming time code. When Bars:Beats is selected for the Time Scale, press the Equal key to capture the nearest measure.
7. If you recorded the region while online, you can use the Original Time Stamp button to recall and enter the SMPTE frame location at which the region was originally recorded. You can also access a user-defined Time Stamp in the same fashion. See “Time Stamping” on page 664 for more information.
8. Click OK to close this dialog. The region spots to the chosen SMPTE frame location. When the session is online, this frame number will trigger playback of the region.

Auto-Spotting Regions

The Pro Tools Auto-Spot Regions option simplifies the task of spotting regions even further. If you are using VITC with this option enabled, or MachineControl software, you can pause your video at an appropriate SMPTE frame location, click a region with the Time Grabber tool, and the region will be automatically spotted to the current time code location.

You can also use MachineControl’s serial time code ability to auto-spot by enabling MachineControl and enabling serial time code in the peripheral.

To Auto-Spot a region:

1. Choose Options > Auto-Spot Regions.
2. If you are using VITC, identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
3. Click the region with the Time Grabber tool. The region will be automatically spotted to the current time code location (or machine location).

💡 Clicking a region with any of the Trim tools will allow you to trim the region to the current time code location.

💡 Auto-spotted regions are spotted by their start times, unless you have identified a Sync Point (see “Identifying a Synchronization Point” on page 666). If the region contains a Sync Point, the region is spotted to it.
Using the Trim Tools in Spot Mode

You can use the Spot dialog to trim your regions, including start/end/duration times and referencing incoming time code addresses. If you click a region with any of the Trim tools in Spot mode, the Spot dialog will appear, allowing you to enter a value in the Start or End and Duration fields to specify exactly where you want to trim the region’s beginning or end. Use this to edit the length of a region to correspond to a particular visual “hit point.”

Trimming a region that contains a sync point (see “Identifying a Synchronization Point” on page 666) will not affect the SMPTE location of the sync point, unless the region is trimmed past the sync point.

Show Original Time Code in Regions

This command displays the original “time stamped” SMPTE times in all regions currently placed in tracks. This SMPTE frame number represents the time at which the region was originally recorded online with Pro Tools, and does not necessarily reflect the region’s current SMPTE location in a track.

To display Original Time Stamps in regions:
■ Select View > Region > Original Time Stamp.

To hide Original Time Stamps:
■ Select View > Region > No Time.

Creating a User Time Stamp

If you want to create a separate user-defined SMPTE time stamp, you can use the Time Stamp command in the Region List pop-up menu. This command lets you select a region (or regions) and redefine its SMPTE time stamp. The Original Time Stamp and the User-Time Stamp are then stored with your session.

When audio is first recorded, the User Time Stamp will match the Original Time Stamp, but you can change the User Time Stamp at any time using the Time Stamp command. This feature is particularly useful in post production situations where the SMPTE time code on video “work prints” often changes from one edit revision to another.
Chapter 34: Working with Synchronization

To time stamp a region (or regions) with a new SMPTE frame number:

1. In a track, select the region that you want to time stamp.
2. From the Region List pop-up menu, choose the Time Stamp command.
3. Enter a new SMPTE time by doing one of the following:
   • Enter the numbers manually (with the help of the arrow keys).
   • Click the Current Time Code button (or press the Equal key), if you want to capture the incoming time code address.
   • Click the Current Selection button, if you want to enter the start time of the current on-screen selection.
4. Click OK to close this dialog.

This command can be used in “batch mode” to set new time stamps for several regions at a time. To do this, simply select several regions and choose the Time Stamp Selected command. One after another, a dialog will open for each region, allowing you to quickly enter new values.

Once entered, the user time stamps can be displayed in all regions currently placed in tracks.

To display User Time Stamps in regions:
- Choose View > Region > User Time Stamp.

To hide User Time Stamps:
- Choose View > Region > No Time.

Pro Tools 5.x and Using a Region with User Time Stamp in Another Session

In Pro Tools 5.x, user time stamp information is saved for each region as part of a session—not as part of the audio file itself. Exporting the region as a file will produce a file that has the time stamp information included in it.

To use a Pro Tools 5.x time-stamped region in another session, and keep its time stamps intact:

1. Open the session that contains the original time-stamped region.
2. In the Region List, select the region you want to export.
3. From the Region List pop-up menu, choose Export Regions as Files.
4. From the Export Selected dialog, configure export options.

For more information on Export Selected options, see “Exporting a Region as a New Audio File” on page 131.

5. Click Export to export the new audio file.

The region can now be used in other sessions with its original time stamp references intact.
Identifying a Synchronization Point

The Pro Tools Identify Sync Point command allows you to identify a specific point within a region for audio spotting purposes.

Imagine the following sound effects spotting scenario: You have a single sound effect that consists of a creaky door slamming shut, followed by a few seconds of ambient reverberation. The slam portion of the effect—which you must precisely match to picture—occurs neither at the very beginning of the audio file nor at the very end. It is somewhere in the middle, making it tough to spot.

In this scenario, use the Identify Sync Point command to create a point in the region and synchronize that point to a SMPTE frame.

Creating Sync Points

To create a sync point in a region:

1. Click with the Selector tool at the point in the region that you want to synchronize to a SMPTE frame location.

   — or —

   Press the Down Arrow key while playing back.

2. Choose Region > Identify Sync Point. The current SMPTE time is automatically entered as the SMPTE location for the sync point. A small down arrow appears at the bottom of the region, with a vertical, light grey line indicating the location of the sync point.

Removing Sync Points

To remove a sync point, do one of the following:

- Select the entire region and choose Region > Remove Sync Point.
  – or –

- Alt-click (Windows) or Option-click (Macintosh) the sync point to delete it.

Displaying Sync Points

Sync points in audio regions may displayed or hidden.

To disable the display of sync points in audio regions:

- Deselect View > Region > Sync Point.

To enable the display of sync points in audio regions:

- Choose View > Region > Sync Point.

Dragging Sync Points

You can drag a sync point to another position in the audio region.

To reset the sync point by dragging:

1. If you want the sync point to snap to the current Grid value, set the Edit mode to Grid.

2. Select any Grabber tool.

3. Drag the sync point to a new location in the region.
Scrubbing Sync Points

While viewing an audio waveform can be a good way to set a sync point, a waveform display may not always reveal the desired sync point spot in the audio material. By scrubbing while moving the sync point over an audio waveform, you can listen for the exact sync point.

To scrub while dragging the sync point:

1. If you want the sync point to snap to the current Grid value when you finish scrubbing, set the Edit mode to Grid.
2. Select the Scrubber tool.
3. Drag the sync point to a new location. The sync point will scrub the audio as you move it.

Troubleshooting Synchronization

Getting SMPTE synchronization to work properly can seem like a formidable task at times. The following suggestions may help you troubleshoot and solve common problems.

Use the Incoming/Current Time Field in the Session Setup Window as a Reference

The Current Time field in the Session Setup window indicates whether or not Pro Tools is receiving time code. If this field appears to be inactive when inputting time code into your time code reading device, check your hardware device settings, the device’s connection to your computer, and your Multimedia Setup (Windows) and AMS (Macintosh).

When using MachineControl, the Current Time field will display 9pin code, even though the LTC device may not be connected.

Stripe SMPTE Before You Record

All tapes in your setup (both audio and video) must be striped with SMPTE Time Code before any audio is recorded onto them or to Pro Tools. If tapes aren’t striped, your system may seem to work, but synchronization will never properly occur. The machines and Pro Tools will drift farther and farther apart the longer they run.

The same problem occurs when audio is recorded into Pro Tools without a resolved SMPTE source (for example, if it was recorded before the current session). The audio cannot be accurately synchronized with an analog tape recorder or video tape deck, since the Pro Tools audio was not recorded referenced to the SMPTE time code from the analog tape deck or video tape deck.

Resolve All Components of Your System

When striping time code, make sure that the time code generator and the video record deck are resolved to the same crystal reference. For example, when striping 29.97 Drop Frame time code onto a VTR, both the SMPTE generator and the VTR should be resolved to the same “black burst” or house sync generator. During playback, the master deck should be resolved to “black burst” or house sync.

This convention provides compatibility for your tape between the record and playback passes, and when it’s played back in other facilities on different equipment. This also means that when
playing back a tape striped with time code, the playback deck should be resolved to the same synchronization rate as the record deck was resolved to at the time of the striping. When you stripe time code using an audio transport, it should be “free-running” and unresolved, but should be resolved with a house sync-referenced synchronizer during playback.

Know the True Frame Rate on Your Work Tape

If you get your video tapes from a production company instead of recording them yourself, be absolutely sure that they indicate the SMPTE frame rate used on the tape correctly. Several time code formats use the same frame count (such as 23.976 fps and 24 fps) yet they run at slightly different frame rates per second.

The Digidesign SYNC I/O (and some third-party products) can be used to help determine frame rate. See “Determining SMPTE Frame Rate” on page 649.

29.97 fps Non-Drop Rate Not Recognized

29.97 fps Non-Drop is a slightly slower version of 30 fps Non-Drop time code. When used with color video, each video frame now matches up with each SMPTE frame without having to use a drop-frame coding. This makes any frame number mathematics much simpler, since no frame numbers are dropped.

Unfortunately, some hardware and software devices do not recognize 29.97 Non-Drop as a separate frame rate. For example, any standard SMPTE-to-MTC-converter does not explicitly recognize it. The user must tell the converter to expect 30 fps Non-Drop instead. In fact, many devices that read SMPTE work acceptably by reading 29.97 Non-Drop if they are set to expect 30 fps Non-Drop.

Any SMPTE reader that uses the time code numbers to make real-time calculations (as Pro Tools does when it tries to trigger and synchronize to SMPTE) also needs to know that the frame format is 29.97 and not 30 fps. Since Pro Tools allows this choice of frame rate this does not really pose a problem. The problem exists because many users cannot readily distinguish 29.97 from 30 fps.

Even though NTSC tapes only use 29.97, some production companies will distribute video work prints striped with 29.97 fps but mark them as “30 fps NTSC,” by which they actually mean 29.97 fps Non-Drop.

By the time you get the tape, you may have no idea what’s actually on it. Feeding 29.97 Non-Drop to Pro Tools when it’s set for 30 fps Non-Drop will result in timing errors of about 1.8 frames per minute, causing audio playback to trigger out of sync.

Be Careful When Changing Frame Rates

If you change time code rates in the middle of a session, many SMPTE-to-MIDI Time Code converters need to be turned off and turned on again to be able to recognize the new frame rate.

Use a Consistent Clock Source

When possible, sound files should be played back using the same sync reference signal it was recorded with. This assures the closest match between record and playback sample rates.

Disable Screen Savers and Power Management Features

These types of software can cause your computer to ignore MIDI data (such as MIDI Time Code).
Chapter 35: Working with QuickTime Movies

You can use Pro Tools to import QuickTime movies and audio (such as MP3s), perform audio post production tasks, and export the finished product as a new QuickTime movie.

About QuickTime

QuickTime is digital video technology designed to produce compact video files for multimedia use.

Using QuickTime Movies in Pro Tools

Pro Tools allows you to import QuickTime movies into your Pro Tools sessions.

Once imported into Pro Tools, a QuickTime movie is displayed in its own Movie track in the Edit window, and in a floating Movie window. This floating window can be viewed on a second monitor with appropriate video hardware (including FireWire output of QuickTime DV). With a QuickTime movie in the session, Pro Tools serves as a fast, random-access visual reference for “sweetening” the movie by adding sound effects, music, foley, dialog, or other audio.

Pro Tools Movie track displayed as frames

Pro Tools Movie window

Pro Tools provides precise, frame-accurate audio and video synchronization. This means you can use your Pro Tools system as an off-line audio editing system, leaving the video editing suite free for video editing.
With Pro Tools, you can:

◆ Import a QuickTime movie into a session
◆ Import audio from a QuickTime movie
◆ Import audio files from a CD or a CD-ROM
◆ Import audio from an audio CD (Macintosh only)
◆ Synchronize audio events to a QuickTime movie, using the Pro Tools editing features to spot and nudge regions to video frames
◆ Scrub audio elements in tandem with a QuickTime movie
◆ Use the Pro Tools Bounce to QuickTime Movie command to compile a new “flattened” QuickTime movie file that can be read by any QuickTime-compatible application

If you want to edit or in any other way modify a movie, return to your video capture and assembly software (such as Avid Xpress DV) for editing, then import the edited movie into Pro Tools.

💡 You can capture Avid-compatible video in Pro Tools with AVoption|V10.

### Video Capture/Playback Cards

For professional applications where full-screen, 25/30 frames-per-second playback is critical, we recommend that you invest in a Digidesign-approved third-party video capture and playback card, or an external DV Firewire device.

For more information on compatible video capture cards, visit the Digidesign Web site.

### If You Are New to Audio Post Production

If you are new to digital video, time code, or audio-for-post production, the following suggestions will help you manage your session’s audio and video requirements. Not all of these may apply to every project.

**Plan Ahead** Think through your entire project before you start capturing your video. For best results when working with SMPTE time code, make sure that time code is burned into a window in the movie. Try to anticipate compatibility and configuration issues that may arise.

**Make Sure your Movie is Conformed** Be sure to conform your captured QuickTime movie to the desired frame rate. Consult your video capture software’s documentation for information on how to ensure frame-accurate captures. We recommend that you do this to all video captures to ensure accurate playback in Pro Tools.

In Pro Tools 5.2.x and lower, if your destination is a pulled-down Pro Tools session, this pull down affects QuickTime movie playback speed. You should conform your movie to a 30 fps frame rate for use in a pulled-down session.

**Destined for Video or Film?** What is the ultimate destination of your work? Is it for DVD, HD, TV, film, audio CD or CD-ROM? This will determine such things as the best sample rate to use, the correct time code rate, and pull-down or pull-up rates. Double-check the time code frame rate. You must make sure that you know the correct frame rate of the video source.

**Storage** Make sure you have enough disk space on your drive, and optimize your hard drives regularly.
**Video Compatibility** If you are not digitizing the video material yourself (if the material is already on hard disk) check into the type of video capture and playback system that was used and make sure you can accommodate that format’s compression method. Check whether or not time code is “burned into” or superimposed over a small area of the video.

---

**QuickTime Requirements**

Pro Tools supports playback of QuickTime videos without additional hardware. However, with older Macintosh computers that had video inputs, performance will vary in terms of maximum movie size, frame rate, and smoothness of playback. Capture of 30/25 fps (frames per second), 60/50 fields-per-second video requires a video capture card, and associated software and hardware.

**About Frame Length and QuickTime Movies**

Not all video capture software can guarantee consistent frame lengths. Refer to your video capture software documentation for information on ensuring frame-accurate captures, and on conforming your video to proper frame boundaries.

To take advantage of Pro Tools QuickTime movie playback capabilities, you will need the following:

- QuickTime movie playback and editing software (such as Avid XPress DV) to edit and compile QuickTime movies.

Optionally, you may also need:

- QuickTime movie capture hardware and software to digitize your own movies from a video tape or video camera source.
- A DVD or CD-ROM drive to take advantage of commercially-available QuickTime movies and sound clips.

---

**QuickTime Movie Playback Performance Options**

The Operation Preferences page provides three options for QuickTime Playback Priority: Normal, Higher, and Highest. In most cases, you should leave the performance choice set to Normal. If you are running QuickTime Movies natively, that is, without a capture card, you may need to use one of the other playback performance options. If this does not apply to you, leave QuickTime Playback Priority set to Normal. This is the default setting.

![See also “FireWire Playback of QuickTime DV Movies” on page 673.](image)

**Hard Drive Tips for Best Performance**

If possible, connect the hard drive you are using for video capture and playback on a different SCSI, ATA/IDE, or FireWire bus from the drive with your audio files. This minimizes interference between drives when Pro Tools requests audio and video data. With most capture cards, and moderate data capture rates (800 kilobytes per second or less), this should provide good performance.

For complete information on hard drive requirements, visit the Digidesign Web site.
Importing a QuickTime Movie

Before you import a movie, you should digitize your video material and know the correct frame rate and sample rate when applicable.

⚠️ If a video card with hardware video compression was used to create the QuickTime movie, Pro Tools cannot play the movie without the compression hardware. Make sure the video card is installed and configured correctly before starting your session.

To import a QuickTime movie into Pro Tools:

1. Launch Pro Tools and create a new session, or open an existing one.
2. Check the time code settings of the session to make sure they match those of the movie you want to import, and save the session.
3. Choose File > Import > QuickTime Movie.
4. Select the movie and click Open. Pro Tools imports the movie and displays it in its own Movie track in the Edit window as well as in a floating Movie window. The first frame of the movie is automatically placed at the start time of your session.

About the Movie Track

Once a movie is imported into Pro Tools it appears in the Edit window in its own Movie track. Depending on the Track View setting of your Movie track, the movie displays as blocks, or as a picture-icon (picon) “thumbnail” overview of the frames of the movie it represents. The Movie track will show greater or lesser detail depending on your current zoom level in the Edit window—the closer in you zoom, the greater the number of individual frames that are displayed in the Movie track; the farther out you zoom, the fewer the number of individual frames that are visible.

The Movie track behaves much as a Pro Tools audio or MIDI track in that you can move the movie region with the Time Grabber tool or other editing tools. This allows you to offset the movie to any start point. However, you cannot edit the Movie track by trimming it or capturing regions from within it.
Only one QuickTime movie can be associated with a session at a time. If you want to import a different movie into a session, repeat the previous steps. The new movie will replace the original in the session. A Movie track takes its name from its associated movie file and cannot be independently renamed.

**Frames View Performance**

When using Frames View to view movie content in the Movie track, your computer may exhibit reduced or sluggish performance. If this happens on your computer, switch the Track View of the Movie track to Blocks mode.

*You can also hide the movie track to further optimize performance, if necessary.*

**FireWire Playback of QuickTime DV Movies**

With the addition of an external DV transcoder (decoder), you can play QuickTime DV Movies out through your computer’s Firewire port. These can include QuickTime movies exported as QuickTime DV from Avid Xpress DV.

*Although Firewire playback of DV movies in Pro Tools is supported on Macintosh computers, best performance is achieved by running the DV movie from the Macintosh’s internal ATA drive.*

For the latest compatibility information on Firewire transcoders, see the Digidesign Web site (www.digidesign.com).

QuickTime DV performance may vary, depending on the specifics of your system and projects.

**Supported QuickTime Movies**

**Referenced and Consolidated Media** Exported QuickTime DV movies can be either complete QuickTime files (where media is copied into a Quicktime file) or Quicktime reference files (where just a small composition is in the Quicktime file which references the original DV files).

**Codec Requirements** When exporting from Avid Xpress DV, always use the Apple DV codec. Do not enable “Use Avid Codec” in the export dialog. If an Avid-codec DV movie is imported into Pro Tools, you will not be able to play it.

**DV Stream Movies** Pro Tools does not support audio from a DV Stream file. DV Stream files contain the entire data stream that’s been transferred or recorded over the FireWire cable from a camera. In this type of file, the audio and video data are stored in an interleaved fashion, as opposed to a QuickTime file where audio and video are stored separately.

*See also “Exporting QuickTime DV from Avid” on page 674.*

**To Play QuickTime DV Movies through the FireWire Port:**

1. Import a QuickTime DV movie into a Pro Tools session by choosing File > Import > QuickTime Movie.

2. Choose Options > QuickTime DV Out Firewire.

When this item is enabled, Pro Tools will play DV movies (NTSC or PAL) out the FireWire port to an external DV decoder. This can improve system performance by removing the need for the movie to be software decompressed by the CPU and displayed on the computer screen.
If the desktop Movie Window is open when video is playing out the FireWire port, it will display the text “DV Movie Is Playing Out FireWire Port.”

**Delay Between Video & Audio**

There can be a considerable delay between video and audio playback when using this feature.

**To compensate for delay between audio and video playback:**

1. Choose Setup > QuickTime Movie Offset.
2. Enter a value appropriate to align the audio with video.

Generally, you will need to set this value once for each type of DV decoder used.

*For a list of Digidesign-qualified video capture cards and transcoders, see the Digidesign Web site ([www.digidesign.com/compato](http://www.digidesign.com/compato)).*

**Exporting QuickTime DV from Avid**

The following instructions list export settings for Avid XPress DV. These settings are required to create QuickTime DV movies that can be played back in Pro Tools through the Firewire port.

**To export a QuickTime DV reference movie for Pro Tools Firewire playback, set the following:**

1. Enable the following export options:
   - Flatten video tracks
   - Fill in spaces with black
   - Render all video effects
   - Use Apple DV Codec
   - Enable the Apple DV codec
2. Make sure Use Avid Codec is not enabled.

*These export settings can be saved in Avid XPress DV3.0 as a default, simplifying future media exchange. Refer to your Avid XPress documentation for more information on export settings and defaults.*

**Scrubbing the Movie Track**

You can use the Scrubber tool to scrub a Movie track with full-frame accuracy. If you scrub directly on the Movie track, only the movie will scrub (no audio will play). If you scrub on an audio track, audio and the movie will scrub simultaneously.

**To scrub a Movie track:**

1. Select the Scrubber tool.
2. Click in the Movie track and drag the Scrubber.

*To scrub with finer precision, press the Command key while scrubbing.*

---

674 Pro Tools Reference Guide
About the Movie Window

The Movie window displays the movie playback or the current frame if playback is paused or stopped. You can drag the Movie window anywhere on your computer screen.

To display the Movie window:

- Choose Window > QuickTime Movie. If a movie has already been imported, the Movie window will appear.

See also “FireWire Playback of QuickTime DV Movies” on page 673.

Using a 14-inch Monitor for Playback

If you capture 320 x 240 (NTSC) movies and have a second monitor with 640 x 480 resolution (a standard 14-inch monitor), clicking on the Movie window will route movie playback to that monitor. The Movie will “bounce” over to the second monitor, and will be pixel-doubled so that it takes up the whole screen.

Tips for Optimizing Movie Playback

Since Pro Tools uses QuickTime to play movies, the quality of the playback is dependent on the speed of your computer and hard drive, the size (in pixels) of the movie, and the quality of the video hardware used to capture and play back the digitized video. While QuickTime doesn’t produce broadcast-quality playback, it is frame accurate when spotting to picture.

On PCI-based computers, Pro Tools continuously re-syncs the movie. The movie resolves to the audio sample clock. This allows the movie to smoothly track the audio even when your system is varispeeded.

For more consistently smooth movie playback, here are some suggestions:

- Use a Digidesign-approved video capture and playback card for 25/30 frames-per-second full-screen movie playback.
- Display the movie on a separate monitor driven by a video capture and playback card.
- If you do not have a video capture and playback card, set the QuickTime Playback Priority option to Higher or Highest in the Operation Preferences page. This gives priority to movie playback, rather than other screen graphics tasks such as moving faders.
- Use the fastest computer possible.
- Capture and play QuickTime video from a separate hard drive than your Pro Tools audio drives.
- Disable the Automation preference for Faders Move During Playback.
- Set Scrolling option to None (Options > Scrolling > None).
- Reduce the size of the Edit window to the smallest possible size.
- Close unnecessary windows.
- Reduce the overall length of the SCSI chain of your computer system for improved throughput.
◆ Reduce the pixel size of the movie (for example, reduce it from 640 x 480 pixels to 320 x 240 pixels).
◆ Hide the video track when not needed.
◆ When using video capture cards or transcoders to play back externally to the computer monitor, it may be necessary to keep the QuickTime window open in order to output the movie. In these cases, you can improve screen management by keeping the movie small and out of the way on your computer monitor.

To reduce the size of the QuickTime window using QuickTime Player:
1. Close the session.
2. Open the movie in QuickTime Player, and resize the movie so it is very small.
3. Choose Save, then Quit QuickTime Player.
4. Open the session, and move the QuickTime window away from any Pro Tools windows.

Setting the Movie Start Time (Movie Offset)

When you import a movie into your session, the first frame of the movie defaults to the start time of the session. In some cases, however, you may need to offset the movie by some amount forwards or backwards so that you can accurately spot audio to the movie.

Since a movie can be moved inside the Movie track, it is fairly easy to match these two times. In fact, you may not have to move the Movie track at all.

For finer adjustment of a movie’s start time, you can use the QuickTime Movie Offset command to offset the movie in 1/4-frame increments. This is more accurate than dragging the Movie track, and is especially useful in cases where your movie track happens to begin with a partial frame.

To set the movie offset:
1. Double-check that the session’s SMPTE frame rate matches that of the movie.
2. Choose Setup > QuickTime Movie Offset, enter an offset value, and click OK.
3. Lock the movie in place by choosing Region > Lock/Unlock.

To spot the movie to a sync point:
1. Double-check that the session’s SMPTE frame rate matches that of the movie.
2. In the Edit window, enable Grid mode.
3. Set the session time display to SMPTE.
4. Set the Grid value to Time Code.
5. With the Selector tool, click in the Movie track to place the cursor where you want to create a Sync Point. Often, the best spot will be the “2 beep” two seconds before the first action frame (the start of the video). You can use the plus and minus keys on the QWERTY keyboard to nudge the cursor and the movie one frame at a time.
6. Choose Region > Identify Sync Point to place a Sync Point at the current cursor location.
7. Enable Spot mode by clicking the Spot button in the Edit window.
8 Click the Movie track with the Time Grabber tool. The Spot dialog appears.

9 Enter the time code number displayed in the window-burn of the frame you are spotting to (if the movie has a SMPTE time code window burned into it) and click OK.

The movie’s sync point moves to the SMPTE location you entered.

---

Spotting Audio to a QuickTime Movie

For accurate spotting, Grid mode provides you with an effective tool for quick and accurate selection of waveforms, and alignment of regions in tracks. When Grid mode is enabled, the Selector tool will snap to the current Grid value, and regions selected with the Time Grabber tool and dragged to a track will also align up with the Grid value.

Make Sure Your Movie is Conformed

Before you spot audio to a movie, you should make sure the movie file is conformed so that each frame starts and ends at valid frame boundaries. The movie should be conformed to a time code rate that Pro Tools can work with (30 fps or 29.97 fps).

Consult your video capture software documentation for more information.

More Tips for Spotting Audio

- Specify your movie size up front. For purposes of spotting audio, 320 x 240 is usually adequate. If you are displaying the movie on a second monitor with 640 x 480 resolution, with pixel doubling, it will fill the screen.
- Try to work with a window burn in the movie, since it will help you spot material. You can produce your own window burns for the capture using Digidesign’s SYNC I/O.
- Set the Scrolling option (in the Options menu) to Continuous or Center Playhead.

⚠️ The Continuous and Center Playhead options require more CPU power, and may degrade the quality of your movie playback.

Using Grid Mode to Spot and Nudge Regions with Frame Accuracy

(Pro Tools HD and Pro Tools LE with DV Toolkit Only)

Grid mode allows you to constrain the movement of regions so that they snap to SMPTE-based measurements (minutes, seconds, frames, or subframes).

To spot audio to a movie:

1 Click the Grid button at the upper left corner of the Edit window. This ensures that the audio will align to a frame boundary.
2 Set your Grid value to Time Code using the pop-up menu.
3 Choose a desirable Grid unit setting. Note that you can set the grid units independently of the Main Time Scale.
4 Using the Selector tool, place the insertion cursor at a location in the movie. If you want, use the Nudge value pop-up to set the nudge units to frames. You can then use the plus and minus keys on the QWERTY keyboard to nudge the insertion point frame by frame.
While pressing the Control key, drag a region from the Region List to the appropriate track. Pro Tools will automatically spot the region to the same time location as the cursor.

To spot elements directly to locations in the movie, use the technique described above. In this scenario, Auto Spot mode is not recommended, since it uses incoming MTC for location information.

Importing QuickTime Audio (and Other Compressed Video Files)

Pro Tools allows you to import audio directly from a QuickTime movie. You can import audio from a movie currently loaded into a session, or from a different movie. The procedure is the same for both.

Pro Tools supports the following compressed QuickTime file formats:
- MP3
- QDesign
- uLaw 2:1
- aLaw 2:1
- Intel ADPCM
- Microsoft ADPCM
- IMA 4:1
- 32-bit floating point
- 64-bit floating point
- 16-bit Big Endian
- 16-bit Little Endian
- MACE 6:1
- MACE 3:1

QuickTime files can be imported into sessions using the Import Audio from Current Movie command (if the QuickTime Movie is already in the session) or the Import Audio from QuickTime Movie menu command.

Sample Rate Conversion Quality

If you import QuickTime audio that was not originally recorded at the session’s sample rate, the sample rate is converted to match the audio to your session. Pro Tools allows you to choose the quality of the sample rate conversion by means of the Conversion Quality setting in the Editing Preferences page.

There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality of sample rate conversion, the longer it takes to convert the bounced file.

To set the sample rate conversion quality:
1. Choose Setup > Preferences and click the Editing tab.
2. Click the Conversion Quality pop-up menu and select a conversion setting.

Importing Audio from a QuickTime Movie

You can use the Import Audio from Current Movie command to import audio tracks from a QuickTime movie currently in the session. To import audio from other QuickTime movies on your hard disk or on CD (Macintosh only), use
the Import Audio from QuickTime Movie command, or drag and drop tracks from the DigiBase browser, Windows Explorer or Macintosh Finder, or a folder.

To use DigiBase to import audio from CDs with drag and drop, see “Importing Audio Files and Regions with Drag & Drop” on page 123.

For additional details on using DigiBase, refer to the DigiBase Guide.

To import audio tracks from a QuickTime movie (using menu commands):

1. Do one of the following:
   - If you want to import audio from a QuickTime movie that is already in the session, choose File > Import > Audio From Current Movie.
   - or –
   - If you want to import audio from a QuickTime movie that has not been imported into the session, choose File > Import > Audio from QuickTime Movie.

2. Select the QuickTime movie from which you want to import audio. The Track Import dialog appears, listing information about the audio tracks.

3. Select the audio tracks you want to import by clicking them. To select multiple tracks contiguously in this dialog, Shift-click them. To select discontiguous tracks, Command-click them.

4. Click OK. The audio is converted to the session’s sample rate and bit resolution, and a new region appears in the Region List for each imported file (two regions appear for each imported stereo file). The regions are listed in the Region List with the region name, the number of the originating track, and the number of the region from the track.

5. Drag the imported regions from the Region List to tracks in your session.

---

Bouncing to a New Movie

When you have finished your final mix and synchronized your audio events to the movie, you can use the Pro Tools Bounce to QuickTime Movie command to compile a new QuickTime movie with the bounced audio embedded in the QuickTime movie file as the soundtrack. As a QuickTime file, the new movie is supported by all software applications that support QuickTime video.

To create a new QuickTime movie with bounced audio embedded as the soundtrack:

1. Adjust track output levels and finalize your mix. Any inserts and effects settings that are active on tracks will be permanently written to the bounced tracks.

2. Make sure that what you are hearing is what you want to bounce, and that your “bounce-to-disk” output assignments correspond to the outputs you are listening to.
3 If you want to bounce the entire session, press the Return to Zero button on the Transport to go to the beginning of the session. The new movie file will include all the video and audio material in the session, even if the duration of the video material is longer than the audio or vice versa. If you only want to bounce a portion of a session, open the Edit window and select the section that you want to include in the bounce.

4 Choose File > Bounce to > Quicktime Movie.

5 Select the file format for the movie audio. Choose Stereo to retain the stereo mix of the session for the movie audio. Choose Mix-to-Mono to combine the left and right channel output of the session to a mono movie soundtrack.

6 Select the resolution for the movie audio. Red Book audio CDs are always 16-bit, while some multimedia presentations and CD-ROMs use 8-bit resolution. You cannot create a QuickTime movie with 24-bit audio; audio from 24-bit sessions is converted to 16-bit or 8-bit audio, depending on what you choose.

7 If you intend to convert the session to 8-bit resolution for use in multimedia, use the Squeezer option (click the Convert after Bounce option, then the Settings button to access this feature) to improve the fidelity of the converted 8-bit audio. This option uses a proprietary DSP algorithm that preprocesses the audio using compression, limiting and gating before converting to 8-bit resolution. This option is recommended for optimal results for 8-bit audio.

8 Select the Sample Rate for the movie audio (click the Convert after Bounce option, then the Settings button to enable this choice). The default audio sample rate is 44100 (44.1 kHz), which is the standard sample rate for audio CDs. Multimedia presentations and CD-ROMs may use a sample rate of 11025 (11.025 kHz) or 22050 (22.050 kHz).

9 Click Bounce, name the new movie, and choose where to save it.

10 The audio tracks are converted to the selected sample rate and bit resolution, and a new flattened movie is created incorporating the audio. You can open and play the flattened movie in any software application that supports QuickTime.

Mix-to-Mono may result in clipping if you do not leave 6 dB of headroom in the mix.

Pro Tools sample rate and bit resolution conversions use large amounts of processing power. You can save time by selecting a lower sample rate conversion quality in the Editing Preferences page.
Glossary

9-pin (Sony 9-pin; DB-9) Industry standard for serial machine control of professional video and audio transports, made by Sony and other manufacturers. Refers to the DB-9-style physical external control connector found on 9-pin-compatible devices.

Absolute Grid mode An editing mode that constrains movement and alignment of regions to precise increments on a user-defined grid. See also Relative Grid mode.

A/D (analog-to-digital) Analog-to-digital converters operate at various bit-rate resolutions and sampling rates, converting analog audio signals to digital audio signals.

ADAT lightpipe Standard industry term for optical connection of digital audio. Created by Alesis, the lightpipe can simultaneously stream eight channels of digital audio.

address (time code address) Specific SMPTE/EBU time code reference or reading, in hours:minutes:seconds:frames.

AES/EBU (Audio Engineering Society/European Broadcasters’ Union) Industry professional standard for transferring digital audio between professional-quality audio devices. Most AES/EBU connections utilize an XLR-style 3-pin connector to carry two channels of digital audio.

AIFF (Audio Interchange File Format) An Apple Computer audio file format.

AMS (Audio MIDI Setup) Apple Computer’s audio and MIDI operating system, which is part of Mac OS X. For Macintosh users, AMS replaces Opcode Systems’ OMS (Open Music System).

ASIO Driver The Digidesign ASIO Driver is a single-client, multichannel sound driver that allows ASIO third-party audio programs that support the ASIO Driver standard to record and playback through qualified Digidesign audio interfaces.

ATR (Audio Tape Recorder) A tape recorder of any format, including a Digital Audio Tape (DAT) deck.

audio interface Among most Pro Tools systems, the audio interface is a separate box that is attached with a special cable to the audio card, or to a USB or FireWire port. An audio interface typically has analog and digital audio inputs and outputs, and may be equipped with level meters, level controls, and other features.

audio region A region of an audio file that is defined nondestructively with pointers. See also region.
AudioSuite plug-in: Digidesign’s proprietary file-based, non-real-time plug-in format. AudioSuite plug-ins are used to process and modify audio files on disk, rather than nondestructively in real time. Depending on how you configure a non-real-time AudioSuite plug-in, it will either create an entirely new audio file, or alter the original source audio file.

Audition: Listening to, or “monitoring,” one or more tracks or audio files. In Pro Tools, you can audition files before you load them into the program. There are also various ways to audition takes from the Region List, the Takes List pop-up menu, and from DigiBase browsers.

Auto-created region: Automatically created regions are a by product of editing and punch recording over existing regions.

Automation modes: Function for recording and playing changes in volume levels, panning, and virtually every adjustable parameter (including plug-in parameters) in Pro Tools. There are several different automation modes in which to write automation data in Pro Tools.

Aux: See Auxiliary Inputs.

Auxiliary Inputs (Auxiliary Input Tracks): In Pro Tools, these input channels are used for send and bus returns (input only). Sends are used for output routing.

Auxiliary send: See send.

Avid DNA Video Peripheral: Avid interface (such as Avid Mojo) that integrates Avid video technology with Pro Tools systems.

AVOption|V10: Video interface and software that integrates Avid video technology with Pro Tools|HD systems.
clipping, clipping indicator the LED at the top of each channel meter indicates a level may have run out of headroom, and is approaching clipping.

clock reference Common “speed” reference, which various devices can use to establish synchronization during playback and recording.

Conductor rulers A ruler that can show session data. There are three types of Conductor rulers, called Tempo, Meter, and Markers rulers.

continuous controller data MIDI instructions that affect MIDI note parameters, including volume, panning, velocity, pitch bend, and modulation. Also, the main type of instructions sent by MIDI control surfaces.

Control|24 Digidesign-dedicated controller for Pro Tools systems. Includes 16 premium microphone preamps, a control room monitoring section, and a line submixer. Ideal front-end for Pro Tools recording, mixing, and editing.

CoreAudio The Digidesign CoreAudio Driver is a multi-client, multichannel sound driver that allows CoreAudio compatible applications to record and play back through qualified Digidesign audio interfaces.

crossfade Function for fading out from one region as you fade in to another region. Crossfade duration is user-selectable from within the Edit window. As with fades, portions of audio for which the crossfade function has been applied are stored in the session’s Fade Files folder.

D/A (digital-to-analog) Digital-to-analog converters operate at various bit-rate resolutions and sampling rates, converting digital audio signals to analog audio signals.

DAE (Digidesign Audio Engine) Digidesign’s real-time operating system that provides the core functionality of hard disk recording, digital signal processing, mix automation, and MIDI required by Pro Tools and other Digidesign products.

database Databasing is a convenient way of storing, organizing, searching, and displaying information. A database file is a collection of records that hold data. In this guide, the term “database” refers to a DigiBase database file. Pro Tools creates and stores database files on local volumes as needed.

DB-9 See 9-pin.

Digi 002 Digidesign’s FireWire-based Pro Tools LE studio with integrated control surface. Includes eight touch-sensitive, motorized faders and 8 motion-sensitive rotary encoders, eight analog inputs and outputs, four mic preamps, eight channels of ADAT optical I/O, two channels of S/PDIF I/O, and 24-bit/96 kHz A/D and D/A converters.

Digi 002 Rack Rack version of Digidesign’s Digi 002. This FireWire-based Pro Tools LE system includes eight analog inputs and outputs, 4 mic preamps, eight channels of ADAT optical I/O, two channels of S/PDIF I/O, and 24-bit/96 kHz A/D and D/A converters.

Digidesign Audio Engine See DAE.

dither “Noise” added to an audio signal when down-sampling bit rates. Designed to create a smoother transition at lower amplitudes.

drop frame Refers to a variance of SMPTE/EBU time code for NTSC color video (29.97 fps) that omits two frames (frames “0” and “1”) every minute except for every tenth minute.
DSP (Digital Signal Processing) In audio terms, DSP refers to manipulation of digital audio—everything from reverberation to changes in level.

edit cursor Flashing line that appears when you click in a track in the Edit window.

Edit Decision List (EDL) List of edits, or events, typically with each event’s respective source in and out times, source reel number, and record in and out times.

Edit insertion point Location within a track where you click (without dragging); also location at which a region’s start, end, or synchronization point will be placed.

Edit selection In the Edit window, this is what is highlighted in the playlist (such as a region).

Event List See MIDI Event List.

expansion chassis Expands the capabilities of Pro Tools|HD systems by adding more external PCI slots.

ExpressPro-Tools ATTO’s hard disk utility for the preparation of hard drives for Pro Tools. For Mac OS X, a new version of this utility, ExpressStripe, must be used.

fade A selection in which the volume rises or falls, typically from or to –∞. See also crossfade.

FireWire A high-speed peripheral standard capable of transferring data. FireWire is commonly used for digital audio and video devices, as well as external hard drives and other high-speed peripherals.

frames per second (fps) Number of frames that elapse per second, as defined by the four SMPTE/EBU Time Code fps standards. These include:

- 24 fps (for film applications)
- 25 fps (the PAL/SECAM video standard)
- 29.97 fps (the NTSC color video standard) (see also drop frame)
- 30 fps (the NTSC black and white video standard)

general preference A preference that affects all sessions for the same user. This differs from a global preference, which is the same for all users. See also user preference.

Grid mode Used to align regions in tracks to the grid or between Grid boundaries. See also Absolute Grid mode and Relative Grid mode.

Groove Template A template derived from an audio selection using Beat Detective. Groove templates contain information on the timing nuances and dynamics of the selected audio performance. Groove templates can then be used to conform or impose these performance characteristics on other audio material using Beat Detective, or on other MIDI material using the Grid/Groove Quantize command.

groups Linked tracks in which an action in one of the tracks is mirrored in all tracks in the group. Groups can be created separately or linked between the Mix and Edit windows.

HD Accel PCI card with additional DSP for Pro Tools|HD systems.

HD Core PCI core card, which connects to audio interface and contains the DSP, for a Pro Tools|HD system.

HD Process PCI card with additional DSP for Pro Tools|HD systems.

headroom Amount of remaining gain available for a given signal before the onset of unacceptable clipping.
**Glossary**

**house video reference (black burst)** A type of clock reference signal commonly used to synchronize audio or video devices during playback or recording.

**inactive** Items that have been turned off in Pro Tools to free up or conserve DSP. An example, when a track, send, or plug-in is inactive, its name appears in italics and the item is silent.

**indexing** Used by databases to obtain and maintain the data displayed in browsers. Indexing creates and updates a database with the latest metadata information.

**item** In DigiBase, each row of data is referred to as an item in the Items List. Items include Volumes, Catalogs, Session files, and Media files, as well as other types of files.

**latency** Time delays inherent in internal processing or generation of audio signals within a computer.

**Legacy I/Os** Older Digidesign audio interfaces (such as 888|24 I/O and 882|20 I/O) that can be connected to Pro Tools|HD audio interfaces (such as 192 I/O and 96 I/O) for additional input and output channels. Legacy interfaces can only be used with 44.1 kHz and 48 kHz sessions.

**lightpipe** See ADAT Lightpipe.

**Loop Sync** A dedicated clock signal for synchronizing multiple Pro Tools|HD audio interfaces together. Loop Sync uses a Word Clock signal based on sampling rates of either 44.1 kHz or 48 kHz. As sample rates increase in the system, Loop Sync continues to operate at a base rate of 44.1 kHz or 48 kHz, depending upon the higher rate. Loop Sync should be used only to chain multiple Pro Tools|HD peripherals together.

**machine control** Pro Tools functions to control or be controlled by an external transport, typically a VTR or ATR.

**Marker** Memory Location referenced on a timeline, typically used to store locations to important points in a session. See also Memory Location.

**master (device)** “Lead” machine or Pro Tools system in a synchronized machine arrangement. Slaves follow masters. There can only be one master at any given time.

**Master Fader track** Governs the overall output of one or more tracks.

**media file** A file that contains actual audio, video, or graphics data. It also contains a variety of metadata (such as file name and format).

**Memory Location** Pro Tools supports up to 999 Memory Locations, which can include markers, Edit selections, record and play ranges, track settings, and other data. They can be viewed and sorted in the Memory Locations window, from which they can also be accessed.

**metadata** Media files, session files, and other types of files contain their own sets of metadata, which include general types of data such as file name, creation date, and file size. Metadata varies with file type, format, and kind.

**MIDI (Musical Instrument Digital Interface)** A communication protocol designed to allow equipped instruments such as synthesizers to intercommunicate for control and playback purposes. Information transmitted over MIDI includes note-ons, note-offs, key velocity, pitch bend, and other performance data. Connections are made using cables equipped with 5-pin DIN connectors.

**MIDI Event List** Pro Tools window that shows the contents of a MIDI track in a column, for easy editing of individual MIDI events.
MIDI I/O Digidesign’s USB-based MIDI interface. Features 10 MIDI inputs and outputs for a total of 160 MIDI channels and supports time-stamping for superior timing accuracy and precision.

MIDI Machine Control (MMC) See machine control.

MIDI Time Code See MTC.

MP3 (MPEG Layer 3) An adjustable-quality audio compression format developed by the Fraunhofer Institute.

MTC (MIDI Time Code) Non-SMPTE form of time code that is used by some devices (including Pro Tools) to send and receive timing information.

nondestructive editing Leaves audio files intact. As you edit audio within Pro Tools, you are only editing the regions, or “pointers,” to audio files that are stored on the hard drive, unless you explicitly choose destructive modes (during recording, or when using AudioSuite processing).

non-drop frame Time code that is not in drop-frame format. In North America, the standard format outside of color video production or post production is typically 29.97 fps non-drop frame.

NTSC Video standards developed by the National Television Standards Committee. NTSC color video runs at 29.97 frames per second; NTSC black and white video runs at 30 fps. Used primarily in North and South America and Japan.

Nyquist frequency The highest audio frequency that can be accurately sampled, equivalent to one-half of the sampling frequency. The Nyquist sampling theorem showed that the sampling rate must be at least twice the highest frequency present in the sample in order to accurately reconstruct the original signal.

offline (media) Not connected to or directly accessible by a computer.

offline (synchronization) Not under the control of (or controlling) another device for synchronized playback or recording.

OMS (Open Music System) A “MIDI operating system” for Macintosh OS 9 systems, developed by Opcode. It handles the exchange of MIDI data between applications, including timing signals such as MTC. OMS is replaced by AMS (Apple’s Audio MIDI Setup utility) in Mac OS X.

online (media) Connected to and directly accessible by a computer.

online (synchronization) Controlled by (or controlling) another device for synchronized playback or recording.

peak indicator Indicator light designed to warn of the possibility of clipping, which illuminates as a device’s input reaches a preset degree of headroom.

performance volume A storage volume that has been designated to record and/or play back media files in a Pro Tools session.

PFL (Pre Fader Listen) Sometimes called a “cue,” this is a channel’s level before it is attenuated or boosted by the fader setting. Master faders are PFL in Pro Tools. See also pre-fader.

playlist A group of regions arranged on an audio or MIDI track.
**positional reference** Common reference that provides location information that various devices can use to establish synchronization during playback and recording. Most commonly, the information is delivered in the form of SMPTE/EBU Time Code.

**post-fader** Output from a track (typically a send) that is governed by the channel’s fader setting.

**post-roll** Adjustable time for playback to continue beyond the current playback or recording of a selection.

**PRE** Digidesign’s remote controllable 8-channel microphone preamp. Features eight discrete, matched transistor hybrid mic-preamp circuits and offers a pristine signal path designed specifically for the Pro Tools environment, but can also be utilized as a stand-alone microphone preamp.

**preamp** In recording studio terminology, a circuit designed to boost relatively low signal levels, such as a microphone output, up to standard line levels of –10 dBV or +4 dBu. Digi 002 and Digi 002 Rack are equipped with four microphone preamps. Mbox 2 and Mbox are equipped with two microphone preamps. See also PRE.

**pre-fader** Output from a track (typically a send) that is independent of the channel’s fader setting.

**pre-roll** Adjustable time that precedes the playback or recording of a selection.

**ProControl** Digidesign-dedicated controller that communicates with Pro Tools by means of ethernet. Features include touch-sensitive, motorized faders, and a dedicated effects editing section.

**Pull Up/Pull Down** Refers to the deliberate “miscalibration” of the audio or video sample rate clock (the audio pitch) in order to compensate for a speed change elsewhere in the production chain. The usual situation in which these rates are encountered is when film footage (at 24 fps) is transferred to color NTSC-standard video tape (at 29.97 fps). Video Pull Up/Pull Down is supported in Pro Tools 5.3.1 and higher.

**quantize** To adjust MIDI note locations or durations to the nearest unit or template structure so that a particular rhythmic “feel” is achieved.

**QuickTime** Apple’s system extension for control of time-based events, such as digitized video movies and digitized sound.

**RealAudio** Audio compression scheme designed for streaming over the internet.

**record** Element of a database. A database is a collection of records. Each record represents a particular file (such as a media file or session file). The record contains all of the metadata describing that file, but none of the media. Therefore a record is much smaller than the actual file, and much easier to parse for information.

**region** Within Pro Tools, a “pointer” to a particular track selection or file. Regions can be dragged from the Region List, or a DigiBase browser, to a track.

**Relative Grid mode** An editing mode that constrains movement and alignment of regions to precise increments on a user-defined grid while allowing the region to maintain an offset relative to that grid point. See also **Absolute Grid mode**.

**resolving** The process of synchronizing multiple devices to a common clock reference.
RTAS (Real-Time Audio Suite) plug-ins Digidesign’s host-based, real-time effects plug-in format.

Sample rate One of two main specifications that describe digital audio quality (the other is bit rate resolution). Sample rate refers to how frequently incoming audio is sampled per second during conversion from an analog to a digital signal.

SCSI HBA (Small Computer System Interface and Host Bus Adapter) Digidesign’s conformed terminology for SCSI cards. SCSI is a type of data bus allowing for the high speed transfer of data between a computer and peripheral devices. An HBA is the card that connects the SCSI bus between the computer and peripheral devices such as hard drives.

Send An adjustable additional track output, which can be routed to an internal bus for effects processing, monitoring, and submixing.

Session file A work file, much like a word processing document or a graphics program file. A Pro Tools session file contains data describing how media files are to be played and displayed. It also contains metadata about the files on which it depends (audio and MIDI files, and related data such as fades, playlists, and selections). Each separate project worked on should be stored as its own session.

Session template A Pro Tools session file whose parameters are preset to a user’s specific preferred state. Any Pro Tools session may be saved as a template using the Save As command for convenience of setup.

Slave Device that “follows” the master during synchronization.

Slave Clock (or Super Clock) Digidesign’s proprietary hi-speed Word Clock that runs at 256x (256 times) the sample rate. It is required by Pro Tools|24 MIX and Pro Tools|24 systems to synchronize audio interfaces to a single, highly-accurate clock from SYNC I/O, USD, or HD audio interface. See also Legacy I/Os.

Sound Designer II (SD II) Digidesign’s high-quality digital audio file format.

S/PDIF Semi-professional version of the AES/EBU standard. Stands for “Sony/Philips Digital Interface Format.” S/PDIF connections use coaxial (RCA) or TOSlink optical in/out connectors. Most S/PDIF connections carry two channels of digital audio at a time.

Spot Audio post production process of aligning audio events to visual events. In Pro Tools, Spot mode lets spot regions to particular time code events.

Standard MIDI File Universal format that can be read by virtually any software that reads MIDI. Type 0 is a single line sequence, type 1 is multi-track.

Submix Routing multiple audio sources to an Auxiliary Input for monitor mixes, bus-master control over levels, and shared effects processing.

Subgroup See groups.

Super Clock (256x) See Slave Clock.

SYNC I/O Digidesign’s multi-format synchronization peripheral for Pro Tools|HD systems that supports all major industry-standard clock sources and time code formats. SYNC I/O features near sample-accurate lock to time code or bi-phase/tach signals and a 192 kHz capable, high-fidelity, low-jitter Word Clock.
synchronization Process of having two or more audio, video, or other devices play and record as one, at the same speed.

**Sysex (System Exclusive)** MIDI data specific to a particular piece of hardware or instrument.

**TDM (Time Division Multiplexing)** A technology that employs a networked bus of DSP chips that supply the processing power for Pro Tools|HD systems.

**TDM plug-in** Digidesign’s proprietary real-time, nondestructive plug-in format for Pro Tools|HD systems.

**time code address** See address.

**time code generation** Process of creating “fresh” time code.

**Time Scale Timebase rulers** The Main Time Scale is the Timebase ruler that determines the time format used for Transport functions, and Grid and Nudge values. The Sub Time Scale is the Timebase ruler that provides additional timing reference.

**Timebase rulers** Up to five discrete strips measuring different units (samples, feet.frames, minutes:seconds, bars:beats, or time code) displayed across the top of the Edit window.

**Timeline insertion point** Location on the timeline corresponding to the cursor point, and the point from where playback or recording begins.

**Timeline selection** A selection in any Timebase ruler that determines the playback or record range.

**transfer volume** A storage volume that has been designated as a Transfer Volume in DigiBase Workspace will not be used to record or play media in a Pro Tools session. Volumes that are not supported by Pro Tools for audio playback, (such as network share volumes or CD-ROMs) will be designated as transfer volumes by default.

**Universe window** Provides a visual overview of all tracks in a session, and can be used to quickly navigate to any location in a session.

**USB (Universal Serial Bus)** A high-speed peripheral standard capable of transferring data at up to 12 Mb/sec. USB is used for many audio and video peripheral devices.

**user preference** A user-definable state for a specific Pro Tools parameter or system setup. Macintosh has the ability to create separate preferences files for each user. For Pro Tools database functions, these include Browser views, and parameter and search settings. See also *general preference*.

**user-defined region** Explicitly defined regions that are created when recording or importing audio or MIDI; capturing, separating, or consolidating a selection; trimming a whole-file audio region; or renaming an existing region.

**velocity** MIDI data parameter that describes how fast or hard a key is struck and controls the volume of MIDI note playback.

**video reference signal** Clock information contained in all video signals, which can be used as a clock reference.

**voiceable track** Previously known as virtual voicing; total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system.

**voices** With a Pro Tools system, refers to the number of channels that can be played back simultaneously.

**VTR (Video Tape Recorder)** A video tape recorder of any format.
.WAV Pronounced “wave,” this is Microsoft’s Audio File Format. Can be read by Pro Tools on both Windows and Macintosh platforms.

WaveDriver The Digidesign WaveDriver is a single-client, multichannel sound driver that allows third-party audio programs that support the WaveDriver MME (Multimedia Extensions) standard to play back through qualified Digidesign audio interfaces:

waveform Means of visually representing a sound. When sound regions are imported into the Pro Tools Edit window, they can be viewed in Waveform view. Preview waveforms can also be viewed in DigiBase browsers.

whole-file audio regions Created when recording or importing audio, consolidating existing regions, and when processing with an AudioSuite plug-in.

Word Clock Many professional digital audio products—including open-reel multitrack tape recorders, digital mixing consoles, and digital recorders—have Word Clock (1x sample rate) connectors.

Word Clock allows Word Clock-compatible devices to send or receive external clock information that controls the sample rate, which in turn (where applicable) controls the play and record speed.

zero crossing Point at which a wave’s amplitude crosses the center line of the waveform display. Typically, a good spot to edit a sound file is at zero crossings, to avoid unwanted artifacts.

Zoom Function used to view waveform displays within the Edit window with greater detail or more data.
Index

Numerics
1622 I/O 6
18-bit
  Bounce to Disk 580
176.4 kHz
  and pull factors 655
192 Digital I/O 6
192 I/O 6
  Hardware Setup 43
  Soft Limit 43
192 kHz
  and pull factors 655
1x 690
24 FPS 638
24-bit
  Bounce to Disk 580
  TDM processing 509
24-bit ADAT Bridge I/O 6
25 FPS (EBU) 638
256x 688
29.97 FPS Drop 637
29.97 FPS Non-Drop 637, 668
3 Second option
  Clip Indication 92
  Peak Hold 92
  3 Second Peak Hold preference 58
  3:2 Pulldown 638
30 FPS Drop 637
30 FPS Non-Drop 637
32-bit, floating 509
3-knob panning 625
5.0 paths in 5.1 mixes 614
5.1 formats in Pro Tools 603
882|20 I/O 6
888|24 I/O 6
8-bit 580
96 I/O 6
  Hardware Setup 43
96i I/O 6
  Hardware Setup 43

A
AAF format 133
Absolute Grid mode 247, 303
active
  items 17
  making inserts 514
  making plugins 18
  tracks 111
Add Marker/Memory Location button 384
Add Meter Change button 374
Add Tempo Change button 354, 371
Add Unique Triggers 412
adding
  a new playlist 237
  audio tracks 169
  Instrument tracks 192
  MIDI tracks 192
  sends 488
AES/EBU
  Hardware Setup 43
AFL (After Fader Listen) 108
AFL/PFL Path
  selecting 85
  setting a level 85
AFL/PFL Path Selector 85
After Playback Scrolling option 271
After Write Pass, Switch To preference 65, 536
AIFF file format 576
All MIDI Notes Off command 436
all tracks
  hiding 99
  selecting all regions in 275
  selecting in Timebase rulers 280
  showing 99
Amount of memory to reserve for automation recording option 65
Analog In 43
Analog Out 43
Apply Real-Time Properties option 138
applying to automatically bypassed tracks 507
archiving
  preparing with Compact Selected 349
Assignment View
  sends 490
Audio During Fast Forward/Rewind option 59, 266
audio files
  compacting 349
  concepts 13
  default names 158
  formats 576
  importing 119
  mixed file types 51
  mixed formats 120
Audio Files folder 46
audio format, for session 646
audio interfaces 8
input channels 14
Audio Pull Up and Pull Down 652
audio regions 226
  and automation 228
  fitting to an Edit selection 287
  stripping silence from 345
  whole-file 220
audio tracks 13
  5.1 format 599
  adding 169
  and Output format 608
  and surround sessions 606
  bouncing to disk 574
  channel strips 88
  configuring for recording 169
  creating a tempo map for 370
  loop recording 177
  placing audio in multichannel tracks 607
  punch recording 176
  recording multiple 173
  signal flow 478
Waveform View 226
Audio Zoom In button 249
Audio Zoom Out button 249
AudioSuite
  Dither 509
  Duplicate plug-in 320
  plug-ins 510
  processing 319
AudioSuite Buffer Size preference 66
AudioSuite Dither preferences 66
Audition Paths Selector 83
auditioning
  fades 335
  pre/post-roll 284
  programs 432
  selection start and end points 284
  takes 178
Auto button 520
Auto Input Monitoring mode 154, 155
Auto Match Pull Factors 653
Auto Regions Fade In/Out Length option 61, 343
Auto Rename command 351
auto-created regions 220
  hiding 351
  renaming 350
auto-fades 343
AutoGlide mode 626
AutoGlide Time preference 65, 627
AutoJoin 537
  indicator 538
AutoMatch indicators 541
AutoMatch Time option 65, 541
Automatically Copy Files on Import option 59
Automatically Find and Relink 142
automating
  plug-ins 546
  sends 544
  switched controls 544
  tracks 543
automation 533
  and audio regions 228
  and multichannel pan 630
  and multiple output assignments 608
  breakpoints 553
  buffer size 541
  capture & apply 569
  creating 546
  cutting, copying, and pasting 315, 556
  deleting 549
  delta 538
drawing with Pencil 550
  editing 552
  editing with Smart Tool 260
  enabling, suspending 547
  for grouped tracks 555
  for hidden tracks 100
  on multichannel tracks 554
  On Stop 563
  pass-through point 537
  playlists 236, 534, 542
  plug-in accuracy in bounce 581
  relative and absolute 538
  rule and Track View 312
  Safe button 520
  safing 542
  smoothing 540
  special Paste mode 559
  stepped 553
  thinning 541, 549
to next breakpoint 563
  Trim mode 538
  trimming 560
  Write to Current or All Enabled 569
  writing 543
  writing to selection, selection start, or selection end 561
Automation Enable window 543
Automation Mode selector 536
Automation modes
  Latch 537
  Latch/Trim 539
  Off 536
  Read 536
  Read/Trim 539
  Touch 537
  Touch/Trim 539
  Trim/Off 539
  Write 536
  Write/Trim 540
Automation Preferences 64
  AutoMatch Time option 65, 541
  Memory for Automation Recording option 541
  Mutes Follow Groups option 107
  Smooth and Thin Data After Pass option 550
  Solos Follow Groups option 107
  Touch Timeout option 65
Auto-Name Memory Locations While Playing option 63, 385
Auto-Name Separated Regions option 63, 290
auto-naming
  and Strip Silence 346
  audio files and regions 158
  playlists 237
  QuickPunch regions 208
  separated regions 290
  takes 158
AutoSave option 61
Auto-Spot Regions command 663
Auxiliary Inputs 16, 87
  channel strips 89
  monitoring and mixing 499
  signal flow 479
Avid Video Errors Stop Playback option 60
Avid Xpress DV
  codec requirements for export 673
  playback in Pro Tools 673
Back and Play command 267
Back command 267
Back/Forward Amount 267
Back/Forward commands 267
  extending selections 268
  repeating 268
backing up sessions automatically 47, 61
  bank select 20, 429
Bar|Beat Markers
  and tempo events 372
  audio with varying tempos 373
  editing 373
  from Identify Beat command 371
  generated with Beat Detective 401
  moving 372
Bars:Beats Time Scale 232
bass
  extension 598
  management 595, 598
  redirection 598
  sub content 595
Batch Fades dialog 344
Beat Detective 391, 392
  beat triggers
    deleting 399
    generating 396
    inserting 400
    moving 399
    promoting 400
Collection Mode 410
  conforming regions 406
  defining the selection 394
  detecting transients 396
DigGroove templates 402
  edit smoothing 408
  extrapolation 403
  generating Bar|Beat Markers 401
  Groove Templates
    extracting 402
    Scroll Next 401
  separating regions 404
  system requirements 392
  templates 402
  Trigger Pad 404
    window 393
    with multiple tracks 405
  Beat Detective command 393
  Big Counter window 265
  Bi-Phase/Tach 636
  bit depth, for session 46, 646
  black burst 667
  Blocks View 221
  Bounce to Disk
    File Type 576
    Bounce to Disk command 571, 574
      and dither 572
      and time stamps 574
      Bounce Options 575
      Convert After Bounce 581
      Convert During Bounce 581
      File Type 576
      Format 579
      Help 582
      recording a submix 582
      Resolution 580
      sample rate conversion options 580
      sample rate conversion quality 581
      source path 575
      Use Squeezer option 581
    Bounce to QuickTime Movie command 679
    bouncing
      to a stereo mix 583
      to a submix 582
      to QuickTime movies 679
    breakthroughs 553
    Avid keyframes 552
    Bring to Front command 292
    Browser
      defined 682
    Buffer Size
      Hardware 157
    bussing
      multichannel sends 610
      sends 488
    signal paths 69
    submixing and effects processing 499
    surround examples 614
    BWF (.WAV) file format 576
    Bypass button
      for real-time plug-ins 520
Calculator Entry mode (for numeric entry) 280
Calibration Mode command 152
Calibration Reference Level preference 62
cancelling record takes 172, 195
Capture Region command 289
capturing time code 662
Center % (Percentage) 628
Center % in Output window 629
  Center Playhead Scrolling option 272
  centered crossfade 334
Change Duration command 437, 451
Change Edit to Match Timeline command 286
Change Meter command 374, 376, 377
Change Tempo command 354
Change Timeline to Match Edit command 286
Change Velocity command 437, 449
Channel Delay indicator 91
channel mapping
default path order 86
ingoing 78
re-mapping 78
Channel selector 521
for multi-mono plug-ins 611
channel strips 15
audio tracks 88
Auxiliary Inputs 90
Instrument tracks 90
Master Fader tracks 89
MIDI tracks 90
channels 14
chasing
controller events 434
MIDI notes 433
program changes 434
Cinema Stereo 590
Classic Numeric Keypad Mode 33, 60
Clear All Clip Indicators command 92, 93, 491
Clear command 314
Clear command (regions) 352
Clear Special commands 315, 559
All Automation 315, 559
Pan Automation 315, 559
Plug-In Automation 315, 559
click
configuring 165
enabling 166
Click plug-in 165
clicks 166
clicks and pops, avoiding 227
Clip Indication options
3 Second 92
Infinite 92
None 92
Clip LED 520
clipping 151, 520
clock source 531
Clock Source popup menu 43
Close Session command 54
closing multiple plug-in windows 522
Collection Mode, Beat Detective 410
Color Coding options 111
Color Palette window 114
Command|8 510
Commands Keyboard Focus 32
Comments View 95, 484
Compact Selected command 349
Compare button 520
compatibility
information 4
surround formats 596
Compatibility Preferences 67
compressed QuickTime file formats 678
Conductor button 29
Conductor rulers 231
including in selections 281
configuring
click options 165
MMC 658
Pro Tools 37
SMPT 649
conforming QuickTime movies 677
connecting
effects units 531
external audio devices 530
Consolidate command 348
Constant Tempo command 365
Consolidate command 348
Continuous controller events 20
Continuous Scroll During Playback option
and half-screen 272
Continuous Scroll with Playhead option
and half-screen 272
Continuous Scrolling option 272
continuous zoom 249
control surfaces
Command|8 510
Control|24 510
D-Command 510
D-Control 510
ProControl 510
controller events 20, 426
and MIDI regions 230
chasing 434
editing 427
editing with Smart Tool 260
inserting 427
Controller Meter Path Selector 83
Conversion Quality option 63, 121, 581, 678
Tweak Head setting 581, 678
Convert Plug-In selector 520
Convert WAV files to AES31/BroadcastWave option 59, 143
converting session
audio file format 50
bit depth 50
sample rate 50
Copy command 313
Copy Settings command 523
Copy Special commands 315, 558
All Automation 315, 558
Pan Automation 315, 558
Plug-In Automation 315, 558
Copy to Send command 545
copying
a plug-in setting 525
all automation playlists for a track 315
MIDI notes with the Split command 454
selections and regions 313
track automation to sends 545
track control settings to sends 493
countoff 166
Countoff button 29
CPU processing activity 55
CPU Usage Limit 39
Create Fades command 340, 341
creating
crossfades 340
fade-ins/outs 341
groups 116
Mac and PC compatible sessions 145
Markers and Memory Locations 384
region groups 321
regions 289
sessions 45
settings subfolders 524
Crossfade Preference for Pre/Post-Roll option 63, 339
Index

695

crossfades 333
and dither 510
creating with Smart Tool 259
equal gain 337
equal power 337, 339
Fades dialog 335
in batches 343
linear 339
pre/post 341
removing 340
trimming 340
types 333
with dither 337
current meter 29, 374
Current Meter button 167
Current Meter indicator 29
current tempo 29, 354
Current Time display 647
Cursor
location 24
value 24
Cursor Location display 25
custom session templates 53
Custom Shuttle Lock Speed 262
Cut command 313
Cut Special commands 315, 558
All Automation 315, 558
Pan Automation 315, 558
Plug-In Automation 315, 558
Cut Time command 376, 380
cutting
automation 556
MIDI notes with the Split command 454
selections and regions 313

D
DAE 11
DAE errors 186
DAE Playback Buffer Size 41
DAT recorder, recording from 185
database 683
D-Command 510
D-Control 510
default
audition path 83
I/O Setup 81
meter 166
metering path 83
output path 84
path order 86
paths 75
program change 429
sample rate 40
tempo 167
Default Fade Settings 63
Default Note On Velocity option 67, 419
Default Path Order Selector 86
Default Settings preference, for TC/E plug-in 66
Default Thru Follows First Selected MIDI Track preference 67
Default Thru Instrument 189
Default Thru Instrument option 67
Degree of Thinning option 65
Delay
Real-Time Properties 463
delay
Channel Delay indicator 91
MIDI Track Offsets 435
Delay After Play Command preference 68
Delay Compensation 505, 507
bypassing 507
changing track delay 507
configuring Delay Compensation Engine 506
dedicating DSP resources 40
during recording 157
enabling 505
engine 40
exceeding compensation limit 507
H/W Insert 86
information 506
MIDI Beat Clock 67
MIDI Timecode 67
mode 57
Plug-In Delay (dly) indicator 506
settings 505
User Offset (+/-) field 506
viewing 93, 485
Delay Compensation Engine
configuring 506
Delay Compensation Mode option 57
Delay Compensation View 93, 485
Delay Compensation View option 506
Delay for External Devices options 67
Delay plugins 511
Delete Current Settings File command 523
Delete Fades command 340
Delete Group command 116
Delete Path 77
Delete Track command 96
deleting
automation 549, 556
existing I/O paths 77
groups 117
in MIDI Event List 473
Memory Locations 388
MIDI notes 424
playlists 238
program changes 432
sysex events 433
tracks 96
unused regions 352
delta
trimming automation 538
destination folder for plug-in settings 524
destructive editing
compacting audio files 349
Destructive Record mode 163, 174
destructive recording 174
Digi 002 9
punching with footswitch 205
Digi 002 Rack 9
Digidesign Audio Engine 11
DigGroove templates 402
digital clipping 151
Digital Format 43
digital mastering 584
DigiTranslator Integrated Option 133
Direct Outputs mode 83
Disable “Input” When Disarming Track (In “Stop”) option 60
discrete signal control 607
Disk Allocation 159
and cross-platform sessions 160
and system volume 161
resizing the window 159
window 159
Disk Processing Activity 55
Disk Space window 162
options 162
Display Events as Modified by Real-Time Properties option 67, 466
Display Preferences 56
Draw Grids in Edit Window option 248
Draw Waveforms Rectified option 226
Show Meters in Sends View option 491
displaying
all rulers 231
file info for audio regions 241
Meter Ruler 374
Original Time Stamps 664
region names 225
region times 225
Tempo ruler 354
User Time Stamps 665
dither
and Bounce to Disk 572
and fades 337, 510
AudioSuite 509
on Master Faders 572
preferences 509
resolution and Bounce to Disk 580
Dither Plug-In preference 66
divergence
and width 595
drawing 628
using 627
Dolby Digital 594
Dolby Surround 590
Dolby Surround EX 590
Draw Grids in Edit Window option 56, 248
Draw Waveforms Rectified option 56, 226
drum machine style loop recording 197
DSP
active and inactive items 17
and inactive outputs 487
and inactive sends 492
and no output 488
and overall resources 16
and Send meters 491
DTS 590, 594
dubber
preference to emulate 59, 211
Duplicate command 317
Duplicate plug-in 320
Duplicate Track command 97, 535
duplicating
inserts 519
MIDI note selections 317
playlists 237
selections and regions 317
sends 493
Duration
Real-Time Properties 462
durations, for MIDI notes
editing with Change Duration command 451
making more legato 453
making more staccato 453
randomizing 453
DV
and sync offset 674
DV Movies
playback through FireWire 673
DV Stream 673
Dynamically Allocated Voicing 103
Dynamics plug-ins 511
E
Edit commands 312
and Edit mode 312
clear 314
copy 313
cut 313
paste 313
edit cursor 265
and scrubbing 260
moving to region boundaries 282
Edit Dither Settings preference, for Dither plug-in 66
Edit Groups 117
and selections 274
Edit Insertion Follows Scrub/Shuttle option 59, 260
Edit insertion point
placing regions at 297
trimming regions to 293
Edit Markers 273
and selection length 278
Edit menu
Change Edit to Match Timeline command 286
Change Timeline to Match Edit command 286
Clear command 314
Clear Special commands 315, 559
Consolidate command 348
Copy command 313
Copy Special commands 315, 558
Copy to Send command 545
Create Fades command 340, 341
Cut command 313
Cut Special commands 315, 558
Delete Fades command 340
Duplicate command 317
Fade To End command 342
Fade To Start command 342
Fades command 335
Heal Separation command 295
Identify Sync Point command 304
Insert Silence command 347
Paste command 313
Paste Special commands 315
Play Edit Selection command 288
Play Timeline Selection command 288
Redo command 239
Repeat command 318
Repeat to Fill Selection command 316
Select All command 275
Separate Region commands 290
Shift command 307
Strip Silence command 345, 346
TCE Edit to Timeline Selection command 287
Thin Automation command 550
Trim Automation to All Enabled command 570
Trim Automation to Current command 570
Trim Region End to Fill Selection command 294
Trim Region Start to Fill Selection command 293
Trim Region Start to Insertion command 293
Trim Region to Fill Selection command 294
Trim Region to Selection command 293
Undo command 239
Write Automation commands 568, 569
Edit mode buttons 246
Edit modes 246
and edit commands 312
and placing regions 296
Grid 247
Relative Grid 247
Shuffle 246
Slip 246
Spot 246, 661
edit playlists 236
Edit Selection Follows Region List Selection option 63, 275
Edit Selection indicators 24, 279
Edit selections
auditioning with Playhead enabled 288
copied from Timeline selection 286
copied to Timeline selection 286
sliding in the Ruler 282
edit smoothing, with Beat Detective 408
Edit tools 24, 248
Grabber 248, 276
Pencil 248, 320
Scrubber 248, 260
Selector 248, 265
Smart Tool 248
Trim 248, 254
Zoomer 248, 249
Edit window 21, 23
All Views option 483
half-screen 272
None Views option 483
scrolling from the Ruler 269
Views option 21
Edit Window Default Length option 57
Edit Window Follows Bank Selection option 56
Edit Window option 21
Edit Window view options 483
Edit Window View selector 483
editing
across multiple tracks 316
and Edit modes 246
and Grid modes 303
and hidden tracks 100
and Track View 312
automation 552
Bar|Beat Markers 373
breakpoints 553
controller events 427
during playback 219
Grid mode 247
in MIDI Event List 472
Markers 387
Memory Locations 387
meter events 375
MIDI notes 419
MIDI regions 229
nondestructive 219
nondestructively for audio 227
nondestructively for MIDI 230
note attributes 424
note durations 451
note velocities 422, 449
program changes 431
regions as grid 248
Shuffle mode 246
Slip mode 246
Spot mode 246
tempo events 355
waveforms 226
Editing Preferences
Auto-Name Memory Locations While Playing option 385
Auto-Name Separated Regions option 290
Conversion Quality option 121
Crossfade Preference for Pre/Post-Roll option 63, 339
Edit Selection Follows Region List Selection option 275
QuickPunch Crossfade Length option 205, 210
Region List Selection Follows Edit Selection option 241,
275
Separate Region Operates On All Related Takes option
179, 290
Take Region Lengths That Match option 179
Take Region Names That Match Track Names option
179
Effect Bypass button 520
effects, printing to disk 571
Enable Session File Auto Backup option 61
enabling
automation 547
AutoSave option 61
groups 118
MIDI input devices 188
plug-in automation 528
encoding and decoding 597
Enforce Mac/PC Compatibility option 51, 145
EQ plug-ins 511
equal gain crossfades 337
equal power crossfades 337, 339
Event Edit Area 24
note attributes 424
Event menu
All MIDI Notes Off command 436
Beat Detective command 393
Change Meter command 374
Identify Beat command 370
MIDI commands 437
MIDI Event List 467
MIDI Track Offsets command 435
Remove Duplicate Notes command 436
Renumber Bars command 382
tempo commands 384
Time commands 376
Exit command (Windows) 54
Expanded Track Display 224, 554
Export MIDI command 138
Export MIDI Settings dialog
Apply Real-Time Properties option 138
MIDI File Format pop-up menu 138
Export Region Definitions command 133
Export Regions as Files command 131
Export Selected dialog 132
Index 697
Export Selected Tracks as OMF/AAF command 133
Export Session Info as Text command 133
Export Settings button (I/O Setup) 82
exporting
 a session as text 133
 AAF files 133
 audio 131
 audio from regions 131
 markers 138
 MIDI tracks 138
 OMF files 133
 region definitions 133, 665
 region groups 139
 stereo interleaved files 132
 Ext. Clock Output 43, 644
 extending selections 279, 361
to adjacent tracks 280, 281
to include adjacent regions 279
to Markers and Memory Locations 279
to region boundaries 279, 361
external clock source 531
external side-chain processing 529
External Time Code Offsets 648
extrapolation 403

F
factory I/O settings 83
Fade Files folder 46
Fade To End command 342
Fade To Start command 342
fade-in shapes 338
fade-out shapes 336
Faders Move During Playback option 64
fades 341
 and dither options 510
 auto-fades 343
 creating 341
 creating with Smart Tool 259
 in batches 343
 regenerating 142
 with dither 337
Fades command 335
Fades dialog 339
 In Shape 338
 Link option 337
 Out Shape 336
 Use Dither option 337
Fast Forward
 incrementally 267
 locating with 266
Fast Forward button 26
Feet, Frames and QuickTime offset 676
Feet, Frames Time Scale 232
file formats (audio) 576
 AIFF 576
 BWF (.WAV) 576
 MP3 577
 MXF 577
 QuickTime 576
 SND resource 576
 Sound Designer II 576
File menu
 Bounce to Disk command 574
 Bounce to QuickTime Movie command 679
Close Session command 54
 Exit command (Windows) 54
 Export MIDI command 138
 Export Selected Tracks as OMF/AAF command 133
 Export Session Info as Text command 133
 Import Audio from Current Movie command 679
 Import Audio from QuickTime Movie command 679
 Import Audio to Track command 122
 Import MIDI to Region List command 137
 Import MIDI to Track command 137
 Import QuickTime Movie command 672
 New Session command 45
 New Track command 169, 192
 Open Session command 47
 Revert to Saved command 49
 Save As command 49
 Save command 49
 Save Copy In command 52, 146
 Send via DigiDelivery 136
 Film 590
 film speed 639
 filtering in bass management 598
 final mixdown 583
 Find command 242
 Find Matching Tracks option 128
 finding regions 242
 Find History 243
 FireWire
 QuickTime DV playback 673
 Flatten Performance command 437, 449
 formats
 supported multichannel 590
 Forward and Play command 267
 Forward command 267
 frame rate
 pull up and pull down 653
 freewheeling time code 648
 Front Divergence 627
 Front/Rear Divergence 627

G
generating time code 648, 656
Glide Automation commands 559
Global MIDI Playback Offset option 67, 434
Go to End button 27
Grabber tool 276
 editing breakpoints with 361, 552
 Object Grabber 276
 selecting MIDI notes with 420
 Separation Grabber tool 291
 Grabber tools 248
 Grid
 setting for MIDI editing 418
 Grid mode 247, 303
 Absolute 247, 303
 configuring 247
 Draw Grids in Edit Window option 248
 Regions/Markers option 248
 Relative 247, 303
 setting the Grid value 302
 suspending 303
 grid panners in Mix and Edit 620
 Grid value 302, 418
 Grid Value selector 247
LFEs Follow Groups option 65
Librarian menu 520
Limit To option 61
linear crossfades 339
Linear Sample Display 363
Linear Tempo command 366
Linear Tick Display 363
Linearity Display Mode 363
Link Enable buttons 521
in multi-mono plug-ins 611
Link Mix and Edit Group Enables option 60
Link Record and Play Faders option 156
Link Selection button 273, 274
Link Timeline and Edit Selection option 273
Link Track and Edit Selection option 274
linking
inverse panning 496
multi-mono plug-ins 611
plug-in controls 527
stereo panners 495
Local Control 20, 189
locating
the playback cursor 270
with Fast Forward/Rewind 266
with Location Indicators 269
Location Indicators 269
locating with 269
locations, for MIDI notes
dragging 421
quantizing 441
randomizing 440, 443
Lock Settings File command 523
Lock/Unlock Regions command 308
Locked indicator 647
locking regions 308
Loop Playback option 284
and Touch mode 543
loop points 180
and Playback Markers 181
Loop Record mode 163, 177
loop recording
and pre/post-roll 177
audio 177
MIDI 197
drum machine style 197
multiple takes 198
Loop Trimmer 332
looped regions 328
copying and pasting automation 332
creating 329
editing 331
renaming 330
selecting 331
trimming 331
trimming with Loop Trimmer 332
unlooping 330
looping
playback 284
regions 328
selections 285
loops and reverb, delay 574
low latency monitoring
Bounce to Disk 357
during recording 157
Low Latency Monitoring option 157
LTC (Linear Time Code) 636
M
Machine Chases Memory Location option 68, 659
Machine Control preferences 68
Machine Cues Intelligently option 68
Machine Follows Edit Insertion/Scrub option 68, 659
Machine Track Arming window 660
Macintosh sessions
compatibility with Windows 145
Main Counter selectors 233
Main Counters 233
main paths 70
Main Time Scale 232, 233, 652
Main Timebase ruler 232
Make Active command 111
Make Inactive command 111
managing regions 350
Manual Tempo mode 29, 168
Manually Find and Relink 142
mapping paths in I/O Setup 78
Markers 382
creating 384
creating on the fly 385
deleting 388
editing 387
exporting 138
extending selections to 279
importing 137
moving 387
sorting 390
tick-based and sample-based 383
viewing options 389
Markers ruler 231, 383
Master Faders
as master send level control 504
channel strips 89
inactive 481
inserts 512
meters pre/post fader 481
multichannel 610
post-fader inserts 480
signal flow 480
Master Link button 521
in multi-mono plug-ins 611
Master View for tracks 223, 557
mastering
digitally 584
to disk 583
Matching Start Time Takes List preference 63
matrix 593
Mbox 9
Mbox 2 9
measures
renumbering 382
media 685
Memory for Automation Recording option 541
Memory Location dialog 382
Memory Locations 382, 383
creating 384
creating on the fly 385
deleting 388
deleting all 388
editing 387
Index  701
extending selections to 279
Markers 382
recalling 386
recalling Edit selections 182
renaming 386
Selection Memory Locations 383
storing Edit selections 182
Memory Locations window 386
View Filter 389
viewing options for Markers 389
Merge mode (see MIDI Merge mode)
Merge Paste Special command 315
Metadata 685
meter
current 374
default 166
display 29
meter events 374
editing 375
inserting 374
meter map
importing 131
Meter Path Selector 83
Meter Ruler
displaying 374
extending an Edit selection to 375
meters
and control surfaces 83
pre/post fader levels 92
Sends View 491
SurroundScope plug-in 630
Metronome Click button 29, 166
Mic Preamps View 484
MIDI 19
common misconceptions 20
Default Thru Instrument 189
patch names 430
select and split notes 454
setting the Grid value for editing 418
signal paths 20
MIDI channels 20
assigning 105
MIDI clips and Region List 241
MIDI control surfaces 19
MIDI controller devices 19, 187
Local Control 20, 189
MIDI devices 19
MIDI Event List 467
deleting events 473
editing events 472
inserting events 470
Options menu 474
selecting events 473
View Filter 468
MIDI File Format pop-up menu 138
MIDI files (see Standard MIDI Files)
MIDI Input selector 91, 105, 192
Instrument track 106
MIDI interface 19
MIDI Machine Control 657
MIDI Machine Control (MMC) 657
configuring in Pro Tools 658
controlling external devices with 657
remote track arming 660
MIDI Merge 29, 164, 191
MIDI Merge mode 164
MIDI Note Display options 67
MIDI notes
attributes for 424
chasing 433
deleting 424
duplicating selected 317
editing 419
durations 451
pitch 421
velocities 422, 449
inserting 418
lengths in ticks 234
moving 421
quantizing 443
scrolling 443
selecting 420
splitting 454
transposing 421, 453
trimming start/end points 421
MIDI offsets 434
MIDI Operations commands 437
Change Duration command 451
Change Velocity command 449
Flatten Performance command 449
Grid/Groove Quantize command 438
Input Quantize command 190, 456
Restore Performance command 448
Select/Split Notes command 455
Step Input command 200, 457
Transpose command 453
MIDI Operations window 437, 438
MIDI Output selector 91, 105, 193
Instrument track 107
MIDI patch name files (.midnam) 430
MIDI Preferences 67
Default Note On Velocity option 419
Global MIDI Playback Offset option 434
Pencil Tool Resolution When Drawing Controller Data option 67, 428, 551
MIDI Real-Time Properties 460
on tracks and regions 464
settings 461
MIDI recording 187
cancelling takes 195
enabling input devices 188
Input Filter 190
Merge/Replace mode 191
monitoring with MIDI Thru 189
quantizing on input 190, 456
System Exclusive data 203
undoing a take 195
Wait for Note 191
MIDI regions 228
and controller events 230
and punch recording 197
guidelines for editing 229
MIDI Replace mode 29, 164, 191
MIDI Setup commands
Input Devices command 188
Input Filter command 190
MIDI Beat Clock command 661
MIDI sound source 19
MIDI Step Input command 200
MIDI Studio Setup window 430
MIDI Thru command 189
MIDI tone generator 19
MIDI Track Offsets command 435
MIDI tracks
  and MIDI offsets 434
  assigning to multiple channels 193
  channel strips 90
  configuring for recording 192
  default program change 429
  input 105
  loop recording 197
  note chasing 433
Notes View 221, 228
output 105
punch recording 195
punching on the fly 196
recording 187
Regions View 221, 229
selecting a pitch range in 455
Sysex View 432
Velocity View 422
MIDI Volume fader 92
MIDI Zoom In button 249
MIDI Zoom Out button 249
Minimum Sync Delay option 660
Minutes:Seconds Time Scale 232
Mirror MIDI Editing 415
missing files 142
mix busses 146, 489
resetting 77
Mix Groups 117
Mix window 21, 22
  All Views option 21, 483
  None Views option 483
  track controls 21
  track width 93
Mix Window Follows Bank Selection option 56
Mix Window option 21
Mix Window view options 483
Mix Window View selector 483
mixed file types 51, 120
mixing 589
  surround formats 590
  mixing down to stereo 583
MMC (see MIDI Machine Control)
Momentary Solo Latch option 110
monitoring
  during punch recording 177
  indicator 27
  MIDI recording with MIDI Thru 189
monitoring latency 156
monitoring modes 154
  Auto Input 154
  Input Only 155
mono
  Bounce to Disk 579
  format 590
  inserts 512
  paths 75
  mono in/stereo out 512
Move Song Start command 376, 381
Movie Tracks 672
  scrubbing 674
  setting sync point 676
Movie window 675
moving
  Bar|Beat Markers 372
  inserts 519
 Markers 387
  MIDI notes 421
  program changes 432
  sysex events 433
MP3 file format 577
MP3 Option 119, 577
MTC (MIDI Time Code) 635
outputting 648
multichannel formats 590
multichannel plug-ins 512, 611
multichannel regions 220
multichannel tracks 169
  and automation 554
  dragging regions to 319
  names for 159
  replacing regions in 311
  signal routing 605
splitting 318
multilingual application support 148
multi-mono
  plug-in Channel selector 611
  plug-ins 512, 611
Multiple mono 579
multiple outputs
  Hardware Setup 45
multiple tracks
  and Beat Detective 405
  audition takes 179
  editing across 316
  extending selections to 280, 281
  fitting audio regions to Edit selection 287
  nudging regions in 306
  pasting to 316
  selecting 280
  separating regions on 291
  shuffling regions on 300
multi-timbral 19
Mute Audio Inputs in Auto Input option 216
Mute automation 553
Mute button 110
Mute Frees Assigned Voice option 110, 111
Mute Overwrite/Extend command 565
Mute Record Armed Tracks While Stopped option 60, 216
Mute/Unmute Region command 64, 107
muting
  regions 309
  tracks 110
MXF format 120, 577
N
Narrow Mix view option 93
New Group command 116
New Memory Location dialog 182
New Session command 45
  and last used 82
New Track command 94, 169, 192
New Tracks dialog 169
New Track Default Output Selector 84
New Tracks dialog 94
Next Setting button 520
no Clip Indication 92
No Output
  by deleting paths 77
  No Output option 488
  No Peak Hold option 58, 92
  no scrolling during playback 271
  non-contiguous selections 276
  nondestructive editing 219
    for audio 227
    for MIDI 230
  Nondestructive Record mode 162
  nondestructive recording 174
    recording to a new playlist 175
    with QuickPunch 205
  nonlinear 11
  Normal QuickTime Playback Priority option 61, 671
  Normal Zoom mode 250
  Note Chasing option 433
  notes (see MIDI notes)
  Notes report 48
  Notes View 221, 228
    MIDI and Instrument tracks 228
    mini-keyboard 228
    scrolling up or down 229
  NTSC
    speed 639
  Nudge value 305
    trimming regions by 294
    nudging 305
    by next Nudge value 306
    multiple regions 306
    region contents 307
    selection range 278
    selection start/end points 278
    selections and regions 306
    setting the Nudge value 305
  Number of Voices 39
  numeric entry
    shortcuts 280
  Numeric Keypad modes 33, 60
    Classic 33
    Shuttle 34, 262
    Transport 34

O
Object Grabber 276
  and Edit Groups 277
Object selections 276
  offline regions 220
  OMFI format 133
On Stop 563
Online button 26
Online option 61
  online recording 656
  on-the-fly punch recording
    MIDI tracks 196
    QuickPunch 163, 205
  Open Ended Record Allocation option 61, 161
  Open Session command 47
  opening multiple plug-in windows 522

Operation Preferences 59
  Audio During Fast Forward/Rewind option 266
  Auto Regions Fade In/Out Length option 343
  Edit Insertion Follows Scrub/Shuttle option 260
  Link Record and Play Faders option 156
  Machine Chases Memory Location option 659
  Machine Follows Edit Insertion/Scrub option 659
  Open Ended Record Allocation option 161
  Record Online option 656
  Use F11 for Wait for Note 191
  Operation/Destination Track pop-up menus 128
  Operations menu
    Calibration Mode command 152
    Link Timeline and Edit Selection option 273
    Link Track and Edit Selection 274
    Low Latency Monitoring option 157
  Optical
    ADAT I/O 43
  Optical (S/PDIF)
    Hardware Setup 43
  Options menu
    Auto-Spot Regions command 663
    Delay Compensation option 505
    Destructive Record mode 174
    Link Track and Edit Selection option 274
    Loop Playback option 284
    Loop Record mode 177
    MIDI Thru command 189
    Mirror MIDI Editing command 415
    Mute Frees Assigned Voice option 110, 111
    Pre/Post Roll option 184
    Pre-Fader Metering option 92
    QuickTime DV Out FireWire Port command 673
    Scrolling options 271
    Transport Online command 656
  Organize Plug-In Menus By option 57, 517
  Original Time Stamp 302, 664
  Other Playlists menu 237
  Output Channel Selector 43
  Output Options
    Conversion Quality option 581
    Sample Rate 580
  Output Path selector 91, 101
  Output selectors 101
  Output Window button 621
  Output windows 486
  outputs
    default 5.1 paths and sub-paths 601
    format and tracks 608
    to multichannel paths 609
  overlap crossfades 339
  overlapping paths 79

P
Page Scrolling option 266, 271
Pan automation 553
Pan indicator 91
Pan slider 91
  panning
    3-knob 625
    and groups 630
    automation and groups 555
    fine-adjust mode 625
grids 620
guidelines 613
linked stereo 495
multichannel automation playlists 630
take over in grid 625
trajectory 626
X/Y mode 625
Parabolic Tempo command 367
parallel mixing 608
pass-through point 537
Paste command 313
Paste Settings command 523
Paste Special commands
  Merge 315, 558
  Overwrite 558
  Repeat to Fill 315
  Repeat to Fill Selection 315
  To Current Automation Type 315, 558
pasting
  automation 559
  between automation playlists 315
  multiple data types 316
  plug-in settings 525
  selections and regions 313
  to multiple tracks 316
  with Repeat to Fill Selection command 316
Patch Select button 429
Path Select dialog 429
paths
  active and inactive 79
  applying 79
  arranging 76
  audition 83
  creating and editing 74
  creating multichannel 602
  default mono and stereo 75
  default order 86
  default output 84
  deleting 77
  for surround 612
  last used 82
  main 70
  mapping 78
  mono versus stereo 75
  multichannel example 78
  naming 75
  overlapping 79
  reset using Default 77
  selecting 76
  Stereo Mix preset 83
  sub-path surround examples 614
PCI bus activity 55
Peak Hold options
  3 Second 92
  Display Preferences 58
  Infinite 92
  None 92
Peak indicator 91
Pencil tool 248, 320, 416
  as Eraser 425
  drawing automation with 550
  editing breakpoints with 552
  Freehand 416
  inserting MIDI notes with 418
Line 416
  Tempo editing 359
Random 417
repairing waveforms with 320
resolution for inserted controller events 428
selecting the Pencil tool shape 416
shapes 416, 550
Square 417
Triangle 416
Pencil Tool Resolution When Drawing Controller Data option 67, 428, 551
Performance Volume
  defined 686
  Playback 686
  Record 686
PFL (Pre Fader Listen) 108
Phase Invert button 521
pitch, for MIDI notes
  transposing 421
  transposing with Transpose command 453
Play button 26
Play Edit Selection command 283, 288
Play MIDI Notes When Editing option 67
Play Timeline Selection command 284, 288
playback
  no scrolling 271
  playback cursor 265
  Playback Cursor locator 270
  Playback Engine 644
  RTAS Processors setting 38
  Playback Markers 181, 273
  and Edit selections 274
  and selection length 278
  and Timeline selections 286
  Playhead 272
  and Edit selections 288
  and Timeline selections 288
  moving to region boundaries 288
playing
  and on-the-fly selections 276
  at half-speed 186
  Edit selections with Playhead enabled 288
  from a track point 266
  selections 283
  Timeline selections with Playhead enabled 288
  tracks 265
Playlist selector 14, 237
playlists 14, 236
  adding new 237
  and groups 238
  and multichannel tracks 554
  and nondestructive MIDI editing 230
  assigning 237
  automation playlists 236, 534, 542
  auto-naming 237
  changing timebase of 235
  deleting 238
  duplicating 237
  edit playlists 236
  Playlist selector 237
  recalling 237
  recording to new 175
  renaming 238
  setting pre/post-roll in 183
plug-in controls
adjusting 528
linking 527
Plug-In Delay (dly) indicator 506
plug-in inserts 511
Plug-In Selector
for real-time plug-ins 520
plug-in settings librarian 523
Plug-In Settings menu 520
plug-in window
closing multiple windows 522
opening multiple windows 522
plug-ins
“Organize Plug-In Menus By” 517
and pull rates 655
and surround mixing 610
automating 546
automation accuracy in bounce 581
bypassing from window 527
Category 517
Category and Manufacturer 518
Channel selector for multi-mono 611
creating a default setting 525
enabling automation 528
favorites 519
Flat List 517
for surround 611
inserting during playback 516
inserting on tracks 515
inserting on-the-fly 516
linking 611
linking and unlinking 527
making inactive (and active) 18
Manufacturer 518
mono-to-stereo 512
multichannel 512
multi-mono 512, 611
multi-processors 39
Next Setting button 520
Plug-Ins Settings Select button 520
Previous Setting button 520
removing from tracks 516
RTAS Processors setting 38
Plug-Ins Settings Select button 520
pops 186
positional reference 635
post crossfades 334, 341
Post-Roll button 27
PRE settings
importing 131
Pre/Post Fader button 496
Pre/Post Roll option 184
pre/post-fader inserts 512
pre/post-roll
and loop recording 177
and punch recording 176
auditioning 284
setting 183
Pre/Post-Roll Flags 184, 273
Pre-Fader Metering option 92
Preferences
AudioSuite Dither
Bit Depth option 66
general 684

Mac OS X User 689
Mute Audio Inputs in Auto Input 216
Mute Record Armed Tracks While Stopped 216
Tool Tips Display 30
TrackPunch 156
TrackPunch 210
Preferences command 56
Pre-Process using Standard Conform 408
Pre-Roll button 27
Previous Setting button 520
Pro Tools LE
file management 141
systems 9
Pro Tools LE systems 10
Pro Tools M-Powered 10
Pro Tools session file icon 12
Pro Tools|HD Accel systems 6
Pro Tools|HD systems 6
audio capabilities 7
audio interfaces 8
file management 141
I/O capabilities 8
MIDI capabilities 7
QuickPunch 206
TrackPunch 208
processing bandwidth 55
Processing Preferences 66
ProControl 510
Program Change dialog 429, 430
program changes 20, 429
and bank select 429
auditioning 432
chasing 434
default, for MIDI tracks 429
deleting 432
editing 431
inserting 431
moving 432
Progressive Scan 655
Project browser 142
ProLogic 590
pull up and pull down 640
and plug-ins 655
and rulers 655
audio 652
video 653
Pull Up/Down
3:2 Pulldown 638
Punch In Frame Offset preference 68
Punch Out Frame Offset preference 68
punch points 380
and Playback Markers 181
punch recording
and monitoring 177
and pre/post-roll 176
audio 176
MIDI 195
MIDI on-the-fly 196
Q
Quantize
Real-Time Properties 461
Quantize command
experimenting with 443
Index

Quantize Regions command
and Grid value 302
Quantize to Grid command 308
Quantize window 440
quantizing
MIDI notes 443
attacks vs. releases 440
MIDI on input 190, 456
QuickPunch 163, 205
crossfades 205, 210
LE systems 207
Pro Tools|HD systems 206
region/take numbering 208
QuickPunch Crossfade Length option 64, 205, 210
QuickTime
and Avid Xpress DV 673
QuickTime DV Out FireWire Port command 673
QuickTime file formats 576, 678
QuickTime Movie Offset command 674, 676
QuickTime movies
bouncing to 679
conforming 670, 677
frame length 671
importing 672
importing audio from 678
offset in Feet.Frames 676
offsetting 676
optimizing for playback 675
playback quality 671
requirements 671
setting start time 676
spotting 677
sync 674
QuickTime Playback Priority menu command
Higher option 61, 671, 675
Highest option 62, 671, 675
Normal option 61, 671
QuickTime window 675
R
randomizing
note durations 453
note locations 440
real-time editing 219
real-time plug-ins 511
Real-Time Properties
clearing 465
Delay 463
Display Events as Modified by Real-Time Properties
option 67
displayed in the Edit window 466
displayed in the MIDI Event List 465
Duration 462
enabling 461
on tracks and regions 464
Quantize 461
region-based 464
settings 461
track-based 464
Transpose 463
Velocity 463
View 460
viewing 460
writing to regions 465
writing to tracks 464
Real-Time Properties View 460, 485
Real-Time Properties window 460
Real Divergence 627
Recall Memory Location Selection at Original Track option 63
Recompute Invalid Overviews option 56
record (database) 687
Record Enable button 27, 152, 162, 212
record enabling tracks 152
record modes 162
and MIDI 164
Destructive Record mode 163
Loop Record mode 163
Nondestructive Record mode 162
QuickPunch 163
switching with Record button 162
Record Online at Insertion/Selection preference 61
Record Online at Time Code (or ADAT) Lock preference 61
Record Online option 656
Record Pause mode 173
Record Safe mode 154
recording 169
a mono audio track 169
a stereo audio track 169
a submix to disk 573
additional takes 173
at half-speed 186
bouncing to disk 574
cancelling takes 172
destructively 174
deleting a take 172
driver 27
from a digital source 184
driver from Record Pause mode 173
from Record Safe mode 154
driver 27
keyboard shortcuts 173
monitoring latency 156
multichannel tracks 169
multiple audio tracks 173
nondestructive 11
nondestructively 174
nonlinear 11
online 656
status LED 212
System Exclusive data 203
to a new playlist 175
to the system volume 161
undoing a take 172
with a countoff 166
with Record Safe mode 154
with the click 165
Red Book Audio CDs 680
Redo command 239
Regenerate Missing Fades 142
region boundaries
extending selections to 279, 361
moving edit cursor to 282
moving Playhead to 288
region definitions 133, 665
region group file format (.rgp) 139, 327
region group files
exporting 327
importing 328
region groups 220, 321
changing timebase format 324
creating 321
defining 325
Index 707
exporting to different hard drives 140
fades and crossfades 327
importing 140
importing and exporting 139
mixed 323
multitrack 323
regrouping 322
separated 324
tick-based 324
timebase format 322
trimming 326
ungrouping 322
Region Groups folder 46
Region List 240
and MIDI clips 241
displaying file info for audio regions 241
dragging from 295
Export Regions as Files command 131
finding regions 242
Keyboard Focus 32
Region List Keyboard Focus 244
Region List menu 664
Auto Rename command 351
Clear command 352
Compact Selected command 349
Export Region Definitions command 133
Find command 242
Rename command 350
Selected Unused command 352
Show Auto-Created option 351
Sort By option 242
Time Stamp Selected command 302
Timeline Drop Order command 296
Region List Selection Follows Edit Selection option 63, 241, 275
Region List Selection Follows Track Selection option 63
Region menu
Bring to front command 292
Capture command 289
Identify Sync Point 666
Lock/Unlock command 308
Mute/Unmute command 309
Quantize to Grid command 308
Remove Sync Point command 304, 666
Rename command 350
Send to Back command 292
Ungroup All Regions command 322
Ungroup Regions command 322
Unloop Regions command 330
Region Name view option 225
Region Time view option 225
regions 13
aligning to region start points 298
auto-created 220
auto-naming options 351
auto-spotting 663
bringing to front 292
capturing 289
clearing 314
clearing Real-Time Properties 465
conforming with Beat Detective 406
consolidating 348
copying 313
creating 289
crossfading between 340
cutting 313
default names 158
displaying names 225
displaying region names 225
displaying times 225
dragging from Region List 295
dragging to multichannel tracks 319
duplicating 317
exporting as audio files 131
extending selections to include 279
finding 242
healing separations 295
hiding auto-created 351
inserting silence into 347
locking 308
looping 328
managing 350
moving in Grid mode 303
multichannel 220
muting 309
nudging 306
offline 220
Original Time Stamp 302
pasting 314
placing at Edit insertion point 297
placing in tracks 295
quantizing 308
removing silence from 346
removing unused 352
renaming 350
repeating 318
replacing 309
selecting 242
selecting all in a track 275
selecting related takes 178
separating 290
separating with Beat Detective 404
separating with Separation Grabber 291
shifting 307
shuffling 299
on multiple tracks 300
sliding 299
slipping 300
sorting 242
spotting 301, 663
spotting to movies 677
sync points 303, 666
time stamping 664
trimming by Nudge value 294
trimming start/end points 255
trimming to Edit insertion point 293
trimming unwanted data from 293
User Time Stamp 302
user-defined 220, 350, 351
whole-file audio regions 220
Regions View 221, 229
related takes 178
and Separate Region command 179
preferences for 179
Relative Grid mode 247, 303
Remote Mode option 68
remote track arming 680
Remove Duplicate Notes command 436
Remove Sync Point command 304, 666
Index

removing crosstides 340
plug-ins from tracks 516
sends 489
Rename command (Region List menu) 350
Rename Region command (Region menu) 350
Renamed Audio Files
save copy in 143
renaming auto-created regions 350
groups 117
Memory Locations 386
playlists 238
regions 350
Renumber Bars command 382
Repeat command 318
Repeat to Fill Selection command 316
repeating selections and regions 318
Replace mode
Replace Region command 309
and multichannel tracks 311
Replace Region dialog 309
reset paths 77
Restore Performance command 437, 448
Return to Zero button 26
Revert to Saved command 49
Rewind
incrementally 267
locating with 266
Rewind button 26
Root Settings folder 523
specifying 524
Round Robin Allocation 160
RTAS plug-ins 512
additional latency 513
RTAS Processors setting 38, 39
Ruler View selector 232
rulers
changing display order 232
Conductor rulers 231
displaying all 231
pull up and pull down 655
scrolling in 269
Timebase rulers 231
zooming in 251
Rulers View options 231
Bars:Beats Time Scale 232
Feet:Frames Time Scale 232
Minutes:Seconds Time Scale 232
Samples Time Scale 232
Time Code Time Scale 232
Save As command 49
Save command 49
Save Copy In command 50, 52, 146
saving a copy of a session 50
saving a session 49
saving plug-in settings 524
Save Plug-In Settings To command 524
Save Settings As command 523
saving the session file with a new name 49
Scale Tempo command 369
scaling note velocities 423, 451
Scroll To Track command 95, 271
scroll wheel
and MIDI track’s Note display 229, 254
scrolling a Pro Tools window 269
zooming in the Edit window 254
scrolling in the Edit windows 254
scrolling
in the ruler 269
Mix and Edit to tracks 270
Notes View up or down 229
Pro Tools window vertically or horizontally 269
scrolling MIDI track’s Note display 229, 254
Scrolling options 271
After Playback 271
Center Playhead 272
Continuous 272
None 271
Page 266, 271
Scrub Trim tool 257
Scrubber tool 248, 260
in Shuttle mode 261
selecting with 282
scrubbing 260
a single audio track 261
and edit cursor 260
Movie Tracks 674
on two audio tracks 261
playback speed and direction 261
resolution 261
with Scrub Trimmer 257
with the Selector 261
Scrubber tool
S-Curve command 368
SDDS 590
Select All command 275
Select Unused Regions command 352
Select Split Notes command 437, 454, 455
Split notes action 455
selecting
a pitch range of notes 455
across all tracks 280
across multiple tracks 280
all regions in a track 275
all regions in all tracks 275
during playback 276
in MIDI Event List 473
MIDI notes 420
non-contiguous regions 276
notes in a chord 456
regions 275
track material 274
with Edit Selection indicators 279
with Scrubber 282
Selection Changes Alternate Playlists 235
S/PDIF Hardware Setup 43
saving automation 542
sample rate 580
film speed vs. video speed 639
Sample Rate Conversion options 128
time conversion quality 121, 580, 678
Sample Rate setting 40, 580
sample-based timing 234, 383
Samples Time Scale 232
Selection commands
   Play Edit Selection 283
   Play Timeline 284
Selection Memory Location 383
   moving stored selection 387
selections
   across multiple tracks 275, 280
   and Bounce to Disk 574
   and Edit Groups 274
   and hidden tracks 274
   and Playback Markers 274
   auditioning start and end points 284
   changing length of 278
   clearing 314
   consolidating 348
   copying 313
   cutting 313
   duplicating 317
   extending 279, 361
   extending to the Meter Ruler 375
   extending to the Tempo ruler 355, 388
   including Conductor rulers 281
   looping 285
   moving to adjacent tracks 281
   moving to the next/previous region 282
   non-contiguous 276
   nudging 278, 306
   nudging start/end points 278
   Object 276
   on-the-fly 276
   pasting 313
   playing 283
   removing a track from 281
   repeating 318
   shifting 307
   storing with Memory Locations 383
Selector tool 248, 265
   scrubbing with 261
   selecting MIDI notes with 420
Send controls 488
Send Levels Follow Groups option 65
Send mute 488
Send Mutes Follow Groups option 65
Send pan 488
Send to Back command 292
Send via DigiDelivery command 136
   sends 488
   adding 488
   and multichannel mixing 609
   Assignment View 490
   automating 544
   changing default setting 489
   copying track automation to 545
   default level 489
   displaying controls for 491
   for hardware I/O 489
   for mix busses 489
   labeling 530
   mono or stereo 489
   multichannel 609
   removing 489
   Sends Default to -INF option 59
   Sends View 484
   Separate Region commands 290
   and multiple tracks 291
   and related takes 179
   At Selection 290
   At Transients 290
   On Grid 290
Separate Region Operates On All Related Takes option 64, 179, 290
Separation Grabber 291
session data
   importing 124
   Session Data to Import menu 129
Session File Backups folder 47
session files
   concepts 12
   session parameters 51
   Session Setup window 645
   Current TC 667
sessions 12
   audio format 464
   backups 47, 61
   bit depth 46, 464
   closing 54
   creating 45
   creating for surround mixing 600
   frame rate 467
   mixed audio formats 51
   opening 47
   opening from a Transfer volume 47
   sample rate 40, 46, 464
   saving 49
   start frame 464
   templates 53
Set As User Default command 523
Set Plug-In Default To command 523
Set Record Tracks to Auto Input command 156
Set Record Tracks to Input Only command 156
Set Root Settings Folder command 524
Set Servo Lock Bit at Play (Tamura Support) preference 68
setting punch/loop points 180
settings
   choosing a destination for 524
   copying 525
   creating subfolders 524
   creating User Default 525
   importing 525
   pasting 525
   saving 525
   Settings Preferences command 523
Setup menu
   Click/Countoff Options dialog 165
   Disk Allocation 159
   I/O Setup 72
   MIDI windows 430
   Preferences command 56
   QuickTime Movie Offset command 674, 676
   Session Setup 645
Shift command 307
Shift dialog 307
shortcuts for keyboard input 528
Show Auto-Created option 351
Show Meters in Sends View option 56, 491
Show Original Setup button 81
Shuffle mode 246
   and locked regions 308
   and moving regions 299
shuttle
fixed mode option 262
Shuttle, Numeric Keypad mode 34, 61, 262
side-chain
definition 529
side-chain filters 529
side-chain processing 521
signal flow
audio tracks 478
Auxiliary Inputs 479
Instrument tracks 481
Master Faders 480
signal routing
and default path order 86
basics for surround 609
example 15
surround examples 615
Single Zoom mode 251
SIP (Solo In Place) 108
Skip All 142
slices 392
sliding regions 299
Slip mode 246
and moving regions 300
Smart Tool 248, 259
and audio tracks 259
and MIDI tracks 259
and multichannel tracks 260
creating crossfades with 259
creating fades with 259
editing automation with 260
editing controller events with 260
Smooth and Thin Data After Pass option 64, 550
smoothing automation 540
SMPTEx
configuration 649
frame formats 637
start frame for session 646
SMPTEx/ITU 590
Snap Pan to Speaker icons 624
snapshot automation 568
adding to empty automation playlists 568
and trim values 570
writing over existing automation 569
SND resource file format 576
Soft Limit 43
Solo button 107
Solo Latch options 109
Solo Modes 108
Solo modes
selecting 109
Solo Safe mode 110
soloing
tracks 108
tracks in a submix 505
SoloS Follow Groups option 65, 107
Song Start Marker 353
editing tempo 353
moving 353
Sort By option 242
sorting
Markers 390
regions 242
Sound Designer II file format 576
Source Path 575
speakers
layouts 590
suggested 5.1 placement 592
surround calibration 593
surround placement 592
Speed Cal indicator 648
split (MIDI) 454
Split into Mono Track command 318, 607
Split notes action 455
splitting stereo and multichannel tracks 318
Spot dialog 301, 662
Use Subframes option 662
User Time Stamp button 664
Spot mode 246, 661
and moving regions 301
trimming regions in 664
spotting
auto-spotting 663
QuickTime movies 677
regions 301, 661, 663
SRC options 128
Standard MIDI Files 136
exporting 138
importing 136
Type 0 136
Type 1 136
start frame, for sessions 646
Start, End, and Length display 24, 181
stems 71
surround examples 616
Step Input command 200, 437, 457
stepped control automation 553
Stereo 580
stereo format 590
stereo inserts 512
stereo interleaved files, exporting 132
Stereo Mix
I/O Setup factory preset 83
stereo tracks
dragging regions to 319
names for 158
replacing regions in 311
splitting 318
Stop at Shuttle Speed Zero option 68
Stop button 26
Stop Disarms Audio Track Record Button 211
Stretch Tempo command 370
Strip Silence command 345, 346
and region naming 346
Strip Silence window 345
stuck notes 436
Sub Counter selectors 233
Sub Time Scale 233, 652
subfolders, creating for settings 524
subframes 662
submixes
applying an insert to 502
bouncing to 582
bouncing to disk 573
soloing tracks in 505
sub-paths 71
examples for surround 612
surround
and sends 609
basic signal routing 609

Index 711
bass management 598
center percentage (%) 628
concepts 589
configuring Pro Tools and sessions 600
delivery formats 597
discrete level, solo, mute 607
divergence basics 595
encoding and decoding 597
equation.5.1 format paths 603
importing I/O Settings 601
Lt Rt 594
mix compatibility 596
mixing concepts 596
pan playlists and automation 630
panning grids 620
Pro Tools formats 590
settings files 600
speaker arrangements 590
terminology 593
using paths 612
using sub-paths, examples 612
SurroundScope 630
Suspend All Groups command 116
suspending automation 547
writing automation 547
swing 440, 442
SYNC I/O 634, 637
and VSO
generating time code with 657
resolving with 643
sync options 644
Sync Mode field 646
Sync Offset 649
Sync Point View option 304, 666
sync points 666
for QuickTime movie 676
for regions 303
from Beat Detective 409
identifying 304, 666
synchronization 633
3:2 Pulldown 638
and film 638
Bi-Phase/Tach 636
black burst 667
film speed vs. video speed 639
guide tracks 638
LTC 636
MIDI Beat Clock 661
MMC 657
options 643
positional reference 635
pull up and pull down 640
resolving 667
SMpte frame formats 637
time code 635
troubleshooting 667
VITC 636
Sysex View 432
system
settings 37
shutting down 37
starting up 37
System Exclusive data 20, 432
deleting 433
moving 433
recording 203
System Memory Allocations 41
system resources 16
System Usage window 55
View options 55
Tab to Transients button 283
take over (surround pan) 625
Take Region Lengths That Match option 64, 179
Take Region Names That Match Track Names option 63, 179
takes
auditioning 178
auditioning from Takes List 178
default names 158
numbering for QuickPunch 208
recording additional 173
Takes List pop-up menu 178
and multiple tracks 179
tapping in the tempo 168
Target button 521
Tascam DA30 43
Task Manager 124
TC/E Plug-in preference 66
TCE Edit to Timeline command
and multichannel tracks 287
TCE Edit to Timeline Selection command 287
TDM plugins 512
TDM Time Slot usage 55
templates
Beat Detective 402
DigGroove 402
Pro Tools session 53
tempo
current 354
default 167
display 29
effects on Markers and Memory Locations 383
Manual Tempo mode 168
tapping in 168
Tempo Edit Density pop-up menu 360
tempo events 354
and Bar|Beat Markers 372
editing 355
inserting 354
tempo map
from Identify Beat command 370
importing 131
Tempo Operations commands
Constant command 365
Linear command 366
Parabolic command 367
Scale command 369
S-Curve command 368
Stretch command 370
Tempo Operations window 364
Tempo Resolution selector 359
Tempo ruler
displaying 354
extending an Edit selection to 355, 388
Tempo Ruler Enable button 29

Tempo slider 29
Tempo Sync 521
test 581
Thin Automation command 550
thinning automation 541, 549
tick-based timing 234, 383
time code 635
and Jam Sync 649
capturing 662
freewheeling 648
generating 648, 656
Time Code Mapping options 127
Time Code Time Scale 232
Time Compression/Expansion plug-in 287
Time Compression/Expansion Trim tool 66, 255, 425
Time Grabber tool 277
Time Operations commands 376
Change Meter command 377
Cut Time command 380
Insert Time command 378
Move Song Start command 381
Time Operations window 374, 376
Time Scale 232
Bars:Beats 232
Feet:Frames 232
Minutes:Seconds 232
Samples 232
Sub 233, 652
Time Code 232
Time Stamp command 179, 664
Time Stamp Selected command 302
time stamps 664
and Bounce to Disk 574
Timebase rulers 231
and selecting on all tracks 280
and Timeline selections 285
Edit Markers 273
Playback Markers 273
Pre/Post-Roll Flags 273
sliding Edit selections 282
sliding Timeline selections 286
Timecode Rate pop-up menu 647
Timeline and Edit selection, unlinked 272
Timeline Drop Order command 296
Timeline Insertion Follows Playback option 59
timeline selections 285
and Playback Markers 286
auditioning with Playhead enabled 288
copied from Edit selection 286
copied to Edit selection 286
in Timebase rulers 285
sliding in the Ruler 286
start, end, and length fields 27
toggling
track height 224
Track View 223
zoom level 254
Tool Tips 30, 57
Touch Timeout option 65
Track Compensation (cmp) indicator 507
track controls
Edit window 24
Mix window 24
track data 220
Track Height 224
and Zoom Toggle 253
track layout
default path order 86
track level meters 92
Track List 98
Track menu
Auto Input Monitoring mode 155
Clear All Clip Indicators command 92, 93, 491
Delete command 96
Duplicate command 97, 535
Group command 117
Input Only Monitoring mode 155
Make Active command 111
Make Inactive command 111
New Track command 94
Scroll to Track 95
Scroll to Track command 271
Set Record Tracks to Auto Input 156
Set Record Tracks to Input Only 156
Split into Mono command 318, 607
Write MIDI Real-Time Properties command 464
Track Name/Comments dialog 94
Track number command 95, 271
Track Offset options 128
Track Position Numbers Stay with Hidden Tracks option 56
Track Record Enable indicator 27
Track Selector 520
Track View 221
and edit content 312
Blocks 221
changing 222
Expanded Track Display 224, 554
Master View 557
Notes 221, 228
Regions 221, 229
Sysex 432
toggling 223
Velocity 422
Waveform 226
Track View selector 222
Track View Toggle 223
track width 93
TrackInput Monitor button 155
TrackInput Monitor indicator 27
TrackPunch mode 208
TrackPunch preferences 210
tracks
5.1 format track layout 606
adding comments 95
adding to selection 280, 281
and surround 605
appending new material to end of 175
Color Coding options 111
concepts 13
duplicating multichannel tracks into mono tracks 607
deleting 96
hiding 99
locating with Fast Forward/Rewind 266
making inactive/active 111
Master View 223, 557
metering 92
moving selections between 281
Pro Tools Reference Guide

714

muting 110
  names 93, 158
  placing regions in 295
  playback priority 103
  playing 265
  record enabling 152
  removing from a selection 281
  scrolling shortcut 270
  selecting across multiple 280
  selecting all regions in 275
  selecting all regions in all tracks 275
  selecting material in 274
  soloing 108
  Track Height 224
  Track View 221, 222
  transposing 453
  trimming unwanted data from 293

trajectory panning 626
Transfer files 142
Transfer Volume defined 689
  transients
    detecting with Beat Detective 396
    tabbing to 283
Transport
  Track Record Enable indicator 27
  TrackInput Monitor 27
  Transport Master button 28
  Transport Numeric Keypad Mode 34, 61
  Transport Online option 656
  Transport RecordLock option 59, 211, 215, 216
  Transport view options 28, 181, 183, 269
  Transport window 25
    MIDI controls 28
    pre/post-roll 27, 183
    record status display 212
    start, end, and length fields 27, 181
    transport controls 25
  Transport, Numeric Keypad mode 34
Transpose
  Real-Time Properties 463
  Transpose command 437, 453
  transposing 453
    by octave 454
    key 454
    MIDI notes 421
    tracks 453
Trim Automation commands 570
  Trim to All Enabled 570
  Trim to Current 570
Trim Region commands
  End to Fill Selection 294
  End to Insertion 293
  Start to Fill Selection 293
  To Fill Selection 294
  To Selection 293
Trim tools 248, 254, 362, 552
  Scrub Trim tool 257
  Time Compression/Expansion Trim tool 66, 255, 425
trimming
  automation breakpoints 362, 552, 560
  crossfades 340
  note start/end points 421
  region start/end points 255
  regions by Nudge value 294
  regions to Edit insertion point 293
  regions with Scrub Trim 297
  unwanted region and track data 293
Tweak Head setting 581, 678
U
  unavailable I/O
    showing 81
  unavailable resources 48
  Undo and audio recording 172
  Undo command 239
  Undo History window 239
  Undo Queue 240
  Ungroup All Regions command 322
  Ungroup Regions command 322
  Universe window 263
  unlinked Timeline and Edit selection 272
  unlinking plug-in controls 527, 611
  Unloop Regions command 330
  Use All Available Space option 61
  Use AudioSuite Dither preference 66, 509
  Use F11 for Wait for Note option 60, 191
  Use MIDI to Tap Tempo option 67
  Use Squeezer option 581
  Use Subframes option 662
  User Default setting, creating 525
  User Offset (+/-) field 506
  User Time Stamp 302, 665
  user-defined regions 220, 350, 351
V
  Variable Speed Override 647
  velocities, for MIDI notes
    default for inserted 419
    drawing with Pencil 423
    editing 422, 449
    editing velocity 422
    fading 451
    scaling 451
    scaling with Trimmer 423
Velocity
  Real-Time Properties 463
  Velocity View 422
  video
    recording limits with pull 655
  video capture/playback cards 670
  Video Media options 127
  Video Pull Up/Down 653
  video speed 639
  View Filter
  Memory Locations window 389
  View Filter command 468
View menu
  Edit Window view option 21
  Edit Window view options 483
  Mix Window option 21
  Mix Window view options 483
  Narrow Mix view option 93
  Region Name view option 225
  Region Sync Point View option 304
  Region Time view options 225
Index

Sync Point view option 666
System Usage view options 55
Track Number command 95, 271
Transport view options 28, 181, 183, 265
views
Delay Compensation 93
I/O View 91
Inserts View 484
 Sends View 484
Wide Meters View 93
VITC (Vertical Interval Time Code) 636
Voice 22
Voice selector 103
voices
and RTAS 513
and track priority 103
auto-assignment of ascending 104
for TrackPunch 208
Volume
types, definitions 686
Volume automation 552
Volume fader 92
Volume indicator 91
VSO (see Variable Speed Override)

W
Wait for Note 29, 191
WAV file format 143, 576
AES31/Broadcast compliant 143
WaveCache.wfm file 48
Waveform View 226
waveforms 226
and zero-crossing 227
avoiding clicks and pops 227
drawn rectified 226
guidelines for editing 226
repairing with Pencil tool 320
Web site 4
whole-file audio regions 220
Wide Meters View 93
Window menu
Automation Enable command 543
Big Counter command 265
Color Palette 114
Disk Space command 162
Edit command 21
Machine Track Arming command 660
Memory Locations command 386
Mix command 21
Project command 142
QuickTime command 675
System Usage command 55
Task Manager command 124
Transport command 25
Undo History command 239
Universe command 263
Workspace command 160
Windows sessions
compatibility with Macintosh 145
Word Clock 43
about 690
workflows 214
Workspace browser 160, 161
Write Automation command 569
Write Automation commands 568, 569
Write Automation to Next Breakpoint command 563
Write Automation to Next Breakpoint on Stop command 565
Write Automation to Selection/Selection Start/Selection End
buttons 561
Write MIDI Real-Time Properties command 464
Write to All Enabled Automation command 569
Write to Current Automation command 569
writing
automation 543
automation on stop 563
automation to next breakpoint 563
automation to selection, selection start, or selection end
561
snapshot automation 568

X
XML (Extensible Markup Language) 430
X–OR (Cancels Previous Solos) Solo Latch option 110

Z
zero-crossing 227
Zoom buttons 249
Zoom Presets 252
Zoom Toggle command 253, 254
Zoomer tool 248, 249, 250
zooming 249
a track area 250
all the way out 250
around a track point 250
continuously 249
horizontally for all tracks 249
in the ruler 251
on a selection 250
recalling zoom levels 252
return to the previous zoom level 250
storing zoom levels 252
to make all regions visible 250
vertically for all audio tracks 249
vertically for all MIDI tracks 249, 250
with a scroll wheel 254
Zoom Toggle 253
zooming without changing playlists 254