
   

What’s New M-Powered 7.0.book  Page i  Friday, October 21, 2005  2:59 PM
What’s New
Pro Tools M-Powered™ 7.0



   

What’s New M-Powered 7.0.book  Page ii  Friday, October 21, 2005  2:59 PM
Copyright

© 2005 Digidesign, a division of Avid Technology, Inc. All rights 
reserved. This guide may not be duplicated in whole or in part 
without the express written consent of Digidesign. 

Avid, Digidesign, M-Audio, and Pro Tools are either trademarks 
or registered trademarks of Avid Technology, Inc. in the US and 
other countries.  All other trademarks contained herein are the 
property of their respective owners.  

Product features, specifications, system requirements, and 
availability are subject to change without notice. 

PN 9329-17736-00 REV A 11/05



   

contents

                                                   

What’s New M-Powered 7.0.book  Page iii  Friday, October 21, 2005  2:59 PM
Chapter 1. Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1

System Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1

New Features in 
Pro Tools M-Powered 7.0 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1

Chapter 2. System Configuration and Session Compatibility Updates . . . . . . . . . . . . .  5

Additional Supported M-Audio USB Hardware. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

Increased Sends and Busses  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

Up to 999 Markers/Memory Locations per Session  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

Compatibility  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  6

Localization  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9

General Performance Enhancements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9

Chapter 3. Pro Tools Menus and Windows  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11

Improved and Expanded Menus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11

New Consolidated Region List for Audio, MIDI, and Region Groups. . . . . . . . . . . . . . . . . . . . .  12

Tool Tips. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

New Shortcuts and Tools for Mix and Edit Window Display Options  . . . . . . . . . . . . . . . . . . . .  15

Enhancements to I/O Setup and Disk Allocation Dialogs. . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

DigiBase Changes and Additions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

Improved Window Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

Chapter 4. New Track Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17

Instrument Tracks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17

Increase in Total Number of Sends Per Track to Ten . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  22

Moving and Copying Sends. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23

New Duplicate Tracks Dialog and Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  24

Color Coding Improvements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  25

Importing and Exporting. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  27
Contents iii



  

iv

                                                       

What’s New M-Powered 7.0.book  Page iv  Friday, October 21, 2005  2:59 PM
Chapter 5. Audio and MIDI Features for Composition . . . . . . . . . . . . . . . . . . . . . . . . . .  29

Region Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29

Importing REX Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  38

Importing ACID Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39

Region Looping  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40

Special Cut, Copy, Paste, and Clear Commands. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  44

Drag and Drop Features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

Preview Files from Windows Explorer or Macintosh Finder . . . . . . . . . . . . . . . . . . . . . . . . . .  47

Link Track and Edit Selection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  48

Zoom Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49

Additions to Strip Silence  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

Additions to Separate Regions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

Chapter 6. MIDI Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  53

MIDI Real-Time Properties. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  53

Sample-Based MIDI  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  60

Mirrored MIDI Editing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  61

Previewing MIDI Regions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  62

Default Thru Follows First Selected MIDI Track Selection Preference . . . . . . . . . . . . . . . . . . .  62

Selection of Note Ranges from Track Mini-Keyboard  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63

New Select and Split Notes Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  65

New Quantize Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  66

Legato, Overlap, and Duplicate Additions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  67

New Remove Duplicate Notes Command . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  68

Transpose Window Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  68

New Import MIDI Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  68

Exporting MIDI Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

MIDI File Support in DigiBase  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  70
What’s New in Pro Tools M-Powered 7.0



                               

What’s New M-Powered 7.0.book  Page v  Friday, October 21, 2005  2:59 PM
Chapter 7. Plug-Ins  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71

RTAS Performance Features. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71

New Shortcuts to Enable All Plug-In Parameters. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  73

RMS and Peak Calibration Modes for Signal Generator Plug-In  . . . . . . . . . . . . . . . . . . . . . . .  73

RMS and Peak Calibration Modes for Normalize Plug-In . . . . . . . . . . . . . . . . . . . . . . . . . . . .  74

RMS and Peak Calibration Modes for Gain Plug-In . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  74

TimeAdjuster RTAS Plug-In. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  74

Trim Plug-In +12 dB Updates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  75

EQ III Band-Pass Mode. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  75

Synchronic Updates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  76

Bomb Factory Updates. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  79

Pro Tools M-Powered Support for Additional Plug-Ins  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80

Chapter 8. Control Surface Features. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  81

Command|8 New Features and Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  81
Contents v



  

vi

 

What’s New M-Powered 7.0.book  Page vi  Friday, October 21, 2005  2:59 PM
What’s New in Pro Tools M-Powered 7.0



              

What’s New M-Powered 7.0.book  Page 1  Friday, October 21, 2005  2:59 PM
chapter 1

Introduction
This document is an overview of new features in 
Pro Tools 7.0 for Pro Tools M-Powered systems 
on Windows XP or Mac OS X. 

System Requirements
For complete system requirements, visit the 
compatibility page of the Digidesign Web site 
(www.digidesign.com/compato).

Compatibility Information

Digidesign can only assure compatibility and 
provide support for hardware and software it 
has tested and approved. 

For a list of Digidesign-qualified computers, op-
erating systems, hard drives, and third-party de-
vices, refer to the latest compatibility informa-
tion on the Digidesign Web site 
(www.digidesign.com/compato). 
New Features in 
Pro Tools M-Powered 7.0
Pro Tools M-Powered 7.0 includes the following 
new or enhanced features:

System Configuration and Session 
Compatibility Updates

• New support for M-Audio USB devices

• Increased Sends and Busses 

• 999 Markers/Memory Locations per session 

• Sessions and compatibility:

• New session file format (“.ptf”)

• Support for long file names

• Removal of +6 dB option for new sessions

• All sessions are Mac/PC compatible 

• Recommended BWAV dialog

• Localization:

• Cross-platform and language session com-
patibility

• Traditional Chinese localization

• General Performance Enhancements:

• Faster session opening on Windows XP

• Improved editing speed

• Improved window redraw on Windows XP
Chapter 1: Introduction 1
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Pro Tools Menus and Windows

• Improved and expanded menus

• Tool Tips

• Consolidated Region List with improved 
search tools

• Shortcuts and new tools for Mix and Edit win-
dow views 

• Resizable I/O Setup and Disk Allocation dia-
logs

• DigiBase changes and additions:

• Support for Standard MIDI Files

• Bar|Beat display of Duration (length) for 
tick-based audio and MIDI files 

• New Tempo column 

• Improved window interaction for 
Windows XP

Track Features

• Instrument tracks

• Software and hardware instruments

• Unrestricted MIDI and audio routing 

• Increased sends per track to 10

• Ability to move and copy sends 

• Increased busses on Pro Tools LE and M-Pow-
ered to 32

• New Duplicate Tracks dialog and options

• Color Coding improvements

• Importing and exporting:

• REX and Acid files

• AAC files

• Groups and markers from other sessions

• Importing audio from audio CDs 
(Windows XP)
What’s New in Pro Tools M-Powered 7.0
Audio and MIDI Composition Features

• Region groups:

• Audio and MIDI regions

• Multi-track region groups

• Nested groups

• Fades and crossfades across grouped re-
gions

• Importing and exporting region groups

• DigiBase support for grouped files

• Looping audio and MIDI regions or region 
groups

• Special Cut, Copy, Paste, and Clear com-
mands

• Drag and drop features: 

• Drag and drop audio, REX, ACID, or MIDI 
files from Windows Explorer or Macintosh 
Finder to the timeline or Region List

• New Timeline Drop Order Modes to drop 
multiple regions (Top to Bottom or Left to 
Right)

• Drag and drop audio files to plug-ins from 
DigiBase

• DigiBase support for drag and drop of REX, 
ACID, region groups, and Standard MIDI 
files

• Ability to preview files from Windows Ex-
plorer or Macintosh Finder

• Link Track and Edit Selection command

• Zooming enhancements:

• Improved Zoom Toggle for streamlined 
MIDI and audio editing

• Continuous zoom with Zoom tool

• Marquee Zoom both vertical and horizon-
tal zoom on MIDI tracks

• Independent vertical track zoom

• Automatic “Show All Notes” scaling for 
vertical zoom of MIDI regions
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• Additions to Strip Silence:

• Extract function (extract silence)

• Separate function

• Additions to Separate Regions commands:

• Separate on Grid command

• Separate at Transients command

MIDI Features

• MIDI Real-Time Properties

• Sample-based (tempo-independent) MIDI

• Mirrored MIDI Editing

• MIDI region previewing in the Region List

• Selection of note ranges from on-screen mini-
keyboard

• New Preference for “Default Thru follows 
Track Selection”

• New Select/Split Notes window

• New Grid/Groove Quantize window

• Groove Quantize support for Input Quantize 

• New Remove Duplicate Notes command

• Legato and Overlap additions 

• Transpose Window enhancements

• New Import MIDI to Timeline options

• Support for exporting MIDI files
New or Enhanced Plug-In Features

• Multi-processor support for RTAS plug-ins 

• RTAS Performance Enhancements

• New shortcuts to enable plug-in parameters

• RMS and Peak calibration modes for Signal 
Generator, Gain, and Normalize plug-ins

• Support for RTAS version of Time Adjuster 
plug-in

• Trim plug-in +12 dB update

• EQ III Band-Pass mode

• Synchronic updates:

• Drag and drop audio files to Synchronic 
Waveform display

• Support for AudioSuite version of Synchro-
nic

• Bomb Factory updates:

• Updated rotary control behavior

• Restore Bomb Factory plug-in settings

• Support for the AudioSuite versions of Sound-
Replacer and NoNOISE plug-ins

Control Surface Features

• Support for 10 sends on Command|8

• Support for Instrument tracks on Command|8
Chapter 1: Introduction 3
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chapter 2

System Configuration and Session 
Compatibility Updates
This chapter describes changes to Pro Tools sys-
tem capabilities. 

Additional Supported M-Audio 
USB Hardware
With Pro Tools M-Powered 7.0, Pro Tools is now 
supported on the following M-Audio USB de-
vices:

• Black Box (USB)

• Ozone (USB) 

• Transit (USB)

• Fast Track (USB)

• MobilePre (USB)

For the most current list of supported M-Audio 
hardware, visit the Digidesign Web site: 
(www.digidesign.com/compato).

Increased Sends and Busses
On all systems, each audio, Auxiliary Input, and 
Instrument track now provides 10 sends for 
routing audio to internal busses or hardware 
outputs. For instructions on displaying and us-
ing the increased number of sends, see “Increase 
in Total Number of Sends Per Track to Ten” on 
page 22.
Chapter 2: 
With Pro Tools LE and M-Powered, 32 internal 
busses are now available. (In previous versions 
of Pro Tools LE and M-Powered, the maximum 
was 16). This provides greater bussing resources 
for sessions, and simplifies session interchange 
between Pro Tools HD, LE and M-Powered ses-
sions. 

Up to 999 Markers/Memory 
Locations per Session 
Each session can include up to 999 Mark-
ers/Memory Locations. (In previous versions of 
Pro Tools, the maximum number of memory lo-
cations was 200 per session). 

Markers and Memory Locations are useful for 
identifying sections of songs or scenes, to 
quickly navigate to specific locations, and to 
store selections for consistency when audition-
ing, editing, and bouncing to disk. 

Markers/Memory Locations are also avail-
able as choices in the Import Session Data 
command, to transfer markers or memory 
locations from one session into another. For 
more information, see “Importing and Ex-
porting” on page 27. 
System Configuration and Session Compatibility Updates 5
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Compatibility

New Session File Format (“.ptf”)

Pro Tools 7.0 uses a new session file format and 
extension (.ptf) to distinguish its sessions from 
sessions created with previous versions. 

The new .ptf file format supports many new op-
tions for session compatibility and transfer as 
described in the following sections. 

Pro Tools 7.0 file icons identify Pro Tools HD, 
Pro Tools LE, and Pro Tools M-Powered session 
files. Each Pro Tools system features a unique 
icon which will be used for all session files on 
that system (regardless of whether a session file 
was created on a different Pro Tools system). 

WaveCache

Each session folder also contains a WaveCache 
file. Pro Tools creates this file automatically and 
uses it to store waveform overview data. By stor-
ing waveform data in the WaveCache file, ses-
sions are able to open more quickly. The session 
WaveCache file can be included whenever a ses-
sion is transferred to another Pro Tools 7.0 sys-
tem. 

Pro Tools also maintains a distinct WaveCache 
file inside the local Digidesign Databases folder 
(C:\\Digidesign Databases) which retains wave-
form data for all files used on the system. Addi-

Session file icons

Pro Tools HD Pro Tools LE Pro Tools M-Powered
What’s New in Pro Tools M-Powered 7.0
tional WaveCache files are created on each ex-
ternal hard drive attached to your system, and 
stored in the Digidesign Databases folder on 
each drive. 

Deleting or trashing any of the WaveCache files 
will not harm the session or your system. Each 
session will merely need more time to open due 
to having to recalculate waveform data for asso-
ciated audio (and store that data in a new Wave-
Cache file). 

Session Compatibility

A Pro Tools 7.0 format session cannot be played 
on Pro Tools versions 6.9.x or lower. To save a 
7.0 session that is compatible with previous ver-
sions of Pro Tools, use the File > Save Copy In 
command to choose the destination session for-
mat (such as 5.1–6.x) and other options. See the 
Pro Tools Reference Guide for details on session 
and file compatibility. 

Pro Tools 7.0 and later session attributes are 
changed in the following ways when the session 
is saved to a prior version of Pro Tools:

• Long file names are shortened.

• Region groups are dropped.

• Region loops are dropped.

• Sample based MIDI regions are dropped.

• Sample based MIDI tracks are dropped.

• Sends F–J and automation (if any) are 
dropped.

• Markers/Memory Locations 201–999 are 
dropped.

• Instrument tracks are converted to MIDI 
and Auxiliary Input tracks.
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Support for Long File Names and 
Unsupported Characters

Pro Tools 7.0 lets you name files with as many as 
128 characters. 

However, files can be renamed in certain situa-
tions when saving a copy of a session to a 
Pro Tools version that does not support long file 
names. See “Renamed Audio Files Folder” on 
page 7.

Pro Tools also automatically renames files while 
opening sessions when file names contain ille-
gal characters.

Renamed Audio Files Folder

This folder includes file that have been re-
named. Files can be renamed when you open a 
session that references audio file names with in-
compatible characters. Files can also be renamed 
in certain situations when saving a copy of a ses-
sion to a Pro Tools version that does not support 
long file names.

Opening a Session that Contains Audio File 
Names with Illegal Characters

Pro Tools 7.0 does not support audio file names 
that contain certain ASCII characters (such as * 
and @).

When opening sessions that contain audio file 
names with illegal characters, Pro Tools auto-
matically creates a renamed copy of each file 
that contains illegal characters (replacing these 
characters with an underscore “_”). Renamed 
files are copied to the Renamed Audio Files 
folder. The original files are left intact in the Au-
dio Files folder.
Chapter 2: 
Before the session opens, you are prompted to 
save a detailed report of the renamed files and 
their original file names to a Notes text file. Fol-
low the on-screen instructions. By default, the 
Notes text file is saved to the Session folder.

Saving a Copy of a Session that Contains Long 
Audio File Names

When saving files to Pro Tools 6.9.x and lower 
(using Save Copy In), audio files with file names 
that exceed the limits of the destination format 
will be truncated and located in the Session 
folder, as follows:

• If the new session is saved to the same direc-
tory as the original, a Renamed Audio Files 
folder is created in the session’s original 
folder, and the renamed audio files are placed 
in it.

• If the new session is saved to a different direc-
tory than the original the All Audio Files op-
tion is not checked, a new Session folder is 
created, which includes an Audio Files folder 
and a Renamed Audio Files folder. Renamed 
audio file will be included in the Audio Files 
folder.

• If the new session is saved to a different direc-
tory than the original and the All Audio Files 
option is checked, a new Session folder is cre-
ated, which includes an Audio Files folder. Re-
named audio files will be included in the 
Audio Files folder.

It is possible to have a Pro Tools 7.0 session 
that contains audio file names with illegal 
characters. In this case, if you Save Copy In 
the session to Pro Tools 6.9.x or lower with 
Mac/PC Compatibility on, the tracks will 
be renamed with legal characters. If you 
Save Copy In the session to Pro Tools 6.9.x 
or lower with Mac/PC Compatibility off, 
the characters are not changed.
System Configuration and Session Compatibility Updates 7
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Saving a Notes Report

Pro Tools Session notes list the old and new 
names of converted files. To save a text (.txt) file 
containing a more detailed Notes report while 
opening a session, follow the on-screen instruc-
tions when prompted. The Notes report will be 
named with the session name, followed by 
Notes.txt. You can choose to save this file in 
your Session folder, or in another location.

When saving a Pro Tools 7.0 session to a previ-
ous version, session notes list all parameters that 
are not supported and will be dropped when 
opened on the destination system. To save a text 
(.txt) file containing a more detailed Notes re-
port while saving a copy of a session to a previ-
ous version, follow the on-screen instructions. 

Opening a session with different settings than the 
current configuration
What’s New in Pro Tools M-Powered 7.0
The Notes report will be named with the session 
name, followed by Notes.txt. You can choose to 
save this file in your Session folder, or in an-
other location.

Fader Gain Always +12 dB in 
Pro Tools 7.0 Sessions

All sessions created with Pro Tools 7.0 are 
“+12 dB” sessions. (The previously available 
+6 dB fader gain option has been removed from 
the New Session dialog.) 

You can save Pro Tools 7.0 sessions to lower ver-
sions of Pro Tools that do support +6 dB using 
the File > Save Copy In command. 

Reminder before saving a Pro Tools 7 session to a 
previous version
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All Pro Tools 7.0 Sessions Are Mac/PC 
Compatible 

Sessions created and saved as Pro Tools 7.0 ses-
sions are always compatible on both Windows 
and Macintosh systems.

The Enforce Mac/PC Compatibility option re-
mains available in the Save Copy In dialog for 
saving sessions to be compatible with lower ver-
sions of Pro Tools. In addition, there are cross-
platform limits to consider when completing 
the Save Copy In. For more information, see the 
Pro Tools Reference Guide.

Recommended BWAV Dialog

The recommended file format for cross-platform 
interoperability is BWF (.WAV). To support op-
timal session interchange, Pro Tools defaults to 
BWF format for new sessions.

Pro Tools lets you save, bounce, and export in a 
variety of file formats. If you attempt to create a 
session and use the SD II format, however, a 
warning dialog will appear reminding you of its 
limitations:

• SD II is not supported on Windows XP.

• The maximum sample rate for SD II files is 
48 kHz. 

The previously available setting for new ses-
sions “Mac/PC Compatibility Mode” is no 
longer required and has been removed from 
the New Session dialog. 
Chapter 2: 
Localization
Pro Tools 7.0 provides improved cross-platform 
language session compatibility. This lets ses-
sions from localized versions of Pro Tools be 
transferred between compatible languages while 
preserving the appropriate settings. 

For the most current information on localized 
versions of Pro Tools, see the compatibility 
pages of the Digidesign Web site for your lan-
guage.

General Performance 
Enhancements
Pro Tools 7.0 includes the following enhance-
ments to general Pro Tools system performance: 

• Faster session opening on Windows XP

• Improved window redraw on Windows XP

• Improved editing speed
System Configuration and Session Compatibility Updates 9
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chapter 3

Pro Tools Menus and Windows
Pro Tools menus and windows have been up-
dated, as described in the following sections. 

Improved and Expanded 
Menus
Menus have been restructured to simplify learn-
ing and using Pro Tools, as follows. 

File Menu Provides commands that read and 
write session data to and from disk. 

Edit Menu Provides actions that operate on the 
current selection and affect data in tracks or the 
clipboard.

View Menu Provides choices to customize what 
is shown in various windows. 

Track Menu Provides actions that operate at the 
track level (affecting whole tracks).

Region Menu Provides actions that operate at 
the region level.

Event Menu Provides actions that operate at the 
event level (such as MIDI and other tick-based 
data).

AudioSuite Menu Provides AudioSuite plug-ins. 

Options Menu Provides items that determine 
how Pro Tools responds.
Setup Menu Provides dialogs and windows to 
configure application and hardware peripheral 
settings.

Window Menu Provides actions for selecting and 
opening specific Pro Tools windows. 

Help Menu Provides links to important Pro Tools 
documentation, including Keyboard Shortcuts, 
DigiBase Guide, DigiRack Plug-Ins Guide, Pro Tools 
Menus Guide, Pro Tools Reference Guide.

For more information, see the Pro Tools Menus 
Guide. 

Tracks, Regions, and Groups List Pop-Up 
Menus

Pop-up menus are provided at the top of the 
Track, Region, and Group Lists. These pop-up 
menus provide commands that affect the con-
tents of their corresponding lists, as follows:

Tracks List Pop-Up Menu Provides commands to 
show, hide and sort tracks in the Mix and Edit 
windows. 

Tracks List pop-up menu
Chapter 3: Pro Tools Menus and Windows 11
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Region List Pop-Up Menu Provides commands to 
find, select, sort, clear, rename, time stamp, 
compact, and export items in the Region List. 
The Region List pop-up menu also provides the 
Recalculate Waveform Overviews and Timeline 
Drop Order commands.

Mix and Edit Group List Pop-Up Menus Provide 
commands to create, display, suspend, and de-
lete Mix and Edit Groups. 

Region List pop-up menu

Mix and Edit Group List pop-up menu
What’s New in Pro Tools M-Powered 7.0
New Consolidated Region List 
for Audio, MIDI, and 
Region Groups
The Edit Window displays all audio regions, 
MIDI regions and region groups in a single, 
comprehensive Region List. 

All regions can be shown in the Region List. 
Items can be dragged from the list to tracks and 
arranged in any order. All types of regions can 
be auditioned from the Region List by Alt-click-
ing (Windows) or Option-clicking (Macintosh) 
them. 

At the top of the Region List is the Region List 
pop-up menu, which provides commands and 
tools for managing the contents of the Region 
List. 

Region list

Previous versions of Pro Tools provided two 
separate lists (the Audio Region List and the 
MIDI Region List) and each list had its own 
menu. The new Region List and Region List 
menu consolidate the functions of these pre-
viously available items. 
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Region List Menu 

The Region List pop-up menu provides tools to 
search, select, sort, export, clear, and manage 
items in the Region List. 

To access the Region List menu:

■ In the Edit window, click the Region List pop-
up at the top of the Region List. 

Enhancements for Sorting and 
Searching the Region List

The more regions a session contains, the harder 
it can become to locate a particular region in the 
Region List. The ability to search and sort re-
gions in the Region List is useful in large ses-
sions. 

Sorting Regions

To sort regions in the Region List:

1  Click on the Region List pop-up menu (at the 
top of the Region List) and choose Sort By. 

Region List pop-up menu

Click to 
display
2  Select a basis for sorting from the submenu:

• Region Type

• Name

• Length

• Original Time Stamp

• User Time Stamp

• Time Base

• Start in Parent

• End in Parent

• File Name

• File Length

• File Creation Date

• File Modification Date

• Disk Name (audio and region groups only

• Track Format/Width

3  To adjust sort results in an ascending or de-
scending order, choose Region List > Sort By, 
and select Ascending or Descending.

Finding Regions

The Find command has been enhanced with a 
new Find History and improved search tools. 

Use the Find command to display all regions in 
a list whose names contain a particular word or 
phrase. 

To find and display regions that match a word or 
phrase:

1  Click the Region List pop-up menu at the top 
of the Region List, and choose Find. Or press 
Control+Shift+F (Windows) or Com-
mand+Shift+F (Macintosh).

Find Regions
Chapter 3: Pro Tools Menus and Windows 13
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2  Type the name, or any portion of the name, 
for the regions you want to find. 

As you enter search text, it is displayed at the 
top of the Region List. Matching results appear 
in the list as they are found. 

3  Click OK. Regions of any type whose name 
match the word or phrase you searched are dis-
played in the Region List. The search string is 
displayed at the top of the Region List in brack-
ets. 

Text entered into the Find dialog is saved in a 
Find History, letting you quickly repeat previous 
searches with a minimum of retyping. 

To repeat a previous search:

1  Click the Region List pop-up menu at the top 
of the Region List, and choose Find.

2  Click the small arrow to the right of the text 
field in the Find dialog and select a text string 
from the Find History pop-up menu. 

The Find History is saved with the session. 

Region List while searching

An example of a Find History

Display of 
search text
What’s New in Pro Tools M-Powered 7.0
In addition to storing each text string previously 
entered, you can insert multiple entries into the 
Find History manually (without having to per-
form each Find in order to store words or 
phrases). 

To compile a Find History without performing each 
search:

1  Choose Region List > Find. 

2  Type the name, or any portion of the name, 
for the regions you want to find. 

3  Click and hold the arrow to the right of the 
text field in the Find dialog and choose Insert 
Entry from the pop-up menu. 

4  Type another entry and choose Insert Entry 
again to add additional search strings to the his-
tory. 

To remove an entry from the history:

1  Select it from the Find History pop-up menu 
so it is displayed in the text field. 

2  Choose Remove Entry from the Find History 
pop-up menu. 

To clear the Find History:

■ Choose Remove All Entries from the Find His-
tory pop-up menu. 

Region List while searching

For more information on using the Region 
List and Regions menu, see the Pro Tools 
Reference Guide. For an overview of the Re-
gions, see the Pro Tools Menus Guide. 
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Tool Tips
Pro Tools provides Tool Tips in all main win-
dows. Parking the cursor for a few seconds over 
an abbreviated name, or unlabeled icon or tool, 
will display either the function or details of the 
item (depending on the Tool Tips preferences 
settings).

To configure Tool Tips for Pro Tools:

1  Choose Setup > Preferences, and click the Dis-
play tab.

2  In the Tool Tips Display section, click the Tool 
Tip options you want displayed. 

Function Shows the functional name of different 
Pro Tools items (such as specific buttons, indica-
tors, modes, selectors, and Edit tools).

Details Shows abbreviated or hidden Pro Tools 
names or values for different Pro Tools items 
(such as insert names, gain levels, settings, and 
routing assignments).

3  Click Done. 

Leave both options unchecked to turn off 
Tool Tips.
New Shortcuts and Tools for 
Mix and Edit Window Display 
Options
This section describes new ways to manage con-
trol views in the Mix and Edit windows.

Shortcut for Hiding Edit Window Views

In the Edit window, you can you use a keyboard 
shortcut to hide an Edit window view (such as 
Comments, Instruments, Inserts, Sends A–E, 
Sends F–J, I/O, Real-Time Properties and Track 
Color). 

To hide an Edit Window view:

■ Alt-click (Windows) or Option-click (Macin-
tosh) the name of the Edit window view (located 
at the top of the view's column). Choices in-
clude Mic Pre, Comments, Instrument, Inserts, 
Sends A–E, Sends F–J, I/O, Real-Time MIDI Prop-
erties, and Track Color.

New Mix Window View Selector

The new Mix Window View selector is located 
in the lower-left corner of the Mix window. 

The Mix Window View selector provides op-
tions that are identical to the options as found 
in the View > Mix Window submenu.

Mix Window Shows selector

Click to display
Chapter 3: Pro Tools Menus and Windows 15
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Enhancements to I/O Setup 
and Disk Allocation Dialogs 

Resizing Enhancements

With Pro Tools 7.0, the I/O Setup and Disk Allo-
cation dialogs can be resized, and provide short-
cuts for scrolling. 

To resize the I/O Setup or Disk Allocation dialogs:

■ Drag the lower-right corner of the dialog ac-
cording to standard convention for your operat-
ing system.

Scrolling Enhancements

With Pro Tools 7.0, scrolling is supported in the 
I/O Setup and Disk Allocation dialogs.

To scroll up or down in the I/O Setup and Disk 
Allocation dialogs:

■ Press Page Up or Page Down.

To scroll left or right in the I/O Setup dialog:

■ Press Alt+Page Up/Down (Windows) or Op-
tion+Page Up/Down (Macintosh).

The Disk Allocation dialog does not scroll 
horizontally, but can be resized to display 
more information.
What’s New in Pro Tools M-Powered 7.0
DigiBase Changes and 
Additions
DigiBase browsers have been enhanced with the 
following additions: 

Support for Standard MIDI Files

DigiBase supports standard MIDI files in brows-
ers, and lets you import (drag and drop) them 
directly into Pro Tools sessions. See “Drag and 
Drop Features” on page 45. 

Bar|Beat Display of Duration 

DigiBase browsers show the length (duration) of 
the following items in Bar|Beats: tick-based au-
dio and MIDI files, region groups, REX files, and 
ACID files. See “DigiBase Support for Region 
Group Files” on page 37. 

New Tempo Column 

When showing tick-based audio and MIDI files, 
region groups, REX and ACID files, DigiBase 
browsers now provide a Tempo column. This 
new column displays the native tempo associ-
ated with the item. 

Improved Window 
Management
(Windows XP Only)

Pro Tools main window displays can be inde-
pendently resized and maximized, letting you 
take advantage of standard Windows XP win-
dow controls while navigating through sessions. 
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chapter 4

New Track Features
This chapter explains the following new or 
changed features that relate to sessions, tracks, 
and compatibility. 

• “Instrument Tracks” on page 17

• “Increase in Total Number of Sends Per Track 
to Ten” on page 22

• “Moving and Copying Sends” on page 23

• “New Duplicate Tracks Dialog and Options” 
on page 24

• “Color Coding Improvements” on page 25

• “Importing and Exporting” on page 27
Instrument Tracks 
Instrument tracks are a special type of track that 
provide MIDI and audio capabilities in a single 
channel strip. Instrument tracks make it easy to 
use software and hardware MIDI instruments, 
record MIDI, and monitor audio from the in-
strument.

Instrument tracks let you do all of the following: 

• Insert RTAS instrument plug-ins or assign ex-
ternal MIDI devices as inputs.

• Record and edit MIDI data for inserted instru-
ment plug-ins, or trigger external MIDI de-
vices. 

• Combine sounds from instrument plug-ins 
and external MIDI devices, and trigger them 
from the same Instrument track. 

• Route and monitor audio output from instru-
ment plug-ins or external MIDI devices. 

• Automate all parameters directly in the In-
strument track, and record and play back 
MIDI controller data on the Instrument track.

• Insert processing plug-ins to process audio 
from instrument plug-ins and external MIDI 
devices. 
Chapter 4: New Track Features 17
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• Insert multiple instrument plug-ins in a row 
so that instrument plug-ins that support (au-
dio) input mode can be used to further pro-
cess audio coming from the first instrument 
on the Instrument track.

• Insert up to 10 sends on each Instrument 
track to route audio to internal busses or hard-
ware outputs. 

• Use fewer total tracks per session, which 
streamlines use of some system resources and 
simplifies session navigation. 

Instrument tracks are supported on all versions 
of Pro Tools and all supported control surfaces. 
Sessions can include up to 128 Instrument 
tracks with Pro Tools HD, and up to 32 Instru-
ment tracks with Pro Tools LE and M-Powered 

Instrument Tracks Quickstart

The basic procedure for using Instrument tracks 
includes the following:

1  Create a new Instrument track in a session. 

2  Select an Instrument, by doing one of the fol-
lowing:

• Insert an instrument plug-in, such as a soft-
ware synthesizer, on the Instrument track. 
The track’s MIDI output is automatically 
assigned to the inserted instrument plug-
in.

• Assign the Instrument track audio input to 
the corresponding hardware inputs from 
an external MIDI device, such as a hard-
ware sampler or synthesizer, then assign 
the desired MIDI output in the Instrument 
track to the appropriate MIDI port and 
channel for the external MIDI device. 
What’s New in Pro Tools M-Powered 7.0
3  Record-enable the Instrument track and play 
your MIDI controller. You can now record MIDI 
data to the Instrument track while playing 
through the instrument plug-in or external 
MIDI device. 

Creating Instrument Tracks

To add Instrument Tracks to a session:

1  Choose Track > New.

2  In the New Tracks dialog, do the following:

• Select Instrument Track from the Track 
Type pop-up menu.

• Select the track format (mono or stereo) 
from the Track Format pop-up menu.

• Select the timebase (samples or ticks) from 
the Track Timebase pop-up menu. 

• Enter the number of new tracks. 

• Click create. 

New Tracks dialog.

For more information on the New Track di-
alog, see the Pro Tools Reference Guide. 
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Inserting Instrument Plug-Ins on 
Instrument Tracks

To insert an instrument plug-in on an Instrument 
track:

■ Click an Insert selector on the Instrument 
track and select the instrument plug-in that you 
want to use. 

A MIDI node is automatically created and as-
signed as the track’s MIDI output. 

Instrument Track Display Options

Instrument tracks follow Pro Tools display set-
tings for the Mix and Edit windows. You can 
show all or some of the control sections for In-
strument tracks by choosing the desired options 
from the View menus, including the new Instru-
ments View. Views can be configured for the 
Mix and Edit windows separately. 

To show or hide Instruments View in the Mix or 
Edit windows: 

1  Choose View > Mix Window > Instruments, or 
View > Edit Window > Instruments. 

Instrument track with an instrument plug-in (Digidesign 
Synchronic shown)

For more information on View options, see 
the Pro Tools Reference Guide.

Insert with instrument plug-in
Instruments View Controls

Instruments View (View > Mix Window > In-
struments, or View > Edit Window > Instru-
ments), provides controls for Instrument tracks 
that affect MIDI data or performance. 

MIDI Input Selector Lets you view and change 
the MIDI Input assigned to the track. 

MIDI Output Selector Shows the current MIDI 
output assignment (usually the instrument 
plug-in on the track), and lets you choose a dif-
ferent MIDI destination to replace or add to the 
current MIDI output assignment. If you insert 
an instrument plug-in, or if you replace one in-
strument plug-in with another one, the plug-
in’s MIDI node will be connected automatically.

MIDI Volume Pop-Up Fader Lets you change the 
MIDI volume (MIDI controller number 7) of the 
track. MIDI volume data is unique from the In-
strument track’s audio Volume automation.

MIDI Activity LED and Velocity Meter Shows 
MIDI input activity on the track. 

Instruments View (Mix window)

MIDI Volume pop-up fader

MIDI Input selector

MIDI Volume pop-up fader
MIDI Output selector

MIDI Activity LED and Velocity Meter
MIDI Pan pop-up slider 
and Mute button
Chapter 4: New Track Features 19
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MIDI Pan Pop-Up Slider Lets you view and 
change the MIDI pan (MIDI controller number 
10) on the track. 

MIDI Mute Button Mutes the MIDI output of the 
track. MIDI mute is independent of audio mute. 

Instrument Track Controls

Each Instrument track has its own set of con-
trols for audio and MIDI. Instrument tracks can 
be color coded, grouped, shown or hidden, and 
support active and inactive track states. 

Instrument Track Controls (Edit 
Window)

MIDI Pan pop-up slider

Instrument track (Edit window)

MIDI Input selector

MIDI Volume pop-up fader

MIDI Output selector

Record Enable (MIDI)

MIDI Activity LED and Velocity meter

Patch selector

Track View

Keyboard

MIDI Playlists

MIDI Mute

buttonSolo (audio)

Mute (audio)

MIDI Pan 
pop-up 
slider

Timebase 
selector
What’s New in Pro Tools M-Powered 7.0
Record Enable Enables MIDI recording on the 
track. 

Solo Mutes post-fader audio output on all other 
(un-soloed) tracks.

Mute Mutes the post-fader audio output of the 
track.

Track View Selects the Instrument track’s view: 
Blocks, Regions, Notes, Volume, Pan, Mute, Ve-
locity, Pitch Bend, After Touch, Program, SysEx, 
and any continuous controller type for MIDI, as 
well as Volume, Pan, Mute, or any plug-in con-
trols that have been automated for audio.

Playlist Selector Shows the main and alternate 
MIDI playlists for the track. 

Patch Selector Opens the Patch Select dialog 
where you can specify patch, program, and bank 
changes for the instrument.

Timebase Selector Sets the Instrument track’s 
timebase to ticks or samples.

Automation Mode Selector Controls how the 
track’s automation data is written and played 
back.

Keyboard Lets you select, audition, and view 
MIDI data. 
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Instrument Track Controls (Mix 
Window)

Audio Input Selector Selects the audio input 
path for the track. If you are using an external 
MIDI instrument, select the audio input path to 
which audio outputs of the MIDI instrument are 
connected. For instrument plug-ins, the audio 
input path is effectively bypassed.

Audio Output Selector Selects the audio output 
path for monitoring audio from the Instrument 
track.

Instrument track (Mix window)

MIDI Input selector

MIDI Volume pop-up fader
MIDI Output selector

MIDI Activity LED and Velocity meter
MIDI Pan pop-up slider 
and Mute button

Inserts

Sends

Audio Input selector
Audio Output selector
Automation Mode selector

Audio Pan sliders and indicators

Record Enable (MIDI)

Solo and Mute (audio)

Output Window button

Volume Fader (audio)

Level Meters (audio)

Patch selector
Group ID
Track Type indicator

Volume indicator (audio)
Automation Mode Selector Controls how the 
track’s automation data is written and played 
back.

Audio Pan Sliders Controls the balance between 
assigned stereo audio output paths for the track.

Record Enable Enables MIDI recording on the 
track. 

Solo Mutes post-fader audio output on all other 
(un-soloed) tracks.

Mute Mutes the post-fader audio output of the 
track.

Volume Fader Controls the audio volume for the 
track.

Patch Selector Opens the Patch Select dialog 
where you can specify patch, program, and bank 
changes for the instrument.

Duplicating Instrument Tracks

When you duplicate an Instrument track, all 
MIDI and audio routing as well as inserts and 
sends are copied. Instrument plug-ins (if any) 
are also copied in the duplicated tracks. 

Active and Inactive Instrument 
Tracks

Instrument tracks support Pro Tools active and 
inactive states. Inactive instrument tracks gray 
out, and do not consume any DSP or other sys-
tem resources. 

To make an Instrument track inactive or active:

1  Select the desired track.
Chapter 4: New Track Features 21
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2  Choose Track > Make Inactive or Make Active.

– or –

In the Mix window, click the Instrument track’s 
Track Type Indicator and select Make Inactive or 
Make Active.

Instrument Tracks and Mix/Edit 
Groups

When Instrument tracks are grouped, MIDI vol-
ume and MIDI mute states follow standard Mix 
and Edit group behavior. MIDI input and output 
routings do not follow grouping. Other parame-
ters follow grouping when the control being ad-
justed supports grouping (such as audio mute 
and solo) and when a matching parameter is 
available on the Instrument track.

Editing Instrument Tracks

In the Edit window, Instrument tracks can be 
edited just like MIDI tracks. Instrument tracks 
also let you edit automation playlists just like 
Auxiliary Input tracks. 

Instrument tracks support the Pro Tools 
keyboard shortcut for applying edits to all 
items: Alt-click (Windows) and Option-
click (Macintosh). These tracks also support 
the keyboard shortcut for applying edits to 
all selected items: Alt-Shift-click (Win-
dows) and Option-Shift-click (Macintosh).

For information on editing MIDI data and 
automation on tracks, see the Pro Tools Ref-
erence Guide.
What’s New in Pro Tools M-Powered 7.0
Increase in Total Number of 
Sends Per Track to Ten
Each audio, Auxiliary Input, and Instrument 
track provides 10 sends for routing audio to in-
ternal busses or hardware outputs. 

All 10 sends provide identical controls, routing 
options and automation capabilities. 

Compatibility Note

In prior versions of Pro Tools, only 5 sends are 
supported per track. If you save a copy of a 
Pro Tools 7.0 session as a “5.1 –.> 6.9.x” and 
lower version, sends F–J will be dropped and 
their automation cleared (if any).

Configuring Sends View in the Mix 
and Edit Windows

Audio tracks, Auxiliary Inputs, and Instrument 
tracks include two sets of Sends Views: Sends 
A–E (sends 1–5) and Sends F–J (sends 6–10). The 
View menu provides separate options for view-
ing these sends in the Mix and Edit windows.

To display sends in the Mix or Edit window:

■ Choose View > Mix Window (or Edit Win-
dow) > Sends A–E (or Sends F–J).

Pro Tools LE and M-Powered 7.0 also pro-
vide an increased number of internal busses 
(32 maximum instead of the previous max-
imum of 16). Opening a Pro Tools HD 7.0 
session on a Pro Tools LE or M-Powered sys-
tem will retain the first 32 internal busses, 
and subsequent busses will be made inac-
tive. 



What’s New M-Powered 7.0.book  Page 23  Friday, October 21, 2005  2:59 PM
To show or hide Sends in the Mix window:

■ Click the Mix Window View selector (in the 
lower-left corner of the screen) and choose 
Sends A–E or Sends F–J. 

To show or hide Sends in the Edit window:

■ Click the Edit Window View selector (in the 
black Edit bar below the Zoom Presets) and 
choose Sends A–E or Sends F–J. 

Sends View Options

Sends are displayed in the Mix and Edit window 
according to the Sends A–E View and Sends F–J 
View options. Each Send View has six view 
choices: Assignments View and five individual 
Send Views (A–E or F–J).

Assignments View

This is the default Sends View, showing all five 
of the Sends A–E or Sends F–J sends on all tracks 
displayed in the Mix and Edit windows.

To hide one of the Sends columns in the 
Edit window (or any other column) Alt-click 
(Windows) or Option-click (Macintosh) the 
name of that column, near the top of the 
Edit window. 

Assignments View, no sends (left) and with an assigned 
send (right)

Send selectors

Send A, Assignment View
In Assignment View, send controls are adjusted 
from Send windows. 

To show all send assignments:

1  If sends are not currently visible on your 
tracks, choose View > Mix Window (or Edit Win-
dow) > Sends A–E (or Sends F–J).

2  Do one of the following:

• Choose View > Sends A–E > Assignments or 
View > Sends F–J > Assignments. 

– or –

• When displaying sends in an individual 
send view (such as Send A View), Control-
click (Windows) or Command-click (Mac-
intosh) the Send selector and select Assign-
ments.

Moving and Copying Sends 
Sends can be moved and copied to other tracks, 
or to other positions on the same track using 
conventional drag and drop. Sends can be 
dropped to create new sends at the destination, 
or dropped onto existing send assignments to 
replace them. 

Sends can be moved and copied to tracks with 
compatible send formats (mono or stereo). 
Pro Tools alerts you when you try to move or 
copy a send to an incompatible destination. (For 
more information, see “Send Format and Track 
Compatibility” on page 24). 

To move a send:

1  Make sure the Transport is stopped. 

2  Click the send name and drag it at a new po-
sition in the original track or in a different track. 
Chapter 4: New Track Features 23
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To copy a send:

1  Make sure the Transport is stopped. 

2  Alt-drag (Windows) or Option-drag (Macin-
tosh) the send and drop it at a new position. 

Moving or copying a send maintains all routing 
assignments, automation (if any), 
level/pan/mute settings, and output format. 

Send Format and Track Compatibility

Sends can only be copied to other tracks with a 
compatible send output format (mono or ste-
reo). In addition, the following conditions ap-
ply when moving or copying sends among 
tracks:

• When copying a stereo send from a mono 
track to a stereo track, Send pan automation 
(if any) will be dropped without warning. 

• When copying a stereo send from a stereo 
track to a mono track, the left Send pan auto-
mation data is retained and the right side data 
is dropped. A warning dialog appears for you 
to confirm or cancel this destructive opera-
tion. 

• When moving or copying a send and replac-
ing an existing send, all automation on the 
existing send will be replaced. A warning dia-
log appears for you to confirm or cancel this 
destructive operation. 

New Duplicate Tracks Dialog 
and Options
The Duplicate Tracks dialog lets you define how 
many copies of a track you want to create, and 
specify which properties will be copied to dupli-
cated tracks. 
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To duplicate tracks:

1  Select a track in the Mix or Edit window. 

2  Choose Track > Duplicate. Or press 
Alt+Shift+D (Windows) or Option+Shift+D 
(Macintosh). 

3  Configure the following options as needed:

• Enter how many copies you want to create 
by typing into the Number of Duplicates 
field. 

• To copy the currently active (visible) Edit 
playlist from the source track, enable Ac-
tive Playlist. 

• To copy all Edit playlists on the source 
track, enable Alternate Playlists

• To copy all automation from the source 
track, enable Automation. 

• To copy all plug-in and insert assignments, 
enable Inserts. 

• To copy all sends and send assignments, 
enable Sends.

• To maintain all Mix and Edit Group assign-
ments, enable Group Assignments. 

Duplicate Tracks
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4  Configure the “Insert after last selected track” 
option as desired: 

• If you want the duplicate tracks to be added 
next to each of the selected source tracks, 
deselect the option. This lets you keep orig-
inals and their duplicates together (moving 
and renumbering tracks accordingly).

• To have the new duplicate tracks added af-
ter all currently visible tracks (to the far-
right in the Mix window, and at the bottom 
in the Edit window), enable the option. 
This lets you keep all originals tracks in 
their current location (and Track number), 
and keep all duplicates together below or to 
the right of all previously existing tracks. 

5  Click OK to duplicate tracks according to the 
settings in the Duplicate Tracks dialog. Click 
Cancel to close the dialog and not create dupli-
cate tracks. 

Color Coding Improvements
Pro Tools provides new Preference options for 
color coding, as well as improved tools and fea-
tures in the Color Palette that let you more eas-
ily assign and manage color coding of session el-
ements. 

Region List Color Coding Option

With Pro Tools 7.0, the default color coding as-
signment for regions in the track playlist in-
cludes a Region List Color option. With this op-
tion selected, you can change (default) the color 
of any region in the track to match its color in 
the Region List.
To configure Region Color Coding default 
assignment to the color of regions in the Region 
List:

1  Choose Setup > Preferences > Display. 

2  In the Default Region Color Coding section, 
click to enable Region List Color. 

Enhancements to the Color 
Palette

The Color Palette has an updated Apply to Se-
lected pop-up menu and new Hold button.

Enhancements to Apply to Selected 
Pop-Up Menu

With Pro Tools 7.0, regions in tracks and the Re-
gion List can be independently color coded. The 
Apply to Selected pop-up menu in the Color Pal-
ette includes the following new options

Regions in Tracks Lets you apply a chosen color 
to regions in the currently selected track with-
out changing the color of corresponding regions 
in the Region List. 

Regions in Region List Lets you apply a chosen 
color to regions currently selected in the Region 
List without changing the color of correspond-
ing regions (copies) in tracks. 

See “Enhancements to the Color Palette” on 
page 25 to learn how to define default colors 
for regions in the Region List and how to ap-
ply them to regions in tracks. 

Color Palette

Apply to Selected Hold Default None

Last Assigned Color
Chapter 4: New Track Features 25



26

What’s New M-Powered 7.0.book  Page 26  Friday, October 21, 2005  2:59 PM
To apply a color from the Color Palette:

1  Choose Window > Color Palette.

2  Do one of the following:

• In the Apply to Selected pop-up menu, se-
lect the destination for color coding: 
Tracks, Markers, Group, Regions in Tracks, 
or Regions in Region List. 

– or –

• Select a track, marker, group, track region 
or Region List region in the appropriate 
Pro Tools window. The Apply to Selected 
menu will display the type of item you 
have selected. 

3  Select a color from the palette, or select one of 
the following:

Default Removes any custom coloring and re-
stores the color to the default color orientation. 

None Turns off color assignment. Affected re-
gions are drawn with black waveform or MIDI 
notes on light gray background. Affected tracks 
and groups no longer show their color bars. 

New Hold Button 

The Color Palette provides a Hold button to sim-
plify the process of assigning colors. 

If selecting a marker does not display the 
Marker option in the Apply to Selected pop-
up menu, then the Always Display Marker 
Colors option in the Display Preferences 
page is deselected. See the Pro Tools Refer-
ence Guide for more information. 

Color Palette

Hold

Last Assigned Color
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By default, the Hold button is off. When off, the 
Color Palette automatically highlights the as-
signed color (if any) of items as you select them. 

When the Hold button is enabled, the assigned 
color selected in the Color Palette persists and 
does not change when a different track or region 
is selected. 

To use the Hold button to assign the same color to 
multiple items: 

1  Click the Hold button to enable it. The Hold 
button becomes white, and the currently se-
lected color is now highlighted with a wider 
white outline. 

2  Select additional tracks or regions to which 
you want to assign the same color. Because the 
Hold button is enabled, the Color Palette does 
not follow item selection; it remains (or 
“holds”) at the last currently assigned color. 

3  Click the assigned color again to assign it to 
the new selection of tracks or regions. Use the 
Apply to Selected pop-up menu to determine 
which selected elements are affected. 

4  To turn off Hold and return the Color Palette 
to its default mode of color-selection-follows-
item-selection, click the Hold button until it 
turns off. 
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Importing and Exporting
Pro Tools 7.0 provides the following new file im-
porting and exporting features. 

REX and ACID File Support 

Pro Tools lets you import and export REX and 
ACID files. For information on REX and ACID 
files, see “Region Groups” on page 29.

Importing AAC Files

Pro Tools 7.0 adds new support for AAC audio, 
including audio with AAC, Mp4, and M4a file 
extensions.

Pro Tools cannot import protected AAC or MP4 
files with the M4p file extension. These files are 
protected under the rules of digital rights man-
agement, and cannot be imported.

Importing Markers Using Import 
Session Data

Pro Tools 7.0 lets you import Markers/Memory 
Locations from one session into the current ses-
sion. 

To import Markers/Memory Locations:

1  Choose File > Import Session Data. 

2  Enable the Markers/Memory Locations option 
to import all markers and memory locations 
from the imported session into the current ses-
sion. Markers will be added after any existing 
markers or memory locations. 

3  Configure other Import Session Data settings 
as needed (for details, see the Pro Tools 
Reference Guide). 

4  Click OK to import data to the current session.
Importing Audio from Audio CDs 
on Windows XP

Pro Tools 7.0 and DigiBase support importing 
audio from Red Book audio CDs on Windows 
XP. This lets you import audio CD tracks from 
the Workspace directly into Pro Tools sessions 
and browsers, with look-up of CD metadata 
through supported Windows  XP protocols. 

New Drag and Drop Features

You can import audio and many other types of 
items using drag and drop. This is the fastest 
way to import loops and samples while creating, 
composing, and editing. 

New drag and drop features include the follow-
ing: 

• Support for drag and drop of MIDI, region 
group, REX, and ACID files.

• Drag and drop items directly from Windows 
Explorer or Macintosh Finder with enhanced 
capabilities to create new tracks with drag and 
drop. 

• Timeline Drop Order modes for dropping 
multiple Region List items to a single track or 
to multiple tracks.

• Drag and drop to plug-ins. 

For more information, see “Drag and Drop Fea-
tures” on page 45, and“New Import MIDI Op-
tions” on page 68. 
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chapter 5

Audio and MIDI Features for Composition
This chapter describes the following new and 
changed audio and MIDI features that enhance 
composition, arranging, and spotting in 
Pro Tools 7.0. 

• “Region Groups” on page 29

• “Importing REX Files” on page 38 

• “Importing ACID Files” on page 39

• “Region Looping” on page 40

• “Special Cut, Copy, Paste, and Clear Com-
mands” on page 44

• “Drag and Drop Features” on page 45

• “Link Track and Edit Selection” on page 48

• “Zoom Enhancements” on page 49

• “Additions to Strip Silence” on page 52

• “Additions to Separate Regions” on page 52
Region Groups
A region group is a collection of any combination 
of audio and MIDI regions that looks and acts 
like a single region. Region groups can be cre-
ated on a single or on multiple adjacent audio, 
MIDI, and Instrument tracks. Region groups let 
you “nest” multiple regions into “macro” re-
gions for groove and tempo manipulation, edit-
ing, and arranging. 

Region groups are essentially containers holding 
one or more regions. Region groups can be 
placed on tracks alongside standard regions, and 
edited using many of the same Pro Tools editing 
techniques. Certain edits to a region group will 
apply to all regions contained by the region 
group, such as Cut or Delete. Other edits only 
apply to the boundaries off the region group 
and do not affect the underling regions, such as 
Trim.
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Region groups are particularly useful for:

• Grouping tick-based audio regions that have 
been separated into many small regions, such 
as with individual hits of a drum pattern. 
Many such small regions can easily be created 
with Beat Detective or the Separate Region At 
Transients command, or imported as REX and 
ACID files.

• Grouping parts and sections to facilitate com-
position and arranging. For example, group-
ing the regions of a brass section during the 
chorus to copy it to the next chorus.

The region group file type is identified with an 
.rgrp extension and has its own icon.

Creating Region Groups

To create a region group:

1  Select one or more regions on one or more 
tracks. (For more information on multitrack re-
gion groups, see “Multitrack Region Groups” on 
page 31).

The size of the selection determines the size of 
the region group. The selection can start and 
end on any region boundary, empty space, or 
even in the middle of a region. Selections start-
ing or ending within a region will separate the 
region at the selection boundary when you cre-

Region groups have no relation to and are 
completely independent of Mix and Edit 
Groups.

Region group file icon
What’s New in Pro Tools M-Powered 7.0
ate a region group. Region groups created from 
object-based selections include all regions be-
tween the first and last selected region on the 
track whether they are selected or not.

2  Choose Region > Group.

The region group will appear as one region with 
a region group icon in the lower left corner. Re-
gion groups also appear in the Region List.

Region Group Timebase Format

Region groups are created in the same timebase 
format (samples or ticks) as the tracks they are 
on. Multitrack region groups can include both 
sample-based and tick-based tracks.

Selecting regions to be grouped on a single audio track

A region group on an audio track and in the Region List

A region group on an audio track

Region group icon

Audio region group icon
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Ungrouping Regions

To ungroup a region group:

1  Select a region group. 

2  Choose Region > Ungroup.

The region group disappears, revealing all un-
derlying regions and any nested region groups. 
When there are multiple nested region groups, 
the Ungroup command ungroups the front-
most top-layer region group only, preserving 
any underlying region groups.

To ungroup all a region group, including all of its 
nested region groups:

1  Select a region group.

2  Choose Region > Ungroup All.

A region group on a MIDI track

Region groups can be created from empty se-
lections. This can be useful when working 
in Shuffle mode to preserve the gaps between 
regions.

The Group and Ungroup Regions com-
mands apply to any Time or Edit selection 
regardless of the current Track View.

MIDI region group icon
Regrouping Regions

The Regroup command undoes the last Un-
group command and regroups the individual re-
gions back to their former region group state. 
This lets you ungroup a grouped region, edit its 
underlying regions in any way desired, and re-
group it to continue working on higher-level 
composition and arranging.

To regroup a region group:

1  Select any region from the ungrouped region 
group.

2  Choose Region > Regroup.

If you used the Ungroup All command, the Re-
group command recreates all previous nested re-
gion groups.

3  If you regroup an ungrouped region group 
that is used more than once in the session, the 
Change All dialog opens. 

4  Do one of the following:

• Choose Modify to apply your changes to all 
other instances of the same region group. 

• Choose Copy to create a copy and apply 
your changes only to the copied region 
group. 

Multitrack Region Groups

Multitrack region groups (region groups created 
across multiple tracks) are useful for grouping 
parts, such as multi-miked drum tracks, and for 
composing and arranging. Multitrack region 
groups can be created across any combination of 
audio, MIDI, and Instrument tracks, and can in-
clude either or both tick-based or sample-based 
tracks.

Multitrack region groups work much like single-
track region groups. Multitrack region groups 
appear as a single object across adjacent tracks.
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To create a multitrack region group:

1  Select regions across multiple adjacent tracks.

2  Choose Region > Group.

Selecting regions to be grouped across multiple tracks

Multitrack region group (audio regions only)

Region group icon
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Separated Multitrack Region Groups

You can insert, move, hide, or delete tracks in 
multitrack region groups, but it may break the 
region group. A separated region group displays 
a break in the region group icon. Separated re-
gion groups will continue to function as a single 
region group, but the separated icon indicates 
that the region group displayed is somehow in-
complete or separated across nonadjacent 
tracks.

Mixed multitrack region group (sample- and tick-based 
audio, and tick-based MIDI)

Multitrack region groups create nested re-
gion groups of multiple regions by track be-
fore grouping them across tracks.

The Regroup command supports multitrack 
region groups.

Mixed region group icon
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A region group is separated when you do any of 
the following:

• Insert a track within a multitrack region 
group.

• Move a track that is part of a multitrack region 
group so that it is no longer adjacent with the 
other tracks of the region group.

• Hide a track that is part of a multitrack region 
group.

• Delete a track that is part of a multitrack re-
gion group.

• Change the tempo of a mixed sample-based 
and tick-based region group.

• Record into a region group.

• Change playlists on a track that is part of a 
multitrack region group.

There may be situations where you want sepa-
rated region groups. For example, if you use the 
same accompaniment on verses one and two of 
a song, you can group the parts of verse one and 
copy them as a region group for verse two, but 
still have a continuous vocal track in the middle 
of those region groups.

Region group separated by deleting a track

Separated region group icon
Changing Region Group Timebase

The timebase format of a region group can be 
changed by:

◆ Changing the track’s timebase.

◆ Dragging the region group to a track with a 
different timebase.

Changing the timebase creates a copy of the 
original region group. Both region groups (the 
original and the copy) appear in the Region List, 
but they have different timebases.

Converting Samples to Ticks

When dragging a region group from a sample-
based track to a tick-based track, the length of 
the region group will not change. This is be-
cause region groups are converted from samples 
to ticks after they are moved into tick-based 
tracks. The length of the region group will only 
change with subsequent tempo changes. If pos-
sible, change the local tempo on the tick-based 
track to match the tempo of the sample-based 
region group before moving a sample-based re-
gion group to a tick-based track.

Converting Ticks to Samples 

When dragging a region group from a tick-based 
track to a sample-based track, the length of the 
region group will not change unless it is moved 
to another time location with a different tempo. 
This is because region groups are converted 
from ticks to samples after they are moved into 
the sample-based tracks. 

If you want to delete a track and keep the re-
gion group intact, first ungroup the region 
group, then delete the desired track, and 
then Regroup the region group. The region 
group will be recreated intact, but without 
the deleted track.
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Multitrack Region Groups with Sample- and 
Tick-Based Tracks

Multitrack region groups can include both sam-
ple-based and tick-based tracks. Changing the 
tempo will break the region group between sam-
ple-based tracks and tick-based tracks.

Region Groups on Tick-Based Tracks

When changing tempos, region groups on tick-
based tracks adjust their length by adjusting the 
position of all enclosed regions accordingly. 
This is useful for arranging rhythmic material 
and for playing back REX and ACID files. 

A multitrack region group separated across sample-
based and tick-based tracks after changing tempo

A region group on a tick-based audio track 120 BPM 
and at 160 BPM
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Editing Region Groups

Region groups are edited in much the same way 
as regular regions: They can be named, moved, 
cut, copied, pasted, trimmed, muted, locked, 
and so on. However, there are a few significant 
differences between editing regular regions and 
region groups. 

Editing MIDI Region Groups

If a MIDI region within a region group is modi-
fied in any way, a new region copy is created 
and placed over of the region group. For exam-
ple, if you record, draw in a new note, edit MIDI 
controller data, or Quantize a Timeline selec-
tion, a new region is created over the region 
group. 

Editing Audio Region Groups

Certain audio editing commands create new re-
gions over region groups. To use these com-
mands and maintain the region group, ungroup 
the region group, perform the edit, and then re-
group the region group.

The following edit commands create new re-
gions over region groups:

• AudioSuite processing of a grouped region re-
sults in a new region over the region group.

• Consolidating a selection of a grouped region 
creates a new audio file and region over the re-
gion group.

• Recording into a region group creates a new 
audio file and region over the region group.

• Pencil tool waveform redraw results in a new 
region over the region group.

To avoid creating new regions over region 
groups when editing, ungroup the region 
group, make the desired edits, then regroup 
the region group.
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Tabbing to Transients and Region Boundaries

With Tab to Transients enabled, the Tab key 
moves the Location Cursor to transients and re-
gion boundaries within a region group.

With Tab to Transients disabled, the Tab key 
moves the cursor to region group boundaries 
only (and the sync point, if present).

Trimming Region Groups

Trimming region groups works the same way as 
trimming regular regions, regardless of whether 
the you are trimming a single-track region 
group or a multitrack region group. The excep-
tion is the TCE Trim Tool. 

Trimming a region group does not trim the un-
derlying regions. All underlying regions retain 
their length and location. This is true for all un-
derlying audio and MIDI regions, and nested re-
gion groups. Consequently, if you trim the re-
gion group shorter, underlying regions may not 
be heard on playback because they are outside 
the region boundaries of the trimmed region 
group. 

The TCE Trim Tool applies only to audio re-
gions, and creates a new region over any region 
group.

If you Ungroup after trimming a region group in 
(shorter), audio regions falling outside of the 
bounds of the current region group are trimmed 
to fit and removed.

Recording

When recording audio or MIDI, new regions are 
created over (in front) of region groups instead 
of being included in the region group. To record 
into a region group, first ungroup the region 
group, then record, and then regroup the region 
group. The region group will be recreated intact 
with the newly recorded material.
Fades and Crossfades on Region 
Groups

Region groups can have fades and crossfades 
just like regular regions. Fades only apply to au-
dio regions. In addition to crossfading between 
region groups, you can also crossfade between 
region groups and regular audio regions.

Import and Export of Region 
Group Files

Pro Tools can export and import the new region 
group file format (.rgrp). The ability to import 
and export these files lets you do the following 
benefits:

• Separate region group metadata from audio 
files to avoid unnecessary file copy opera-
tions when exporting audio region groups 
composed from multiple source files

• Export MID data as part of a region group

• Create multitrack loops

Two multitrack region groups with crossfades on the 
audio tracks, but not on the MIDI track

Ungrouping a region group removes any re-
gion group level fades or crossfades. Fades 
and crossfades are restored by the Regroup 
command.
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Region group files store the following metadata:

• References to all audio files within the re-
gion group

• Region names and relative location in 
tracks

• Fades and crossfades

• Region group names and format (single or 
multitrack)

• All MIDI data present in the region group 
(such as notes, controllers, and Sysex)

• Track names

Region group files do not store the following:

• Automation 

• Plug-ins

• Track routing

• Tempo and Meter map 

• Region List information

To export a region group:

1  Select one or more region groups in the Re-
gion List.

2  From the Region List pop-up menu, choose 
Export Region Groups. The Export Region 
Groups dialog opens.

Export Region Groups dialog
What’s New in Pro Tools M-Powered 7.0
3  The Destination Directory defaults to the 
auto-created Region Groups folder in the session 
folder. You can change the Destination Direc-
tory by clicking the Choose button, navigating 
to the desired location, and clicking Choose. 
Click Reset to reset the Destination Directory to 
the default location.

4  Enable one of the following options for resolv-
ing duplicate region group file names:

• Prompting for Each Duplicate (default)

• Auto Renaming

• Replacing with New Files

5  Click OK. 

To import a region group:

1  Choose File > Import > Region Groups.

2  Navigate to and select the desired region 
group for import. 

3  Click Import.

– or –

Drag and drop the region group file from a 
DigiBase browser or from Windows Explorer or 
Macintosh Finder to the Timeline, a track, the 
Track List, or the Region List.
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Dropping a region group has the following dif-
ferent results depending on where you drop it:

• When dropping a region group in a track, 
Pro Tools checks for the matching track for-
mat, number of channels, and (in the case of 
multitrack region groups) if there are enough 
matching adjacent tracks to import the region 
group file. If these criteria match, the region 
group is imported and spotted to the drop lo-
cation in the track or tracks.

• Dropping a region group on the Timeline or 
on the Track List creates new tracks for the im-
ported region group. 

• Dropping a region group in the Region List 
adds a new region group in the Region List. 
All audio and MIDI regions, and even other 
region groups, contained within the dropped 
region group also appear in the Region List. 

Exporting Region Groups to Another Hard Drive

Generally, if you are exporting region groups to 
another hard drive, you should copy any refer-
enced audio files. This way you can move region 
groups not only from one session to another, 
but from one system to another.

To export a region group to a different hard drive 
and include its audio files:

1  Export one or more region groups to the de-
sired drive.
2  Create a new session on the new drive and en-
able the Automatically Copy Files on Import 
preference.

3  Import all previously exported region groups. 

The audio files folder of the new session now 
contains all files referenced by the region 
groups.

DigiBase Support for Region 
Group Files

In DigiBase browsers, region group files display 
a unique icon and include the following infor-
mation (see “Region group files displayed in a 
DigiBase browser” on page 37):

Duration As measured in the last specified 
(saved) timebase.

Kind Region Group File.

Number of Channels Can include multitrack re-
gion groups, indicated in the number of audio 
(n A) and the number of MIDI and Instrument 
tracks (n M).

Format Region Group.
Figure 1.  Region group files displayed in a DigiBase browser
Chapter 5: Audio and MIDI Features for Composition 37



38

What’s New M-Powered 7.0.book  Page 38  Friday, October 21, 2005  2:59 PM
Importing REX Files
The REX file format was invented by Propeller-
head Software. REX files are created exclusively 
with their ReCycle application and consist of 
both audio data and metadata. REX file meta-
data includes slice (like a Pro Tools region) and 
tempo information. REX files are typically ed-
ited into small slices (regions) so that when you 
put them on a tick-based audio track the slices 
adjust with changes in tempo. 

Pro Tools lets you import two different REX file 
formats: .rex and .rx2. The original REX file for-
mat (.rex) stores uncompressed PCM audio data 
and only supports mono. The REX 2 file format 
(.rx2) supports mono or stereo and also stores 
compressed PCM audio data and metadata. 
Pro Tools lets you import both REX and REX 2 
file formats.
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To import a REX file into Pro Tools:

■ Drag and drop the REX file from a DigiBase 
browser or from Windows Explorer or Macin-
tosh Finder to a track, the Track List, the Time-
line, or the Region List.

The REX file is converted to a region group on 
import, and all its slices are converted into indi-
vidual audio files and regions.

DigiBase Support for REX Files

In DigiBase browsers, REX files display a unique 
icon and the following information:

Duration As measured in the last specified 
(saved) timebase.

Kind Audio File.

Format AIFF (REX 1 files) or ReCycle (REX 2 
files).

Larger REX files may contain many audio 
regions that can quickly fill up the Region 
List. To hide these individual audio regions, 
deselect Show > Auto-Created in the Region 
List pop-up menu.

REX files can be previewed in DigiBase 
browsers just like regular audio files. Play-
back speed of REX files when previewed in 
browsers follows the tempo at the current 
insertion point or selection start.
Figure 2.  REX files displayed in a DigiBase browser
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Importing ACID Files
The ACID file format was created as a “stretch-
able” and “tunable” format for Sony ACID® 
software. ACID files are created by Acid and con-
sist of the original audio data (WAVE files) plus 
metadata about tempo, number of bars, pitch, 
and slice information. ACID files may not al-
ways contain slice metadata. If this information 
is not available, you may need to manually slice 
the imported file (using, for example, the Sepa-
rate Regions At Transients command or Beat De-
tective).

DigiBase Support for ACID Files

In DigiBase browsers, ACID files display a 
unique icon and the following information:

Duration As measured in the last specified 
(saved) timebase.

Kind Audio File.

Format Wav (Wave ACID) or Wav (WAVE).

Sliced ACID files display WAV (Wave ACID) in 
the Format column. ACID files with no slice 
data display Wav (WAVE) in the Format col-
umn.
To import an ACID file into Pro Tools:

■ Drag and drop the ACID file from a DigiBase 
browser or from the Desktop to the Timeline, a 
track, the Track List, or the Region List.

If slice metadata is present in the ACID file, it is 
converted and imported as a region group, and 
all slices are converted into individual audio 
files and regions. If slice data is not available, it 
is imported as a regular audio file.

ACID files can be previewed in DigiBase 
browsers just like regular audio files. Play-
back speed when previewing ACID files that 
contain slice data follows the tempo at the 
current insertion point or selection start.

Use the Separate Region At Transients com-
mand or Beat Detective to slice an unsliced 
ACID file.
Figure 3.  ACID files displayed in a DigiBase browser
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Region Looping
Audio regions, MIDI regions, and region groups 
can all be looped using the Loop and Unloop Re-
gion menu commands. Looping regions is an 
easy and powerful way to repeat a single region 
on a track or regions across tracks for composing 
and arranging. Looping regions provides more 
flexibility than the traditional Pro Tools Repeat 
and Duplicate Edit menu commands.

When looping regions, you can specify the 
number of loops, the loop length, or enough to 
fill the specified Loop Length (such as 30 sec-
onds or until the next region on the track). The 
source region is the original region selected for 
looping. Loop iterations are all looped regions 
following the source region. In cases where a 
specific number of repetitions has not been in-
dicated, the last loop iteration will be truncated 
to fill to the end of the selection or specified 
Loop Length.

Looped region

Loop icons

Source region Loop iterations

Looped region
What’s New in Pro Tools M-Powered 7.0
Once looped, the looped region can be edited 
much like a region group. For example, selecting 
and moving a looped region selects and moves 
the source region and all its loop iterations to-
gether.

Creating Looped Regions

To loop a region:

1  Select an audio or MIDI region, or region 
group. 

2  Choose Region > Loop. The Region Looping 
dialog opens.

You can select regions across multiple tracks 
for looping.

Selecting and looping more than one region 
on a track will loop only the first region in 
the selection.

Looping a region does not loop any automa-
tion associated with the source region. Use 
the Copy Special and Paste Special Repeat 
To Fill Selection commands to copy auto-
mation for the source loop to all loop itera-
tions (see “Automation and Looped Re-
gions” on page 43).

Region Looping dialog
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3  Do one of the following:

• Select the Number of Loops option and en-
ter the number of times to loop the region.

• Select the Loop Length option and enter 
the duration according to the main time-
base. If the duration is not an exact multi-
ple of the source loop’s duration, the last 
loop iteration will be truncated.

• Select the Loop Until End of Session or 
Next Region option. The looped region will 
be repeated until the end of the session, or 
until the next region on the track. The last 
loop iteration will be truncated to fit.

4  If desired, select the Enable Crossfade option. 
This will create a crossfade at the loop point. To 
edit the loop crossfade:

• Click the Settings button.

• Configure the Loop Crossfades dialog as 
desired.

• In the Loop Crossfade dialog, click OK.

5  Click OK.

Loop Crossfade dialog
Looped regions (all iterations) display a Loop 
icon in the lower, right corner. 

To edit the Region Looping dialog settings for a 
looped region, do one of the following:

■ Select the looped region and choose Region > 
Loop Region.

– or –

■ Double-click the loop icon with the Grabber.

To unloop a looped region:

1  Select the looped region.

2  Choose Region > Unloop. The Unloop Re-
gions dialog opens.

3  Do one of the following:

• Click Remove to unloop and remove all 
loop iterations except the first full loop it-
eration.

– or –

• Click Flatten to unloop and create individ-
ual regions from each loop iteration.

To unloop and ungroup a selection down to its 
individual regions:

1  Select a looped region that contains one or 
more region groups.

2  Choose Region > Ungroup All.

Unloop Regions dialog

Region Ungroup functions on loops the 
same as using the Unloop command and 
choosing Flatten.
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Editing Looped Regions

Looped regions can be edited as a group or as in-
dividual regions. For example, selecting a 
looped region with the Grabber Tool will select 
the entire loop (the source region and all its loop 
iterations), but clicking the Loop icon of one of 
the loop iterations will select only that one iter-
ation.

Moving a looped region moves the source re-
gion and all its looped aliases together as a 
group. Loop iterations cannot be moved inde-
pendent of their source region. If you move or 
paste another shorter region over of a looped re-
gion the loop is continued after the new region. 
The parts of a separated looped region can be ad-
justed independently.

To select a looped region as a group, do one of the 
following:

■ With the Grabber or Smart Tool, single-click 
the looped region. 

– or –

■ With the Selector, double-click the looped re-
gion.

The source region and all its loop iteration will 
be selected.

To select an individual source region or loop 
iteration, do one of the following:

■ With the Grabber or Smart Tool, single-click 
the Loop icon of the source region or loop itera-
tion.

– or –

■ With the Selector Tool, single click the 
Looped Region icon and drag to the left until 
the region is selected.
What’s New in Pro Tools M-Powered 7.0
Tabbing to Transients and Region Boundaries

Tab to Transients tabs to transients and region 
boundaries in a looped region. Normal Tab (Tab 
to Transients disabled) tabs to the start and end 
boundaries of the entire looped region.

Trimming Looped Regions

Trimming looped regions can be done using the 
Trim tool, the Loop Trimmer, or one of the Trim 
Region commands. The Trim Tool trims the en-
tire looped region. The Loop Trimmer provides 
the most unique feature of loop editing and 
trims the duration of the individual loop itera-
tion while filling the total length of the looped 
region.

To trim a looped region as a group:

1  Select the Standard or Scrub Trim Tool.

2  Trim the start or end of the looped region as 
desired.

Trimming a looped region with the Standard Trim Tool

Hold down the Start key on Windows, or 
the Control key on Macintosh, while trim-
ming to trim in loop iteration increments.

Trimming a loop does not trim any under-
lying Fades.

The TCE Trimmer unloops and consoli-
dates the looped region.
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To trim a looped region using the Loop Trimmer:

1  Select the Standard or Scrub Trim Tool.

2  Move the cursor over a Loop icon in the 
looped region. The cursor changes to the Loop 
Trimmer icon.

3  Trim the start or end of the loop iteration as 
desired.

The number of repetitions of the trimmed loop 
increases or decreases to fill the length of the en-
tire looped region.

To trim a looped region to selection:

1  Use the Selection Tool to make an Edit selec-
tion including some or all of the looped region.

2  Choose Edit > Trim Region, and one of the fol-
lowing Trim Region commands:

• To Selection.

• To Fill Selection.

• Start to Fill Selection.

• End to Fill Selection.

Trimming a loop using the Loop Trimmer

Looped region trimmed using the Loop Trimmer

Loop Trimmer
If the source region is extended to the left using 
the Trimmer tool for the total length of the 
loop, the source region is moved earlier in the 
Timeline and loop iterations fill in up to the 
point where the last original loop iteration 
ended. If the trim to the left is part of the source 
region’s length, the source region is not moved 
and a partial loop iteration is created to the left 
of the source region. This is a powerful feature 
that lets you make quick changes to your ar-
rangement by using partial loops as upbeats, or 
by extending looped sound effects or ambience 
earlier in a film score.

Automation and Looped Regions

Looping an audio region does not loop any au-
tomation associated with the source region. 
This is useful in that automation can be applied 
across an entire looped region. For example, you 
may want to have a long fade across part or all of 
the looped region. 

You can also repeat automation on individual 
loops. Use the Copy Special and Paste Special 
Repeat to Fill Selection commands to copy and 
paste any or all automation data from the source 
region to some or all of its loop iterations. 

Looped MIDI regions always loop all MIDI 
data within the region, including all contin-
uous MIDI controller data (such as pitch 
bend, modulation, and volume).
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To copy and paste automation from the source 
region to loop iterations:

1  Select the source region.

2  Choose Edit > Copy Special > All Automation, 
or Pan Automation, or Plug-In Automation, de-
pending on what automation you want to copy.

3  Select the looped region.

4  Choose Edit > Paste Special > Repeat to Fill Se-
lection.

Special Cut, Copy, Paste, and 
Clear Commands
The Edit menu commands, Cut Special, Copy 
Special, Paste Special, and Clear Special are pro-
vided for editing automation playlists (volume, 
pan, mute, and plug-in automation) on audio, 
Auxiliary Input, Master Fader, and Instrument 
tracks. The commands can also be used for MIDI 
controller data.

Cut Special

All Automation Cuts all automation or MIDI 
controller data whether it is shown or not. 

Selected Pan automation for Special Copy

Pan automation Special Paste to Fill Selection

You cannot paste MIDI controller data to 
automation data nor automation to MIDI.
What’s New in Pro Tools M-Powered 7.0
Pan Automation Cuts only pan automation or 
MIDI pan data whether it is shown or not.

Plug-In Automation Cuts only the plug-in auto-
mation that it is shown.

Copy Special

All Automation Copies all automation or MIDI 
controller data whether it is shown or not. 

Pan Automation Copies only pan automation or 
MIDI pan data whether it is shown or not.

Plug-In Automation Copies only the plug-in au-
tomation that it is shown.

Paste Special

Merges Pastes the MIDI note data from the clip-
board to the selection and merges it with any 
MIDI note data in the current selection.

Repeat to Fill Selection Repeatedly pastes the 
automation data or MIDI controller data from 
the clipboard to fill the selection. This com-
mand makes it easy to fill passages with room 
tone, ambience, or musical loops in a single 
command.

To Current Automation Type Pastes the automa-
tion data or MIDI controller data from the clip-
board to the selection as current automation 
type or MIDI controller. This lets you copy auto-
mation from any type to any other type. For ex-
ample, you can copy Pan automation to Plug-In 
automation. Or, you can copy MIDI volume 
data and paste it to MIDI pan.

Clear Special

All Automation Clears all automation or MIDI 
controller data whether it is shown or not. 

Pan Automation Clears only pan automation or 
MIDI pan whether it is shown or not.
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Plug-In Automation Clears only the plug-in auto-
mation that it is shown.

Drag and Drop Features

Drag and Drop from Windows 
Explorer or Macintosh Finder

Pro Tools lets you drag and drop audio, MIDI, 
region group, REX, and ACID files from Win-
dows Explorer or Macintosh Finder to the Time-
line or Region List. You can also drag and drop a 
Pro Tools session file to the Timeline to open 
the Import Session Data dialog.

Drag and Drop from the Region 
List

Multiple regions can be selected in the Region 
List and dragged to the Timeline in order to 
place multiple regions in a single track, or place 
each region in its own new track, in one opera-
tion. 

Region List Timeline Drop Order 
Command 

The Timeline Drop Order command sets 
whether regions dragged from the Region List 
are dropped sequentially in a single track or 
spread across multiple tracks. You can drag and 
drop multiple audio or MIDI regions or region 
groups. Multiple items can be dropped to create 
new tracks for the items, or to place items in ex-
isting, compatible tracks. 

The Region List pop-up menu provides the 
Timeline Drop Order command and submenu 
with the following two choices:
Top to Bottom When enabled, regions spread 
across multiple destination (drop) tracks or on 
new tracks (when dragging to the area below the 
last track or to the Track List). 

Left to Right When enabled, regions are placed 
sequentially in a single destination (drop) track 
or on a new track (when dragging to the area be-
low the last track or on to the Track List).

To set the Region List Drop Order:

■ Choose Region List > Timeline Drop Order, 
and then Top to Bottom or Left to Right. 

To drag and drop multiple items from the Region 
List to multiple new tracks:

1  From the Region List pop-up menu, choose 
Timeline Drop Order > Top to Bottom.

2  Search and sort the Region List if desired to 
configure the order in which items will be 
placed. 

3  Select multiple items in the Region List and do 
one of the following:

• To create new tracks and place items to a 
specific location, drop items at the desired 
location along the area below the last track. 

• To create new tracks and have items placed 
at the start of the session, drop the items on 
the Track list. 

New tracks after dropping multiple Region List items, 
with Timeline Drop Order set to Top to Bottom mode
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To spot multiple items across multiple existing 
tracks:

1  From the Region List pop-up menu, choose 
Timeline Drop Order > Top to Bottom.

2  Select multiple items in the Region List and 
drop them in the playlist of a compatible track 
at the desired location. When the cursor is over 
a compatible destination, the region outlines 
appear at the location. 

To drag and drop multiple items from the Region 
List to a single track: 

1  From the Region List pop-up menu, choose 
Timeline Drop Order > Left to Right.

2  Search and sort the Region List if desired to 
configure the order in which items will be 
placed. 

3  Select multiple items in the Region List and do 
one of the following:

• To create a new track and spot the first item 
to a specific location, drop at the desired lo-
cation in the area below the last track 
shown in the Edit window. 

• To create a new track and have the first 
item placed at the start of the session, drop 
the items on the Track list. 

• To place items in an existing track, drop the 
items in the Edit playlist for the desired 
track. 

New tracks created by dropping multiple Region List 
items with Timeline Drop Order set to Left to Right 
mode
What’s New in Pro Tools M-Powered 7.0
If the selected items include mixed types of re-
gions (such as audio and MIDI, or region groups 
and MIDI) the appropriate track types will be 
created and each corresponding item will be 
placed in them. Similarly, if the selected items 
include multiple formats (mono or stereo) new 
tracks of each format will be created and those 
regions placed in them. 

Drag and Drop to Plug-Ins

Audio files can be dragged from any DigiBase 
browser to a plug-in window to quickly load 
samples into plug-ins, such as Digidesign Syn-
chronic. You can also drag and drop MIDI data 
from a plug-in to the Timeline, Track List, or to 
the Region List. Check with the plug-in manu-
facturer as to whether or not your plug-in sup-
ports drag and drop with Pro Tools.

DigiBase Support for Standard 
MIDI File Drag and Drop 

DigiBase supports standard MIDI files as well as 
audio files and region groups. MIDI files can be 
dragged from browsers and dropped into 
Pro Tools sessions. 

Drag and Drop to Track List to 
Create New Tracks

Pro Tools creates new tracks when you drag 
items (regions, region groups, audio files, or 
MIDI files) from the Region List, browsers, or the 
desktop, to the Track List. 

In previous versions of Pro Tools, the Tracks 
List was known as the Show/Hide List. 
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To import items as new tracks using drag and 
drop: 

1  Select items in the Region List, browsers, or on 
the desktop. 

2  Drag the items and drop them onto the Track 
List. 

Pro Tools creates new tracks (below the cur-
rently selected track in the Edit window or to 
the right of the currently selected track in the 
Mix window), and places the items you dropped 
into the new tracks.

Dragging an audio file from a DigiBase browser and 
dropping it on the Tracks list

Tracks list Browser
Preview Files from Windows 
Explorer or Macintosh Finder
Pro Tools lets you preview files from Windows 
Explorer or Macintosh Finder. 

To preview an audio file from Windows Explorer:

■ While Pro Tools is launched, double-click an 
audio file.

– or –

■ Drag an audio file onto the Pro Tools applica-
tion icon.

A DigiBase browser window opens, with the file 
selected and it's directory displayed, and the file 
begins playing back.

To preview an audio file from the Macintosh 
Finder:

■ While Pro Tools is launched, double-click an 
audio file.

– or –

■ Drag an audio file onto the Pro Tools applica-
tion icon in the Finder or in the Dock.

A DigiBase browser window opens, with the file 
selected and it's directory displayed, and the file 
begins playing back.

To preview an audio file by double-clicking 
it in Windows Explorer or Macintosh 
Finder, the audio file must be set to open in 
Pro Tools. Select Pro Tools as the applica-
tion to use in Properties dialog (Windows) 
or the Info dialog (Macintosh). 
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Link Track and Edit Selection
Link Track and Edit Selection links or unlinks 
the Track selection with Edit selections. When 
Link Track and Edit Selection is enabled, you 
can make an Edit selection within a track or 
across multiple tracks and each associated track 
is selected. This lets you quickly apply track-
level commands (such as Track View toggle or 
change track heights) to have the command ap-
ply to all selected tracks (using Alt+Shift on 
Windows or Option+Shift on Macintosh). For 
example, you can make an Edit selection in a 
track with Link Track and Edit Selection en-
abled, and then apply the Duplicate Tracks com-
mand to duplicate the track. Conversely, you 
can select one or more tracks to make an Edit se-
lection of the entire track.

Linking the Track and Edit selection can be 
useful for switching from region-based Real-
Time Properties to track-based Real-Time 
Properties (see “MIDI Real-Time Properties” 
on page 53).
What’s New in Pro Tools M-Powered 7.0
To enable Link Track and Edit Selection:

■ Select Options > Link Track and Edit Selec-
tion.

– or –

■ Click the Link Track and Edit Selection but-
ton.

When Link Track and Edit Selection is disabled, 
making an Edit selection does not automatically 
select all associated tracks. 

Link Track and Edit Selection toggle

Link Track and Edit Selection button
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Zoom Enhancements
Pro Tools 7.0 provides enhancements to Zoom 
Toggle and continuous zooming, to streamline 
audio and MIDI editing. 

Enhancements to Zoom Toggle

MIDI editing frequently involves repeatedly 
switching back and forth between different 
views of data such as zoom states, track heights, 
and track views. The Zoom Toggle feature has 
been improved to simplify MIDI display and ed-
iting. 

The Zoom Toggle lets you define and toggle be-
tween zoom states directly from the Edit win-
dow, with enough flexibility and control to pro-
vide separate track views for audio, Auxiliary 
Input, and Master Fader tracks, and MIDI and 
Instrument tracks. 

Zoom Toggle Parameters

The Zoom Toggle stores and recalls the follow-
ing parameters:

• Track Height

• Display mode (track view)

• MIDI and Audio Zoom In and Out

• Horizontal Zoom

• Grid setting

The Zoom Toggle lets you set separate track 
heights for audio, Auxiliary Input, and Master 
Fader tracks, and MIDI and Instrument tracks. 
Using Zoom Toggle 

The Zoom Toggle button in the Edit window lets 
you define a zoom state and toggle between it 
and the current zoom state. When Zoom Toggle 
is enabled, the Edit window displays the stored 
zoom state. When Zoom Toggle is disabled, the 
Edit window reverts to the last zoom state.

To store a zoom state using Zoom Toggle:

1  Make an Edit selection.

2  Click the Zoom Toggle button. It will light to 
indicate that Zoom Toggle is enabled.

3  Adjust Track Height, Vertical Zoom, Track 
view, and the Grid as desired.

4  Click the lit Zoom Toggle button again to re-
vert to the last zoom state. 

5  Make another Edit selection and click the 
Zoom Toggle button to recall the stored zoom 
state and continue editing.

Zoom Toggle button in the Tool bar

In Command Keyboard Focus mode, press 
the E key to enable or disable Zoom Toggle.

Zoom Toggle button
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To modify the stored Zoom Toggle state:

1  Make sure the Zoom Toggle button is lit (en-
abled). 

2  Adjust Track Height, Vertical Zoom, Track 
view, and the Grid as desired. As you adjust set-
tings they are stored as the new Zoom Toggle 
state.

– or –

Click and hold the Zoom Toggle button select 
one of the following options from the Zoom 
Toggle pop-up menu:

• Zoom Toggle In

• Zoom Toggle Out

• Cancel Zoom Toggle

To clear the stored Zoom Toggle state:

1  Make sure the Zoom Toggle button is lit (en-
abled). 

2  Alt-click (Windows) or Option-click (Macin-
tosh) the Zoom Toggle button.

– or –

Select Cancel Zoom Toggle from the Zoom Tog-
gle pop-up menu.

Zoom Toggle pop-up menu
What’s New in Pro Tools M-Powered 7.0
Continuous Zoom with the Zoomer 
Tool

You can use the Zoom tool to zoom in or out 
continuously. 

To use continuous zoom:

1  Select the Zoomer tool. 

2  Hold the Start key (Windows) or Control 
(Macintosh) and do one of the following:

• Drag up to zoom in vertically

• Drag down to zoom out vertically

• Drag to the right to zoom in horizontally

• Drag to the left to zoom out horizontally

For horizontal zoom, all tracks zoom together. 
Tracks will zoom in or out centered horizontally 
on the location where you click. 

Zooming In or Out of All Audio Tracks 
Continuously

The continuous zoom feature usually only af-
fects the track or group of tracks in which you 
click and drag. When using continuous zoom 
on audio tracks, you can choose to have all 
shown audio tracks zoom as one. 

To vertically zoom all audio tracks using 
continuous zoom:

1  Select the Zoomer tool. 

2  Press Start+Shift (Windows) or Control+Shift 
(Macintosh) and drag up or down. When you re-
lease the mouse, all shown audio tracks will 
zoom to the same zoom level. 

Zoom Presets Enhancements

The Zoom Preset buttons (1–5) now provide 
pop-up menus to recall and save Zoom presets. 
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To store a view as a Zoom preset:

1  Use the Zoomer tool to configure the Track 
view as desired. 

2  Click and hold one of the Zoom Preset but-
tons (1–5) and choose Save Zoom Preset from 
the Zoom Preset pop-up menu. The Zoom Preset 
button flashes momentarily, and any previously 
stored zoom preset at that number is replaced. 

To recall a saved Zoom preset:

■ Click the appropriate Zoom preset button 
(1–5).

– or –

■ Click and hold the Zoom preset button and 
choose Recall Zoom Preset from the Zoom Preset 
pop-up menu. 

MIDI Zoom and View 
Improvements

Pro Tools 7.0 introduces several improvements 
to how MIDI data is displayed and accessed, in-
cluding the following: 

• Marquee Zoom support for Horizontal 
Zoom In and Out, and MIDI Zoom In and 
Out on MIDI and Instrument tracks.

• Independent MIDI Zoom In and Out on 
MIDI and Instrument tracks.

• Automatic scaling of MIDI Zoom In and 
Out to always show all notes in Region 
tracks view.

Zoom Preset pop-up menu
Marquee Zooming

Pro Tools 7.0 supports Marquee Zooming for 
MIDI and Instrument tracks. With the Zoomer 
tool selected, Control-click on Windows and 
Command-click on Macintosh to make a mar-
quee zoom selection on a single track for Hori-
zontal Zoom In and Out, and MIDI Zoom In and 
Out at the same time. Marquee Zooming is not 
available in Regions view.

Independent MIDI Zoom In and Out

In Notes view, MIDI and Instrument tracks can 
be independently zoomed vertically. Indepen-
dent vertical track zoom is not available in Re-
gions view.

To zoom vertically on a single track:

■ Hold the Start key (Windows) or the Control 
key (Macintosh) and click and drag up to zoom 
in vertically, or click and drag down to zoom out 
vertically. 

With the Zoomer tool, Alt-F-click on Win-
dows or Option-F-click on Macintosh to 
zoom tracks horizontally to the current Edit 
selection. MIDI tracks that contain the Edit 
selection or edit cursor will zoom out verti-
cally so that all notes within the selection 
are shown.

With the Zoomer tool selected, Alt-A-click a 
track on Windows or Option-A-click a track 
on Macintosh to zoom out all the way hor-
izontally and vertically. MIDI and Instru-
ment tracks will zoom vertically to display 
all notes.
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Regions View Shows all Notes

In MIDI Regions view the MIDI Zoom In and 
Out level is automatically constrained to en-
compass and display all notes on the track. 
Tracks scale their vertical range in regions view 
to always show all notes at all times, regardless 
of individual track vertical zoom levels or track 
height.

Additions to Strip Silence 
Pro Tools 7.0 provides two new buttons for ex-
tracting and separating regions in the Strip Si-
lence window:

Extract Extracts audio and leaves the silent por-
tions of the track (in other words, an “inverse” 
strip silence feature that is ideal for generating 
room tone or ambience to use elsewhere).

Separate Separates regions based on the bound-
aries detected by Strip Silence. 

Strip Silence window
What’s New in Pro Tools M-Powered 7.0
Additions to Separate 
Regions
To simplify the task of separating regions into 
multiple smaller regions, the following two new 
choices are provided in the Edit menu: 

Separate Regions On Grid Separates regions 
based on the currently displayed Grid values 
and boundaries.

Separate Regions At Transients Separates re-
gions at each detected transient using the same 
algorithm as the Tab to Transients feature.

The Grid and Transient choices let you specify a 
Pre-Separate amount (handle) to pad the head of 
the newly separated regions. 

When working with looped regions, the Sepa-
rate Regions commands (At Selection, On Grid, 
and At Transients) automatically unloop and 
flatten the looped regions before separating 
them.

Pre-Separate Amount dialog for Separate Regions on 
Grid or at Transients commands
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chapter 6

MIDI Features
This chapter describes the following new and 
changed MIDI features in Pro Tools 7.0:

• “MIDI Real-Time Properties” on page 53

• “Sample-Based MIDI” on page 60

• “Mirrored MIDI Editing” on page 61

• “Previewing MIDI Regions” on page 62

• “Default Thru Follows First Selected MIDI 
Track Selection Preference” on page 62

• “Selection of Note Ranges from Track Mini-
Keyboard” on page 63

• “New Select and Split Notes Window” on 
page 65

• “New Quantize Features” on page 66 

• “Legato, Overlap, and Duplicate Additions” 
on page 67 

• “New Remove Duplicate Notes Command” 
on page 68

• “Transpose Window Enhancements” on 
page 68

• “New Import MIDI Options” on page 68

• “MIDI File Support in DigiBase” on page 70
MIDI Real-Time Properties
MIDI Real-Time Properties let you change some 
MIDI properties in MIDI and Instrument tracks 
(or MIDI regions) during playback. There are 
five types of MIDI Real-Time Properties: Quan-
tize, Duration, Delay, Velocity, and Transpose. 

MIDI Real-Time Properties can be adjusted dur-
ing playback, while you listen for the desired re-
sult. Once you have found the desired settings, 
you can write the settings to the selected tracks 
or regions. This overwrites the corresponding 
MIDI properties on selected tracks or regions 
and resets the Real-TIme Properties display.

Real-Time Properties can be edited in the Real-
Time Properties view in the Edit window, or in 
the Real-Time Properties window.

Real-Time Properties View

The Real-Time Properties View in the Edit win-
dow only applies to tracks. To apply Real-Time 
Properties to regions, use the Real-Time Proper-
ties window (see “Real-Time Properties Win-
dow” on page 54).

In previous versions of Pro Tools, these edits 
could only be made while the Transport was 
stopped.
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To enable Real-Time Properties View in the Edit 
window:

■ Select View > Edit Window > Real-Time Prop-
erties. 

For Mini and Small track heights, the Real-Time 
Properties View only displays one or two prop-
erties, respectively. By default, the first one or 
two properties that are enabled are displayed au-
tomatically.

To select a different Real-Time Property in Mini or 
Small View:

■ Control-click (Windows) or Command-click 
(Macintosh) on a real-time property element to 
select a different element from the pop-up 
menu.

Real-Time Properties Window

Using the Real-Time Properties window, you 
can apply Real-Time Properties to selected tracks 
or regions.

To open the Real-Time Properties window:

■ Choose Event > MIDI Real-Time Properties. 

Real-Time Properties View in the Edit window
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The Real-Time Properties window can be used to 
apply either track-based or region-based Real-
Time Properties by making an Edit or Time se-
lection and selecting the desired tracks or re-
gions from the Apply To pop-up menu.

Expanded Real-Time Properties View

In the Real-Time Properties window, Quantize, 
Duration, and Velocity each provide an ex-
pand/collapse triangle to show or hide addi-
tional settings. 

Real-Time Properties window with properties enabled

Real-Time Properties window, expanded view

Expand/collapse
triangles
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Enabling Real-Time Properties

To enable Real-Time Properties:

1  Select a track, or make and Edit or Time selec-
tion.

2  In Real-Time Properties View in the Edit win-
dow, or in the Real-Time Properties window, se-
lect the desired Real-Time Properties by clicking 
the property name (Quantize, Duration, Delay, 
Velocity, or Transpose). Enabled Real-Time Prop-
erties are highlighted and display their settings.

3  If you are using the Real-Time Properties win-
dow and Link Track and Edit Selection mode is 
enabled, select the track or region to affect from 
the Apply To pop-up menu.

4  Configure the Real-Time Properties settings as 
desired.

Enabled Real-Time Properties will be heard on 
playback and play through for the selected 
tracks and regions.

Real-Time Properties Settings

Quantize

Quantize either can be based on a grid or a 
groove template. For grid quantize, additional 
tuplet and grid offset settings are available in ad-
dition to the standard MIDI quantize properties. 
For groove quantize, additional controls are pro-
vided to set the extent to which the groove’s du-
ration and velocities are applied. Both grid and 
groove quantize also let you set a strength 
amount, an “include” range, and a randomize 
amount.

When using Real-Time Properties, enable 
Link Track and Edit Selection mode to make 
a track selection from an Edit selection. See 
“Link Track and Edit Selection” on page 48.
Quantize Pop-Up Menu Select the desired quan-
tize value, including all standard note rhythm 
values between whole notes and 64th notes, in-
cluding dotted and triplet options. This pop-up 
menu also provides access to all standard and 
custom grooves.

Swing Value Enter the desired amount of swing 
as a percentage between 0 and 300%. 

Tuplet Value Enable Tuplet and enter the ratio 
for the tuplet (1–99), such as 3 to 2 or 5 to 4. Tu-
plet is only available in the expanded Real-Time 
Properties window.

Offset Value Enable Offset and enter the desired 
offset value in Ticks between –2000 and 2000. 
Offset is only available in the expanded Real-
Time Properties window.

Strength Value Enable Strength and enter the 
amount as a percentage between 0 and 100%. 
Strength is only available in the expanded Real-
Time Properties window.

Include Enable Include and enter the range be-
tween 0 and 100%. Include is only available in 
the expanded Real-Time Properties window.

Selecting a Grid Quantize value or a Groove Template
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Random Enable Random and enter a percentage 
between 0 and 100%. Random is only available 
in the expanded Real-Time Properties window.

Duration

Duration can be used to increase or decrease the 
duration of MIDI notes by a fixed amount or by 
a percentage. This is useful for creating legato or 
staccato passages.

Duration Mode Pop-Up Menu

Select one of the following options from the Du-
ration Mode pop-up menu: Set, Add, Subtract, 
Scale, Legato/Gap, or Legato/Overlap.

Set Select to set notes to the specified duration.

Add Select to add the specified duration to the 
current duration of each note.

Subtract Select to subtract the specified duration 
from the current duration of each note.

Scale Select to scale the current duration of each 
note by a percentage from 1 to 400%.

Legato/Gap Select to extend each note to the 
following note. The specified duration is the 
subtracted to create a consistent gap between 
notes.

Selecting a Duration mode
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Legato/Overlap Select to extend each note to the 
following note. The specified duration is then 
added to create a consistent amount of overlap.

Duration Amount

If the Ticks or Notes pop-up menu is set to ticks, 
enter a duration as a number of quarter-notes 
plus a number of ticks, such as 4|000. If the Ticks 
or Notes pop-up menu is set to a note size, enter 
a number to by which to multiply that note size, 
such as 7 16th-notes.

Ticks or Notes Pop-Up Menus

Selects either Ticks or a note size for Note Dura-
tions. There is also a Ticks or Notes pop-up 
menu for the Minimum and Maximum Dura-
tions options.

Minimum and Maximum Durations

Enable either or both minimum and maximum 
durations and enter a value in quarter notes plus 
ticks or as a multiple of a note size. The Mini-
mum and Maximum Durations options are only 
available in the expanded Real-Time Properties 
window.

Delay

Delay lets you delay or advance all MIDI data in 
the selected region or track. Select “+” from the 
Delay pop-up menu to delay MIDI data, or select 
“–” to advance MIDI data. Select Ticks or Milli-
seconds from the Ticks or Milliseconds pop-up 
menu. Enter the Delay amount in Tick or Milli-
second values. Delay is limited to a maximum of 
value of 2000 ms or 999 ticks.
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Velocity

Velocity lets you change MIDI velocity by a per-
centage or by constant value. Enter a percentage 
value in the Dynamics field to scale velocity 
around the median velocity of 64. You can also 
enter an offset by adding (+) or subtracting (–) 
values between 1 and 127. You can also enter 
Minimum and Maximum Velocity value limits. 
The Minimum and Maximum Durations op-
tions are only available in the expanded Real-
Time Properties window.

Velocity can be applied as a Real-Time Property 
to MIDI Input and Thru.

Transpose

Transpose lets you transpose MIDI notes up or 
down by a specified number of octaves and 
semitones. You can also transpose to a specified 
pitch. Select By or To from the Transpose pop-
up menu to transpose by and interval or to a 
specific pitch. To transpose by an interval, enter 
the desired number of octaves and semitones as 
a positive or negative numbers. To transpose to 
a specific pitch, enter the desired MIDI note.

Transpose can be applied as a Real-Time Prop-
erty to MIDI Input and Thru.

Real-Time Properties On Tracks 
and Regions

Real-Time Properties can be configured to apply 
to an entire track (all regions on that track), or 
on a region-by-region basis. Track-level proper-
ties also provide real-time MIDI input process-
ing of velocity and transposition.
The presence of track-based Real-Time Proper-
ties are indicated by a “T” displayed in the upper 
right-hand corner of MIDI regions. Region-
based Real-Time Properties are indicated by an 
“R” displayed in the upper right-hand corner of 
the region. Regions boundaries are indicated in 
notes view.

Region-Based Real-Time Properties

Region-Based Real-Time Properties can only be 
applied using the Real-Time Properties window 
(Event > MIDI Real-Time Properties). Real-Time 
Properties can be applied to multiple regions. 
Once Real-Time Properties have been assigned 
to a region, the region can be moved or copied 
and pasted and retain its Real-Time Properties.

Track-Based Real-Time Properties

All track-based Real-Time Properties consis-
tently apply to MIDI sequences throughout the 
entire track. However, regions with region-
based Real-Time Properties will take precedence 
over any track-based Real-Time Properties. You 
can clear region-based Real-Time Properties by 
selecting the region and clicking the Clear Re-
gion Properties button in the Real-Time Proper-
ties window (see “Writing Real-Time Properties 
to Tracks or Regions” on page 58).

Track-based and region-based Real-Time Property 
indicators

In previous versions of Pro Tools, MIDI re-
gion boundaries were only visible in Regions 
view.

Indicates
track-based

Real-Time Properties

Indicates
region-based

Real-Time Properties
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To allow greater flexibility when using Real-
Time Properties, whenever Real-Time Properties 
are assigned on a track basis they are actually 
contained in a track playlist. This lets you create 
multiple playlists containing different Real-
Time Property settings.

Writing Real-Time Properties to 
Tracks or Regions

Once you have found the desired settings, you 
can write Real-Time Properties to the selected 
tracks or regions using the Real-Time Properties 
window. Real-Time Properties are applied to the 
current MIDI data on the track or in a region.

To write Real-Time Properties to tracks:

1  Select one or more tracks to which you want 
to apply Real-Time Properties.

2  Open the Real-Time Properties window (Event 
> MIDI Real-Time Properties).

3  If Link Track and Edit Selection mode is en-
abled, select Tracks from the Real-Time Proper-
ties Apply To pop-up menu.

4  Configure the Real-Time Property settings as 
desired.

5  Click the Write to Track button.

To write Real-Time Properties to regions:

1  Select one or more regions to which you want 
to apply Real-Time Properties.

2  Open the Real-Time Properties window (Event 
> MIDI Real-Time Properties).

3  If Link Track and Edit Selection mode is en-
abled, select Regions from the Real-Time Proper-
ties Apply To pop-up menu.

4  Configure the Real-Time Property settings as 
desired.
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5  Click the Write to Region button.

To clear Real-Time Properties from a region:

1  Select the region for which you want to clear 
Real-Time Properties.

2  Open the Real-Time Properties window (Event 
> MIDI Real-Time Properties).

3  Select Regions from the Real-Time Properties 
Apply To pop-up menu.

4  Click the Clear Region Properties button.

Real-Time Properties In the MIDI 
Events List

In the MIDI Events List, the presence of track-
based Real-Time Properties are indicated by a 
“T” displayed to the right of each event. Region-
based Real-Time Properties are indicated by an 
“R.”

Track-based and region-based Real-Time Properties 
indicated in the MIDI Event List
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Display of Real-Time Properties 
Effects

Typically, the effects of Real-Time Properties are 
heard but not seen—you see the notes and other 
MIDI events in their original location, but you 
hear them as they are effected by the Real-Time 
Properties settings. Pro Tools provides a prefer-
ence, Display Events as Modified by Real-Time 
Properties, to display or not display the effects 
of Real-Time Properties in both the Edit window 
and the MIDI Event List. This preference is off 
by default.

To enable or disable the Display Events as 
Modified by Real-Time Properties preference:

1  Choose Setup > Preferences.

2  Click the MIDI Tab.

3  Enable or disable the Display Events as Modi-
fied by Real-Time Properties option.

4  Click Done.

Display Events as Modified by Real-Time Properties 
preference
Real-Time Properties Effects Displayed 
in the MIDI Event List

The MIDI Event List takes into account the ef-
fect of Real-Time Properties whenever the Dis-
play Events as Modified by Real-Time Properties 
preference is enabled. When editing or inserting 
an event in a track or region with active Real-
Time Properties, Pro Tools takes the properties 
into account and edits or inserts the event in a 
different place if necessary to match the effect of 
the Real-Time Properties.

Real-Time Properties Effects Displayed 
in the Edit Window

In the Edit window with the Display Events as 
Modified by Real-Time Properties preference en-
abled, MIDI events appear where they sound. 
However, MIDI events are not actually written 
to their modified locations until you write the 
Real-Time Properties to the track or region.

When moving MIDI events, the actual locations 
(pitch or time) move by the amount the events 
are dragged, but the effect of Real-Time Proper-
ties is displayed.

When inserting an event in a track or region 
with active properties, Pro Tools takes the prop-
erties into account and edits or inserts the event 
in a different place if necessary to match the ef-
fect of the Real-Time Properties.
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Sample-Based MIDI
Pro Tools supports sample-based MIDI on MIDI 
and Instrument tracks. MIDI events on sample-
based tracks are anchored to a sample location 
rather than the usual tick-based grid. Sample-
based MIDI is useful for keeping MIDI data inde-
pendent of the current tempo. For example, you 
can create a tempo map from a MIDI perfor-
mance with rubato, and tempo and meter 
changes. This frees you from having to record 
your MIDI performances with a click, and prede-
termined tempo and meter tracks.

Sample-based MIDI tracks are also useful in post 
production when triggering samples or other ex-
ternal devices (such as color streamers) while 
keeping MIDI notes locked to Timecode.

All MIDI editing functions apply to sample-
based MIDI just as they do to tick-based MIDI. 
The only difference is that with sample-based 
MIDI, MIDI events are anchored to a sample and 
do not move according to changes in tempo.

To create a sample-based MIDI or Instrument 
track:

1  Choose Track > New.

2  Configure the New Tracks dialog as desired in-
cluding a MIDI or Instrument track.

3  For the MIDI or Instrument track, select Sam-
ples from the Timebase pop-up menu.

4  Click Create.

Creating a sample-based MIDI track
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To change a MIDI or Instrument track’s timebase:

■ Select Samples or Ticks from the MIDI track’s 
Timebase Selector pop-up menu.

Tempo Change and Sample-Based MIDI

Since sample-based MIDI is anchored to the 
sample and not to the Conductor track (tempo 
map), it does not respond to changes in tempo.

In Figure 1 on page 61, the top graphic is a MIDI 
sequence at 49 bpm (the original tempo). In 
terms of absolute time, it will be the same 
whether the track is tick-based or sample-based. 
The middle graphic shows the same MIDI se-
quence on a sample-based track, but the tempo 
has been changed to 64 bpm. Notice that the 
MIDI data stays the same in terms of absolute 
time, but the location of the bar lines changes 
relative to the change in tempo (the Conductor 
track and Bar|Beats ruler are always tick-based). 
The bottom graphic shows the same MIDI se-
quence on a tick-based track with a tempo of 64 
bpm. The MIDI events maintain their relation-
ship to the Bar|Beat ruler and Conductor track, 
but change the position in absolute time (min-
utes and seconds). The dotted line help to show 
the timebase relationships between the three 
graphics.

Selecting a sample-based MIDI track
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Tick-Based MIDI Regions and Sample-
Based Tracks

If you drag and drop, or cut or copy and paste, 
tick-based MIDI region to a sample-based MIDI 
track, the region and all its data are copied and 
converted to a sample-based time format. The 
absolute time of the MIDI events at the current 
tempo in the tick-based track will be preserved 
when they is copied to the sample-based track. 
The same is true if you change a track’s timebase 
from tick-based to sample-based.

If you switch a MIDI or Instrument track from 
ticks to samples, all MIDI regions will be con-
verted and new regions appear in the Region 
List. You can show which regions are tick or 
sample-based by selecting Show > Time Base 
from the Region List pop-up menu.

Figure 1.  Top: Sample-based MIDI at 49 bpm, Middle: 
Sample-based MIDI at 64 bpm, Bottom: Tick-based 
MIDI at 64 bpm
Sample-Based MIDI Regions and Tick-
Based Tracks

If you drag and drop, or cut or copy and paste, a 
sample-based MIDI region to a tick-based MIDI 
track, the region and all its data are copied and 
converted to a tick-based time format. The same 
is true if you change a track’s timebase from 
sample-based to tick-based.

Mirrored MIDI Editing
Mirrored MIDI Editing lets you edit MIDI re-
gions and have your edits apply to every MIDI 
region of the same name. This can be particu-
larly useful when editing looped MIDI regions.

To enable Mirrored MIDI Editing, do one of the 
following:

■ Select Options > Mirror MIDI Edit.

– or –

■ Enable the Mirrored MIDI Edit button in the 
Edit window.

In Mirrored MIDI Editing mode, the Mirrored 
MIDI Edit button will blink Red once as an edit 
is made to alert you that your edit is being ap-
plied to more than one region.

Mirrored MIDI Edit toggle in the Edit window

Mirrored MIDI Edit button
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To disable Mirrored MIDI Editing, do one of the 
following:

■ Deselect Options > Mirror MIDI Editing.

– or –

■ Disable the Mirrored MIDI Edit button in the 
Edit window.

Previewing MIDI Regions
MIDI regions in the Region List can be pre-
viewed to audition them through an instrument 
plug-in or external MIDI device. Previewed 
MIDI regions are played through the default 
MIDI Thru instrument. 

To preview a MIDI region in the Region List:

■ Alt-click (Windows) or Option-click (Macin-
tosh) the MIDI region in the Region List. 

To set the MIDI device used to preview MIDI:

1  Choose Setup > Preferences. 

2  Click the MIDI tab. 

3  Do one of the following:

• Select a specific device from the Default 
Thru Instrument pop-up menu to define a 
consistent preview sound source. 

– or –

If Mirrored MIDI Editing mode is disabled, 
and you edit notes of looped regions in notes 
view, the edit flattens the loop. Similarly ed-
iting region groups separates the region 
groups.

You can define a specific MIDI Thru instru-
ment, or configure the MIDI Thru assign-
ment to follow track selection in the 
Pro Tools MIDI Preferences.
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• Select “Follows First Selected MIDI Track” 
to have MIDI preview assignment follow 
the first selected MIDI or Instrument track’s 
assigned MIDI output (see “Default Thru 
Follows First Selected MIDI Track Selection 
Preference” on page 62). When multiple 
MIDI or Instrument tracks are selected, pre-
viewing will use the top track in the Edit 
window and the left track in the Mix win-
dow. 

Default Thru Follows First 
Selected MIDI Track Selection 
Preference
In addition to setting the Pro Tools MIDI Thru 
to a specific device and channel, you can also as-
sign the default MIDI Thru to use the first se-
lected MIDI or Instrument track’s assigned MIDI 
output. The Default MIDI Thru Instrument set-
ting determines the device used to preview MIDI 
regions in the Region List.

MIDI Default Thru Instrument Preference

The Default Thru Follows First Selected 
MIDI Track Selection also lets you play an 
instrument without having to create and 
record-enable a MIDI or Instrument track.
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To configure a default Thru instrument:

1  Choose Setup > Preferences. 

2  Click the MIDI tab. 

3  Do one of the following:

• Select a specific device from the Default 
Thru Instrument pop-up menu to define a 
consistent preview sound source. 

– or –

• Select “Follows First Selected MIDI Track” 
to have MIDI preview assignment follow 
MIDI track selection. When multiple MIDI 
tracks are selected, previewing will use the 
top track/left track in the Edit and Mix win-
dows. 

MIDI Default Thru Instrument Preference
Selection of Note Ranges 
from Track Mini-Keyboard
The MIDI or Instrument track’s mini-keyboard 
lets you select all instances of a specific note or a 
range of pitches. See Table 7 on page 64 for a 
summary of modifier keys for selecting MIDI 
notes.

To select all instances of a specific note on a MIDI 
or Instrument track:

■ Control-click (Windows) or Command-click 
(Macintosh) a key on a MIDI or Instrument 
track’s mini-keyboard. The selected note will 
playback through the MIDI or Instrument 
track’s assigned output.

To select a range of notes on a MIDI or Instrument 
track:

■ Control-Shift-click (Windows) or Command-
Shift-click (Macintosh) a bottom key and a top 
key on a MIDI or Instrument track’s mini-key-
board.

– or –

■ Start-click (Windows) or Control-click (Mac-
intosh) and drag across a range of keys on a 
MIDI or Instrument track’s mini-keyboard.

Selecting all instances of a note with the mini-keyboard

Selecting a range of notes with the mini-keyboard
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Table 7. Summary of key commands for selecting MIDI no
What’s New in Pro Tools M-Powered 7.0
tes using a MIDI or Instrument track’s mini-keyboard
Task Windows Shortcuts Macintosh Shortcuts

Audition and select a single note 
(deselecting all other notes)

Control-Start-click Command-Control-click

Audition and add all notes the 
mouse passes over to the selec-
tion

Control-Start-drag Command-Control-drag

Auditions clicked note and 
extends the selection to that note

Control-Shift-click Command-Shift-click

Auditions the note and toggles its 
selection state

Control-Alt-click Command-Option-click

Auditions the note mouse is cur-
rently over and toggles the selec-
tion state of that note

Control-Alt-drag Command-Option-drag

Select a single note (deselecting 
all other notes)

Start-click Control-click

Add all notes the mouse passes 
over to the selection

Start-drag Control-drag

Extends the selection to the 
clicked on note

Start-Shift-click Control-Shift-click

Toggles the note’s selection state Start-Alt-click Control-Option-click

Toggles the selection state of the 
note the mouse is currently over

Start-Alt-drag Control-Option-drag
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New Select and Split Notes 
Window
Pro Tools 7.0 combines the Select Notes and 
Split Notes MIDI Operation in a single new Se-
lect/Split Notes window. The Select/Split Notes 
window provides a complete set of tools to se-
lect and split notes based on a wide variety of 
criteria. 

New selection options have been added for ve-
locity, duration, and relative position. 

In addition, tools are provided to specify 
whether selected data is copied to the clipboard 
or to new tracks, whether the data is split to 
multiple new tracks or a single destination, and 
more. 

MIDI Operations window, Select/Split Notes

In previous versions of Pro Tools, two sepa-
rate windows provided Select Notes and 
Split Notes functionality. 
To select and split notes:

1  Choose Event > Select/Split Notes. 

2  Configure the Pitch Criteria as desired.

3  Configure the Other Criteria (Velocity, Dura-
tion, and Position) as desired.

4  Enable the Select or Split option as desired. 

5  From the Split Notes pop-up menu, select 
Copy or Cut. 

6  Select the desired Copy or Cut to destination:

The Clipboard Copies the selected data to the 
clipboard only.

A New Track Copies all selected data to a single, 
new track. If the selection includes multiple 
tracks, that same number of tracks will be cre-
ated. The new tracks will duplicate the original 
track type (Instrument or MIDI). 

A New Track per Pitch Copies all selected data to 
multiple new tracks (one new track for each 
pitch). If the selection includes multiple tracks, 
each track will have its data split separately. 

7  If desired, enable the Include MIDI Controller 
Data option. Enabling this option will include 
all controller data associated with the split notes 
in newly created tracks. Leave this option un-
checked to split only note data to new tracks. 

8  Click Apply. 

Any real-time MIDI properties associated with 
the track or regions are copied to new tracks cre-
ated by Select/Split Notes. 

New Other Criteria Settings

Velocity Enable the Velocity option to specify a 
range of velocities for selecting or splitting 
notes. Enter the desired minimum and maxi-
mum velocities. 
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Duration Enable the Duration option to specify a 
range of durations (in beats and ticks) for select-
ing or splitting notes. Enter the desired mini-
mum and maximum durations.

Position Enable the Position option to select or 
split all notes that fall into a range of relative 
beat and tick locations within each bar. The 
minimum value determines the start of the 
range, the maximum value sets the end of the 
range.

New Quantize Features
The Quantize, Groove Quantize, and Input 
Quantize commands have been consolidated, 
and updated with new capabilities. 

Grid/Groove Quantize Window

The new Grid/Quantize window provides both 
standard Quantize and Groove Quantize fea-
tures.

MIDI Operations window, Grid/Groove Quantize
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Groove Quantize also includes randomization 
to make grooves applied to multiple tracks 
sound more lively and realistic.

Groove Quantize Support for Input 
Quantize

The updated Input Quantize window provides 
all the options available in the primary Quan-
tize window, to apply quantization or grooves 
to MIDI on input. 

In previous versions of Pro Tools, two sepa-
rate windows provided Grid Quantize and 
Groove Quantize functionality. 

Press Alt+0 (zero) (Windows) or Option+0 
(zero) (Macintosh) to open the Grid/Groove 
Quantize window.

MIDI Operations window, Input Quantize
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Legato, Overlap, and 
Duplicate Additions
The Change Duration window has been up-
dated to provide more control over legato, and 
the overlap of or gaps between notes. 

New Consolidated Set/Add/Subtract/Scale 
Option

In Pro Tools 7.0, the Set, Add, Subtract, and 
Scale Duration options have been combined 
into a single pop-up menu. In previous versions 
of Pro Tools, there were separate options for Set, 
Add, Subtract, and Scale Duration.

MIDI Operations window, Change Duration

Press Alt+P on Windows or Option+P on 
Macintosh to open the Change Duration 
window.
Legato

Enable the legato option to add legato to the 
MIDI selection. Select Gap or Overlap from the 
Legato pop-up menu and enter the desired gap 
or overlap in beats and ticks. To avoid the possi-
bility of stuck notes, notes of the same pitch will 
not overlap, even with Overlap enabled.

Remove Overlap

The Remove Overlap option removes any note 
overlap for all notes of the same pitch. This 
command is different from Legato in that non-
overlapping notes of the same or different 
pitches remain unchanged. To create a gap be-
tween previously overlapping notes, enter the 
desired gap in beats and ticks. 

Transform Sustain Pedal To Duration

The new Transform Sustain Pedal To Duration 
option extends the length of all notes which are 
sounding when the sustain pedal (controller 64) 
is down (0 to 63) to the point when the sustain 
pedal goes up (64 to 127). Enable the Delete Sus-
tain Pedal Events option to delete the sustain 
pedal events within the selection.

Consolidated Change Continuously Option

The new consolidated Change Continuously 
option (previously called “Change Smoothly”) 
lets you change the duration of notes continu-
ously in ticks or by percentage. Adjust the Curve 
slider to modify the shape of the change.
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New Remove Duplicate Notes 
Command
The Remove Duplicate Notes command lets you 
quickly identify and remove any duplicate MIDI 
notes. If a note starts within the first 25% of the 
duration of a note of the same pitch which is al-
ready sounding (or within an eighth-note, 
whichever is shorter), it is considered a dupli-
cate and is combined with the previous note. If 
it starts later than that, the first note is short-
ened so that it ends at the same tick at which the 
new one starts.

To remove duplicate notes:

1  Make an Edit selection including the duplicate 
notes that you want to remove.

2  Choose Event > Remove Duplicate Notes.

Transpose Window 
Enhancements
The Transpose window provides a new Trans-
pose by Octaves option and a new Transpose all 
Notes To option.

MIDI Operations window, Transpose
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Transpose By Octaves

In addition to the Transpose by Semitones op-
tion, the Transpose by Octaves option lets you 
transpose the selected MIDI notes by up to +/– 
10 octaves. Previous versions of Pro Tools only 
provided a Transpose by Semitones option.

Transpose All Notes To

The new Transpose All Notes To option sets all 
selected notes to the same pitch. Use the slider 
or the number entry box to enter the desired 
pitch to which to transpose all selected notes.

New Import MIDI Options
Pro Tools 7.0 provides new import MIDI op-
tions. You can import MIDI files to tracks or to 
the Region List using File > Import > MIDI to 
Tracks or > MIDI to Region List menu com-
mands. You can also drag and drop MIDI files 
from a DigiBase browser or from the Desktop to 
the Region List or existing tracks, or to the Track 
List or the Timeline to create new tracks. When-
ever you import MIDI to tracks, use the Import 
MIDI Settings dialog to configure MIDI import 
options.

To import MIDI files to the Region List, do one of 
the following:

• Choose File > Import > MIDI to Region List. 
The MIDI file is imported to the Region List.

– or –

• Drag and drop a MIDI file from a DigiBase 
browser or the Desktop to the Region List. The 
MIDI file is imported to the Region List.

Press Alt+T on Windows or Option+T on 
Macintosh to open the Transpose window.
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To import MIDI files to tracks:

1  Do one of the following:

• Choose File > Import > MIDI to Track to im-
port MIDI files to tracks. The Import MIDI 
Settings dialog opens.

• Drag and drop a MIDI file from a DigiBase 
browser or the Desktop to the Track List or 
the Timeline. The Import MIDI Settings di-
alog opens.

2  Configure the Import MIDI Settings as de-
sired.

The MIDI file will be imported according to the 
settings in the Import MIDI Settings dialog.

Import MIDI Settings

Import Location Select Session Start or Song 
Start. This option is available only if the Song 
Start marker is not located at the session start 
(sample zero). The imported MIDI sequence will 
start at either at the Session Start or Song Start 
Marker accordingly.

Import Tempo Map From MIDI File Enable this 
option to overwrite any existing tempo map 
with tempo information read from the MIDI 
file. 

Import MIDI Settings dialog
Remove Existing Instrument Tracks Enable this 
option to delete any existing Instrument tracks. 
All existing MIDI regions will be left in the re-
gion bin.

Remove Existing MIDI Tracks Enable this option 
to delete any existing MIDI tracks. All existing 
MIDI regions will be left in the region bin.

Remove Existing MIDI Regions Enable this op-
tion to delete existing MIDI regions (thus all 
data on all MIDI and Instrument tracks) but 
leave existing MIDI and Instrument tracks in 
place. 

Exporting MIDI Files
Pro Tools 7.0 provides new export MIDI op-
tions. You can export MIDI files from tracks us-
ing File > Export > MIDI.

To export all MIDI and Instrument tracks in the 
current session:

1  Make sure to unmute any MIDI tracks in the 
session that you want included in the exported 
MIDI file. (Or, conversely, mute any MIDI tracks 
you do not want included in the exported MIDI 
file.) For Instrument tracks, enable or disable the 
MIDI mute button (Instruments View) as de-
sired.

2  Choose File > Export > MIDI. The Export MIDI 
Settings dialog opens.

Export MIDI dialog
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3  From the MIDI File Format pop-up menu, se-
lect 1 (multi-track) or 0 (single-track).

4  If the Song Start time is different from the Ses-
sion Start time, select Session Start or Song Start 
from the Location Reference pop-up menu.

5  Enable or disable the Apply Real-Time Proper-
ties option as desired.

6  Click OK. A Save dialog opens.

7  Specify a folder destination and name for the 
MIDI file.

8  Click Save. 

Pro Tools exports all unmuted MIDI and Instru-
ment tracks in the current session to a Standard 
MIDI File and writes it to your hard drive. Ex-
ported MIDI information includes notes, con-
troller events, program changes, and System Ex-
clusive data, as well as events for tempo, meter, 
and markers.

The SMPTE start time for the session or the song 
(depending on the selection from the Location 
Reference pop-up menu) is also exported. This 
ensures that the exported tracks, when played 
from another MIDI application, will align with 
the correct SMPTE frames, and also synchronize 
correctly to tape and video devices, or Pro Tools.
What’s New in Pro Tools M-Powered 7.0
Export MIDI Settings

MIDI File Format Determines whether the ex-
ported MIDI file is a Type-0 Standard MIDI File 
(single-track) or Type-1 Standard MIDI File 
(multi-track).

Location Reference Determines the SMPTE start 
time for the exported MIDI file as being the ses-
sion start time or the song start time (if different 
from the session start time).

Apply Real-Time Properties Determines whether 
or not any enabled Real-Time Properties are ap-
plied on export. For more information on Real-
Time Properties, see “MIDI Real-Time Proper-
ties” on page 53.

MIDI File Support in DigiBase
Standard MIDI Files are now supported in Digi-
Base. This means you can now view, sort, and 
drag/drop standard MIDI files from the Work-
space to the Region List or Timeline. For more 
information about DigiBase, see the DigiBase 
Guide.

MIDI files cannot be previewed in the 
Workspace, but they can be previewed from 
the Region List. For more information, see 
“Previewing MIDI Regions” on page 62. 
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chapter 7

Plug-Ins
This chapter describes the following new and 
changed plug-in features in Pro Tools 7.0. 

• New options for maximizing RTAS perfor-
mance

• Numerous additions and changes to individ-
ual DigiRack and Digidesign Development 
Partner plug-ins:

• Peak and RMS calibration modes for Signal 
Generator

• TimeAdjuster RTAS version

• Trim plug-in +12 dB

• EQ III Band-Pass Filter

• Synchronic updates

• Bomb Factory updates

• Pro Tools M-Powered support for the 
AudioSuite versions of SoundReplacer and 
NoNOISE
RTAS Performance Features
This section describes new features for optimiz-
ing Pro Tools RTAS performance on all systems. 

Multiple RTAS Processors

Pro Tools supports multi-processor computers, 
as well as Hyperthreaded and “multi-core” pro-
cessors, for RTAS processing. 

When using Pro Tools on dual- and multi-pro-
cessor computers, you can allocate two or more 
available processors to RTAS processing tasks. In 
combination with the CPU Usage Limit setting, 
Pro Tools provides extensive control over the 
way RTAS processing and other Pro Tools tasks 
occur on your particular system. For example: 

• For sessions with large numbers of RTAS plug-
ins you can allocate two or more processors to 
RTAS and set a high CPU Usage Limit.

• In sessions with few RTAS plug-ins, you can al-
locate fewer processors to RTAS and set a low 
CPU Usage Limit to leave more CPU resources 
available for automation accuracy, screen re-
sponse, or video. 
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• Depending on the importance of video and 
overall screen response, and on the density of 
automation being employed, different combi-
nations of RTAS Processing and CPU Usage 
Limit settings may achieve the best results. 
For example, try reducing the number of RTAS 
processors but keep the CPU Usage Limit at a 
high setting. 

The System Usage window shows the combined 
amount of RTAS processing occurring on all en-
abled processors with a single indicator, regard-
less of how many CPUs are in the system. If the 
System Usage Window shows that you are at the 
limit of available resources, increase the number 
of RTAS processors and/or the CPU Usage Limit 
setting. 

Adjusting RTAS Processing Resources

Multi-processor support is controlled using the 
new RTAS Processing selector in the Playback 
Engine dialog. 

To specify the number of processors for RTAS:

1  Choose Setup > Playback Engine.

2  From the RTAS Processing pop-up menu, 
choose the number of available processors you 
want to allocate:

• Choose 1 Processor to limit RTAS process-
ing to one CPU in the system. 

Playback Engine dialog
What’s New in Pro Tools M-Powered 7.0
• Choose 2 Processors to enable load balanc-
ing across two available processors.

• On systems running four or more proces-
sors, choose the desired number of RTAS 
processors as needed. 

3  From the CPU Usage Limit pop-up menu, se-
lect the percentage of each enabled RTAS proces-
sor you want to allocate to RTAS performance. 

CPU Usage Limit

The CPU Usage Limit controls the percentage of 
CPU resources allocated to Pro Tools host pro-
cessing tasks.

◆ Lower CPU Usage Limit settings limit the ef-
fect of Pro Tools processing on other CPU-inten-
sive tasks, such as screen redraws, and are useful 
when you are experiencing slow system re-
sponse, or when running other applications at 
the same time as Pro Tools.

◆ Higher CPU Usage Limit settings allocate 
more processing power to Pro Tools, and are 
useful for playing back large sessions or using 
more real-time plug-ins. 

The maximum CPU Usage Limit is 85 percent 
for single-processor computers and 99 percent 
for multi-process computers. (The 99 percent 
setting dedicates one entire processor to 
Pro Tools.)

On multi-processors computers, the maximum 
CPU Usage Limit is reduced when you use all 
your processors (as selected in the RTAS Process-
ing pop-up menu). For example, on dual-proces-
sors, the limit will be 90%. On four-processor 
computers, the limit will be 95%.

Increasing the CPU Usage Limit may slow 
down screen responses on slower computers.
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To change the CPU Usage Limit:

1  Choose Setups > Playback Engine. 

2  From the CPU Usage Limit pop-up menu, se-
lect the percentage of CPU processing you want 
to allocate to Pro Tools. 

3  Click OK.

RTAS Performance Enhancements

In addition to support for multiple RTAS proces-
sors, plug-ins that have been updated for 
Pro Tools 7.0 can take advantage of a larger 
RTAS buffer for improved RTAS processing and 
system performance. 

New Shortcuts to Enable All 
Plug-In Parameters
Pro Tools 7.0 provides a new shortcut to enable 
all parameters for a single plug-in in one step. 

To enable all plug-in parameters:

1  Make sure the plug-in window is open for the 
plug-in you want to automate. 

2  Control+Alt+Start-click (Windows) or Com-
mand+Option+Control-click (Macintosh) on 
the Auto button at the top of the plug-in win-
dow. 

In previous versions of Pro Tools, the maxi-
mum CPU Usage Limit setting on single-
processor computers was 85%. 

Contact the manufacturer of your plug-ins 
for information about updates for 
Pro Tools 7.0 compatibility. 
RMS and Peak Calibration 
Modes for Signal Generator 
Plug-In
In Pro Tools 7.0, Signal Generator has been up-
dated to include an RMS/Peak toggle that lets 
you switch calibration between RMS and Peak 
modes:

RMS Generates signal at levels consistent with 
the RMS (Root-Mean-Square) value, or the effec-
tive average level of the signal.

Peak Generates signal at the maximum possible 
level without clipping.

Signal Generator plug-in

For more information on Signal Generator, 
see the DigiRack Plug-Ins Guide.

RMS and 
Peak toggles
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RMS and Peak Calibration 
Modes for Normalize Plug-In
In Pro Tools 7.0, the AudioSuite Normalize 
plug-in has been updated to include an 
RMS/Peak toggle that lets you switch calibration 
between RMS and Peak modes.

RMS Normalizes the input signal at a level con-
sistent with the RMS (Root-Mean-Square) value, 
or the effective average level of the selected re-
gion.

Peak Normalizes the input signal at the maxi-
mum possible level without clipping. 

RMS and Peak Calibration 
Modes for Gain Plug-In
In Pro Tools 7.0, the Gain plug-in has been up-
dated to include an RMS/Peak toggle that lets 
you switch calibration between RMS and Peak 
modes.

RMS Boosts or lowers the selected input signal 
to a level consistent with the RMS (Root-Mean-
Square) value, or the effective average level of 
the selected region.

Normalize plug-in

For more information on Normalize, see the 
DigiRack Plug-Ins Guide.

RMS and 
Peak toggles
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Peak Boosts or lowers the gain of the selected in-
put signal to the maximum possible level with-
out clipping. 

TimeAdjuster RTAS Plug-In
In Pro Tools 7.0, TimeAdjuster has been up-
dated to include an RTAS version, which lets 
you compensate for delays incurred with RTAS 
plug-ins.

Gain plug-in

For more information on Gain, see the Digi-
Rack Plug-Ins Guide.

TimeAdjuster RTAS (short version, mono track shown)

For more information on TimeAdjuster, see 
the DigiRack Plug-Ins Guide.

RMS and 
Peak toggles
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Trim Plug-In +12 dB Updates
In Pro Tools 7.0, the Trim plug-in includes a 
Gain toggle, which lets you switch the maxi-
mum level of attenuation (controlled by the 
Gain slider) to +6 dB and +12 dB.

+6 Switches the maximum level of attenuation 
to +6 dB.

+12 Switches the maximum level of attenuation 
to +12 dB.

In previous versions of Pro Tools, the Trim 
plug-in could be used to attenuate an audio 
signal from –∞ (Infinity) dB to +6 dB.

Trim +12 dB update

Automation data adjusts to reflect the cur-
rent Gain setting. When working with au-
tomation data from an older version of the 
Trim plug-in, ensure the Gain setting is set 
at +6 dB.

For more information on Trim, see the Digi-
Rack Plug-Ins Guide.

Gain 
toggle

Gain 
slider
EQ III Band-Pass Mode
In Pro Tools 7.0, you can temporarily set any 
EQ III control to Band-Pass mode. Band-Pass 
mode cuts frequencies above and below the Fre-
quency setting, leaving a narrow band of mid-
range frequencies. It is especially useful for ad-
justing limited bandwidth in order to solo and 
fine-tune each individual filter before reverting 
the control to notch filter or peaking filter type 
operations.

To switch an EQ III control to Band-Pass mode:

• Hold Start+Shift (Windows) or Control+Shift 
(Macintosh), and drag any rotary control or 
control point horizontally or vertically.

When in Band-Pass mode, the Frequency and Q 
controls function differently.

Frequency Sets the frequency above and below 
which other frequencies are cut off, leaving a 
narrow band of mid-range frequencies. 

Q Sets the width of the narrow band of mid-
range frequencies centered around the Fre-
quency setting.

Band-Pass mode does not affect EQ III Gain 
controls.

EQ III interactive graph displaying Band-Pass mode
Chapter 7: Plug-Ins 75



76

What’s New M-Powered 7.0.book  Page 76  Friday, October 21, 2005  2:59 PM
To switch an EQ III control out of Band-Pass mode:

• Release Start+Shift (Windows) or Con-
trol+Shift (Macintosh), and drag any rotary 
control or control point horizontally or verti-
cally.

Synchronic Updates

Dragging and Dropping Audio Files 
to Synchronic Waveform Display

In Pro Tools 7.0, you can drag and drop audio 
files from the Workspace directly into the Syn-
chronic Waveform display.

Synchronic AudioSuite

In Pro Tools 7.0, Synchronic has been updated 
to support AudioSuite. The AudioSuite version 
of Synchronic replicates most of the features 
found in its real-time counterpart, with the fol-
lowing differences:

• New Load Selection button

• One-loop limit

• Changes to modules for AudioSuite
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New Load Selection Button

The AudioSuite version of Synchronic has a 
Load Selection button, which lets you automat-
ically load a selected portion of a Pro Tools track 
into the Waveform display. 

Synchronic (AudioSuite version shown)

New Load Selection button

See “Loading a Pro Tools Selection into Syn-
chronic” on page 78 for more information.
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One-Loop Limit

You can work with one audio loop for each in-
stance of Synchronic AudioSuite.

Changes to Synchronic Modules for 
AudioSuite

The AudioSuite version of Synchronic includes 
three of the five modules found in its real-time 
counterpart: Sound, Playback, and Effect. Each 
of these modules has been modified slightly for 
the AudioSuite version.

Edit Mode Only in AudioSuite Modules

In the RTAS version of Synchronic, each module 
can be independently switched between Edit 
and Performance modes with the Mode toggle.

In the AudioSuite version of Synchronic, the 
modules function only in Edit mode. Perfor-
mance mode is not available since its features 
are not relevant to non-real time functionality, 
and the Mode toggle does not exist.

Changes to the Sound Module in AudioSuite

In Synchronic AudioSuite, the Sound module 
lets you import, delete, slice-up, and fine-tune 
audio (loops) for Synchronic playback.

The XFade and MIDI modules are real-time 
based and are included only in the RTAS 
version of Synchronic.

Synchronic Sound module (AudioSuite version)
This module replicates the Edit mode function-
ality of its real-time counterpart, with the fol-
lowing differences:

Load Selection Button The Load Selection but-
ton lets you automatically load a selected por-
tion of audio from the Pro Tools Edit window 
into the Waveform display.

One Loop Limitation The AudioSuite version of 
Synchronic lets you work with one audio loop at 
a time.

Changes to the Playback Module in AudioSuite

In Synchronic AudioSuite, the Playback module 
lets you edit the Playback parameters.

This module replicates the Edit mode function-
ality of its real-time counterpart, with the fol-
lowing differences:

The Load Selection button is only available 
in the AudioSuite version of Synchronic.

See the Synchronic Guide for detailed infor-
mation on using the Sound module in Edit 
mode

Synchronic Playback module (AudioSuite version)

Pitch and Offset
Select and Enable
buttons

Pitch or Offset
parameters
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Playback User Knobs Unavailable The Playback 
user knobs are available only in the RTAS ver-
sion of Synchronic.

Changes to the Effect Module in AudioSuite

The Effect module provides easy access to the 
Gain, Noise, Filter, and Delay effects and their 
parameters. 

This module replicates the Edit mode function-
ality of its real-time counterpart, with the fol-
lowing differences:

Effect User Knobs Unavailable The Effect user 
knobs are available only in the RTAS version of 
Synchronic.

See the Synchronic Guide for detailed infor-
mation on using the Playback module in 
Edit mode.

Synchronic AudioSuite Effect module

See the Synchronic Guide for detailed infor-
mation on using the Effect module in Edit 
mode.
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Working with Synchronic 
AudioSuite

The AudioSuite version of Synchronic adds two 
new features:

• Loading a Pro Tools selection into the 
Waveform display

• Printing an audio loop to a track

Loading a Pro Tools Selection into 
Synchronic

The AudioSuite version of Synchronic lets you 
load a selected portion of a Pro Tools audio track 
directly into the Waveform display.

To load a selection from Pro Tools into Synchronic:

1  In the Pro Tools Edit window, select the por-
tion of audio you want to loop in Synchronic.

For more information about using general 
features in Synchronic, see the Synchronic 
Guide.

Making a selection in Pro Tools



What’s New M-Powered 7.0.book  Page 79  Friday, October 21, 2005  2:59 PM
2  In the Sound module of the AudioSuite ver-
sion of Synchronic (AudioSuite > Instrument > 
Synchronic), click Load Selection.

The selected portion of audio appears in the 
Synchronic Waveform display.

Printing a Loop to a Pro Tools Track

Processing the AudioSuite version of Synchronic 
involves “printing” the audio loop to a selected 
track or portion of a track.

To print an audio loop to Pro Tools:

1  In the Pro Tools Edit window, select the por-
tion of an audio track where you want to print 
the audio loop.

2  Click Process to print the audio loop to the se-
lection.

Making a selection in Pro Tools

Pro Tools selection loaded into Waveform display

Printing an audio loop from Synchronic Au-
dioSuite to a selection in a Pro Tools audio 
track will overwrite any audio material in 
that selection.

Load
Selection
Bomb Factory Updates

Updated Rotary Control Behavior

In Pro Tools 7.0, the behavior of rotary controls 
in all Bomb Factory plug-ins has been updated 
to be consistent with the behavior of rotary con-
trols in other Digidesign plug-ins. Parameter 
values increase as you drag upward or to the 
right, and decrease as you drag downward or to 
the left.

Restoring Bomb Factory Plug-In 
Settings

In Pro Tools 7.0, you can restore the default set-
tings of any Bomb Factory control by Alt-click-
ing (Windows) or Option-clicking (Macintosh) 
the control.

This addition affects the functionality of the 
Fairchild 670 and the BF76 Bomb Factory plug-
ins.

Bomb Factory rotary control (BF-2A shown)

In previous versions of Bomb Factory, it was 
necessary to drag around a rotary control in 
a circular motion to adjust the parameters. 
You can temporarily revert to this behavior 
by holding down Start+Shift (Windows) or 
Control+Shift (Macintosh) while adjusting 
the control.
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Changes to Stereo-Linking Controls in 
Fairchild 670

In previous versions of the Bomb Factory Fair-
child 670 plug-in, you could stereo-link its con-
trols by Alt-clicking (Windows) or Option-click-
ing (Macintosh) either control.

In Pro Tools 7.0, Shift-click a control to link a 
control to the other control’s settings.

Changes to Enabling “All Buttons In” 
Mode in BF76

In previous versions of the Bomb Factory BF76 
plug-in, Alt-clicking (Windows) or Option-click-
ing (Macintosh) one of the Ratio Push switches 
would enable all of the Ratio Push switches 
(known as “All Buttons In” mode).

Bomb Factory Fairchild 670 plug-in
What’s New in Pro Tools M-Powered 7.0
In Pro Tools 7.0, Shift-click or double-click one 
of the Ratio Push switches to enable “All But-
tons In” mode.

Pro Tools M-Powered Support 
for Additional Plug-Ins
Pro Tools M-Powered 7.0 adds support for the 
AudioSuite versions of the following plug-ins:

• SoundReplacer

• NoNOISE

Bomb Factory BF76 plug-in
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chapter 8

Control Surface Features
This chapter provides information about new 
features and enhancements in Pro Tools 
M-Powered 7.0 for the Digidesign Command|8 
control surface:

Command|8 New Features and 
Enhancements

Support for 10 Sends

The ten available sends in Pro Tools can be 
viewed from Sends View on Command|8.

The five Console View switches are dual-func-
tion (A/F, B/G, C/H, D/I, E/J). Sends F–J are ac-
cessed with the Shift key.

To view Sends F–J:

◆ To view Sends F–J, put Command|8 in Sends 
view, then hold Shift/Add and press the corre-
sponding switch (A=F, B=G, C=H, D=I, or E=J). 
The switches flash to indicate display of Sends 
F–J.

Support for Instrument Tracks

The Instruments View in Pro Tools lets you as-
sign MIDI Inputs and Outputs and provides ac-
cess to MIDI controls for Instrument tracks. 
MIDI Controls on Instrument Tracks

The Instruments View in Pro Tools contains 
MIDI controls that can be displayed on Com-
mand|8 data encoders.

To display MIDI controls (“Input Mode”):

1  Press the Pan switch to make sure you are in 
Home view.

2  Hold the Command/Control switch and press 
the F5 switch.

The MIDI controls appear on each channel as 
follows:

◆ Rotary encoder: MIDI Volume

◆ Select switch: MIDI Mute

To exit display of MIDI controls:

■ Hold the Command switch and press the F5 
switch again.

Instruments view in an Instrument track

MIDI Input, MIDI Output, and MIDI Pan 
controls can be accessed on-screen.

MIDI Input selector

MIDI Output selector

MIDI Volume

MIDI Pan MIDI Mute button
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