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Chapter 1: Introduction
Audio drivers for Windows let you use your 
Pro Tools hardware interface with third-party 
applications that support the ASIO Driver or 
WaveDriver MME (Multimedia Extension) 
standards.

The following Pro Tools® system interfaces are 
supported:

• Pro Tools HD® audio interfaces

• Avid Mbox

• Avid Mbox Mini

• Avid Mbox Micro

• Avid Mbox Pro

• Eleven Rack

• 003®

• 003 Rack

• 003 Rack+

• Digi 002®

• Digi 002 Rack

• Mbox® 2

• Mbox 2 Mini

• Mbox 2 Micro

For Mbox 2 Pro systems, see Part 2, 
“Mbox 2 Pro Audio Drivers.”

The original Mbox is not supported 
by Mbox family audio drivers. 
Installation

Drivers are automatically installed when you 
install Pro Tools 8.0.4 or higher. 

Check our website (www.avid.com) periodically 
to acquire any updated drivers for your system 
as they become available. 

Pro Tools LE 

After installing Pro Tools LE software, new con-
trol panels will appear on your system for your 
interface and other Avid interfaces (such as 
Eleven Rack). This lets you have a friend bring 
their Eleven Rack or other audio interface over 
to your studio and use it with your system right 
away, without having to install additional soft-
ware. 

Pro Tools HD

Pro Tools HD software only installs drivers for 
your Pro Tools HD hardware. You can add driv-
ers for Eleven Rack and other interfaces by 
downloading their installers from our website 
(www.avid.com). 

For instructions on installing Pro Tools, 
see the User Guide or Setup Guide that 
came with your system.
Chapter 1:: Introduction 3



4

Standalone Installers for Audio Drivers

Standalone driver installers for your interface 
are available on our website (www.avid.com). 
Download these installers and install the drivers 
if you want to do any of the following: 

• If you want to use your interface with a 
supported software application (such as 
iTunes) but do not want to install and use 
Pro Tools on your computer. 

– or –

• If you want to update to a newer version of 
the driver for your interface. Avid routinely 
provides new drivers online to improve 
your interface’s capabilities for with 
Pro Tools and other supported software 
applications. For example, to support new 
or updated OS (operating system) versions, 
new interfaces, or to improve the perfor-
mance between your interface and 
software. 
Windows Audio Drivers Guide
Driver Installers for Pro Tools LE Interfaces

(Excluding Mbox 2 Pro)

For Pro Tools LE interfaces (excluding 
Mbox 2 Pro), go to our website (www.avid.com) 
and download the Avid Audio Drivers Setup in-
staller. 

Driver Installers for Pro Tools HD

For Pro Tools HD systems, go to our website 
(www.avid.com) and download the standalone 
installers for the Digidesign ASIO Driver and/or 
the Digidesign WaveDriver. Versions of these 
drivers are installed automatically when you 
install Pro Tools 8.0.4. 

System Requirements and 
Compatibility

Avid can only assure compatibility and provide 
support for hardware and software it has tested 
and approved. 

For complete system requirements and a list of 
qualified computers, operating systems, hard 
drives, and third-party devices, visit:

www.avid.com/compatibility

These audio drivers are not compatible 
with Pro Tools LE versions lower than 
8.0.4. If you are running Pro Tools LE 
8.0.3 or lower, do not use these drivers. 
Instead, use the drivers that came with 
your Pro Tools Installer disc. 



Conventions Used in This 
Guide
All of our guides use the following conventions 
to indicate menu choices and key commands:
:

The names of Commands, Options, and Settings 
that appear on-screen are in a different font.

The following symbols are used to highlight 
important information:

Convention Action

File > Save Choose Save from the 
File menu

Control+N Hold down the Control key 
and press the N key

Control-click Hold down the Control key 
and click the mouse button

Right-click Click with the right 
mouse button

User Tips are helpful hints for getting the 
most from your system.

Important Notices include information that 
could affect your data or the performance of 
your system.

Shortcuts show you useful keyboard or 
mouse shortcuts.

Cross References point to related sections in 
this guide and other Pro Tools guides.
About www.avid.com
The Avid website (www.avid.com) is your best 
online source for information to help you get 
the most out of your Pro Tools system. The fol-
lowing are just a few of the services and features 
available. 

Product Registration Register your purchase 
online. 

Support and Downloads Contact Avid Customer 
Success (technical support); download software 
updates and the latest online manuals; browse 
the Compatibility documents for system re-
quirements; search the online Knowledge Base 
or join the worldwide Pro Tools community on 
the User Conference. 

Training and Education Study on your own using 
courses available online or find out how you can 
learn in a classroom setting at a certified 
Pro Tools training center. 

Products and Developers Learn about Avid 
products; download demo software or learn 
about our Development Partners and their plug-
ins, applications, and hardware. 

News and Events Get the latest news from Avid 
or sign up for a Pro Tools demo.
Chapter 1:: Introduction 5
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Chapter 2: Avid Audio Drivers
The Avid Audio Drivers are multi-client, multi-
channel sound drivers that allow third-party au-
dio programs that support the ASIO Driver or 
WaveDriver MME/DirectX (Multimedia Exten-
sion) standards to record and play back through 
qualified Pro Tools audio interfaces.

Full-duplex playback of 24- and 16-bit audio are 
supported at sample rates up to 96 kHz, depend-
ing on your Avid hardware and third-party pro-
gram used. 

Multi-client support lets more applications uti-
lize Pro Tools hardware in more combinations. 
These drivers also provide user-selectable Error 
Suppression, for greater flexibility when opti-
mizing performance on slower or older systems.

Avid Audio Driver Capabilities
Avid Audio Drivers can be used with the follow-
ing Pro Tools hardware:

• Avid Mbox

• Avid Mbox Mini

• Avid Mbox Micro

• Avid Mbox Pro

• Eleven Rack

• 003, 003 Rack, and 003 Rack+

• Digi 002 and Digi 002 Rack

• Mbox 2

• Mbox 2 Mini

• Mbox 2 Micro
Avid Audio Drivers provide up to 18 channels of 
input and output, depending on your interface:

Mbox Family

• Up to 8 channels of I/O with Avid Mbox Pro

• Up to 4 channels of input and 2 channels of 
output with Mbox 2 and Avid Mbox

• Up to 2 channels of I/O with Mbox 2 Mini and 
Avid Mbox Mini

• 2 channels of output with Mbox 2 Micro and 
Avid Mbox Micro

003 Family

• Up to 18 channels of I/O with 003, 003 Rack, 
and 003 Rack+, Digi 002, and Digi 002 Rack 

Eleven Rack

• Up to 8 channels of input and 6 channels of 
output with Eleven Rack

Limitations of the Pro Tools Audio 
Drivers

Pro Tools Audio Drivers cannot be used with 
Pro Tools LE versions prior to 8.0.4 (this in-
cludes Pro Tools 8.0.3 and any CS releases). Only 
install these drivers on systems that do not have 
Pro Tools installed, unless it is Pro Tools version 
8.0.4 or later. 

For the latest third-party drivers for 
Pro Tools hardware, as well as any known 
issues, visit www.avid.com/compatibility.
Chapter 2:: Avid Audio Drivers 7
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Audio Driver Control Panel
Configuring Driver settings can be done within 
some third-party ASIO-compatible client appli-
cations.

Accessing the Pro Tools Audio 
Driver Settings

To access the ASIO Driver Control Panel from a 
third-party application:

Refer to your program’s documentation.

For example, with Ableton Live, choose Options 
> Preferences, then click the Audio button. Use 
the “Driver Type” or “Host” (or other) selector 
to choose MME or ASIO, then configure the 
available parameters as needed. 

Audio setup in Ableton Live 

Audio setup in Audacity
Windows Audio Drivers Guide
ASIO Settings

When the chosen Driver Type is ASIO, your de-
vice becomes selected as the current Audio De-
vice (or other device), and settings appear for 
you to configure your hardware. Available set-
tings vary depending on the client application.

Using the ASIO Control Panel

From the Driver Control Panel, you can change 
the Buffer Size and Clock Source settings for 
your hardware.

Buffer Size

You may select from the following buffer sizes 
(depending on your hardware):

• 128 samples

• 256 samples

• 512 samples

• 1024 samples

• 2048 samples

 ASIO settings in Ableton Live 

 ASIO Control Panel



Small buffers have the advantage of low la-
tency in the record monitor path. (Latency is 
the time delay between a signal entering the au-
dio inputs and leaving the outputs during re-
cording.) 

Larger buffers have the advantage of making 
the ASIO Driver more immune to audio drop-
outs during playback and recording. 

In some ASIO-compatible audio programs, per-
forming various tasks will interrupt the ASIO 
Driver and may result in clicks and pops in au-
dio playback or recording. Choosing medium or 
large buffers (such as 256, 512, or 1024) can help 
alleviate this problem.

Changing the Buffer Size for the Driver does not 
affect the H/W Buffer Size settings in the 
Pro Tools Playback Engine dialog.

Clock Source

Clock Source lets you choose Internal or S/PDIF 
(as available on your hardware). Use S/PDIF to 
clock your hardware when recording into 
Pro Tools from an external digital source 
through S/PDIF. 

For more information on the Hardware 
Setup dialog, see the User Guide or Setup 
Guide that came with your system.

For more information on setting the Clock 
Source, see the User Guide or Setup Guide 
that came with your system.
MME Settings

When the chosen Driver Type is MME/DirectX, 
your device is selected as the current Audio De-
vice (or other), and settings appear for you to 
configure your hardware. Available settings vary 
depending on the client application.

Use the MME driver to let third-party audio pro-
grams that support the WaveDriver MME (Mul-
timedia Extensions) standard to play back 
through qualified Pro Tools audio interfaces on 
Windows. 

Playback of 24- and 16-bit audio is supported at 
sample rates up to 48 kHz, depending on your 
Pro Tools hardware and client application. The 
MME driver provides 2 channels of output on all 
systems. 

MME/DirectX settings in Ableton Live
Chapter 2:: Avid Audio Drivers 9
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Chapter 3: Digidesign ASIO Driver 
(Pro Tools HD Only)
Digidesign ASIO Driver 
Capabilities
The Digidesign ASIO Driver is a single-client, 
multichannel sound driver that allows third-
party audio programs that support the ASIO 
Driver standard to record and play back through 
qualified Pro Tools audio interfaces.

Full-duplex playback of 24- and 16-bit audio are 
supported at sample rates up to 96 kHz, depend-
ing on your hardware and ASIO program used.

The Digidesign ASIO Driver provides up to 8 
channels of input and output, depending on 
your Pro Tools hardware:

• Up to 8 channels of I/O with Pro Tools HD 

Limitations 

The ASIO Driver cannot be used with multiple 
applications at the same time. Only one applica-
tion at a time can use the ASIO Driver. Be sure to 
disable the Windows system sounds. It is also 
recommended that you use a separate sound 
card for games or other general work. 

For the latest drivers for Pro Tools hard-
ware, visit www.avid.com/compatibility.
ASIO Driver Control Panel
Configuring ASIO Driver settings can be done 
using the Digidesign ASIO Control Panel, which 
is accessed within some third-party ASIO-com-
patible client applications.

Accessing the Digidesign ASIO 
Driver Control Panel

To access the Digidesign ASIO Driver Control 
Panel from a third-party application:

Refer to your program’s documentation.

For example, with Propellerhead Reason, click 
the Control Panel button.
Chapter 3:: Digidesign ASIO Driver (Pro Tools HD Only) 11
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The Digidesign ASIO Driver Control Panel can-
not be accessed under the following circum-
stances:

• When Pro Tools is running.

• When playing or recording in an audio 
program that does not support the ASIO 
Driver. 

• When using a third-party audio program 
that has an option to keep the ASIO Driver 
open even when you are not playing or re-
cording. (You must close the audio pro-
gram before you can open the ASIO Driver 
Control Panel.)

Setup Example, using Propellerhead Reason

Control 
Panel button
Windows Audio Drivers Guide
Using the ASIO Driver Control 
Panel

From the ASIO Driver Control Panel, you can 
change the Buffer Size setting or access the Hard-
ware Setup dialog for your hardware.

Buffer Size

You may select from the following buffer sizes 
(depending on your hardware):

• 128 samples

• 256 samples

• 512 samples

• 1024 samples

• 2048 samples

Small buffers have the advantage of low la-
tency in the record monitor path. (Latency is 
the time delay between a signal entering the au-
dio inputs and leaving the outputs during re-
cording.) 

Larger buffers have the advantage of making 
the Digidesign ASIO Driver more immune to au-
dio dropouts during playback and recording. 

In some ASIO-compatible audio programs, per-
forming various tasks will interrupt the ASIO 
Driver and may result in clicks and pops in au-
dio playback or recording. Choosing medium or 
large buffers (such as 256, 512, or 1024) can help 
alleviate this problem.

Digidesign ASIO Control Panel



Changing the Buffer Size for the Driver does not 
affect the H/W Buffer Size settings in the 
Pro Tools Playback Engine dialog.

Device

The Device Type will always be set to your in-
stalled Pro Tools hardware.

Advanced Button

The Advanced button opens the Hardware Setup 
dialog for the hardware that you are using. 

For more information on the Hardware 
Setup dialog, refer to the User Guide or 
Setup Guide that came with your system.
Chapter 3:: Digidesign ASIO Driver (Pro Tools HD Only) 13
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Chapter 4: WaveDriver Windows 
System Audio Driver (Pro Tools HD Only)
WaveDriver Capabilities
The Digidesign WaveDriver Windows System 
Audio Driver is a single-client, multichannel 
sound driver that lets third-party audio pro-
grams that support the WaveDriver MME (Mul-
timedia Extensions) standard play back through 
qualified Pro Tools interfaces on Windows.

Playback of 24- and 16-bit audio are supported 
at sample rates up to 48 kHz, depending on your 
Pro Tools hardware and WaveDriver client ap-
plication. The Digidesign WaveDriver provides 
2 channels of output on all systems.

The Digidesign WaveDriver Window System 
Audio Driver supports all qualified Pro Tools HD 
interfaces. 
Chapter 4:: Wave
Limitations

WaveDriver is not multi-client. Only one appli-
cation at a time can use the WaveDriver. It is 
also recommended that you use a separate 
sound card for games or other general work. For 
third-party software synthesizers and samplers, 
or for any applications requiring full duplex in-
put and output use the Digidesign ASIO Driver. 
Refer to Chapter 3, “Digidesign ASIO Driver 
(Pro Tools HD Only).”

For the latest third-party drivers for 
Pro Tools hardware, as well as any known 
issues, visit www.avid.com/compatibility.
Driver Windows System Audio Driver (Pro Tools HD Only) 15
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Configuring WaveDriver for 
Using iTunes
In order to let iTunes for Windows play back 
through Pro Tools hardware under 
Windows XP, you must select the waveOut op-
tion in the QuickTime Player Audio settings. 

The same basic steps apply for other Windows 
operating systems.

To configure WaveDriver as the iTunes default 
device:

1  Close all WaveDriver third-party applications 
(including iTunes).

2  Choose Start > Programs > QuickTime > 
QuickTime Player.

3  In QuickTime Player, choose Edit > Prefer-
ences > QuickTime Preferences.

4  In the QuickTime Settings window, click the 
Audio Tab.

5  Select the “Safe mode (waveOut only)” op-
tion, and click Apply.

6  Click OK to close the QuickTime Settings win-
dow.

7  Exit QuickTime Player.

8  Re-launch iTunes.

You may also need to add iTunes to the 
WaveDriver Application Access list. See 
“Adding Third Party Applications to the 
Application Access List” on page 17.
Windows Audio Drivers Guide
Configuring WaveDriver for 
Windows Media Player and 
Other Programs
On Windows XP, the WaveDriver is configured 
in the Sounds and Audio Devices Control Panel 
(for programs that use the Windows Sound Play-
back Default Device, such as Windows Media 
Player), or as a preference in third-party Wave-
Driver client applications. 

The same basic steps apply for other Windows 
operating systems. 

To configure WaveDriver as the Windows Sound 
Playback Default Device:

1  Choose Start > Control Panel.

2  Double-click Sounds and Audio Devices. 

3  Click the Audio tab.

4  Select the Pro Tools hardware in the Sound 
Playback default device lists. 

5  Close the Control Panel. 

Sounds and Audio Devices Control Panel



When you run Windows Media Player, it auto-
matically outputs to your hardware.

To configure WaveDriver for a third party 
WaveDriver application:

In the third-party application, select the 
Pro Tools hardware as the preference for your 
playback hardware. For details on setting this 
preference, refer to your program’s documenta-
tion.

You may also need to add your third party 
WaveDriver application to the WaveDriver 
Application Access list. See “Adding Third 
Party Applications to the Application Ac-
cess List” on page 17.
Chapter 4:: Wave
Adding Third Party 
Applications to the 
Application Access List
The Digidesign WaveDriver uses an Application 
Access list to control third party application ac-
cess to the Pro Tools hardware. Some third party 
audio applications may not work with the 
WaveDriver unless they are included in this list.

For the latest instructions for adding and remov-
ing applications to the WaveDriver Application 
Access list, refer to the KnowledgeBase on our 
website (www.avid.com)

Modifying the Digidesign WaveDriver Ap-
plication Access list requires editing the 
Windows System Registry. Because editing 
the Windows Registry can result in prob-
lems if not done correctly, make sure to 
carefully follow the instructions for adding 
and removing applications.
Driver Windows System Audio Driver (Pro Tools HD Only) 17
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Chapter 5: Introduction (Mbox 2 Pro Only)
Introduction
The Digidesign ASIO Driver and DirectSound 
Driver let you use your Digidesign Mbox 2 Pro 
hardware interface with third-party applications 
that support the ASIO Driver or DirectSound 
Driver standard.

This chapter provides information on the 
Mbox 2 Pro Control Panel, which can be used to 
configure either Mbox 2 Pro driver.

Installation

The Digidesign ASIO Driver and DirectSound 
Driver for Mbox 2 Pro are automatically in-
stalled when you install Pro Tools. 

For specifications and additional configura-
tion information specific to each Mbox 2 
Pro driver, see Chapter 3, “Digidesign ASIO 
Driver (Pro Tools HD Only)” and 
Chapter 7, “DirectSound Windows System 
Audio Driver (Mbox 2 Pro Only).”

For instructions on installing Pro Tools, 
see the User Guide or Setup Guide that 
came with your system.
Standalone Digidesign Windows Audio 
Drivers

Digidesign Windows Audio Drivers can be in-
stalled on Windows systems that do not have 
Pro Tools installed. Use the standalone version 
of the Digidesign Windows Audio Drivers in-
staller (Digidesign Audio Drivers Setup.exe), 
which is available from the Support and Down-
loads area of our website (www.avid.com). 

System Requirements and 
Compatibility
The Digidesign ASIO Driver and DirectSound 
Driver can be used with Mbox 2 Pro on 
Pro Tools systems running on a qualified ver-
sion of Windows 7, Windows XP and 
Windows Vista.

Avid can only assure compatibility and provide 
support for hardware and software it has tested 
and approved. 

For complete system requirements and a list of 
qualified computers, operating systems, hard 
drives, and third-party devices, visit:

www.avid.com/compatibility
Chapter 5:: Introduction (Mbox 2 Pro Only) 21
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Mbox 2 Pro Driver 
Control Panel
Configuring ASIO Driver or DirectSound set-
tings can be done using the Mbox 2 Control 
Panel, or within some third-party ASIO-compat-
ible or DirectSound-compatible client applica-
tions.

Accessing the Mbox 2 Pro Control 
Panel

The Mbox 2 Pro Control Panel can be accessed 
without opening a third-party application (from 
the Windows Control Panel folder), or from 
within some third-party programs.

To access the Mbox 2 Pro control panel without 
opening a third-party application:

Choose Start > Control Panel > Digidesign 
Mbox 2 Pro.

For additional configuration information 
specific to each driver, see Chapter 3, 
“Digidesign ASIO Driver (Pro Tools HD 
Only)” and Chapter 7, “DirectSound Win-
dows System Audio Driver (Mbox 2 Pro 
Only).”

Digidesign Mbox 2 Pro Control Panel
Windows Audio Drivers Guide
To access the Mbox 2 Pro from a third-party 
application:

Refer to your program’s documentation.

For example, with Propellerhead Reason, click 
the Control Panel button.

No Hardware Detected Dialog

If your hardware is not connected or cannot be 
detected, the No Hardware Detected dialog will 
open instead of the Mbox 2 Pro Control Panel.

In this case, click OK, then check the FireWire 
(1394) connection between the computer and 
Mbox 2 Pro. If reconnecting the cable does not 
correct the problem, check that you have in-
stalled Pro Tools correctly.

Setup Example, using Propellerhead Reason

No Hardware Detected dialog

Control 
Panel button



Using the Mbox 2 Pro 
Control Panel

Use the Mbox 2 Pro Control Panel to identify 
your Digidesign hardware, check firmware, view 
or change the Clock Source, and enable S/PDIF 
mirroring of analog outputs 1 and 2.

The ASIO Driver and DirectSound Driver use the 
same Mbox 2 Pro Control Panel.

Device Information Section

This area shows the hardware (Mbox 2 Pro) de-
tected by the Control Panel, the firmware ver-
sion of your Mbox 2 Pro, and other informa-
tion.

Digidesign Mbox 2 Pro Control Panel

Changing the Clock Source in the Mbox 2 
Pro Control Panel will not dynamically up-
date the setting in the Pro Tools Hardware 
Setup or Session Setup window if it is open. 
The Pro Tools Hardware Setup and Session 
Setup window will update when you close 
and reopen them.
Device Properties Section

Clock Source

This pop-up menu lets you choose the clock 
source for Mbox 2 Pro:

Internal Use this setting for normal playback of 
audio, or if you are recording audio through the 
analog inputs.

S/PDIF Use this setting if you are recording au-
dio through the S/PDIF input.

Word Clock Use this setting to clock Pro Tools to 
a Word clock source connected to the Mbox 2 
Pro Word Clock In port.

S/PDIF Output Mirroring

Check this box to set the S/PDIF output chan-
nels to always mirror analog outputs 1 and 2.

S/PDIF input is only available when S/PDIF 
is the Clock Source.
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24
 Windows Audio Drivers Guide



Chapter 6: Digidesign ASIO Driver 
(Mbox 2 Pro Only)
Introduction
The Digidesign ASIO Driver is a single-client, 
multichannel sound driver that allows third-
party audio programs that support the ASIO 
Driver standard to record and play back through 
your Mbox 2 Pro.

Full-duplex playback of 24- and 16-bit audio are 
supported at sample rates up to 96 kHz, depend-
ing on third party program used.

The Digidesign ASIO Driver will provide up to 4 
channels of input and 2 channels of output with 
Mbox 2 Pro.

Limitations of the Digidesign ASIO 
Driver

The ASIO Driver cannot be used with multiple 
applications at the same time. Only one applica-
tion at a time can use the ASIO Driver. Be sure to 
disable the Windows system sounds. It is also 
recommended that you use a separate sound 
card for games or other general work.

For the latest third-party drivers for 
Pro Tools hardware, as well as any known 
issues, visit www.avid.com/compatibility.
ASIO Driver Control Panel
On Windows XP, configuring ASIO Driver set-
tings can be done using the Digidesign ASIO 
Control Panel, which is accessed within some 
third-party ASIO-compatible client applications. 

The same basic steps apply for other Windows 
operating systems.

Accessing the Digidesign ASIO 
Driver Control Panel

To access the Digidesign ASIO Driver Control 
Panel from a third-party application:

Refer to your program’s documentation.

For example, with Propellerhead Reason, click 
the Control Panel button.
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The Digidesign ASIO Driver Control Panel can-
not be accessed under the following circum-
stances:

• When Pro Tools is running.

• When playing or recording in an audio 
program that does not support the ASIO 
Driver. 

• When using a third-party audio program 
that has an option to keep the ASIO Driver 
open even when you are not playing or re-
cording. (You must close the audio pro-
gram before you can open the ASIO Driver 
Control Panel.)

Setup Example, using Propellerhead Reason

Control 
Panel button
Windows Audio Drivers Guide
Using the ASIO Driver Control 
Panel

From the ASIO Driver Control Panel, you can 
change the Buffer Size setting or access the Hard-
ware Setup dialog for your Digidesign hardware. 

Buffer Size

You may select from the following buffer sizes 
(depending on your hardware):

• 128 samples

• 256 samples

• 512 samples

• 1024 samples

• 2048 samples

Small buffers have the advantage of low la-
tency in the record monitor path. (Latency is 
the time delay between a signal entering the au-
dio inputs and leaving the outputs during re-
cording.) 

Larger buffers have the advantage of making 
the Digidesign ASIO Driver more immune to au-
dio dropouts during playback and recording. 

In some ASIO-compatible audio programs, per-
forming various tasks will interrupt the ASIO 
Driver and may result in clicks and pops in au-
dio playback or recording. Choosing medium or 
large buffers (such as 256, 512, or 1024) can help 
alleviate this problem.

Digidesign ASIO Control Panel



Changing the Buffer Size for the Digidesign 
ASIO Driver does not affect the H/W Buffer Size 
settings in the Pro Tools Playback Engine dialog.

Device

The Device Type will always be set to your in-
stalled Pro Tools hardware.

Advanced Button

The Advanced button opens the Hardware Setup 
dialog for the hardware that you are using. 

For more information on the Hardware 
Setup dialog, refer to the User Guide or 
Setup Guide that came with your system.
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Chapter 7: DirectSound Windows 
System Audio Driver (Mbox 2 Pro Only)
Introduction
The DirectSound Windows System Audio Driver 
is a multi-client, multichannel sound driver that 
allows third-party audio programs that support 
the DirectSound standard to play back and re-
cord through Mbox 2 Pro.

Playback and recording of 24- and 16-bit audio 
are supported at sample rates up to 96 kHz, de-
pending on your DirectSound client applica-
tion.

The DirectSound Driver provides up to 6 chan-
nels of input and 8 channels of output with 
Mbox 2 Pro systems.

For the latest third-party drivers for 
Pro Tools hardware, as well as any known 
issues, visit www.avid.com/compatibility.
Chapter 7:: Direc
Configuring DirectSound 
Driver Settings
On Windows XP, configuring DirectSound set-
tings can be done using the Mbox 2 Pro Control 
Panel, or within most third-party DirectSound-
compatible client applications.

The same basic steps apply for other Windows 
operating systems.

Some third-party applications require additional 
configuration step (such as iTunes). See “Config-
uring DirectSound Driver for Using iTunes” on 
page 30 and “Configuring DirectSound Driver 
for Windows Media Player and Other Programs” 
on page 30.

For information on the Mbox 2 Pro Control 
Panel, see “Mbox 2 Pro Driver 
Control Panel” on page 22.

For more information on configuring your 
program, refer to its documentation.
tSound Windows System Audio Driver (Mbox 2 Pro Only) 29
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Configuring DirectSound 
Driver for Using iTunes
In order to let iTunes for Windows play back 
through Pro Tools hardware, you must select the 
waveOut option in the QuickTime Player Audio 
settings.

To configure DirectSound Driver as the iTunes 
default device:

1  Close all DirectSound Driver third-party appli-
cations (including iTunes).

2  Choose Start > Programs > QuickTime > 
QuickTime Player.

3  In QuickTime Player, choose Edit > Prefer-
ences > QuickTime Preferences.

4  In the QuickTime Preferences window, click 
the Audio Tab.

5  Select the “Safe mode (waveOut only)” op-
tion, and click Apply.

6  Click OK to close the QuickTime Settings win-
dow.

7  Exit QuickTime Player.

8  Re-launch iTunes.

Configuring DirectSound 
Driver for Windows Media 
Player and Other Programs
The DirectSound Driver is configured in the 
Sounds and Audio Devices Control Panel (for 
programs that use the Windows Sound Playback 
Default Device, such as Windows Media Player), 
or as a preference in third-party DirectSound 
Driver client applications.
Windows Audio Drivers Guide
To configure DirectSound Driver as the Windows 
Sound Playback Default Device:

1  Choose Start > Control Panel.

2  Double-click Sounds and Audio Devices. 

3  Click the Audio tab.

4  Select the Pro Tools hardware in the Sound 
Playback default device lists. 

5  Close the Control Panel. 

When you run Windows Media Player, it auto-
matically outputs to your Digidesign hardware.

To configure DirectSound Driver for a third-party 
DirectSound Driver application:

In the third-party application, select the 
Pro Tools hardware as the preference for your 
playback hardware. For details on setting this 
preference, refer to your program’s documenta-
tion.

Sounds and Audio Devices Control Panel
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