ECx Ethernet Control
for VENUE Systems
# Contents

## Chapter 1. Overview
- ECx Capabilities and Features ......................................................... 1  
- ECx Components .............................................................................. 1  
- System Requirements and Compatibility Information ...................... 1  
- About This Guide ............................................................................ 2  
- About www.avid.com ....................................................................... 2  

## Chapter 2. Installing ECx Software ................................................. 3
- Installing ECx Host Software ............................................................ 3  
- Installing the ECx Client Software ................................................... 3  
- Uninstalling ECx Host Software ....................................................... 4  
- Reinstalling ECx Host Software ....................................................... 4  

## Chapter 3. Configuring and Using ECx ........................................ 5
- Overview .......................................................................................... 5  
- Connecting a Computer Directly to VENUE ................................... 5  
- Connecting a Wireless Router or WAP to VENUE ......................... 5  
- Setting VENUE and Client IP Addresses ....................................... 6  
- Establishing a Wireless Connection ............................................. 9  
- Enabling Remote Operation ......................................................... 10  
- Disconnecting ECx ......................................................................... 11  
- Changing the Ethernet Control Password .................................. 11
Welcome to ECx Ethernet Control for Avid VENUE systems. ECx lets you control a VENUE system remotely over an Ethernet network using compatible wired or wireless network equipment (purchased separately).

**ECx Capabilities and Features**

ECx provides the following:

- Remote control of a VENUE system from a client computer, including a laptop or Tablet PC
- Exact duplication of VENUE software on the remote client computer

**ECx Components**

The ECx package includes the following items:

- ECx card (pre-installed in the VENUE FOH Rack, VENUE Mix Rack and the VENUE SC48™)
- Ethernet cable for connecting the ECx card to your client computer, wireless router, or wireless access point device
- ECx Ethernet Control Software installer CD-ROM (containing ECx host and client software)

---

**System Requirements and Compatibility Information**

The following are required to use ECx:

- A VENUE system that has already been installed and configured, running VENUE software 1.1 or higher
- A qualified router or wireless access point (WAP) device
- A client computer running qualified Windows or Mac OS X software with wired or wireless Ethernet capability.
- For wireless communication with ECx, 802.11g capable devices (or faster) are recommended.

Avid can only assure compatibility and provide support for hardware and software it has tested and approved.

For complete system requirements and a list of qualified computers, operating systems, hard drives, and third-party devices, visit:

www.avid.com/compatibility
About This Guide

This guide provides installation and operational instructions for using ECx Ethernet Control.

For complete instructions on connecting and configuring your VENUE system, see the VENUE D-Show, VENUE Profile, or VENUE SC48 guide.

Conventions Used in This Guide

All of our guides use the following conventions to indicate menu choices and key commands:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save</td>
<td>Choose Save from the File menu</td>
</tr>
<tr>
<td>Control+N</td>
<td>Hold down the Control key and press the N key</td>
</tr>
<tr>
<td>Control-click</td>
<td>Hold down the Control key and click the mouse button</td>
</tr>
<tr>
<td>Right-click</td>
<td>Click with the right mouse button</td>
</tr>
</tbody>
</table>

The names of Commands, Options, and Settings that appear on-screen are in a different font.

The following symbols are used to highlight important information:

💡 User Tips are helpful hints for getting the most from your system.

⚠️ Important Notices include information that could affect your data or the performance of your system.

👉 Shortcuts show you useful keyboard or mouse shortcuts.

➢ Cross References point to related sections in this guide and other VENUE guides.

About www.avid.com

The Avid website (www.avid.com) is your best online source for information to help you get the most out of your system. The following are just a few of the services and features available.

Product Registration Register your purchase online.

Support and Downloads Contact Avid Customer Success (technical support); download software updates and the latest online manuals; browse the Compatibility documents for system requirements; search the online Knowledge Base or join the worldwide Avid community on the User Conference.

Training and Education Study on your own using courses available online or find out how you can learn in a classroom setting at a certified training center.

Products and Developers Learn about Avid products; download demo software or learn about our Development Partners and their plug-ins, applications, and hardware.

News and Events Get the latest news from Avid or sign up for a product demo.
Chapter 2: Installing ECx Software

To use ECx Ethernet Control, you must do the following:
- Install the ECx host software on your VENUE system.
- Install the ECx client software on your remote computer.

If you need to uninstall the ECx host software from your VENUE system, see “Uninstalling ECx Host Software” on page 4.

If you need to re-install the ECx host software, (after a System Restore or an Update), see “Reinstalling ECx Host Software” on page 4.

After you install the host and client software, see Chapter 3, “Configuring and Using ECx” for information on setting up your VENUE system and client computer for remote operation using ECx.

Installing ECx Host Software

The ECx Ethernet Control Software installer disc contains the ECx host software. This software enables your VENUE system to communicate with computers running the remote client software.

**To install ECx host software on your VENUE system:**
1. Insert the ECx installer disc in VENUE’s CD-ROM drive.
2. Do one of the following to put your system into Config Mode:
   - Press the Console Config switch on the console.
   - or –
   - Double-click the Mode box in the bottom-right corner of the screen.
3. Go to Options > System Config and click Update.
4. Click Yes to exit VENUE software and begin the installation.
5. After the ECx software installation is complete, VENUE software restarts.

Whenever you perform an Update or a System Restore of your VENUE system, you must reinstall the ECx host software. See “Reinstalling ECx Host Software” on page 4.

Installing the ECx Client Software

The ECx Ethernet Control Software installer CD-ROM contains remote control applications for both Windows and Mac platforms.

Installing the ECx Client in Windows

**To install the ECx control client application (“UltraVNC”) in Windows:**
1. Insert the ECx installer disc in the computer CD or DVD drive.
2. Open the Windows Client folder.
4. Follow the on-screen installation instructions to complete the installation.

Installing the ECx Client on Mac

**To install the ECx control client application (“Chicken of the VNC”) on Mac:**
1. Insert the ECx installer disc in the computer CD or DVD drive.
2. Open the Mac OS X Client folder.
3. Double-click the “cotvnc-20b4.dmg” file.
4. In the window that opens, drag the “Chicken of the VNC” icon to copy it to a location on your hard drive.
**Uninstalling ECx Host Software**

If you need to uninstall ECx software from your VENUE system, you can do so from the system desktop.

**To uninstall ECx host software from your VENUE system:**

1. Do one of the following to put your system into Config Mode:
   - Press the Console Config switch on the console
   - or –
   - Double-click the Mode box in the bottom-right corner of the screen.

2. Go to Options > System Config.

3. Hold the Control key and click Shut Down to go to the system desktop.

4. Locate and double-click the ECx host software uninstall program (C:\Program Files\D-Show Ethernet Control Software\Uninstall.bat).

The ECx host software is uninstalled, and the VENUE software automatically restarts.

*The ECx folder will remain on your VENUE system hard drive after uninstalling.*

**Reinstalling ECx Host Software**

If ECx is installed on your VENUE system, you will have to reinstall the ECx host software after performing a System Restore or an Update.

**System Restore** If you perform a complete System Restore, the ECx host software must be reinstalled from its original installer disc. See “Installing ECx Host Software” on page 3.

**Update** If you perform an Update, you must still reinstall the ECx host software. You can reinstall without using the ECx installer disc because an Update leaves the ECx installer on your VENUE system’s hard drive. You can also reinstall using the original installer disc.

**To reinstall after an Update without using the ECx installer disc:**

1. Remove any USB key disks from all USB ports, and make sure no installer discs are in the CD-ROM drive.

2. Do one of the following to put your system into Config Mode:
   - Press the Console Config switch on the console.
   - or –
   - Double-click the Mode box in the bottom-right corner of the screen.

3. Go to the Options > Systems page.

4. Click the Update button.
Overview

You can control your VENUE system (the “host”) with a remote computer (the “client”) using standard VNC (Virtual Network Computing) protocol over TCP/IP, allowing remote access to your system via a wired or wireless Ethernet-based network. This chapter covers the steps for configuring and using ECx.

For a wired network, the steps include:
- Connecting the remote computer directly to your VENUE system using an Ethernet cable.
- Setting the IP addresses of your VENUE system and your client computer manually.
- Enabling remote operation of your VENUE system.

For a wireless network, the steps include:
- Connecting a wireless router or a wireless access point (WAP) device to your VENUE system.
- Setting the IP addresses of your VENUE system and your client computer manually or automatically.
- Establishing a connection between your wireless router and the client computer.
- Enabling remote operation of your VENUE system.

Connecting a Computer Directly to VENUE

If you are establishing a fixed remote control station and do not need a mobile connection, you can connect the remote computer directly to your VENUE system using an Ethernet cable.

To connect a computer directly to your VENUE system:
1. Connect one end of the appropriate Ethernet cable type (with RJ-45 connectors) to the ECx port on your VENUE system, and the other end to the Ethernet port on the computer. The type of cable depends on the operating system of the remote computer:
   - Windows To connect a Windows computer directly to your VENUE system, an Ethernet crossover cable is required. Alternatively, you can use an Ethernet hub and connect standard Ethernet cables between your VENUE system, the hub, and the remote computer.
   - Mac To connect a Mac computer directly to your VENUE system, you can use either a standard Ethernet cable or an Ethernet crossover cable.
2. Configure the VENUE system and the client computer IP addresses manually. See “Setting IP Addresses Manually” on page 6.

Connecting a Wireless Router or WAP to VENUE

VENUE systems work with standard wireless routers or WAP devices.

Before connecting a wireless router or WAP device, you should configure the SSID of the device so that its wireless network can be easily identified on the client computer. You can specify any unique network name for the device, such as “VENUE Network.”

To configure the SSID and any network security features of your wireless router or WAP, refer to the manufacturer’s instructions.

To connect a wireless router or WAP device to a VENUE system:
1. Connect one end of the appropriate type of Ethernet cable to the ECx port and the other end to the Ethernet connector port on the router or WAP. Do one of the following depending on the type of device you are using:
   - If you are using a wireless router, use a standard Ethernet cable to your VENUE system.
   - or –
   - If you are using a WAP, use an Ethernet crossover cable to connect to your VENUE system.
2 Do one of the following:

- If you are using a wireless router or WAP device that does not include a DHCP server function (such as the Cisco Aironet 1230AG), you must configure your VENUE system and the client computer IP addresses manually. See “Setting IP Addresses Manually” on page 6.

- or –

- If you are using a wireless router that includes a DHCP server function (such as the Belkin Pre-N), you can configure your VENUE system and the client computer to set the IP addresses automatically. See “Setting VENUE and Client IP Addresses Automatically” on page 8.

Setting VENUE and Client IP Addresses

You can set the IP addresses of your VENUE system and client computer manually or automatically depending on the configuration of your network:

- If you are connecting a computer directly to your VENUE system, or you are using a wireless router or WAP device that does not include a DHCP server function, see “Setting IP Addresses Manually” on page 6.

- or –

- If you are using a wireless router that includes a DHCP server function, see “Setting VENUE and Client IP Addresses Automatically” on page 8.

⚠️ IP configuration changes on your VENUE system and client computer can take up to 2 minutes to become effective. After making changes, be sure to allow sufficient time for the system to assign IP addresses and establish communication between all the components. If network communication is not established after allowing sufficient time for IP addressing, check all cables and connections.

Setting IP Addresses Manually

Set VENUE and client computer IP addresses manually if you are connecting a computer directly to your VENUE system, or you are using a wireless router or WAP device that does not include a DHCP server function.

Setting a VENUE System IP Address Manually

To manually set the IP address for your VENUE system:

1 In VENUE software, go to Options > Interaction.

2 In the Ethernet Control section, click Network Settings.

Ethernet Control section of the Interaction page

3 Click Use the Following Address and enter the following:

- IP address: 10.0.0.1
- Subnet Mask: 255.255.255.0
- Default Gateway: 10.0.0.1

Setting an IP address manually

4 Click Apply.

5 Select Enable Remote Control to activate the VENUE ECx host.

6 Go to “Setting the Client Computer IP Address Manually” on page 7.
Setting the Client Computer IP Address Manually

After manually setting your VENUE system’s IP address, you need to set your client computer’s IP address.

**Windows**

To manually set the IP address in Windows:

1. Go to Control Panels > Network Connections, and do one of the following:
   - If you are connecting the computer directly to your VENUE system, right-click the Local Area Connection icon and choose Properties.
   - or –
   - If you are connecting using a wireless router or WAP, right-click the Wireless Network Connection icon and choose Properties.

2. In the Connection Properties window, double-click Internet Protocol (TCP/IP).

3. In the Internet Protocol Properties window, select Use the following IP Address and enter the following:
   - IP address: 10.0.0.2
   - Subnet Mask: 255.255.255.0
   - Default Gateway: (none required)

4. Click OK to close the Internet Protocol properties window.

5. Click OK to close the Network Connection Properties window.

6. Do one of the following depending on the configuration of your network:
   - If you are using a wireless network, go to “Establishing a Wireless Connection” on page 9.
   - or –
   - If you are using a wired network, go to “Enabling Remote Operation” on page 10.

**Mac**

To manually set the IP address on a Mac:

1. Launch System Preferences > Network.

2. Do one of the following:
   - If you are connecting the computer directly to your VENUE system, choose Ethernet from the network connections services list.
   - or –
   - If you are connecting using a wireless router or WAP, choose Airport from the network connections services list.

3. Choose Manually from the Configure pop-up menu.
4 Enter the following:
   - IP address: 10.0.0.2
   - Subnet Mask: 255.255.255.0
   - Router: (none required)

5 Click Apply.

6 Do one of the following depending on the configuration of your network:
   - If you are using a wireless network, go to “Establishing a Wireless Connection” on page 9.
   - or –
   - If you are using a wired network, go to “Enabling Remote Operation” on page 10.

**Setting VENUE and Client IP Addresses Automatically**

You can configure your VENUE system and client computer to set their IP addresses automatically using DHCP. Set the IP automatically if you are using a wireless router that includes a DHCP server function.

**Setting the VENUE IP Address Automatically**

To set the IP address of your VENUE system automatically:

1 In the VENUE software, go to the Options page and click the Interaction tab.

2 In the Ethernet Control section, click Network Settings.

3 In the Ethernet Control window, select Obtain Address Automatically.

4 Click Apply.

5 Wait until the VENUE system is assigned an IP address. This may take time (up to two minutes). If no DHCP server is found, the VENUE system will self-assign an IP address.

   Make a note of the IP address assigned to your VENUE system, as you will need to enter it into the client software.

6 Select Enable Remote Control to activate the VENUE system ECx host. Your system’s status will be displayed as “Waiting for connection.”

7 Go to “Setting a Client Computer IP Address Automatically” on page 8.

**Setting a Client Computer IP Address Automatically**

After setting the IP address for your VENUE system using DHCP, you need to do the same for your client computer.

**Windows**

To automatically set the IP address in Windows:

1 Go to Control Panel > Network Connections.

2 Right-click the Wireless Network Connection icon and choose Properties.

3 In the Connection Properties window, double-click Internet Protocol (TCP/IP).
4 In the Internet Protocol Properties window, select “Obtain an Address Automatically.”

5 Click OK to close the Internet Protocol properties window.

6 Click OK to close the Network Connection Properties window.

7 Go to “Enabling Remote Operation” on page 10.

Mac

To automatically set the IP address on a Mac:
1 Launch System Preferences > Network.
2 Choose Airport from the network connections services list.
3 Click the Advanced button, then click the TCP/IP tab.
4 Choose Using DHCP from the Configure IPv4 menu.
5 Click OK.

Establishing a Wireless Connection

Once IP addresses are set, you can establish a connection from the client computer to the wireless network.

Windows

To establish a wireless connection in Windows:
1 Go to Control Panel > Network Connections.
2 Right-click the Wireless Network Connection icon and choose Properties.
3 In the Connection Properties window, click the Wireless Networks tab.
4 Under Preferred Networks, click Add, and type the SSID of the wireless router or WAP device connected to your VENUE system.
5 Choose the Network Authentication and Data Encryption settings to match the corresponding router or WAP configuration settings.
6 Click OK. The VENUE SSID should appear in the list of available wireless networks.
7 Go to “Enabling Remote Operation” on page 10.
**Enabling Remote Operation**

In order to enable remote operation of your VENUE system, you need to have obtained valid IP addresses for your VENUE system and your client computer. If you are using a wireless network, you also need to have established a network between the wireless router or WAP device that is connected to your VENUE system and your client computer.

**To enable remote operation with a Windows client computer:**

1. Double-click the "ECx Ethernet Control (UltraVNC Viewer)" icon on your desktop (or go to Start Menu > Programs > UltraVNC > Run UltraVNC Viewer) to launch the UltraVNC Viewer application.
2. Enter the IP address of the ECx host (your VENUE system).
3. Click Connect.
4. Enter the password when prompted (VENUE's default password is "password") and click Connect.

The client launches and displays the VENUE system screen. You can then view and operate all on-screen controls from the client computer.

**To enable remote operation with a Mac client computer:**

1. Double-click the "Chicken of the VNC" icon to launch the application.
2. Enter the IP address of the ECx host (your VENUE system).
3. Enter the password (VENUE's default password is "password") and click Connect.

The client launches and displays the VENUE system screen. You can then view and operate all on-screen controls from the client computer.
Disconnected ECx

To disconnect ECx:

1. Close the ECx client application by doing one of the following:
   - In Windows, move the pointer to the top of the screen until the control strip appears, and click the close box.
   - or –
   - On Mac, press Command+Q to quit.

2. On the VENUE system, deselect Enable Remote Control in the Ethernet Control section of the Options > Interaction page.

Changing the Ethernet Control Password

You can change the password that users need to enter in order to control your VENUE system from a remote client.

💡 By default, the VENUE Ethernet Control password is “password” (all lowercase).

To change the Ethernet Control password:

1. In the Ethernet Control section of the Options > Interaction page, double-click the Password field.

2. Enter a new password and press Enter.

💡 Make a note of the new password and your system’s IP address, as you will need to enter it into the client software.