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Chapter 1: What’s New in 
Pro Tools | Software and 
Pro Tools | HD Software Version 12.0
Pro Tools® | Software and Pro Tools | HD Software

version 12.0 provide a few new features and en-

hancements for qualified versions of Mac OS X

and Windows.

New Features and 
Improvements in Pro Tools 12

Subscription, Avid Application 
Manager, and In-Application 
Plug-in Purchase
• Pro Tools 12 provides new subscription and ser-

vice options

• Pro Tools 12 installs the Avid Application Man-

ager to help manage your software updates and

entitlements

• Pro Tools 12 lets you browse, purchase, and in-

stall plug-ins from within the application

Dashboard
• The new Dashboard window lets you create or

open sessions (replacing the Quick Start win-

dow)

Session Metadata
• The new Metadata Inspector window lets you

view and edit metadata for sessions
Chapter 1: What’s New in Pro Tools | Software and Pro Tools | H
I/O Setup Improvements
• Changes to the Output and Bus pages

• Virtually unlimited Bus paths

• Subpaths for Output paths

• Automatic downmix and upmix of Output busses

to Outputs paths of different channel widths

• New Monitor Path setting

• Session Interchange and I/O Mapping improve-

ments

• New keyboard modifiers for enabling and as-

signing Output busses

• Audition path improvements

• AFL/PFL path improvements

• Ability to restore the I/O Setup from the session

• I/O Settings files automatically created and re-

called for different Playback Engines

• New Organize Track I/O Menus By preference

• Ability to import IO Settings from session files

• Access to the I/O Setup in the Session Notes dialog
D Software Version 12.0 1



System Requirements and 
Compatibility Information
Avid can only assure compatibility and provide

support for hardware and software it has tested and

approved.

For complete system requirements and a list of

qualified computers, operating systems, hard

drives, and third-party devices, visit:

www.avid.com/compatibility
Chapter 1: What’s New in Pro Tools | Software and Pro Tools | H
Conventions Used in 
Pro Tools Documentation
Pro Tools documentation uses the following con-

ventions to indicate menu choices, keyboard com-

mands, and mouse commands:
:

The names of Commands, Options, and Settings

that appear on-screen are in a different font.

The following symbols are used to highlight

important information:

Convention Action

File > Save Choose Save from the

File menu

Control+N Hold down the Control

key and press the N key

Control-click Hold down the Control

key and click the mouse

button

Right-click Click with the right

mouse button

User Tips are helpful hints for getting the
most from your Pro Tools system.

Important Notices include information that
could affect your Pro Tools session data or
the performance of your Pro Tools system.

Shortcuts show you useful keyboard or mouse
shortcuts.

Cross References point to related sections in
this guide and other Avid documentation.
D Software Version 12.0 2
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Chapter 2: Pro Tools Subscription, Avid 
Application Manager, and In-Application 
Plug-in Purchase

Pro Tools Subscription
Pro Tools 12 is available as a perpetual license, or

as a monthly or annual subscription.

Avid Application Manager
When you install Pro Tools 12, the Avid Applica-

tion Manager is also installed. The Avid Applica-

tion Manager is used to manage your software and

entitlements related to your MyAvid account. The

Avid Application Manager helps you maintain the

most current Pro Tools software and audio plug-in

updates that you are entitled to when new versions

become available. For more information about the

Avid Application Manager, see the Avid Applica-
tion Manager Guide (available online through the

Avid Knowledgebase).

In-Application Plug-in 
Purchase
Pro Tools 12 lets you purchase plug-ins from the

Avid Marketplace through Pro Tools. All plug-ins

from the Avid Marketplace through Pro Tools are

installed silently and, following activation, are

available for use without having to restart

Pro Tools.

To purchase and install a plug-in from the Avid

Marketplace:

1 Launch Pro Tools.

2 Do one of the following:

• In Pro Tools, choose Marketplace > Plug-Ins.

• Select Avid Marketplace from any plug-in insert

in your Pro Tools session.

• When you open a Pro Tools session that uses

plug-ins that are not installed on your system,

you are given the opportunity to purchase them

through the Avid Marketplace.

3 Find the plug-in you want in the Avid Market-

place and follow the on-screen instructions.

For more information about Pro Tools pur-
chase and subscription plans, visit the Avid
website at www.avid.com.

You can also access the Avid Marketplace on-
line at shop.avid.com.



Chapter 3: Dashboard
Pro Tools 12.0 provides a new Dashboard window

on launch (replacing the Quick Start dialog) that

lets you quickly and easily create a new session or

open an existing one.

When you first launch Pro Tools, you are prompted

by the Dashboard to do one of the following:

• Create a new session from a template.

• Create a new blank session.

• Open any of the last ten most recent sessions.

• Open any other session on your system.

You can also access the Dashboard while Pro Tools

is running by choosing File > Create New.

Press Control+Up Arrow or Down Arrow
(Windows) or Command+Up Arrow or
Down Arrow (Mac) to select different options
in the Dashboard. Also, you can use the Up
and Down Arrows to select different items in
the Recent Sessions and Session Templates
lists.
Chapter 3: Dashboard
Creating a New Session from 
a Template
To create a new session from a template:

1 In the Dashboard, click the Create tab.

2 Select the Create From Template option.

3 From the Template Group pop-up menu, select

the category for the session templates you want.

Dashboard, Create From Template option enabled
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4 Select the session template you want to use from

the list (on the right).

5 If you want to change any of the session param-

eters, do any of the following:

• Select the Audio File Type for the session (WAV

or AIF).

• Select the Bit Depth (16 bit, 24 bit, or 32 bit float).

• Select the Sample Rate.

• Select the I/O Settings that you want to use.

• To create interleaved multichannel audio files in

the session, select Interleaved.

6 Click OK.

7 In the Save dialog, choose where you want to

save the session, and click Save.

For optimum compatibility between Mac
and Windows, set the file type to BWF
(.WAV).
Chapter 3: Dashboard
Creating a New Blank 
Session
To create a new blank session:

1 In the Dashboard, select Create.

2 If not already shown, click the Create tab.

3 If you want to change any of the session param-

eters, do any of the following:

• Select the Audio File Type for the session (WAV

or AIF).

• Select the Bit Depth (16 bit, 24 bit, or 32 bit float).

• Select the Sample Rate.

• Select the I/O Settings to use for the session. Sev-

eral pre-configured I/O Settings are included

with your system, or you can select a custom I/O

Setting.

• To create interleaved multichannel audio files in

the session, select Interleaved.

4 Click OK.

5 In the Save dialog, name the session, choose

where you want to save the session, and click

Save.

Dashboard, Create New Session
5



Opening a Recent Session

To open a recent session:

1 In the Dashboard, select Recent.

2 Select any of the last ten recent sessions from the

list (on the right).

3 Click OK.

The Open Recent Session option is not avail-
able the first time you launch Pro Tools (or if
you have cleared the Recent Sessions list by
choosing File > Open Recent > Clear).

Dashboard, Recent Sessions list
Chapter 3: Dashboard
Showing (or Hiding) the 
Dashboard on Startup
You can choose to show or hide the Dashboard on

startup. You can always access it when Pro Tools is

running by choosing File > Create New or File >

Open Recent.

To show or hide the Dashboard on startup, do one

of the following:

 In the Dashboard, enable (or disable) the Show

on startup option.

 In the Warnings & Dialogs section of the Dis-

play Preferences page (Setup > Preferences),

select (to show) or deselect (to hide) the Show

Dashboard window when Pro Tools starts op-

tion. Click OK.
6



Chapter 4: Session Metadata
Pro Tools 12.0 provides a new Metadata Inspector

window for sessions. This window lets you view

and edit metadata for sessions—such as Artist,

Contributors, Sample Rate, Bit Depth, Location,

and so on. Certain session metadata is display only.

Metadata is stored with the session file (.ptx). Ses-

sion metadata can also be viewed in browser win-

dows.

To open the Metadata Inspector:

 Choose Window > Metadata Inspector.

Metadata Inspector Window
The Metadata Inspector window displays the fol-

lowing information about your session. Some

metadata can be edited and some is display only.

Session Metadata Inspector window
Chapter 4: Session Metadata
Name
Name is display only and shows the name of the

session.

Title
Title is manually entered and is editable.

Artist(s)
Artist(s) is manually entered and is editable.

Contributor(s)
Contributor(s) is manually entered and is editable.

Sample Rate
Sample Rate is display only and shows the session

sample rate.

Bit Depth
Bit Depth is display only and shows the session bit

depth.

Location
Location is manually entered and is editable.

Date Created
Date Created is display only and shows the date

and time that the session was created.
7



Date Modified
Date Modified is display only and shows the date

and time that the session was last modified.

BPM
BPM is display only and shows the range of tempi

in the session in beats per minute.
Chapter 4: Session Metadata
 8



Chapter 5: I/O Setup Improvements
Changes to the Output and 
Bus Pages
In Pro Tools 11, the Output and Bus pages of I/O

Setup both displayed the following controls:

• Audition Paths

• Default Output Bus

Pro Tools 12 provides these controls only in the rel-

evant pages in I/O Setup.

The Output page provides the following:

• Monitor Path (new in Pro Tools 12), and only

output paths are available

• Audition Path, and only output paths are avail-

able

• Output Meter Path, and only output paths are

available

• AFL/PFL Path (Pro Tools HD only), and only

output paths are available

The Bus page only provides the Default Output Bus

setting and only Bus paths are available.

Unlimited Bus Paths
Pro Tools 12 provides virtually unlimited bus

paths. 24 busses are created by default, but you can

create as many more as you need.
Chapter 5: I/O Setup Improvements
Subpaths for Output Paths
Pro Tools 12 lets you create subpaths for Output

paths.

Downmix and Upmix Output 
Busses to Outputs
(Pro Tools | HD Software Only)

Pro Tools 12 lets you map track Output paths to

physical Output paths on your audio interface that

have a channel format of a greater or lesser width.

This means that you monitor your session on any

system (Playback Engine) without having to

change the session’s I/O settings.

For example, if you have a session with 5.1 Output

bus, you can assign it to a stereo Output path in the

Bus page while maintaining the mixer configura-

tion for the session. In this case, Pro Tools down-

mixes the 5.1 Output bus to the stereo outputs on

your audio interface.

5.1 Output path with subpaths
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Similarly, you can assign a stereo Output bus to a

greater-than-stereo Output path in the Bus page.

Pro Tools automatically maps matching channels

from the source signal to the destination Output

path. For example, when assigning a stereo source

to a 5.1 Output bus, the left channel of the source is

mapped directly to the left channel of the Output

path and the right channel of the source is mapped

directly to the left channel of the Output path (the

center, surround, and LFE channels are not used).

However, if the source and the destination do not

have directly matching channels, Pro Tools up-

mixes the source to the destination. For example,

when assigning an LCRS source to a 5.1 destina-

tion, the LCR channels of the source are mapped

directly to the LCR channels of the destination, but

the surround channel (S) is upmixed to the left sur-

round and right surround channels of the 5.1 Out-

put path.

To assign downmix or upmix Output bus paths:

1 Open the I/O Setup (Setup > I/O).

2 Select the Bus page (I/O Setup > Bus).

3 Click the Mapping to Output column on the row

for the Output bus that you want to remap to a

lower or higher channel format (from the avail-

able Output paths).

It is not recommended that you mix while
monitoring the session through a downmixed
or unmixed Output path. Uses downmixed or
upmixed monitoring for editing and other
non-mixing tasks.

Selecting a stereo Output path for a 5.1 Output Bus
Chapter 5: I/O Setup Improvements
4 Click OK to save your changes and close I/O

Setup.

Downmix and Upmix Indicators 
for Output Paths
When a track or send is set to an Output path of a

different channel width, the source audio is down-

mixed or upmixed accordingly. The Output selec-

tor in the Mix, Edit, and Output windows displays a

> (downmix) or a < (upmix) symbol respectively.

This lets you easily identify any track that is down-

mixing or upmixing to an Output path of a different

channel width.

Monitor Path
Pro Tools 12 provides a new Monitor Path setting in

the Output page of the I/O Setup. Pro Tools uses

the selected Monitor path for the main output of

your Pro Tools session. When you open a session

created on one Pro Tools system (with its own

unique Monitor path configuration) on another

Pro Tools system, it automatically maps the ses-

sion’s Monitor path to the system’s assigned Mon-

itor path.

The Monitor path is indicated in track and send

Output selectors, and in Output paths in the Output

and Bus pages of the I/O Setup by a speaker icon.

5.1 track with Downmix indicator
10



Pro Tools automatically downmixes or upmixes the

session Monitor path to the system Monitor path so

that you always hear session playback regardless of

any mismatch between the session Monitor path

channel width and the system Monitor path channel

width.

For example, if a session is saved with a 5.1 Moni-

tor path and then opened on a system that only has

a stereo monitor path available, the session’s 5.1

Monitor path is automatically downmixed to the

system’s stereo Monitor path.

Session Interchange and I/O 
Mapping
I/O Setup mappings are saved both with the system

and the session. When opening a session on a sys-

tem that has a different I/O Setup, Pro Tools fol-

lows these rules to ensure the best possible re-map-

ping of the session I/O Setup to the new system:

• Pro Tools always maps the Monitor Path of the

session to the Monitor path of the current system,

• If Monitor subpaths exist in the session, Pro Tools

uses the best matching format for the system Mon-

itor subpaths.

Selecting the Monitor Path
Chapter 5: I/O Setup Improvements
• If the session was saved with an HD OMNI Mon-

itor path assignment, the HD OMNI Monitor path

assignment is mapped to the system Monitor path.

This applies to sessions saved in a lower version of

Pro Tools as well. If the session was not saved with

an HD OMNI Monitor path assignment, the first

Output bus is mapped to the system Monitor path.

• Session Output busses that are not mapped to a

Monitor path are mapped to the system Output

paths by name and format only.

• If the session settings do not accurately map to the

system settings automatically, you can either click

Restore from Session (which overwrites the sys-

tem I/O settings with the session’s I/O settings), or

you can reconfigure I/O Setup manually.

After configuring the I/O Setup on any given sys-

tem for a session, the settings are retained with the

session file.

Indication of Remapping in the 
Bus Page
Where the system Output path name or format has

changed, session Output busses that are success-

fully remapped are displayed in green.

Additionally, a Previous Output Mappings column

appears to the right of the Output Mappings col-

umn. This lets you take note of the output mappings

that the session used the last time it was saved.

You can recall the I/O settings saved with the
session and overwrite the system settings (see
“Restore from Session” on page 13).

Remapped Output Busses displayed in green
11



Once you save the session, the Output mapping

changes from green to black and is saved both with

the system and with the session.

Show Last Saved or Current 
Setup
When opening a session that was saved with a dif-

ferent I/O Setup configuration for either hardware

inputs or outputs, Pro Tools 12 lets you switch be-

tween the I/O Setup last saved with the session and

the current system I/O Setup. This lets you take

note of the hardware Input and Output configura-

tion of the I/O Setup saved with the session.

Both the Input and Output pages of the I/O Setup

window provide the Show Last Saved Setup/Show

Current Setup button.

Once you save the session, the Show Last Saved

Setup/Show Current Setup button is hidden.

When showing the I/O Setup last saved with the

session, any unavailable hardware Inputs or Out-

puts are displayed in italics.

Previous Output Mappings column

Show Last Saved Setup button in the Input page
Chapter 5: I/O Setup Improvements
Additionally, when showing the I/O Setup last

saved with the session, the Monitor Path, Audition

Path, Output Meter Path, and AFL/PFL Path set-

tings that were saved with the session are shown

grayed out.

To show the last saved I/O settings:

1 Open the I/O Setup (Setup > I/O).

2 Click either the Input or Output tab.

3 Click the Show Last Saved Setup button (the

button updates to read Show Current Setup).

To show the current I/O settings:

1 If not already open, open the I/O Setup (Setup >

I/O).

2 Click either the Input or Output tab.

3 Click the Show Current Setup button (the button

updates to read Show Last Saved Setup).

Unavailable hardware Input shown in italics

Paths last saved with the session shown grayed out

When viewing the I/O Setup last saved with
the session, the OK option is not available for
saving and closing I/O Setup.
12



Using Keyboard Modifiers 
When Enabling or Assigning 
Output Busses
Pro Tools 12 lets you use keyboard modifiers when

enabling or assigning Output busses in the same

way that you can when assigning track inputs, and

track and send outputs:

• Option-click (Mac) or Alt-click (Windows) to

apply to all busses.

• Command-Option-Shift-click (Mac) or Control-

Alt-Shift-click (Windows) to apply only to se-

lected Output busses.

• Control-click (Mac) or Start-click (Windows) for

each additional Output path you want to assign

an Output bus to.

• Command-Option-click (Mac) or Control-Alt-

click (Windows) to assign a bus to the selected

Output path and all subsequent busses to the next

available Output path sequentially.

Audition Path Improvements
As with the Monitor path, Pro Tools 12 lets you as-

sign the Audition path to any available Output path

regardless of its channel width. For mismatched

channel widths, the Audition path is automatically

downmixed or upmixed to the selected Output

path.

AFL/PFL Path Improvements
(Pro Tools | HD Software Only)

Pro Tools 12 provides a combined AFL/PFL Path

setting that can use any available Output path, re-

gardless of channel width. For mismatched channel

widths, the AFL/PFL path is automatically down-

mixed or upmixed to the selected Output path.
Chapter 5: I/O Setup Improvements
Restore from Session
Pro Tools 12 provides the new Restore from Ses-

sion button. The Restore from Session button only

affects the page that is currently viewed in I/O

Setup (for example, if you are viewing the Output

page, only the Output settings are overwritten by

the settings saved with the session).

To restore I/O settings from the session:

1 Open the I/O Setup (Setup > I/O).

2 Select the tab for the page that you want to re-

store from the session.

3 Click Restore from Session.

4 Click OK to save your changes and close I/O

Setup.

I/O Settings Files 
Automatically Created and 
Recalled for Different 
Playback Engines
When you change the Playback Engine (for exam-

ple, from HDX to Built-in) Pro Tools 12 automati-

cally creates and recalls I/O Settings (.pio) files

based on the playback engine. This facilitates

changing the Playback Engine without having to

manually remap Output Busses in the I/O Setup.

These I/O Settings files are named after the corre-

sponding Playback Engine and are saved both on

the system and with the session.

Enable the Apply to all tabs option or press
Option (Mac) or Alt (Windows) while click-
ing Restore from Session to restore settings
for all I/O Setup pages from the session.
13



Importing IO Settings from 
Session Files
Pro Tools 12 lets you import I/O Settings from ses-

sion files (.ptx) in addition to Pro Tools I/O settings

files (.pio).

To import I/O settings for your Pro Tools system

from a Pro Tools session file:

1 Open the I/O Setup (Setup > I/O).

2 Select the tab for the page where you want to im-

port settings.

3 Click Import Settings.

4 In the Open dialog, navigate to and select the

session file from which you want to import I/O

settings.

5 Click Open.

6 Click OK to save your changes and close I/O

Setup.

Enable the Apply to all tabs option or press
Option (Mac) or Alt (Windows) while click-
ing Import Settings to overwrite I/O Settings
in all pages with the settings imported from a
session file.
Chapter 5: I/O Setup Improvements
Organize Track I/O Menus By 
Preference
Pro Tools 12 provides a new preference that lets

you organize track I/O Menus by Type, Width, or

both Type and Width.

To specify the organization of Track I/O Menus:

1 Choose Setup > Preferences.

2 Select the Display tab.

3 Select one of the following options from the Or-

ganize Track IO Menus By selector:

Type Displays only the I/O Type (Interface or Bus)

as I/O categories in Track I/O menus.

Width Displays only the I/O Channel Width (such

as stereo or 5.1) as I/O categories in Track I/O

menus.

Type and Width Displays both Type and Width as

I/O categories in Track I/O menus.

4 Click OK.

Track IO menus organized by both Type and Width
14



I/O Setup in Session Notes
When opening a session in Pro Tools 12, the Ses-

sion Notes dialog provides a complete list of any

mismatched Output bus mappings. In addition to

being able to see this information and save it to a

text file, you can also open the I/O Setup from the

Session Notes dialog to resolve any unmapped

Output busses.

To open the I/O Setup from the Session Notes

dialog:

1 If the Session Notes dialog reports unmapped

bus paths, click the I/O Setup button.

2 In I/O Setup, reassign any unmapped bus paths

as necessary.

3 Click OK to save your changes and close I/O

Setup.

Session Notes with unmapped Output busses
Chapter 5: I/O Setup Improvements
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